JMPの使用法 > JMPを使い始める > ファイルや開いているウィンドウの管理
公開日: 09/09/2026

ファイルや開いているウィンドウの管理

「JMPホームウィンドウ」から、開いているウィンドウやファイルに簡単にアクセスできます。たとえば、最近開いたファイルを開いたり、ウィンドウを閉じたり、頻繁に使うファイルがリストに常に表示されるよう固定したりできます。

Windowsの「JMPホームウィンドウ」

Windowsでは、JMPを起動すると「JMPホームウィンドウ」が開きます。「JMPホームウィンドウ」では、次のような操作ができます。

• 「最近使ったファイル」リストでは、最近開いたファイルを開いたり、または頻繁に使うファイルをリスト上部に固定したりできます。

• 「最近使ったファイル」リストを右クリックする、一般的なファイル操作を実行できます。

• 「ウィンドウリスト」では、開いているJMPウィンドウを手前に表示させたり、または閉じたりできます。

• ウィンドウ上部にある現在のデータテーブルを表示しているボタンから、別のデータテーブルを選択して現在のデータテーブルを変更できます。

図2.14 JMPホームウィンドウでのアクション 

JMP Home Window Actions

最近使ったファイル

Windowsの場合は、「最近使ったファイル」リストを使って、最近開いたファイルにすばやくアクセスできます。

よく使うファイルをすぐに開けるようにリストの上部に固定表示できます。ファイル名の上にカーソルを置き、画鋲のアイコン(Image shown here)をクリックします。ファイルの固定表示を解除するには、画鋲のアイコン(Image shown here)をクリックします。

「最近使ったファイル」リストからファイルをドラッグし、次の場所にドロップできます。

• JMPの「ウィンドウリスト」にドロップし、そのファイルを開く

• Windowsのフォルダまたはデスクトップにドロップし、そのファイルのコピーを作成する

• Microsoftメモ帳やMicrosoft Wordなどのアプリケーションにドロップし、そのファイルを編集する

ファイルを右クリックすると、次のようなオプションが表示されます。

• ファイルを開く。

• ファイルのパスをコピーする。

• ファイルが存在するフォルダを開く。

• ファイルを名前のアルファベット(内部コード)順、または最近使用したものから順に並べ替える。

• 選択されているファイル(複数可)をリストから削除する。

• 移動または削除されたなどで元の場所に存在しないファイルの名前(複数可)をリストから削除する。(ファイル名を選択してからDeleteキーを押すのと同じ。)

• (JSLスクリプト)スクリプトを編集・実行・デバッグする。

• (テキストファイル)読み込み方法を変更したり、プレーンテキストとして開いたりする。

• (SQLクエリー)クエリービルダーで保存したSQLクエリーを実行する。また、既存のクエリーをテンプレートとして使用して新しいクエリーを作成することも可能。

• JMPアプリケーションを実行または編集する。

「最近使ったファイル」リストからJMP形式以外のファイルを開いた場合は、読み込みに関する環境設定に従ってデータが認識されます。テキストファイルを右クリックすると、読み込み方法を変更したり、テキスト編集ウィンドウでファイルを開いたりできます。ポップアップメニューでは、環境設定の指定に従って読み込むための項目が太字で示されます。

ヒント: スクリプトにより開かれたファイルが「最近使ったファイル」ウィンドウに表示されないようにするには、[ファイル]>[環境設定]>[一般]を選択し、[「最近使ったファイル」リストにスクリプトが開いたファイルを追加する]チェックボックスをオフにします。

「最近使ったファイル」リストでのJMPファイルの検索

複数の最近使ったファイルのなかからファイル名に基づいて目的のファイルを検索するには、「最近使ったファイル」の「フィルタ」ボックスにファイル名の一部を入力します。

以下のような操作で検索が行えます。

• ファイルリストの上にある「フィルタ」ボックスにファイル名の一部を入力する。

• 「フィルタ」ボックスの上にカーソルを置いて検索のヒントを表示する。

• ファイルがフィルタリングされた状態で、上下矢印キーを使用してファイルの選択を変更する。Enterキーを押して選択されているファイルを開く、またはカーソルを使ってファイルを選択する。

• 「最近使ったファイル」リストでファイルが選択されているときに、CtrlキーとFキーを同時に押して「フィルタ」ボックスをアクティブにする。

• 検索語句を入力した後、Escキーを押すか、[X]ボタンをクリックしてフィルタリングモードを終了する。

「最近使ったファイル」の設定オプション

Windowsでは、「最近使ったファイル」パネルの設定ボタン(Image shown here)に以下のオプションが含まれています。

表示Image shown here

「最近使ったファイル」パネルに表示されるファイルを、一般的に使用される種類の中から選んでフィルタリングできます。複数のオプションを同時に選択すると、複数の種類のファイルをフィルタリングできます。

すべてのファイル

最近開いたファイルとピン留めしたファイルをすべて表示します。これは、デフォルトのオプションです。

データテーブル

JMPデータテーブルを表示します。

Excelファイル

XLSX、XLSM、XLSファイルを表示します。

テキストファイル

TXTやCSVなどのテキストファイルを表示します。

すべてのデータファイル

データテーブルファイルとテキストファイルの両方を表示します。

スクリプト

JSLスクリプトを表示します。

Pythonスクリプト

Pythonスクリプトを表示します。

ワークフロー

JMPワークフローファイル(JMPFLOW)を表示します。

ジャーナル

JMPジャーナルファイル(JRN)を表示します。

レポート

JMPレポートファイル(JRP)を表示します。

プロジェクト

JMPプロジェクトファイル(JMPPRJ)を表示します。

アプリケーション

JMPアプリケーションファイル(JMPAPPSOURCE)を表示します。

名前で並べ替えImage shown here

最近使ったファイルを文字コード順に並べ替えます。

最近使用した順に並べ替えImage shown here

ファイルを使用日時の新しい順に並べ替えます。

レイアウトの切り替えImage shown here

「JMPホームウィンドウ」を再配置し、「最近使ったファイル」パネルと「ウィンドウリスト」パネルのレイアウトを水平方向と垂直方向で交互に切り替えます。

大きいアイコンを表示Image shown here

「最近使ったファイル」リスト内の項目のフォントサイズやアイコンサイズを拡大します。

更新Image shown here

「最近使ったファイル」リストを更新します。

見つからないアイテムを削除

JMPを起動してから削除または移動されたファイルを削除します。

ウィンドウリスト

Windowsでは、「ウィンドウリスト」にデータテーブル・レポート・スクリプトなど、開いているJMPウィンドウが表示されます。JMPウィンドウを開いたり、閉じたり、配置を変更したり、非表示にしたりできます。

• 「ウィンドウリスト」でファイルの上にマウスポインタを置くと、サムネールが表示されます。

• ウィンドウリストを個別のウィンドウで開くには、[表示]>[ウィンドウリスト]を選びます。

• ウィンドウを並べて表示するには、選択したウィンドウを右クリックして[整列]を選びます。

• ウィンドウを最大化したときに、いつも自動的にウィンドウリストを表示するには、[ファイル]>[環境設定]>[Windowsのみ]を選び、[ウィンドウを最大化したときウィンドウリストを表示する]を選択します。

ファイルを右クリックすると、次のようなオプションが表示されます。

• ウィンドウを表示する。

• ウィンドウを閉じる。(ファイルを選択してDeleteキーを押しても同様のことができる。)

• 現在選択されているウィンドウ以外のすべてのウィンドウを閉じる。(選択されているウィンドウがレポートウィンドウの場合、関連するデータテーブルもすべて開いたままになる。)

• ウィンドウを最背面に移動する。

• ウィンドウを表示または非表示にする。(ウィンドウをWindowsタスクバーにも表示しない。)

• すべてのウィンドウを選択またはすべての選択をクリアする。

メモ: アクティブなファイルの名前は太字で表示されます。

より詳細な情報が必要な場合や、質問があるときは、JMPユーザーコミュニティで答えを見つけましょう (community.jmp.com).