发布日期: 09/15/2026

定制工具栏

JMP 提供可供您向其中添加新按钮的工具栏,您也可以自行创建工具栏。默认情况下,JMP 窗口类型确定显示哪些栏。例如,“文件编辑”工具栏会在所有窗口中显示。在数据表中,“数据表”工具栏也会显示。

入门

显示“入门”菜单的按钮。

Image shown here

项目

显示项目按钮。

Image shown here

文件编辑

显示用于“文件”菜单和“编辑”菜单中的选项的按钮。

Image shown here

分析

显示用于“分析”菜单中的常用选项的图标。

Image shown here

图形

显示用于“图形”菜单中的选项的按钮。

Image shown here

工具

显示您可以点击并用作光标的工具的按扭。在某些窗口中,工具栏会隐藏,取代它的是一条蓝线。悬停在蓝线上方时可显示工具栏。

Image shown here

数据表列表

显示打开的数据表的列表。您可以在该列表中选择某个数据表,使其成为当前表。请注意,当前表不一定是最前面的窗口。要将表(或任何窗口)移至最前,请从“窗口”菜单的列表中选择其名称。

Image shown here

表

显示用于“表”菜单中的选项的按钮。

Image shown here

实验设计

显示用于“实验设计”菜单中的选项的按钮。

Image shown here

应用程序生成器

显示用于“应用程序生成器”菜单中的选项的按钮。

Image shown here

主窗口

显示“文件”菜单中常用的按扭。

Image shown here

数据表

显示在数据表中执行常见任务的按扭,如打开“数据过滤器”、“拟合模型”和“重新编码”窗口。

Image shown here

脚本编辑器

显示用于运行、调试和重新格式化脚本的按扭。

Image shown here

报表

显示用于打开“本地数据过滤器”、“列切换器”以及将脚本保存到数据表的按扭。

Image shown here

您可以为默认工具栏中未包含的常用选项创建您自己的工具栏。您可以将选项指定给按钮,并且可以添加其他属性,如快捷键、按扭和 JSL 脚本。

若要基于现有工具栏创建工具栏,请复制现有工具栏,然后根据需要更改设置。请参见复制和粘贴菜单、菜单项、工具栏和按钮。

第 1 步:创建工具栏

1. 选择视图 > 定制 > 菜单和工具栏。

“工具栏”列表显示在窗口左侧。

2. (可选)更改定制设置,控制可以查看定制内容的用户。

请参见定制设置选项。

3. 在“菜单编辑器”仍保持打开期间,右击工具栏之一,如文件编辑。

选择任意工具栏,因为所有新工具栏都显示在“工具栏”列表的末尾。

4. 选择新建工具栏。

该工具栏插入列表的末尾。该工具栏包含无标题按钮因为所有工具栏都必须至少包含一个按钮。

第 2 步:指定标题和内部名称

工具栏具有若干基本属性:

• 标题显示在“视图 > 工具栏”列表中,可通过该列表显示或隐藏工具栏。为每个工具栏指定唯一名称。JMP 将在关闭并重新打开“菜单编辑器”后合并同名的工具栏。

• 内部名称,不区分大小写。JMP 根据项的内部名称而不是项标题来确定项的位置。

要指定这些工具栏属性,请执行以下步骤:

1. 在“菜单编辑器”仍保持打开期间,选择工具栏。

“常规”属性显示在窗口右侧。

2. 在内部名称旁边输入内部名称。

3. 在标题框中,为工具栏或按钮输入唯一名称。

4. (可选)要指定标题的译文,请执行以下操作:

‒ 为要定制的项点击本地化按钮。

‒ 选择语言。

‒ 在文本旁边输入译文。

‒ 点击确定。

5. (可选)点击隐藏可在创建工具栏后保持工具栏处于隐藏状态。

6. 按创建菜单项和工具栏按钮中所述定制无标题按钮。

7. 点击保存保存所做更改。

需要更多信息?有问题?从 JMP 用户社区得到解答 (community.jmp.com).