“JMP 主窗口”提供即时访问来打开窗口和文件。打开最近打开的文件、关闭窗口和固定常用的文件均为其中的选项。
在 Windows 上,打开 JMP 时将显示“JMP 主窗口”。在“JMP 主窗口”中,您可以执行以下任务:
• 打开“最近使用的文件”列表中最近使用的文件或固定常用文件。
• 右击“最近使用的文件”列表中的文件执行常见任务。
• 打开或关闭“窗口列表”中的活动 JMP 窗口。
• 通过从顶部的数据表列表中选择打开的数据表以将其设置为当前数据表。
图 2.14 “JMP 主窗口”操作
在 Windows 上,“最近使用的文件”列表提供对最近打开的文件的快速访问。
您可以将您的收藏文件保留在列表顶部以便于快速访问。悬停在文件名上方并点击固定图标 (
)。要取消固定某个文件,请点击固定图标 (
)。
您可以将文件从“最近使用的文件”列表拖入以下位置:
• 拖入“JMP 窗口列表”以打开该文件
• 拖入 Windows 文件夹或您的桌面上以创建该文件的副本
• 拖入 Microsoft 记事本或 Microsoft Word 之类的应用程序以编辑该文件
右击文件可访问以下选项:
• 打开一个文件。
• 将位置路径复制到文件。
• 在包含文件的文件夹中打开该文件。
• 按名称或最近打开的文件的字母顺序对文件排序。
• 从列表中删除所选的一个或多个文件。
• 删除不再位于同一位置的一个或多个文件。(也可以选择这些文件并按 Delete 键。)
• (JSL 脚本)编辑、运行或调试脚本。
• (文本文件)更改导入方法或以纯文本方式打开。
• (SQL 查询)运行您保存在“查询生成器”中的 SQL 查询。您还可以将现有查询用作模板来创建新的查询。
• 运行或编辑 JMP 应用程序。
从“最近使用的文件”列表中打开非 JMP 文件时,JMP 使用导入首选项来排列数据。您可以通过右击某一文本文件,更改导入方法或在文本编辑窗口中打该文件。导入首选项在弹出式菜单中以粗体显示。
提示:要防止脚本打开的文件出现在“最近使用的文件”窗口中,请选择文件 > 首选项 > 常规,并取消选择将脚本打开的文件添加到“最近使用的文件”列表。
要在较长的文件列表中查找最近打开的文件,可在“最近使用的文件”的“过滤器”框中输入部分文件名。
提供以下选项:
• 在文件列表上方的“过滤器”框中输入部分文件名。
• 悬停在“过滤器”框上方可查看搜索提示。
• 过滤文件时,上箭头键或下箭头键可更改选定的文件。按 Enter 键可打开选定的文件,也可以使用光标选择文件。
• 若在“最近使用的文件”列表中选定了某个文件,先按 Ctrl+F 即可激活“过滤器”框。
• 输入搜索项后,按 Esc 键或点击 X 按钮可退出过滤模式。
在 Windows 上,“最近使用的文件”面板上的“设置”按钮 (
) 包含以下选项:
显示 ![]()
按照一些最常用的文件类型过滤“最近使用的文件”面板中显示的文件。可以同时选择多个选项,以过滤多种类型的文件。
所有文件
显示最近打开和固定的所有文件。这是默认选项。
数据表
显示 JMP 数据表文件。
Excel 文件
显示 XLSX、XLSM 和 XLS 文件。
文本文件
显示文本文件,如 TXT 和 CSV。
所有数据文件
同时显示数据表和文本文件。
脚本
显示 JSL 脚本。
Python 脚本
显示 Python 脚本。
工作流
显示 JMP 工作流 (JMPFLOW) 文件。
记录
显示 JMP 记录 (JRN) 文件。
报表
显示 JMP 报表 (JRP) 文件。
项目
显示 JMP 项目 (JMPPRJ) 文件。
应用
显示 JMP 应用程序 (JMPAPPSOURCE) 文件。
按名称排序 ![]()
按字母顺序对最近使用的文件排序。
按最近使用排序 ![]()
按最近使用时间顺序对文件进行排序。
切换布局 ![]()
重新组织“JMP 主窗口”,在“最近使用的文件”面板和“窗口列表”面板的水平和垂直布局之间交替显示。
显示大图标 ![]()
加大“最近使用的文件”列表中项的字体大小和图标大小。
刷新 ![]()
刷新“最近使用的文件”列表。
删除缺失项
删除自 JMP 打开以来已删除或移动的文件。
在 Windows 上,“窗口列表”显示打开的 JMP 窗口,如数据表、报表和脚本。您可以打开、关闭、重新排列和隐藏 JMP 窗口。
• 若悬停在“窗口列表”中的某个文件上方,此时将出现一个缩略图。
• 要单独在一个窗口中打开“窗口列表”,请选择视图 > 窗口列表。
• 要并排显示各个窗口,请右击选定的窗口,然后选择排列。
• 若要始终在最大化窗口中自动显示“窗口列表”,请选择文件 > 首选项 > Windows 特定,然后选择在最大化窗口中停放窗口列表。
右击文件可访问以下选项:
• 查看窗口。
• 关闭窗口。(也可以选择文件并按 Delete 键。)
• 关闭除当前选定窗口之外的所有窗口。(若所选窗口是一个报表窗口,则报表依赖的数据表也会保持打开。)
• 将某窗口移到最后。
• 在 Windows 任务栏中隐藏窗口或取消隐藏窗口。
• 选择所有窗口,或清除所有选择内容。
注意:当前文件的格式设置为加粗文本。