使用 JMP > 输入和编辑数据 > 选择数据表中的列 > 在 JMP 列管理器中选择列
发布日期: 09/15/2026

在 JMP 列管理器中选择列

“列”菜单中的“列管理器”选项可帮助您按照特性、属性和统计量快速选择列,特别是在有许多列的数据表中。您可以查看这些列的汇总统计量和属性、查看汇总统计量中的四分位数、对数据取子集,以及执行其他操作。“列管理器”窗口中的列还链接至数据表列。

图 4.11 “列管理器”中的链接列 

Linked Columns in the Column Manager

使用“列管理器”可以快速查看数据表特征。例如,“汇总统计量”显示哪些列包含缺失值。您可以在报表中选择这些列,然后从数据表中排除它们。

图 4.12 标识缺失值 

Identify Missing Values

“汇总统计量”显示以下信息:

• 总行数(数目)

• 带缺失值的行数(缺失值个数)

• 唯一值的个数(唯一值数)

• 连续数据的最小值和最大值、分布以及整数个数

选定“扩展统计量”时,“列管理器”还显示以下统计量:

• 列值的算术平均值(均值)

• 样本标准差(标准差)

• 第一四分位数,即列值下半部分的中位数 (Q1)

• 第 50 百分位数,在该值处有一半的数据低于第 50 分位数,一半数据高于或等于第 50 分位数(中位数)

• 第三四分位数,即列值上半部分的中位数 (Q3)

关于查找带特定属性的列的示例

该示例显示如何查找带有“公式”属性的列,然后同时查看所有公式。

1. 选择帮助 > 样本数据文件夹,然后打开 Consumer Preferences.jmp。

2. 选择列 > 列管理器打开“数据表列管理器”窗口。

3. 选择公式列两次可按“升序”进行排序。

带有“公式”属性的列显示在“列管理器”顶部。

图 4.13 对“列管理器”中的公式列排序 

Sort the Formula Columns in the Columns Manager

4. 选择员工任期、职位任期和薪水组列,然后选择列 > 列信息。

选定列的公式显示在数据表的“列设置”窗口中。

图 4.14 查看“列设置”窗口中的公式 

View Formulas in the Column Settings Window

关于显示汇总统计量的示例

该示例显示如何查找带有低标准差的列。若您想要从分析中删除或排除数据,这会很有帮助。

1. 选择帮助 > 样本数据文件夹,然后打开 Semiconductor Capability.jmp。

2. 选择列 > 列管理器打开“数据表列管理器”窗口。

3. 在“过滤器”框中键入 PNP 并按 Enter 键。

4. 展开过程分组以显示 PNP 列。

分组过程随即显示。

图 4.15 按名称过滤列 

Filter Columns by Name

5. 点击扩展统计量将附加汇总统计量添加至“列管理器”窗口。

各行显示了每列的数目、均值、标准差、最小值、第一四分位数、中位数、第三四分位数、最大值、缺失值数量、唯一值数量以及每列的分布情况。

图 4.16 选定列的扩展汇总统计量 

Extended Summary Statistics for Selected Columns

6. 选择标准差列两次可按“升序”进行排序。

请注意,PNP6 没有标准差,因为最小值、最大值和均值均为 0。

图 4.17 经过排序的“标准差”列 

Sorted Std Dev Column

7. 在“列管理器”中,选择 PNP6 所对应的行,然后显示数据表。

8. 查看数据表,向右滚动找到 PNP6 列,选择该列,然后按 Delete 键删除选定列。

该列将从数据表中删除。

9. 要关闭“列管理器”,请点击窗口右上角 (Windows) 或窗口左上角 (Apple macOS) 的 X 按钮。

需要更多信息?有问题?从 JMP 用户社区得到解答 (community.jmp.com).