Version 10

Highlights in JMP 10

“The real voyage of discovery consists not in seeking new landscapes, but in having new eyes.”

Marcel Proust

JMP A Business Unit of SAS
SAS Campus Drive
Cary, NC 27513
Get the Most from JMP®

Whether you are a first-time or a long-time user, there is always something to learn about JMP.

Visit JMP.com to find the following:

- live and recorded Webcasts about how to get started with JMP
- video demos and Webcasts of new features and advanced techniques
- schedules for seminars being held in your area
- success stories showing how others use JMP
- a blog with tips, tricks, and stories from JMP staff
- a forum to discuss JMP with other users

http://www.jmp.com/getstarted/
Contents
Highlights in JMP 10

Basic Analysis and Graphing ................................................................. 2
  Bubble Plot ................................................................. 2
  Graph Builder ................................................................. 2
Data Tables ......................................................................................... 3
  Compare Data Tables ................................................................. 3
  Multilingual Sample Data Tables ................................................... 3
  Inverted Selection in Filtered Data ................................................... 3
  Filter Hierarchical Data ................................................................. 4
Design of Experiments ....................................................................... 4
  Custom Design ........................................................................ 4
  Evaluate a Design ...................................................................... 4
General Enhancements ....................................................................... 5
  Bootstrapping ........................................................................ 5
  Column Switcher ...................................................................... 5
  Graph Preferences .................................................................... 5
  Menu Preferences .................................................................... 6
  Local Data Filter ..................................................................... 6
  Replacing Graph Variables .......................................................... 6
  SAS Support ........................................................................... 7
Modeling and Multivariate Methods ..................................................... 7
  Model Comparison .................................................................. 7
  Nonlinear .............................................................................. 8
  Partial Least Squares ............................................................... 8
  Partition ................................................................................ 8
Quality and Reliability Methods .......................................................... 8
  Control Chart Builder .............................................................. 8
  Measurement Systems Analysis .................................................. 9
  Reliability Forecast .................................................................. 10
  Reliability Growth .................................................................. 11
JMP 10 provides several powerful new analysis platforms, additions to existing platforms, and JMP Scripting Language (JSL) enhancements.

New analysis platforms include the following:

- Control Chart Builder
- Measurement Systems Analysis
- Model Comparison
- Reliability Forecast
- Reliability Growth
- DOE Evaluate Designs

Major additions to existing platforms include the following:

- one-click bootstrapping to approximate the sampling distribution of a statistic
- Partial Least Squares personality in the Fit Model platform
- Fit Curve personality in the Nonlinear platform
- changing variables within a report using the Column Switcher

Other important new features include the following:

- the ability to compare data tables
- JSL tools
  - Add-In Builder provides an interface for creating JMP add-ins.
  - Application Builder eases the creation of JSL applications with an interactive development environment
  - JSL Debugger helps you troubleshoot JSL scripts.

*indicates features that are available only in JMP Pro.*
Basic Analysis and Graphing

This section describes new features and enhancements in the basic analysis and graphing areas.

Bubble Plot

The Bubble Plot platform contains the following new options within the red triangle menu:

- **Set Shape** changes the shape of the bubble. Choices include Circle (default), Triangle, Square, Diamond, Arrow, or Custom. Custom shapes are created using JSL. If no custom shape is defined, the Custom option defaults to the circle shape.

- **Orient Shapes** orients shapes as they move in particular directions over time, following the shape of the data. This option appears only if you have specified a Time variable.

- **Color Theme** changes the colors representing the high, middle, and low values of the color variable. This option appears only if you have specified a Coloring variable.

- **Draw** the Filled option now resides within this menu, and two new options appear: Outlined and Filled and Outlined.

- **Lock Scales** prevents axis scales and gradient legend scales from automatically adjusting in response to data or filtering changes.

- **Color as Sum** within Aggregation Options, a new option appears: Color as Sum. This option computes the mean of the data values and maps to a color. This option appears only for continuous variables.

The Bubble Plot platform also contains the following enhancements:

- If you split bubbles and then select Script > Redo Analysis, the state of split bubbles is preserved.
- Excluded rows in the data table no longer contribute to the computation or to the display of the bubble plot, including axes, bubble sizes, and time states.
- If you have hidden rows in your data table, they are used in the computation, but do not appear in the bubble plot. All rows associated with a bubble must be hidden in order for the bubble to disappear.

When exporting a bubble plot to an Adobe Flash file (.swf), note the following enhancements:

- Background maps are retained.
- You can split or combine bubbles.

Graph Builder

- Instead of right-clicking on a graph and selecting a new element or changing element properties, you can do so directly from the Graph Builder window. The Graph Builder window now contains icons that change the element. Properties for most element types also appear.
• The following new elements are supported in Graph Builder:
  – Regression line, or line of fit
  – Density ellipse
  – Violin plot (appears in place of a Contour plot when there is only 1 continuous variable)
  – Pie chart
  – Shaded area
  – Treemap
  – Heatmap
  – Caption box
  – Function
• You can nest categorical X variables, resulting in nested X axes.

### Data Tables

This section describes new features and enhancements to data tables.

#### Compare Data Tables

The Compare Data Tables platform enables you to compare two data tables. You can compare differences in the data, table variables and scripts, and column attributes and properties.

To launch the Compare Data Tables platform, select Tables > Compare Data Tables.

#### Multilingual Sample Data Tables

For any translated sample data tables, instead of providing three sets of sample data tables for English, Japanese, and Chinese, we now have one set of sample data. The data table names are in English. When you open a translated sample data table, your locale settings are detected and the content in the data table appears in the appropriate language (English, Japanese, or Chinese).

#### Inverted Selection in Filtered Data

In filtered data, you can select excluded columns using the Invert Selection message. For example, if males between the ages of 12 and 14 are filtered, select males of other ages:

```javascript
df << (Filter Column (:age) << Invert Selection;
```
Filter Hierarchical Data

Data that consists of subcategories within categories is considered hierarchical data. For example, geographical regions might contain states. The Data Filter Hierarchical red triangle option lets you filter data so that the second filtered list shows only subcategories of the first filtered list.

Design of Experiments

This section describes new features and enhancements in the design of experiments area.

Custom Design

The Custom Design platform has the following new features:

- Factors can now be of Discrete Numeric type. This is a numeric variable that can take only a discrete number of values. Discrete Numeric factors have an implied order for their levels.

- The Number of Center Points and Number of Replicates options are now specified before the clicking the Make Design button. This is done so the optimization routine can return a design that accounts for the center points and replicates. The Number of Replicates option no longer replicates the entire design, but specifies how many replicate runs to add to the design. The optimization routine decides which design points to replicate.

- The Custom Designer now supports I-optimal split-plot designs. When creating response surface designs using an optimal design approach, the I-optimality criterion can be more appropriate than the D-optimality criterion. You can use I-optimal split-plot designs to address response surface experiments with restricted randomization.

To create an I-optimal split-plot design, select DOE > Custom Design. From the red triangle menu, select Optimality Criterion > Make I-Optimal Design.

Evaluate a Design

Use the Evaluate Design command to evaluate designs for any table treated as a design. From the results, you can change the model terms and the aliasing terms and the diagnostics update accordingly. To evaluate a design, select DOE > Evaluate Design.
General Enhancements

General enhancements include changes that affect multiple platforms or areas.

Bootstrapping

Bootstrapping approximates the sampling distribution of a statistic. The data is resampled (with replacement) and the statistic is computed. This process is repeated to produce a distribution for the statistic. To access the bootstrapping option, right-click on a statistic in a report and select Bootstrap.

Figure 1.1 Example of the Bootstrap Confidence Limits Report

Column Switcher

Within a report, use the Column Switcher to change an existing variable to another variable. To open the Column Switcher, from a report window, select Script > Column Switcher from the red triangle menu.
Graph Preferences

There is a new panel called Graphs in the Preferences window. The Graphs panel includes the following:

- preferences for graphs that existed previously in the Reports panel
- new options pertaining to areas such as borders, framing, tick marks, and grid lines
- a preview area where you can see your changes before applying them

To see Graph preferences, select File > Preferences > Graphs.

Menu Preferences

The Menu preferences show and hide menus based on how you use JMP. This gives you fewer menu items to browse through and streamlines the JMP interface. For example, if you never design experiments, deselect Design of Experiments. Other menus are grouped by area of interest, such as quality engineering, reliability and survival, and SAS options.

Local Data Filter

The Data Filter normally modifies the row states in a data table. If you do not want to modify the row states in your data table, use the Local Data Filter option. This option embeds the Data Filter within a report window and does not affect or alter the associated data table or other associated reports.

To access this option, from a report window, click on the red triangle menu. Select Script > Local Data Filter.

Replacing Graph Variables

To replace variables in a graph, you can drag and drop a variable. For example, in the Bivariate report, you can swap variables by dragging and dropping a variable from one axis to the other axis. Or, you can click on a variable in the Columns panel of the data table and drag it onto an axis.

The following platforms support dragging and dropping a variable from an axis or from a data table into a graph:

- Fit Y by X: Bivariate, Contingency
- Graph: Contour Plot, Scatterplot Matrix
- Quality and Process: Measurement Systems Analysis, Variability

The following platforms support dragging and dropping a variable from a data table into a graph:

- Distribution
- Fit Y by X: Logistic, Oneway
In the Distribution platform, when you drag a variable from the data table, drop it into the axis to replace the existing variable. To insert a new variable and create a new histogram, drag and drop the variable outside of an existing histogram. The new variable can be placed before, between, or after the existing histograms.

**Note:** In the Distribution platform, remove a variable by selecting *Remove* in the red triangle menu.

### SAS Support

JMP 10 fully supports SAS 9.3, including the ability to specify the default SAS mid-tier (or environment), metadata server, or workspace server in the JMP preferences.

When browsing data on a SAS server, you can select *Get Details* to see a data set’s size and the last modification date for all data sets in the library.

### Modeling and Multivariate Methods

This section describes new features and enhancements in the modeling and multivariate methods area.

#### Model Comparison

The Model Comparison platform is used to compare the fit of different models. Measures of fit, diagnostic plots, and profilers are reported for easy comparison of models. You can combine the models through model averaging to achieve better predictive ability. The platform accepts models for both continuous and categorical responses.

To launch the Model Comparison platform, select *Analyze > Modeling > Model Comparison*.

**Figure 1.2** Example of the Model Comparison Report
Nonlinear

**Fit Curve** is a new personality of the Nonlinear platform. **Fit Curve** provides tools for fitting a suite of nonlinear models without having to specify prediction formulas or starting values. After fitting one or more models, you can compare parameter estimates, test for parallelism, and compare different fits. **Fit Curve** features a variety of different built-in models, including several that are popular for bioassay and pharmacokinetic data analysis.

To use the **Fit Curve** personality, select **Analyze > Modeling > Nonlinear**. Provide a column of numeric data (with no predictor formula) in the **X, Predictor Formula** role.

Partial Least Squares

- The Partial Least Squares platform in JMP Pro now uses validation to assess model fit and determine the number of latent factors. Cross validation methods include **Holdback** and **KFold**. To access the Partial Least Squares platform, select **Analyze > Multivariate Methods > Partial Least Squares**.

- The Fit Model platform in JMP Pro contains a new PLS personality. The PLS personality can fit models using categorical input variables and can include transformations on continuous variables. Models can also include interaction and polynomial terms. To access the PLS personality in Fit Model, select **Analyze > Fit Model** then select **PLS** from the **Personality** list.

Partition

The Show Split Count red triangle option shows or hides each frequency level for all nodes in the tree. This is for categorical responses only.

Quality and Reliability Methods

This section describes new features and enhancements in the quality and reliability methods area.

Control Chart Builder

The Control Chart Builder is a new platform for interactively creating control charts. The interface features a drag-and-drop workspace. You can quickly add or remove variables from the chart, use multiple Ys, add phase variables, or change chart types. This allows for easy exploration of data. The platform creates X-Bar, IR, Range, Standard Deviation charts, and Moving Range charts.
To launch Control Chart Builder, select **Analyze > Quality and Process > Control Chart Builder**.

**Figure 1.3** Example of the Control Chart Builder

---

**Measurement Systems Analysis**

The Measurement Systems Analysis platform provides methods for assessing the variation in your measurement system and gauges. You can study parallelism, bias, compute variance components, and study the increment resolution of your system.

To launch the Measurement Systems Analysis platform, select **Analyze > Quality and Process > Measurement Systems Analysis**.
Reliability Forecast

The Reliability Forecast platform uses historical product failure data to forecast warranty returns and repair costs. You can interactively investigate different combinations of warranty length and production volumes to see the impact on forecasted repairs.

To launch the Reliability Forecast platform, select Analyze > Reliability and Survival > Reliability Forecast.
Reliability Growth

The Reliability Growth platform performs Crow-AMSAA analysis of a repairable system. This platform lets you analyze the mean time between failures (MTBF) and cumulative failure counts for a system with multiple stages, where a single model is not adequate to describe the entire time line.

To launch the Reliability Growth platform, select **Analyze > Reliability and Survival > Reliability Growth.**
Figure 1.6 Example of the Reliability Growth Platform

### Scripting

This section describes new features and enhancements in the scripting area.

### Add-In Builder

The Add-In builder simplifies creating a JMP add-in. Rather than creating add-ins manually, you select **File > New > Add-In** and begin specifying the add-in name, menu item name, JSL script, and other options.
Application Builder

The Application Builder is a drag-and-drop interface that lets you visually design new JMP windows with buttons, lists, graphs, and other objects. This saves you the step of writing scripts to create these objects. JMP then guides you through writing scripts that provide functionality to the objects.

For example, you often perform the same tasks everyday (such as running Distribution and Fit Model analyses on a data table and viewing the results). In the Application Builder, you can create an application that shows the results for both analyses in one window rather than in separate platform windows.

Create a new application by selecting File > New > Application.

Figure 1.7 Example of the Application Builder

Enhanced Graphics Scripting

Many features of graphs that are generated by JMP are available in graphs generated by JSL (for example, clickable markers, curves, smooth line styles, and density gradient fills).
JSL Debugger

The JSL Debugger helps identify the point at which a script causes an error or fails. Rather than commenting portions of the script or adding `Print()` statements, you can use the debugger to find the problem.

A variety of debugging methods are available: setting breakpoints, creating watches, stepping through statements, and other typical debugging options.

To open the JSL Debugger within a script, click the Debug Script button, or right-click and select Debug Script.

Script Editor

The Script Editor features drag-and-drop editing, and more syntax coloring for SAS code. And you can now see the script and log in the same window. To access the split window, right-click in the script and select Show Embedded Log.

Scripting Index

The JSL Functions Index, DisplayBox Scripting Index, and Object Scripting Index are now in one searchable index. Search for functions, objects, display boxes, or search all categories. You can customize your query to limit the search to examples, titles, and the like. Regular expressions are also supported in queries.

Open the Scripting Index by selecting Help > Scripting Index.