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About the Release Notes

JMP 11.1 is a general maintenance release that contains enhancements, bug fixes, and some new 
features. A few of the specific issues that have been fixed in this release are listed below. Note that this 
list is intended to show the scope of the 11.1 fixes but is not a complete list of all fixes. The majority of 
customer-reported issues, reproducible system errors, and numeric issues have been corrected. 
Applying this maintenance release is recommended for all sites.
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New Features

This section contains new features that have been implemented in JMP 11.1.

Data Tables

• When you color cells in a data table, the color is now retained in journals and in HTML output.

Degradation

• The Degradation platform now allows generating pseudo failure for every unit with a single 
observation, by extrapolating a line from the origin through the observation.

Design of Experiments

• When you select Fast Flexible Filling in the Space Filling platform or Space Filling in the Mixture 
platform, a new option called Set Average Cluster Size has been added (under Advanced Options). 
This option enables you to increase the number of uniform random points that are generated to 
create the clusters. This option can be particularly useful in designs with a large number of factors 
or if disallowed combinations restrict the distribution of points used in the clustering algorithm. 

Fit Life by X

• The Censor Code option on the launch window has been enhanced. For the Censor Code, you can 
select from a list of possible values that are based on the values in the Censor column. The option 
of 1 has been removed from the list of possible Censor Code values.

Fit Model

• The Fit Model launch window now contains all of the column options in the Select Columns red 
triangle menu.

Generalized Regression

• The Profit Matrix column property for nominal responses is now supported.

• Selecting a line in the Solution Path plot highlights the corresponding term in the Parameter 
Estimates for Centered and Scaled Predictors report. Likewise, selecting a term in the Parameter 
Estimates report highlights the corresponding line in the Solution Path plot.

• Early stopping rules have been added. In the Model Launch control panel, you can select Early 
Stopping as an option to help speed up the modeling process. Early stopping can significantly 
speed up the processing if there are only a few effects in the model. This option is off by default, to 
avoid the risk of stopping too early.

• A new report, Parameter Estimates for Original Data, has been added. The report shows the 
parameter estimates for a model expressed in terms of the original (uncentered and unscaled) data. 
Tests and confidence intervals are also provided.
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Mixed Model

• New options to save conditional predictions for random coefficient models have been added. New 
options include saving conditional prediction formulas, the standard error of conditional 
predicted formulas, and conditional residuals.

• New options to add conditional model diagnostic plots have been added. The plots are: Actual by 
Conditional Predicted, Conditional Residual by Predicted, Conditional Residual by Row, and 
Conditional Residual Quantile.

• New options for conditional model profiling have been added. The new options are: Conditional 
Profiler, Conditional Contour Profiler, Conditional Mixture Profiler, and Conditional Surface 
Profiler.

• The Random Effects Predictions report no longer appears by default. In addition to BLUP, its 
standard error and confidence intervals have been added to the report when it is displayed.

• The options in the red triangle menu have been reorganized and categorized.

Fit Parametric Survival and Fit Proportional Hazards

• The Censor Code option on the launch window has been enhanced. For the Censor Code, you can 
select from a list of possible values that are based on the values in the Censor column.

Fit Y by X

• Enhancements have been made to residual plots. Specifically, the following changes have been 
made:

– The horizontal axis of the Residual by Predicted Plot reflects the minimum and maximum of 
the predicted values for Y instead of the observed values for Y.

– Points in the Residual by Row Plot are now connected.

– Confidence bands have been added to the Residual Normal Quantile Plot.

Installation

• On the final window of the JMP installation, there is a new option to check for an updated version 
of JMP.

Life Distribution

• The Censor Code option on the launch window has been enhanced. For the Censor Code, you can 
select from a list of possible values that are based on the values in the Censor column. The option 
of 1 has been removed from the list of possible Censor Code values.

Macintosh

• Within the Home Window, you can drag and drop files from the Recent Files list in the following 
locations:

– Into the JMP Window List to open the file

– Into the Favorites pane

You can also run or debug a JSL script by holding down the Ctrl key and clicking on the script.
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Partition

• In the launch window, there is a new option called Ordinal Restricts Order which means that only 
splits that respect the ordering will be considered.

Reliability Growth

• A new stand-alone model has been added, called Crow-AMSAA with Modified MLE. This model 
enables you to explore Crow AMSAA with beta adjusted for bias, as well as lambda, accordingly.

Scripting

• For Response Screening, use the JSL Select Columns() function to select the column in the 
original table that corresponds to a selected point in the p-values table.

• Platform Preferences(), Set Platform Preferences(), and Get Platform Preferences() 
provide options for setting and getting preferences globally or within a platform. Preferences can 
be reset back to the default settings, or turned on or off using this function. See the JSL Syntax 
Reference for more detailed syntax descriptions.

• A new JSL platform launch command, Ignore Platform Preferences(), has been added. If this 
command is set to true, any current platform preference settings will not be applied. You can 
invoke this command from any platform.

• For Tabulate, you can now set the column width for tables using the Display Column Width() 
function.

Statistics Index

• Improvements have been made to the following descriptions in the statistics index: rare events 
chart, FDR, and standardize robustly.

Variability

• For Heterogeneity of Variance tests, if the model is large, there is now a Cancel button to stop the 
test during the creation process.

General Improvements

This section contains general improvements that have been made in JMP 11.1.

Automation

Methods for automating JMP on Windows have been updated and added. SVG and TIFF graphic 
formats are supported in SaveGraphicItem and SaveGraphicOutputAs.

The follows methods have been added:

• Analysis:

– NumberColGetHeading

– NumberColHide
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– StringColHide

– NumberColSetHeading

– StringColSetHeading

– StringColGetHeading

• Data Table: GetChangedRowStateVector, RowStateBeingMonitoring

• Data Table Column: SetCellMissing, SetCurrencyType

• Cluster: KMSOBandwidth

• Logistic: ROCSetPositiveLevel, LineColor

• Attribute Chart: EffectivenessReport

• Survival: MidstepQuantilePoints

Data Filter

• When the Conditional option is on, and you add multiple column filters using the Add button, JMP 
no longer quits unexpectedly.

• When the Conditional option is on, and you remove one of the filters, the filters are now reset 
correctly.

• For dates that are formatted as Date Long, the Local Data Filter no longer shows the date values as 
missing. The slider responds as expected. 

• The Local Data Filter formats date/time values as specified on the column (instead of as an integer) 
when you save a WHERE clause.

• The <<Get Script message now returns the correct script instead of no script.

• When the Auto Clear option is turned off, output for the WHERE clause now updates properly.

• The <<Match message no longer crashes JMP if the corresponding filter columns have not been 
previously added.

Data Tables

• When creating a subset, if you specify All Columns, the source script for the subset table now 
contains all columns.

• If you send the <<Get Script message to a Compare Data Tables object, the script is now correctly 
returned to the object and printed in the log.

• There is no longer a limit of 50 by columns when sorting a data table using JSL.

• The Compare Data Tables object now recognizes the <<Journal and <<Journal Window messages.

• The original row state is overwritten if the following conditions are met:

– Your data table has row states defined.

– You choose a new column to color or mark by.

– The new column contains missing values.

Then the original row state is now overwritten.
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• The column names appear correctly as the Split By column if the following conditions are met:

– You perform a split using a data table from the sample library.

– You save the split table.

– You re-open the split table.

• JMP no longer quits unexpectedly if the following conditions are met:

– You perform a split using a data table from the sample library.

– You create a subset of all rows and columns in the split table.

• When you select Run Script in the tables panel, only the selected script is run, instead of all of the 
scripts in the table.

• When creating a summary table from another summary table, if you send the <<Copy Table 
Script or <<Get Script messages, JMP now works as intended.

• Joining two data tables that have columns with color properties set on them no longer results in 
performance degradation.

• If you use the <<Go To Row message in an On Open script for a data table, it automatically scrolls to 
the specified row once the data table comes into view.

• If you receive the following JMP alert, it appears only once instead of multiple times: “Check script 
for using an assignment with single = where a test for equality with double == is normally 
expected.”

• The Recall button in the Join launch window now remembers all states as set in the last invocation, 
including the checked state of the Select columns for joined table option.

• The Columns Viewer is now completely synchronized with the source data table. Selecting 
columns in different panels and data table views is now in sync with the selections in the source 
table.

• In a data table that contains mostly missing values, the standard deviation calculated in the 
Columns Viewer is now correct. It is equivalent to the standard deviation calculated in the 
Distribution platform. This issue was observed only on data tables that have 5000 rows or more 
where there is a long run of missing values that are adjacent to nonmissing values.

• If you right-click a column in the columns panel and select Label, then you select Edit > Undo, the 
label property is now removed correctly.

• Data tables that have 250 million rows or more now save and load correctly with no corruption 
issues.

• In the Fan Burnout.jmp sample data table, the G chart script is now a T chart script.

• Deleting rows from the data table that have columns with the Value Color property no longer 
causes JMP to quit unexpectedly.

• The grouping column's formula is now correctly removed in the resulting summary table if the 
following conditions are met:

– You are creating a summary table that is unlinked from the source table.

– The grouping column has a formula based on other columns in the source table.

• The data table will be deemed corrupted if the following conditions are met:

– A script changes the data type of a table variable (from character to numeric).

– The data table is saved.

– You try to reopen the data table.
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• The following add-ins now work not just the first time, but subsequent times as well, if the 
following conditions are met:

– The Show Alternate Column Name preference is selected.

– You try to use the Switch to Long Names and Switch to Short Names add-ins.

• When you stack a large data table that has thousands of columns, the stacked table opens and 
saves correctly.

Display

• Using the Rows > Label command on tables with thousands of rows no longer causes issues in 
JMP.

• Text boxes in journals or reports that are hidden can now be revealed when you select them or 
right-click to turn off the Hidden option.

• In the Matched Pairs platform, when using the selection tool to copy a portion of the report, JMP 
no longer quits unexpectedly.

• Selecting the Categorical Color Theme and pressing the Enter key in Graph Builder no longer 
causes JMP to quit unexpectedly.

• Adding a table to Tabulate using the Tab Box function no longer causes JMP to quit unexpectedly.

Formula Editor

• When multiple By variables are specified in a column formula, a change in either variable now 
triggers an automatic re-evaluation of the formula.

Import

• If you import a SAS data set that contains Mu symbols, these symbols are no longer imported as 
missing.

• When importing an Excel file, dates in format DD/MM/YYYY are now correctly interpreted.

• When importing a table from Excel, the OnOpen script for Subscribe to Data Table List now 
returns the proper data table name.

• In the Excel Wizard, the Rows Shown values are now consistent and correct.

Interactive HTML

• When you save a report as interactive HTML, the text labels near the plot are now aligned 
correctly. 

• The alignment of drop-down list options are improved in the interactive HTML report.

• Table columns are no longer misaligned in the interactive HTML report.

• The Sample Size and Alpha values are now included in the interactive HTML report if the 
following conditions are met:

– You are in the Distribution platform, within the Test Mean report.

– You select PValue animation or Power animation.

• In the Profiler, the Simulator Sequencing results now appear in a table format rather than linearly 
in the interactive HTML report.
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• In the Model Comparison platform, if you have selected the horizontal layout for the Actual by 
Predicted plots, they now appear correctly in the interactive HTML report.

• In the Nonlinear platform, the prediction model formulas are now arranged in a vertical layout 
instead of a horizontal layout in the interactive HTML report.

• In the Distribution platform, the histogram is no longer missing in the interactive HTML report.

• In the Bivariate, Generalized Linear Model, and Oneway platforms, text is now on separate lines 
instead of running together in the interactive HTML report.

• In the Distribution platform, the Arrange in Rows option is now respected in the interactive HTML 
report.

• If you create a check box using JSL, the labels now appear in the interactive HTML output.

• In the Factor Analysis platform, values are no longer missing in the interactive HTML output.

• If you right-click a report and select Append Item > Add File Reference, the file now appears in the 
interactive HTML output.

• In the Contour Profiler, some of the response values and a slider that were missing now appear in 
the interactive HTML report.

• In the Measurement Systems Analysis platform, the buttons within the Customize and Select Tests 
report now appear correctly in the interactive HTML report.

• In the MANOVA personality of Fit Model, the initial options within the report window now 
appear in the interactive HTML report.

• In the Oneway platform, if you right-click the gray disclosure button and select Append Item > Add 
Script Button, the button now appears in the interactive HTML report.

• In Graph Builder, the element type icons now appear above the graph.

Journal

• When inserting a data table into a journal, the scroll bar no longer disappears, and the data table is 
no longer shortened.

Macintosh

• In the Set Background Map window, multiple selections are no longer possible for each type of 
map. Only one choice is allowed per map.

• Within a graph, if you drag and drop a variable to swap locations from one axis to another, and 
you perform this operation multiple times, JMP no longer quits unexpectedly.

• When using the Selection tool to drag and drop items in JMP, the error message “The operation 
could not be completed” no longer appears and the operation is successful.

• When launching the JSL Debugger, an additional JMP Home Window no longer opens.

• The editable combo box now triggers a callback.

• The log window no longer appears on top of the Home Window when JMP is launched. A button 
has been added to the top of the Home Window to show the log.

• The existing Degradation script no longer freezes JMP.

• Graphics are no longer exported with a transparent background.
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• On Mountain Lion, JMP no longer quits unexpectedly if the following conditions are met:

– You create a new journal.

– You drag an image into the journal.

– You click below the image to add an outline node.

– You use File > Save or File > Save As to save the journal.

Multivariate

• A JMP exception no longer appears if the following conditions are met:

– You perform a multivariate analysis on continuous variables.

– You add a scatterplot matrix.

– You use the scroll bar to navigate in the report.

Print

• If you have a plot that contains reference lines, both the dashed and the solid lines now appear 
when you print or select the Print Preview option.

• Marker labels now print correctly.

• Markers that have been sized using the Size role now print correctly.

SAS Integration

• The Get SAS Macro value is no longer truncated.

• Exporting JMP data to an existing SAS data set no longer fails or appends data. It now replaces the 
data as intended.

Transform

• In a launch window, after assigning a transformed variable to a Statistics role, right-clicking on the 
variable and selecting a menu option no longer causes JMP to quit unexpectedly.

Windows

• Scrolling in formula boxes now works properly in the Column Info window.

• In the Windows Specific preferences, if the Show on the Windows taskbar is set to Main JMP 
window only, minimized data table windows are no longer affected.

• Using the Pick File() option on Windows now enables you to select more files, due to an 
increase in the buffer size.

• Very large analyses no longer result in an out of memory condition due to a memory leak when 
capturing pictures.
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Statistics and Graphics

This section contains updates that impact statistical platforms and graphics in JMP 11.1.

Axis

• When the axis scale is set to probability, the axis format can now be changed without reverting 
back to the original format. This issue was observed when using the Weibull scale in the Life 
Distribution platform. The Axis Settings format was changed to percent, then the Grabber tool was 
used to drag the Y axis.

• The reference line color, style, and width is now saved in the Axis column property under the 
following conditions:

– You have a plot that contains reference lines.

– You right-click an axis and select Save to Column Property.

• In Variability charts, the Y axis no longer becomes extended under the following conditions:

– You turn on the Y Axis Title Above Graph preference.

– You close the outline box for the graph.

– You re-open the outline box for the graph.

• On Macintosh, in a Distribution, the count and probability axes no longer lose re-scaling upon 
printing.

• In the Oneway platform, turning on the Y-Axis Title Above Graph preference no longer causes the 
comparison circles to appear below the graph. They now appear next to the graph as intended.

• In the Bivariate platform, histogram borders now appear correctly when the Y-Axis Title Above 
Graph preference is turned on.

• The Increment option has been added back to the Axis Settings window for categorical columns.

• When you have more than 10,000 levels in a nominal distribution, level names are no longer 
missing on the axis.

Bootstrap

• Multiple prompts no longer appear when bootstrapping.

• In the Distribution platform, if you have multiple variables, bootstrapping is now performed on 
the variable that you select rather than the first variable.

Bubble Plot

• Using double quotation marks in the title of the bubble plot no longer causes a parsing XML error 
when loading the Flash file.

• If you split a bubble that has two ID variables which contain missing values, JMP no longer quits 
unexpectedly with an access violation.

• If you hold your mouse pointer over a bubble, the number of rows that appear in the tooltips 
within JMP and the Flash output are now the same. This number represents the number of rows 
used in the computation, rather than the total number of rows.
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• If you export a bubble plot map to Flash, the bubbles now line up exactly as they appear in the 
original JMP version.

• Using angle brackets in titles and variable names no longer causes errors in the Flash output.

• When using the Local Data Filter, the bubble plot report no longer slows down or becomes 
unresponsive.

• When updating the Show Roles options at the top of the bubble plot, the axis settings now remain 
intact.

Capability

• For Individual Detailed Reports, the histograms for Long Term Sigma no longer force zero to exist 
on the axis, resulting in a better scale.

• Capability preferences are now respected if the response columns do not contain a specification 
limit column property.

Categorical

• The Save Excel File() option now accepts a pathname and a Boolean option for whether cells 
should be saved as multiline (Separate Rows for Each Cell Statistic).

• If you choose the Save Excel File option after using the Structured tab, you no longer receive an 
error message in the log.

• If you choose the Save Excel File option when you have categorical cross tabs, the process now 
works.

• Missing values now appear in the structured report when the Count Missing Responses option is 
turned on.

• In the launch window, the Recall button now correctly recalls the selected columns when using the 
Structured tab.

• You can now save mean scores. From the red triangle menu, after you have selected the Mean 
Score option, select Save Tables > Save Mean Scores.

• The sample group is now identified in the results if the following conditions are met:

– You have one table with one category variable on top and one category variable on the side.

– You choose one of the Save Tables options.

• When using the Structured tab, if a column in the data table is entirely blank, a report still appears.

• When using the Structured tab, copying and pasting the resulting report now shows the entire 
report.

• JMP no longer quits unexpectedly if the following conditions are met:

– You turn on the Filter preference for the platform.

– You use the Structured tab to create the report.

– You select Save Tables > Save Excel File.

• There is improved handling in JMP when you have nested columns resulting in empty table 
dimensions.

• When using the Save Tables > Save Test Homogeneity option, chi-squared statistics and p-values 
calculated on user groups are now saved.
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• For Multiple Response columns used in Structured tables, the resulting table includes a Total 
Cases Responding category, which counts each person who responded at least once. People who 
do not respond at all are not included.

• The Categorical launch window updates automatically to reflect the changes if the following 
conditions are met:

– The launch window is open.

– You make a change to a column name in an associated data table.

• Cell chi-square p-values are now saved correctly in Excel.

• Within the Structured tab, if you have nested responses, the Total Responses results are now 
accurate in the report.

• If you have a frequency column containing decimal values, the counts are displayed as whole 
numbers.

Cluster

• Analyzing a missing data pattern table no longer gets Row State events for the original table 
instead of the missing data pattern table.

• JMP no longer quits unexpectedly when several separate clustering sequences are specified.

• For two-way clustering, if you click on a cluster for columns, the columns are now selected in the 
data table.

• Using the Ward and Fast Ward methods, JMP no longer quits unexpectedly when you try to cancel 
the clustering.

Control Chart Builder

• When you set the control limits and turn on all tests for special causes, the first observation is now 
taken into account.

• G-charts no longer give an UCL that is lower than the average.

• Upon removing a local data filter, if you exclude rows, the upper and lower control limits are now 
correct.

• Incorrect control limits are no longer given for some rare event charts.

• Tests are now correct when the limits column property or set limits does not specify the average.

• N trials constants that are entered are now cleared when switching to variables or rare event 
charts.

• Individual points are now correct with missing categories turned off.

• Attribute and rare event charts are now correct if you add right-click options before adding a Y 
variable.

• There are no longer inconsistencies between SAS and JMP with user-defined asymmetric limits 
and tests.

• When you select Warnings > Customize Tests, if you change the value of the first test, the results 
are now accurate.

• Attribute limit lines and limit summaries are now correct with nonconstant sample sizes.
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Design of Experiments

• Load Factors now honors the Factor Changes column property, and you can modify the Changes 
property after loading the factors.

Discriminant

• The 2-D and 3-D Canonical Plots no longer appear disproportionately stretched or blank under 
certain conditions.

Distribution

• The Automatic Recalc option is now included in the Preferences section for Distribution.

• You receive only one error alert instead of multiple error alerts if the following conditions are met:

– You enter all columns for the distribution.

– You click OK.

– You go back to the data table and delete columns.

• If you have journaled a distribution with no levels, the journal now opens without error.

• The robust statistics are no longer missing in the output if the following conditions are met:

– You selected the Robust Mean and Robust Std Dev preferences in the Distribution Summary 
Statistics.

– You request these preferences using JSL.

Fit Life by X

• The default scale for the response variables is now based on the distribution selected in the launch 
window, producing the correct model plot in the output.

• When journaling or copying and pasting a Fit Life by X report, the Scatterplot Density Curve is no 
longer missing.

Fit Model

• On Macintosh, when specifying a By group with all missing values, Fit Model no longer produces 
an error.

Mixed Model

• For BLUPs, when the G matrix of a random coefficient model is not positive definite, the standard 
errors for conditional predicted are now calculated correctly.

Response Screening

• Models without an intercept cannot be handled. Therefore, the No Intercept option in the Fit 
Model launch window is no longer selectable for Response Screening.
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Standard Least Squares

• P-values close to 1 are no longer missing in the Tukey test.

• If the response is a constant (meaning that all of the estimates in a linear model are zero except for 
the intercept), then the Effect Screening commands now work properly.

Stepwise

• The AICc is now reported as missing for a saturated model.

Fit Y by X

Bivariate

• A polynomial model with 2 observations now fits a straight line.

• If the X variable is constant, the estimate of the slope is now zero.

• You can turn off options with JSL by specifying zero as the argument. For example: Fit 
Orthogonal( 0 ).

• There is now a warning to indicate that the Kernel Smoother does not support the Freq and Weight 
variables.

Oneway

• Phantom instances of Oneway reports no longer appear in the Window List after lengthy scripts 
are ran.

• P-values close to 1 are no longer missing in the Tukey test.

• P-values for Hsu’s constrained MCB are now correct.

• The results of the Brown-Forsythe test for homogeneity of variances are now in agreement with 
the SAS results when the sample size is odd.

Graph Builder

• When saving a journal file, color change information is no longer lost in the legend.

• The display of bars less than one pixel thick is now supported.

• When using the Lock Scales option and the Local Data Filter with a map, the graph no longer 
becomes blank.

• When selecting the Histogram and then the Contour element icons, the histograms no longer 
appear along with the contour element.

• Graph marker preferences are now maintained after coloring points.

• If the same variable is specified for color and overlay, the color and the marker shape is now varied 
to distinguish between the two different roles.

• For Summary Statistics such as % of Total, a loss of color or change in color no longer occurs.

• On Macintosh, saving a graph with a background map no longer results in JMP quitting 
unexpectedly.
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• When using the Line of Fit, if you journal the results then save and re-open them, the confidence 
shading now remains.

• If your graph contains a legend at the bottom of the graph, using the Recall button no longer 
causes JMP to quit unexpectedly.

Life Distribution

• The Life Distribution report with a Failure Distribution of Individual Best can now be created in 
German, French, and Chinese.

Maps

• The disputed area between Morocco and the Western Sahara has been updated in the World-
Name.jmp file.

Nonlinear

• If the model that you are fitting has many parameters and little data, you can now enter values in 
the Custom Inverse Prediction window and JMP remains stable.

• If a convergence failure occurs, an error message appears and the fit is not added to the report.

Overlay

• When you journal an overlay plot that contains a legend, the legend is now oriented correctly.

• When you double-click the legend, JMP no longer quits unexpectedly.

Pareto

• The local and global Data Filters now behave the same within a Pareto plot.

Partial Least Squares

• A progress bar has been added when the K in k-fold cross validation is large, allowing you to 
cancel the process if desired.

• Confidence ellipses are no longer plotted in the Y Score Scatterplot Matrix.

Partition

• In JSL, models within Fit Group can now be separated by semicolons in addition to commas.

Principal Components

• The 3-D Score Plot option now appears when creating principal components based on covariances 
or unscaled cases.
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Profilers

• Using JSL to save an expanded formula that contains a summation no longer produces an error.

• If constraints are used, when you save the linear constraints, a constraints script is added to the 
data table that is generated by the Output Random Table option.

• The output for the Defect Profiler is now similar to the output from JMP 10.

• In the Flash output, categorical variables no longer have incorrect axis titles.

Recurrence Analysis

• The Timestamp at Start button is now appearing on the launch window in JMP as well as JMP Pro.

Reliability Forecast

• The Nevada format is now processed correctly when failures are sparse.

• The option of 1 has been removed from the list of possible Censor Code values.

Tabulate

• The JSL Quantiles() function now resolves the variable argument.

Variability

• Adding a row legend does not cause the nominal axis to be separated from the graph when the 
row legend is long.

• If you save your results to a journal, the histogram bars in the Overall Measurement Bias Report 
are now the same length as the original histogram bars.

Scripting

This section contains scripting improvements that have been made in JMP 11.1.

• When using the Column() function and specifying a By variable in a JSL script, the multiple 
distribution graphs are now correct and do not simply repeat the same results.

• In a table operation, if you use a list of columns followed by a column in a table, JMP no longer 
quits unexpectedly.

• The <<Set Items message for a combo box no longer runs the combo box’s script.

• Using the Local Here() function twice to create buttons no longer causes a JMP alert.

• Specific JMP Add-Ins that worked in JMP 10 but were having issues in JMP 11 are now fixed.

• If you run a Col statistic command with no arguments, JMP no longer quits unexpectedly.

• If you double-click a word in the Script Editor that contains an underscore, the entire word is now 
selected.

• In the Scripting Index, the example for <<Go To within Data Table Cols now works properly.
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Application Builder

• A template function has been added to the script that appears when creating a new tab. Once you 
have created a new Tab Box, right-click the icon and select Scripts > Tab New.

• Once you have combined windows, Application Builder no longer shows an exception.

• The JSL command box <<Close Window(nosave) now closes the application window.

• When using the Prompt dialog, the Application Builder no longer reverts back to the current data 
table for the parameter dialog.
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