Publication date: 10/01/2019

JMP Home Window on macOS

Use the JMP Home window on the macOS to quickly access JMP files and open windows.

Open recent files in the Recent Files list.

Press Control and select a file in the Recent Files list to perform common tasks, such as adding or removing a favorite.

Open or close active JMP windows in the Windows list.

Set an open data table as the current data table by selecting it from the Active Table list. Press the Option key while selecting the data table from the list to activate the data table without bringing it to the front.

Open the log.

Find a file in the Recent Files list or an open window in the Windows list by entering a search term in the Search box.

Click Toggle Layout to display the Recent Files and Windows lists horizontally instead of vertically.

Open the JMP Home window on macOS by selecting Window > JMP Home (Figure 2.15). To view the window each time you open JMP, select JMP > Preferences > General > Home Window.

Figure 2.15 Example of the JMP Home Window (macOS) 

Tips:

The Status bar area shows the path for the currently selected file. You can click a folder to open the folder to view its contents.

To be able to quickly view the JMP Home window from any JMP window, press Control and click the window, select Customize Toolbar, and drag the JMP Home icon to the toolbar.

To copy a file from Recent Files to another document or into the Finder, select the file and then select Edit > Copy.

Recent Files

On macOS, the Recent Files list provides quick access to files that you recently opened.

You can also click the star that appears when you place your cursor over the file name to add it to your favorites.

Press the Control key and select a file to access other options. For example, you can run or debug a JSL script by holding down the Control key and selecting Run Script or Debug Script.

Tip: To prevent files that were opened by scripts from appearing in the Recent Files window, select JMP > Preferences > General and de-select Add files opened by scripts to the Recent Files list.

Windows List

On macOS, the Windows list shows open JMP windows, such as data tables, reports, and scripts.

To close a window, click the x button that appears when you place your cursor over the window in the Windows list.

If the window that you are closing is a parent to one or more children, you are prompted to Hide Data Table, Cancel, or Close All windows. Select Close All to close the parent and all its children windows.

Want more information? Have questions? Get answers in the JMP User Community.