For the latest version of JMP Help, visit JMP.com/help.

Publication date: 07/30/2020

Save as a Google Sheet

A Google Sheet is a spreadsheet (which consists of sheets, like tabs) that is saved in your Google account. Exporting a JMP data table to Google Sheets enables you to share the data with others and edit the data outside of JMP.

You can export a JMP data table to an existing Google spreadsheet or create a new one.

To export a JMP data table as a Google spreadsheet, follow these steps:

1. If you are exporting to an existing spreadsheet, perform these steps first. Otherwise, go to step 2.

a. From a browser, log in to https://sheets.google.com.

b. Open the existing spreadsheet.

c. Copy the URL from the browser's address bar.

2. In JMP, open the data table with the data you want to export.

3. Select File > Export > Google Sheets.

4. Under Spreadsheet Type, choose either Existing or New Spreadsheet.

5. Type your Google account name. (@gmail.com is unnecessary.)

6. (Existing spreadsheets only) Next to Spreadsheet Name, paste the URL of the Google spreadsheet you copied in step 1.

7. (New spreadsheets only) Enter a name for the new spreadsheet.

8. Enter the name of the sheet (the tab name).

9. Click Save.

10. If you have already exported a data table from JMP, the data will appear in Google Sheets. Go to your Google spreadsheet to see the data in the specified sheet.

or

If you are exporting data using the specified Google account for the first time, you are prompted to give JMP access to your Google account.

a. Click Allow.

b. Go to your Google spreadsheet to see the data in the specified sheet.

Depending on the size of the data table, the save operation might take some time.

About Exporting Google Sheets

JMP features such as formulas and List Check column properties are not supported in Google Sheets.

If the spreadsheet is empty, look in the JMP log for error messages. On Windows, select View > Log. On macOS, select Window > Log.

See About Importing Google Sheets for more information about security, country restrictions, and more.

If Display intranet sites in Compatibility View in Internet Explorer on Windows is selected, the Google Sheet cannot be exported. To avoid this issue, follow these steps:

1. In Internet Explorer, select the Tools button and then select Compatibility View settings.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).