Using JMP > Import Your Data > About Importing Data to JMP
Publication date: 08/13/2020

About Importing Data to JMP

You can import many file formats into JMP and save them as data tables. JMP opens many files by default. The file formats which JMP does not support by default require specific Open Database Connectivity (ODBC) drivers.

The Following File Formats Are Supported by Default:

Comma-separated (.csv)

.dat files that consist of text

ESRI shapefiles (.shp)

Flow Cytometry versions 2.0 and 3.0 (.fcs)

Hierarchical Data Format, Version 5 (.h5)

HTML (.htm, .html)

JSON (.json)

MATLAB (.m, .M)

Microsoft Excel 1997 through 2019 on macOS (.xls, .xlsx)

Microsoft Excel 2010 through 2019 on Windows (*.xlsx, *.xlsm)

Minitab Portable Worksheet (.mtp)

Plain text (.txt)

R (.r)

SAS transport (.xpt, .stx)

SAS versions 7 through 9 on macOS (.sas7bdat)

SAS versions 7 through 9 on Windows (.sas7bdat, .sas7bxat)

SPSS (.sav)

SQLite 3.0 or higher (.sqlite, .db, .sqlite3, .db3)

Tab-separated (.tsv)

Teradata database (.trd)

Triple-S (.sss, .xml)

xBase data files (.dbf)

XML data files (.xml)

Notes on SAS Support:

On both Windows and macOS, you can open SAS data sets directly through the File > Open command. See Import SAS Data Sets.

Another option is connecting to a SAS server by selecting File > SAS > Browse Data. See Open SAS Data Sets through a SAS Server.

The Following Files Require ODBC Drivers:

Database (dBASE) (.ndx, .mdx) is supported with a V3+ compliant ODBC driver. .dbf files do not require an ODBC driver.

Microsoft Access Database (.mdb) is supported with a V3+ compliant ODBC driver.

See Import Data from a Database for more information for working with databases.

Your computer’s available memory affects data import. Very large files might load slowly or not at all. Consider splitting up large files before importing them. In JMP, you can then join or concatenate the tables. See Concatenate Data Tables in the Reshape Data section and Join Data Tables in the Reshape Data section.

Note: You can open R code (.R) and SAS program files (.sas) in JMP, but the text opens in a Script window, not in a data table.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).
.