Discovering JMP > Save and Share Your Work > Create a Web Report
Publication date: 08/13/2020

Create a Web Report

The File > Publish option creates a web page in which reports, descriptive text, and graphics are displayed. The web page, graphics, and support files are saved in the directory that you specify so that you can zip the files and send them to another user. This feature is particularly helpful for non JMP users.

Some graphs can be displayed as interactive HTML (for example, bubble plots or background maps). When you click the thumbnail of the graph in a web report, the interactive graph appears on a new web page.

To generate a web report, follow these steps:

1. Select Help > Sample Data Library and open SATByYear.jmp.

2. Run the Graph Builder Map and Bubble Plot by State scripts.

3. From any JMP window, select File > Publish.

4. Click Select All to display both graphs in the report.

Note that the Folder Name box indicates the current date and time. The web report files are saved in this folder.

5. Click Next.

6. Enter the descriptions shown in Figure 7.17.

Note: If you selected one report, you have the option of generating an index page. The index page shows a thumbnail of the report. You click the thumbnail to view the report. Figure 7.18 shows an example.

Figure 7.17 Customizing the Web Report 

Notes:

The reports are in the order you created them. In this example, the Graph Builder Map script was run first, so the map is the first report. Use the arrows next to the reports to rearrange them. Also, after you remove a report, a Restore Reports button appears in case you want to add the report again.

Click Add Image to append an image to the bottom of the report.

7. Enter SAT By Year Reports in the Web Report Title box.

8. Click Build Report.

The web page opens in your default browser.

Figure 7.18 Web Report 

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).
.