Using JMP > Extend JMP > Combine Reports by Creating a Dashboard > Example of Creating a Dashboard with Two Reports
Publication date: 08/13/2020

Example of Creating a Dashboard with Two Reports

Suppose that you created two reports and want to run the reports again the next day against an updated set of data. This example shows how to create a dashboard from the reports.

1. Select Help > Sample Data Library and open Hollywood Movies.jmp.

2. To create the reports, run the table scripts named “Distribution: Profitability by Lead Studio and Genre” and “Graph Builder: World and Domestic Gross by Genre”.

3. From any window, select File > New > Dashboard.

Templates for common layouts appear.

4. Select the 2x1 Dashboard template.

A box with room for two reports appears on the workspace.

5. In the Reports list, double-click the report thumbnails to put them on the dashboard (Figure 11.3).

6. Click the Dashboard Builder red triangle and select Preview Mode.

A preview of the dashboard appears. Notice that the graphs are linked to each other and the data table. They also have the same red triangle options as the Distribution and Graph Builder platforms.

Figure 11.2 A Dashboard with Two Reports 

7. Click Close Preview.

8. In Dashboard Builder, select File > Save, and then save the file as a .jmpapp file.

Users who have JMP can open the data table and double-click this file to display the dashboard. Note that the .jmpapp file cannot be edited.

9. Return to the Dashboard Builder window, select File > Save As, and then save the file as a .jmpappsource file.

The dashboard is saved in a file that you can edit in the future.

Note: You might also want to save the dashboard as an add-in. Users then view the dashboard by selecting a menu item in the main Add-Ins menu instead of opening the .jmpapp file. See Example of Creating a JMP Query Dashboard and Add-In.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).
.