Using JMP > Import Your Data > Import Microsoft Excel Files > Import a Microsoft Excel File Directly
Publication date: 08/13/2020

Import a Microsoft Excel File Directly

Microsoft Excel files open in the Excel Import Wizard by default. This option is helpful when the structure of data in the worksheet is irregular. For example, you might want to exclude hidden columns or convert text in the third row to column headings.

Instead of opening spreadsheets in the Excel Import Wizard, you can select File > Open to open the file. By default, JMP detects whether the first row contains labels and converts them to column headings. You can change this setting in the General preferences. The Excel Open Method preferences are in File > Preferences > General (Windows) and JMP > Preferences > General (macOS). From the Use Excel Labels for Headings list, select Always or Never.

To set the Excel Open Method preference

To always open Microsoft Excel files outside the wizard, change the Excel Open Method preference. Choose to open all worksheets at once or select them from a list.

To open a Microsoft Excel file (Windows)

1. After you set the Excel Open Method as described above, select File > Open.

2. To convert text in the first row to column headings, select Always next to Always enforce Excel Row 1 as labels.

3. Select the Excel Files file type, select the file, or enter the URL.

4. To import all worksheets, click Open.

or

To select the worksheets that you want to open, click the Open button arrow, and then select Open Selected Worksheets. Select one or more worksheets and click OK.

To open a Microsoft Excel file (macOS)

1. Select File > Open and select the file.

2. (.xls only) To convert text in the first row to column headings, select Use Excel Labels as Headings.

3. (.xls only) To open specific worksheets, select Select Individual Excel Worksheets.

4. Click Open.

If you chose to open specific worksheets, select those worksheets from the list, and then click OK. You can also click Select All if you change your mind and want to import all worksheets.

If you selected an .xlsx file, a preview of the data appears in the Excel Wizard. See Preview and Import the Microsoft Excel Data.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).
.