Using JMP > Import Your Data > Import Data from the Internet or a Remote Computer
Publication date: 08/13/2020

Import Data from the Internet or a Remote Computer

Import data from the Internet, FTP sites, or other computers by selecting File > Internet Open. A file path can start with http, ftp, or file; a drive letter; or, the path to a network drive (relative or absolute).

Using Internet Open, you can import data and images from the Internet or a remote computer and save it as a data table, web page, or text. You can also open a SAS stored process report using this option. See Import Data from Google Sheets for more information about using Internet Open to import a Google spreadsheet.

Suppose that you want to import data (with images) from a table on a web page and save it as a data table. The specific web page lists countries by population.

1. Select File > Internet Open > Web Page.

2. Enter the following URL: https://en.wikipedia.org/wiki/List_of_countries_and_dependencies_by_population.

3. Click OK.

4. Keep Open As set to Data, and click OK again.

JMP finds several tables on the specified page.

5. Click Rank country (or dependent territory)... and click OK.

JMP opens a data table that contains the information from the web page table.

6. (Optional) To add the images to the data table, run the Load pictures script.

Notes:

You can open a remote file as one of the following formats:

Data

Opens the file as a data table.

Web page

Opens the web page in the JMP browser (Windows) or the default browser (macOS).

From the File menu on Windows, you can then choose to save the file or import the data as a data table. Select this option to import data that is generated by web page scripts and server-side requests.

Text

Opens the file in the script editor. If you imported an HTML file, the HTML tags of a web page are displayed.

When you open a file from an FTP server, an FTP login window appears. For an anonymous account, click OK. For an authenticated login, enter your user ID and password. The file then opens as you specified.

Note: Some anonymous FTP servers require a user ID. If the data table does not open, try typing either “ftp” or “anonymous” in the User ID text box. Leave the Password text box empty and click OK.

JMP waits 60 seconds before stopping the import due to an error. You can change the Internet Time Out setting on the General preferences page.

If the table that you are importing contains images, the images are first imported as text. To display the images in your data table, run the automatically generated table script named Load pictures. A new expression column that contains the images is added to the data table.

Running the Source script in a data table enables you to re-import and refresh the data.

To open a SAS stored process report as a data table (Windows only)

1. Select File > Internet Open and select the file.

The file opens in the JMP browser.

2. In the JMP browser, select File > Import Table as Data Table.

A window appears that lists the tables found in the web page.

3. Select the table or tables that you want to import.

4. Click OK.

Each table is opened as a new data table.

See Run Stored Processes for more information about stored process reports.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).
.