Using JMP > Save and Share Data > Save and Share Data Tables
Publication date: 08/13/2020

Save and Share Data Tables

JMP saves data tables in the formats listed in Table 10.1.

Here are the basic steps for saving a data table:

(Windows) Select File > Export to save the data table in multiple formats.

(macOS) Select File > Save As to save as a JMP file (.jmp). Select File > Export to save in Text (.dat), Microsoft Excel (.xls or .xlsx), SAS Transport (.xpt), and SAS Data Sets (.sas7bdat), and JSON formats.

Note: To save a data table as a journal, select Edit > Journal and then File > Save As.

Table 10.1 Supported File Types for Saving Data Tables

File Type(s)

OS Availability

JMP Data Table (.jmp)

All

Excel Workbook (.xls, .xlsx)

All

Text Export File (.txt)

All

Comma-delimited File (.csv)

Windows

Tab-delimited File (.tsv)

Windows

SAS Data Set (.sas7bdat)

All

SAS Data Set with Extended Attributes (.sas7bxat)

Note: JMP can save column properties and table properties as extended attributes in a SAS 9.4 .sas7bxat file. Select File > Export, select the SAS file type, and then select the check box for saving extended attributes. JMP names the file with the .sas7bxat extension. The SAS Integration preferences also include this option, which is off by default.

Windows

SAS Transport File (.xpt,.stx)

All

JSON Data File (.json)

All

You can also save files for types that have a corresponding ODBC driver. See Save Data Tables to a Database.

Notes:

The maximum length of the data table’s name depends on your computer’s operating system. See your operation system documentation for details.

JMP tries to save any modified files when a crash is detected.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).
.