Using JMP > Save and Share Data > Save and Share Data Tables > Save as a SAS Transport File
Publication date: 08/13/2020

Save as a SAS Transport File

You can save a JMP data table in SAS transport file format. JMP replaces spaces in filenames and column names with underscores, converts column headings to uppercase SAS variables, and makes other changes to follow the transport file specifications.

When you save the data table as a transport file, you can opt to append it to an existing transport file. When you reopen the transport file in JMP, the two data tables open in separate windows.

Note: The maximum length for SAS transport filenames is 8 characters. JMP warns that characters beyond that limit are omitted.

Windows

1. Select File > Export.

2. Select SAS Transport File and click Next.

3. Enter the file name in the File name box.

4. (Optional) Append the data table to an existing SAS transport file. Select the file to which you want to append the data table, and then click the Save arrow. Select Append To, and then click Yes to replace the selected data table.

An alert appears regarding loss of formulas, formatting information, and other metadata.

Note: Images in Expression columns cannot exceed 200 characters, otherwise they are not supported.

5. Click Yes.

Alerts appear regarding other SAS format modifications.

6. Click OK on each alert.

macOS

1. Select File > Export.

2. Select SAS Transport.

3. (Optional) To append the data table to an existing SAS transport file, select the Append check box.

4. Click Next.

5. Do one of the following:

If you chose to append the data table, select the file to which you want to append the data table and click Append.

Enter a name for the file in the Save As box, and then click Export.

Alerts appear regarding SAS format modifications.

6. Click OK on each alert.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).
.