Using JMP > Save and Share Data > Save Parts of a Report in a Graphic Format
Publication date: 08/13/2020

Save Parts of a Report in a Graphic Format

You can save part of an analysis report window as a graphic. You can save the selection in .png, .jpg, .gif, .eps, .emf, .pdf, .tiff, and .svg formats. On macOS, you can save the selection in .png, .jpg, .gif, .svg, .eps, .pdf, and .pptx formats.

To save a selection, follow these steps:

1. Click the selection tool ().

2. Highlight the area that you want to save.

3. On Windows, select Edit > Save Selection As. On macOS, hold down the Ctrl key and select File > Save Selection As.

The Save Selection As window appears (or the Save window on macOS).

4. Enter the filename for the graphic.

On macOS, change the file extension to save the file in a format other than .png, the default format.

Note: If you use Save Selection As and create a PDF file from the selection, the PDF file has headers and footers. With JSL, you can control pagination on both Windows and macOS. See db<<Save Picture(<path>, <format>) in the JSL Syntax Reference.

5. Change options on Windows:

Select the graphics file format type to which you want to save the selection. See Save and Share Reports.

Select the Image DPI Setting. 300 or higher is best for graphics that must be stretched or printed.

To keep your selected DPI Setting for the current session, select Always use this setting.

To avoid opening the file in the default graphics program after saving, deselect Open the file after saving.

Select Select this filter the next time this window is invoked to save your file type selection for the current session.

Note: If you cannot see the Select this filter option, select a folder location for saving the graphic file.

6. Click Save.

Tips:

You can change the default DPI setting selection in the Windows Specific preferences from 96 to 300 DPI. The following script lets you set the default DPI to a different value. Change the number if you want a different DPI and then run the script.

Pref( Save Image DPI( 600 ) );

On macOS, you cannot change the default DPI, which is 72.

When you export a graph or report that contains a bitmap image to an .svg file, the image is embedded in the .svg file. The exported content is then easier to reuse in other documents.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).
.