Using JMP > Save and Share Data > Save and Share Reports > Save a Report as Interactive HTML
Publication date: 08/13/2020

Save a Report as Interactive HTML

Interactive HTML enables you to share JMP reports that contain dynamic graphs so that even non JMP users can explore the data. The JMP report is saved as a web page that includes interactive features, which you can email to users or publish on a website. Users then explore the data as they would in JMP.

Interactive HTML provides a subset of features from JMP:

Explore interactive graph features, such as selecting histogram bars and viewing data values.

View data by brushing.

Show or hide report sections.

Figure 10.3 Brushing Data in Interactive HTML 

Many changes that you make to the graphs, such as ordered variables, horizontal histograms, background colors, and colored data points, are saved in the web page. Graphs and tables that are closed when you save the content remain closed on the web page until the user opens them.

Interactive HTML Contains Data

When you save reports as interactive HTML in JMP, your data are embedded in the HTML. The content is unencrypted, because web browsers cannot read encrypted data. To avoid sharing sensitive data, save your results as a non-interactive web page. (Select File > Save As > HTML File on Windows, or File > Export > HTML on macOS.)

To create interactive HTML

1. In JMP, create the report and make it the active window.

2. Select File > Export, select Interactive HTML with Data and click Next.

3. Name the file.

4. (Optional) To avoid opening the HTML file in the default browser after saving, deselect Open the file after saving.

5. Click Save.

The output is saved in the selected folder.

Which Reports Are Supported

When you save a report as interactive HTML, the Save Report As window warns you if one or more features in the report are not supported (and might be static in the output). For more detailed information, view the JMP log (View > Log).

If the contents are fully supported, output is created with no warnings.

Partially or unsupported features are still saved in an interactive web page. When you place your cursor over an unsupported feature, a tooltip states that the feature is not yet interactive.

For information about exploring interactive HTML output, visit https://www.jmp.com/interactive.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).
.