Scripting Guide > Scripting Tools > Working with the Log
Publication date: 08/13/2020

Working with the Log

As you run a script, the output appears in the log window. The actual script is shaded in the log, and the output appears beneath it (Figure 4.8).

Figure 4.8 The Script Window (left) and the Log Window (right) 

Syntax and compatibility errors are reported in the log, including the line number and code that JMP could not process (Figure 4.9).

Figure 4.9 Syntax Error Message 

Open the log by selecting View > Log (Window > Log on macOS).

Tips:

To omit compatibility warnings from the log, deselect Show log warnings for JSL compatibility changes in 12 in the JMP General preferences.

Change the log font and colors in the Script Editor preferences. See Color Coding and Themes.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).
.