Using JMP > Save and Share Your Data > Save and Share Reports > Publish Reports to JMP Live or JMP Public
Publication date: 03/23/2021

Publish Reports to JMP Live or JMP Public

JMP Live is a website purchased by your company for sharing JMP content privately. JMP Live can be hosted by SAS or your company. JMP Public is a website using the same technology as JMP Live, where anyone can share JMP content with the public.

JMP Live and JMP Public are platforms for sharing JMP data, visualizations, and dashboards. Prepare your reports in JMP and publish them as posts to collaborate with your colleagues, even those who might not have JMP.

JMP Live and JMP Public offer the visual interactivity of JMP to explore your data, and let you do the following:

Store all of your reports in one location.

Control sharing of individual reports with those who need to see them.

Maintain up-to-date reports for your team in an easily accessible location.

Extend the functionality of reports to other locations: embed and interact with your reports in web pages, blogs, social media posts and more.

Register and Sign Into a SAS Profile (JMP Public Only)

Before you can publish posts to JMP Public, you must register and sign in using a SAS profile.

Note: If you are not signed in to JMP Public, you see only featured posts.

1. In a browser, go to https://public.jmp.com.

Supported browsers include Chrome, Firefox, Safari, and Edge (based on Chromium).

2. At the top right, click Sign in.

3. If you already have a SAS profile, log on using those credentials, then click Submit.

4. If you do not have a SAS profile:

a. Click Register. Complete the form and click Create profile.

b. Follow the instructions in the email to set your password and activate your profile.

Add a JMP Live Server

Before you can publish to JMP Live, you must add a JMP Live server.

1. In JMP, select File > Publish > Manage Connections.

2. Click Add New.

3. Enter an identifying name for the connection, such as JMP Live.

4. Enter the server URL, formatted like this: https://jmpliveserver.com:3501 (where 3501 is the default web server port).

5. (Optional) To use JSL to create JMP Live reports, enter an API key.

6. Click Next.

7. Sign in to the JMP Live server with your user name and password.

8. Once the connection is created successfully, click Save.

The server name appears under Select a connection.

9. Click Exit.

Create and Publish JMP Reports

1. In JMP, create the reports.

You can create a single report, which appears as its own post in JMP Live or JMP Public, or multiple reports which appear in a folder.

2. (Skip if your report does not contain a Local Data Filter.) If the report contains a Local Data Filter, add columns before you publish, otherwise the Local Data Filter will be static instead of active. To add columns, select them in the Local Data Filter and click the Add icon.

3. Select File > Publish > Publish to JMP Live or Publish to JMP Public.

(JMP Live only) If you have not added a JMP Live server, add one now. See Add a JMP Live Server.

You might need to sign in to JMP Live or JMP Public.

Note: To register for a SAS login, visit https://www.jmp.com and click Sign In near the search box at the top of the page.

Figure 10.4 Select Reports Window 

Select Reports Window

4. (JMP Live only) Next to Publish to, select a JMP Live server.

5. Select the open reports that you want to publish.

6. Choose your action and then click Next:

Create a New Post

Add Reports to an Existing Folder

Replace an Existing Report in a Post (if a post with the exact name exists)

Create a New Post

Figure 10.5 Create a New Post with Multiple Reports 

Create a New Post with Multiple Reports

Note: If you are publishing a single report, the window and options in Figure 10.5 are slightly different.

1. (Multiple posts only) Enter a title for the folder and an optional description.

2. (Optional) Update the title for each report and add descriptions.

3. Choose how to share the post:

Only Me keeps your post private and visible to you only.

Everyone shares your post with everyone on JMP Public or JMP Live.

Groups shares your post with groups that you select. Groups that you can publish to appear below this option.

4. Change additional options. See Post Options.

5. Click Publish.

6. Click OK to dismiss the informative window.

Figure 10.6 JMP Live Folder Containing Reports 

JMP Live Folder Containing Reports

Add Reports to an Existing Folder

Figure 10.7 Select an Existing Folder 

Select an Existing Folder

Note: You see only folders that you have permission to update. These are folders that you own or folders in a group that you are a member of.

1. Select a folder. Do one of the following:

Click a folder in the list and click Next.

Search for a folder—In the Keyword Search box, enter a word that appears in the folder name or description and then click a folder. Click Next.

Figure 10.8 Add a Report to an Existing Folder 

Add a Report to an Existing Folder

Note: If you are publishing multiple reports, the window and options in Figure 10.8 are slightly different.

2. (Optional) Update the title for each report and add descriptions.

3. Change additional options. See Post Options.

4. Click Publish.

5. Click OK to dismiss the informative window.

Figure 10.9 Report Added to Existing JMP Live Folder 

Report Added to Existing JMP Live Folder

Replace an Existing Report in a Post

Figure 10.10 Select an Existing Post 

Select an Existing Post

Note: You see only posts that you have permission to update.

1. Select a post. Do one of the following:

Click a post in the list and click Next.

Search for a post—In the Keyword Search box, enter a word that appears in the post name or description and then click a post. Click Next.

Figure 10.11 Replace an Existing Post 

Replace an Existing Post

2. Choose one of the following options:

To use the same title and description (if one exists) from the existing post, click Copy to New.

To use an updated title and description, enter a new title and description.

3. Change additional options. See Post Options.

4. Click Publish.

5. Click OK to dismiss the informative window.

Figure 10.12 Report Replaced in JMP Live 

Report Replaced in JMP Live

Post Options

Title

Add a title for the web page. You can also change the report titles.

Description

(Optional) Add a description to the web page that appears under the title. You can also add report descriptions that appear under the report titles.

Publish Data

Select this for interactive reports. If you deselect this option, the reports are static. When selected, the data behind the report and a JSL script of the report are published.

Note: To avoid sharing sensitive data, save your results as a non-interactive web page. (For a single report, select File > Export > HTML. For multiple reports, select File > Publish > Publish to File and deselect Publish Data.)

Enable Warnings

(Applicable for platforms that support control charts only.) Notifies interested parties when the post has control chart warnings. Interested parties include the publisher of the post and any groups the post is shared with that have warning notifications enabled.

Add Image

Adds an image as an image-only report.

Allow data and scripts to be downloaded

Allows data tables and scripts associated with the reports to be downloaded. If you do not select this option, in JMP Live there is no download option next to the data table names and no JSL script to re-create the report. See Note on Data Accessibility.

Open published web report

Opens the web page in a browser once you click Publish.

Close reports after running

Closes the reports in JMP once you publish the web report.

Delete icon Image shown here

Deletes a report.

Arrow icons Image shown here

Changes the order of reports.

JMP Live and JMP Public Help

For help with using JMP Live or JMP Public, click Image shown here > Help. This opens one of these help pages:

JMP Live: https://www.jmp.com/jmplive

JMP Live (administrator): https://www.jmp.com/jmpliveadmin

JMP Public: https://www.jmp.com/jmppublic

Note on Data Accessibility

The data that is represented in your published reports will exist online in HTML5 files as well as in the JMP data table format.

Disabling the Allow data to be downloaded option prevents any user who has access to the JMP Live page from being able to download the data in the JMP data table format, but it does not prevent a user from being able to get the HTML file containing the data in XML format. Enabling the Allow data to be downloaded option allows a user who has access to the JMP Live page to get the data in either way. The JMP format is only useful to users who have access to the JMP Live page who also have a separate license of JMP software or a third-party software that knows how to read JMP files, but a user of the JMP Live page only needs a web browser to see the data in the HTML file.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).