Quality and Process Methods > Control Chart Builder > Control Chart Builder Options > Control Chart Builder Red Triangle Menu Options
Publication date: 03/23/2021

Control Chart Builder Red Triangle Menu Options

The Control Chart Builder red triangle menu contains the following options:

Show Control Panel

Shows or hides the following elements:

buttons

the Select Columns box

the drop zone borders

check boxes and drop-down menus

Show Limit Summaries

Shows or hides the Limit Summaries report. This report shows the control limits (LCL and UCL), the center line (Avg), the Points and Limits plotted, and the Sample Size for the chart. Sample size is not shown for rare event charts.

Show Capability

(Available only for Shewhart Variables charts that have specification limits.) Shows or hides the Process Capability Analysis report. Since the report is part of the Limit Summaries report, the Process Capability report appears only when the Show Limit Summaries option is selected. For more information, see The Process Capability Report. You can set preferences for many of the options in the Process Capability report in Control Chart Builder at File > Preferences > Platforms > Process Capability.

Note: Show Capability is not available if the response variable has no variation.

Show Alarm Report

Shows or hides a report that contains information about out of control samples. The report reflects failures for currently enabled tests in each chart and updates automatically as different tests are enabled and disabled and as data and row states change. A second table lists the currently enabled tests for each chart. The first table contains the following columns:

Position

Indicates the numerical position of the chart, starting from the top of the report.

Total Samples Out of Control

Counts the number of samples that failed at least one of the selected tests.

Alarm Rate

The total number of samples out of control divided by the total number of nonmissing samples. This is also known as the Proportion Out of Control.

Note: The counts that contribute to the calculation of the alarm rate include excluded samples only if the Test Excluded Subgroups and the Show Excluded Region options are both selected.

Show Limit Labels

Shows or hides labels for the limits in each chart. The limits are shown inside the right frame of the chart.

Show Sigma Report

(Available only for Shewhart Variables charts.) Shows or hides the Process Sigma Report, which is a table of sigma values. The Process Sigma Report contains the overall sample size, number of subgroups, sample mean, overall sigma, within sigma, and stability index. For three way control charts, the between-sigma and between-and-within sigma values are also shown. If a phase variable is specified, a set of values is given for each phase.

Note: The Process Sigma Report appears only if the Limit Summaries report is turned on.

Get Limits

Retrieves the control limits that are stored in an open or saved data table.

Show Excluded Region

Shows (on) or removes (off) the regions of the chart where samples have been excluded. When entirely excluded subgroups are shown on the location chart, they appear as dimmed points to indicate that they are excluded.

Caution: The Show Excluded Region option impacts the chart. Excluded samples are removed from the calculation of control limits, whether this option is on or off. Excluded samples are included in alarm rate calculations only if the Test Excluded Subgroups and the Show Excluded Region options are both selected.

Set Subgroup Size

(Not available if a subgroup variable is specified.) Sets a subgroup size. Missing values are taken into account when computing limits and sigma.

Note: If the Set Subgroup Size option is used, the Show Excluded Region option is turned on automatically.

Save Limits

Saves the control limits in one of the following ways:

in Column

Saves control limits as a column property in the existing data table for the response variable. If the limits are constant, LCL, Avg, and UCL values for each chart type in the report are saved. This option is not available with phase charts. In addition, the option has no effect if the sample sizes are not constant for each chart.

in New Table

Saves the standard deviation and mean for each chart into a new data table. If the limits are constant, the LCL, Avg, UCL, and Sample Size for each chart are saved as well. If there are phases, a new set of values is saved for each phase. There is a row for each statistic and a column for each Y variable.

in New Tall Table

(Not available for Rare Event, Attribute, or Phase charts.) Saves the standard deviation, mean, and Sigma for each chart into a new data table. If the limits are constant, the LCL, Avg, UCL, and Sample Size for each chart are saved as well. There is a row for each Y variable and a column for each statistic. A column for Sigma that can be used in the Process Screening platform is also saved.

Save Summaries

Creates a new data table containing such information as the sample label, sample sizes, statistic being plotted, center line, control limits, and any tests, warnings and failures. The specific statistics included in the table depend on the type of chart.

Graph Spacing

Sets the amount of space between the graphs.

Include Missing Categories

Enables the graph to collect rows with missing values in a categorical column, and displays the missing values on the graph as a separate category. If this option is disabled, all rows with a missing X value are removed from the calculations, in addition to being hidden from the graph.

This option is not available for continuous X variables or categorical Y variables because there is no compelling way to display the collected missing values on the relevant axes. By default, this option is enabled.

Note: If Include Missing Categories is enabled, capability analysis results in Control Chart Builder do not match those in the Process Capability platform if a categorical X variable has missing values.

Use Event Chooser

(Available only for attribute charts with numeric non-continuous Y variables.) Categorizes ordinal numeric data and offers individual numeric-level modeling selections.

Alarm Script

Enables you to write and run a script that indicates when the data fail special causes tests. See Tests. Results can be written to the log or spoken aloud, and there is an option to include an explanation of why the test failed. You can also send results to an email using the custom script option.

As an Alarm Script is invoked, the following variables are available, both in the issued script and in subsequent JSL scripts:

qc_col is the name of the column

qc_test is the test that failed

qc_sample is the sample number

qc_phase is the label of the phase during which the failure occurred

See Run Alarm Scripts in the Scripting Guide for more information about writing custom Alarm Scripts.

Note: Alarm scripts are not available in reports that use the Local Data Filter.

Sort by Row Order

Sorts all subgroup and phase variables in the order in which the levels appear in the data table. This applies to all combinations of nested subgroup and phase variables.

Test Excluded Subgroups

(Available only if the Show Excluded Region option is selected.) Includes (on) or excludes (off) entirely excluded subgroups in the computation of tests. When excluded subgroups are shown and the Text Excluded Subgroups option is not selected, the excluded subgroups are treated as missing values.

Note: For any test that relies on consecutive points (runs tests), an entirely excluded subgroup is treated as missing and counts of consecutive points are restarted.

Control Chart Dialog

(Available only if the control chart is launched through a Control Chart launch window.) Opens the Control Chart launch window with the original settings that were used to create the control chart.

See Local Data Filters in Reports, Redo Menus in Reports, and Save Script Menus in Reports in Using JMP for more information about the following options:

Local Data Filter

Shows or hides the local data filter that enables you to filter the data used in a specific report.

Redo

Contains options that enable you to repeat or relaunch the analysis. In platforms that support the feature, the Automatic Recalc option immediately reflects the changes that you make to the data table in the corresponding report window.

Save Script

Contains options that enable you to save a script that reproduces the report to several destinations.

Column Switcher is available only for a single Y variable having two or fewer associated charts. Based on the selected chart type, only columns that are appropriate for the Y role are included in the Column Switcher column list.

In Control Chart Builder, the Automatic Recalc option is turned on by default and cannot be turned off.

When using the local data filter, you can deselect the Show Excluded Region option for more focused exploration.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).