Using JMP > JMP Reports > Reformat Tables in Reports
Publication date: 05/24/2021

Reformat Tables in Reports

There are many ways to change the formatting of a report table. Right-click a report table to access the following formatting options:

Table Style

Adds borders, shading, and dividing lines to the table. Select from the following options:

Underline Headings

Shows the preference setting for Underline Table Headings.

Shade Headings

Shows the preference setting for Shade Table Headings.

Heading Column Borders

Shows divider lines between columns in headings.

Column Borders

Contains borders outside columns and divider lines between columns.

Row Borders

Contains borders outside rows and divider lines between columns.

Shade Alternate Rows

Shades alternate rows.

Shade Cells

Shades the body of the table. When used with Shade Alternate Rows, a darker shade is used on alternate rows.

Note: Change the format of all report tables by selecting the preceding options in the JMP preferences. On Windows, the Report Tables options are in File > Preferences > Styles. On macOS, select the Report Tables options in JMP > Preferences > Styles.

Columns

Shows or hides columns in the table.

Note: Columns whose names begin with a tilde (~), such as ~Bias, are not applicable to the analysis that you ran and do not appear in the table, even if you place checks next to their names.

Sort by Column

Sorts the columns in descending or ascending order by the selected column. You can also select Numerical Order to sort a sorted string column numerically. After you do that, the Numerical Order option is available when you right-click the column. For more information about the sorting rules used by the Numerical Order option, see Numerical Order.

Make into Data Table

Creates a JMP data table from the report table. The data table script recreates the report and the data table generated by Make into Data Table.

Make Combined Data Table

Searches the report for other tables like the one you selected and combines them into a single data table. The data table contains a column that identifies the original data table. The data table script recreates the report and the data table generated by Make Combined Data Table.

Make Into Matrix

Creates a JMP matrix from a report table. See Turn a Table in a JMP Report Into a Matrix.

Select Where

(Available only for categorical columns) Creates a Where clause using the selected columns or a complex expression.

Show Properties

Enables you to modify the formatting of display boxes in the report.

Format Columns

Changes the numeric formatting of one or more columns in the table.

Copy Column

Copies the contents of the right-click column to the clipboard for pasting into another window or application.

Copy Table

Copies the right-click table to the clipboard for pasting into another window or application.

Simulate

Provides simulated results for the selected column of statistics in a report.

Image shown here Bootstrap

Approximates the sampling distribution of a statistic. See Bootstrapping in Basic Analysis.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).