Using JMP > Save and Share Your Data > Save Reports as PDF Files
Publication date: 05/24/2021

Save Reports as PDF Files

You save reports as PDF files by selecting File > Save As > PDF File (*.pdf) (Windows) or File > Export > Image > PDF (macOS).

Windows

You can control pagination features such as headers, footers, and margins when you export the file.

Select File > Export, select PDF, and click Next.

Name the file, click Save, and then change settings in the Page Setup window.

You can also control pagination by selecting File > Page Setup. Note that you can click Set as Default to apply the settings to future page setups.

You can also control pagination by selecting File > Print Preview.

macOS

Select File > Export > Image > PDF. The resulting PDF file contains a single PDF image with no headers or footers.

You can also select File > Print and then select Save as PDF from the PDF window. The resulting PDF file is paginated into multiple pages as needed, with headers and footers, and using the page size, orientation, scaling, and margins that you selected in the Print and Page Setup windows.

Windows and macOS

Through JSL, you can control pagination on both Windows and macOS. See the following sections for more information:

db<<Set Page Setup<Margins(left, right, top, bottom)>, <Scale(s)>,<Portrait(Boolean)>, <Paper Size(paper size)>)

db<<Set Print Headers(left header, center header, right header)

db<<Set Print Footers(left footer, center footer, right footer)

db<<Save PDF(<path>, <Show Page Setup(Boolean)>, <Portrait(Boolean)>)

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).