この例で作成されるWorkflowBuilderForEach.jmpflowは、「Samples」の「Workflows」フォルダにあります。このワークフローは、元のデータテーブルの2つのサブセットに対して同じ分析を実行します。
まず、サンプルワークフローを開きます。
1. [ヘルプ]>[サンプルの索引]を選択します。
2. 「サンプルの索引」の赤い三角ボタンをクリックし、[サンプルを開く]>[ワークフロー]を選択します。
3. 「WorkflowBuilderForEach.jmpflow」を開きます。
この後、以下の手順に従ってワークフローを作成します。
1. [ファイル]>[新規作成]> [ワークフロー]を選択します。
2. [ヘルプ]>[サンプルデータフォルダ]を選択し、「Diabetes.jmp」を開きます。
3. 「アクションを記録しますか?」というポップアップウィンドウで[はい]をクリックします。
4. [テーブル] > [サブセット]を選択します。
5. [列の値ごとにサブセット]オプションを選択し、「列」リストから「性別」を選択して、[OK]をクリックします。
step 5で生成された2つのテーブルのうちの1つを使用します。
6. [分析]>[一変量の分布]を選択します。
7. 「Y 順序尺度」、「BMI」、および「総コレステロール」を選択し、[Y, 列]をクリックします。
8. [OK]をクリックします。
9. 「総コレステロール」の赤い三角ボタンをクリックし、[保存]> [水準番号]を選択します。
10. 「一変量の分布」ウィンドウを閉じます。
11.
をクリックして記録を停止します。
12. 「ワークフロービルダー」の赤い三角ボタンをクリックし、[詳細]>[For Eachを追加]を選択します。
13. [レポートのスナップショット]ステップと[列の保存]ステップを選択して[For Each Item]ステップにドラッグします。
14.
をクリックしてリセットします。これで、開いているウィンドウがすべて閉じ、ワークフローが最初の状態にリセットされます。
15.
をクリックしてワークフローをテストします。
このワークフローを実行すると、「性別」の各水準について「一変量の分布」レポートが生成されます。