公開日: 09/09/2026

プリセットの共有

プリセットの書き出しと読み込み

プリセットを書き出すと、1つの.jmppresetsファイルが作成されます。このファイルをメールで送信したり、サーバーに置いたりすれば、他のユーザがそのプリセットを利用できます。

JMPの[プラットフォームのプリセット]環境設定にアクセスするには、Windowsでは[ファイル]>[環境設定]、Apple macOSでは[JMP]>[設定]を選択し、[プラットフォームのプリセット]をクリックします。

プリセットを書き出すには

1. ソースおよび書き出したいプリセットまたはプリセットグループを選択します。書き出せるのは1つのソースからのみです。

2. [書き出し]をクリックします。

プリセットを読み込むには

1. 読み込み先のソースを選択します。

2. [読み込み]をクリックします。

3. .jmppresetsファイルを選択します。

サンプルのプリセットやアドインで作成したソースに読み込むことはできません。

プリセットのアドイン

組織内でプリセットを配布したい場合や、個人用のプリセットとは別にプリセットのグループを管理したい場合、あるいは「お気に入りのプリセット」と同じ階層にプリセットのグループを追加したい場合は、プリセットのアドインを作成します。

プリセットのアドインを作成するには:

1. [ファイル]>[新規作成]>[アドイン]を選択します。

2. [一般情報]タブで、アドイン名、ID、バージョンを入力します。

3. (オプション)最低限必要なJMPバージョンや動作する最新のJMPバージョン、動作するホスト、保存後にインストールするかどうかを入力します。

4. [プラットフォームのプリセット]タブを選択します。

5. アドインを作成するための.jmppresetsファイルを選択するか、現在インストールされているプリセットの中からアドインに含めたいものを選択し、「アドインに含まれるもの」リストに移動させます。

6. 「アドインに含まれるもの」リスト内のプリセットを並べ替えます。

プリセットは、名前の変更、削除、グループ化ができるほか、ドラッグ&ドロップ操作で移動できます。

7. ラベルと説明を入力します。

ラベルは、「お気に入りのプリセット」と同じ階層で、ソース名として、および第一階層のプラットフォームのプリセットメニュー名として使用されます。ラベルが指定されていない場合は、アドインIDが使用されます。

8. [保存]をクリックします。

[保存後にインストール]を選択しなかった場合は、プリセットのアドインを他のアドインと同じ手順でインストールし、JMPで開くことができます。

アドインでインストールされたプリセットについて:

• カスタマイズ用のウィンドウやJMPの環境設定では変更できません。代わりに、アドイン内で編集してから再インストールする必要があります。

• [表示]>[アドイン]を選択して「アドインステータス」ウィンドウを開き、そこで削除する必要があります。

プリセットのアドインを編集用に開くには:

1. [ファイル]>[開く]を選択します。

2. プリセットのアドインを選択します。

3. [開く]ボタンのドロップダウンメニューをクリックし、[アドインビルダーを使って開く]を選択します。

より詳細な情報が必要な場合や、質問があるときは、JMPユーザーコミュニティで答えを見つけましょう (community.jmp.com).