使用 JMP > 导入数据 > 导入 XML 和 JSON 文件 > 直接导入 JSON 文件
发布日期: 09/18/2023

直接导入 JSON 文件

JSON 文件包含导入为列标题和数据的名称和值对。您可以使用“XML 导入向导”导入 JSON 文件(预览和导入 XML 和 JSON 数据),也可以直接导入。

要直接打开 JSON 文件,请执行以下步骤:

1. 在 Windows 上:

‒ 选择文件 > 打开。

‒ 将文件类型设置为 JSON 数据文件。

‒ 选择文件。

‒ 选择打开方式旁边的数据(最佳推测)。

2. 在 macOS 上:

‒ 选择文件 > 打开,然后选择文件。

‒ 点击窗口左下角的选项。

‒ 选择数据(最佳推测)。

3. 点击打开。

该文件将作为数据表打开。

注意:

• 导入的 JSON 文件不包含用于确定列格式的日期、时间、货币、地理、百分比和科学信息。若要使用这些格式中的任何一种,请右击数值列,选择列信息,然后在“数据类型”列表中更改格式。

• 名称-值对中的成员名称不区分大小写。

• JSON 导入代码不使用 JSON 文件的数值、布尔值或字符串区分方式。相反,它确定整列是数值还是非数值。若猜测非您所想,则可以将列明确指定为字符列。

• 该文件不得包含空的数组元素。名称必须用引号引起来,放在名称-值对中的冒号之前。

• JSON 标准接受带小数点的小数。

需要更多信息?有问题?从 JMP 用户社区得到解答 (community.jmp.com).