使用 JMP > 保存和共享您的数据 > 保存数据表 > 将 JMP 数据另存为 Google Sheet
发布日期: 09/18/2023

将 JMP 数据另存为 Google Sheet

Google Sheet 是一种保存在 Google 帐户中的电子表格。将 JMP 数据表导出到 Google Sheets 可允许您与其他人共享数据并在 JMP 之外编辑数据。

您可以将 JMP 数据表导出到现有的 Google 电子表格或创建新的电子表格。

要将 JMP 数据表导出为 Google 电子表格,请执行以下步骤:

1. 若您要导出到现有的电子表格,请首先执行这些步骤。如若不然,转至第 2 步。

a. 从浏览器中登录 https://sheets.google.com。

b. 打开现有电子表格。

c. 从浏览器地址栏中复制 URL。

2. 在 JMP 中,打开您要导出数据的数据表。

3. 选择文件 > 导出 > Google Sheets。

4. 在“电子表格类型”下,选择现有或新建电子表格。

5. 输入您的 Google 帐户名称。(没必要键入 @gmail.com。)

6. (仅限现有电子表格)在“电子表格名称”旁边,粘贴您在第 1 步中复制的 Google 电子表格的 URL。

7. (仅限新电子表格)输入新电子表格的名称。

8. 输入工作表的名称(选项卡名称)。

9. 点击保存。

10. 若您已从 JMP 导出了数据表,则该数据显示在 Google Sheets 中。转到您的 Google 电子表格以查看指定工作表中的数据。

或

若您是第一次使用指定的 Google 帐户导出数据,系统将提示您为 JMP 提供对您的 Google 帐户的访问权限。

a. 点击允许。

b. 转到您的 Google 电子表格以查看指定工作表中的数据。

根据数据表的大小,保存操作可能需要一些时间。

关于导出 Google Sheets

• Google 用来对您帐户进行身份验证的信息存储在 C:/Users/<用户名>/AppData/Roaming/
SAS/JMP/OAuthTokens.jmp
中(在 Windows 上)。在 Mac 上,oAuthTokens.jmp 存储在 ~/Library/Application Support/JMP 中。(密码不存储在计算机上,访问令牌会被加密。)若将令牌存储在数据表中,您就可以使用相同的 Google 帐户导入和导出数据,而无需再次提供身份验证信息。请注意,有权访问您的计算机用户帐户的用户也有权访问您的所有 Google 电子表格。若电子表格包含机密信息,请重新考虑共享您的用户帐户。

• Google Sheets 不支持公式和“列表检查”列属性之类的 JMP 功能。

• 若电子表格为空,请在 JMP 日志中查找错误消息。在 Windows 上,选择视图 > 日志。在 macOS 上,选择窗口 > 日志。

• 若 Google Sheet 只有一个工作表,则不能用新工作表替换该工作表。添加另一个具有唯一名称的工作表,然后删除原始工作表。在“导出至 Google Sheets”窗口中,选择现有的电子表格,然后再次导出数据表。您指定的工作表名称将显示在工作表中。

• 有关安全、国家限制等方面的详细信息,请参见“关于导入 Google Sheets” 。

• 若在 Windows 上的 Internet Explorer 中选择了在兼容性视图中显示 Intranet 站点,则无法导出Google Sheet。要避免该问题,请执行以下步骤:

1. 在 Internet Explorer 中,选择“工具”按钮 Image shown here,然后选择兼容性视图设置。

2. 取消选择在兼容性视图中显示 Intranet 站点。

需要更多信息?有问题?从 JMP 用户社区得到解答 (community.jmp.com).