使用 JMP > 输入和编辑数据 > 在数据表中组织数据 > 编辑数据表中的单元格
发布日期: 09/15/2026

编辑数据表中的单元格

使用“行编辑器”可以浏览或编辑单元格,一次处理一行。使用以下方法之一打开“行编辑器”:

• 选择行 > 行编辑器。

• 在数据表中,双击行号区域。所用的行将成为“行编辑器”中显示的第一行。

• 在报表窗口中,右击某个图形并选择行编辑器。

图 4.21 行编辑器 

Row Editor

双击数据表最后一列右侧的空白区域可添加一列。

• 若打开了某个报表窗口,而您希望编辑的数据自动体现在该窗口中,请务必打开“自动重新计算”功能。请参见“­自动重新计算­”。

• 若数据表包含值标签,“行编辑器”会显示这些标签;当单元格突出显示进行编辑时,它将显示实际值。请参见“­“SPSS 标签”、“长名称”和“SAS 标签”­”。

行编辑器按钮

点击箭头按钮可浏览选定行或整个数据集(若未选定任何行)。

Image shown here 显示上一行。

Image shown here 显示上一选定行。

Image shown here 使行在图形中闪烁。

Image shown here 显示下一选定行。

Image shown here 显示下一行。

Image shown here 搜索行。请参见选择包含特定值的行。

Image shown here 在数据表末尾创建新行。

注意:当您在“行编辑器”中更改字段时,使用“行编辑器”对行所做的更改会写入数据表。您仍必须将更改保存至数据表。

行编辑器选项

“行编辑器”中的红色小三角菜单包含以下选项:

下一选定行

显示有关当前行之后的选定行的信息。

上一选定行

显示有关当前行之前的选定行的信息。

下一行

显示有关当前行之后的行的信息,不论是否选定了该行。

上一行

显示有关当前行之前的行的信息,不论是否选定了该行。

保存

保存数据表以及您通过“行编辑器”对其所做的任何更改。

新建行

在数据表中创建新行。

查找

显示好像您在选定行 > 行选择 > 选择符合条件的行时出现的窗口。选择当前选择菜单中的选项之一,然后突出显示要选择其行的列。输入您希望 JMP 搜索的值。请参见选择包含特定值的行。

闪烁

使当前行突出显示,并快速闪烁。

注意:无法编辑锁定列中的文本或锁定的数据表。请参见“­锁定­”和锁定数据表。

“数据网格编辑”窗格

随即显示“新建列”窗口。使用“数据网格编辑”窗格隔离某个单元格的值,以便在不干扰数据表中其他单元格的情况下对该单元格进行修改。

点击数据表左下角的“打开编辑窗格”按钮 (Image shown here) 以打开“数据网格编辑”窗格。

图 4.22 已打开的“数据网格编辑”窗格 

The Opened Data Grid Edit Pane

示例:使用“数据网格编辑”窗格编辑长文本值

在本例中,数据表包含一列叙述文字,描述了向国家运输安全委员会报告的飞机事故。对于包含长文本值(如叙述性文字)的单元格,在数据表中编辑较为困难,因此建议使用“数据网格编辑”窗格来更便捷地修改文本值。

1. 选择帮助 > 样本数据文件夹,然后打开 Aircraft Incidents.jmp。

2. 滚动至数据表的最右侧。

3. 选择报告原因列的第 6 个单元格。

4. 点击数据表左下角的“打开编辑窗格”按钮。

“数据网格编辑”窗格随即打开。

图 4.23 在“数据网格编辑”窗格中显示长文本值 

Displaying a Long Text Value in the Data Grid Edit Pane

5. 在“数据网格编辑”窗格中,从文本值中删除“maintenance”一词。

6. 回到数据表中选择其中任意区域。

7. 要确认更改,请再次选择报告原因列的第 6 个单元格。

需要更多信息?有问题?从 JMP 用户社区得到解答 (community.jmp.com).