使用 JMP > 保存和共享您的数据 > 共享交互式报表和数据 > 将报表作为交互式 HTML 发布
发布日期: 09/15/2026

将报表作为交互式 HTML 发布

交互式 HTML 允许您共享包含动态图形的 JMP 报表,这样即便是非 JMP 用户也能探索数据。JMP 报表另存为可以与其他用户共享(例如,在共享网络驱动器上,通过电子邮件或在网站上)的交互式网页。然后用户可以如同在 JMP 中一样探索数据。

交互式 HTML 包含数据

当您将报表导出或发布为交互式 HTML 时,您的数据嵌入在 HTML 中。内容未经加密因为 Web 浏览器无法读取加密数据。因此,为了避免共享敏感数据,通过选择文件 > 导出并选择 HTML 将结果导出为非交互式网页。

交互式支持的功能

交互式 HTML 提供 JMP 中的一部分功能:

• 若完全支持您的报表中的功能,网页创建时没有警告。

• 若您的报表包含不支持的功能,您会在导出或发布窗口中看到一条消息指出部分实现交互式 HTML。详细信息,请参见 JMP 日志(视图 > 日志)。

• 部分实现或不支持的功能在网页中会静态显示。点击某个静态功能会显示一条消息,指示该功能不是交互式功能。

有关了解交互式 HTML 输出的信息,请访问 www.jmp.com/interactive。

将单个报表导出为交互式 HTML

要将单个 JMP 报表导出为交互式 HTML,使用“导出”作为“数据交互式 HTML”选项创建单个网页。

1. 在 JMP 中,创建该报表并使它成为活动窗口。

注意:若报表包含“本地数据过滤器”,则它在 Web 报表中是静态的,用户无法更改选择。要使“本地数据过滤器”可交互,取消选择包括模式。(在“图形生成器”中,要查看“包括”模式,从“本地数据过滤器”红色小三角中选择显示模式。)

2. 选择文件 > 导出,选择数据交互式 HTML,然后点击下一步。

3. 导航到您想要保存该文件的位置。

4. (可选)重命名文件。

5. 保持保存后打开文件选项处于选中状态。

6. 点击保存。

输出内容保存在选定文件夹中并在浏览器中打开。

图 11.2 单个交互式 HTML 报表的网页 

Web Page for Single Interactive HTML Report

将多个报表发布为交互式 HTML

要将多个 JMP 报表发布为交互式 HTML,使用“发布至文件”选项,它会创建包含报表的索引页面。

提示:当您发布多个 JMP 报表时,请指定保存索引页面和报表文件的位置。您可以选择共享网络文件夹并将该位置提供给其他用户,或选择您的计算机上的文件夹并在共享前压缩文件。若您共享的对象不使用 JMP,这将会特别有帮助。

1. 在 JMP 中,创建报表。

注意:若报表包含“本地数据过滤器”,则它在 Web 报表中是静态的,用户无法更改选择。要使“本地数据过滤器”可交互,取消选择包括模式。(在“图形生成器”中,要查看“包括”模式,从“本地数据过滤器”红色小三角中选择显示模式。)

2. 从报表窗口中,选择文件 > 发布 > 发布至文件。

3. 选择要发布的报表。

4. (可选)更改父级文件夹所在的位置或更改将包含报表的子文件夹的名称。

5. 点击下一步。

6. 输入索引页面的标题。

您还可以更新报表标题。

7. (可选)更改其他选项。

请参见交互式 HTML报表选项。

8. 点击发布。

图 11.3 多个交互式 HTML 报表的索引页面 

Index Page for Multiple Interactive HTML Reports

9. 点击报表标题以打开报表。

有关使用交互式报表的详细信息,请从 HTML 报表中点击 Image shown here > 帮助。这将打开帮助,网址为 www.jmp.com/interactive。

交互式 HTML报表选项

标题

为索引页面(仅多个报表)或报表添加标题。

说明

(可选)将说明添加至索引页面或报表。说明显示在标题下方。

定制

(仅为多个报表显示)更改网页的外观。您可以更改样式、主题、字体、徽标以及是否显示日期或时间。请参见定制索引页面选项。

运行后关闭报表

在您发布 Web 报表后关闭 JMP 中的报表。

发布数据

为交互式报表选择该选项。若您取消选择该选项,报表是静态的。

注意:要避免共享敏感数据,请将结果另存为非交互式网页。(对于单个报表,选择文件 > 导出,然后选择 HTML。对于多个报表,选择文件 > 发布 > 发布至文件,然后取消选择发布数据。)

添加图像

将图像添加至网页。您可以使用“箭头”图标上下移动图像。

“删除”图标 (Image shown here)

(仅为多个报表显示)删除报表。

箭头图标 (Image shown here)

(仅为多个报表显示)更改报表的顺序。

定制索引页面选项

样式格式

确定报表的布局。

大列表

在具有大缩略图的列中显示报表。

小列表

在具有小缩略图的列中显示报表。

网格

在行中显示报表。

定制 CSS

允许您指定一个 CSS 文件来格式化网页。将该 CSS 文件复制到名为 _css 的子文件夹中。指向 CSS 文件的链接是相对的,以便您可以将报表和支持文件发送到另一用户并维护 CSS 格式。

颜色主题

指定网页、标题和边框的颜色。默认网页有一个白色背景、橙色标题和蓝色边框。

更改字体

更改报表中应用的字体。

更改徽标

指定要与报表一起显示的图像。点击图像旁边的向上或向下箭头可以将它移到报表之上或之下。

显示日期/时间

显示或隐藏生成网页的日期和时间。

需要更多信息?有问题?从 JMP 用户社区得到解答 (community.jmp.com).