JMP Live SPC
统计过程控制 (SPC) 方法可帮助您监管和控制各个过程,从而协助您解决问题并提升质量。从 JMP Live 19 版开始,您可对控制图警告进行分级处理,并能与过程筛选控制图进行交互操作。
提示:要了解有关 JMP 中的控制图和过程筛选的信息,请参见 JMP 帮助中的《质量和过程方法》。
了解如何:
图 1.1 显示 JMP Live 中的控制图警告的示例

JMP Live 中的控制图处理
从 JMP Live 19 开始,对于控制图处理,您可以:
|
•
|
确定哪些过程确实处于失控状态且需要立即关注
|
|
•
|
在造成不稳定的根本原因处于调查的阶段发出警示信号
|
|
•
|
在根本原因得到解决、过程恢复稳定并按预期运行时,向相关人员发送通知
|
|
•
|
将团队资源集中用于处理最关键的问题,从而实现更有效的问题解决与过程改进
|
重要:
控制图处理功能仅支持静态限值,不支持动态计算的限值。动态的控制图限值可能会导致警告列表不稳定,该列表的内容会随数据的添加或更改而改变。要查看添加静态控制图限值(作为列属性)的示例,请参见设置静态控制限。如需了解添加静态控制图限值的其他方法,请参阅 JMP 帮助中的“控制限示例”。
处理控制图警告的示例
在本例中,一名工程师有一组与钢垫圈生产相关的数据。该工程师将基于静态控制图限值,识别并处理各批次钢垫圈的缺陷品比例。按以下步骤执行:
|
1.
|
|
2.
|
|
3.
|
|
4.
|
|
5.
|
|
6.
|
|
7.
|
设置静态控制限
|
1.
|
在 JMP 中,选择帮助 > 样本数据文件夹,然后打开 Quality Control/Washers.jmp。
|
|
2.
|
右击缺陷数列并选择列属性 > 控制限。
|
|
3.
|
将均值改为 P。
|
|
4.
|
为“平均值”输入 0.0055。
|
|
5.
|
为“下控制限”输入 0。
|
|
6.
|
为上控制限输入 0.015。
|
|
7.
|
为“子组大小”输入 400。
|
图 1.2 JMP 中的控制限

|
8.
|
点击确定。
|
创建控制图
|
1.
|
在 JMP 中,选择分析 > 质量和过程 > 控制图 > P 控制图。
|
|
2.
|
选择缺陷数并点击 Y,有缺陷数。
|
|
3.
|
选择批并点击子组。
|
|
4.
|
选择批大小并点击 n 次试验。
|
|
5.
|
点击确定。
|
|
6.
|
点击“控制图生成器”旁边的红色小三角并选择显示控制面板。
|
|
7.
|
打开警告 > 检验并点击检验 1。
|
图 1.3 JMP 中的控制图

|
8.
|
点击完成。
|
P 图显示每个批次的缺陷垫圈的比例。您可以看到有两个点位于控制图限值之外。
发布控制图
|
1.
|
在 JMP 中,当控制图报表处于打开状态时,选择文件 > 发布 > 将报表发布至 JMP Live。
|
|
2.
|
按照向导中的步骤发布该报表,然后在 JMP Live 中打开该报表。
|
图 1.4 JMP Live 中的控制图帖子

图形中的控制图警告已用红色圆圈标出,“警告”图标显示在左侧,用红色感叹号指示。
点击控制图中的警告以打开“警告”面板。您可以执行以下任意操作:
|
•
|
查看警告信息。点击行链接,打开数据表并突出显示受影响行。
|
|
•
|
查看哪些测试失败。
|
|
•
|
对警告进行分类处理、添加备注并查看处理历史。
|
共享控制图
在 JMP Live 控制图帖子中,点击
> 复制链接。您可以将该链接粘贴到文本或电子邮件中。
分配待处理警告
|
1.
|
在 JMP Live 中打开一个控制图帖子。
|
|
2.
|
点击该控制图中的某个警告。
|
“警告”面板随之打开,并显示该警告的详细信息。请参见图 1.5。
提示:要将多个警告分配给单个人或组,可在控制图中框选这些警告,然后右击并选择处理。
|
3.
|
点击“受理人”旁边的
将警告分配给有权访问该帖子的个人或组。或者,点击分配给我。 |
|
4.
|
(可选)为该受理人输入任何关于该警告的注释。
|
|
‒
|
您可在注释中 @提及某人,对方会收到相应通知。
|
|
‒
|
您可以使用 markdown 语法进行格式设置,例如用 * 文本表示项目符号、用 1. 文本表示编号列表、用 *italics* 表示斜体、用 **bold** 表示粗体。
|
|
5.
|
点击保存。
|
图 1.5 在 JMP Live 中分配警告

受理人通过电子邮件收到 JMP Live 中的通知。有关通知的详细信息,请参见 管理警告通知。
处理警告
|
1.
|
在 JMP Live 中打开控制图帖子。
|
|
2.
|
点击该控制图中的某个警告。
|
“警告”面板随之打开,并显示该警告的详细信息。
提示:要一次处理多个警告,可在控制图中框选这些警告,然后右击并选择处理。使用该方法,所有选定的警告在处理之后会具有相同的状态。
|
3.
|
将状态改为正在调查或已解决。
|
|
4.
|
(可选)输入关于该调查或解决方案的任何相关的注释。
|
|
5.
|
点击保存。
|
图 1.6 在 JMP Live 中处理警告

检查已处理的警告
|
1.
|
在 JMP Live 中打开控制图帖子。
|
|
2.
|
点击警告。
|
|
3.
|
点击
查看某个警告的详细信息。 |
|
4.
|
确认该警告“已解决”并检查可能有的注释。
|
图 1.7 在 JMP Live 中确认警告已解决

|
5.
|
(可选)点击打开历史记录查看或下载该警告的处理历史记录。
|
获取处理信息
在控制图中,您可以:
|
•
|
悬停在某个警告上方以查看详细信息
|
|
•
|
点击某个警告,在“警告”面板中打开其详细信息
|
处理状态
待解决(红色圆圈)
该警告尚未解决,需要关注。
正在调查(黄色菱形)
该警告正在调查之中。
已解决(绿色方形)
该警告已解决。
图 1.8 控制图中的处理状态

提示:要显示处理图例,请在帖子中点击
> 高级 > 显示处理状态图例。
控制图图标
星形 (*)
该标记指示超出限值(检验超出限值)。
1-8
该标记指示未通过 Shewhart 检验 1-8。
1:2S
该标记指示未能满足 Westgard 规则,Westgard 规则采用缩写形式表示特定规则的违背情况。本例指示违背的是第一条规则,即有一个点超出了 2 倍 sigma 的范围。
管理警告通知
若您启用控制图警告通知功能,则会收到一封电子邮件,内容为您已订阅的帖子的相关警告。当某一帖子中的所有警告均完成处理(即移出“未解决”状态)后,系统将不再发送后续通知。
订阅警告
|
1.
|
在包含控制图的空间、文件夹或帖子中,点击
|
|
2.
|
点击以订阅空间或文件夹中的所有帖子或是单个帖子中的控制图警告。
|
启用或禁用警告通知
|
1.
|
在 JMP Live 中,点击“通知”
|
控制图有两个通知设置:
|
‒
|
已分配控制图警告
|
|
‒
|
控制图警告(针对您已订阅的帖子)
|
|
2.
|
启用或禁用这些通知。
|
|
3.
|
对于已启用的通知,选择您希望通过电子邮件收到通知的频率。
|
有关更多详细信息,请参见 JMP Live 帮助中的“图形中的控制图警告”和“管理通知”。
警告失效和重置
将控制图发布至 JMP Live 后,若发生以下任一更改:
|
•
|
控制限有变化
|
|
•
|
执行的控制图检验有变化
|
|
•
|
原始数据值有变化或被删除(追加新数据不会导致警告失效或重置)
|
您的控制图警告可能会发生变化或从控制图中消失,即变为失效。
|
•
|
某个警告被重置后,处理状态将恢复为“未解决”,而且受理人和注释将被移除。不过,您可以在警告历史记录中查看之前的处理决策。请参考JMP Live 中的过程筛选。
|
注意:若您在某个帖子中过滤数据、排除或隐藏数据点,这些操作均可能会影响警告,并导致该帖子不同步。(这些更改仅会出现在您的数据视图中,其他用户不会看到这些更改。)在此情况下,将禁止您使用处理功能,同时会显示警告消息。若您刷新该页面或选择警告消息上的“重置”按钮,该帖子便会恢复为其最初的发布状态,您可以继续处理操作。
搜索警告
搜索所有警告
|
1.
|
打开主页。
|
|
2.
|
点击概述。
|
在“控制图警告”下方,您可以查看最近有更新的包含警告的帖子(在您有权访问的空间和文件夹内)。
|
3.
|
(可选)点击全部查看可查看包含警告的所有帖子。
|
搜索分配给您的警告
|
1.
|
打开主页。
|
|
2.
|
点击警告列表。
|
|
3.
|
(可选)更改状态或受理人过滤器。
|
提示:要查看未分配的警告,请将受理人改为未分配。
在空间内搜索警告
|
1.
|
打开一个空间。
|
|
2.
|
点击警告。
|
在文件夹内搜索警告
|
1.
|
打开一个文件夹。
|
|
2.
|
点击右上角的
|
|
3.
|
选择过滤要依据的控制图状态。还可以点击分配给我的警告。
|
在帖子内搜索警告
|
1.
|
打开包含警告的帖子。
|
|
2.
|
点击警告。
|
|
3.
|
点击
|
|
4.
|
选择作为过滤依据的选项。
|
查看警告历史记录
要查看某个帖子中警告的历史记录,需打开该警告并点击打开历史记录。
要查看某个空间中的警告的历史记录,需打开该空间并点击“历史记录”。您可以根据警告的创建或更新操作进行过滤。
JMP Live 管理员可以通过管理员 > 日志访问警告的更多历史详细信息。
下载警告
对于您拥有下载权限的数据,可将警告当前状态或历史记录下载为 .csv 文件。
下载帖子的所有警告
|
1.
|
打开包含警告的帖子。
|
|
2.
|
点击警告。
|
|
3.
|
点击
|
|
4.
|
选择是下载帖子的所有警告的当前状态还是历史记录。
|
|
5.
|
(可选)更改要下载哪些警告的过滤条件。
|
|
6.
|
点击下载。
|
下载单个警告的警告历史记录
|
1.
|
打开包含警告的帖子。
|
|
2.
|
点击警告。
|
|
3.
|
点击
查看某个警告的详细信息。 |
|
4.
|
点击打开历史记录查看或下载该警告的处理历史记录。
|
JMP Live 中的过程筛选
自 JMP Live 19 起,您可以发布交互式过程筛选报表,便于同时监控多个过程并以交互方式选择特定过程,以便开展进一步的分析或调查。
交互式过程筛选的示例
在本例中,您想确定包含过程测量值的数据表中有哪些过程不稳定。每列都包含“规格限”列属性。若过程稳定,则适合计算过程能力。
|
1.
|
选择帮助 > 样本数据文件夹,然后打开 Semiconductor Capability.jmp。
|
|
2.
|
选择列 > 列管理器。
|
|
3.
|
在过滤器框中点击并输入 IVP。
|
|
4.
|
选择过程 旁边的灰色小三角以便查看结果。选择所有 IVP 过程,然后关闭该报表。
|
|
5.
|
在数据表中,选择分析 > 质量和过程 > 过程筛选。
|
|
6.
|
点击过程变量。这会将您选定的 10 列指定为过程变量。
|
请注意,“控制图类型”设置为“单值和 MR”(单值和移动极差图)。
|
7.
|
点击确定。
|
图 1.9 JMP 中的过程筛选汇总报表

该报表包含每个过程的结果表。这些结果按稳定性指标排序,该指标用于测量过程的稳定性。稳定过程的稳定性指标接近 1。数值越高,表明过程的稳定性越差。(排序方式由“稳定性指标”旁边的补注符号指示。)
|
8.
|
如需进一步查看稳定性更差的过程,可点击 IVP8、IVP7 及 IVP9。右击突出显示的行并选择为选定的项显示图表。
|
|
9.
|
点击“过程筛选”红色小三角并选择以下选项:
|
|
‒
|
警报图形
|
|
‒
|
目标图
|
注意:当您将报表发布至 JMP Live 时,附加图表会显示在多个选项卡中。
|
10.
|
选择文件 > 发布 > 将报表发布至 JMP Live。
|
注意:必须设置 JMP Live 服务器连接,并且您可能需要登录 JMP Live。请参见 JMP 帮助中的“添加与 JMP Live 服务器的连接”。
|
11.
|
按照向导中的步骤发布该报表,然后在 JMP Live 中打开该报表。
|
图 1.10 JMP Live 中的过程汇总帖子

请注意关于该帖子的以下事项:
|
•
|
附加图表(在本例中为“目标图”、“警报图形”和“为选定项显示的图表”)显示在多个选项卡中。“为选定项显示的图表”选项卡包含的图表对应于您在发布至 JMP Live 之前于 JMP 中选定的行。
|
|
•
|
点击表中的列或图形中的点,右侧会显示其对应的单值控制图。
|
环境检测的示例
在本例中,某制药厂商对其各生产场地开展可能的环境污染物监测工作。数台监测设备每日多次上报污染物相关数据。可利用“过程筛选”平台以有意义的方式对这些数据进行处理,并在 JMP Live 中共享该报表。
|
1.
|
在 JMP 中,选择帮助 > 样本数据文件夹,然后打开 Quality Control/Environmental Monitor Sim.jmp。
|
|
2.
|
选择分析 > 质量和过程 > 过程筛选。
|
|
3.
|
选择计数并点击过程变量。
|
|
4.
|
选择类型、等级和位置,然后点击分组。
|
|
5.
|
选择时间并点击时间。
|
|
6.
|
将“控制图类型”设置为计数。
|
图 1.11 JMP 中的“过程筛选”启动窗口

|
7.
|
点击确定。
|
|
8.
|
在“汇总”表中,选择类型为 Viable 的第四行。
|
|
9.
|
点击“过程筛选”红色小三角并选择以下选项:
|
|
‒
|
为选定的项显示图表
|
|
‒
|
警报图形
|
|
10.
|
点击“为选定项显示的图表”红色小三角并选择以下选项:
|
|
‒
|
显示标记
|
|
‒
|
显示区域
|
|
‒
|
圈出报警点
|
图 1.12 JMP 中的“过程筛选”报表

“汇总”表(部分显示)按“操作”计数对各过程进行排序。
提示:要调整“汇总”表的大小,可在该表底部点击并拖动鼠标。
针对您选定的过程:
|
•
|
2024 年 1 月下旬曾有一次操作报警。操作限值(操作分位数上限)设置为 16,该值对应拟合分布的 99.85% 分位数。
|
|
•
|
警报图形按日期显示有 6 个过程报警,其中 2 个过程的报警时间与您所选过程的报警时间接近。该结果可能指示各监测场地间存在交叉污染的可能性。
|
|
11.
|
选择文件 > 发布 > 将报表发布至 JMP Live。
|
注意:必须设置 JMP Live 服务器连接,并且您可能需要登录 JMP Live。请参见 JMP 帮助中的“添加与 JMP Live 服务器的连接”。
|
12.
|
按照向导中的步骤发布该报表,然后在 JMP Live 中打开该报表。
|
|
13.
|
在“汇总”表中,选择类型为 Viable 的第四行。
|
图 1.13 JMP Live 中的过程汇总帖子

请注意关于该帖子的以下事项:
|
•
|
附加图表(在本例中为“警报图形”和“为选定项显示的图表”)显示在多个选项卡中。“为选定项显示的图表”选项卡包含的图表对应于您在发布至 JMP Live 之前于 JMP 中选定的行。
|
|
•
|
点击表中的列或图形中的点,右侧会显示其对应的单值控制图。
|
将警告分配给有权访问该帖子的个人或组。或者,点击
查看某个警告的详细信息。