Using JMP > Import Your Data > Import Text Files > Open a Text File in a Text Editing Window
Publication date: 08/13/2020

Open a Text File in a Text Editing Window

You can open a text file in a Script window, where you edit the text. Then you can import the text as a data table. This feature is helpful when you want to reformat the text before importing it as a data table. For example, you might need to insert the correct delimiters or modify the text.

Another option is opening a JMP add-in definition (.def) file as text and then editing it in a Script window.

To open a text file in a text editing window (Windows)

Files that you recently opened are listed in the JMP Home window. For most files, right-click the text file and select Open as Plain Text to open the file in a text editing window. JMP add-in definition files cannot be opened as plain text from the JMP Home window.

When you are opening the file for the first time, follow these steps:

1. Select File > Open.

2. Select Text Files from the list next to File name.

Figure 3.16 Select Text FilesĀ 

3. (Optional) To set the default option file type to Text Files, select the check box beside Select this filter the next time this window is invoked.

4. Select the file.

5. Select Plain text into Script window next to Open as.

6. Click Open.

The text appears in a Script window.

To open a text file in a text editing window (macOS)

1. Select File > Open.

Figure 3.17 Opening a Text Document on macOSĀ 

2. Select the file.

3. Click Options.

4. Select Text from the Open As list.

5. Click Open.

The text appears in a Script window.

For more information about converting the text to a data table, follow step 3 in Import Text from the Script Editor.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).
.