Using JMP > Import Your Data > Import Text Files > Import Text from the Script Editor
Publication date: 08/13/2020

Import Text from the Script Editor

You can import text from the Script Editor as a data table. The text can be in a table format (for example, from a Microsoft Word document or Web page) or in plain text format. This feature is helpful when you want to reformat the text before importing it as a data table. For example, you might need to insert the correct delimiters or modify the text.

JMP uses the import settings in the preferences to determine how to structure and format the text. Some options include removing quotation marks around text and specifying the rows that contain column headings and data. See Text Data Files in the JMP Preferences section.

Note: You can also import an entire web page as a data table. See Import SPSS Files.

This section describes how to import text that you paste into the Script Editor. For more information about opening a text file in the Script Editor, see Open a Text File in a Text Editing Window.

To import text from the Script window

1. Open a new Script window in JMP by selecting File > New > Script (Windows) or File > New > New Script (macOS).

2. Copy and paste the text into the Script Editor.

3. Do one of the following:

To import all text from the Script Editor, select Edit > Import as Data.

To import specific text, select the text, and then select Edit > Import as Data.

The text is imported into a JMP data table.

Note: To preview text that you import from the Script Editor, hold down the Shift key before you select File > Import as Data.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).
.