Using JMP > Import Your Data > Import Text Files
Publication date: 08/13/2020

Import Text Files

You can open text files with the extensions .txt, .csv, and .tsv, and the text is converted to a data table. Files with the .dat extension that consist of text are also supported. Text files can be delimited using almost any character, or they can be fixed-width files.

Trailing whitespace is removed when you import text files into JMP.

When JMP finds an integer in the text file that is greater than 9,007,199,254,740,991, the column is considered character data. You can set the column to numeric using the Text Import Wizard window or an import script.

Tip: You can import more than one text file at a time using the Multiple File Import option. See Import Multiple Files.

To adjust import settings, choose from one of the following options

Select File > Preferences > Text Data Files to change the import settings so that JMP determines the best way to structure and format the data table.

Manually select the import settings as you open the file (described in this section).

Open the file in the Script Editor, edit the content, and then import the content. This option is helpful when you need to add text delimiters or modify the text.

To import a text file

1. Select File > Open.

2. On Windows, you can set the file type to Text Files.

3. Select the text file that you want to open.

For information about the options, see Table 3.1 and Table 3.2.

Table 3.1 Opening Text Files on Windows

Automatically Determining Data Arrangement

Manually Specifying Data Arrangement

1. Select File > Open.

2. From the list next to File name, select Text Files.

3. To use the import rules from the preferences, select Data, using Text Import preferences. (See Text Data Files in the JMP Preferences section.)

To have text import use its best guess to arrange the data, select the Data, using best guess option.

(Optional) Select the Select this filter the next time this window is invoked option to apply the filter that you chose by default.

4. Select the file that you want to open.

5. Click Open.

Tip: The JMP Home window provides a shortcut to the above steps if you recently opened the file. Right-click the file in the Recent Files list and select Import (Preferences) or Import (Best Guess). (Your import preference is bolded in the right-click menu.)

1. Select File > Open.

2. From the list next to File name, select Text Files.

3. Select Data with Preview next to Open as at the bottom of the window.

4. Select the file that you want to open.

5. Click Open.

6. Complete the Text Import window. See Text Import Wizard Options.

7. Click Import.

Tip: The JMP Home window provides a shortcut to the above steps if you recently opened the file. Right-click the file in the Recent Files list and select Import (Preview).

Table 3.2 Opening Text Files on macOS

Automatically Determining Data Arrangement

Manually Specifying Data Arrangement

1. Select File > Open.

2. Select the file that you want to open.

3. In the Open As field, select Data (Best Guess) or Data (Using Preferences).

4. Click Open.

1. Select File > Open.

2. Select the file that you want to open. In the Open As field, select Data (Using Preview).

3. Click Open.

4. Complete the Text Import Wizard window. See Text Import Wizard Options.

5. Click Import.

Notes:

On Windows, JMP can open text files in your computer’s default text editor. Select File > Open, and then select All Files (*.*) from the File name list. Select the text file, and then select Use default program to open. Uncheck to open as text.

If you cancel the import while JMP is scanning the data, data is imported based on what JMP detected. The data might not appear as you expect. For example, you might see missing values in a column that was incorrectly detected as numeric. If you cancel the import after the data is scanned, only the data read up to that point is imported.

For more information about importing text from a Script window, see Import Text from the Script Editor.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).
.