Using JMP > Get Started > Data Tables > Open Data File Options
Publication date: 08/13/2020

Open Data File Options

Note: For more information about opening files, see Import Your Data.

To open a data file, select File > Open and select the file type. Some file types have additional features and options that appear in the Open Data File window (Table 2.1).

Tips:

Windows only: To open the same file type every time, select the Select this filter the next time this window is invoked check box.

Open a file by dragging it onto the JMP Home Window.

To change which directory the File > Open command looks in, see File Locations in the JMP Preferences section.

Table 2.1 File > Open Options by File Type

File Type

Additional Features and Options

JMP Data Tables

Table notes, the number of columns (Cols), and the number of rows appear.

Use the Select Columns option to select which columns are imported into the data table. On Windows, click the arrow next to Open and then use the Select Columns option to specify which columns are imported into the data table. On macOS, you can select which columns to import after you click Open.

Excel Files

Import the file in the Excel Import Wizard by default to customize the layout and preview the data before you import it.

Click the arrow next to Open and then select one of the options. Convert the first spreadsheet row into column headings.

Text Files

To automatically determine data arrangement, select one of the following options:

Data (Using Preferences)

Data (Best Guess)

Text in the Script Editor

To manually specify data arrangement, select the Data (Using Preview) option. See Text Import Wizard Options in the Import Your Data section.

SAS Data Sets

Use SAS variables for column names

(Windows only) Enter a password when you open a password-protected data set.

(SAS Transport files only) Select columns before opening

SPSS Data Files

Use SPSS variable or label names for column names.

XML Data Files

See Text Files for more information about the options.

JSON Data Files

See Text Files for more information about the options.

All Files

To automatically determine data arrangement, select one of the following options:

Open as data using preferences

Open as data using a best guess

Open as plain text into a script window

To manually specify data arrangement, select the Data (Using Preview) option.

(Windows only) To open text files using your computer’s default text editor, select Use default program to open.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).
.