Using JMP > Personalize JMP > Personalize Toolbars and Menus on Windows > Rearrange Custom Menus, Menu Items, and Buttons
Publication date: 08/13/2020

Rearrange Custom Menus, Menu Items, and Buttons

On Windows, you can rearrange the order of menus, menu items, and buttons that you create. For example, under the File > New menu, you could move your custom menu before the Data Table command.

In the item’s General properties, the Source determines whether you can move the item. You can move items if the Source is Custom Item. Built-in items cannot be moved. Items that are defined in other customization sets can be moved only in that customization set. See Change Customization Sets.

Note: The right-click menu has options for cutting and pasting items. To cut an item, you can also hold down the Ctrl key and press X, or hold down the Shift key and press Delete. To paste, hold down the Ctrl key and press V, or hold down the Shift key and press Insert.

To rearrange custom menus and menu items

1. Select View > Customize > Menus and Toolbars.

The Main Menu list appears on the left.

2. Do the following:

Select the item that you want to move.

Verify that the Source is Custom Item.

If the Source is All Users or JMP Add-In, select the specified customization set and verify that the Source is Custom Item.

3. Right-click the custom menu or menu item that you want to move and select Cut.

4. Right-click the new location of the cut item and select Paste.

One of the following occurs:

A list appears with the possible locations of the cut item. This occurs when you select a menu (such as File or New) or the first item in a menu (such as Data Table in the File > New menu).

The cut menu item appears below the selected menu item. Skip to step 6.

5. Select the location of the cut item by doing one of the following:

To paste the cut item before the selected item, select Paste before.

To paste the cut item after the selected item, select Paste after.

To paste the cut item inside the selected menu, select Paste into. (Available only when you select a menu as the new location.)

To cancel the move, select Cancel.

The item appears as you indicated.

6. Click Save to save your changes.

To rearrange custom buttons

1. Select View > Customize > Menus and Toolbars.

The Toolbars list appears on the left.

2. Do the following:

Select the custom button that you want to move.

Verify that the Source is Custom Item.

If the Source is All Users or JMP Add-In, select the specified customization set and verify that the Source is Custom Item.

3. Right-click the custom button that you want to move and select Cut.

4. Right-click the new location of the cut button.

One of the following occurs:

A list appears with the possible locations of the cut button. This occurs when you select the first button on the toolbar (such as New Data Table in the File_Edit toolbar).

The button is pasted at the end of the toolbar. This occurs when you select the name of the toolbar. For example, when you select File_Edit and paste, the button appears after the last button, Run Script. Skip to step 6.

The cut button appears after the selected button. Skip to step 6.

5. Select the location of the cut button by doing one of the following:

To paste the cut button before the selected button, select Paste before.

To paste the cut button after the selected button, select Paste after.

6. Click Save to save your changes.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).
.