Publication date: 08/13/2020

Retrieve Generated SAS Data Sets

SAS code that you submit might generate SAS data sets. You can have them automatically imported into JMP for further analysis.

1. Select File > Preferences (Windows) or JMP > Preferences (macOS).

2. Open the SAS Integration category.

3. Select the Import generated SAS data sets into JMP option.

Export JMP Data Tables to SAS

You can export JMP data tables to a SAS Workspace Server.

1. Connect to the SAS Workspace Server.

2. Open the file that you want to export.

3. Select File > SAS > Export Data to SAS.

If necessary, you are connected automatically using your profile’s user name and password.

4. Select the data table that you want to export to SAS from the list of open data tables under Select Data to Export.

Figure 3.64 Export Data to SAS 

5. (Optional) To export only some of the columns in the data table, click Select Columns. See To select columns to export.

6. Select the Destination Server.

7. Select the Library.

Tip: If your libraries do not appear, see Show Libraries in the Export Data to SAS Window.

A list of the data sets in the library appears.

8. Enter the name as you want it to appear in the SAS library.

9. (Optional) Set the export options that you want to use. See Export Options.

10. Click Export.

To select columns to export

1. To export only some of the columns in the data table, click Select Columns.

2. In the window that appears, select the columns to export and click Add.

3. When all the columns have been added to the Selected Columns list, click OK.

Export Options

The available export options are as follows:

Ignore ‘excluded’ row state (export all rows)

Select this option to export all rows in the data table. Deselect this option to export only those rows that are not excluded. This option is on by default.

Preserve SAS variable names

This option is useful for data tables that were imported originally from SAS. When importing a SAS data set, the original SAS variable name is saved in a column property for each column. Select this option to use the SAS variable name for each column when exporting to SAS. Deselect this option to export the JMP variable names. This option is off by default.

Preserve SAS formats

This option is useful for data tables that were imported originally from SAS. When importing a SAS data set, the original SAS format and informat is saved in a column property for each column. Select this option to use the SAS format and informat for each column when exporting to SAS. Deselect this option to export the JMP formats instead. This option is on by default.

Show Libraries in the Export Data to SAS Window

If your libraries do not appear in the Export Data to SAS window, define the library in one of the following ways:

Using JSL, submit code to the SAS server. The code defines a library using a libname command.

Define an autoexec.sas file that runs a snippet of SAS code every time SAS is invoked. This creates the same librefs every time you connect to SAS. For more information about autoexec.sas files, see the SAS documentation.

Libraries that are defined in metadata (such as libraries defined in the SAS Management Console under the Data Library Manager) cannot be accessed from the Export Data to SAS window.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).
.