Using JMP > JMP Reports > The Data Filter > Animation in Data Filters
Publication date: 05/24/2021

Animation in Data Filters

The animation feature sequentially highlights the values of a single variable. The variable’s values are highlighted in the data table. However, patterns are more interesting if you first create a plot and then animate a variable using the Data Filter to see how it behaves on the plot.

To use the animation feature, click the Data Filter red triangle and select Animation. Then select the variable that you want to animate. The highlighted frame around the variable indicates which variable is selected for animation.

Figure 9.13 Animation Control Panel in the Data Filter and Local Data Filter 

Animation Control Panel in the Data Filter and Local Data Filter Animation Control Panel in the Data Filter and Local Data Filter

The Animation Control panel contains the following controls:

The middle button (Image shown here) starts and pauses the animation. After you start the animation cycles, the button changes to a pause button (Image shown here). By default the animation begins with the first value of the topmost variable.

The backward arrow (Image shown here) moves the animation backward one cycle. Click more than once to go backward more than one cycle.

The forward arrow (Image shown here) moves the animation forward one cycle. Click more than once to go forward more than one cycle.

The square button (Image shown here) hides the Animation Control section on the Data Filter window. Select Animation from the menu on the Data Filter title bar again to see the Animation Control.

The looping button (Image shown here) enables looping and is on by default. If you turn the looping button off, the animation will cycle through the sequence of values one time and then stop.

The record button (Image shown here) starts recording the animation. After you start the recording, the button changes to a stop recording button (Image shown here).

The save button (Image shown here) saves the recorded animation.

Use the slider to adjust the speed of the animation (slower to faster).

The Animate drop-down menu contains the following options:

Forward

Highlights values from first to last.

Backward

Highlights values from last to first.

Bounce

Highlights forward and then backward repeatedly.

Save Where Clause in Data Filters

Once you have filtered variable values in the Data Filter, that information can be expressed as a JMP Where clause. The Where clause is used in JSL (JMP Scripting Language) programs to identify specific rows of data for processing or analysis. The Data Filter builds a Where clause based on the value selections that you make.

The options in the Save Where Clause menu include the following:

To Clipboard

Creates a Where clause from the filter criteria and puts it on the clipboard.

To Row State Column

Creates a row state column in the data table that has a formula equivalent to the filter criteria.

To Formula Column

Creates a formula column in the data table that has a formula equivalent to the filter criteria.

To Data Table

Creates a Where clause from the filter criteria and saves it as a JSL command with the current data table in a table property called Filter.

To Script Window

Creates a Where clause from the filter criteria and appends it to the current script text window, or creates a new script if one does not exist already.

To Journal

Creates the Where clause from the filter criteria and appends it to the current journal, or creates a new journal if one does not already exist.

Example of Saving a Where Clause

1. Select Help > Sample Data Library and open Big Class.jmp.

2. Select Rows > Data Filter.

3. Select age, sex, and height and click Add.

Select all females who are twelve and fourteen years old and whose height is between 56 and 60 inches:

4. Click the 12 and 14 blocks and the F block.

5. Click 51 and type 56.

6. Click 70 and type 60.

7. Click the Data Filter red triangle and select Save Where Clause > To Script Window.

The Where clause that is created from this example appears in a script window:

Select Where(
(:age == 12 | :age == 14) & :sex == "F" & (:height >= 56 & :height <= 60)
);
Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).