Using JMP > Save and Share Your Data > Create Journals > Example of Making a Journal for a Presentation
Publication date: 05/24/2021

Example of Making a Journal for a Presentation

Most people use a presentation application like PowerPoint to give presentations. With JMP journals, you can avoid using a presentation application: all your bullet points can be combined with live links and buttons to help automate the analyses that you want to show. Interactivity is also maintained in reports.

Follow this example to create a presentation using a journal.

1. Select File > New > Journal.

2. Right-click in the journal. Start your outline by selecting Add Outline Item.

3. Enter the title of the presentation “My Bivariate Demo.”

Figure 10.24 Add an Outline Item 

Add an Outline Item

A presentation should have outline nodes. The nodes are nested, opened, and closed in sequence, as you give the presentation.

4. To add bullet points into the outline, click the red triangle in the My Bivariate Demo title bar and select Add Text Item.

5. Enter the text shown in Figure 10.25.

Figure 10.25 Add Text Item 

Add Text Item

6. Select the Bullet Point check box and click OK.

Tip: A horizontal flashing line appears at the top of the journal. Use the arrow keys to move the line to where you want to insert an object.

Now add a window reference as a link. These links lets you open a file with one click during the presentation.

7. Select Help > Sample Data Library and open Big Class.jmp.

8. Click the red triangle in the My Bivariate Demo title bar and select Add Window Reference.

9. Select Big Class and click OK.

Figure 10.26 Add a Window Reference 

Add a Window Reference

10. Click the window reference to verify the link.

11. Display the window reference as a button by right-clicking the link and selecting Style > Normal.

Figure 10.27 Change the Link to a Button 

Change the Link to a Button

12. Select Edit > Lock Journal to see the final journal.

When you lock the journal, the journal toolbar and insertion cursor no longer appear. And when you select Save Script > To Journal from a platform, the journal is not appended to the open locked journal.

Figure 10.28 Final Journal 

Final Journal

Tip: You can also add objects to the journal by dragging them from the journal toolbar or putting your cursor where you want the object and double-clicking the object in the journal toolbar. The toolbar is available when you place your cursor over it.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).