Using JMP > Import Your Data > Import Text Files > Import Text from the Script Editor
Publication date: 05/24/2021

Import Text from the Script Editor

You can import text from the Script Editor as a data table. The text can be in a table format (for example, from a Microsoft Word document or Web page) or in plain text format. This feature is helpful when you want to reformat the text before importing it as a data table. For example, you might need to insert the correct delimiters or modify the text.

JMP uses the import settings in the preferences to determine how to structure and format the text. Some options include removing quotation marks around text and specifying the rows that contain column headings and data. See Preferences for Importing and Exporting Text Files.

Note: You can also import an entire web page as a data table. See Import Data from the Internet or a Remote Computer.

This section describes how to import text that you paste into the Script Editor. For more information about opening a text file in the Script Editor, see Edit Text Before Importing into JMP.

To import text from the Script window

1. Open a new Script window by selecting File > New > Script (Windows) or File > New > New Script (macOS).

2. Copy and paste the text into the Script Editor.

3. Do one of the following:

To import all text from the Script Editor, select Edit > Import as Data.

To import specific text, select the text, and then select Edit > Import as Data.

The text is imported into a JMP data table.

Note: To preview text that you import from the Script Editor, press Shift before you select File > Import as Data.

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).