Using JMP > Import Your Data
Publication date: 05/24/2021

Import Your Data

Create Data Tables

This chapter covers the following topics:

How to import data, such as text files, PDF files, SPSS files, and SAS data

How to transfer Excel data

How to read in real-time data

How to create a new data table

Figure 3.1 Importing a Text File 

Importing a Text File

Contents

About Importing Data

Import Microsoft Excel Files

Preview and Import Microsoft Excel Data
Import a Microsoft Excel File Directly

Import Text Files

Find Missing Characters in Imported Data
Options in the JMP Text Import Wizard
Edit Text Before Importing into JMP
Import Text from the Script Editor

Import Multiple Files

Import PDF Files

Concatenate Tables into One Data Table
Concatenate Tables by Column Headers
Import Tables that JMP Does Not Auto-Detect
PDF Preview Red Triangle Options
Data Table Preview Options
PDF Preview Right-Click Options

Import XML and JSON Files

Preview and Import XML and JSON Data
Import XML Files Directly
Import JSON Files Directly

Build SQL Queries in Query Builder

Connect to a SQL Database
Select Tables from a SQL Database
Build an SQL Query
Save and Run a JMP Query
Open the Selected Data
Query Builder Red Triangle Options
Write SQL Statements in Query Builder

Import Data from SAS

Java Runtime Environment (JRE) Requirements
SAS Menu Options
Import SAS Data Sets
Create SAS Transport Files in SAS from JMP
Connect to SAS from JMP
Open SAS Data Sets with SAS Query Builder
Open SAS Data Sets through a SAS Server
Using SAS Extended Attributes to Import Metadata
Run Stored Processes
Submit SAS Code
Generate ODS Results
Import Generated SAS Data Sets

Import Data from a Database

Connect to a Database
Open Data from a Database
Write SQL Statements to Query a Database
Structured Query Language (SQL): A Reference

Import Data from Google Sheets

About Importing Google Sheets
Google Sheet Settings

Import SPSS Files

Import Triple-S Survey Data

Import HDF5 Data

Import Data from MATLAB

Import Data from R

Import Data Using the Excel Add-In

Transfer Excel Data to a Data Table
About the JMP Add-In for Excel
Uninstall the JMP Excel Add-In

Import Data from the Internet or a Remote Computer

Create New Data Tables

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).