JMP에서 Graphlet을 사용하여 그래프나 이미지의 썸네일을 가리키기 라벨에 추가할 수 있습니다.
• 사전 설정 Graphlet: 사전 설정 Graphlet은 사전 정의되어 있으며 편집 가능합니다. 그래프를 마우스 오른쪽 버튼으로 클릭하고 가리키기 라벨 > 그래프 유형을 선택하면 손쉽게 추가할 수 있습니다. 또는 가리키기 라벨 편집기에서 추가할 수도 있습니다.
참고: 데이터 테이블에 연결되지 않은 합성 데이터(예: 시뮬레이션에 사용된 데이터)를 기반으로 하는 그래프는 사전 설정 그래프를 지원하지 않습니다.
• Graphlet 붙여넣기: 그래프 빌더에서 그래프를 생성합니다. 스크립트를 클립보드에 저장하는 방법으로 복사한 후 기준 그래프에 Graphlet으로 붙여 넣습니다.
가리키기 그래프를 추가한 후에는 기준 그래프의 요소 위에 커서를 놓습니다. 그러면 해당 요소에 대한 가리키기 그래프의 썸네일 미리보기가 표시됩니다. 예를 들어 집계 데이터의 경우 기본 데이터 분포의 가리키기 그래프를 볼 수 있습니다.
일부 JMP 플랫폼에는 주성분, 공정 변수 선별, 모형 기반 다변량 관리도, 함수 데이터 탐색기와 같은 기본 제공 가리키기 라벨 그래프가 있습니다. 별도의 작업 없이도 이러한 그래프를 시각화 요소에 추가할 수 있습니다. 시각화 요소를 마우스로 가리키면 가리키기 라벨에 자동으로 그래프가 나타납니다.
JSL을 사용하여 가리키기 라벨 그래프를 사용자 정의할 수도 있습니다. 자세한 내용은 Scripting Guide의 "Hover Labels"에서 확인하십시오.
가리키기 그래프에서 다음 작업을 수행할 수 있습니다.
• 가리키기 그래프를 클릭하여 새 창에서 시작하거나, 이미지를 클릭하여 관련 링크를 엽니다.
• Ctrl 키를 누른 채 가리키기 라벨 그래프를 클릭하여 기준 그래프를 가리키기 라벨 그래프로 대체합니다.
• Alt 키를 누른 채 가리키기 라벨 그래프를 클릭하여 새 창을 열지 않고 마지막으로 실행한 창의 내용을 대체합니다.
이 예에서는 그래프를 생성하고, 가리키기 라벨에 사전 설정 그래프를 추가한 다음, 가리키기 라벨 그래프를 사용자 정의합니다.
1. 도움말 > 샘플 데이터 폴더를 선택하고 JMP Man Dozen.jmp를 엽니다.
2. 그래프 > 그래프 빌더를 선택합니다.
3. X 및 Y를 선택하고 Y 영역으로 드래그합니다.
4. Data Set를 선택하고 X 영역으로 드래그합니다.
5. 막대 요소 (
)를 클릭합니다.
6. "오차 구간"에서 표준편차를 선택합니다.
그림 9.55 JMP Man Dozen.jmp의 원래 그래프
이 그래프에서는 관측값의 평균 및 표준편차가 모두 동일하기 때문에 알 수 있는 것이 많지 않습니다. 사전 설정 그래프를 사용하면 데이터에 대한 더 많은 정보를 얻을 수 있습니다.
1. 그래프에서 마우스 오른쪽 버튼을 클릭하고 가리키기 라벨 > 히스토그램을 선택합니다.
그러면 가리키기 라벨에 사전 설정 히스토그램이 추가됩니다.
2. 일부 막대를 가리킵니다.
이 예에서는 dots 및 star의 빨간색 막대를 가리킵니다.
팁: 다른 가리키기 라벨과 비교할 수 있도록 가리키기 라벨을 고정하려면 가리키기 라벨 오른쪽 상단의 고정 아이콘(
)을 클릭합니다. 자세한 내용은 JMP 그래프의 가리키기 라벨 고정에서 확인하십시오.
그림 9.56 사전 설정 히스토그램의 예
측정값의 분포가 명확히 다르다는 것을 알 수 있습니다. 하지만 다른 유형의 그래프, 즉 산점도도 확인하려고 합니다.
3. 그래프에서 마우스 오른쪽 버튼을 클릭하고 가리키기 라벨 > 점을 선택합니다.
그러면 사전 설정 그래프가 히스토그램에서 산점도로 변경됩니다.
4. down_parab의 파란색 막대와 down_parab의 빨간색 막대를 마우스로 가리킵니다.
축의 Y 변수와 X 변수가 서로 바뀌어 있음에 유의하십시오.
모든 그래프에 동일한 X 및 Y 역할 할당을 사용하려고 합니다. 즉, X 축에 X 변수를 할당하고, Y 축에 Y 변수를 할당하려고 합니다. 또한 평활기를 적합선으로 변경하고, 산점도에 요약 통계량이 포함된 캡션 상자를 추가하려고 합니다.
그래프 빌더에서 그래프를 사용자 정의한 다음 이 그래프를 템플릿으로 복사하여 이 그래프의 모든 가리키기 라벨에 적용할 수 있습니다.
1. down_parab의 파란색 막대를 마우스로 가리키고 해당 그래프를 클릭하여 새 창에서 엽니다.
해당 그래프가 그래프 빌더에서 열립니다.
참고: 사전 설정 그래프를 실행하면 그래프 왼쪽에 로컬 데이터 필터가 표시됩니다. 로컬 데이터 필터를 사용하여 그래프를 확장하고 변경할 수 있습니다. 자세한 내용은 JMP 보고서의 로컬 데이터 필터에서 확인하십시오.
2. "그래프 빌더"의 빨간색 삼각형을 클릭하고 제어판 표시를 선택합니다.
3. 적합선 요소 (
)를 클릭합니다.
4. 캡션 상자 아이콘 (
)을 클릭합니다.
5. "캡션 상자"에서 "요약 통계량"을 5가지 숫자 요약으로 변경합니다.
6. 완료를 클릭합니다.
그림 9.57 down_parab에 대한 사용자 정의 그래프
7. "그래프 빌더"의 빨간색 삼각형 메뉴를 클릭하고 스크립트 저장 > 클립보드에를 선택합니다.
8. 이 그래프 빌더 창을 닫습니다.
9. 원래 그래프에서 마우스 오른쪽 버튼을 클릭하고 가리키기 라벨 > Graphlet 붙여넣기를 선택합니다.
그러면 이 사용자 정의 그래프가 모든 가리키기 라벨 그래프에 템플릿으로 적용됩니다. 일부 막대를 마우스로 가리켜서 변경 사항을 확인합니다.
팁: 원래 그래프와 가리키기 라벨에서 실행된 그래프를 더 잘 비교하려면 프로젝트를 사용합니다. 자세한 내용은 "데이터 저장 및 공유"에서 확인하십시오.
범주형 열을 사용하는 사전 설정 그래프에서는 필터링 기준으로 사용할 열을 지정할 수 있습니다.
1. 도움말 > 샘플 데이터 폴더를 선택하고 NYC 311 Records.jmp를 엽니다.
이 데이터는 뉴욕시의 자치구별 민원 자료를 보여 줍니다.
2. 그래프 > 그래프 빌더를 선택합니다.
3. borough를 선택하여 X 영역으로 드래그합니다.
4. 트리맵 요소 (
)를 클릭합니다.
뉴욕시의 각 자치구를 나타내는 트리맵이 표시됩니다.
5. 그래프를 마우스 오른쪽 버튼으로 클릭하고 가리키기 라벨 > 트리맵을 선택합니다.
6. "Brooklyn" 위에 커서를 올려 가리키기 라벨 그래프를 표시합니다.
그림 9.58 Brooklyn에 대한 초기 가리키기 라벨 그래프
가리키기 라벨 그래프는 각 자치구별 사건 수를 날짜별로 보여 줍니다. 대신 이 예에서는 각 자치구별 사건 수를 민원 유형별로 보려고 합니다.
1. NYC 311 Records.jmp 데이터 테이블에서 borough 열 머리글을 마우스 오른쪽 버튼으로 클릭하고 열 특성 > 계층 내 다음 수준을 선택합니다.
2. "계층 내 다음 수준"에서 complaint_type을 클릭합니다.
그림 9.59 complaint_type이 다음 계층 수준으로 선택됨
3. 확인을 클릭합니다.
4. 첫 번째 가리키기 라벨 그래프가 실행될 경우에 표시되는 계층의 두 번째 수준을 추가합니다.
a. NYC 311 Records.jmp 데이터 테이블에서 complaint_type 열을 마우스 오른쪽 버튼으로 클릭합니다.
b. 열 특성 > 계층 내 다음 수준을 선택합니다.
c. "계층 내 다음 수준"에서 descriptor를 클릭합니다.
d. 확인을 클릭합니다.
5. 그래프 빌더에서 다시 "Brooklyn" 위에 커서를 올려 업데이트된 가리키기 라벨 그래프를 표시합니다.
그림 9.60 Brooklyn에 대한 업데이트된 가리키기 라벨 그래프
이제 가리키기 라벨 그래프는 각 자치구별 사건 수를 민원 유형별로 보여 줍니다.
6. 가리키기 라벨 그래프를 클릭하여 시작합니다.
7. 커서를 "Noise-Residential" 위에 놓습니다.
그림 9.61 Residential Noise 민원에 대한 두 번째 수준 가리키기 라벨 그래프
두 번째 수준의 가리키기 라벨 그래프는 생활 소음(Residential Noise) 범주 내의 사건 수를 설명 항목(descriptor)별로 보여 줍니다.
일부 경우에는 제거하려는 열을 기준으로 가리키기 라벨 그래프를 필터링할 수 있습니다. 예를 들어 필터 열이 너무 세부적이어서 유용하지 않은 경우가 있을 수 있습니다. 가리키기 라벨 편집기를 사용하여 필터 열을 제거할 수 있습니다.
1. 도움말 > 샘플 데이터 폴더를 선택하고 PopAgeGroup.jmp를 엽니다.
이 데이터는 전 세계 지역 및 국가의 연령 비율을 보여 줍니다.
2. 그래프 > 그래프 빌더를 선택합니다.
3. Pop을 선택하여 Y 영역으로 드래그합니다.
4. Year를 선택하여 X 영역으로 드래그합니다.
5. Region을 선택하여 중첩 영역으로 드래그합니다.
6. 선 요소 (
)를 클릭합니다.
그림 9.62 연간 세계 지역별 평균 인구
이 그래프는 몇 년 동안 세계 각 지역의 평균 인구를 보여줍니다. 가리키기 라벨 그래프에서 지역 대신 국가별 영향을 보다 세부적으로 확인하려고 합니다.
7. 이 창을 열어 둡니다.
1. "그래프 빌더"의 빨간색 삼각형을 클릭하고 다시 실행 > 분석 다시 실행을 선택합니다.
원래 그래프의 복사본이 나타납니다.
2. 그래프 복사본에서 Country를 선택하여 중첩 영역으로 드래그합니다.
그러면 Region이 Country로 바뀝니다.
3. 완료를 클릭합니다.
그림 9.63 연간 국가별 평균 인구
4. "그래프 빌더"의 빨간색 삼각형을 클릭하고 스크립트 저장 > 클립보드에를 선택합니다.
5. 이 그래프를 닫습니다.
6. 원래 그래프에서 마우스 오른쪽 버튼을 클릭하고 가리키기 라벨 > Graphlet 붙여넣기를 선택합니다.
7. "Asia" 선을 커서로 가리키고 클릭하여 가리키기 라벨 그래프를 시작합니다.
그림 9.64 아시아 지역의 국가 및 연도별 인구를 보여 주는 가리키기 라벨 그래프
아직 연도별로 필터링하고 있기 때문에 이 보기는 너무 세분화되어 유용하지 않습니다. 그래프가 지역별로만 필터링되도록 연도 필터를 제거하려고 합니다.
8. "Asia" 지역에 대한 가리키기 라벨 그래프를 닫습니다.
1. 원래 그래프를 마우스 오른쪽 버튼으로 클릭하고 가리키기 라벨 > 가리키기 라벨 편집기를 선택합니다.
2. "Graphlet" 창에서 필터 탭을 클릭합니다.
3. 필터링에서 제외할 Year 열을 선택합니다.
그림 9.65 가리키기 라벨 편집기에서 필터 건너뛰기
4. 확인을 클릭합니다.
5. "Asia" 선을 커서로 가리키고 클릭하여 가리키기 라벨 그래프를 시작합니다.
그림 9.66 아시아 지역의 국가 및 연도별 인구를 보여 주는 가리키기 라벨 그래프
이제 가리키기 라벨 그래프가 연도별로 필터링되지 않고 지역별로만 필터링되어 훨씬 더 유용한 시각화 자료를 생성합니다.
라벨 열의 경우 가리키기 라벨은 첫 번째 라벨 이미지 열의 이미지와 라벨 텍스트 열의 값 최대 4개를 포함할 수 있습니다. 더 많은 라벨 이미지나 텍스트 관측값을 표시하려면 라벨 보기를 사용하십시오.
1. 도움말 > 샘플 데이터 폴더를 선택하고 Big Class Families.jmp를 엽니다.
2. 그래프 > 그래프 빌더를 선택합니다.
3. weight를 선택하여 Y 영역으로 드래그합니다.
4. height를 선택하여 X 영역으로 드래그합니다.
5. 막대 요소 (
)를 클릭합니다.
6. 65인치 높이를 나타내는 막대를 커서로 가리키고 고정 요소(
)를 클릭합니다.
그림 9.67 초기 이미지만 있는 가리키기 라벨
이 막대에 5개의 이름이 포함되어 있지만 첫 번째 이미지만 가리키기 라벨에 나타납니다. 가리키기 라벨에 더 많은 이미지를 표시하고 싶습니다.
7. 그래프를 마우스 오른쪽 버튼으로 클릭하고 가리키기 라벨 > 라벨 보기를 선택합니다.
그림 9.68 다중 이미지가 있는 가리키기 라벨
이제 최대 8개의 이미지가 가리키기 라벨에 나타납니다.
8. 추가 이미지를 보려면 가리키기 라벨에서 썸네일을 클릭합니다.
9. 라벨 보기에서 앞으로 화살표 (
)를 클릭하여 5번째 이미지를 표시합니다.