발행일: 09/10/2026

필터 보기

필터 보기를 사용하면 테이블에 필터를 적용하고 실시간 부분집합을 확인할 수 있습니다. 필터를 변경하면 부분집합도 바뀝니다. 이 부분집합을 기반으로 분석을 시작할 수 있습니다. 또한 필터 보기에 이름을 지정하고 테이블에 저장할 수도 있습니다.

샘플 인덱스의 테이블에서 필터 보기를 사용할 수 있습니다. Lipid Data.jmp 샘플 테이블이 업데이트되어 필터 보기를 포함합니다. 이 테이블을 보려면 도움말 > 샘플 인덱스를 선택한 후 검색 필드에 "Lipid"를 입력하십시오.

필터 보기 생성

필터 보기를 생성하는 방법에는 두 가지가 있습니다.

먼저, 데이터 테이블 열 이름의 오른쪽 상단에 마우스 포인터를 올려놓으면 필터 아이콘이 나타납니다.

그림 9.14 열의 필터 

Filter on a Column

필터 아이콘을 클릭하여 해당 열에 대한 필터가 포함된 필터 보기를 생성하고 필터 기준을 선택합니다.

다음으로, "필터 보기" 탭을 클릭한 후 "새 필터 보기 생성" 버튼(Image shown here)을 클릭하여 필터 보기를 생성합니다. 필터 보기가 생성되고 테이블 오른쪽에 테이블 필터 기준이 표시됩니다.

그림 9.15 필터 보기 탭에서 필터 보기 생성 

Create a Filter View from the Filter Views Tab

활성 필터(현재 적용되었거나 편집 중인 필터)는 "필터 보기" 탭에 체크 표시가 있습니다.

그림 9.16 활성 필터 보기 

The Active Filter View

필터 보기에 사용되는 열에는 필터 아이콘이 표시됩니다.

그림 9.17 표시된 필터 보기 열 

Marked Filter View Columns

필터 보기 저장

필터 보기는 테이블에 저장하지 않으면 임시 상태로 유지됩니다.

"필터 보기" 탭에서 생성된 필터 보기에는 기본 이름이 지정되며 파일 > 저장을 선택하여 테이블에 저장할 수 있습니다.

처음에 열에서 필터링하여 생성된 필터 보기의 경우 보기 저장을 클릭하여 "필터 보기" 탭에서 보기 이름을 지정한 후 파일 > 저장을 선택하여 테이블에 저장합니다.

그림 9.18 보기 저장 

Save View

필터 보기 편집

기존 필터 보기를 편집하려면 "필터 보기" 탭에서 필터 보기를 선택한 후 수정합니다. 잠긴 필터 보기는 편집할 수 없습니다.

필터 보기 이름 바꾸기

"필터 보기" 탭에서 필터 보기 이름을 두 번 클릭하고 새 이름을 입력합니다. 잠긴 필터 보기의 이름을 바꿀 수 있습니다.

필터 보기 삭제

"필터 보기" 탭에서 필터 보기를 선택하고 삭제 아이콘을 클릭합니다.

그림 9.19 필터 보기 삭제 

Delete a Filter View

삭제된 필터 보기를 복원하려면 편집 > 실행 취소를 사용합니다.

필터 보기에서 부분집합 생성

활성 필터 보기를 기반으로 하는 새 테이블을 생성하려면 필터 보기 메뉴를 클릭하고 보기를 새 테이블로 열기를 선택합니다.

그림 9.20 필터 보기를 새 테이블로 열기 

Open a Filter View as a New Table

필터 보기 잠금

활성 필터 보기를 잠그려면 필터 보기 메뉴를 클릭하고 잠금을 선택합니다.

그림 9.21 필터 보기 잠금 

Lock a Filter View

잠긴 필터 보기 이름은 기울임꼴로 표시됩니다.

잠긴 필터 보기의 이름을 바꿀 수는 있지만 필터 기준은 편집할 수 없습니다.

필터 페인 열기/닫기

필터 보기가 적용된 경우 필터 보기 페인의 표시 여부를 전환할 수 있습니다.

그림 9.22 필터 페인 토글 

Filter Pane Toggle

필터 보기 종료

필터링되지 않은 보기로 돌아가려면 "필터 보기" 탭에서 보기 종료를 클릭하거나 필터 보기 배너의 "X"를 클릭합니다.

그림 9.23 필터링되지 않은 보기로 돌아가기 

Return to an Unfiltered View

테이블 필터의 빨간색 삼각형 옵션

"테이블 필터"의 빨간색 삼각형 옵션은 "데이터 필터"의 옵션과 동일합니다. 자세한 내용은 데이터 필터의 빨간색 삼각형 옵션에서 확인하십시오.

필터 보기 스크립팅

필터 보기를 생성하고 조작하기 위한 완전한 JSL 인터페이스가 제공됩니다. 자세한 내용은 스크립트 인덱스에서 Data Table > Filter Views 항목을 참조하십시오.

다음 JSL 스크립트는 필터 보기를 생성하고 활성 필터 보기의 이름을 반환합니다.

Names Default To Here( 1 );
dt = Open( "$SAMPLE_DATA/Penguins.jmp" );
dt << New Filter View(
	"Dream",
	Data Filter(
		Add Filter( Columns( :Island ), Where( :Island == "Dream" ) )
	)
);
fvActive = dt << Get Active Filter View;
Show( fvActive << Get Name );

Set Name은 잠긴 필터 보기의 이름을 바꿀 수 없습니다.

New Filter View를 사용하여 이미 존재하는 이름으로 필터 보기를 생성할 경우 JMP에서 순차적으로 이름에 숫자를 추가합니다. 예를 들어 "FilterName"이 이미 있는 상태에서 새 필터 두 개를 생성하면 각각 "FilterName 2"와 "FilterName 3"이 됩니다.

더 많은 정보를 원하십니까? 질문이 있습니까? JMP 사용자 커뮤니티에서 답변 받기 (community.jmp.com).