JMP 사용 > 데이터 재구성 > 데이터 테이블 정렬
발행일: 09/10/2026

데이터 테이블 정렬

JMP 데이터 테이블을 열 기준으로 오름차순 또는 내림차순 정렬할 수 있습니다. 기본적으로 열은 오름차순으로 정렬됩니다. 정렬된 값을 포함하는 새 테이블을 생성하거나, 원래 테이블을 정렬된 테이블로 바꿀 수 있습니다.

열에 값 라벨이 포함된 경우 정렬은 값 라벨이 아니라 실제 데이터 값을 기준으로 합니다. 자세한 내용은 "­SPSS 라벨, 긴 이름, SAS 라벨­"에서 확인하십시오. 하지만 정렬된 데이터 테이블에서는 값 라벨이 표시됩니다.

"값 순서" 또는 "목록 확인" 특성을 사용하여 열의 데이터 순서를 지정할 수 있습니다. 정렬된 열에서 이러한 특성 중 하나를 사용하는 경우 먼저 해당 순서에 따라 열이 정렬됩니다. 자세한 내용은 "­값 순서­" 및 "­목록 확인­"에서 확인하십시오.

예: 데이터 테이블 정렬

1. 도움말 > 샘플 데이터 폴더를 선택하고 Popcorn.jmp를 엽니다.

2. 테이블 > 정렬을 선택합니다.

그림 6.5 정렬 창 

The Sort Window

3. 정렬 기준으로 사용할 열의 이름을 강조 표시합니다.

이 예에서는 popcorn과 yield를 선택합니다.

4. 기준을 클릭하여 정렬 목록에 열을 추가합니다.

목록에 열을 추가하는 순서에 따라 정렬 우선 순위가 결정됩니다. 목록의 첫 번째 열이 주 정렬 필드입니다. 그 다음의 각 변수는 정렬 목록의 이전 변수 내에서 정렬됩니다. "기준" 목록 내에서 열을 드래그하여 놓는 방법으로 정렬 순서를 변경할 수 있습니다.

5. 추가 옵션을 사용하여 정렬을 세부적으로 사용자 정의합니다.

이 예에서는 yield를 강조 표시하고 내림차순 버튼 (Image shown here)을 클릭합니다.

6. 출력 테이블 이름 옆의 상자에 정렬된 새 테이블의 이름을 입력합니다.

이 예에서는 sorted popcorn을 입력합니다.

그림 6.6 완료된 정렬 창 

Completed Sort Window

7. 확인을 클릭합니다.

정렬 옵션

열 선택 필터 메뉴

열을 검색 및 필터링하기 위한 옵션이 포함되어 있습니다. 자세한 내용은 "­열 필터 메뉴­"에서 확인하십시오.

테이블 바꾸기

정렬된 값을 포함하는 새 테이블을 생성하는 대신 원래 데이터 테이블을 정렬된 테이블로 바꿉니다. 이 옵션은 원래 테이블에서 생성된 보고서 창이 열려 있는 경우에는 사용할 수 없습니다.

출력 테이블 이름

(선택 사항) 정렬된 테이블의 이름을 지정합니다.

대화상자 열린 채 유지

"확인"을 클릭한 후 "정렬" 창을 열린 채로 유지합니다.

소스 테이블에 스크립트 저장

동일한 설정을 사용하여 데이터를 다시 정렬할 수 있는 스크립트를 원래 데이터 테이블에 저장합니다.

기준

정렬 기준으로 사용할 열을 추가합니다. 목록에 열을 추가하는 순서에 따라 정렬 우선 순위가 결정됩니다. 목록의 첫 번째 열이 주 정렬 필드입니다. 그 다음의 각 변수는 정렬 목록의 이전 변수 내에서 정렬됩니다.

제거

강조 표시된 열을 제거합니다.

오름차순 및 내림차순 버튼(Image shown here)

그룹화 변수의 값 목록 순서를 오름차순 또는 내림차순으로 변경할 수 있습니다. "기준" 변수 목록에서 변수를 선택하고 필요에 따라 오름차순 또는 내림차순 버튼을 클릭합니다. 그러면 변수 옆의 아이콘이 정렬 순서를 나타내는 모양으로 바뀝니다.

기본 옵션 저장

현재 설정을 새 기본 옵션으로 저장합니다.

자동 새로 고침

테이블 미리보기를 자동으로 새로 고칩니다. 미리보기를 완료하는 데 시간이 너무 오래 걸리는 경우 이 옵션을 선택 취소하고 "새로 고침" 버튼 (Image shown here)을 클릭할 수 있습니다. 이 옵션은 기본적으로 선택되어 있습니다.

랜덤 부분집합으로 미리보기

"미리보기" 페인을 새로 고칠 때 지연이 발생할 수 있는 매우 큰 테이블에 대해 이 옵션을 선택합니다. 이 옵션은 기본적으로 선택 취소되어 있습니다.

더 많은 정보를 원하십니까? 질문이 있습니까? JMP 사용자 커뮤니티에서 답변 받기 (community.jmp.com).