过滤器视图支持您在表中应用过滤器并实时查看子集。子集随过滤器的更改而更改。您可以基于该子集启动分析。还可以命名某个过滤器视图并随表保存该视图。
过滤器视图在“样本索引”的表中提供。样本表 Lipid Data.jmp 经过更新,新增了过滤器视图。要查看该表,请选择帮助 > 样本索引,然后在搜索字段中输入“Lipid”。
可通过两种方式创建过滤器视图。
第一种方式是将鼠标指针悬停在数据表列名的右上角,直到出现过滤器图标。
图 9.14 对某列进行过滤
点击过滤器图标,使用该列上的过滤器创建一个过滤器视图,然后选择过滤条件。
创建过滤器视图的第二种方式是点击“过滤器视图”选项卡,然后点击“新建过滤器视图”按钮 (
)。将创建过滤器视图,并且“表过滤器”条件显示在该表的右侧。
图 9.15 从“过滤器视图”选项卡创建过滤器视图
活动过滤器(当前应用或正在编辑的过滤器)在“过滤器视图”选项卡中有一个复选标记。
图 9.16 活动过滤器视图
过滤器视图中使用的列显示过滤器图标。
图 9.17 标记的过滤器视图列
除非将过滤器视图保存到表中,否则它们是临时的。
从“过滤器视图”选项卡创建的过滤器视图具有默认名称,并且可以通过选择文件 > 保存保存到表中。
若过滤器视图是通过最初对列进行过滤创建的,请点击保存视图在“过滤器视图”选项卡上命名该视图,然后选择文件 > 保存将其保存到表中。
图 9.18 保存视图
要编辑现有过滤器视图,请从“过滤器视图”选项卡中选择该过滤器视图并做出更改。无法编辑已锁定的过滤器视图。
从“过滤器视图”选项卡中,双击要重命名的过滤器视图名称并输入新名称。无法重命名已锁定的过滤器视图。
从“过滤器视图”选项卡中,选择过滤器视图并点击“删除”图标。
图 9.19 删除过滤器视图
要恢复删除的过滤器视图,请使用编辑 > 撤销。
要基于活动过滤器视图创建新表,请点击过滤器视图菜单并选择将视图作为新表打开。
图 9.20 将过滤器视图作为新表打开
要锁定活动过滤器视图,请点击过滤器视图菜单并选择锁定。
图 9.21 锁定过滤器视图
已锁定的过滤器视图名称以斜体显示。
您可以重命名已锁定的过滤器视图,但无法编辑过滤条件。
若“过滤器视图”有效,您可以切换“过滤器视图”窗格的显示。
图 9.22 “过滤器”窗格切换
要返回到未过滤的视图,请在“过滤器视图”选项卡中点击退出视图,或点击“过滤器视图”横幅中的“X”。
图 9.23 返回到未过滤的视图
“表过滤器”红色小三角选项与“数据过滤器”的红色小三角选项相同。请参见“数据过滤器”的红色小三角选项。
可通过完整的 JSL 接口来创建和操作过滤器视图。请参见“脚本索引”中的“数据表”>“过滤器视图”了解详细信息。
以下 JSL 脚本创建了一个过滤器视图,并返回活动过滤器视图的名称:
Names Default To Here( 1 );
dt = Open( "$SAMPLE_DATA/Penguins.jmp" );
dt << New Filter View(
"Dream",
Data Filter(
Add Filter( Columns( :Island ), Where( :Island == "Dream" ) )
)
);
fvActive = dt << Get Active Filter View;
Show( fvActive << Get Name );
Set Name 无法重命名已锁定的过滤器视图。
若使用新建过滤器视图创建名称已经存在的过滤器视图,JMP 会在该名称后追加数字,且每次创建数字都会递增。例如,若“FilterName”已存在,创建两个新过滤器将生成“FilterName 2”和“FilterName 3”。