To change between the two specifications, use the Degradation Path Style submenu from the platform red triangle menu.
To model linear degradation paths, select Degradation Path Style > Simple Linear Path from the platform red triangle menu.
Simple Linear Path Model Specification
Simple Linear Path Options describes the options for the Simple Linear Path specification.
If you need to perform a transformation that is not given, use the Custom option. For example, to transform the response variable using exp(-x2), enter the transformation as shown in the Scale box in Custom Transformation Options. Also, enter the inverse transformation in the Inverse Scale box.
Custom Transformation Options
Name the transformation using the text box. When finished, click the Use & Save button to apply the transformation. Select a transformation from the menu if you have created multiple custom transformations. Click the Delete button to delete a custom transformation.
To model nonlinear degradation paths, select Degradation Path Style > Nonlinear Path from the platform red triangle menu. This is useful if a degradation path cannot be linearized using transformations, or if you have a custom nonlinear model that you want to fit to the data.
To facilitate explaining the Nonlinear Path Model Specification, open the Device B.jmp data table. The data consists of power decrease measurements taken on 34 units, across four levels of temperature. Follow these steps:
1.
Open the Device B.jmp data table in the Reliability folder of Sample Data.
2.
Select Analyze > Reliability and Survival > Degradation.
3.
Select Power Drop and click Y, Response.
4.
Select Hours and click Time.
5.
Select Degrees C and click X.
6.
Select Device and click Label, System ID.
7.
Device B Overlay Plot shows the initial overlay plot of the data.
Device B Overlay Plot
The degradation paths appear linear for the first several hundred hours, but then start to curve. To fit a nonlinear model, select Degradation Path Style > Nonlinear Path from the platform red triangle menu to show the Nonlinear Path Model Specification outline. See Initial Nonlinear Model Specification Outline.
Note: To view the Edit button displayed in Initial Nonlinear Model Specification Outline, you must have the interactive formula editor preference selected (File > Preferences > Platforms > Degradation > Use Interactive Formula Editor).
Initial Nonlinear Model Specification Outline
The Reaction Rate options are applicable when the degradation occurs from a single chemical reaction, and the reaction rate is a function of temperature only. Select Reaction Rate or Reaction Rate Type 1 from the menu shown in Initial Nonlinear Model Specification Outline. Although similar to the Reaction Rate model, the Reaction Rate Type 1 model contains an offset term that changes the basic assumption concerning the response value’s sign.
Unit and Baseline Selection
For this example, select Reaction Rate and then select Celsius as the Temperature Unit. Click OK to return to the report. For details about all the features for Model Specification, refer to Model Specification Details.
Select Constant Rate from the menu shown in Initial Nonlinear Model Specification Outline. The Constant Rate Model Settings window prompts you to enter transformations for the Path, Rate, and Time.
Constant Rate Transformation
After all selections are made, click OK to return to the report. For details about all the features for Model Specification, refer to Model Specification Details.
For details about how to create a model and store it as a column, refer to Fit a Custom Model or the Nonlinear Regression chapter of the Specialized Models book.
Select Prediction Column from the menu shown in Initial Nonlinear Model Specification Outline. The Model Specification outline changes to prompt you to select the column that contains the model.
Column Selection
If the model that you want to use already exists in a column of the data table, select the column here, and then click OK. You are returned to the Nonlinear Path Model Specification. For details about all the features for that specification, refer to Model Specification Details.
If the model that you want to use does not already exist in the data table, you can click the Model Library button to use one of the built-in models. For details about using the Model Library button, refer to Model Library or the Nonlinear Regression chapter of the Specialized Models book. After the model is created, relaunch the Degradation platform and return to the column selection shown in Column Selection. Select the column that contains the model, and then click OK. You are returned to the Nonlinear Path Model Specification. For details about all the features for that specification, refer to Model Specification Details.
If the model that you want to use is not in the data table, and you do not want to use one of the built-in models, then you are not ready to use this model specification. First, create the model, relaunch the Degradation platform, and then return to the column selection (Column Selection). Select the column containing the model, and then click OK. You are returned to the Nonlinear Path Model Specification. For details about all the features for that specification, refer to Model Specification Details. For details about using the Model Library button, refer to Model Library or the Nonlinear Regression chapter of the Specialized Models book for additional information.
Note: To view the Edit button displayed in Initial Model Specification and Model Specification, you must have the interactive formula editor preference selected (File > Preferences > Platforms > Degradation > Use Interactive Formula Editor).
Initial Model Specification
A model is now shown in the script box that uses the Parameter statement. Initial values for the parameters are estimated from the data. For complete details about creating models that use parameters, refer to Fit a Custom Model or the Nonlinear Regression chapter in the Specialized Models book. A nicely formatted view of the model is shown below the row of buttons.
Model Specification
The Fit Model button is used to fit the model to the data.
The Fit by System ID is used to fit the model to every level of Label, System ID.
Newton chooses whether Gauss-Newton (for regular least squares) or Newton-Raphson (for models with loss functions) is the optimization method.
QuasiNewton SR1 chooses QuasiNewton SR1 as the optimization method.
QuasiNewton BFGS chooses QuasiNewton BFGS as the optimization method.
The Optimization Settings button is used to change the optimization settings.
The Delete button is used to delete a model from the model menu.
The Generate Report for Current Model button creates a report for the current model settings. See Model Reports.
The initial parameter values are shown at the bottom, along with sliders for visualizing how changes in the parameters affect the model. To do so, first select Graph Options > Show Fitted Lines from the platform red-triangle menu to show the fitted lines on the plot. Then move the parameter sliders to see how changes affect the fitted lines.
Dinf (D) - asymptotic degradation level
Ru (RU) - reaction rate at use temperature (tempU)
Ea (Ea) - reaction-specific activation energy
D(t; temp) = D x {1-exp[-RU x AF(temp) x t]}
where RU is the reaction rate at use temperature tempU, RU x AF(temp) is the reaction rate at a general temperature temp, and for temp > tempU, AF(temp) > 1
AF(temp, tempU, Ea) =
To compute the optimal values for the parameters, click the Fit Model or Fit by System ID button.
To fix a value for a parameter, check the box under Fixed for the parameter. When fixed, that parameter is held constant in the model fitting process.
You can use the Formula Editor to enter a model. Click the Edit button to open the Formula Editor to enter parameters and the model. For details about entering parameters and formulas in the Formula Editor, see Using JMP.
Note: To view the Edit button displayed in Alternate Model Specification Report, you must have the interactive formula editor preference selected (File > Preferences > Platforms > Degradation > Use Interactive Formula Editor).
Alternate Model Specification Report
3.
Select Analyze > Modeling > Nonlinear.
4.
Assign the Y variable to the Y, Response role.
5.
7.
8.
Click Go on the Control Panel to fit the model.
3.
Select Parameters from the popup menu above the list of columns.
4.
Click New Parameter.
8.
In the formula editor, when you add a parameter, note the check box for Expand Into Categories, selecting column. This option is used to add several parameters (one for each level of a categorical variable for example) at once. When you select this option a window appears that enables you to select a column. After selection, a new parameter appears in the Parameters list with the name D_column, where D is the name that you gave the parameter. When you use this parameter in the formula, a Match expression is inserted, containing a separate parameter for each level of the grouping variable.
The Model Library can assist you in creating the formula column with parameters and initial values. Click Model Library on the window to open the library. Select a model in the list to see its formula in the Formula box.
Click Show Graph to show a 2-D theoretical curve for one-parameter models and a 3-D surface plot for two-parameter models. No graph is available for models with more than two explanatory (X) variables. On the graph window, change the default initial values of parameters using the slider, or clicking and entering values directly.
The Reset button sets the initial values of parameters back to their default values.
Click Show Points to overlay the actual data points to the plot. A window opens, asking you to assign columns into X and Y roles, and an optional Group role. The Group role allows for fitting the model to every level of a categorical variable. If you specify a Group role here, also specify the Group column on the platform launch window.
Clicking Make Formula at this point (after using Show Points) creates a new column in the data table. This column has the formula as a function of the latest parameter starting values.
Note: If you click Make Formula before using the Show Graph or Show Points buttons, you are asked to provide the X and Y roles, and an optional Group role. After that, you are brought back to the plot so that you have the opportunity to adjust the parameters starting values if desired. At that point click Make Formula again to create the new column.
The Model Library is created by a built-in script named NonlinLib.jsl, located in the Resources/Builtins folder in the folder that contains JMP (Windows) or in the Application Package (Macintosh). You can customize the nonlinear library script by modifying this script.
To add a model, you must add three lines to the list named Listofmodellist#. These three lines are actually a list themselves, which consists of the following three parts.
The values of lowx, highx, lowy, and highy specify the initial window for the theoretical graph.