Using JMP > Get Started with JMP > Data Table Features > Data Grid in Data Tables
Publication date: 05/24/2021

Data Grid in Data Tables

The data grid is the main part of the data table that contains your data. Figure 2.10 illustrates how to interact with the data grid. See also Select Rows in Data Tables.

Figure 2.10 Interacting with the Data Grid 

Interacting with the Data Grid

No.

Description

1

Hides or shows the data table panels.

2

Click to deselect any selected columns. To select all columns, press Shift and click. Double-click to add multiple columns.

3

The red triangle shows the columns menu.

4

The histogram shows histograms in the column header row.

5

Click to select the column.

Double-click to view the Column Info window. See About the Column Info Window.

Right-click for column options. See Right-Click Options for Columns.

6

Double-click the column name to edit it in the Column Info window, or select the column name and press Enter.

7

Click and drag to change a column width. To change several column widths, select the columns, press Alt, then click and drag.

8

Click to select the row.

Double-click to open the Row Editor. See Edit Cells in Data Tables.

Right-click for row options. See Right-Click Options for Rows.

9

Shows the rows menu.

10

Click to deselect all selected rows. To select all rows, press Shift and click. Double-click to add rows.

Right-Click Options for Columns

Right-clicking in a column heading shows these options:

Column Info

Opens the Column Info window. See About the Column Info Window.

Standardize Attributes

Copies attributes (data types, modeling types, numeric formats, and so on) or properties (formulas, notes, list and range checks, and so on) from one column to other columns. Also deletes selected attributes or properties from columns. See Standardize Attributes and Properties Across Columns.

Column Properties

Contains a list of column properties. Select one to open the Column Info window and apply it to the column. This list is also available from the Column Info window. See Column Properties in JMP.

Formula

Opens the Formula Editor. See Create Formulas in JMP.

Recode

Enables you to change all of the values in a column at once. See Recode Data in a Column.

New Formula Column

Creates a formula column. See Make a New Formula Column.

Insert Columns

Inserts one or more columns before the selected column or columns.

Delete Columns

Deletes all selected columns.

Label/Unlabel

Labels or unlabels selected columns in all plots. See Label Rows and Columns.

Link ID

Used in virtually joined data tables to mark a column in the auxiliary data table as the ID column. That is, the rows of the data table are uniquely identified by the values of the ID column. The Link ID column property checkbox is selected if the column is the ID column for the data table. See Link Data Tables with Virtual Join Properties.

Link Reference

Used in virtually joined data tables to map a column in the main data table to the ID column in the auxiliary data table. The Link Reference column property specifies the path name of the auxiliary data table. See Link Data Tables with Virtual Join Properties.

Sort

Sorts all of the rows in the table by the values in the selected column. You can choose to sort the rows in ascending or descending order. See Sort Data Tables.

Copy Column Properties

Copies the column properties.

Paste Column Properties

Pastes the column properties.

Copy Columns

Copies the script to recreate the columns. It copies all of the attributes and properties but no data.

Paste Columns

Creates new columns from the script generated by Copy Columns. The column will be placed after the selected column. If no column is selected, the new columns are placed at the end of the data table. The new columns populate (in the destination table) as many rows as there are data in the script.

Right-Click Options for Rows

Right-clicking in a row heading shows these options:

Hide and Exclude

Hides the selected rows in all plots and graphs and excludes them from analyses. See Hide and Exclude Rows in Data Tables.

Exclude/Unexclude

Excludes or includes selected rows from analyses. See Exclude Rows in Data Tables.

Hide/Unhide

Hides or shows selected rows in all plots and graphs. See Hide Rows in Data Tables.

Label/Unlabel

Labels or unlabels selected rows in all plots. See Label Rows and Columns.

Colors

Provides a color palette. Select a color to apply it to the selected rows. The color is used in plots and graphs. See Assign a Color to Rows.

Markers

Provides a palette of markers or symbols. Select a marker to apply it to the selected rows. The marker is used in plots and graphs instead of points. See Add Markers to Rows.

Color Rows by Row State

Colors the row the same as the current row state color. See Assign Colors or Markers to Rows Based on Column Values.

Select Matching Cells

Selects rows in the active data table with values that match the selected row(s). See Resize Rows and Columns

Invert Selection

Selects all previously deselected rows, and deselects all currently selected rows.

Clear Row States

Clears all active row states in the data table. All rows become included, visible, unlabeled, and show in plots as black dots. It does not affect row states saved in row state columns. See Delete Row Characteristics.

Add Rows

Adds the specified number of rows to the data table. See Add Rows to Data Tables.

Delete Rows

Removes all selected rows from the data table. Use the Undo command on the Edit menu to undo an accidental deletion. See Delete Rows in Data Tables.

Cursor Forms

The cursor takes different forms, depending on its location in the data grid.

Arrow Cursor Image shown here

The standard arrow cursor appears in the following locations:

In the panels area to the left of the data table

In the triangular rows and columns area, located in the upper left corner of the data grid

You can perform the following actions with the arrow cursor:

To select a column using the arrow cursor, click its name in the Columns panel.

Double-click a column name in the Columns panel to edit it.

Click the triangular areas in the upper left corner of the data grid to deselect rows and columns.

Selection (Large Plus) Cursor Image shown here

When the cursor is at the top of a column heading, or in a row number area, it becomes a large plus, indicating that you can select rows or columns. When you click, that row or column is selected and highlighted. Click and drag to select multiple rows or columns, and press Ctrl and click to select discontiguous rows or columns.

Double-click a column heading area to see the Column Info window for that column.

Select a column to change the column name. The column highlights. Begin typing (if it is not in a locked column or locked data table).

Double-click the row number area to edit the rows using the Row Editor.

I-beam Cursor Image shown here

When you select editable text, the cursor becomes a standard I-beam. To edit text, position the I‑beam within highlighted text. Click to mark an insertion point, or drag to select text for replacement.

Double Arrow Cursor Image shown here

The cursor changes to a double arrow when it is on a column or a panel boundary. Drag this cursor left or right to change the width of a column or panel. Changing the width of a column does not affect the column field width specified in the Column Info window (accessed by double-clicking a column name).

Tip: You can adjust widths of all selected columns at once by pressing Alt as you drag the double arrow cursor on any of the selected column boundaries.

List Check Cursor Image shown here

The cursor changes form when you move the mouse over values in columns that have data validation in effect. It becomes a small, downward-pointing arrow on a column with list checking. When you click, the value is highlighted and the cursor becomes the I-beam. Enter or edit data as usual with any values defined as valid text or valid numbers. See List Check.

Pointer Cursor Image shown here

The cursor changes to a pointer over these objects:

Red triangle menus for options

Triangular disclosure icons Image shown here that open or close panels

Modeling type icons for changing

Want more information? Have questions? Get answers in the JMP User Community (community.jmp.com).