公開日: 09/09/2026

フィルタビュー

フィルタビューを使用すると、テーブルにフィルタを適用して、その場でサブセットを確認できます。フィルタを変更すると、サブセットも変わります。そのサブセットを使用して分析を開始できます。また、フィルタビューに名前を付けて、テーブルと一緒に保存することもできます。

フィルタビューは、[サンプルの索引]のテーブルでも利用できます。サンプルの「Lipid Data.jmp」テーブルには、フィルタビューが追加されています。このテーブルを表示するには、[ヘルプ]>[サンプルの索引]を選択し、検索フィールドに「Lipid」と入力してください。

フィルタビューの作成

フィルタビューを作成するには、2通りの方法があります。

1つ目は、データテーブルの列名の右上隅にマウスポインタを置き、フィルタアイコンを表示する方法です。

図9.14 列のフィルタ 

Filter on a Column

フィルタアイコンをクリックして、その列にフィルタを設定したフィルタビューを作成し、フィルタの条件を選択します。

フィルタビューを作成する2つ目の方法は、[フィルタビュー]タブをクリックしてから、[新しいフィルタビューを作成する]ボタン(Image shown here)をクリックすることです。フィルタビューが作成され、テーブルの右側にテーブルフィルタの条件が表示されます。

図9.15 [フィルタビュー]タブからフィルタビューを作成 

Create a Filter View from the Filter Views Tab

[フィルタビュー]タブでは、アクティブなフィルタ(現在適用中または編集中のフィルタ)ににチェックマークが付きます。

図9.16 アクティブなフィルタビュー 

The Active Filter View

フィルタビューで使用されている列には、フィルタアイコンが表示されます。

図9.17 フィルタビューで使用されている列 

Marked Filter View Columns

フィルタビューの保存

フィルタビューは、テーブルに保存しない限り一時的なものとなります。

[フィルタビュー]タブから作成されたフィルタビューにはデフォルトの名前が付いており、[ファイル]>[保存]を選択することでテーブルに保存できます。

最初に列でフィルタをかけて作成されたフィルタビューの場合は、[ビューを保存]をクリックして[フィルタビュー]タブでビューに名前を付け、[ファイル]>[保存]を選択してテーブルに保存します。

図9.18 ビューを保存 

Save View

フィルタビューの編集

既存のフィルタビューを編集するには、[フィルタビュー]タブからフィルタビューを選択し、変更を加えます。ロックされたフィルタビューは編集できません。

フィルタビューの名前の変更

[フィルタビュー]タブで、フィルタビュー名をダブルクリックして新しい名前を入力します。ロックされたフィルタビューの名前も変更できます。

フィルタビューの削除

[フィルタビュー]タブで、フィルタビューを選択し、削除アイコンをクリックします。

図9.19 フィルタビューの削除 

Delete a Filter View

削除したフィルタビューを復元するには、[編集]>[元に戻す]を使用します。

フィルタビューからサブセットを作成

アクティブなフィルタビューに基づいて新しいテーブルを作成するには、フィルタビューのメニューをクリックし、[ビューを新しいテーブルとして開く]を選択します。

図9.20 フィルタビューを新しいテーブルとして開く 

Open a Filter View as a New Table

フィルタビューのロック

アクティブなフィルタビューをロックするには、フィルタビューのメニューをクリックし、[ロック]を選択します。

図9.21 フィルタビューのロック 

Lock a Filter View

ロックされたフィルタビューの名前は斜体で表示されます。

ロックされたフィルタビューの名前は変更できますが、フィルタの条件は編集できません。

フィルタパネルを開閉する

フィルタビューが有効な場合、フィルタビューパネルの表示/非表示を切り替えることができます。

図9.22 フィルタパネルの切り替え 

Filter Pane Toggle

フィルタビューの終了

フィルタリングされていないビューに戻るには、[フィルタビュー]タブの[ビューを閉じる]をクリックするか、フィルタビューのバナーにある[X]をクリックします。

図9.23 フィルタリングされていないビューに戻る 

Return to an Unfiltered View

「テーブルフィルタ」の赤い三角ボタンのオプション

「テーブルフィルタ」の赤い三角ボタンのオプションは、「データフィルタ」の赤い三角ボタンのものと同じです。詳細については、「データフィルタ」の赤い三角ボタンのメニューオプションを参照してください。

フィルタビューのスクリプト作成

フィルタビューを作成および操作できる完全なJSLインターフェースが用意されています。詳細については、[スクリプトの索引]で[Data Table]>[Filter Views]を参照してください。

次のJSLスクリプトは、フィルタビューを作成し、アクティブなフィルタビューの名前を戻します。

Names Default To Here( 1 );
dt = Open( "$SAMPLE_DATA/Penguins.jmp" );
dt << New Filter View(
	"Dream",
	Data Filter(
		Add Filter( Columns( :島 ), Where( :島 == "Dream" ) )
	)
);
fvActive = dt << Get Active Filter View;
Show( fvActive << Get Name );

Set Nameでは、ロックされたフィルタビューの名前を変更できません。

[新しいフィルタビューを作成する]ボタンを使用して既に存在する名前のフィルタビューを作成すると、名前に通し番号が付加されます。たとえば、「フィルタ名」という名前がすでに存在する場合、2つの新しいフィルタを作成すると、「フィルタ名 2」と「フィルタ名 3」になります。

より詳細な情報が必要な場合や、質問があるときは、JMPユーザーコミュニティで答えを見つけましょう (community.jmp.com).