JMP 살펴보기 > JMP 시작하기 > 데이터 테이블 기능 > 다양한 유형의 데이터 파일 열기
발행일 : 03/10/2025

다양한 유형의 데이터 파일 열기

데이터 집합을 열려면 파일 > 열기를 선택하고 파일 유형을 선택합니다. 일부 파일 유형의 경우 "데이터 파일 열기" 창에서 추가 기능 및 옵션이 나타납니다(Table 2.1).

팁:

• (Windows에만 해당) 매번 동일한 파일 유형을 열려면 다음에 이 창이 호출될 때 이 필터 선택 체크박스를 선택합니다.

• 파일을 JMP 홈 창으로 드래그하는 방법으로 열 수도 있습니다.

• 파일 > 열기 명령 사용 시 기본 검색 디렉터리를 변경하는 방법은 파일 위치 환경 설정에서 확인하십시오.

• 파일 열기에 대한 자세한 내용은 데이터 가져오기에서 확인하십시오.

표 2.1 파일 유형별 파일 > 열기 옵션

파일 유형

추가 기능 및 옵션

JMP 데이터 테이블

테이블 노트, 열 수 및 행 수가 나타납니다.

데이터 테이블로 가져올 열을 선택하려면 열 선택 옵션을 사용합니다. Windows의 경우, 열기 옆의 화살표를 클릭한 후 "열 선택" 옵션을 사용하여 데이터 테이블로 가져올 열을 지정합니다. macOS의 경우, 열기를 클릭한 후 가져올 열을 선택할 수 있습니다.

Excel 파일

• 레이아웃을 사용자 정의하고 파일을 가져오기 전에 데이터를 미리 볼 수 있도록 기본적으로 Excel 가져오기 마법사에서 파일을 가져옵니다.

• 열기 옆의 화살표를 클릭한 후 옵션 중 하나를 선택합니다. 첫 번째 스프레드시트 행을 열 머리글로 변환합니다.

텍스트 파일

• 데이터 배열을 자동으로 결정하려면 다음 옵션 중 하나를 선택합니다.

– 데이터(환경 설정 사용)

– 데이터(최적 추측)

– 스크립트 편집기의 텍스트

• 데이터 배열을 수동으로 지정하려면 데이터(미리보기 사용) 옵션을 선택합니다. 자세한 내용은 JMP 텍스트 가져오기 마법사 옵션에서 확인하십시오.

SAS 데이터 집합

• 열 이름에 SAS 변수를 사용합니다.

• (Windows에만 해당) 암호로 보호된 데이터 집합을 열 경우 암호를 입력합니다.

• (SAS 전송 파일에만 해당) 열기 전에 열을 선택합니다.

SPSS 데이터 파일

열 이름에 SPSS 변수 또는 라벨 이름을 사용합니다.

XML 데이터 파일

옵션에 대한 자세한 내용은 텍스트 파일에서 확인하십시오.

JSON 데이터 파일

옵션에 대한 자세한 내용은 텍스트 파일에서 확인하십시오.

모든 파일

• 데이터 배열을 자동으로 결정하려면 다음 옵션 중 하나를 선택합니다.

– 열기 형식: 데이터(텍스트 가져오기 환경 설정 사용)

– 열기 형식: 데이터(최적 추측 사용)

– 열기 형식: 일반 텍스트(스크립트 창에)

• 데이터 배열을 수동으로 지정하려면 데이터(미리보기 사용) 옵션을 선택합니다.

• (Windows에만 해당) 컴퓨터의 기본 텍스트 편집기를 사용하여 텍스트 파일을 열려면 기본 프로그램을 사용하여 엽니다.를 선택합니다.

더 많은 정보를 원하십니까? 질문이 있습니까? JMP 사용자 커뮤니티에서 답변 받기 (community.jmp.com).