발행일: 09/10/2026

도구 모음 사용자 정의

JMP에는 새 버튼을 추가할 수 있는 도구 모음이 포함되어 있으며, 사용자가 직접 도구 모음을 생성할 수도 있습니다. 기본적으로 JMP 창 유형에 따라 표시되는 도구 모음이 결정됩니다. 예를 들어 모든 창에는 "파일 및 편집" 도구 모음이 있습니다. 데이터 테이블에서는 "데이터 테이블" 도구 모음도 표시됩니다.

시작하기

"시작하기" 메뉴에 대한 버튼을 표시합니다.

Image shown here

프로젝트

프로젝트에 대한 버튼을 표시합니다.

Image shown here

파일 및 편집

"파일" 및 "편집" 메뉴 옵션에 대한 버튼을 표시합니다.

Image shown here

분석

"분석" 메뉴의 공통 옵션에 대한 버튼을 표시합니다.

Image shown here

그래프

"그래프" 메뉴 옵션에 대한 버튼을 표시합니다.

Image shown here

도구

클릭하여 커서처럼 사용할 수 있는 도구의 버튼을 표시합니다. 일부 창에서는 도구 모음이 숨겨지고 대신 파란색 선이 나타납니다. 파란색 선을 마우스로 가리키면 이 도구 모음이 표시됩니다.

Image shown here

데이터 테이블 목록

열려 있는 데이터 테이블의 목록을 표시합니다. 이 목록에서 데이터 테이블을 선택하면 해당 데이터 테이블이 현재 테이블이 됩니다. 현재 테이블 창이 반드시 맨 앞의 창인 것은 아닙니다. 테이블(또는 임의의 창)을 맨 앞으로 가져오려면 "창" 메뉴의 목록에서 해당 이름을 선택합니다.

Image shown here

테이블

"테이블" 메뉴 옵션에 대한 버튼을 표시합니다.

Image shown here

DOE

"DOE" 메뉴 옵션에 대한 버튼을 표시합니다.

Image shown here

응용 프로그램 빌더

응용 프로그램 빌더의 옵션에 대한 버튼을 표시합니다.

Image shown here

홈

"파일" 메뉴에서 자주 사용되는 버튼을 표시합니다.

Image shown here

데이터 테이블

데이터 필터, 모형 적합, 재코딩 창 열기 등 데이터 테이블에서 자주 사용하는 작업을 수행하는 버튼을 표시합니다.

Image shown here

스크립트 편집기

스크립트 실행, 디버깅, 서식 조정 등을 위한 버튼을 표시합니다.

Image shown here

보고서

로컬 데이터 필터와 열 전환기를 열거나 스크립트를 데이터 테이블에 저장하는 버튼을 표시합니다.

Image shown here

기본 도구 모음에 포함되어 있지 않지만 자주 사용하는 옵션을 위한 사용자 지정 도구 모음을 생성할 수 있습니다. 버튼에 옵션을 할당하고 바로 가기 키, 버튼, JSL 스크립트 등의 다른 특성을 추가할 수 있습니다.

기존 도구 모음을 기반으로 새 도구 모음을 생성하려면 기존 도구 모음을 복사한 후 필요에 따라 설정을 변경합니다. 자세한 내용은 메뉴, 메뉴 항목, 도구 모음 및 버튼 복사하여 붙여넣기에서 확인하십시오.

1단계: 도구 모음 생성

1. 보기 > 사용자 정의 > 메뉴/도구 모음을 선택합니다.

창 왼쪽에 "도구 모음" 목록이 표시됩니다.

2. (선택 사항) 이 사용자 정의를 볼 수 있는 사용자를 제어하려면 사용자 정의 집합을 변경합니다.

자세한 내용은 사용자 정의 집합 옵션에서 확인하십시오.

3. 메뉴 편집기가 열려 있는 상태에서 도구 모음 중 하나(파일 및 편집)를 마우스 오른쪽 버튼으로 클릭합니다.

모든 새 도구 모음은 "도구 모음" 목록의 맨 끝에 추가되므로 아무 도구 모음이나 선택하십시오.

4. 새 도구 모음을 선택합니다.

목록 끝에 도구 모음이 삽입됩니다. 모든 도구 모음에는 버튼이 하나 이상 있어야 하므로 이 도구 모음에는 제목 없는 버튼이 하나 포함되어 있습니다.

2단계: 캡션 및 내부 이름 지정

도구 모음에는 몇 가지 기본적인 특성이 있습니다.

• 캡션: 보기 > 도구 모음 목록에 표시되며 이를 통해 도구 모음을 표시하거나 숨길 수 있습니다. 각 도구 모음에 고유한 이름을 지정해야 합니다. 메뉴 편집기를 닫았다가 다시 열면 JMP는 동일한 이름의 도구 모음을 병합합니다.

• 내부 이름(대/소문자 구분 안 함): JMP는 항목의 위치를 캡션이 아니라 내부 이름으로 식별합니다.

이러한 도구 모음 특성을 지정하려면 다음 단계를 수행하십시오.

1. 메뉴 편집기가 열려 있는 상태에서 도구 모음을 선택합니다.

창 오른쪽에 "일반" 특성이 표시됩니다.

2. 내부 이름 옆에 내부 이름을 입력합니다.

3. 캡션 상자에 도구 모음 또는 버튼의 고유 이름을 입력합니다.

4. (선택 사항) 캡션의 번역을 지정하려면 다음 작업을 수행합니다.

– 사용자 정의하려는 항목에 대한 로컬라이즈 버튼을 클릭합니다.

– 언어를 선택합니다.

– 텍스트 옆에 번역을 입력합니다.

– 확인을 클릭합니다.

5. (선택 사항) 생성 후 도구 모음을 숨김 상태로 유지하려면 숨김을 클릭합니다.

6. 메뉴 항목 및 도구 모음 버튼 생성에 설명된 대로 제목 없는 버튼을 사용자 정의합니다.

7. 저장을 클릭하여 변경 사항을 저장합니다.

더 많은 정보를 원하십니까? 질문이 있습니까? JMP 사용자 커뮤니티에서 답변 받기 (community.jmp.com).