Version 11

Using JMP

“The real voyage of discovery consists not in seeking new landscapes, but in having new eyes.”
Marcel Proust

JMP, A Business Unit of SAS
SAS Campus Drive
Cary, NC 27513
Technology License Notices

- Scintilla - Copyright © 1998-2012 by Neil Hodgson <neilh@scintilla.org>. All Rights Reserved. Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee is hereby granted, provided that the above copyright notice appear in all copies and that both that copyright notice and this permission notice appear in supporting documentation. NEIL HODGSON DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT SHALL NEIL HODGSON BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

- Telerik RadControls: Copyright © 2002-2012, Telerik. Usage of the included Telerik RadControls outside of JMP is not permitted.


- Made with Natural Earth. Free vector and raster map data @ naturalearthdata.com.

- Packages - Copyright © 2009-2010, Stéphane Sudre (s.sudre.free.fr). All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. Neither the name of the WhiteBox nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission. THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

• iODBC software - Copyright © 1995-2006, OpenLink Software Inc and Ke Jin (www.iodbc.org). All rights reserved.
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

– Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

– Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

– Neither the name of OpenLink Software Inc. nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL OPENLINK OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

• bzip2, the associated library “libbzip2”, and all documentation, are Copyright © 1996-2010, Julian R Seward. All rights reserved.
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

The origin of this software must not be misrepresented; you must not claim that you wrote the original software. If you use this software in a product, an acknowledgment in the product documentation would be appreciated but is not required.
Altered source versions must be plainly marked as such, and must not be misrepresented as being the original software.

The name of the author may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


• MATLAB software is Copyright © 1984-2012, The MathWorks, Inc. Protected by U.S. and international patents. See www.mathworks.com/patents. MATLAB and Simulink are registered trademarks of The MathWorks, Inc. See www.mathworks.com/trademarks for a list of additional trademarks. Other product or brand names may be trademarks or registered trademarks of their respective holders.
Get the Most from JMP®

Whether you are a first-time or a long-time user, there is always something to learn about JMP.

Visit JMP.com to find the following:

- live and recorded webcasts about how to get started with JMP
- video demos and webcasts of new features and advanced techniques
- details on registering for JMP training
- schedules for seminars being held in your area
- success stories showing how others use JMP
- a blog with tips, tricks, and stories from JMP staff
- a forum to discuss JMP with other users

http://www.jmp.com/getstarted/
Display and Arrange Open Windows ........................................... 51
Using the Reveal Feature .......................................................... 52
View Preview of Data (Windows Only) ....................................... 52
Anatomy of a JMP Session ......................................................... 54

3 Import Your Data

Create Data Tables ..................................................................... 59
About Importing Data to JMP ..................................................... 61
Import Microsoft Excel Files ....................................................... 62
  Preview and Import the Microsoft Excel Data (Windows) .......... 62
  Import a Microsoft Excel File Directly ...................................... 66
Import Text Files ....................................................................... 67
  Text Import Preview Options ................................................ 69
  Open a Text File in a Text Editing Window ............................... 73
  Import Text from the Script Window ....................................... 75
Import Remote Files and Web Pages .......................................... 75
Import SPSS Files ..................................................................... 77
Import Data from SAS ................................................................ 78
  Import SAS Data Sets ............................................................ 79
  Create SAS Transport Files in SAS ....................................... 81
  Connect to SAS ..................................................................... 82
  Open SAS Data Sets through a SAS Server .............................. 87
  Run Stored Processes ........................................................... 95
  Submit SAS Code .................................................................. 96
  Generate ODS Results ........................................................... 97
  Retrieve Generated SAS Data Sets ......................................... 98
Import Data from R ................................................................... 100
Import Data Using the Excel Add-In .......................................... 101
  Transfer Excel Data to a JMP Data Table ................................. 101
  About the JMP Add-In for Excel ............................................ 102
  Uninstall the Excel Add-In .................................................... 103
  Uninstall Previous Versions of the Excel Add-In ...................... 103
Import Data from a Database ..................................................... 103
  Open Data from a Database .................................................. 104
## 4 Enter and Edit Data

### Perform Basic Data Table Tasks

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Retrieve Data Using SQL Statements</td>
<td>106</td>
</tr>
<tr>
<td>Structured Query Language (SQL): A Reference</td>
<td>107</td>
</tr>
<tr>
<td>Use the WHERE Clause Editor</td>
<td>111</td>
</tr>
<tr>
<td>Read in Real-Time Data</td>
<td>113</td>
</tr>
<tr>
<td>Create New Data Tables</td>
<td>114</td>
</tr>
<tr>
<td>Enter Data</td>
<td>117</td>
</tr>
<tr>
<td>Add Rows</td>
<td>119</td>
</tr>
<tr>
<td>Add Columns</td>
<td>119</td>
</tr>
<tr>
<td>Fill Columns with Sequential Data</td>
<td>120</td>
</tr>
<tr>
<td>Enter Cell Formulas</td>
<td>121</td>
</tr>
<tr>
<td>Select Rows</td>
<td>122</td>
</tr>
<tr>
<td>Locate Next and Previously Selected Rows</td>
<td>124</td>
</tr>
<tr>
<td>Select Columns</td>
<td>125</td>
</tr>
<tr>
<td>Select Columns in a Data Table</td>
<td>125</td>
</tr>
<tr>
<td>Select Columns in the Columns Viewer</td>
<td>126</td>
</tr>
<tr>
<td>Select Cells</td>
<td>130</td>
</tr>
<tr>
<td>Edit Data</td>
<td>132</td>
</tr>
<tr>
<td>Delete Rows and Columns</td>
<td>132</td>
</tr>
<tr>
<td>Edit or Delete Cells</td>
<td>133</td>
</tr>
<tr>
<td>Edit Column Names</td>
<td>133</td>
</tr>
<tr>
<td>Recode Data</td>
<td>133</td>
</tr>
<tr>
<td>View Patterns of Missing Data</td>
<td>134</td>
</tr>
<tr>
<td>Find and Replace Cell Values</td>
<td>136</td>
</tr>
<tr>
<td>Reorder Columns</td>
<td>139</td>
</tr>
<tr>
<td>Group Columns</td>
<td>139</td>
</tr>
<tr>
<td>Move Values</td>
<td>140</td>
</tr>
<tr>
<td>Use the Row Editor</td>
<td>141</td>
</tr>
<tr>
<td>Context Menus for Rows and Columns</td>
<td>142</td>
</tr>
<tr>
<td>Make Binning Formula</td>
<td>143</td>
</tr>
<tr>
<td>Edit Data Tables</td>
<td>144</td>
</tr>
<tr>
<td>Change Table Names</td>
<td>145</td>
</tr>
<tr>
<td>Lock Tables</td>
<td>145</td>
</tr>
</tbody>
</table>
Compress Tables ................................................................. 145
Use Table Variables .......................................................... 146
Create and Save Scripts ....................................................... 148
Compare Data Tables ........................................................... 151
Assign Characteristics to Rows and Columns ......................... 155
Hide and Exclude Rows ........................................................ 155
Exclude Rows and Columns .................................................... 155
Hide Rows and Columns ........................................................ 156
Label Rows and Columns ....................................................... 157
Assign Colors or Markers to Rows ........................................ 157
Create Color Themes ........................................................... 160
Delete Custom Color Themes ............................................... 165
Delete Row Characteristics .................................................. 165
Lock Columns in Place ........................................................ 165

5 Set Column Properties
The Column Info Window ..................................................... 167
The Column Info Window ..................................................... 169
About Data Types and Modeling Types .................................. 170
The Short-Integer Format ..................................................... 171
Numeric Formats ............................................................... 172
Row State Columns ............................................................. 175
Fill in Initial Data Values ..................................................... 177
Assign Column Properties ................................................... 178
Formula ............................................................................ 179
Notes .............................................................................. 179
Range Check ................................................................. 179
List Check ................................................................. 180
Missing Value Codes ....................................................... 180
Value Labels ............................................................. 180
Value Scores ............................................................ 181
Value Ordering ........................................................... 181
Value Colors ............................................................ 182
Color Gradient ............................................................ 183
Axis ............................................................. 183
6 Reshape Data
Create Subsets, Sort Data, and More

Create a Subset Data Table .......................... 199
Stratified Subsets ...................................... 201
Create a Subset Data Table from a Report ............... 201

Sort Data Tables ........................................ 202
Stack Columns .......................................... 205
Example of Stacking into One Column ...................... 207
Example of Stacking into More than One Column ........... 208
Split Columns .......................................... 210
Examples of Splitting Columns  .................................................. 212
Transpose Rows and Columns ....................................................... 214
Examples of Transposing Rows and Columns ................................. 216
Concatenate Data Tables .............................................................. 217
Example of Concatenating Data Tables ......................................... 219
Example of Concatenating Data Tables and Table Variables ............ 219
Join Data Tables ........................................................................... 220
Examples of Joining Data Tables ................................................. 224
Update Data Tables ........................................................................ 231
Example of Updating a Data Table ............................................... 233

7 Formula Editor

Construct Formulas ......................................................................... 235
Create a Formula ............................................................................ 237
Reference Columns and Table Variables ....................................... 238
Use Local Variables ....................................................................... 239
Incorporate Parameters .................................................................. 240
Insert Constants ............................................................................ 241
Add Operators ................................................................................. 242
Keypad Reference ........................................................................... 243
Use Functions ................................................................................ 244
Order Expressions in Formulas ...................................................... 247
Build a Formula in Order of Precedence ....................................... 248
Use Formula Editor Options ........................................................... 249
Calculate Derivatives ..................................................................... 249
Simplify Complex Formulas ............................................................ 250
Evaluate Formulas ......................................................................... 250
Ignore Errors .................................................................................. 251
View a Formula's Values from the Formula Editor ....................... 251
View a Formula in JSL ..................................................................... 252
Edit Formulas ................................................................................ 252
Correct Mistakes ............................................................................ 252
Select Expressions ......................................................................... 253
Delete Functions ............................................................................. 253
Cut, Copy, and Paste ................................................................. 254
Click and Drag ................................................................. 254
Customize Formulas ............................................................... 254
Change the Font Size ............................................................... 254
Hide and Show Boxing ............................................................ 255
Change a Formula’s Orientation .................................................... 255
Open and Close Arguments .......................................................... 255
Examples and Tutorials ............................................................... 256
Use Basic Formula Editor Features .................................................. 256
Use Local Variables in a Formula ..................................................... 257
Use the Munger Function ............................................................. 258
Use the Match Conditional Function ................................................... 259
Use the Delete Expression Key ......................................................... 260
Keyboard Shortcuts ........................................................................ 261
Glossary of Terms .......................................................................... 261

8 Summarize Data
The Table Summarize Command ......................................................... 265
Summarize Columns ....................................................................... 267
Create a Summary Table ................................................................. 267
Add a Statistics Column to an Existing Summary Table ......................... 271
Explanation of Statistics ................................................................ 272
Example of Creating a Summary Table ................................................ 274

9 JMP Platforms
Launch and Report Windows ............................................................... 277
Launch Windows ............................................................................ 279
Virtual Columns ............................................................................ 281
Platforms that Support Multithreading .................................................. 286
Navigating Reports .......................................................................... 287
Use the Hand Tool .......................................................................... 288
Access Report Display Options .......................................................... 288
Show and Hide Parts of a Report ......................................................... 289
Combine Several Reports ................................................................ 290
Rename a Title ................................................................................. 290
Customize Axes and Axis Labels ................................................................. 320
Change the Order of Values ................................................................. 326
Customize Tick Marks and Tick Mark Labels ........................................... 326
Add Reference Lines ............................................................................. 329
Add Geographical Images and Boundaries ........................................... 329
Drag and Drop an Image into a Graph .................................................. 330
Extract Data from an Image .................................................................... 332
Add Graphics Elements to a Report ....................................................... 333
Annotations ............................................................................................ 333
Add Shapes ............................................................................................... 334
Add Graphics ........................................................................................... 337
Customize Graphical Elements ............................................................... 337

10 Save and Share Data
Get Your Data Out of JMP .................................................................... 343
Save and Share Data Tables .................................................................... 345
Save as a CSV File .................................................................................... 346
Save as a Text File .................................................................................... 346
Save as a SAS Transport File ................................................................. 347
Save as a SAS Data Set .......................................................................... 348
Save as a Microsoft Excel File ............................................................... 349
Save Data Tables to a Database ............................................................. 350
Replace a Database with a Data Table .................................................... 351
E-mail a Data Table ................................................................................ 351
Save and Share Reports .......................................................................... 351
E-mail a Report ......................................................................................... 353
Save the Report as Interactive HTML .................................................... 353
Save as Flash ............................................................................................ 355
Setting the DPI ......................................................................................... 355
Save Your Analysis as a Script ............................................................... 355
Save Using the Layout Command .......................................................... 355
Save Parts of a Report in a Graphic Format ............................................ 358
Print Reports ........................................................................................... 359
Copy and Paste Reports .......................................................................... 359
JMP Journals ............................................................................................ 360
Create a New Journal ................................................................. 360
Prevent Modifications ................................................................. 361
Append Reports to a Journal ......................................................... 361
Add and Edit Outline Levels ......................................................... 362
Control the Display of Outline Levels .............................................. 363
Add a Graph or Graphic .......................................................... 363
Customize Journal Items ........................................................... 363
Save the Journal in Another Format .............................................. 364
Print a Journal ................................................................. 364
Delete Items from a Journal ......................................................... 365
Example of Making a Journal for a Presentation ..................... 365
Save JMP Sessions ............................................................... 367
Save Sessions Upon Exiting ........................................................ 367
Save Sessions Manually ............................................................... 367
JMP Projects (Windows Only) ................................................... 368
Create a JMP Project .............................................................. 368
Save a JMP Project .............................................................. 369
Close a JMP Project ............................................................... 370
Open a JMP Project ............................................................... 370
Add Items to a JMP Project ......................................................... 370
Customize the Project ............................................................ 371
Fix Broken Links ................................................................. 372
Save a Log Window ............................................................... 373

11 Personalize JMP

Customize Menus, Toolbars, and Add New Features ..................... 375

Personalize Toolbars and Menus on Windows ......................... 377
Change Customization Sets ....................................................... 378
Create Toolbars ................................................................. 380
Create Main Menus ............................................................... 382
Create Menu Items and Toolbar Buttons ..................................... 383
Rearrange Toolbars ............................................................... 386
Copy and Paste Menus, Menu Items, Toolbars, and Buttons ........... 387
Rearrange Custom Menus, Menu Items, and Buttons .................... 389
Delete Custom Items ............................................................. 390
Using JMP

Show and Hide Items .............................................. 391
Import Customizations ........................................... 392
Remove Customizations ........................................... 392
Personalize Toolbars on Macintosh ............................ 393
JMP Add-Ins ......................................................... 395
Manage JMP Add-Ins ............................................... 395

12 JMP Preferences
The Preferences Window ......................................... 397
Overview ........................................................... 399
General ............................................................. 399
Reports ............................................................... 403
Graphs ............................................................... 406
Styles ................................................................. 408
Tables ................................................................. 410
Platforms ............................................................. 414
  Graph Builder Preferences ..................................... 415
Print ................................................................. 416
Text Data Files ..................................................... 418
Windows Specific .................................................. 421
Mac OS Settings ................................................... 424
Fonts ................................................................. 425
Communications .................................................... 427
File Locations ....................................................... 428
Script Editor ........................................................ 429
SAS Integration ...................................................... 432
JMP Updates ........................................................ 435
JSL Debugger ........................................................ 436
Menu Preferences .................................................. 438
Scripting-Only Preferences ...................................... 439

A Formula Functions Reference
Descriptions of Functions in the Formula Editor ............ 441
Row Functions ....................................................... 443
Numeric Functions .............................................................. 445
Transcendental Functions ................................................... 445
Trigonometric Functions ....................................................... 448
Character Functions ............................................................ 449
Character Pattern Functions .................................................. 456
Comparison Functions .......................................................... 459
Conditional Functions .......................................................... 460
Probability Functions ............................................................ 465
Discrete Probability Functions ............................................... 474
Statistical Functions .............................................................. 476
Random Functions ............................................................... 480
Date Time Functions ............................................................. 484
Row State Functions ............................................................. 487
Assignment Functions ........................................................... 492
Parametric Model Functions .................................................. 493
Finance Functions ............................................................... 493

Index
Using JMP .............................................................. 495
Chapter 1
Learn about JMP
Documentation and Additional Resources

This chapter includes the following information:

• book conventions
• JMP documentation
• JMP Help
• additional resources, such as the following:
  – other JMP documentation
  – tutorials
  – indexes
  – Web resources

Figure 1.1 The JMP Help Home Window on Windows
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Formatting Conventions</td>
<td>21</td>
</tr>
<tr>
<td>JMP Documentation</td>
<td>21</td>
</tr>
<tr>
<td>JMP Documentation Library</td>
<td>22</td>
</tr>
<tr>
<td>JMP Help</td>
<td>26</td>
</tr>
<tr>
<td>Additional Resources for Learning JMP</td>
<td>26</td>
</tr>
<tr>
<td>Tutorials</td>
<td>27</td>
</tr>
<tr>
<td>Sample Data Tables</td>
<td>27</td>
</tr>
<tr>
<td>Learn about Statistical and JSL Terms</td>
<td>27</td>
</tr>
<tr>
<td>Learn JMP Tips and Tricks</td>
<td>28</td>
</tr>
<tr>
<td>Tooltips</td>
<td>28</td>
</tr>
<tr>
<td>JMP User Community</td>
<td>28</td>
</tr>
<tr>
<td>JMPer Cable</td>
<td>28</td>
</tr>
<tr>
<td>JMP Books by Users</td>
<td>29</td>
</tr>
<tr>
<td>The JMP Starter Window</td>
<td>29</td>
</tr>
</tbody>
</table>
**Formatting Conventions**

The following conventions help you relate written material to information that you see on your screen.

- Sample data table names, column names, pathnames, filenames, file extensions, and folders appear in *Helvetica* font.
- Code appears in *Lucida Sans Typewriter* font.
- Code output appears in *Lucida Sans Typewriter* italic font and is indented farther than the preceding code.
- **Helvetica bold** formatting indicates items that you select to complete a task:
  - buttons
  - check boxes
  - commands
  - list names that are selectable
  - menus
  - options
  - tab names
  - text boxes
- The following items appear in italics:
  - words or phrases that are important or have definitions specific to JMP
  - book titles
  - variables
- Features that are for JMP Pro only are noted with the JMP Pro icon. For an overview of JMP Pro features, visit [http://www.jmp.com/software/pro/](http://www.jmp.com/software/pro/).

**Note:** Special information and limitations appear within a Note.

**Tip:** Helpful information appears within a Tip.

---

**JMP Documentation**

JMP offers documentation in various formats, from print books and Portable Document Format (PDF) to electronic books (e-books).

- Open the PDF versions from the Help > Books menu or from the JMP online Help footers.
Learn about JMP

JMP Documentation

• All books are also combined into one PDF file, called JMP Documentation Library, for convenient searching. Open the JMP Documentation Library PDF file from the Help > Books menu.

• e-books are available at Amazon, Safari Books Online, and in the Apple iBookstore.

• You can also purchase printed documentation on the SAS website: http://support.sas.com/documentation/onlinedoc/jmp/index.html

JMP Documentation Library

The following table describes the purpose and content of each book in the JMP library.

<table>
<thead>
<tr>
<th>Document Title</th>
<th>Document Purpose</th>
<th>Document Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>Discovering JMP</td>
<td>If you are not familiar with JMP, start here.</td>
<td>Introduces you to JMP and gets you started creating and analyzing data.</td>
</tr>
<tr>
<td>Using JMP</td>
<td>Learn about JMP data tables and how to perform basic operations.</td>
<td>Covers general JMP concepts and features that span across all of JMP, including importing data, modifying columns properties, sorting data, and connecting to SAS.</td>
</tr>
<tr>
<td>Basic Analysis</td>
<td>Perform basic analysis using this document.</td>
<td>Describes these Analyze menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Distribution</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Fit Y by X</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Matched Pairs</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Tabulate</td>
</tr>
<tr>
<td></td>
<td></td>
<td>How to approximate sampling distributions using bootstrapping is also included.</td>
</tr>
</tbody>
</table>


<table>
<thead>
<tr>
<th>Document Title</th>
<th>Document Purpose</th>
<th>Document Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>Essential Graphing</td>
<td>Find the ideal graph for your data.</td>
<td>Describes these Graph menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Graph Builder</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Overlay Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Scatterplot 3D</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Contour Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Bubble Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Parallel Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Cell Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Treemap</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Scatterplot Matrix</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Ternary Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Chart</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Also covers how to create background and custom maps.</td>
</tr>
<tr>
<td>Profilers</td>
<td>Learn how to use interactive profiling tools, which enable you to view cross-sections of any response surface.</td>
<td>Covers all profilers listed in the Graph menu. Analyzing noise factors is included along with running simulations using random inputs.</td>
</tr>
<tr>
<td>Design of Experiments Guide</td>
<td>Learn how to design experiments and determine appropriate sample sizes.</td>
<td>Covers all topics in the DOE menu.</td>
</tr>
<tr>
<td>Document Title</td>
<td>Document Purpose</td>
<td>Document Content</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>-----------------------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Fitting Linear Models</td>
<td>Learn about Fit Model platform and many of its personalities.</td>
<td>Describes these personalities, all available within the Analyze menu Fit Model platform:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Standard Least Squares</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Stepwise</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Generalized Regression</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Mixed Model</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• MANOVA</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Loglinear Variance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Nominal Logistic</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Ordinal Logistic</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Generalized Linear Model</td>
</tr>
<tr>
<td>Specialized Models</td>
<td>Learn about additional modeling techniques.</td>
<td>Describes these Analyze &gt; Modeling menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Partition</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Neural</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Model Comparison</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Nonlinear</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Gaussian Process</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Time Series</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Response Screening</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The Screening platform in the Analyze &gt; Modeling menu is described in Design of Experiments Guide.</td>
</tr>
<tr>
<td>Multivariate Methods</td>
<td>Read about techniques for analyzing several variables simultaneously.</td>
<td>Describes these Analyze &gt; Multivariate Methods menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Multivariate</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Cluster</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Principal Components</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Discriminant</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Partial Least Squares</td>
</tr>
<tr>
<td>Document Title</td>
<td>Document Purpose</td>
<td>Document Content</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>---------------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Quality and Process Methods</td>
<td>Read about tools for evaluating and improving processes.</td>
<td>Describes these Analyze &gt; Quality and Process menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Control Chart Builder and individual control charts</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Measurement Systems Analysis</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Variability / Attribute Gauge Charts</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Capability</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Pareto Plot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Diagram</td>
</tr>
<tr>
<td>Reliability and Survival Methods</td>
<td>Learn to evaluate and improve reliability in a product or system and analyze survival data for people and products.</td>
<td>Describes these Analyze &gt; Reliability and Survival menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Life Distribution</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Fit Life by X</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Recurrence Analysis</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Degradation</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Reliability Forecast</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Reliability Growth</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Reliability Block Diagram</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Survival</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Fit Parametric Survival</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Fit Proportional Hazards</td>
</tr>
<tr>
<td>Consumer Research</td>
<td>Learn about methods for studying consumer preferences and using that insight to create better products and services.</td>
<td>Describes these Analyze &gt; Consumer Research menu platforms:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Categorical</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Factor Analysis</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Choice</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Uplift</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Item Analysis</td>
</tr>
</tbody>
</table>
Learn about JMP

Chapter 1
Using JMP

Additional Resources for Learning JMP

<table>
<thead>
<tr>
<th>Document Title</th>
<th>Document Purpose</th>
<th>Document Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scripting Guide</td>
<td>Learn about taking advantage of the powerful JMP Scripting Language (JSL).</td>
<td>Covers a variety of topics, such as writing and debugging scripts, manipulating data tables, constructing display boxes, and creating JMP applications.</td>
</tr>
<tr>
<td>JSL Syntax Reference</td>
<td>Read about many JSL functions on functions and their arguments, and messages that you send to objects and display boxes.</td>
<td>Includes syntax, examples, and notes for JSL commands.</td>
</tr>
</tbody>
</table>

Note: The Books menu also contains two reference cards that can be printed: The Menu Card describes JMP menus, and the Quick Reference describes JMP keyboard shortcuts.

JMP Help

JMP Help is an abbreviated version of the documentation library that provides targeted information. You can open JMP Help in several ways:

• On Windows, press the F1 key to open the Help system window.
• Get help on a specific part of a data table or report window. Select the Help tool 🕵 from the Tools menu and then click anywhere in a data table or report window to see the Help for that area.
• Within a JMP window, click the Help button.
• Search and view JMP Help on Windows using the Help > Help Contents, Search Help, and Help Index options. On Mac, select Help > JMP Help.
• Search the Help at http://jmp.com/support/help/ (English only).

Additional Resources for Learning JMP

In addition to JMP documentation and JMP Help, you can also learn about JMP using the following resources:

• Tutorials (see “Tutorials” on page 27)
• Sample data (see “Sample Data Tables” on page 27)
• Indexes (see “Learn about Statistical and JSL Terms” on page 27)
Tip of the Day (see “Learn JMP Tips and Tricks” on page 28)
Web resources (see “JMP User Community” on page 28)
JMP Per Cable technical publication (see “JMP Per Cable” on page 28)
Books about JMP (see “JMP Books by Users” on page 29)
JMP Starter (see “The JMP Starter Window” on page 29)

Tutorials
You can access JMP tutorials by selecting Help > Tutorials. The first item on the Tutorials menu is Tutorials Directory. This opens a new window with all the tutorials grouped by category.
If you are not familiar with JMP, then start with the Beginners Tutorial. It steps you through the JMP interface and explains the basics of using JMP.
The rest of the tutorials help you with specific aspects of JMP, such as creating a pie chart, using Graph Builder, and so on.

Sample Data Tables
All of the examples in the JMP documentation suite use sample data. Select Help > Sample Data to do the following actions:
• Open the sample data directory.
• Open an alphabetized list of all sample data tables.
• Find a sample data table within a category.

Sample data tables are installed in the following directory:
On Windows: C:\Program Files\SAS\JMP\<version_number>\Samples\Data
On Macintosh: \Library\Application Support\JMP\<version_number>\Samples\Data
In JMP Pro, sample data is installed in the JMPPRO (rather than JMP) directory.

Learn about Statistical and JSL Terms
The Help menu contains the following indexes:
Statistics Index Provides definitions of statistical terms.
Scripting Index Lets you search for information about JSL functions, objects, and display boxes. You can also edit and run sample scripts from the Scripting Index.
Learn JMP Tips and Tricks

When you first start JMP, you see the Tip of the Day window. This window provides tips for using JMP.

To turn off the Tip of the Day, clear the Show tips at startup check box. To view it again, select Help > Tip of the Day. Or, you can turn it off using the Preferences window. See the Using JMP book for details.

Tooltips

JMP provides descriptive tooltips when you place your cursor over items, such as the following:

- Menu or toolbar options
- Labels in graphs
- Text results in the report window (move your cursor in a circle to reveal)
- Files or windows in the Home Window
- Code in the Script Editor

Tip: You can hide tooltips in the JMP Preferences. Select File > Preferences > General (or JMP > Preferences > General on Macintosh) and then deselect Show menu tips.

JMP User Community

The JMP User Community provides a range of options to help you learn more about JMP and connect with other JMP users. The learning library of one-page guides, tutorials, and demos is a good place to start. And you can continue your education by registering for a variety of JMP training courses.

Other resources include a discussion forum, sample data and script file exchange, webcasts, and social networking groups.

To access JMP resources on the website, select Help > JMP User Community.

JMPer Cable

The JMPer Cable is a yearly technical publication targeted to users of JMP. The JMPer Cable is available on the JMP website:

http://www.jmp.com/about/newsletters/jmpercable/
JMP Books by Users

Additional books about using JMP that are written by JMP users are available on the JMP website:

http://www.jmp.com/support/books.shtml

The JMP Starter Window

The JMP Starter window is a good place to begin if you are not familiar with JMP or data analysis. Options are categorized and described, and you launch them by clicking a button. The JMP Starter window covers many of the options found in the Analyze, Graph, Tables, and File menus.

- To open the JMP Starter window, select View (Window on the Macintosh) > JMP Starter.
- To display the JMP Starter automatically when you open JMP on Windows, select File > Preferences > General, and then select JMP Starter from the Initial JMP Window list. On Macintosh, select JMP > Preferences > Initial JMP Starter Window.
To get you started with JMP, this chapter covers the following topics:

- learn about the initial windows that appear when you start JMP
- understand data tables
- open data files
- manage open windows
- learn about the anatomy of a typical JMP user session

**Figure 2.1** The JMP Home Window on Windows
Contents

Manage JMP Files and Open Windows ................................................. 33
  JMP Home Window on Windows ..................................................... 33
  JMP Home Window on Macintosh ................................................... 36
JMP Starter Window ................................................................. 37
JMP Personalization Window ......................................................... 38
Data Tables ........................................................................... 39
  Data Table Panels ................................................................. 40
  Data Grid ........................................................................... 45
Open Data Files ................................................................. 49
Display and Arrange Open Windows .................................................. 51
View Preview of Data (Windows Only) .............................................. 52
Anatomy of a JMP Session .......................................................... 54
Manage JMP Files and Open Windows

The JMP Home Window provides instant access to open window and files

JMP Home Window on Windows

On Windows, the JMP Home Window appears when you open JMP.

- **Recent Files:** Shows recently opened files. See “Recent Files” on page 34.
- **Window List:** Shows open JMP windows. See “Window List” on page 35.
- **Recent Help:** Shows recently opened Help topics. Click on a topic to open it.
- **Projects:** Shows open JMP projects. See “Projects” on page 35.

**Tip:** If you close a panel and want to reopen it, select View > Home Window Panes and select the panel that you want to open.

Figure 2.2 Example of the JMP Home Window (Windows)

Open the JMP Home Window by selecting View > Home Window or clicking the JMP Home Window button in the lower right corner of most JMP windows. If you cannot see the JMP Home Window button, select View > Status Bars.
Tip: If you prefer to see the JMP Starter or the Window List upon start-up, you can specify that on Windows in the Preferences. Select File > Preferences > General and select an option from the Initial JMP Window list.

JMP Home Window Buttons

The JMP Home Window panels can contain the following buttons:

- The Open Selected button opens the selected files in the Recent Files list.
- The Sort By Name button sorts recent files alphabetically.
- The Filter button filters the types of files that appear in the Recent Files and Window List panels.
- The Clear Filter button clears any filters that are set in the Recent Files and Window List panels, showing all types of files and windows. If this button is dimmed, no filters are selected.
- The New Project button creates a new project.
- The Open Project button opens a project file.
- The Save Selected Project button saves the selected project.
- The Close button closes the panel.

Recent Files

The Recent Files list provides quick access to files that you recently opened.

Keep your favorite files at the top of the list for quick access. Place your cursor over the filename and click the pin icon . To unpin a file, click the pin icon .

You can drag and drop files from the Recent Files list, as follows:

- Into a JMP project to add the file
- Into the JMP Window List to open the file
- Into a Windows folder or on to your desktop to create a copy of the file
- Into applications such as Notepad or Microsoft Word to edit the file

Use the right-click menu to:

- Open a file
- Copy the location path to a file
- Open a file within the folder that contains it
- Sort files alphabetically by name or by most recent
- Remove a file (alternatively, you can select files and press the DELETE key)
• (JSL scripts only) Edit, run, or debug a script
• (Text files only) Change the import method or open as plain text
• Run or edit a JMP application

When you open a non JMP file from the Recent Files list, JMP applies your import preferences to arrange the data. You can right-click on a text file to change the import method or to open the file in a text editing window. Your import preference is bolded in the right-click menu.

Window List

The Window List shows open JMP windows, such as data tables, reports, and scripts. You can open, close, rearrange, and hide JMP windows.

• If you place your mouse pointer over a file in the Window List, a thumbnail appears.
• To open the Window List in its own window, select View > Window List.
• To display windows side-by-side, right-click the selected windows and select Arrange.
• To always automatically display the Window List inside maximized windows, select File > Preferences > Windows Specific and select Dock the Window List in maximized windows.

Use the right-click menu to:

• View a window
• Close a window (alternatively, you can select files and press the DELETE key)
• Close all windows except the currently selected window (if the selected window is a report window, the dependent data table also remains open)
• Move a window to the back
• Hide or unhide a window (hides the window from the Windows taskbar)
• Select all windows, or clear all selections

Projects

In the Projects panel, you can use the project buttons to create a new project, open an existing project, and save a project. Right-click a project to add items to the project and customize the project. For details about projects, see “JMP Projects (Windows Only)” on page 368 in the “Save and Share Data” chapter.

Tip: Select View > Projects to open the project list in a new window.
Rearrange Panels in the Home Window

To rearrange the panels in the Home Window, click and drag the title bar of the panel. Drop the title bar onto a top, bottom, left, or right arrow to position the panel. A blue box indicates where the panel will be placed. To turn the panels into tabs, drag and drop any panel into the middle of the Home Window.

Tip: To put the Home Window back into its original order, select View > Home Window Panes > Revert to Factory Layout.

JMP Home Window on Macintosh

Use the JMP Home window to quickly access JMP files and open windows.

- Open recent files in the Recent Files List.
- Open or close active JMP windows in the Window list.
- Add files to a list of favorites in the Favorites pane.
- Select an open data table from the Current Data Table list.

The two buttons in the upper left corner of the JMP Home window let you manage recent files and favorites.

- Click to show or hide the Favorites list.
- Click to remove files from the Recent Files list.

Open the JMP Home window on Macintosh by selecting Window > JMP Home (Figure 2.3). To view the window each time you open JMP, select JMP > Preferences > General > Home Window.

Figure 2.3 Example of the JMP Home Window (Macintosh)
The JMP Starter window is a good place to begin if you are not familiar with JMP or data analysis. Options are categorized and described, and you launch them by clicking a button. The JMP Starter window covers many of the options found in the Analyze, Graph, Tables, and File menus.

- To open the JMP Starter window, select View (Window on the Macintosh) > JMP Starter.
- To display the JMP Starter automatically when you open JMP, select File > Preferences > General, and then select JMP Starter from the Initial JMP Window list.

Figure 2.4 shows the JMP Starter window for Windows. The Macintosh JMP Starter window is identical.

**Figure 2.4 The JMP Starter Window (Windows)**
JMP Personalization Window

The very first time that you open JMP, the Personalization window appears. This window also appears if you re-install JMP and you do not have an existing preference file.

Figure 2.5  Personalization Window

This window contains two panels:

**Menu Options**  Deselect any menu options that you want to hide from your JMP view.

**General Options**  Select from common general preferences. For more information about these preferences, see “General” on page 399 in the “JMP Preferences” chapter.
Data Tables

In JMP, data points are organized into rows and columns referred to as the data table. A data table has two parts: the data table panels at left and the data grid at right.

Figure 2.6 Parts of a Data Table

The data table has the following characteristics:

- Column names can contain any keyboard character, including spaces, and can be up to 255 characters long.
- The maximum length of the data table's name depends on your computer's operating system.
- Change the default size and font for names and values selecting File > Preferences > Fonts. (On the Macintosh, select JMP > Preferences > Fonts.)
- Column names automatically wrap in the column name area to accommodate the column width that you specify.
- Move column boundaries and enlarge the column to view long values. Adjust widths of all selected columns at once by pressing the ALT key as you drag the double arrow cursor on any of the selected column boundaries.
- The number of rows and columns in a data table is limited only by your computer's memory.
Data Table Panels

Data tables contain three panels:

- Table panel
- Columns panel
- Rows panel

These panels are located on the left of the data grid. They contain information about the table and its contents. Each panel has interactive areas. See Figure 2.7.

Figure 2.7 Interacting with the Data Table Panels

Table Panel

The Table panel contains the following elements:

- Name of the data table
- Icons indicating the table state
- Red triangle menus containing table and script options
- (Optional) Table variables
- (Optional) Table scripts
Table Options

Clicking on the red triangle menu next to the data table name shows these options:

Tables: Contains the same options as the Tables menu. See “Reshape Data” chapter on page 197.

New Table Variable: Creates a new table variable, which can be text or any other constant character value that you always want to be available in the data table. Table variables are normally used to document tables. Using the Formula Editor, you can incorporate table variables into formulas or JSL scripts. See “Use Table Variables” on page 146 in the “Enter and Edit Data” chapter for more information.

Note: To rename a table variable, double-click on it and enter a new name in the Name field.

New Script: Creates a JSL script to save with the data table. Using the Formula Editor, you can incorporate these scripts into formulas. After selecting this command, name the script and type in the value (the JSL commands). After you click OK, the new script is listed in the Table panel and you can click its red triangle menu to run, edit, or delete it. See “Create and Save Scripts” on page 148 in the “Enter and Edit Data” chapter.

Suppress Formula Eval: Turns off the feature that automatically evaluates formulas. You can turn off evaluation and build sections of a formula, and then turn evaluation on to test the formula.

Lock Data Table: Locks the data table so that values cannot be edited or added. You can still run analyses, assign characteristics, add rows and columns, and so on. See “Lock Tables” on page 145 in the “Enter and Edit Data” chapter.

Compress file when saved: Compresses the data table when it is saved. After the data table is saved, a compressed file icon appears next to the data table name in the table panel. See “Compress Tables” on page 145 in the “Enter and Edit Data” chapter.

Note: To save a data table using compression, you must enable saving tables in the extended file format by selecting Preferences > Tables > Save table in extended file format. This preference is selected by default.
Note: You can also configure JMP to always use GZ compression when saving tables by selecting Preferences > General > Save Data Table Columns GZ Compressed.

Note: The Compress file when saved option only decreases the file size. This command does not affect the memory required to analyze the data. To reduce both the file size and memory required for analyzing, use Cols > Compress Selected Columns. See “Compress Selected Columns” on page 195 in the “Set Column Properties” chapter.

Copy Table Script  Copies the script that re-creates the table. To re-create the table, paste the script into a new script and run it.

Rerun Formulas  Re-evaluates all columns containing formulas within the data table.

Script Options
Clicking on the red triangle menu next to a script name shows these options:

Run Script  Runs the script.

Debug Script  Opens the script in the JSL Debugger.

Edit  Opens the script in a window so that you can edit it.

Delete  Deletes the script.

Copy  Copies the script. You can then paste it into the Table panel of another data table.

Additional Options
In the Table panel, you can also do the following actions:

• Double-click a table variable or script name to edit the name and content.

• Click and drag on a table variable or script to rearrange it.

Columns Panel
The Columns panel contains the following information:

• Column options (same options as the Cols menu)

• Total number of columns and number of columns selected in the data table

• A list of columns found in the data table

• Icons indicating each column’s modeling type (see “About Data Types and Modeling Types” on page 170 in the “Set Column Properties” chapter)

• Icons representing characteristics and properties assigned to the columns (not shown, see Figure 2.10)
**Figure 2.9** Example of a Columns Panel

Icons Representing Column Characteristics and Properties

Icons to the right of each column name indicate characteristics and properties the columns contain.

**Figure 2.10** Icons Indicating Column Characteristics and Properties

**Note:** Italics indicate that the column is locked into place. When you scroll horizontally, the column remains visible.

Icons that can appear in the Columns panel are described as follows:

- Indicates that points on plots corresponding to the column are labeled by the value instead of the row number. See “Label Rows and Columns” on page 157 in the “Enter and Edit Data” chapter.
- Indicates that the column is excluded from the calculations. See “Exclude Rows and Columns” on page 155 in the “Enter and Edit Data” chapter.
- Indicates that the column is not included in graphs. See “Hide Rows and Columns” on page 156 in the “Enter and Edit Data” chapter.
- Can be X or Y. Indicates that the column has been assigned the preselected role of x or y. See “Assign a Preselected Analysis Role” on page 194 in the “Set Column Properties” chapter.
- Indicates that the column contains one or more properties. Click to reveal a list of properties the column contains.
Indicates that the values in the column result from a formula. When formula evaluation is suppressed, the icon appears gray. Double-click to view and edit the formula. See “Use Formula Editor Options” on page 249 in the “Formula Editor” chapter.

Indicates that the range check or the list check option is turned on. Click to view and edit the range or list. See “Range Check” on page 179 in the “Set Column Properties” chapter and “List Check” on page 180 in the “Set Column Properties” chapter.

Indicates that the column has been assigned the preselected role of weight. See “Assign a Preselected Analysis Role” on page 194 in the “Set Column Properties” chapter.

Indicates that the column has been assigned the preselected role of frequency. See “Assign a Preselected Analysis Role” on page 194 in the “Set Column Properties” chapter.

**Rows Panel**

The Rows panel contains the following information:

- Row options (same options as the **Rows** menu)
- Total number of rows
- Number of selected (highlighted), excluded, hidden, and labeled rows

**Figure 2.11** Example of a Rows Panel

<table>
<thead>
<tr>
<th>row options</th>
<th>All rows</th>
<th>Selected</th>
<th>Excluded</th>
<th>Hidden</th>
<th>Labeled</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>233</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

Right-click the categories in the Rows panel to select rows, clear the selection, or to create a **data view**.

A data view creates a linked subset of the main data table. For example, if several rows are marked hidden, you might want to open a window that shows you only the hidden rows. Right-click **Hidden** in the Rows panel and select **Data View**.
When using a data view, continue to do most of your editing in the main data table. When you make changes in either the main data table or in the data view, the changes are reflected in both. You can make minor changes (such as changing some data or adding a column) in the data view. However, if you want to make major changes (like adding a formula) you must make those changes in the main data table.

**Data Grid**

The data grid is the main part of the data table that contains your data. Figure 2.13 illustrates how to interact with the data grid. See also “Select Rows” on page 122 in the “Enter and Edit Data” chapter.

**Figure 2.13 Interacting with the Data Grid**

1. Hides or shows the data table panels.
2. Click to deselect any selected columns. To select all columns, hold down the SHIFT key and click.
Context Menu for Columns

Right-clicking in a column heading shows these options:

- **Column Info**  
  Opens the Column Info window. See “Assign Column Properties” on page 178 in the “Set Column Properties” chapter.

- **Column Properties**  
  Contains a list of column properties. Select one to open the Column Info window and apply it to the column. This list is also available from the Column Info window. See “Assign Column Properties” on page 178 in the “Set Column Properties” chapter.

- **Modeling Type**  
  Contains a list of modeling types. Select one to apply it to the column. See “About Data Types and Modeling Types” on page 170 in the “Set Column Properties” chapter.

- **Preselect Role**  
  Contains a list of roles. Select one to apply it to the column. See “Assign Column Properties” on page 178 in the “Set Column Properties” chapter.

- **Formula**  
  Opens the Formula Editor. See the “Formula Editor” chapter on page 235.

- **Color Cells**  
  Provides a color palette. Select a color to apply it to the selected cells in the column. To revert back to the original color, select black.
Use Value Labels  (Applicable only if the Value Labels property is set) Shows or hides value labels in the data table.

Label/Unlabel  Labels or unlabels selected columns in all plots. See “Label Rows and Columns” on page 157 in the “Enter and Edit Data” chapter.

Scroll Lock/Unlock  Scroll lock locks a column in place so that when you scroll horizontally, the column remains visible. See “Lock Columns in Place” on page 165 in the “Enter and Edit Data” chapter.

Hide/Unhide  Hides or shows selected columns in all plots and graphs. See “Hide Rows and Columns” on page 156 in the “Enter and Edit Data” chapter.

Exclude/Unexclude  Excludes or includes selected columns from analyses. See “Exclude Rows and Columns” on page 155 in the “Enter and Edit Data” chapter.

Data Filter  Opens the Data Filter. See “The Data Filter” on page 296 in the “JMP Platforms” chapter.

Sort  Sorts all of the rows in the table by the values in the selected column. You can choose to sort the rows in ascending or descending order.

Delete Columns  Deletes all selected columns.

Copy Column Properties  Copies all of the column properties for the selected column.

Paste Column Properties  Pastes all of the copied column properties into the selected column.

Context Menu for Rows

Right-clicking in a row heading shows these options:

Exclude/Unexclude  Excludes or includes selected rows from analyses. See “Exclude Rows and Columns” on page 155 in the “Enter and Edit Data” chapter.

Hide/Unhide  Hides or shows selected rows in all plots and graphs. See “Hide Rows and Columns” on page 156 in the “Enter and Edit Data” chapter.

Label/Unlabel  Labels or unlabels selected rows in all plots. See “Label Rows and Columns” on page 157 in the “Enter and Edit Data” chapter.

Colors  Provides a color palette. Select a color to apply it to the selected rows. The color is used in plots and graphs. See “Assign a Color to Rows” on page 158 in the “Enter and Edit Data” chapter.

Markers  Provides a palette of markers or symbols. Select a marker to apply it to the selected rows. The marker is used in plots and graphs instead of points. See “Add Markers to Rows” on page 158 in the “Enter and Edit Data” chapter.

Color Rows by Row State  Colors the row the same as the current row state color. For more details, see “Assign Colors or Markers to Rows Based on Column Values” on page 158 in the “Enter and Edit Data” chapter.
Select Matching Cells  Selects rows in the active data table with values that match the selected row(s).

Invert Selection  Selects all previously deselected rows, and deselects all currently selected rows.

Clear Row States  Clears all active row states in the data table. All rows become included, visible, unlabeled, and show in plots as black dots. It does not affect row states saved in row state columns.

Delete Rows  Removes all selected rows from the data table. Use the Undo command on the Edit menu to undo an accidental deletion. See “Delete Rows and Columns” on page 132 in the “Enter and Edit Data” chapter.

cursor forms
The cursor takes different forms, depending on its location in the data grid.

Arrow Cursor  The standard arrow cursor appears in the following locations:

- In the panels area to the left of the data table
- In the triangular rows and columns area, located in the upper left corner of the data grid
- In the middle or bottom of a column heading

You can perform the following actions with the arrow cursor:

- To select a column using the arrow cursor, click its name in the Columns panel.
- Double-click a column name in the Columns panel to edit it. Or, in the column heading, double-click on the column name to edit it.
- Click the triangular areas in the upper left corner of the data grid to deselect rows and columns.

Selection (Large Plus) Cursor  When the cursor is at the top of a column heading, or in a row number area, it becomes a large plus, indicating that you can select rows or columns. When you click, that row or column is selected and highlighted. Click and drag to select multiple rows or columns, and hold down the CTRL key and click to select discontiguous rows or columns.

- Double-click a column heading area to see the Column Info window for that column.
- Select a column to change the column name. The column highlights. Begin typing (if it is not in a locked column or locked data table).
- Double-click the row number area to edit the rows using the Row Editor.

I-beam Cursor  When you select editable text, the cursor becomes a standard I-beam. To edit text, position the I-beam within highlighted text. Click to mark an insertion point, or drag to select text for replacement.
Double Arrow Cursor ➡️ The cursor changes to a double arrow when it is on a column or a panel boundary. Drag this cursor left or right to change the width of a column or panel. Changing the width of a column does not affect the column field width specified in the Column Info window (accessed by double-clicking a column name).

**Note:** You can adjust widths of all selected columns at once by pressing the ALT key as you drag the double arrow cursor on any of the selected column boundaries.

List Check Cursor ⬇️ The cursor changes form when you move the mouse over values in columns that have data validation in effect. It becomes a small, downward-pointing arrow on a column with list checking. When you click, the value is highlighted and the cursor becomes the I-beam. Enter or edit data as usual with any values defined as valid text or valid numbers. See “List Check” on page 180 in the “Set Column Properties” chapter, for details.

Pointer Cursor 🔖 The cursor changes to a pointer over these objects:
- Red triangle menus for options
- Triangular disclosure buttons that open or close panels
- Data table titles for editing
- Table script titles for opening
- Modeling type icons for changing

Open Data Files

**Note:** For more details about opening files, see the “Import Your Data” chapter on page 59.

To open a data file, select **File > Open** and select the file type. Some file types have additional features and options that appear in the Open Data File window. See Table 2.1.

Tips:
- Windows only: To open the same file type every time, select the **Select this filter the next time this window is invoked** check box.
- Windows only: Open a file by dragging it onto the JMP Home Window.
- To change which directory the **File > Open** command looks in, see “File Locations” on page 428 in the “JMP Preferences” chapter.
- To quickly access a directory that you frequently use, add a shortcut to your Favorites folder by clicking this button: . Then open your Favorites folder by clicking this button: .
Table 2.1  Additional Features and Options by File Type

<table>
<thead>
<tr>
<th>File Type</th>
<th>Additional Features and Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>JMP Data Tables</td>
<td>Table notes, the number of columns (Cols), and the number of rows appear. Use the Select Columns option to select which columns are imported into the data table. On Windows, click the arrow next to Open and then use the Select Columns option to specify which columns are imported into the data table. On Macintosh, you can select which columns to import after you click Open.</td>
</tr>
<tr>
<td>Excel Files</td>
<td>• Convert the first row into column headings. • If the file includes multiple worksheets, specify which worksheets to import. Click the arrow next to Open and then use the Open Selected Worksheets option.</td>
</tr>
<tr>
<td>Text Files</td>
<td>• To automatically determine data arrangement, select one of the following options: – Open as data using preferences – Open as data using a best guess – (Windows only) Open as plain text into a script window • To manually specify data arrangement, select the Data with preview option. See “Text Import Preview Options” on page 69 in the “Import Your Data” chapter.</td>
</tr>
<tr>
<td>SAS Data Sets (options are for Windows only)</td>
<td>• Use SAS variables for column names • Enter a password when you open a password-protected data set. • (SAS Transport files only) Select columns before opening</td>
</tr>
<tr>
<td>SPSS Data Files</td>
<td>Use SPSS variable or label names for column names.</td>
</tr>
</tbody>
</table>
In JMP, typically you have several windows open at once (for example, data tables, reports, and the JMP Home Window). JMP provides several ways to arrange and display these open windows.

On Windows:

- Press the CTRL + TAB keys to switch between windows.
- Use the Reveal feature (F9 or Window > Reveal). See “Using the Reveal Feature” on page 52.
- Use the options in the Window menu. Note that Arrange options are also available using the Arrange Menu in the bottom right corner of most windows.
- To display the JMP Home Window, click the JMP Home Window button in the lower right corner of most windows, or hold down CTRL and press 1.
- To show the data table for a report, click View Associated Data button in the bottom right corner of the report.

Tip: If you cannot see the Arrange Menu, JMP Home Window, and View Associated Data buttons, select View > Status Bars.

- To open an associated report when you are viewing a data table, double-click the thumbnail preview of the report in the bottom pane. To enlarge the preview, place your cursor over the thumbnail. See Figure 2.14.
On Macintosh:

- Use the options in the Window menu.
- Use the Expose feature (F9 or F3).

**Using the Reveal Feature**

On Windows, press F9 to use the Reveal feature. The Reveal feature shows a top-level window with thumbnails of all open JMP windows.

- Click on a window to activate it.
- Press the spacebar to turn on Preview mode, where a full-sized view of the thumbnail under the cursor appears in the center of the screen.
- By default, the windows are ordered to match the original ordering on the screen in a top-down, left-to-right order. Press S to sort the thumbnails by name.
- To exit the Reveal feature, press F9, ESC, or ALT+TAB and select another application.

**View Preview of Data (Windows Only)**

For some JMP file types, you can use Windows Explorer’s preview pane to view a snapshot of the selected file. This feature works for JMP data tables, journals, and scripts.

To view a preview of a JMP file:

1. In Windows Explorer, navigate to the file location and select the file to preview.
2. Select to **Show the preview pane** button.

The preview pane shows a portion of the selected file.

**Figure 2.15 Data Table Preview Pane**
Anatomy of a JMP Session

Figure 2.16 Anatomy of a Typical JMP Session on Windows

JMP Home Window Actions
Your files, windows, projects, and recent help can be accessed and managed from the Home Window. See “Manage JMP Files and Open Windows” on page 33.
**Data Table Actions**

You can enter, view, edit, and manipulate data using data tables. In a data table, each variable is a column, and each observation is a row. See “Data Tables” on page 39.
**Figure 2.18 Data Table Actions**

Launch platforms from the Analyze and Graph menus.

Click on a red triangle menu to access options.

Double-click a thumbnail to see associated reports.

Right-click in the row or column area to access options.

**Launch Window Actions**

Specify your analysis using the launch window for the type of analysis that you want to run. For example, Figure 2.16 shows the Distribution launch window. See “Launch Windows” on page 279 in the “JMP Platforms” chapter.
Figure 2.19 Launch Window Actions

(Optional) Click on a red triangle menu to access column options.

1. Select a column.
2. Click a button to assign the column to a role.
3. Click OK to launch the analysis.

Figure 2.20 Report Window Actions

Place your cursor over the blue bar to reveal the main menu and toolbars.

Click on a red triangle menu to access options.
Click on a bar or point to highlight the corresponding rows in the data table.
Right-clicking on areas in the report window provides additional options.
This chapter covers the following topics:

- How to import data into JMP, such as text files, SPSS files, SAS data, and so on
- How to transfer Excel data into a JMP data table
- How to read in real-time data
- How to create a new data table

Figure 3.1 Importing a Text File
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>About Importing Data to JMP</td>
<td>61</td>
</tr>
<tr>
<td>Import Microsoft Excel Files</td>
<td>62</td>
</tr>
<tr>
<td>Import Text Files</td>
<td>67</td>
</tr>
<tr>
<td>Text Import Preview Options</td>
<td>69</td>
</tr>
<tr>
<td>Open a Text File in a Text Editing Window</td>
<td>73</td>
</tr>
<tr>
<td>Import Text from the Script Window</td>
<td>75</td>
</tr>
<tr>
<td>Import Remote Files and Web Pages</td>
<td>75</td>
</tr>
<tr>
<td>Import SPSS Files</td>
<td>77</td>
</tr>
<tr>
<td>Import Data from SAS</td>
<td>78</td>
</tr>
<tr>
<td>Import SAS Data Sets</td>
<td>79</td>
</tr>
<tr>
<td>Create SAS Transport Files in SAS</td>
<td>81</td>
</tr>
<tr>
<td>Connect to SAS</td>
<td>82</td>
</tr>
<tr>
<td>Open SAS Data Sets through a SAS Server</td>
<td>87</td>
</tr>
<tr>
<td>Run Stored Processes</td>
<td>95</td>
</tr>
<tr>
<td>Submit SAS Code</td>
<td>96</td>
</tr>
<tr>
<td>Generate ODS Results</td>
<td>97</td>
</tr>
<tr>
<td>Retrieve Generated SAS Data Sets</td>
<td>98</td>
</tr>
<tr>
<td>Import Data from R</td>
<td>100</td>
</tr>
<tr>
<td>Import Data Using the Excel Add-In</td>
<td>101</td>
</tr>
<tr>
<td>Transfer Excel Data to a JMP Data Table</td>
<td>101</td>
</tr>
<tr>
<td>About the JMP Add-In for Excel</td>
<td>102</td>
</tr>
<tr>
<td>Uninstall the Excel Add-In</td>
<td>103</td>
</tr>
<tr>
<td>Uninstall Previous Versions of the Excel Add-In</td>
<td>103</td>
</tr>
<tr>
<td>Import Data from a Database</td>
<td>103</td>
</tr>
<tr>
<td>Open Data from a Database</td>
<td>104</td>
</tr>
<tr>
<td>Retrieve Data Using SQL Statements</td>
<td>106</td>
</tr>
<tr>
<td>Structured Query Language (SQL): A Reference</td>
<td>107</td>
</tr>
<tr>
<td>Use the WHERE Clause Editor</td>
<td>111</td>
</tr>
<tr>
<td>Read in Real-Time Data</td>
<td>113</td>
</tr>
<tr>
<td>Create New Data Tables</td>
<td>114</td>
</tr>
</tbody>
</table>
About Importing Data to JMP

You can import many file formats into JMP and save them as data tables. JMP opens many files by default. The file formats which JMP does not support by default require specific Open Database Connectivity (ODBC) drivers.

The Following File Formats Are Supported by Default:

- Comma-separated (.csv)
- .dat files that consist of text
- ESRI shapefiles (.shp)
- Flow Cytometry versions 2.0 and 3.0 (.fcs)
- HTML (.htm, .html)
- MATLAB Portable Worksheet (.mtp)
- Microsoft Excel 1997–2003 (.xls)
- Microsoft Excel 2007 through 2013 (*.xlsx, *.xlsm) (Windows without an ODBC driver installed)
- Minitab worksheets (.mtp)
- Plain text (.txt)
- R (.r)
- SAS transport (.xpt, .stx)
- SAS versions 7–9 on Macintosh (.sas7bdat)
- SAS versions 7–9 on Windows (.sas7bdat, .sas7bxat)
- SPSS files (.sav)
- Tab-separated (.tsv)
- Teradata database (.trd)
- xBase data files (.dbf)

Notes on SAS support:

On Windows, you can open SAS data sets directly through the File > Open command. Another option is connecting to a SAS server by selecting File > SAS > Browse Data. See “Import SAS Data Sets” on page 79 for details about opening SAS data sets directly. See “Open SAS Data Sets through a SAS Server” on page 87 for details about connecting through a SAS server.

On Macintosh, you cannot connect to a SAS server. However, opening and saving .sas7bdat files is supported, along with transferring .sas7bdat files between other systems that have SAS installed.
Import Microsoft Excel Files

Microsoft Excel files are converted to data tables in JMP. The header row becomes column headers, data in merged cells can be displayed in separate cells, and other spreadsheet features are preserved.

On Windows, the spreadsheet opens in the Excel Import Wizard. JMP detects how the data is structured and provides a preview of the data table. You can then modify the settings before importing the data. For example, indicate which row the data begins on and whether the spreadsheet contains column headers or hidden cells. .xls, .xlsm, and .xlsx formats are supported on Windows.

On Macintosh, you import Excel files (.xls) and select one or more worksheets to import from a spreadsheet. This is also an option on Windows if you would rather not use the wizard. See “Import a Microsoft Excel File Directly” on page 66 for details.

Preview and Import the Microsoft Excel Data (Windows)

Before you import a spreadsheet, it is helpful to know whether the spreadsheet includes hidden or merged cells. In the wizard, you can then exclude hidden columns or rows. Another option is to duplicate the data that were previously merged in the spreadsheet.
To import a Microsoft Excel file that contains several worksheets, follow these steps:

1. Open Team Results.xlsx in Microsoft Excel. The file is located in the JMP Samples/Import Data folder.
   
   Note the rows and columns on which the data begin. The spreadsheet also contains two worksheets. In this example, you import the Ungrouped Team Results worksheet (Figure 3.2).

   **Figure 3.2 Team Results.xlsx Spreadsheet**

   ![Team Results.xlsx Spreadsheet](Image)

2. Open Team Results.xlsx in JMP. (Select File > Open, select the spreadsheet, and then click Open).
   
   The spreadsheet opens in the Excel Import Wizard, where a preview of the data appears along with import options (Figure 3.3).

   **Figure 3.3 Initial Data Preview**

   ![Initial Data Preview](Image)
Text from the first row of the spreadsheet are column headings. However, you want text in row 3 of the spreadsheet to be converted to column headings.

3. Next to Column headers start on row, type 3 and press Enter. The column headings are updated in the data preview. The value for the first row of data is updated to 4 (Figure 3.4).

4. Save the settings only for this worksheet:
   - Deselect Use for all sheets in the lower left corner of the window.
   - Select Ungrouped Team Results in the upper right corner of the window.

Figure 3.4 Selecting the Column Header Row

5. Click Next to change other import settings.

6. To remove the empty Column 5, type 4 next to Data ends with column, and then press Enter. The data preview is updated as shown in Figure 3.5.
7. Click **Import** to convert the spreadsheet as you specified (Figure 3.6).

**Figure 3.5** Specifying the Last Column

**Figure 3.6** Final Data Table

**Tips:**

- JMP can remember your previous changes each time you import a spreadsheet, even after closing and reopening JMP. This feature is very helpful when you want to reimport the same spreadsheet several times and experiment with options. To clear those changes when you import a different spreadsheet, click **Restore Default Settings**.
- Your import settings are saved in a data table script named Source. To reimport the spreadsheet using the same settings, run the script. The script includes the path to the spreadsheet, so make sure that other users have access to that location if necessary.
Import Your Data

Chapter 3
Import Microsoft Excel Files

• As you experiment with settings for a large spreadsheet, the data preview might be slightly delayed. To speed up the preview, deselect Update settings on any change on the first wizard window. Modify the settings and then click Update now to refresh the data preview.

• You can combine two worksheets from the same spreadsheet into one data table. The column names are matched on import, so the order of the columns is irrelevant. See “Concatenate Data Tables” on page 217 in the “Reshape Data” chapter for more information about how tables are concatenated.

Import a Microsoft Excel File Directly

When you open a Microsoft Excel file on Windows, the file opens in the Excel Import Wizard. This option is helpful when the structure of data in the spreadsheet is irregular. For example, you might want to exclude hidden columns or convert text in the third row to column headings.

When you open a Microsoft Excel file on Macintosh (and outside the Excel Import wizard on Windows), JMP automatically detects the best way to format data. JMP preferences also determine how data is imported. For example, JMP can convert the first row to column headings.

JMP also opens Excel files from Web sites that do not require you to log in. On Windows, follow the procedure in this section. On Macintosh, use the File > Internet Open command. See “Import Remote Files and Web Pages” on page 75 for more information.

Tip: To always open Microsoft Excel files directly, change the Excel Open Method preference. See “General” on page 399 in the “JMP Preferences” chapter for details about Microsoft Excel preferences.

To open a Microsoft Excel file (Windows):

1. Select File > Open.
2. Select the Excel Files file type, select the file, or enter the URL.
3. Click the Open button arrow, and then select Open Selected Worksheets.
4. (Optional) To convert text in the first row to column headings, select Always next to Always enforce Excel Row 1 as labels. If you do not want to import specific worksheets, click Open.
5. (Optional) To open specific worksheets, click the Open button arrow, select Open Selected Worksheets, select one or more worksheets, and then click OK.

You can also click Select All if you change your mind and want to import all worksheets.
To open a Microsoft Excel file (Macintosh):

**Note:** If the filename is grayed out, the required ODBC driver is not installed, so the file type is not supported. 64-bit JMP requires a 64-bit ODBC driver.

1. Select **File > Open**.
2. Select the file.
3. (Optional) To convert text in the first row to column headings, select **Use Excel Labels as Headings**.
4. (Optional) To open specific worksheets, select **Select Individual Excel Worksheets**.
5. Click **Open**.
   
   If you chose to open specific worksheets, select those worksheets from the list, and then click **OK**. You can also click **Select All** if you change your mind and want to import all worksheets.

### Import Text Files

You can open text files with the extensions `.txt`, `.csv`, and `.tsv`, and the text is converted to a data table. Files with the `.dat` extension that consist of text are also supported. Text files can be delimited using almost any character, or they can be fixed-width files.

**To adjust import settings, choose from one of the following options:**

- **Select File > Preferences > Text Data Files** to change the import settings so that JMP determines the best way to structure and format the data table.
- Manually select the import settings as you open the file (described in this section).
- Open the file in the Script Editor, edit the content, and then import the content. This option is helpful when you need to add text delimiters or modify the text.

**To import a text file:**

1. Select **File > Open**.
2. On Windows, you can set the file type to **Text Files**.
3. Select the text file that you want to open.
   
   For information about the options, see Table 3.1.
Table 3.1 Opening Text Files

<table>
<thead>
<tr>
<th>Automatically Determining Data Arrangement</th>
<th>Manually Specifying Data Arrangement</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Windows</strong></td>
<td></td>
</tr>
<tr>
<td>1. Select File &gt; Open.</td>
<td>1. Select File &gt; Open.</td>
</tr>
<tr>
<td>2. From the list next to File name, select Text Files.</td>
<td>2. From the list next to File name, select Text Files.</td>
</tr>
<tr>
<td>3. To use the import rules from the preferences, select Data, using Text Import preferences. (See “Text Data Files” on page 418 in the “JMP Preferences” chapter.) To have text import use its best guess to arrange the data, select the Data, using best guess option. (Optional) Select the Select this filter the next time this dialog is invoked option to apply the filter that you chose by default.</td>
<td>3. Select Data with Preview next to Open at the bottom of the window.</td>
</tr>
<tr>
<td>4. Select the file that you want to open.</td>
<td>4. Select the file that you want to open.</td>
</tr>
<tr>
<td>5. Click Open.</td>
<td>5. Click Open.</td>
</tr>
<tr>
<td><strong>Tip:</strong> The JMP Home window provides a shortcut to the above steps if you recently opened the file. Right-click the file in the Recent Files list and select Import (Preferences) or Import (Best Guess). (Your import preference is bolded in the right-click menu.)</td>
<td>6. Complete the Text Import window. See “Text Import Preview Options” on page 69, for details.</td>
</tr>
<tr>
<td></td>
<td>7. Click Import.</td>
</tr>
<tr>
<td></td>
<td><strong>Tip:</strong> The JMP Home window provides a shortcut to the above steps if you recently opened the file. Right-click the file in the Recent Files list and select Import (Preview).</td>
</tr>
</tbody>
</table>
Using JMP Import Text Files

Note: On Windows, JMP can open text files in your computer’s default text editor. Select File > Open, and then select All Files (*.*) from the File name list. Select the text file, and then select Use default program to open. Uncheck to open as text.

For details about importing text from a Script window, see “Import Text from the Script Window” on page 75.

Text Import Preview Options

When you open a text file that JMP supports, JMP can show a preview of the text before opening the file as a data table. This option lets you manually arrange and format the data. For example, you can specify the end-of-line character or strip quotation marks.

JMP detects the file’s structure and shows options for importing text with either delimiters or fixed width fields. If JMP chooses the wrong file structure, click the Delimited fields or Fixed width fields radio button to import the data as the correct format. (For example, the fixed width window might appear when your file is actually delimited.)

The text import preview options are shown in Figure 3.7 and Figure 3.8.

Table 3.1 Opening Text Files (Continued)

<table>
<thead>
<tr>
<th>Automatically Determining Data Arrangement</th>
<th>Manually Specifying Data Arrangement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Macintosh</td>
<td></td>
</tr>
<tr>
<td>1. Select File &gt; Open.</td>
<td>1. Select File &gt; Open.</td>
</tr>
<tr>
<td>2. Select the file that you want to open.</td>
<td>2. Select the file that you want to open. From the Open As field, select Data (Using Preview).</td>
</tr>
<tr>
<td>3. From the Open As field, select Data (Best Guess) or Data (Using Preferences).</td>
<td>3. Click Open.</td>
</tr>
<tr>
<td>4. Click Open.</td>
<td>4. Complete the Text Import Preview window. See “Text Import Preview Options” on page 69, for details.</td>
</tr>
<tr>
<td></td>
<td>5. Click Import.</td>
</tr>
</tbody>
</table>
Figure 3.7  Text Import Preview for Fixed Width Files
**Figure 3.8** Text Import Preview for Delimited Files

- **Charset**  Select the character set used in the imported file, or let JMP detect the character set. If incorrect characters are displayed in the imported file, open the file again and select another character set.

- **End of Field**  (Available only in the Delimited Import window) Select the check boxes beside the character that marks the end of a field. Alternatively, select the check box beside **Other** and enter a character if the appropriate character is not listed.

- **End of Line**  (Available only in the Delimited Import window) Select the check boxes beside the character that marks the end of a line (row). Alternatively, select the check box beside **Other** and enter a character if the appropriate character is not listed. Note that when JMP finds double quotation marks, the delimiter rules change to look for an end double quotation mark. Other text delimiters, including spaces embedded within the quotes, are ignored and treated as part of the text string.

- **File contains column names on line**  Tell JMP where to find data to use as column names. For example, if the column names in your text file are on line (row) 3, select this option and type 3 in the check box. Otherwise, JMP uses the data in the first line of the imported file as the column name in the JMP data table or takes the first line as data.

- **Data starts on line**  Specify the number of the first line that contains data.
**Number of Lines**  Specify the number of lines (rows) that you want to import.

**Strip enclosing quotation marks**  Available only on fixed-width imports. Select this check box when you want JMP to remove quotation marks that enclose data in the text file.

**Two-digit year rule**  Specify how year numbers are displayed. Select the 100-year range in which your dates fall. For example, if the earliest date is 1979, select 1970-2069. If the earliest date is 2012, select 2000-2099. If dates span centuries, you must recode the dates with four-digit years before importing the data.

**Recognize apostrophe as quotation mark (not recommended)**  (Available only in the Delimited Import window). Use this option only if your data comes from a nonstandard source that places apostrophes around data fields rather than quotation marks.

When you are finished selecting the settings, click **Next**. The next window shows each column's modeling type. To change the default modeling types, do one of the following:

- Click on the data type icon to change the data type from numeric ( ) to character ( ). Clicking the icon cycles between the modeling type and exclude ( ). Exclude means that the column is not imported.
- To change a numeric column’s data format, select the format from the red triangle menu.
- Click on the column heading to modify the text.

The top of the Text Import window shows a preview of the text file as it appears when imported into a JMP data file. Click the **Import** button to import the data.

**Figure 3.9**  Text Import Preview Window with Column Options

6. When you are finished, click **Import** to complete the text import.
Open a Text File in a Text Editing Window

You can open a text file in a Script window, where you edit the text. Then you can import the text as a data table. This feature is helpful when you want to reformat the text before importing it as a data table. For example, you might need to insert the correct delimiters or modify the text.

Another option is opening a JMP add-in definition (.def) file as text and then editing it in a Script window.

To open a text file in a text editing window (Windows):

Files that you recently opened are listed in the JMP Home window. For most files, right-click the text file and select Open as Plain Text to open the file in a text editing window. JMP add-in definition files cannot be opened as plain text from the JMP Home window.

When you are opening the file for the first time, follow these steps:
1. Select File > Open.
2. Do one of the following:
   - To open a JMP add-in definition file as text, select All JMP Files or JMP Add-In Files from the list next to File name. Click the Open button arrow, and then select Open as Plain Text. The file opens in a Script window. Skip the remaining steps.
   - To open other text files, select Text Files from the list next to File name.

Figure 3.10 Select Text Files
3. (Optional) To set the default option file type to Text Files, select the check box beside Select this filter the next time this dialog is invoked.

4. Select the file.

5. Select Plain text into Script window next to Open as.

6. Click Open.

   The text appears in a Script window.

To open a text file in a text editing window (Macintosh):

1. Select File > Open.

**Figure 3.11 Opening a Text Document on the Macintosh**

2. Select the file.

3. Select Text from the Open As list.

4. Click Open.

   The text appears in a Script window.

For details about converting the text to a data table, follow step 3 in “Import Text from the Script Window” on page 75.
Import Text from the Script Window

You can import text from the Script window as a data table. The text can be in a table format (for example, from a Microsoft Word document or Web page) or in plain text format. This feature is helpful when you want to reformat the text before importing it as a data table. For example, you might need to insert the correct delimiters or modify the text.

JMP uses the import settings in the preferences to determine how to structure and format the text. Some options include removing quotation marks around text and specifying the rows that contain column headings and data. See “Text Data Files” on page 418 in the “JMP Preferences” chapter for details.

Note: You can also import an entire Web page as a data table. See “Import Remote Files and Web Pages” on page 75 for details.

This section describes how to import text that you paste into the Script window. For details about opening a text file in the Script window, see “Open a Text File in a Text Editing Window” on page 73.

To import text from the Script window:

1. Open a new Script window in JMP by selecting File > New > Script (Windows) or File > New > New Script (Macintosh).
2. Copy and paste the text into the Script window.
3. Do one of the following:
   - To import all text from the Script window, select File > Import as Data (Windows) or Edit > Import as Data (Macintosh).
   - To import specific text, select the text, and then select File > Import as Data (Windows) or Edit > Import as Data (Macintosh).

   The text is imported into a JMP data table.

Import Remote Files and Web Pages

You import data from Internet sites, intranet sites, FTP sites, or other computers by selecting File > Internet Open. The file paths begin with the Uniform Resource Locators (URLs) http, ftp, or file; a drive letter; or the path to a network drive (relative or absolute).

You also use this feature to import a Web page on a local or network drive as a data table. Once the data table is created, there is a script called Source that you can run to re-import and refresh the data. If you open a Web page by selecting File > Open, the page opens in a browser, not as a data table.
SAS stored process reports open in an HTML view. From that view, you can import the file as a data table.

JMP inserts the location of the original data as a note in the data table. For example, the path Z:\example.html is included as a note when you import example.html from the Z drive.

To open a remote file:
1. Select **File > Internet Open**. The window shown in Figure 3.12 appears.

**Figure 3.12** Internet Open Window

2. Enter the URL.
3. Click the list under **Open As**, and select the option that specifies how you would like JMP to display the imported data:
   - **Data** Imports the file as a data table.
   - **Web page** Opens the Web page in a browser. (Select this option to import data generated by Web page scripts and server-side requests.)
   - **Text** Opens the file in a JMP Script window. In an HTML file, the HTML tags of a .html file are displayed.
4. Click **OK**.
   One of the following occurs:
   - The file opens as you specified.
   - If you imported a Web page as data, a window appears that lists all tables on the page. Select the table or tables that you want to open, and then click **OK**. Each table opens in a new data table.
   - If you imported a Web page as a Web page, select **File > Import Data as Data Table** in the browser. Select the table or tables that you want to open, and then click **OK**. Each table opens in a new data table.
   - If the file is on an FTP server, the window in Figure 3.13 appears.

**Figure 3.13** FTP Login Window
5. For an anonymous account, click OK. For an authenticated login, enter your user ID and password. The file then opens as you specified.

**Note:** Some anonymous FTP servers require a user ID. If the data table does not open, try typing either ftp or anonymous in the **User ID** text box. Leave the **Password** text box empty and click OK.

By default, SAS stored processes open reports in an HTML view.

To open a SAS stored process report as a data table:

1. In the HTML view, select **File > Import Table as Data Table.**
   A window appears that lists the tables found in the Web page.
2. Select the table or tables that you want to import.
3. Click OK.
   Each table is opened as a new data table.

See “Run Stored Processes” on page 95 for more information about stored process reports.

---

**Import SPSS Files**

JMP opens SPSS files as data tables and maintains several SPSS features:

- General numeric and character data with minimal formatting are supported.
- SPSS date, datetime, and time formats are supported.
- By default, labels are converted to column headings. When you select this option, and the data contains no labels, the columns are named **Column 1, Column 2, and so on.**
  You also have the option of selecting the conversion method for column headings when opening an SPSS file. The method that you select then overrides the preferences.
  To change the default conversion method, select **File > Preferences** (or **JMP > Preferences** on Macintosh). On the General page, deselect **Use SPSS labels for column names during import.** Variable names are then imported automatically as column headings.
- The value labels that you defined in the SPSS file are saved as **Value Labels** column properties. The value label then appears in each data table cell instead of the original value. For details about Value Label properties, see “Value Labels” on page 180 in the “Set Column Properties” chapter.

SPSS can assign certain values in a variable to be treated as missing for analyses. For example, the value 64 could be regarded as missing for a **Height** variable. Then, the calculation of the distribution of height would ignore values of 64. When you import SPSS into JMP, these values are included in the **Missing Value Codes** column property for the appropriate variable.
At the time of publication, custom currency formats selected in an SPSS file are not maintained on import. In addition, JMP does not read SPSS data that contains double-byte characters, such as non-Unicode Japanese characters.

**Note:** As with importing other files, you might experience a delay when opening and saving large SPSS files.

**To open an SPSS file (Windows):**
1. Select **File > Open**.
2. From the list next to **File name**, select **SPSS Data Files (*.sav)**.
3. Select the SPSS file.
4. (Optional) To specify the column headings, select one of the following **Set JMP column names from** options:
   - **SPSS Labels** creates column headings from SPSS labels.
   - **SPSS Variable Names** creates column headings from variable names.
5. Click **Open**.
   JMP opens the file as a data table.

**To open an SPSS file (Macintosh):**
1. Select **File > Open**.
2. Select the SPSS file.
3. (Optional) To specify the column headings, do one of the following
   - Deselect **Use SPSS Labels as Headings** to convert variable names to column headings.
   - Select **Use SPSS Labels as Headings** to convert labels to column headings.
4. Click **Open**.
   JMP opens the file as a data table.

**Import Data from SAS**

You can connect to a SAS server and work directly with SAS data sets:

- Import whole SAS data sets or portions of data sets
- Make changes to imported SAS data in JMP and then export those changes as a SAS data set
- Run stored processes
- Submit SAS code from JMP
Java Runtime Environment (JRE) requirements

- On Windows, JRE 1.7 or later must be installed on your computer to access SAS. However, JRE 1.7 does not need to be specified as the current version.
- On Macintosh, JRE 1.7 or later must be installed for SAS integration.

Access SAS options from the File > SAS menu:

**Browse Data**  Browse and import data residing on a SAS Server.

**Export Data to SAS**  Export JMP data tables to a SAS Server.

**Browse SAS Folders**  Browse and run SAS stored processes or open Metadata-defined data tables.

**SAS Add-ins**  Opens a window with links to additional JSL and SAS programs available.

**New SAS Program**  Opens a script window for writing and submitting SAS code.

**Submit to SAS**  Sends SAS code directly from JMP to the currently active SAS server.

**Open SAS Log Window**  Opens a SAS log window for the active SAS server.

**Open SAS Output Window**  Opens a SAS output window for the active SAS server. This window shows recent SAS output.

**Server Connections**  Administer connections to SAS servers.

You can also find shortcuts for SAS options on the SAS page of the JMP Starter, and there is a SAS toolbar. You can save certain settings pertaining to SAS Integration on the SAS Integration page of the Preferences window (File > Preferences). For more information about setting your SAS Integration preferences, see “SAS Integration” on page 432 in the “JMP Preferences” chapter.

Import SAS Data Sets

SAS data sets are saved in one of many SAS formats:

- Windows supported formats are .sas7bdat and .sas7bxat.
- Macintosh supports reading and writing .sas7bdat files.

When you open a data set in JMP, the file opens as a data table. JMP uses SAS variable names as column names by default. To use variable labels in a specific file on Windows, select the option when you open the file (see step 5 below).

*To open a SAS data set:*

**Note:** On Macintosh, select File > Open, select the data set, and then click OK.

1. Select File > Open.
2. (Windows only) Select **SAS Data Sets** from the list next to **File name** as shown in Figure 3.14.

**Note:** SAS variable names and formats are preserved and can be saved after changes are made to the SAS data set. See “Save as a SAS Data Set” on page 348 in the “Save and Share Data” chapter.

3. Select the file.

**Figure 3.14** Open SAS Data Set

4. (Optional) Select any of the following options:
   - **SAS variable labels** Uses the SAS variable labels (instead of variable names) as the column names in the JMP data table.
   - **SAS variable names** Uses the SAS variable names (instead of the labels) as the column names in the JMP data table.
5. (Optional on Windows) Select any of the following options:
   - **Apply table and column properties from SAS 9.4 extended attributes**  
     If the SAS server supports extended attributes (SAS 9.4), includes the extended attributes when storing JMP metadata. This setting overrides the SAS 9.4 Extended Attributes preference on the SAS Integration page.
   - **Select this filter the next time this dialog is invoked**  
     Sets the default file type choice to the option that you select next to the File name list. If selected, the default file type will be **SAS Data Sets** the next time you reach this window.

6. (Optional) Select any of the following for a SAS Transport (.xpt) file:
   - **Select member**  
     Lets you enter the name of a specific member, or table, for JMP to open. On Macintosh, select Member Tables > Specified and then enter the name.
   - **Open all members**  
     Opens all members, or tables, in the transport file. On Macintosh, select Member Tables > All.
   - **Save all members**  
     Saves the file as a JMP file as soon as you open it. The file is saved to the same directory where the SAS transport file was opened. On Macintosh, the option is Save all.
   - **Select Columns**  
     Tells JMP to open only certain columns from the transport file. Select the columns that you want to import from the list that appears. On Macintosh, the option is Select columns before opening.

7. Click **Open**.

**Note:** If you are importing date variables from a SAS file, JMP looks for a SAS date format and translates it to a JMP date column.

### Create SAS Transport Files in SAS

JMP can open SAS transport files that were saved using the SAS XPORT engine. For example, below is sample SAS code that creates a transport file called `test`.

**Note:** `misc` and `work` are SAS libref names.

```sas
data test;
  input name $ age weight;
cards;
  Susan 12 72
  Melanie 10 68
  Jonathan 11 77
  Sheila 13 67
;
libname misc xport 'C:/test.xpt';
proc copy in=work out=misc;
```
Import Your Data
Chapter 3
Import Data from SAS

run;

Connect to SAS

You can either connect to a SAS Metadata Server or directly to a SAS Workspace Server. Once connected to a SAS Metadata Server, you can browse through SAS servers, libraries, and data sets.

**Note:** The earliest supported release of the SAS Metadata Server is version 9.1.3 SP4. Connections to earlier releases of the SAS Metadata Server are experimental and are not supported.

- To connect to a SAS server, click **File > SAS > Server Connections**. The SAS Server Connections window in Figure 3.15 appears. All connections are made in this window.

**Figure 3.15** SAS Server Connections

Connect to a SAS Metadata Server

**Note:** You can be connected to only one Metadata Server at a time. If you make a second connection, your first one is disconnected.
To connect to a Metadata Server:

1. Select the version for the SAS Server. Your SAS Metadata Server administrator should have this information.
2. Select the profile that you want to use.
   If you do not have a profile set up, see “To create or modify a SAS Metadata Server profile:” on page 84.
3. Click Connect.
   If JMP is unable to establish a connection, an error message appears. Common reasons are invalid user names or passwords. If you need to update the information for the profile, see “To create or modify a SAS Metadata Server profile:” on page 84.
4. Click Close.

Once you are connected to a SAS Metadata Server, you can connect to any SAS Workspace Servers that the Metadata Server offers.

To connect to a SAS Workspace Server:

1. In the SAS Server Connections window, select the Workspace Server to connect to. See Figure 3.16. Note that connecting to SAS on your computer is available only on Windows.

Figure 3.16 Open a Connection to a Workspace Server

2. Click Connect.
   Under Open Workspace Server Connections, the Workspace Server is shown as the current active connection. See Figure 3.17.

Figure 3.17 Current Active Connection

3. Click Close.
To change the active connection:

**Note:** The active connection is what is used to submit SAS code or handle SAS script commands.

To change the active connection, you first need to be connected to more than one server. Follow the instructions in “To connect to a SAS Workspace Server” on page 83 to add two or more server connections.

1. In the Open Workspace Server Connections section, click the drop-down menu and select the desired server.
2. Click **Set as Active**.
3. Click **Close**.

**Tip:** You can change the active server at any time.

To disconnect from a SAS Workspace Server:

1. In the SAS Server Connections window, select the Workspace Server to disconnect under Open Workspace Server Connections.
2. Click **Disconnect**.

To disconnect from a SAS Metadata Server:

1. In the SAS Server Connections window, select the Metadata Server to disconnect.
2. Click **Disconnect**.

To create or modify a SAS Metadata Server profile:

1. In the SAS Server Connections window, select the **SAS Server Version**.
2. Click **Manage Profiles**.
3. Click **Add** to add a new profile, or click **Modify** to change a profile’s settings.
   
The Create Profile or Modify Profile window appears. If you are adding a new profile, all fields are empty except the Authentication domain field, which contains DefaultAuth, and the Port field. If you are modifying a profile, the fields contain the current information.
4. Fill in the information needed to connect to a SAS Metadata Server. Your SAS Metadata Server administrator should have this information.

**Profile name**  Select a name for this profile. This name is shown in the list of profiles.

**Description**  (Optional) You can enter a short description of this profile.

**Machine**  The name of the machine that hosts the Metadata Server. (Example: myserver.mycompany.com)

**Port**  The port through which you should connect to the machine. (Example: 8561)

**User name**  Your user name for the Metadata Server.

**Password**  Your password. This is always displayed as asterisks.

**Authentication domain**  The domain you, as a user, belong to.

5. Click **Save**.

**Figure 3.18  Create or Modify a Metadata Server Profile**

---

**Connect to a SAS Workspace Server on a Remote Machine**

You can also connect directly to a SAS Workspace Server, instead of going through a Metadata Server.

*To connect to a SAS Workspace Server:*

1. Select **File > SAS > Server Connections** to open the SAS Server Connections window.
2. Under Establish New Workspace Server Connection, select **Connect to remote SAS server** on. See Figure 3.19.
3. Enter the machine name and the port number. Your SAS server administrator has this information.

4. Click Connect.

5. Enter your user name and password in the window that appears.

6. Click OK.

7. Click Close in the SAS Server Connections window.

To disconnect from a SAS Workspace Server:

1. In the SAS Server Connections window, select the server to disconnect under Open Workspace Server Connections.

2. Click Disconnect.

Connect to a SAS Environment (Windows Only)

On Windows, you can connect to a SAS mid-tier (or SAS environment) if SAS Server version 9.3 is selected in JMP’s preferences and your computer or JMP has been configured correctly. (SAS Server version 9.3 is the default setting in the JMP SAS Integration preferences.)

The SAS installer should have set up your computer to find the SAS environment definition file. If not, you can enter the path to the file in the JMP preferences.

To configure your JMP preferences:

1. Select File > Preferences > SAS Integration.

2. Select I want to connect to a SAS Environment and then click Configure.

3. To connect to an environment that JMP has already detected, click Automatic discovery, and then select the URL from the list if necessary.

4. To enter the path to the SAS environment definition file, click Manual configuration and enter the URL.

5. Click OK.
To connect to a SAS Environment:

1. Select File > SAS > Server Connections to open the SAS Server Connections window.
2. In the Metadata Server Connection area, select Connect to a SAS Environment.
   If this option is not available, either your computer or JMP is not configured to find the environment. See “To configure your JMP preferences:” on page 86 for details.
3. Select the name of the environment from the Environment list if necessary.
4. Click Connect.
5. Enter your user name and password if prompted.

Connect to SAS on Your Local Machine (Windows Only)

You can also connect directly to SAS on your local machine.

To connect to SAS on your computer:

1. Select File > SAS > Server Connections to open the SAS Server Connections window.
2. Under Establish New Connection, select Connect to SAS on this machine.
3. Click Connect.
4. Click Close in the SAS Server Connections window.

To disconnect from SAS on your computer:

1. In the SAS Server Connections window, select Local under Open Connections.
2. Click Disconnect.

Open SAS Data Sets through a SAS Server

Once you connect to a SAS Workspace Server, you can browse through the SAS libraries on that server and import data into JMP.

To browse the data sets on the SAS server, select File > SAS > Browse Data. The Browse SAS Data window appears. See Figure 3.20.
The window is initially populated with a list of servers the SAS Metadata Server provides (if connected). Any physical and local connections are also shown (as listed in Figure 3.19 on page 86).

- Select a server to see a list of libraries that server contains.
- Select a library to see a list of data sets within that library.
- Select a data set to see a list of columns within that data set.

When you close and reopen the Browse SAS Data window, the previously viewed library and data set appear in the window. However, at any time, you can select a different server from the SAS Server list and then select a library and data set.

**Tip:** If a server is unavailable, or if the connections failed, the server’s name is shown in light, italic text. Click it to try to re-establish the connection.

**Browse SAS Data Information**

You can select a SAS data set and see information about its contents before opening it using the Get Details, Column Details, and Data Preview options.

**Data Preview**

When you select a data set, the Data Preview outline shows you the first ten rows and columns in the data set. See Figure 3.21.
Figure 3.21 Data Preview

Data Preview

Data Set Details

Click **Get Details** in the Browse SAS Data window to see the size and last modification date for each data set in the library. This option helps you estimate whether your computer can process the entire data set.

Column Details

To see information about a particular column in the data set, select it. The Column Details outline shows you some basic information about the data column. See Figure 3.22.
Open a SAS Data Set in JMP

You can import SAS data sets directly into JMP.

1. From the Browse SAS Data window, select a data set.
   Be default, JMP specifies All rows for import.

2. Click Import.

The entire SAS data set is imported into a JMP data table. When SAS data is imported, JMP attempts to make the best match to the SAS format.
Import a Sample of a SAS Data Set

You can import a sample of a SAS data set directly into JMP.

1. From the Browse SAS Data window, select a data set.
2. Open the Import Options outline. See Figure 3.23.

Figure 3.23 Import Options

3. If you want to import only a portion of a data set, you can do any of the following:
   - Select the first \( x \) number of rows only. See “To import the first \( x \) number of rows only:” on page 91.
   - Select to auto-sample a specified file size. See “To import an auto-sample file of a specified size:” on page 91.
   - Select a subset of the columns. See “To select a subset of columns:” on page 92.
   - Construct a WHERE clause to filter the data. See “To import using a WHERE clause:” on page 92.
   - Take a custom sample of the data. See “Importing a Random Sample of the Data” on page 93.

To import the first \( x \) number of rows only:

1. In the Import Options section, select **First \( x \) rows only** and specify the number of rows to import.
2. In the Browse SAS Data window, click **Import**. JMP imports the specified number of rows.

To import an auto-sample file of a specified size:

1. In the Import Options section, select **Auto-sample** and specify the number of MB to import.
2. In the Browse SAS Data window, click **Import**. JMP imports the specified number of MB.

*To select a subset of columns:*

1. In the Import Options section, click **Select Columns**. The Select Columns window appears. See Figure 3.24.

**Figure 3.24** Select Columns

![Select Columns Window]

2. Select the columns that you want to import. To select more than one column at a time, press CTRL and click each column.
3. Click **Add**.
4. When you have added all the columns that you want, click **OK**.
5. In the Browse SAS Data window, click **Import**. Only the columns that you selected from the SAS data set are imported into a JMP data table.

*To import using a WHERE clause:*

1. Click **Where**.
2. Use the WHERE clause editor to construct your WHERE clause.
3. Click **OK** to return to the Browse SAS Data window.
4. Click **Import**.

Only the data that matches your WHERE clause are imported into a JMP data table.

For information about constructing WHERE clauses and using the WHERE clause editor, see “Use the WHERE Clause Editor” on page 111.

**Note:** If you import data using both a WHERE clause and sampling, the WHERE clause is applied first, and then a sample of the filtered data is taken.
You can also write your own SQL statements.

*To import using a custom SQL statement:*

You can also open a SAS data set using a custom SQL statement.

1. Open the Custom SQL outline under the Import Options outline. See Figure 3.23.

**Figure 3.25** Custom SQL

2. Enter your SQL statement in the window.

3. Click **Execute Custom SQL**.

**Note:** Your SQL is run on the selected server but is not restricted to any selected library or data set.

**Importing a Random Sample of the Data**

You can also import a random sample of the rows of the SAS data set.

**Note:** The sampling feature requires that the SAS server has the SAS/STAT product licensed and installed. If SAS/STAT is not present, sampling is disabled.

In the Sample Imported Data area of the Import Options outline, select the **Custom random sample** check box. By default, 5% of the rows are imported. To change the random sample import settings, click the **Settings** button.
**Figure 3.26 Sampling Settings**

In this window, you specify any of the following:

**Sample Size**  You can set the sample size be percentage or by number of rows. To ensure that each row is sampled only once, de-select the *With replacement* option. To ensure that any row can be sampled and appear more than once in the imported data, select the option.

**Selecting by Column**  You can select strata by moving columns into the Strata list.

**Handling Multiple Row Sampling**  If *With replacement* is selected, you can specify to either add each duplicated row as a separate row or combine all duplicated rows into one row. If the second option is selected, a column is added to the table that contains a count of how many times each row was sampled.

**Setting minimum and maximum numbers of items selected**  Select the option and enter a number.

**Setting the random number seed**  Select the option and enter a seed. Specifying the seed lets you reproduce the exact same sample multiple times.

**Note:** If you import data using both a WHERE clause and sampling, the WHERE clause is applied first, and then a sample of the filtered data is taken.

**Import Options**

There are additional options that you can use to specify how SAS data is imported into JMP.

**Use labels for imported column names**  When selected, this option switches the column name, which has a limited length and might be difficult to decipher, with the column label. This
option is turned off by default. To use the SAS data column names as column names in JMP, uncheck this box.

**Add SQL table variable to imported table**  
When selected, this option adds SQL queries to the data table panel as a variable. This option is turned on by default. If you turn off this option, only two variables are added when you import the data table: the SAS server and the data set.

**Tip:** If your data is password-protected, you might want to turn this option off, because your password might be shown in the SQL.

### Table Variables

After you import the JMP data table, table variables appear in the upper left panel of the data table. These variables show the SAS server, data set, and the SQL query and sampling settings if applicable. There is also a source script added that lets you re-do the import at any time.

### Open Password-Protected Data Sets

JMP can open SAS version 7 or higher data sets that are password protected. The passwords are not case sensitive.

*To open password-protected data sets:*

1. Select `File > Open`.
2. Select `SAS Data Sets` from the `Files of type` list.
3. Select the file.
4. Click `Open`.
5. Enter the password and then click `OK`.

When the password is incorrect, you are prompted to enter it again until you get it right.

### Run Stored Processes

Stored processes are SAS DATA step code saved on the SAS server that you are connected to. You can run them from JMP and see the results of the script in JMP.

**Note:** Depending on the preferences that you have set for SAS, error messages are sent either to the JMP log or to a separate SAS log window.

You must be connected to a Metadata Server to view and run stored processes. If you select `File > SAS > Browse SAS Folders` without such a connection, you are prompted to either make a connection or cancel your action.
To select and run a stored process:

   The Browse SAS Folders window appears.
2. Browse through the stored processes to find the one that you want to run.
3. Select it and click Run.
   The data opens as a JMP data table.

On Windows, you can also right-click a stored process and select Copy Metadata Path. This option copies the path to the clipboard. You can then paste it into a script window to include it as a parameter for the JSL operator Meta Get Stored Process(). For more information, see the Scripting Guide.

Note: Static graphs might not appear in the results returned from a SAS stored process when streaming output is selected.

Stored processes send reports to HTML by default, but you can select RTF or PDF instead on the SAS Integration page of the JMP preferences. Select File > Preferences (Windows) or JMP > Preferences (Macintosh) to view the JMP preferences.

Submit SAS Code

You can submit SAS code directly from JMP to the currently active SAS server. If the submitted SAS code generates SAS Listing output, that output is automatically retrieved from the SAS server and displayed in JMP. Also, the generated SAS Log is retrieved, and, if there are any errors in the submitted code, the SAS Log is automatically displayed in the SAS Log window.

Figure 3.27 SAS Code Submission Example

<table>
<thead>
<tr>
<th>SAS Code</th>
<th>JMP Code to Submit SAS Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>data a;</td>
<td>SAS Connect(&quot;sasmain&quot;);</td>
</tr>
<tr>
<td>x=1;</td>
<td>SAS Submit(&quot;data a; x=1; proc print; run;&quot;);</td>
</tr>
<tr>
<td>proc print;</td>
<td></td>
</tr>
<tr>
<td>run;</td>
<td></td>
</tr>
</tbody>
</table>

To run SAS code directly from JMP:

1. Either open an existing SAS program using File > Open, or create a new SAS program.
   (Create a new SAS program by selecting File > SAS > New SAS Program and typing in the SAS code.)
2. Click the Submit to SAS icon.
You can also right-click in the Program Editor window and select **Submit to SAS**. The menu item also includes the name of the active SAS server that the SAS code will be submitted to.

You can also press the F8 key (press COMMAND-SHIFT-R on Macintosh).

To run SAS code using a JSL script:

Write and run a JSL script that uses either the SAS Submit or SAS Submit File JSL functions. For more information about writing JSL scripts that submit SAS code, see the **Scripting Guide**.

To view the SAS Listing output:

If the submitted SAS code generates SAS Listing (textual) output, that output is automatically be displayed in a SAS Output window when the job is completed. If you need to view the SAS Listing output again later in the JMP session, select **File > SAS > Open SAS Output Window**. The SAS Output Window retains the listing output from the previous 25 submits to the active SAS server.

To view the SAS log:

If the submitted SAS code contained errors, the SAS Log window for the active SAS server is automatically opened, displaying the SAS Log for the job. However, you can view the SAS Log for the most recent 25 submits to the active server at any time by selecting **File > SAS > Open SAS Log Window**.

If you prefer that SAS Log information is appended to the JMP log after a submit completes:

1. Select **File > Preferences** (Windows) or **JMP > Preferences** (Macintosh).
2. Open the SAS Integration category.
3. In the Show SAS Log section, select **JMP Log** rather than **Separate Window**.

Also, in the Show SAS Log section, you can set whether the SAS Log should be displayed **Always**, **Never**, or **On Error** (the default).

**Generate ODS Results**

The SAS Output Delivery System (ODS) is a powerful mechanism for generating reports in HTML, RTF, PDF, and other formats. ODS output is generally much more attractive and customizable than plain-text SAS Listing output. You can set your submitted SAS code generate ODS results rather than SAS Listing output using Preferences.

To generate ODS results from your submitted SAS code:

1. Select **File > Preferences** (Windows) or **JMP > Preferences** (Macintosh).
2. Open the SAS Integration category and find the large SAS Submit Options group, as shown in Figure 3.28.

**Figure 3.28** SAS Submit Options in Preferences

![SAS Submit Options](image)

3. Select the **Automatically generate ODS results** option.
4. From the **ODS Result Format** list, select the format in which to generate the ODS results: HTML, PDF, RTF, or a JMP report.
5. (Optional) You can use other options to specify a style or style sheet to format the results or set the format for generated graphics. For more details, see “**SAS Integration**” on page 432 in the “**JMP Preferences**” chapter.

Performing the previous steps causes JMP to generate additional SAS code, including an ODS statement, that is wrapped around the SAS code that you submit. The SAS code that you submit then automatically generates ODS results in the specified format. Those results are downloaded to your computer and displayed either within JMP, when possible, or in an appropriate external application.

**Retrieve Generated SAS Data Sets**

SAS code that you submit might generate SAS data sets. You can have them automatically imported into JMP for further analysis.

1. Select **File > Preferences** (Windows) or **JMP > Preferences** (Macintosh).
2. Open the SAS Integration category.
3. Select the **Import generated SAS data sets into JMP** option.

**Export JMP Data Tables to SAS**

You can export JMP data tables to a SAS Workspace Server.

1. Connect to the SAS Workspace Server.
2. Open the file that you want to export.
3. Select File > SAS > Export Data to SAS.
   If necessary, you are connected automatically using your profile’s user name and password.

4. Select the data table that you want to export to SAS from the list of open data tables under Select Data to Export.

**Figure 3.29 Export Data to SAS**

5. (Optional) To export only some of the columns in the data table, click Select Columns. See “To select columns to export:” on page 100 for details.

6. Select the Destination Server.

7. Select the Library.

   **Tip:** If your libraries do not appear, see “Show Libraries in the Export Data to SAS Window” on page 100.

   A list of the data sets in the library appears.

8. Enter the name as you want it to appear in the SAS library.

9. (Optional) Set the export options that you want to use. See “Export Options” on page 100 for details.

10. Click Export.
To select columns to export:
1. To export only some of the columns in the data table, click Select Columns.
2. In the window that appears, select the columns to export and click Add.
3. When all the columns have been added to the Selected Columns list, click OK.

Export Options

The available export options are as follows:

Ignore ‘excluded’ row state (export all rows)  Select this option to export all rows in the data table. Deselect this option to export only those rows that are not excluded. This option is on by default.

Preserve SAS variable names  This option is useful for data tables that were imported originally from SAS. When importing a SAS data set, the original SAS variable name is saved in a column property for each column. Select this option to use the SAS variable name for each column when exporting to SAS. Deselect this option to export the JMP variable names. This option is off by default.

Preserve SAS formats  This option is useful for data tables that were imported originally from SAS. When importing a SAS data set, the original SAS format and informat is saved in a column property for each column. Select this option to use the SAS format and informat for each column when exporting to SAS. Deselect this option to export the JMP formats instead. This option is on by default.

Show Libraries in the Export Data to SAS Window

If your libraries do not appear in the Export Data to SAS window, define the library in one of the following ways:

• Using JSL, submit code to the SAS server. The code defines a library using a libref command.

• Define an autoexec.sas file that runs a snippet of SAS code every time SAS is invoked. This creates the same librefs every time you connect to SAS. For details about autoexec.sas files, see the SAS documentation.

Libraries that are defined in metadata (such as libraries defined in the SAS Management Console under the Data Library Manager) cannot be accessed from the Export Data to SAS window.

Import Data from R

JMP provides a scripting interface to R. See the Scripting Guide for details.
Import Data Using the Excel Add-In

The add-in for Excel provides new capabilities to JMP and Excel users on Windows:

- Transfer selected cells in Excel to JMP data tables. See “Transfer Excel Data to a JMP Data Table” on page 101.
- Use the JMP Profiler with calculation models in Excel workbooks. The profiler tool is designed to bring the power of the JMP profiler to models residing in Excel spreadsheets. You do not have to recreate your Excel models in JMP, verify that they are correct, and maintain the model in both JMP and Excel. For more information, see the Profilers book.

Note: During the JMP installation, select the Excel Add-In. This installs the add-in for your version of Microsoft Excel.

- Microsoft Excel 2007, Microsoft Excel 2010, and Microsoft Excel 2013 are supported.

Transfer Excel Data to a JMP Data Table

You can use the JMP Add In for Excel to transfer a spreadsheet from Excel to the following JMP destinations:

- a data table
- Graph Builder
- Distribution platform
- Fit Y by X platform
- Fit Model platform
- Time Series platform
- Control Chart platform

You can also create models for profiling in JMP. See the Profilers book for details.

To transfer data from Excel to a JMP data table and platform:

1. In your Excel worksheet, show the JMP add-in on the ribbon.
2. Click the Preferences button.
3. Accept the default Data Table Name (File name_Worksheet name) or type a name.
4. Select Use the first rows as column names if the first row in the worksheet contains column headers.
5. If you selected to use the first rows a column headers, type the number of rows used.
6. Select Transfer Hidden Rows if the worksheet contains hidden rows to be included in the JMP data table.
7. Select **Transfer Hidden Columns** if the worksheet contains hidden columns to be included in the JMP data table.

8. Click **OK** to save your preferences.

9. Select the cells to transfer into JMP, including any cells that you want to use as column names.
   - If you are using cells as column names, they need to be the first rows in your selection.
   - If only one cell (or no cell) is selected, the entire Excel worksheet is transferred to JMP.

10. Select the JMP destination from the toolbar:
    - Data Table
    - Graph Builder
    - Distribution platform
    - Fit Y by X platform
    - Fit Model platform
    - Time Series platform
    - Control Chart platform

The Excel selection or worksheet is opened as a data table in JMP and the selected platform’s launch window appears.

JMP opens, and the selected data is placed in a new JMP data table and the selected launch window appears.

**Note:** Empty cells are imported as missing data, and dates, numbers, and strings are recognized correctly.

**Note:** Your JMP windows might be hidden behind your Excel window, especially if you maximize Excel.

For more information about using the various JMP platforms refer to the proper book.

### About the JMP Add-In for Excel

The JMP add-in commands are in two groups:

**Transfer to JMP**

- **Preferences** Set preferences for transferring data from Excel to JMP.
- **Data Table** Transfer the selected data in your Excel file to a JMP data table.
- **Graph Builder** Transfer the selected data in your Excel file to a JMP data table and launch the Graph Builder platform.
Distribution  Transfer the selected data in your Excel file to a JMP data table and launch the Distribution platform.

Profile in JMP

Create/Edit Model  Set up preferences for using the JMP profiler with Excel data.

Run Model  Run the JMP profiler.

Uninstall the Excel Add-In

1. Open the Windows Add or Remove Programs utility (in the Control Panel).
2. Select JMP Profiler Core and click Uninstall.
3. Select JMP Profiler GUI and click Uninstall.

Uninstall Previous Versions of the Excel Add-In

JMP automatically installs the Excel Add-In for your version of Excel. If you have a previous version of this add-in, uninstall it:

1. Open the Windows Add or Remove Programs utility (in the Control Panel).
2. Select JMP_ExcelAddinSetup and click Uninstall.

Import Data from a Database

You can import data from a database if you have an ODBC (Open Database Connectivity) driver for the database and then save the data back to the database. (See “Save Data Tables to a Database” on page 350 in the “Save and Share Data” chapter for details.)

Your operating system provides an interface for JMP to communicate with databases using ODBC data sources. Data sources can be created and configured with operating system software: For example, on Windows 7, use Control Panel > System and Security > Administrative Tools > Data Sources (ODBC); on the Macintosh, use Applications > Utilities > ODBC Manager.

When you import data from an ODBC database, within the data table, note the following:

- There is a script called Source that you can run to re-import and refresh the data.
- A table variable is added that might contain user ID and password information. There is a JSL-only preference that can be set to prevent including this possibly sensitive information. See the Scripting Guide for more details.
- If your database supports sampling, you can speed up queries for a large database by sampling the data. This option appears on the Database Open Table window.
Open Data from a Database

To import data from a database:

1. Select **File > Database > Open Table** to display the window shown in Figure 3.30. The Connections box lists data sources to which JMP is connected. The Schemas box lists schemas for those databases that support them. The Tables box lists database tables for the currently selected data source connection.

**Figure 3.30** Database Open Table Window

When one or more database connections are made, the list of connections shows in the Connections list.

If your database supports schemas (for example, Oracle), this field shows the schema list. It disappears if you select a database that does not support schemas.

If there are tables in the selected database file or directory, they appear in the Tables list.

**Note:** The **Fetch Procedures** check box is disabled if the ODBC driver does not support fetching procedures.

2. If the desired data source is *not* listed in the Connections box, click **Connect** to choose a data source. The method of choosing a data source depends on your operating system. Figure 3.31 shows the data source chooser for Windows. Select a data source and click **OK**.
3. Select the desired data source in the Connections box. The tables list in the Tables box updates accordingly. The update might take a several seconds, depending on the number of tables and the speed of the connection to the database. If your database supports schemas, tables are loaded for the first schema in the list, and on other schemas as you click on them.

4. Control which tables are listed by choosing the options in the Include in Table List group of check boxes. Different drivers interpret these labels differently. Your options are as follows:

- **User Tables**: When clicked, displays all available user tables in the Tables list. User tables are specific to which user is logged on to the computer.

- **Views**: When clicked, displays "views" in the Tables list along with all other file types that can be opened. "Views" are virtual tables that are query result sets updated each time you open them. They are used to extract and combine information from one or more tables.

- **System Tables**: When clicked, displays all available system tables in the Tables list. System tables are tables that can be used by all users or by a system-wide service.

- **Synonyms**: When clicked, displays all available ORACLE synonyms in the Tables list.

- **Sampling**: Enter the percentage of rows that you want to appear in the list of tables. Selecting this option speeds up queries in large databases. JMP uses the sampling method supported by the database. The checkbox is unavailable when the database does not support sampling.

5. Select the desired table from the Tables list.
Note: If you are connected to a dBase database, select the database folder to which you would like to connect. Individual files are grayed out and cannot be selected.

6. Click Open Table to import all the data in the selected table, or click Advanced to specify a subset of the table to be imported.

Note: Some databases require that you enter the user ID and password to access the data.

Retrieve Data Using SQL Statements

You can use Structured Query Language (SQL) statements to control what you import from a database. When you open a database file in JMP, you are actually sending an SQL statement to the database. By default, this statement gets all files and records in the database table. In some cases, this is too much data. When you are interested only in a subset of the table's data, you can customize the SQL request to only request the data that you want. After you execute an SQL query, the code for the query is stored in the data table in the SQL table variable.

Note: The SQL Query that you run in this window operates only on the tables and procedures that are displayed in the left panes of the window. Running unrelated SQL here has no results.

To retrieve data using SQL statements:

1. Connect to a database by following the steps in “Open Data from a Database” on page 104.
2. From the Database Open Table window, click the Advanced button to open specific subsets of a table.
3. Either type in a valid SQL statement, or modify the default statement. Figure 3.32 shows a default SQL Select statement appropriate for the selected file. See “Structured Query Language (SQL): A Reference” on page 107, for a description of SQL statements that you can use.

Alternately, you can add expressions by clicking the Where button and using the WHERE Clause editor to create expressions. See “Use the WHERE Clause Editor” on page 111, for details.
Figure 3.32 Reading All Variables from the Solubility Table Stored in an Excel File

4. Click **Execute SQL**. A JMP data table appears with the columns that you selected. The SQL statement becomes an SQL table variable in the JMP data table. (For details, see “Use Table Variables” on page 146 in the “Enter and Edit Data” chapter.)

Note that you can enter any valid SQL statement and click **Execute SQL** to execute the command. Valid SQL varies with the data source and ODBC driver.

**Structured Query Language (SQL): A Reference**

The following sections are a brief introduction to SQL. They give you insight to the power of queries, and they are not meant to be a comprehensive reference.

**Use the SELECT Statement**

The fundamental SQL statement in JMP is the **SELECT** statement. It tells the database which rows to fetch from the data source. When you completed the process in “Open Data from a Database” on page 104 with the Solubility.jmp sample data table, you were actually sending the following SQL statement to your data source.

```
SELECT * FROM "Solubility"
```

The * operator is an abbreviation for “all columns.” So, this statement sends a request to the database to return all columns from the specified data table.
Rather than returning all rows, you can replace the * with specific column names from the data table. In the case of the Solubility data table example, you could select the ETH, OCT, and CCL4 columns only by submitting this statement:

```
SELECT ETH, OCT, CCL4 FROM "Solubility"
```

**Note:** JMP does not require you to end SQL statements with a semicolon.

JMP provides a graphical way of constructing simple SELECT statements without typing actual SQL. To select certain columns from a data source, highlight them in the list of columns (Figure 3.32).

**To highlight several rows:**
- Shift-click to select a range of column names
- Ctrl-click (Windows) or Command-click (Macintosh) to select individual column names.

Note that the SQL statement changes appropriately with your selections.

Sometimes, you are interested in fetching only unique records from the data source. That is, you want to eliminate duplicate records. To enable this, use the DISTINCT keyword.

```
SELECT DISTINCT ETH, OCT, CCL4 FROM "Solubility"
```

**Sort Results**

You can have the results sorted by one or more fields of the database. Specify the variables to sort by using the ORDER BY command.

```
SELECT * FROM "Solubility" ORDER BY LABELS
```

selects all fields, with the resulting data table sorted by the LABELS variable. If you want to specify further variables to sort by, add them in a comma-separated list.

```
SELECT * FROM "Solubility" ORDER BY LABELS, ETH, OCT
```

**Use the WHERE Statement**

With the WHERE statement, you can fetch certain rows of a data table based on conditions. For example, you might want to select all rows where the column ETH has values greater than 1.

```
SELECT * FROM "Solubility" WHERE ETH > 1
```

The WHERE statement is placed after the FROM statement and can use any of the following logical operators.
When evaluating conditions, NOT statements are processed for the entire statement first, followed by AND statements, and then OR statements. Therefore

```
SELECT * FROM "Solubil$" WHERE ETH > -2 OR OCT < 1 AND CCL4 > 0
```

is equivalent to

```
SELECT * FROM "Solubil$" WHERE ETH > -2 OR (OCT < 1 AND CCL4 > 0)
```

Use the IN and BETWEEN Statements

To specify a range of values to fetch, use the IN and BETWEEN statements in conjunction with WHERE. IN statements specify a list of values and BETWEEN lets you specify a range of values. For example,

```
SELECT * FROM "Solubil$" WHERE LABELS IN ('Methanol', 'Ethanol', 'Propanol')
```

fetches all rows that have values of the LABELS column Methanol, Ethanol, or Propanol.

```
SELECT * FROM "Solubil$" WHERE ETH BETWEEN 0 AND 2
```

fetches all rows that have ETH values between 0 and 2.

Use the LIKE Statement

With the LIKE statement, you can select values similar to a given string. Use % to represent a string of characters that can take on any value. For example, you might want to select chemicals out of the Solubil data that are alcohols, that is, have the –ol ending. The following SQL statement accomplishes this task.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Equal to</td>
</tr>
<tr>
<td>!= or &lt;&gt;</td>
<td>Not equal to</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than</td>
</tr>
<tr>
<td>&lt;</td>
<td>Less Than</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Greater than or equal to</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Less than or equal to</td>
</tr>
<tr>
<td>NOT</td>
<td>Logical NOT</td>
</tr>
<tr>
<td>AND</td>
<td>Logical AND</td>
</tr>
<tr>
<td>OR</td>
<td>Logical OR</td>
</tr>
</tbody>
</table>
**Use Aggregate Functions**

Aggregate functions are used to fetch summaries of data rather than the data itself. Use any of the following aggregate functions in a SELECT statement.

**Table 3.3 SELECT Statement Functions**

<table>
<thead>
<tr>
<th>Function</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>SUM( )</td>
<td>Sum of the column</td>
</tr>
<tr>
<td>AVG( )</td>
<td>Average of the column</td>
</tr>
<tr>
<td>MAX( )</td>
<td>Maximum of the column</td>
</tr>
<tr>
<td>MIN( )</td>
<td>Minimum of the column</td>
</tr>
<tr>
<td>COUNT( )</td>
<td>Number of rows in the column</td>
</tr>
</tbody>
</table>

Some examples include:

- The following statement requests the sum of the ETH and OCT columns:
  
  ```sql
  SELECT SUM(ETH), SUM(OCT) FROM "Solubil$"
  ```

- This statement returns the number of rows that have ETH values greater than one:
  
  ```sql
  SELECT COUNT(*) FROM "Solubil$" WHERE ETH > 1
  ```

- The following statement lets you know the average OCT value for the data that are alcohols:
  
  ```sql
  SELECT AVG(OCT) FROM "Solubil$" WHERE LABELS LIKE 'OL'
  ```

**Note:** When using aggregate functions, the column names in the resulting JMP data table are Expr1000, Expr1001, and so on. You probably want to rename them after the fetch is completed.

**The GROUP BY and HAVING Commands**

The GROUP BY and HAVING commands are especially useful with the aggregate functions. They enable you to execute the aggregate function multiple times based on the value of a field in the data set.
For example, you might want to count the number of records in the data table that have ETH=0, ETH=1, and so on, for each value of ETH.

- SELECT COUNT(ETH) FROM "Solubi$" GROUP BY (ETH) returns a single column of data, with each entry corresponding to one level of ETH.
- SELECT COUNT(ETH) FROM "Solubi$" WHERE OCT > 0 GROUP BY (ETH) does the same thing as the above statement, but only for rows where OCT > 0.

When using GROUP BY with an aggregate function of a column, include the column itself in the SELECT statement. For example,

SELECT ETH, COUNT(ETH) FROM "Solubi$" GROUP BY (ETH)

returns a column containing the levels of ETH in addition to the counts.

### Use Subqueries

Aggregate functions are also useful for computing values to use in a WHERE statement. For example, you might want to fetch all values that have greater-than-average values of ETH. In other words, you want to find the average value of ETH, and then select only those records that have values greater than this average. Remember that SELECT AVG(ETH) FROM "Solubi$" fetches the average that you are interested in. So, the appropriate SQL command uses this statement in the WHERE conditional:

SELECT * FROM "Solubi$" WHERE ETH > (SELECT AVG(ETH) FROM "Solubi$")

### Save and Load SQL Queries

After constructing a query, you might want to repeat the query at a later time. You do not have to hand-type the query each time you want to use it. Instead, you can export the query to an external file. To do this, click the Export SQL button in the window shown in Figure 3.32. This brings up a window that lets you save your SQL query as a text file.

To load a saved query, click the Import SQL button in the window shown in Figure 3.32. This brings up a window that lets you navigate to your saved query. When you open the query, it is loaded into the window.

### Use the WHERE Clause Editor

JMP provides help building WHERE clauses for SQL queries during ODBC import. It provides a WHERE clause editor that helps you build basic expressions using common SQL features, allowing vendor-specific functions. For example, you do not need to know whether SQL uses '=' or '==' for comparison, or avg() or average() for averaging.

In addition, string literals should be enclosed by single quotes (‘string’) rather than double quotes (“string”).
To open the WHERE clause editor:

1. Connect to a database by following the steps in “Open Data from a Database” on page 104.
2. From the Database Open Table window, shown in Figure 3.30, click the Advanced button.
3. Click the Where button.

USE the WHERE Clause Editor to add any of the following from the work panel: expressions, functions, and terms. They are applied to the highlighted red box.

1. Click the Table Name Browser to select a table. The columns in that table appear in the list.
2. Click the SQL Vendor Name Browser to select the type of SQL that you want to use: GenericSQL, Access, DB2, MySQL, Oracle, SQL Server, or all of the above. Perform an action by clicking a function or operator in the list and selecting an operator from the list that appears.

Note: The following SQL Server data types are not supported: Binary, Geography, and Geometry.

3. Select an empty formula element in the formula editing area by clicking it. It is selected when there is a red outline around it. All terms within the smallest nesting box relative to the place that you clicked become selected. The subsequent actions apply to those combined elements.
4. Add operators to an expression by clicking buttons on the keypad.
5. (Optional) To customize your WHERE clause, select one of the options from the red triangle menu above the keypad:

   - **Show Boxing**  Show or hide boxes around the WHERE clause terms.
   - **Larger Font**  Increase the font size of the formula.
   - **Smaller Font**  Decrease the font size of the formula.
   - **Simplify**  Simply the WHERE clause statement as much as possible.

The WHERE clause editor works similarly to the Formula Editor, which is described in the “Formula Editor” chapter on page 235.
Read in Real-Time Data

The term *live data feed* describes the way an external data source sends information via a physical or a logical communication link to another device. You can connect JMP to a live data feed through the serial port of your Windows computer to read a stream of incoming data in real time. Remember the following:

- The data feed must come through a standard nine-pin serial port. Data cannot be read through a USB port unless there is a driver that can simulate a serial port.
- You need to know the exact baud rate, parity, stop bits, and data bits for the attached device.

Once you obtain the numbers for your device, enter them into the `Open Datafeed()` command in the script below. (The 4800, even, 2, and 7 in the script below are examples, so replace them with your information). Then connect the data feed to your computer and open and run the script:

```plaintext
streamScript = expr( line = feed << Get Line; show(line);
     len = length(line); show(len);
     if (length(line)>=1, show("Hi"); show(line);
         field = substr(line,5,8); show(field);
```

---

**Figure 3.33** The WHERE Clause Editor

![The WHERE Clause Editor](image)

1. **Labels**
2. **Operators**
3. **Generic SQL**
4. **Column Functions**
5. **Date/Time Functions**
   - Numeric Functions
   - String Functions
   - System Functions
   - OK
   - Cancel
   - Clear
   - Help
   - No formula

---

[Chapter 3](#) Import Your Data

Using JMP

Read in Real-Time Data

113
To create a new data table by entering data manually:

1. Select File > New > Data Table. This shows an empty data table with no rows and one numeric column, labeled Column 1.

2. Move the cursor onto a cell.

3. Click in the cell. The cursor appears as a line in the cell, as shown in Figure 3.34.

4. Enter a value.

There are several ways to fill a table with values:

- Create new rows and columns and type or paste data into the data grid. (See “Add Rows” on page 119 in the “Enter and Edit Data” chapter.)
• Construct a formula to calculate column values. (See “Create a Formula” on page 237 in the “Formula Editor” chapter.)
• Import data from another application. (See “About Importing Data to JMP” on page 61.)
• Copy values from another application and paste them into the table.
• Use a measuring instrument to read external measures. (See “Read in Real-Time Data” on page 113 for details.)
• Drag columns from one table to another.

See the “Enter and Edit Data” chapter on page 117 for details about how to format, edit, and work with data tables.
Chapter 4

Enter and Edit Data
Perform Basic Data Table Tasks

After you import data into JMP or create a new data table, you can format your data to prepare it for analysis.

This chapter contains the following information:

- Change formatting for numeric values
- Add, delete, and select rows and columns
- Use the Row Editor to navigate within rows and edit rows
- Create scripts that are saved to the data table

Figure 4.1 The Rows and Cols Menus
Enter and edit data using the options in the Rows and Cols menus.
## Contents

Enter Data ................................................................. 119
Select Rows .............................................................. 122
Select Columns .......................................................... 125
Select Cells ............................................................. 130
Edit Data ................................................................. 132
  - Delete Rows and Columns ........................................... 132
  - Edit or Delete Cells ................................................ 133
  - Edit Column Names ................................................ 133
  - Recode Data ........................................................ 133
  - View Patterns of Missing Data .................................. 134
  - Find and Replace Cell Values .................................... 136
  - Reorder Columns ................................................... 139
  - Group Columns ..................................................... 139
  - Make Binning Formula ............................................. 143
Edit Data Tables ........................................................ 144
  - Change Table Names ............................................... 145
  - Lock Tables ......................................................... 145
  - Compress Tables .................................................. 145
  - Use Table Variables ............................................... 146
  - Create and Save Scripts .......................................... 148
  - Compare Data Tables ............................................... 151
Assign Characteristics to Rows and Columns ..................... 155
  - Hide and Exclude Rows .......................................... 155
  - Exclude Rows and Columns ...................................... 155
  - Hide Rows and Columns .......................................... 156
  - Label Rows and Columns ......................................... 157
  - Assign Colors or Markers to Rows .............................. 157
  - Create Color Themes ............................................. 160
  - Delete Custom Color Themes .................................... 165
  - Delete Row Characteristics ..................................... 165
  - Lock Columns in Place ........................................... 165
Enter Data

This section describes how to add rows and columns, fill columns with sequential data, and enter cell formulas.

Add Rows

To add any number of rows to the table:

1. Select Rows > Add Rows.
2. Enter the number of rows to add.
3. Specify where to add the new rows (at the start or end of the data table, or after a specific row).
4. Click OK.

To add a single row to the end of the table:

- Below the last row, click anywhere in a cell and begin typing.
- Below the last row, double-click in the empty row number area.

Add Columns

To add new, empty columns:

- Double-click the empty space to the right of the last data table column.
- Select Cols > New Column. You can then specify more details about the column. You can also add subsequent columns by clicking Next. See “The Column Info Window” on page 169 in the “Set Column Properties” chapter.
- Select Cols > Add Multiple Cols. See “Adding Multiple Columns” on page 119.

Note: When you initially create a column, you can choose to fill it with initial data values. See “Fill in Initial Data Values” on page 177 in the “Set Column Properties” chapter. However, after you modify the cells, this option no longer appears.

Adding Multiple Columns

Using the Add Multiple Columns command to define multiple columns is different from using the New Column command. All of the columns that you add using the Add Multiple Columns window have the same data type. Right-clicking anywhere to the right of the last column in a data table to add multiple columns defaults to After Last Column.
To add multiple columns:

1. (Optional) Change the Column prefix.
   By default, the new column names are Column 1, Column 2, and so on.
2. Enter the number of columns to add.
3. (Optional) Specify if the columns should be grouped. See “Group Columns” on page 139.
4. Select the data type (Numeric, Character, or Row State) for all of the columns. See “About Data Types and Modeling Types” on page 170 in the “Set Column Properties” chapter.
5. Specify where you want to put the new columns.
6. (Optional) Select initial data values for all of the columns. See “Fill in Initial Data Values” on page 177 in the “Set Column Properties” chapter.
7. Click OK.

Figure 4.2  The Add Multiple Columns Window

Tip: To change the data type after the columns are created, click on the modeling type icon in the Columns panel and select a different type.

Fill Columns with Sequential Data

To fill columns with a repeating sequence of data or with a continuation of values:

1. Create a sequence of data in a column. See Figure 4.3.
2. Highlight the cells containing the sequenced data. The cells can be in different columns.

3. Right-click the selected cells and select an option under Fill.

**Fill Options**

- **Repeat sequence to end of table**: cells below the selection are filled with repeats of the selected cells.
- **Continue sequence to end of table**: cells below the selection are filled with a continuation of the pattern found in the selected cells. For example, if the selected cells contain the numbers 1 and 2, then the remaining cells are filled with 3, 4, 5, 6, and so on. If the selected cells contain the numbers 2 and 4, then the remaining cells are filled with 6, 8, 10, 12, and so on.
- **Repeat sequence to**: JMP repeats the pattern found in the selected cells to the row number that you specify.
- **Continue sequence to**: JMP continues the pattern found in the selected cells to the row number that you specify.

**Enter Cell Formulas**

In numeric columns, you can enter cell expressions preceded by an equal sign (=). JMP evaluates the expression and stores the new number as the cell's value. Unlike column formulas, a cell expression is not stored. Cell expressions can contain operators, constants, and global and column variables.

To enter an expression:

1. Click the cell where you want to enter the expression.
2. Type an equal sign (=), and then type the expression. See Table 4.1.
3. Press the ENTER key.
Select Rows

**To select one entire row:**
- Click in the empty space that contains the row number.

**To select a specific row number:**
- Select **Rows > Row Selection > Go to Row** and type in the desired row number.

**To select multiple rows:**
- For continuous selection:
  - Click and drag the cursor over the row numbers.
  - Hold down the SHIFT key and click the first and last rows of the desired range.
  - Hold down the SHIFT key and press the up or down arrow key.
- For discontiguous selection:
  - Hold down the CTRL key and click on each row.

**To select or deselect all rows:**
- To select all rows, select **Rows > Row Selection > Select All Rows**.
- To deselect all rows, select **Rows > Clear Row States**.
  or
- Hold down the SHIFT key and click the lower triangular area in the upper left corner of the data grid to select. Click again in the same area to deselect all rows. See Figure 4.4.
- To clear all highlighted areas in the data table, press the ESC key.
Chapter 4
Using JMP

Enter and Edit Data
Select Rows

Figure 4.4 Lower Triangular Area

To select random rows:
1. Select Rows > Row Selection > Select Randomly.
2. You can randomly select either a specific number of rows, or a proportion of the total number of rows:
   - Enter a whole number to select that number of rows.
   - Enter a value between 0 and 1 to select that proportion of rows.
   For example, enter 10 to select 10 rows. Enter 0.1 to select 10% of the rows.

To invert the row selection:
• Select Rows > Row Selection > Invert Row Selection.

To assign a dominant column:
1. Select Rows > Row Selection > Select Dominant.
2. Choose the column(s).
3. Select high or low values for each column.
4. Click OK.

To save the current row selection in a new column:
1. Select Rows > Row Selection > Name Selection in Column.
2. Type a column name.
3. Label the selected and deselected rows.
4. Click OK.

To select excluded, hidden, or labeled rows:
1. Select Rows > Row Selection.
2. Select from the following options:
   - Select Excluded
Enter and Edit Data
Select Rows

– Select Hidden
– Select Labeled

Note: For details about excluded, hidden, or labeled rows, see “Assign Characteristics to Rows and Columns” on page 155.

Locate Next and Previously Selected Rows

You can locate the next selected row after the current row and cause it to flash by selecting Rows > Next Selected. Similarly, you can locate the previously selected row before the current row and cause it to flash by selecting Rows > Previous Selected.

Each time you select Rows > Next Selected or Rows > Previous Selected, the next or previously selected row is found and flashes. A beep signals when the last selected row is located.

You might want to use this feature when you have selected rows intermittently in a large data set and want to look through the selected rows in the data table.

Example of Locating Next and Previously Selected Rows

1. Open the Diamonds Data.jmp sample data table.
2. Select Analyze > Fit Y by X.
3. Select Carat Weight and click Y, Response.
4. Select Price and click X, Factor.
5. Click OK.
   If you cannot see the menu bar, place your mouse pointer over the blue bar below the title bar to reveal it.
7. Lasso some of the points near the 10,000 dollar price at the bottom of the plot. See Figure 4.5.
8. In the data table, select Rows > Next Selected (or you can press the F7 key).
You can easily navigate through the selected rows to see the data for each.
Select Columns

There are several ways to select columns:

- Select columns in the data table itself. See “Select Columns in a Data Table” on page 125.
- In a data table that has many columns, select columns by attributes, properties, and statistics in the Columns Viewer. See “Select Columns in the Columns Viewer” on page 126.

Select Columns in a Data Table

To select one entire column:

- In the data grid, click in the empty space around the column name.
  or
- In the Columns panel, click the column name.

To select a specific column number:

1. Select Cols > Go to.
2. Enter the column number or name and click OK.

To select multiple columns:

- For continuous selection:
  - Click and drag the cursor over the column name.
  - Hold down the SHIFT key and click the first and last columns of the desired range.
  - Hold down the SHIFT key and press the left or right arrow key.
• For columns that are not next to each other:
  – Hold down the CTRL key and click on each column.

To select or deselect all columns:

• Hold down the SHIFT key and click the upper triangular area in the upper left corner of the data grid to select. Click again in the same area to deselect all columns. See Figure 4.6.

Figure 4.6 Upper Triangular Area

<table>
<thead>
<tr>
<th>name</th>
<th>age</th>
</tr>
</thead>
<tbody>
<tr>
<td>KATIE</td>
<td>12</td>
</tr>
<tr>
<td>LOUISE</td>
<td>12</td>
</tr>
<tr>
<td>JANE</td>
<td>12</td>
</tr>
<tr>
<td>JACLYN</td>
<td>12</td>
</tr>
<tr>
<td>LILUE</td>
<td>12</td>
</tr>
<tr>
<td>TIM</td>
<td>12</td>
</tr>
</tbody>
</table>

Tip: To clear all highlighted areas in the data table, press the ESC key.

Select Columns in the Columns Viewer

The Columns Viewer helps you quickly select columns by attributes, properties, and statistics, particularly in a data table that has many columns. You can view summary statistics and properties for those columns, view quartiles in the summary statistics, subset the data, and more. And columns in the Columns Viewer window are also linked to the data table columns (Figure 4.7).
The Columns Viewer gives you a quick view of data table characteristics. For example, the Summary Statistics report shows which columns contain missing values (Figure 4.8). You can select those columns in the report and then exclude them in the data table.

Other options include the following:

**Clear Select**  Deselects columns in the data table and in the Columns Viewer. This option ensures that no columns are selected before you begin selecting columns.

**Subset**  Creates a linked subset data table from the selected columns.
Show Summary  Creates a linked Summary Statistics report for the selected columns. Right-click to select options such as sorting by column or creating a linked data table from selected columns. Select Show Quartiles to include lower quartiles, upper quartiles, and interquartile ranges. And to create a linked data table from all columns in the report, select Data Table View from the Summary Statistics red triangle menu.

Find Columns with Properties  Shows a list of column properties in the Columns with Properties report. Select the properties that you want to find and then click OK to create a linked report from all columns. Or you can select columns first in the Select Columns list and then show the list of properties just for those columns.

Tip: Each time you click the Show Summary or Find Columns with Properties buttons, a new report is added to the window. To delete a report, select Remove from the report’s red triangle menu.

Example of Finding Columns with a Specific Property
This example shows how to find columns that have a Formula property and then view all formulas at once.
1. Open the Consumer Preferences.jmp sample data table.
2. Select Cols > Columns Viewer to open the Data Table Columns Viewer window.
3. Select Find Columns with Properties, select Formula, and click OK.

The Columns with Properties report appears. Several columns include the Formula property (Figure 4.9). Because the list is so long, you want to view all formula columns together.

Figure 4.9 Select the Formula Column Property
4. Right-click the report, select Sort by Column, Formula, and then click OK.

Columns that have a Formula property appear at the top of the report (Figure 4.10).

**Figure 4.10** Sort by Column

![Columns with Properties](image)

Columns that have a Formula property appear at the top of the report.

5. Select the Employee Tenure, Position Tenure, and Salary Group columns and select Column Info.

Formulas for the selected columns appear in the data table’s Column Settings window.

**Example of Showing Summary Statistics**

This example shows how to find columns with a low standard deviation. This can be helpful if you want delete or exclude that data from an analysis.

1. Open the Semiconductor Capability.jmp sample data table.
2. Select Cols > Columns Viewer to open the Data Table Columns Viewer window.
3. In the Select Columns red triangle menu, select Name Starts With.
4. Type PNP and press Enter to select the PNP columns (Figure 4.11).

**Figure 4.11** Filter Columns by Name

![Filter Columns by Name](image)
5. Click **Show Summary** to add the Summary Statistics report (Figure 4.12).

The rows show the minimum, maximum, mean, and standard deviation for each column.

**Figure 4.12** Summary Statistics for Selected Columns

![Summary Statistics](image)

6. Right-click in the report and select **Sort by Column**.

7. Select **Std Dev** and **Ascending**, and then click **OK**.

Notice that PNP6 has no standard deviation, because the minimum, maximum, and mean values are 0.

**Figure 4.13** Sorted Std Dev Column

![Sorted Std Dev](image)

8. In the Summary Statistics report, select the row for PNP6 and then display the data table.

9. View the data table and press **Delete** to remove the selected column.

The column is instantly removed from the data table.

10. To close the Columns Viewer, click the **X** button in the upper right corner (Windows) or upper left corner (Macintosh) of the window.

**Select Cells**

To select a block of cells:

- Drag the arrow cursor diagonally across the cells.
JMP can find all cells whose values are the same as the ones you currently have highlighted. You can do this within one data table or throughout all open data tables. Highlight the cells that contain the values that you want to locate.

To find all matching cells within the active data table:

- Select Rows > Row Selection > Select Matching Cells
  or
- Right-click one of the highlighted row numbers and select Select Matching Cells.

To find all matching cells across all open data tables:

- Select Rows > Row Selection > Select All Matching Cells. The rows that contain the same values as the selected ones are highlighted.

To select cells that contain specific values:

JMP can search for a specific value (or text string) and highlight all of the cells in the data table that contain the specific value.

1. Select Rows > Row Selection > Select Where.

Figure 4.14 Specify Criteria for Selecting Rows

2. From the column list, highlight the name of the column whose rows you want to select.
3. Use the drop-down menu to select a condition from the list (equals, does not equal, and so on). See Figure 4.14.
4. Type the search value. To search for missing values, leave the box empty.
5. Click OK.
You can also specify the following optional features:

- To compare the values of two columns, click the **Compare column** check box. Select from the list of columns for comparison.
- To make the search case-sensitive, click the box beside **Match Case**.

If you currently have rows selected in the data table, you can specify the following optional features:

- Click an option under **Action on currently selected rows** to tell JMP how to handle that current selection:
  - **Clear Current Selection** removes the highlight from currently selected rows and selects all rows that contain the specified value.
  - **Extend Current Selection** keeps the currently selected rows selected and also selects the rows in which the specified value has been found.
  - **Select From Current Selection** selects the rows in the currently selected array that contain the specified values.
- Click **Add Condition** to add a condition to the list.
- To add more conditions to the search, repeat the previous steps. Click the appropriate item in the **Select Rows** area to specify if you would like JMP to select rows conditionally: if *all* conditions are met, or if *any* of the conditions are met.
- To keep the window open after you click **OK**, select **Keep dialog open**.

---

**Edit Data**

This section describes how to edit data in a table, including editing cells and making changes to rows and columns.

**Delete Rows and Columns**

*To delete rows:*

1. Highlight the rows that you want to delete.
2. Press the Delete key, or right-click on the row numbers and select **Delete Rows**.

**Caution:** When you try to delete thousands of rows, an alert might appear if your computer has insufficient memory. Click **No** to cancel the deletion, and then try to delete fewer rows.

*To delete columns:*

1. Highlight the columns to delete.
2. Press the Delete key, or right-click and select **Delete Columns**.

**Edit or Delete Cells**

*To edit or delete the contents of a cell:*

1. Click the cell containing the value that you want to edit or delete.
2. Press the Delete key.
3. To edit the value, click the cell a second time, and then edit the cell’s value.

**Edit Column Names**

To edit a column name, select the column and begin typing. You can also edit the column name in the Column Info window.

**Recode Data**

If you have data that is coded incorrectly (for example, contains typographical errors or incorrect wording), you can recode it so that it follows a consistent format. You can also use the recode feature to replace missing or empty values.

**Note:** If you need to recode similar values within multiple columns, use the Recode option in **Cols > Standardize Attributes**. See “Recode Values” on page 192 in the “Set Column Properties” chapter.

*To recode data:*

1. Select the columns containing the data that you would like to recode.
2. Select **Cols > Recode**.

**Figure 4.15** Example of the Recode Window

3. Type the new value in the text box corresponding to the old value that you want to change.
4. Specify how you would like the text to be recoded. See “Recode Options” on page 134.
5. Click **OK**.
Recode Options

In Place   applies any change to the original data column.
New Column  creates a new column for the changed data and retains the original column.
Formula Column  creates a new column with the changes as a formula instead of values.
Script   creates a new script called Recode in the data table. You can run this script to perform recoding in-place. If you add more recodes later, the script updates (assuming that you select Script as the destination). You can run this script later, to new data, and copy it to other data tables, or run it from your own scripts.

Red Triangle Options for Recode

The red triangle menu contains options for the Recode window. The first three commands apply to all items in the data table list.

Convert to Titlecase  converts to title case, that is, an initial uppercase character and subsequent lowercase characters for each word.
Convert to Uppercase  converts all items to uppercase.
Convert to Lowercase  converts items to lowercase.

Tab characters, space characters, and line separators are often imported into a data table. Remove these characters using the following commands:

Trim Whitespace  removes leading and trailing whitespace characters. For example, if an extra space was imported before and after the name John, this command would delete the spaces.
Collapse Whitespace trims leading and trailing whitespace characters and removes duplicate interior white space. That is, if more than one whitespace character is present, the Collapse Whitespace command replaces the two spaces with one space.

View Patterns of Missing Data

If your data table contains missing data, you might want to determine whether there is a pattern to the missing data. The pattern might help you make discoveries about your data.

To view patterns of missing data:
1. With your data table open, select Tables > Missing Data Pattern.
2. Select the columns for which you would like to find patterns of missing data.
3. Click Add Columns.
4. Select the Count Missing Value Codes check box if you want to count missing value codes as missing values.
5. Click OK.

**Example of Viewing Patterns of Missing Data**

1. Open the Missing Data Pattern.jmp sample data table.
2. Select **Tables > Missing Data Pattern**.

*Figure 4.16 The Missing Data Pattern Window*

3. Highlight all of the columns.

**Note:** For details about the options in the red triangle menu, see “Columns Filter Menu” on page 280 in the “JMP Platforms” chapter.

4. Click **Add Columns**.
5. Click **OK**.

*Figure 4.17 A Missing Data Pattern Table*

**Tip:** To quickly create a Treemap or Cell Plot of the data, select Run Script from the red triangle menu next to Treemap or Cell Plot in the Table panel.
Figure 4.17 shows the following patterns:

- Row 1 shows that there are two instances where all rows in Trial 1, Trial 2, Trial 3, and Trial 4 have no missing values.
- Row 2 shows that there are two rows in the source table whose one missing value is in the Trial 4 column.
- Row 3 shows that there are two rows in the source table whose missing values are in the Trial 3 and Trial 4 columns.
- Row 4 shows that there is one row in the source table whose three missing values are in the Trial 2, Trial 3, and Trial 4 columns.

In the Missing Data Pattern table, JMP automatically assigns the Count column the analysis role of frequency. If you now use the Missing Data Pattern data table to run an analysis, JMP automatically uses Count as a frequency. So you do not have to specify Count as the role each time. For details, see “Assign Column Properties” on page 178 in the “Set Column Properties” chapter.

Find and Replace Cell Values

You can find and replace cell values by selecting the Edit > Search options.

The following rules apply to searching for values:

- To find values in hidden columns, unhide the column.
- Values found in locked columns cannot be modified.
- The Undo command works only with Replace. You cannot undo Replace All.
- If your data table contains value labels, using the Search commands searches for actual values, but does not search for labels. See “Value Labels” on page 180 in the “Set Column Properties” chapter.
- If your data table contains formatted values (such as dates, times, or durations) using the Search command searches for the formatted values, not the actual values.
**Find Window Options**

Refine your search with the following options:

- **Match Case**  Performs a case sensitive search, which can be useful for locating proper nouns or other capitalized words.

- **Match entire cell value**  Detects empty spaces, which lets you search for a series of words in a character column, or locate strings with unwanted leading or trailing empty spaces.

**Tip:** To find missing character values, leave the Find what box empty and check Match entire cell value. To find missing numeric values, insert a period into the Find box and check Match entire cell value.

- **Use regular expressions**  Assumes the find string to be a regular expression instead of the literal string that you enter in the Find what box. The regular expressions follow standard semantics.

- **Restrict to selected rows**  Restricts the search to selected rows.

- **Restrict to selected columns**  Restricts the search to selected columns.

- **Search data**  Searches only data cells (omitting column names).

- **Search column names**  Searches only column names (omitting data cells).

- **By column**  Searches the table column by column, from top to bottom, until it reaches the last cell in the rightmost column, or until you stop the search.

- **By row**  Searches the data table row by row from left to right, to the rightmost cell in the last row or until you stop the search.

- **Multiple lines**  Increases the Find and Replace boxes to 3 lines long instead of 1. The Enter key inserts a return into the field.

**Tip:** You can alternatively click and drag on the Find and Replace boxes to make them larger. If you copy and paste, the boxes resize to 1 line long, but all of your text is still there.

- **Keep dialog open**  Keeps the Find window open during your search.

**Search Actions**

This section describes some common searches that you might perform.

Begin by searching for a value in the data table. The search begins with the first cell in the first column and searches every cell until it locates the value or reaches the end of the table.
To replace the currently highlighted cell value:
Enter a value in the Replace with box and click Replace. Or, if the Search window is closed, select Edit > Search > Replace. If the replace value is a missing value, the currently highlighted cell content becomes a missing value.

To replace all occurrences of the specified value:
Enter a value in the Replace with box and click Replace All. Or, if the Search window is closed, select Edit > Search > Replace All.

To replace the value and search for the next value:
Enter a value in the Replace with box and click Replace. Or, if the Search window is closed, select Edit > Search > Replace and Find Next. Or, press CTRL-L.

To use a selected value as the Find what value:
In the data table, select a value. Select Edit > Search > Use Selection for Find. Next, select Edit > Search > Find. The value that you selected in the data table is already entered in the Find what field.

To use a selected value as the Replace with value:
In the data table, select a value. Select Edit > Search > Use Selection for Replace to populate the Replace with field.

To find the next value when the Search window is closed:
Select Edit > Search > Find Next. Or, press CTRL-G, or F3 on Windows.

To find a missing value:
- To find missing character values, leave the Find what field empty and select Match entire cell value.
- To find missing numeric values, type a period into the Find what text box and select Match entire cell value.

Note: Typing a period into the text box without clicking the Match entire cell value box searches for a period.
Reorder Columns

You can rearrange or sort data table columns by their name, data type, or modeling type, or reverse the current order. To reorder columns, select Cols > Reorder Columns and select from one of the following options:

**Move Selected Columns** moves the selected columns to a particular place in the data table. Specify where to place the selected columns in the Move Selected Columns window:
- **To first**: moves the selected columns so they are in the left-most position in the data table.
- **To last**: moves the selected columns so they are in the right-most position in the data table.
- **After**: moves the selected columns so they are after a column that you identify.

**Original Order** returns the columns to the order they were in at the time the data table was last saved.

**Reorder by Name** arranges the columns from left to right in alphabetical order by column name.

**Reorder By Data Type** arranges the columns from left to right in alphabetic order by data type (row state, character, numeric).

**Reorder By Modeling Type** arranges the columns from left to right in alphabetic order by modeling type (continuous, ordinal, nominal). Row state columns have no modeling type, and are shown last.

**Reverse Order** reverses the order of the data table columns.

Group Columns

Group columns within a single heading to manage large numbers of columns and facilitate analysis role assignment. Grouped columns appear in an outline format within the Columns panel.

To group or ungroup columns:

1. Within the data grid, select the columns that you want to group.
2. From the main menu, select Cols > Group Columns or Cols > Ungroup Columns.
   
   or

1. From the Columns panel, select the columns that you want to group.
2. Right-click on the selected columns and select Group Columns or Ungroup Columns.
Note: Grouped columns are automatically retained for data tables generated from the following commands: **Subset**, **Sort**, **Summary**, **Join**, **Stack**, and **Split**. For the **Stack** command, if all the columns in the stack group belong to the same columns group, then the group’s name is used for the column name.

**Move Values**

To move values in a data table, select the values, click and pause, and then drag and drop the values into the new location.

**Tip:** Clicking and dragging on a selection without pausing extends the selection.

When dragging and dropping values, note the following:

- Cells retain all of their characteristics and column properties.
- After you move cells, missing values appear in the cells that you initially selected.
- The selected cells and the destination cells must have the same data type.
- If you drag a set of cells to an empty area of the table, new columns are automatically created.
- New columns have the original columns’ display format and modeling types.

**To specify where to move rows:**

1. Highlight the rows that you want to move.
2. Select **Rows > Move Rows**.
3. Specify where you would like to move the rows in the Move Rows window:
   - To the beginning of the table (**At start**)
   - To the end of the table (**At end**)
   - After a specific row number (**After row:**)

**Move Content into Another Window**

In Windows, you can drag selected content over a minimized window. The minimized window moves to the front and you can paste your content into it. You can do the same thing in JMP. For example, you can drag selected content over the Home Window button (located in the bottom right corner of most windows). Then in the Window List, drag the content over the window that you want to move the content into. That window moves to the front and you can drop in the content.

**Tip:** If you cannot see the **JMP Home Window** button, select **View > Status Bars**.
For example, you can drag a selected column, row, or cell from one data table into another; drag selected text from one script window into another; or drag selected content from a report into a journal.

**Use the Row Editor**

Use the Row Editor to browse or edit cells one row at a time. Open the Row Editor in one of the following ways:

- **Select** Rows > Row Editor.
- In a data table, double-click in the row number area. The row that you use is the row that first appears in the Row Editor.
- In a report window, right-click in a plot or graph and select **Row Editor**.

**Figure 4.19 Row Editor**

![Row Editor](image)

Note the following:

- If you have a report window open, and you want edited data to be automatically reflected there, make sure that Automatic Recalc is turned on. See “Automatic Recalc” on page 293 in the “JMP Platforms” chapter.
- If your data table contains value labels, the Row Editor displays the label, and when the cell is highlighted for editing, it shows the actual value. See “Value Labels” on page 180 in the “Set Column Properties” chapter.
Row Editor Buttons

Click the arrow buttons to browse through selected rows or the entire data set if no rows are selected. Row Editor buttons are described as follows:

- Shows the previous row.
- Shows the previously selected row.
- Makes the row blink in graphs.
- Shows the next selected row.
- Shows the next row.
- Searches for a row. See “Select Cells” on page 130.
- Creates a new row at the end of the data table.

Row Editor Options

The red triangle menu in the Row Editor contains the following options:

- Next Selected displays information for the selected row that is located after the current one.
- Prev Selected displays information for the selected row that is located before the current one.
- Next displays information for the row that is located after the current one, regardless of whether the row is selected.
- Prev displays information for the row that is located before the current one, regardless of whether the row is selected.
- Save saves the data table and any changes that you have made to it via the Row Editor.
- New Row creates a new row in the data table.
- Find displays the same window as if you had selected Rows > Row Selection > Select Where. Select one of the options on the Action on currently selected rows menu, and then highlight the column whose rows you want to select. Type in the value for which you want JMP to search. See “Select Cells” on page 130.
- Blink causes the current row’s highlight to flash at a rapid rate.

Note: Text in a locked column or a locked data table cannot be edited. For details, see “Lock Tables” on page 145, and “Lock Columns in Place” on page 165.

Context Menus for Rows and Columns

When you right-click in the row number area, or at the top of a column in the column name area, context menus appear. These menus provide quick access to selected commands in the Rows and Columns menus. For details about these options, see “Context Menu for Columns”
on page 46 in the “Get Started” chapter and “Context Menu for Rows” on page 47 in the “Get Started” chapter.

**Make Binning Formula**

You can distribute your data into equal width bins using the Make Binning Formula option. Select the column or columns that you want to divide into bins, then select **Cols > Make Binning Formula**. New formula columns are added to the data table.

The Make Binning Formula window contains the following options:

- **Format**: Select a format for displaying the range of values in the bin. You can see a preview by moving the cursor over the graph.
- **Bin Shape: Offset**: Select an offset value for the lower edge of the bins.

**Note**: Bins are identified by their lower edge. The lower edge is in the bin. The upper edge is in the next bin because it is the next bin’s lower edge.

- **Bin Shape: Width**: Select the width of values for the bins.

**Note**: The colored bands reflect the offset and the width of the bins with respect to the data.

- **Labels**: Select **No Labels** to use the lower edge value as the label. Or, you can use the Value Labels property as either labels or ranges. For more information, see “Value Labels” on page 180 in the “Set Column Properties” chapter.

**Tip**: For use with the Categorical platform, value labels are recommended. Axes may be better labeled with range labels.

- **Make All Like X**: (Appears only if multiple columns are selected) Applies the choices made for the first column (X) to the remaining columns.

- **Make Formula Columns**: Creates the formula columns and closes the window.

**Example of Making a Binning Formula**

1. Open the Big Class.jmp sample data table.
2. Select the height column.
3. Select **Cols > Make Binning Formula**.

You want the range of values to appear as X-X, so keep the range set to **Low - High**.
4. Change the **offset** to -0.5.
For integer data, setting the offset to -0.5 helps to disambiguate values on the edge. In this example, one of the bins covers 59.5 to 64.5, so it is clear that 59 and 65 are not included in this bin.

5. Keep the width set to 5.
6. For the labels, keep it set to Make Value Labels, so that you can see the range of values for the bin.

Figure 4.20 Completed Binning Window

7. Click Make Formula Columns.
A column called height Binned is added to the Big Class.jmp data table.
8. To see how the formula is calculated, right-click on the height Binned column and select Formula.

Figure 4.21 Formula

Edit Data Tables

This section describes the following actions that you can perform on data tables:

- Change the data table name
- Lock data tables
- Add table variables
- Add scripts to the data table
- Compare data tables
Change Table Names

A data table’s name appears at the top of its window, in the table panel, and on all related analysis reports. You can change a data table’s name in any of the following ways:

- Select File > Save As and save as the new name.
- In the table panel, click twice on the table name, type the new name, and then press the Enter key.
- On Windows, select Window > Set Title.

Lock Tables

Locking a JMP data table prevents its values from being edited. You can still run analyses, assign characteristics, and so on. To lock a data table, click the red triangle menu next to the table name in the table panel and select Lock Data Table.

A lock icon 🠅 appears next to the data table name. To unlock the file, select Lock Data Table again.

If you make a data table read-only outside of JMP (for example, by changing its properties on Windows), the data table contains a note informing you that it is locked. See Figure 4.22. This type of lock allows users to edit the data table, but not save the changes.

Figure 4.22 A Read-Only File

Compress Tables

Compressing a JMP (version 6 or higher) data table reduces the size of the stored file. You can still run analyses, assign characteristics, and so on. To compress a data table, click the red triangle menu next to the table name in the table panel and select Compress file when saved and save the data table.
**Note:** To save a data table using compression, you must enable saving tables in the extended file format by selecting *Preferences > Tables > Save table in extended file format*. This preference is selected by default.

After saving the data table, a compressed icon 🎨 appears next to the data table name. To decompress the file, select *Compress file when saved* again.

In addition, you can configure JMP to always use GZ compression when saving by selecting *Preferences > General > Save Data Table Columns GZ Compressed*.

**Note:** The *Compress file when saved* option only decreases the file size. This command does not affect the memory required to analyze the data. To reduce both the file size and memory required for analyzing, use *Cols > Compress Selected Columns*. See “Compress Selected Columns” on page 195 in the “Set Column Properties” chapter.

### Use Table Variables

A table variable can contain textual information (for example, source information for the data), or a value that can be used by column formulas or JSL scripts. Table variable names appear in the table panel at the left of the data grid. See Figure 4.23.

#### Figure 4.23 Table Variables in the Table Panel

<table>
<thead>
<tr>
<th>Table variables</th>
<th>Cols (MI)</th>
<th>Cell Type</th>
<th>Treatment</th>
<th>Prior</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cansort</td>
<td>1</td>
<td>Adevra</td>
<td>Standard</td>
<td>No</td>
</tr>
<tr>
<td>Doseage Amount</td>
<td>2</td>
<td>Adevra</td>
<td>Test</td>
<td>No</td>
</tr>
<tr>
<td>Location</td>
<td>3</td>
<td>Adevra</td>
<td>Standard</td>
<td>Yes</td>
</tr>
<tr>
<td>Concentrate</td>
<td>4</td>
<td>Adevra</td>
<td>Test</td>
<td>No</td>
</tr>
<tr>
<td>Time</td>
<td>5</td>
<td>Adevra</td>
<td>Standard</td>
<td>Yes</td>
</tr>
<tr>
<td>Cell Type</td>
<td>6</td>
<td>Adevra</td>
<td>Test</td>
<td>Yes</td>
</tr>
<tr>
<td>Treatment</td>
<td>7</td>
<td>Adevra</td>
<td>Test</td>
<td>No</td>
</tr>
<tr>
<td>Prior</td>
<td>8</td>
<td>Adevra</td>
<td>Test</td>
<td>No</td>
</tr>
</tbody>
</table>

### Uses for Table Variables

Use table variables in the following situations:

- To document tables
- In formulas
- In JSL scripts
Use Table Variables to Document Tables

Table variables are used primarily to document tables. Many sample data tables installed with JMP contain a table variable named Notes. This variable provides details about the data (for example, the source of the data). The example in Figure 4.23 shows a data table that contains Notes as one of its table variables. JMP also automatically creates table variables when you create a design table using the Design of Experiments commands in JMP. The design table has a table variable named Design with the name of the design type as its value.

Reference Table Variables in Formulas

Table variables can also be incorporated in formulas that you build using the Formula Editor. These formulas calculate values for a column by referring to a table variable. For details about constructing a formula that uses table variables, see “Reference Columns and Table Variables” on page 238 in the “Formula Editor” chapter.

Use Table Variables in JSL Scripts

You can also incorporate table variables into JSL scripts. See the Scripting Guide for details.

Table Variable Actions

To add new table variables

1. In the Table panel, click the red triangle menu to the left of the data table name.
2. Select New Table Variable.
3. Give the variable a name and value in the boxes labeled Name and Value.
4. Click OK.

   The table variable appears in the Table panel.

To view or edit table variables

1. Double-click on the content of an existing table variable.
2. Edit the content.

To edit a table variable name

1. Double-click the table variable name.
2. Edit the name.

To delete table variables

Right-click the table variable name or value and select Delete.
Concatenating Data Tables with Table Variables

See the “Example of Concatenating Data Tables and Table Variables” on page 219 in the “Reshape Data” chapter.

Create and Save Scripts

**Note:** Starting in JMP 10, the Script window is non-modal, meaning that you can access other windows and perform other operations while you are in the Script window.

To automatically complete various analyses and tasks, you can create a JSL script and save it to the data table. See Figure 4.24. For detailed explanations of scripts, see the *Scripting Guide*.

**Figure 4.24** Scripts Saved With the Data Table

<table>
<thead>
<tr>
<th>Name</th>
<th>Age</th>
<th>Sex</th>
<th>Height</th>
<th>Weight</th>
</tr>
</thead>
<tbody>
<tr>
<td>KATE</td>
<td>12</td>
<td>F</td>
<td>69</td>
<td>95</td>
</tr>
<tr>
<td>LOUISE</td>
<td>12</td>
<td>F</td>
<td>61</td>
<td>123</td>
</tr>
<tr>
<td>JANE</td>
<td>12</td>
<td>F</td>
<td>55</td>
<td>74</td>
</tr>
<tr>
<td>JACLYN</td>
<td>12</td>
<td>F</td>
<td>65</td>
<td>145</td>
</tr>
<tr>
<td>LILLIE</td>
<td>12</td>
<td>F</td>
<td>52</td>
<td>94</td>
</tr>
<tr>
<td>TIM</td>
<td>12</td>
<td>M</td>
<td>60</td>
<td>94</td>
</tr>
<tr>
<td>JAMES</td>
<td>12</td>
<td>M</td>
<td>61</td>
<td>120</td>
</tr>
<tr>
<td>ROBERT</td>
<td>12</td>
<td>M</td>
<td>61</td>
<td>79</td>
</tr>
<tr>
<td>BARBARA</td>
<td>13</td>
<td>F</td>
<td>60</td>
<td>112</td>
</tr>
<tr>
<td>ALICE</td>
<td>13</td>
<td>F</td>
<td>61</td>
<td>107</td>
</tr>
<tr>
<td>SUSAN</td>
<td>13</td>
<td>F</td>
<td>56</td>
<td>87</td>
</tr>
<tr>
<td>JOHN</td>
<td>13</td>
<td>M</td>
<td>65</td>
<td>96</td>
</tr>
<tr>
<td>JOE</td>
<td>13</td>
<td>M</td>
<td>63</td>
<td>105</td>
</tr>
<tr>
<td>MICHAEL</td>
<td>13</td>
<td>M</td>
<td>58</td>
<td>95</td>
</tr>
<tr>
<td>DAVID</td>
<td>13</td>
<td>M</td>
<td>59</td>
<td>73</td>
</tr>
<tr>
<td>JUDY</td>
<td>14</td>
<td>F</td>
<td>61</td>
<td>91</td>
</tr>
<tr>
<td>ELIZABETH</td>
<td>14</td>
<td>F</td>
<td>62</td>
<td>91</td>
</tr>
<tr>
<td>LESLIE</td>
<td>14</td>
<td>F</td>
<td>65</td>
<td>142</td>
</tr>
<tr>
<td>CAROL</td>
<td>14</td>
<td>F</td>
<td>63</td>
<td>84</td>
</tr>
<tr>
<td>PATTY</td>
<td>14</td>
<td>F</td>
<td>62</td>
<td>85</td>
</tr>
<tr>
<td>FREDERICK</td>
<td>14</td>
<td>M</td>
<td>63</td>
<td>93</td>
</tr>
<tr>
<td>ALFRED</td>
<td>14</td>
<td>M</td>
<td>64</td>
<td>99</td>
</tr>
<tr>
<td>HENRY</td>
<td>14</td>
<td>M</td>
<td>65</td>
<td>119</td>
</tr>
</tbody>
</table>

Save a Report Script to a Data Table

Once you have run an analysis and you are in the report window, you can add a script to the data table. This script generates the JSL that reproduces your analysis.

*To save a script to the data table:*

- From the report window, click on the red triangle menu for the platform and select **Script > Save Script to Data Table**.
Example of Saving a Report Script to a Data Table

First, you create your analysis, then you save the script.

1. Open the Big Class.jmp sample data table.
2. Select Analyze > Fit Y by X.
3. Select weight and click Y, Response.
4. Select height and click X, Factor.
5. Click OK.
6. From the red triangle menu, select Fit Line.
7. From the red triangle menu for Bivariate Fit, select Script > Save Script to Data Table.

**Figure 4.25** Click the Red Triangle

The script is added to the bottom of the Table panel.

**Tip:** If you want a particular script to run automatically every time the data table is opened, name the script OnOpen. Only one script saved in the data table can be set to run automatically. If you name the script Model (or model) in a Fit Model script, the launch window is automatically filled in based on the script when you select Analyze > Fit Model.
Write a JSL Script for the Data Table

To add a script to a data table using JSL:

1. Click the red triangle menu to the left of the data table name in the Table panel. See Figure 4.26.

Figure 4.26 Creating a Script

2. Select New Script.

3. Give the script a name by typing it into the box beside Name.

4. Add the script by entering JSL code into the box beside Script.

5. Perform one of the following actions:
   - If you want to run the JSL Debugger on the script to check it for errors, click Debug Script.
   - If you are finished editing the script, click OK. The script appears in the Table panel and the window closes.
   - If you are not finished editing the script and want to save it, click Save. The script appears in the Table panel and the window remains open for further editing.
   - If you want to run the script, click Run.
Run, Edit, Delete, or Copy Scripts

To run, edit, delete, or copy a script that is saved to the data table:

1. In the Table panel, click the red triangle menu beside the script's name, or right-click on the script name.
2. Select one of the following commands:
   - Run Script
   - Edit
   - Delete
   - Copy

Once you copy a script, you can then paste it into a script window or into the Table panel of another data table.

Compare Data Tables

JMP can compare two open data tables and report the differences between data, scripts, table variables, column names, column properties, and column attributes. Character values that do not match exactly appear in the report. For numeric data, you can select a relative (or fuzzy) comparison. The numeric values are considered equal if they are within the relative error rate that you specify. The smaller the relative error, the more precise the comparison.

To compare two data tables:

1. Open the data tables.
2. In one of the tables, select Tables > Compare Data Tables.
3. If necessary, select the data table that you want to compare from the list.
4. (Optional) Select Fuzzy Compare and enter the relative error to see numeric differences within the specified rate.
5. Click on the red triangle menu and select the following options:
   - which items you want to compare
   - how to show the differences
6. Click Compare.

The Difference Summary and Difference Plot are shown by default. The red triangle options that you selected also appear.
Basic Table Information

The Tables Info report shows the data table names and locations along with the numbers of columns and rows in each table. In Figure 4.27, you see that Big Class1.jmp contains one more row than Big Class2.jmp.

Figure 4.27 Basic Information

Compare Data

The interactive Difference Summary report and Different Plot indicate how rows differ between reports. Each entry in the Difference Summary report shows which action occurred, how many rows are affected, and the first row in which the change occurs.

In Figure 4.28, Big Class1.jmp (left) and Big Class2.jmp (right) are compared.

- The first entry in Figure 4.28 indicates that one row (N) has changed (or been replaced) in the first row of Big Class2.jmp. When you select the entry in the Difference Summary report on the left, the entry is highlighted in yellow, and the row flashes in the data table.

  For a graphical view of the comparison, place your cursor over a colored cell in the Difference Plot. Figure 4.28 shows that the name KATIE in Big Class1.jmp was changed to KIM in Big Class2.jmp. The entire first row is highlighted in the Difference Plot, which tells you that all values in that row are different.

Figure 4.28 Modified Data
• In Figure 4.29, the second entry indicates that two rows were deleted beginning at row four. The deleted rows are highlighted in Big Class1.jmp on the left. And the Difference Plot specifies the different values. The name in row four of Big Class1.jmp was JACLYN and TIM in Big Class2.jmp.

Figure 4.29 Deleted Rows

• In Figure 4.30, the third entry tells you that one row was added before what was originally row eight. The name in row eight of Big Class1.jmp was ROBERT. PETER is the name in row six of Big Class2.jmp.

Figure 4.30 Identify New Rows

Click the Previous difference and Next difference buttons above the Difference Summary to navigate from row to row.
Tip: Save the Difference Summary report to a data table by selecting Save Difference Summary from the red triangle menu.

Compare Table Properties

Select Compare Table Properties from the red triangle menu to see differences in table scripts and variables. For example, Figure 4.31 shows that the Distribution script in Big Class2.jmp refers to the height column rather than the weight column.

Figure 4.31 Modified Table Script

Compare Column Attributes and Properties

Select Compare Column Attributes and Properties from the red triangle menu to see differences in column notes, cell colors, and the like. For example, Figure 4.32 shows that column notes and value colors differ in Big Class2.jmp.

Figure 4.32 Modified Column Attributes and Properties

original values  new values
Assign Characteristics to Rows and Columns

This section describes how to exclude, hide, label, color, or mark rows and columns in order to customize the appearance of points in scatterplots and graphs. You can also lock columns so that they stay in place when you scroll through the data table.

The menu for row actions can be accessed from the following places:
- the **Rows** menu in the main menu
- right-click on a row
- the red triangle in the Rows panel
- the left red triangle in the upper left corner of the data grid

Similarly, the menu for columns actions can be accessed from the following places:
- the **Cols** menu in the main menu
- right-click on a column
- the red triangle in the Columns panel
- the right red triangle in the upper left corner of the data grid

Hide and Exclude Rows

Hiding and excluding rows means that they will be hidden in plots and not they will not be analyzed.

*To hide and exclude one or more rows from analyses:*
1. Highlight one or more rows that you want to hide and exclude.
2. Right-click on the selected rows and select **Hide and Exclude**.
   or
   From the **Rows** menu, select **Hide and Exclude**.

Exclude Rows and Columns

Marking rows and columns as excluded means that they will not be analyzed. Note the following:

- Excluded observations are excluded from calculations in text reports and graphs. For most platforms, excluded observations are not hidden in plots.
- Use **Hide/Unhide** to hide observations in plots and graphs for most platforms. See “Hide Rows and Columns” on page 156.
• A circle with a strikethrough (●) appears beside either the row number or the column name in the Columns panel. The circle indicates that the row or column is excluded and therefore not analyzed.

• For most platforms, data remain excluded until you select Exclude/Unexclude again.

To exclude one or more rows from analyses:
1. Highlight one or more rows that you want to exclude.
2. Right-click on the selected rows and select Exclude/Unexclude.
   or
   From the Rows menu, select Exclude/Unexclude.

To exclude one or more columns from analyses:
1. Highlight one or more columns that you want to exclude.
2. Select Cols > Exclude/Unexclude or right-click select Exclude/Unexclude.

To unexclude rows or columns:
1. Highlight the excluded rows or columns that you want to include in your analyses.
2. Select Exclude/Unexclude from the Rows menu or Cols menu. You can also right-click rows or columns and select Exclude/Unexclude.

Hide Rows and Columns

Marking rows and columns as hidden means that they do not appear in plots and graphs. Note the following:

• Hiding rows and columns does not exclude them from analyses. They simply do not appear in plots and graphs.

• To exclude hidden observations from analyses, use the Exclude/Unexclude option. See “Exclude Rows and Columns” on page 155.

• A mask icon (■) appears beside the hidden row number or the column name, indicating that the row or column is hidden.

• Observations remain hidden until you select Hide/Unhide again.

To hide one or more rows:
1. Highlight one or more rows that you want to hide.
2. Right-click on the selected rows and select Hide/Unhide
   or
   From the Rows menu, select Hide/Unhide.
To hide one or more columns:
1. Highlight one or more columns that you want to hide.
2. Select **Cols > Hide/Unhide** or right-click and select **Hide/Unhide**.

To unhide rows or columns:
1. Highlight the hidden rows or columns that you want to show in your plots and graphs.
2. Select **Hide/Unhide** from the **Rows** menu or **Cols** menu. You can also right-click rows or columns and select **Hide/Unhide**.

**Label Rows and Columns**

When you position the arrow cursor over a point in a plot, the point's label appears. By default, row numbers are used as labels. You can customize the labels as follows:

- You can change the label to display column values instead of the row number.
- You can enable the label to always appear, not only when you position the cursor over points.
- A label or yellow tag icon (-unused-) appears beside the column name in the Columns panel, indicating that points on plots are identified by the column value. If there are multiple columns that are labeled, their values appear on plots separated by a comma.
- Data remain labeled until you select **Label/Unlabel** again.

To change the label to display column values:
1. Highlight one or more columns whose values you want to appear as the label in plots.
2. Select **Cols > Label/Unlabel** from the menu or right-click and select **Label/Unlabel**.

To enable the label to always appear (not just when you position the cursor over points):
1. Highlight one or more rows whose label you want to always appear in plots.
2. Select **Rows > Label/Unlabel** from the menu.

To turn off labeling for rows or columns:
1. Highlight the labeled rows or columns that you no longer want labeled.
2. Select **Label/Unlabel** from the **Rows** menu or **Cols** menu. You can also right-click columns or rows and select **Label/Unlabel**.

**Assign Colors or Markers to Rows**

- If you assign a color to a row, the points representing the values in that row are colored in the plot.
• If you assign a marker to a row, the point is replaced with the marker in the plot.
• You can also assign colors or markers based on column values.

Assign a Color to Rows

Assigning a color to selected rows means that the points in plots appear in the color that you select. In the data grid, the active color assigned to a row appears next to the row number.

To assign rows a color:
1. Highlight one or more rows that you want to assign a color to.
2. Right-click on the highlighted rows and select **Rows > Colors**.
3. Select one of the available colors.

Tip: To clear an assigned color from the selected rows, assign the color black.

Add Markers to Rows

To replace the standard points in plots with a marker, use the JMP markers palette. In the data table, these markers also appear next to row numbers.

1. Highlight one or more rows that you want to apply the marker to.
2. Right-click on the selected rows and select **Markers**, and then select the marker shape.
   Select **Other** to create custom markers. You can type alphabetic characters, numerals, and other keyboard symbols.

Tip: To return to the default marker, select the initial dot marker.

Assign Colors or Markers to Rows Based on Column Values

You can assign colors or markers to your data table rows based on the values found in a particular column. For example, in a column called **Sex**, you could assign all rows whose value is **F** a red circle marker. All rows whose value is **M** could have a green plus marker. These colors and markers replace the default black dot in plots and appear next to its row number in the data table.

To assign colors or markers to rows based on column values:
1. Select **Rows > Color or Mark by Column**.
2. Highlight the column to assign the color or marker to. See Figure 4.33.
3. Select the Colors and Markers schemes to apply.  
   A preview of your selection appears under Row States.
4. (Optional) Select any additional options. See “Color or Mark by Column Options” on page 159.
5. Click OK.
6. (Optional) To shade all rows according to their row state, right-click in the row numbers area within the data grid and select **Color Rows by Row State**.
   From then on, the rows are shaded with the color that you assign to the rows.

**Color or Mark by Column Options**

**Colors** select a color theme to assign different colors to the rows in your data table. Color assignment is based on the values of the selected column.

**Continuous Scale** assigns colors in a chromatic sequence based on the values in the highlighted column.

**Reverse Scale** assigns colors in a reversed chromatic sequence based on the values in the highlighted column.

**Markers** assigns a different marker to each row in your data table based on the values found in the column that you highlighted.

**Make Window with Legend** Includes a legend with your new characteristics so that you can easily identify which colors and markers correspond with which row.

**Save To Column Property** saves the color and marker information as a column property. The rows in the selected column of the data table are colored, based on the color theme.

**Save To Table Property** saves the color and marker information as a table property.

**Excluded Rows** assigns colors or markers to rows that are excluded.
Create Color Themes

JMP includes several color themes that can distinguish a range of values in a graph. You can also create your own color themes based on an existing color theme or create custom themes.

Note: When you select a default color theme, the colors are not applied to reports that are open. You need to rerun the existing reports to format them with the default color theme.

See “Delete Custom Color Themes” on page 165 for details on deleting custom color themes.

To create a color theme:

1. Select File > Preferences > Graphs.
2. To either create a new Continuous Color Theme or Categorical Color Theme, click the appropriate color theme.
   If you are creating a new continuous color theme, the Continuous Color Themes window appears.

Figure 4.34  Continuous Color Themes Window

[Image of the Continuous Color Themes window]

If you selected to create a new categorical color theme, the Categorical Color Themes window appears.
3. (Optional) To base the theme on an existing theme, select a color themes from the available themes.

4. Click the Custom Color Theme disclosure button to show the Custom Color Theme panel. Figure 4.36 shows the color theme panels for both continuous and categorical themes (respectively).

5. Click **New** to create a new theme.
   A new color theme is created based on the selected color theme. A temporary name is assigned to the theme.

6. Type a new name in place of the temporary label. On Windows, do not press ENTER. The window closes if you do so.

7. To modify the color theme, do any of the following:
   - To modify the gradient of continuous color, move the sliders left or right.
To add more colors to the gradient, click the color bar to pick a color. A new slider is displayed under the color bar.

- To change the color of a slider, click on the slider to display the Color window and choose another color.
- To reverse the order of the colors on the gradient, click Reverse.
- To distribute the colors evenly on the gradient, click Space Evenly.
- To have the custom theme listed in the Sequential pane, select Sequential from the drop-list.
- To have the custom theme listed in the Diverging pane, select Diverging from the drop-list.
- To have the custom theme listed in the Chromatic pane, select Chromatic from the drop-list.
- To prevent a theme from appearing in lists of color themes, select Hidden.
- To remove a color from the color theme, click the color’s slider and drag the slider above or below the color bar.
- To discard your changes, click Cancel.

8. Click Save to save the custom color theme.
   The new custom color theme is appended to the contents of the selected pane.

9. Click OK to close the color theme window.

**Continuous and Categorical Color Themes**

The following figure shows examples of the two types of color themes in JMP, continuous and categorical. When a color theme is selected for continuous data, the colors are graduated (as shown on the left). When the same color theme is selected for categorical data, the color consists of distinct blocks of color (as shown on the right).
Custom Color Themes

Custom color themes can be applied in the same way as built-in color themes:

- You can select custom color themes as defaults from the Continuous Color Theme and Categorical Color Theme drop-down menus in the Graphs preferences. Only continuous color themes are available for continuous data. All color themes are available for categorical data.
- You can apply the custom color themes to components such as markers and data table rows. See “Assign Colors or Markers to Rows Based on Column Values” on page 158 for details.
- In certain reports, such as treemaps and surface plots, you can select specific custom color themes. See the Basic Analysis book for details.

Use Custom Color Themes on Multiple Computers

In Windows, the color themes that you create are defined in the JMP preferences file called JMP.PFS. If you use JMP on more than one computer (for example, at home and at work), you can copy the color theme definitions from one JMP preferences file to another. Custom colors are then available on both computers.

In the preferences file, the code for a custom color theme looks like this:

```
Add Color Theme(
    {"Pink to Blue", {{255, 168, 255}, {255, 0, 255}, {0, 128, 255}}}
),
```

In this example, the name of the color theme is “Pink to Blue.” The Red/Green/Blue (RGB) values for each color slider are located in brackets. The first slider defines the RGB values 255,
168, and 255. The second and third groups of brackets define colors for the second and third sliders.

In a text editor (such as Microsoft Notepad) add this color theme to the preferences file on your other computer. The preferences file is located in your Users folder within the JMP or JMP Pro folder.

C:\Users\<username>\AppData\Local\SAS\JMP\<version_number>

**Note:** To see the preceding folders, you must configure Windows Explorer to show hidden files and folders. For details, refer to the Windows help.

---

**To Transfer Color Themes to Another Windows Computer:**

1. On the computer that contains the customized JMP preferences, select **File > New > Script**.
   The Script window appears.
2. Type the following JSL function:
   ```js
   Show Preferences()
   ```
3. Click the **Run Script** button .
   Your customized preferences are written to the log.
4. Select **View > Log** (or display the open log).
   The custom color theme that you created appears, for example:
   ```js
   Add Color Theme(
     "Pink to Blue", {{255, 168, 255}, {255, 0, 255}, {0, 128, 255}}
   )
   ```
   This definition might be in the middle of other customized preferences that appear in the log.
5. Save the log as **Log.jsl** and open the file on the computer whose preferences you are updating.
6. On the computer whose preferences you are updating, close JMP.
7. Make a backup of **JMP.PFS**, and then open the original **JMP.PFS** in a text editor.
8. Copy and paste the custom color definition from Log.jsl to **JMP.PFS**. The definition goes after **Preferences()** as shown in the following example:
   ```js
   Preferences(
     Add Color Theme(
       "Pink to Blue", {{255, 168, 255}, {255, 0, 255}, {0, 128, 255}}
     )
   );
   ```
Note: Be sure to include the closing parenthesis and comma. The code does not need to be indented. You can put the code in any valid location. Pasting it after `Preferences()` helps ensure that you do not delete any necessary parentheses or commas.

9. Save the file.

   If you open JMP and the new color definition is not displayed in the preferences, delete the updated preferences file and add the definition to the original preferences file. Make sure that you copy and paste the definition in the correct location.

Delete Custom Color Themes

1. Select `File > Preferences > Graphs`.
2. To either delete a color theme, select the either the Continuous or Categorical Color Theme.
   
   The relevant Color Themes window appears.
3. Click the Custom Color Theme disclosure button to show the Custom Color Theme panel.
4. From the appropriate pane, select the custom color to delete.

Note: You can delete only custom color themes.

5. Click `Delete`.
6. Click `OK` to save your changes and close the Color Themes window.

Delete Row Characteristics

To clear all row states in the data table, select `Rows > Clear Row States`. To clear row states only in selected rows, select `Rows > Clear Selected Row States`.

All rows become included, visible, unlabeled, and show in plots as black dots. The Clear Row States command does not affect row states saved in row state columns.

Lock Columns in Place

You can lock a column in place so that when you scroll horizontally, the column remains visible. Highlight the columns and select `Cols > Scroll Lock/Unlock`. Note the following:

- Hidden columns cannot be scroll locked.
- The name of a locked column appears in italics in the Columns panel.
- Scroll locked columns are moved to the left in the data grid. Once you unlock them, they are not moved back to their original locations in the data table, but remain on the left.
• Columns remain scroll locked until you highlight the columns and select Scroll Lock/Unlock again.
Set Column Properties
The Column Info Window

Use the Column Info window to set specific properties on a column in a data table. Here are some examples of the actions that you can perform on a column:

- Change data and modeling types
- Change numeric formats
- Add formulas
- Specify restrictions on values or missing values
- Order categorical values or row data
- Save specification, control, or response limits
- Enter a known value for sigma

You can also standardize attributes and properties across multiple columns, assign a preselected analysis role to columns, and compress columns in a data table.

Figure 5.1 The Column Info Window
Contents

The Column Info Window ................................................................. 169
Assign Column Properties .............................................................. 178
  Formula ......................................................................................... 179
  Notes ............................................................................................ 179
  Range Check ................................................................................ 179
  List Check .................................................................................... 180
  Missing Value Codes ..................................................................... 180
  Value Labels ................................................................................ 180
  Value Scores ................................................................................ 181
  Value Ordering .............................................................................. 181
  Value Colors ................................................................................ 182
  Color Gradient ............................................................................. 183
  Axis ............................................................................................... 183
  Coding .......................................................................................... 184
  Mixture ......................................................................................... 184
  Row Order Levels ......................................................................... 185
  Spec, Control, and Response Limits .............................................. 185
  Design Role ................................................................................ 186
  Factor Changes ............................................................................ 186
  Sigma ............................................................................................ 186
  Units ............................................................................................... 186
  Distribution .................................................................................. 187
  Time Frequency ........................................................................... 187
  Map Role ....................................................................................... 187
  Supercategories ........................................................................... 188
  Multiple Response ....................................................................... 189
  Profit Matrix ................................................................................ 189
  Create Your Own Column Property ............................................ 191

Standardize Attributes and Properties across Columns ...................... 191
Assign a Preselected Analysis Role ..................................................... 194
Compress Selected Columns ............................................................. 195
The Column Info Window

Use the Column Info window to specify all of the attributes and properties of a column.

To access the Column Info window:

- Select Cols > New Column
- or
- Right-click on an existing column heading and select Column Info
- or
- Double-click above the column name.

The Column Info window contains the following information:

**Column Name**  Type or edit the name of the column.

**Lock**  Lock the column so that none of its values can be edited. After you lock a column, the lock icon (🔒) appears next to the column name in the data table’s Columns panel. If you add a formula to a column, the column automatically locks.

**Data Type**  Select or change the data type of a column, which determines the following:

- How the column’s values are formatted in the data grid
- How the column’s values are saved internally
- Whether the column’s values can be used in calculations

See “About Data Types and Modeling Types” on page 170.

Choose from the following data types:

- **Numeric** columns contain only numbers (with or without a decimal point).
Set Column Properties

The Column Info Window

- **Character** columns contain any characters, including numbers. In character columns, numbers are seen as characters and are treated as discrete values instead of continuous values. The maximum field width for character values is 32,766 bytes.

- **Row State** columns contain row state information, which indicates whether the rows are excluded, hidden, labeled, colored, or marked. See “Row State Columns” on page 175.

**Note:** Short-integer formats might also be available. See “The Short-Integer Format” on page 171.

**Modeling Type** (Numeric or Character data types only) Select or change the modeling type of a column, which tells JMP how to treat the column’s values during analyses. You can change the modeling type to look at a variable in different ways. See “About Data Types and Modeling Types” on page 170.

Choose from the following modeling types:

- **Continuous** columns contain only numeric data types. Continuous values are treated as continuous measurement values. JMP uses the numeric values directly in computations.

- **Ordinal** columns contain either numeric or character data types. JMP analyses treat ordinal values as discrete categorical values that have an order. If the values are numbers, the order is the numeric magnitude. If the values are character, the order is the sorting sequence.

- **Nominal** columns contain either numeric or character data types. All values are treated in JMP analyses as if they are discrete values with no implicit order.

**Format** (Numeric data types only) Select or change the display format of a numeric column. See “Numeric Formats” on page 172.

**Initialize Data** (Appears only during new column creation) Specify the type of initial data values that you want to appear in the column. See “Fill in Initial Data Values” on page 177.

**Column Properties** (Contains a list of different properties) Assign properties to columns. See “Assign Column Properties” on page 178.

**Tip:** Use the Next button to continue adding columns.

About Data Types and Modeling Types

A column in a JMP data table can contain different types of information. However, all information in a single column must have the same data and modeling types.

- When you import data, JMP guesses which data and modeling types to use. Therefore, you should verify that JMP has guessed correctly.
• When you manually insert data into JMP, you should assign a data type and a modeling type at that time.

Figure 5.3 illustrates the icons that identify the different modeling types.

Figure 5.3 Modeling Type Icons in the Columns Panel

Click on an icon to change the modeling type.

Tip: You can select Continuous only if your data type is numeric. If the Continuous option is dimmed on the menu and you want to make the column continuous, you must first change the column’s data type in the Column Info window.

The Short-Integer Format

When you use the correct short-integer format for your data, you do not see any difference in how the numbers appear, but the numbers occupy less disk space and use less memory. Short-integer formats must be activated in preferences to appear in the Column Info window.

To make short-integer formats available in the Column Info window:

1. Select File > Preferences and click Tables.
2. Select the Allow short numeric data format option.
3. Click OK to return to the data table.

To store numeric data in short-integer format:

1. Double-click above the column name whose values you want to be short-integer.
   The Column Info window appears.
2. From the Data Type menu, select 1-byte integer, 2-byte integer, or 4-byte integer.

JMP stores values as integers in the range that you selected. The following numbers are examples:

• For 1-byte integer, the range of numbers that you can enter is from -126 to 127.
Set Column Properties

The Column Info Window

• For 2-byte integer, the range of numbers that you can enter is from -32,766 to 32,767.
• For 4-byte integer, the range of numbers that you can enter is from -2,147,483,646 to 2,147,483,647.

Numeric Formats

For numeric columns, the Format menu appears in the Column Info window. Specify the format to tell JMP how to display numbers in the column.

Note the following information:

• For all format options, you can specify the number of total characters that you want the cells in the column to accommodate. See “Specify Width” on page 172.
• For descriptions of the format options, see “Numeric Format Options” on page 172.
• To add commas to values that equal a thousand or more, select the Use thousands separator option. You must account a space for each comma in the Width box, or else they might not appear. This option is available for the Best, Fixed Dec, Percent, and Currency formats.

Specify Width

When you specify a number in the Width field, be sure to include the total number of possible characters. Characters include: numbers, decimal points, commas, and currency symbols.

Numeric Format Options

Choose from the following numeric format options:

Best  Allows JMP to consider the precision of each cell value and select the best way to show it. By default, the physical width of the column is 12 characters.

Fixed Dec  Shows all values in the column rounded to the number of decimal places that you specify.

Note the following:
－ To see only whole numbers, set the number of decimal places to zero.
－ If the value does not have as many numbers after the decimal as the number that you have specified, zeros are added to the number to give it that many decimal places. For example, if the value is 1.23 and you type 5 in the Dec box, JMP shows the number with five decimal places: 1.23000.

Percent  Multiplies numeric values by 100 and shows the number followed by a percent sign.

PValue  Shows probability values. The default value of the width is 12. If a number is less than 0.0001, the number is displayed as <.0001. The format is mostly used in JSL scripts and rarely needed for a data table column.
Scientific  Shows a number in standard scientific notation. If you enter the number 123456, it appears as 1.23456e+5.

Currency  Formats values with two decimal positions, thousands separators, and the currency sign that is specified in your computer’s locale settings (for example, on an American system, the number 123456 shows in the data table as $123,456.00). The default width of the Currency format is 15. If you have a number that requires a wider field width, the format defaults to the Best format. Once assigned, the currency symbol appears in the column and in graphs that contain the column.

Date  Shows all values in the column as a date. See “Date Formats” on page 173.

Time  Shows all values in the column as a specific instance in time, such as 12/2/03 at 2:23 PM. See “Time Formats” on page 174.

Duration  Shows all values in the column as a duration of time, such as hours, minutes, and seconds.
-  :day:hr:m, :day:hr:m:s show a duration of time, such as 52:03:01:30, or fifty-two days, three hours, one minute, and thirty seconds.
-  hr:m, hr:m:s, mins shows a duration of time, such as 17:37, or seventeen hours and thirty-seven minutes.

Geographic  Shows latitude and longitude number formatting for geographic maps. Latitude and longitude options include the following:
-  DDD (degrees)
-  DMM (degrees and minutes)
-  DMS (degrees, minutes, and seconds)

In each format, the last field can have a fraction part. You can specify the direction with either a signed degree field or a direction suffix. To show a signed degree field, such as -59°00’00”, deselect Direction Indicator. To show the direction suffix, such as 59°00’00” S, select Direction Indicator.

To use spaces as field separators, deselect Field Punctuation. To use degrees, minutes, and seconds symbols, select Field Punctuation.

Date Formats

When you choose a Date format, you can also specify an Input Format. The Date format indicates how the date appears in the data table cells, and the Input Format indicates how you type in the date.

If you assign a date format to a numeric column that already contains data, then the numeric values are treated as the number of seconds since January 1, 1904. For example, if you have a numeric column with a cell value of 1,234,567,890 and you change the format to Date > m/d/y, the cell value appears as 02/13/1943.
The examples in Table 5.1 use the date of December 31, 2004.

Table 5.1 Date Formats

<table>
<thead>
<tr>
<th>Format</th>
<th>Appears As</th>
</tr>
</thead>
<tbody>
<tr>
<td>m/d/y</td>
<td>12/31/2004</td>
</tr>
<tr>
<td>mmddyyyy</td>
<td>12312004</td>
</tr>
<tr>
<td>m/y</td>
<td>12/2004</td>
</tr>
<tr>
<td>yyyyQq</td>
<td>2004Q4</td>
</tr>
<tr>
<td>d/m/y</td>
<td>31/12/2004</td>
</tr>
<tr>
<td>ddmm yyyy</td>
<td>31122004</td>
</tr>
<tr>
<td>ddMonthy</td>
<td>31Dec2004</td>
</tr>
<tr>
<td>Monddyyyy</td>
<td>Dec312004</td>
</tr>
<tr>
<td>y/m/d</td>
<td>2004/12/31</td>
</tr>
<tr>
<td>yyyyMMdd</td>
<td>20041231</td>
</tr>
<tr>
<td>yyyy-mm-dd</td>
<td>2004-12-31</td>
</tr>
<tr>
<td>Date Long</td>
<td>Friday, December 31, 2004</td>
</tr>
<tr>
<td>Date Abbrev</td>
<td>Dec 31, 2004</td>
</tr>
<tr>
<td>Locale Date</td>
<td>Varies based on local OS setting. Here is an example: in the United States, the local OS setting is mm/dd/yyyy (12/31/2004).</td>
</tr>
</tbody>
</table>

Note: To change the way a date appears in a graph without changing the way it appears in a data table, see “Change the Numeric Format of an Axis” on page 324 in the “JMP Platforms” chapter.

Time Formats

When you choose a **Time** format, you can also specify an **Input Format**. The **Time** format indicates how the time appears in the data table cells, and the **Input Format** indicates how you type in the time.

- You can add the number of hours, minutes, and seconds after midnight of the prepended date for the following date formats:
  - m/d/y
– d/m/y
– y/m/d
– ddMonyyyy
– Monddyyyy
– Locale Date

For example, December 31, 2004 has a numeric value of 3,187,296,600, which represents 12/31/2004 12:10 AM.

• :day:hr:m and :day:hr:m:s show the number of days, hours, minutes, and seconds since January 1, 1904. For example, the results for December 31, 2004 are :36890:00:10: and :36890:00:10:00.

• h:m:s and h:m show the hours, minutes, and seconds portion of the date in the date field. For example, the results for December 31, 2004 at 12:10 AM are 12:10:00 AM and 12:10 AM.

• yyyy-mm-ddThh:mm and yyyy-mm-ddThh:mm:ss show the year, month, day, and time (for example, 2004-12-31T12:10:00. T is a literal, representing itself).

**Note:** To change the way a time appears in a graph without changing the way it appears in a data table, see “Change the Numeric Format of an Axis” on page 324 in the “JMP Platforms” chapter.

### International Formats

If you are importing or entering data that contains formatting specific to country standards, you might need to make sure that your number formats are interpreted correctly. On Windows, access the Control Panel’s region and language option, and select the country for which the number should be formatted. On the Macintosh, from the Apple menu, select System Preferences > Language & Text > Formats, and select the correct country.

### Row State Columns

Similar to assigning row states to rows, you can create a column that contains only row state information. A row state column stores information about whether rows are excluded, hidden, labeled, colored, marked, or selected. To designate a column as a row state column, in the Column Info window next to **Data Type**, select **Row State**.
1. Select Cols > New Column.
2. Next to Data Type, select Row State.
3. Click OK.

Populate the cells with new row state information or copy existing row state information from rows.

To copy existing row state information:
1. To populate only certain rows in the row state column, highlight those rows. Or, to populate all rows in the column, highlight the row state column.
2. Click the star icon (★) beside the column name in the Columns panel.
3. Select one of the following:
   - **Copy from Row States** Replaces the row states in the column with the row states from the rows.
   - **Add from Row States** Adds the row states from the rows to the row state column.
   - **Copy to Row States** Replaces the row states in the rows with the row states from the column.
– **Add to Row States**  Adds the row states from the row state column to the row states in the rows.

**Permanently Select Cells**

You can save a selection in a row state column just like you save other row state characteristics (hide, exclude, color, and so on). This places a “permanent” highlight on a cell.

*To permanently select cells:*
1. Right-click a cell and select **Row States Cells > Select/Deselect**.
2. Repeat this for as many cells as you would like to select.
3. To remove the highlight, right-click on the cell and select **Row States Cells > Select/Deselect**.

**Fill in Initial Data Values**

When you add a new column to a data table, the Initialize Data menu appears in the Column Info window. Specify the type of initial data values that you want to appear in the new column. Select one of the following options:

- **Missing/Empty**  Places missing values in the column, represented by a black dot (•) for numeric data and a blank space for character data.
- **Constant**  Places one number or character in all of the column’s rows. Type the number or character into the box that appears. Enter any number of characters.
- **Today**  Places today’s timestamp in the column for each row. This option is relevant only for the **Date** or **Time** formats.
- **Sequence Data**  Inserts sequential data based on the parameters that you specify. See “**Numeric or Character Sequence Data**” on page 177.
- **Random**  Inserts random data into the column. Select the type of random number that you want to use, and then enter one of the following:
  - A range for random integers or random uniform numbers.
  - The mean and standard deviation for random normal numbers.
  - Values and proportions for random indicators.

**Numeric or Character Sequence Data**

*To insert sequential data for numeric data:*

1. Next to **Data Type**, make sure **Numeric** is selected.
2. Next to **Initialize Data**, select **Sequence Data**.
3. In the From and To boxes, assign a starting and ending point.
4. In the Step box, assign the sequence.
5. (Optional) In the Repeat each value N times box, type the number of times that you want each numeric value repeated.
6. Click OK.

For example, if you want the column to contain even numbers from 2 to 60, type 2 in the From box, 60 in the To box, and 2 in the Step box.

To insert sequential data for character data:
1. Next to Data Type, make sure Character is selected.
2. Next to Initialize Data, select Sequence Data.
3. In the box next to Add, type the character data and click Add.
4. (Optional) In the Repeat each value N times box, type the number of times that you want each character value repeated.
5. Click OK.

Assign Column Properties

Columns can contain special column properties, such as formulas, notes, and restrictions on values.

When you add a property to a column, the properties icon \(\star\) appears next to the column name in the Columns panel. Note the following exceptions:

- ![Range or List Check](image)
- ![Formula](image)
- Columns with the Notes property do not contain an icon.

To assign a property to a selected column:

1. Right-click on the column that you want to assign a property to.
2. Select Column Properties and select the property that you want to assign.

Note: You can also right-click on a column and select Column Info. Select the property that you want to assign from the Column Properties menu.

The following sections describe the properties that you can add to columns.
Formula

Insert a formula into a column to compute the values for that column. After a formula is added, the column is locked so that its data values cannot be manually edited (preventing invalidation of the formula).

- Click Edit Formula to create a formula. For details about creating a formula, see the “Formula Editor” chapter on page 235.
- If you do not want JMP to evaluate the formula, click Suppress Eval.
- If you do not want JMP to alert you about errors in your formula, click Ignore Errors.
- Once you have created a formula:
  - In the Column Info window, a visual of the formula appears at right. However, if your formula is long, only a portion of it might appear. Click and drag the borders of the formula box to resize it.
  - From the data table, edit the formula by clicking ( ) next to the column name in the Columns panel.

Tip: To bypass the Column Info window when creating a formula, right-click on the column and select Formula.

Notes

Adds notes to the selected column.

Range Check

Range checking validates the data in a column. Set up the column to accept only numbers that fall within a specified range.

Select which formula to use to set up the range. $x$ is the value entered into the column, $a$ is the beginning of the range, and $b$ is the end of the range.

- $a$ = the lowest value that the column accepts
- $b$ = the highest value that the column accepts
- For a single-sided range check, leave either $a$ or $b$ empty.
- From the data table, modify the range check by clicking ( ) next to the column name in the Columns panel.

To turn off range checking:

1. From the data table, right-click the column name in the Columns panel.
2. Select Validation > No Checking. 
List Check

List checking validates the data in a column. Set up the column to accept only individual numbers that you specify. List checking is useful when you want to specify how to order the data in your graphs or plots.

- Use the buttons to add new values, change, or reverse the order of values, and remove values.
- Once a list check is set on a column, the cursor changes to $\text{\textcopyright}$ when positioned over the cells. If you try to enter a value not included on the validation list, a warning message appears.
- To see a menu of acceptable values, right-click a cell and select List Check Values. You can select the cell value from the menu instead of typing it into the cell.
- From the data table, modify the list check by clicking $\text{\textcopyright}$ next to the column name in the Columns panel.

To turn off list checking:

1. From the data table, right-click the column name in the Columns panel.
2. Select Validation > No Checking.

Missing Value Codes

Use missing value codes to specify column values that should be treated as missing. For example, sometimes the value 99 is used as a placeholder to represent missing values, or perhaps several values are used to represent different types of missing values.

Value Labels

Use value labels to show a label in the data table instead of a value. A label appears for each instance of the value. You can show the original values by double-clicking a label within a cell.

- Type the value that you want to assign a label to in the Value box.
- Type the label that you want to appear in the Label box.
- To use ranges, click Allow Ranges then specify the lower and upper values.

Note: If Allow Ranges is selected, Value Labels can be non-integers. Graph Builder can use the Value Labels for the x- and y-axes.

Tip: To assign a label to missing values, enter a period (.) for the lower bound and leave the upper bound empty. To assign a label to all other values, enter three periods (...) for the lower bound and leave the upper bound empty.
• Add, change, or remove labels.

Note the following tips:

• To turn off value labels in the data table without deleting the value labels that you have set up, in the Column Properties window, deselect Use Value Labels. Or, to quickly show or hide value labels in a data table, right-click on a column and check or uncheck Use Value Labels.

• When your data table contains value labels, using the Search commands searches for actual values, but does not search for labels.

• When your data table contains value labels, the Row Editor displays the label, and when the cell is highlighted for editing, it shows the actual value.

• If you copy and paste a cell with a value label, the actual value is pasted.

• In a formula, when you reference a column using value labels, hover your mouse over the value label to see the actual data value.

**Value Scores**

Use value scores to indicate a value-score pair for categorical data columns. The value is a data value and the score is a number. This property associates a data value with a score (for example, the column's data value could be "not satisfied", "satisfied", "very satisfied"). The user could assign a score of 0 to "not satisfied", 50 to "satisfied", and 100 to "very satisfied". Those scores are then used for computation purposes like computing the mean.

To use Value Scores:

1. In the data table, right-click on the column and select Column Info.
2. From the Column Properties list, select Value Scores.
3. Type the value that you want to assign a label to in the Value box (for example, 50).
4. Type the label that you want to appear in the Label box (for example, “satisfied”).
5. Click Add, Change, or Remove.
6. Click OK.

**Value Ordering**

Value ordering reorders categorical values.

**Note:** If you use both the Value Ordering and Row Order Levels properties, the Value Ordering property overrides the Row Order Levels.
The following values automatically appear in the appropriate order in reports:

- January, February, March, April, May, June, July, August, September, October, November, December
- Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec
- Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, Saturday
- Very Low, Low, Medium Low, Medium, Medium High, High, Very High
- Strongly Disagree, Disagree, Neutral, Indifferent, Agree, Strongly Agree
- Failing, Unacceptable, Very Poor, Poor, Bad, Acceptable, Average, Good, Better, Very Good, Excellent, Best

**Value Colors**

Use value colors to assign the values of a nominal or ordinal column a certain color or range of color themes. The column’s values appear with the assigned color in all applicable graphs, such as mosaic plots and plots with color-coded legends. You can also color the values in the data table column.

- To change the color of a specific value, right-click a color circle and select a color.
- To use a color theme, select it from the **Color Theme** menu.
- To create a custom color theme, see “Create a Custom Color Theme” on page 182.
- To also color the cells in the data table, select **Color Cell by Value**.
- (Optional) Select from the options in the **Macros** menu. See “Macros Options” on page 183.

**Create a Custom Color Theme**

*To create a custom color theme:*

1. Select **Custom** from the **Color Theme** menu.
2. Create the color using the sliders.
3. Name the color and click **Save**.
4. Click **OK** two times.

You can access the new custom color in the **Color Theme** menu the next time you use the **Value Colors** property. The color is also saved in your preferences. See “Create Color Themes” on page 160 in the “Enter and Edit Data” chapter.
Macros Options

The Macros menu contains the following options:

Gradient between ends  Sets the colors of the top and bottom values. JMP applies a color gradient across the entire range of values. Use this command to make all of the colors in between for the other levels.

Gradient between selected points  Sets the colors of the top and bottom values so that JMP can apply a color gradient to a range of values that you have highlighted in the Value Colors list.

Reverse colors  Reverses the color of the values from top to bottom or bottom to top.

Revert to old colors  Sets the colors back to their original color values.

Color Gradient

Select a color gradient to color a continuous column in a plot. Color gradients are supported in the Graph Builder, Bubble Plot, Treemap, and Cell Plot platforms.

• To also color the cells in the data table, select Color Cell by Value.
• Select a color gradient from the menu.
• Enter the minimum, maximum, and center values:
  – Minimum values reflect the color at the left of the gradient.
  – Maximum values reflect the color at the right of the gradient.
  – Center values reflect the color in the middle of the gradient.

Note: To see color gradients in Graph Builder, you must assign the column to the Color zone. To see color gradients in Bubble Plot and Treemap, you must assign the column to the Coloring role.

Axis

Use the Axis property to change the default axis settings for a column. JMP automatically uses your settings when the column appears in an analysis.

Specify the following properties in the Axis panel:

Scale Type  Change the scale type to Linear, Log, Geodesic, or Geodesic US.

Min  Set the minimum value in the graph.

Max  Set the maximum value in the graph.

Minor Ticks  Specify the number of minor tick marks in the graph.
Inc Specify the number of increments in the graph.
Show Major Ticks Show major tick marks in the graph.
Show Minor Ticks Show minor tick marks in the graph.
Show Major Grid Show major gridlines in the graph.
Show Minor Grid Show minor gridlines in the graph.
Show Labels Show labels in the graph.
Orientation menu Change the orientation of the axis labels. Choose from the following options:
- Automatic adjusts the orientation based on the length of the label text.
- Horizontal and Vertical describe orientations for single axes.
- Perpendicular and Parallel describe orientations for paired axes (for example, in Scatterplot Matrices).
- Angled adjusts the orientation to be angled at a 45 degree angle.

To set default axis properties for a column from within a graph:
1. Create the graph.
2. Change the axis to your preferred specifications. See “Customize Axes and Axis Labels” on page 320 in the “JMP Platforms” chapter.
3. Right-click the axis and select Save to Column Property.

Coding

When you fit a column in a model, the low and high values of the column are transformed to \(-1\) and \(1\), which makes tests and parameter estimates more meaningful. This is called coding. Use coding to specify which values you want to use as the low and high values in a column. Coding can be used for any continuous variable. Coding is the default for continuous factors generated by the DOE commands in JMP.

Note: If a column has one or more limits missing, JMP substitutes the data’s minimum and maximum for the high and low values.

Mixture

You might have a column in a data table that is one of several factors that form 100% of a mixture. Use the Mixture property to set up the column so that JMP uses it to automatically generate a no-intercept model (using the Fit Model command) when you analyze the data.

- Enter the lower and upper limits and the sum of terms.
• (Optional) Select the L and U PseudoComponent Coding options.

Note: For more information, see the Custom Design chapter in Design of Experiments Guide.

Row Order Levels

The row data in an analysis report appears in order of the data’s values. Use the Row Order Levels property to set the row data to appear in the same order in which it appears in the data table column.

The row ordering applies only to the selected column. To apply it to other columns, repeat the above steps for each column, or use the Standardize Attributes command. See “Standardize Attributes and Properties across Columns” on page 191.

Tip: To show the analyzed row data in another order (besides according to their values or their occurrence in the data table columns) use the Value Ordering property. See “Value Ordering” on page 181. The Value Ordering property overrides the Row Order Levels property when both are evoked.

Spec, Control, and Response Limits

Use the Spec Limits, Control Limits, and Response Limits properties to save specification, control, and response limits in a column. When you perform a capability analysis, control chart analysis, or analyses displaying the prediction and contour profilers, you do not have to re-specify roles and limits each time. Saving these limits in a column also facilitates consistency from use to use. For example, you might run an analysis that uses these limits. When you come back later and change the data, you can run a new analysis on the new data using the same limits.

Specification Limits

Specification limits are used when you perform a capability analysis using the Distribution and Capability platforms.

• Enter a lower and upper specification limit and a target value for a numeric column.
• The Show as graph reference lines option draws specification limits as reference lines on a graph.

Control Limits

Control limits are used when you create a control chart.

• Select the control chart type.
• Enter the values for the average and lower and upper control limits. If any of these values are missing, JMP includes a calculated value in the control chart.

Response Limits
Response limits are used by the prediction and contour profilers and DOE.

• Specify one of the possible goals for a DOE response variable. Choose from the following: **Maximize**, **Match Target**, **Minimize**, or **None**. For example, if you are in the Prediction Profiler, and you want the desired value to be close to zero, select **Match Target**.

• If you have two responses, you can enter an **Importance** value, which specifies how to weigh the importance of one response against the other response.

• Specify values for the lower, middle, and upper limits and desirability values.

• To draw specification limits as reference lines on a graph, select the **Show as graph reference lines** option.

Design Role
Specify a design role to indicate how to use a factor column in a model to design an experiment.

Factor Changes
To create a split plot design using the JMP DOE commands, you must identify a factor as **hard**, meaning that the factor would be difficult to change. You can identify a factor as hard in the DOE design pane each time you design an experiment. To create a split plot design every time you use a certain factor, you can save time by setting up that factor to be hard in all experiments.

Sigma
Use the **Sigma** property to enter a known sigma value. This value is used by applications such as control charts or any application that requires a sigma value to complete computations. If no sigma value is supplied, sigma is calculated from the sample.

Units
Use the **Units** property to specify the measurement units that were used to collect the data for the column. The units appear in parenthesis after the column name. For example, you might want a column to indicate that age values are measured in months, or that a monetary value is in thousands of dollars.
Chapter 5
Using JMP

Set Column Properties
Assign Column Properties

Distribution

For a column that contains continuous numeric data, use the Distribution property to select a distribution type to fit to the column. When you run the Distribution report (Analyze > Distribution) for the column, JMP automatically estimates a fit using the specified distribution. A curve reflects when the data completely fits the specified distribution.

Set the Distribution property only when you already know how the data is distributed. For example, you might already know before you run Analyze > Distribution that the data has a Weibull distribution.

If you set the Distribution property and the Spec Limits property, then the Distribution report produces a Capability Analysis report, reflecting the distribution type that you selected for the column.

Time Frequency

When using the Time Series platform, you can assign the Time Frequency property to data. The Time Frequency property specifies the frequency with which the data is reported (such as annually, quarterly, monthly, and so on). Specifying a time frequency allows JMP to take things like leap years and leap days into account. If no frequency is specified, the data is treated as equally spaced numeric data.

Map Role

If you have created your own data table that contains boundary data (such as countries, states, provinces, or counties) and you want to see a corresponding map in Graph Builder, use the Map Role property.

Note the following:

• If the custom boundary files reside in the default custom maps directory, then you need to specify only the Map Role property in the -Name file.

• If the custom boundary files reside in an alternate location, then you must specify the Map Role property in the -Name file and in the data table that you are analyzing.

• The columns that contain the Map Role property must contain the same boundary names, but the column names can be different.

Note: For an example using the Map Role property, see Essential Graphing.

To add the Map Role property into the -Name data table:

1. Right-click on the column containing the boundaries and select Column Properties > Map Role.
2. Select **Shape Name Definition**.
3. Click **OK**.
4. Save the data table.

*To add the Map Role property into the data table that you are analyzing:*

**Note:** Perform these steps only if your custom boundary files do not reside in the default custom maps directory.

1. Right-click on the column containing the boundaries and select **Column Properties > Map Role**.
2. Select **Shape Name Use**.
3. Next to **Map name data table**, enter the relative, or absolute path to the -Name map data table.
   - If the map data table is in the same folder, enter only the filename. Quotes are not required when the path contains spaces.
4. Next to **Shape definition column**, enter the name of the column in the map data table whose values match those in the selected column.
5. Click **OK**.
6. Save the data table.

When you generate a graph in Graph Builder and assign the modified column to the **Shape** zone, your boundaries appear on the graph.

**Supercategories**

For a column with graded responses (for example, scale of 1 to 5), add the **Supercategories** property to the column. Each supercategory consists of one or more categories from the column.

The **Supercategories** red triangle menu includes the following options:

- **Options > Hide**: hides the category from the data table in the report
- **Add All**: adds all of the categories from the column to the supercategory
- **Add Mean** and **Add Std Dev**: the values are not derived from the column’s categories but are added to data tables generated by the Categorical platform. See the *Consumer Research* book for more information.
Figure 5.5 Example Supercategories Configuration

Multiple Response

Some column's data values may have more than one response in each data cell. For example, a cell in the Brush Delimited column in the Consumer Preferences.jmp sample data table contains the values “Wake, After Meal, Before Sleep.”. For a column that contains multiple responses, use the Multiple Response property to configure the Separator character used to separate the responses within a data cell.

Figure 5.6 Example Multiple Response Configuration

Note: You can use the Multiple Response property in the Categorical platform. See the Consumer Research book for details. You can also use this property in the Data Filter. See the Platforms chapter in the Using JMP book.

Profit Matrix

Use the Profit Matrix property to enhance a predictive model by converting it to a decision model and assigning weights to outcomes. To access the feature, select Column Properties > Profit Matrix. A matrix table appears using each value in the selected column.

- Enter positive numbers as projected profits for correct decisions.
- Enter negative numbers as projected costs for incorrect decisions.

Each row shows the consequences if you predicted this response. Each column shows the consequences if the actual response if this response. The Undecided row indicates any associated profits or costs for situations where no decision is made. For example, an airline may charge a penalty in addition to the reservation fee for purchasing a ticket within 48 hours of the scheduled departure. Alternatively, if an airline has a lot of openings on a scheduled flight the day before the departure, they may offer a bonus as an incentive to selling tickets.
After completing the profit matrix, save the prediction formulas for use in creating best decision columns. The best decision is the one with the greatest expected profit. The example below (Figure 5.7) uses the Airline column in the Travel Costs.jmp sample data table.

**Figure 5.7** Example of Profit Matrix Window

In a profit matrix, positive numbers represent projected profits from making sound and timely decisions. Negative numbers represent projected losses or costs resulting from making unprofitable or untimely decisions.

In a sample scenario, a travel agency uses four airlines to service its customers. The airlines range from Carrier 1, a low budget airline, up to Carrier 4, a luxury airline. The agency earns money by selling airline tickets to its customers. Depending on the carrier selected by the customer, the agency expects a certain amount of profit for each ticket sold. When the agency recommends a carrier they reserve a ticket for a small fee (this is the *prediction*). If the customer decides to take the recommended carrier the agency profits by a certain amount less the reservation fee. However, if the customer decides to take a different carrier, the agency loses the reservation fee already paid and must purchase the alternate ticket and pay another reservation fee. As a result, the agency's profit margin is less than predicted.

For example, the reservation fees for Carrier 1 through Carrier 4 are $15, $20, $30, and $50 respectively. The gross profits for a ticket sale for Carrier 1 through Carrier 4 are $50, $150, $260, and $300 respectively.

If the agency recommends Carrier 1 to a customer who then decides to purchase a ticket, the agency reserves a ticket for $15 and then receives $50 for a net profit of $35. If the agency
predicts a customer will choose Carrier 1 but they instead choose Carrier 2, the agency must pay $15 for the Carrier 1 reservation and $20 for the actual reservation on Carrier 2. This gives the agency a net profit of $115. Conversely, if the agency predicts Carrier 4 but the customer decides on Carrier 1, the agency has a loss of $15.

Create Your Own Column Property

You can create your own column property and assign it any name that you choose. This property is then available for JSL programming.

1. Right-click on the column and select **Column Properties > Other**.
2. Type a name for the new property.
3. Enter a value for the property.

Response Probability

The **Response Probability** property does not appear on the Column Properties menu. JMP automatically assigns this property when the following steps are performed:

1. Create a logistic regression using either the Fit Y by X platform or the Fit Model platform.
2. Select the **Save Probability Formula** option in the logistic report window.

JMP automatically assigns the **Response Probability** property to the new probability columns. The **Response Probability** property makes all of the levels of the categorical variable appear as a single row (instead of separate rows) in the Profiler report.

**Note:** For more details, see the *Profilers* book.

Standardize Attributes and Properties across Columns

A column might contain attributes (data types, modeling types, numeric formats, and so on) or properties (formulas, notes, list and range checks, and so on) that you want other columns to have. You can use the existing column to *standardize* the attributes and properties across columns. This includes both adding and deleting attributes and properties.

*To apply an existing column’s attributes and properties to multiple columns:*

1. Select the column or columns containing the desired attributes or properties.
2. Select **Cols > Standardize Attributes**. The window in Figure 5.8 appears.
Recode Values

Use the Recode option if you need to recode similar values within multiple columns in the same way. Once you click Recode, the values that appear are generated from the union of all of the selected columns. For example, suppose that you have two columns with user responses. One column contains the values Agree and Disagree. The other column contains the values Agree, Disagree, Unsure, and Strongly Disagree. You want to simplify all of the values in both columns to be A, D, U, and SD.

Note: If you want to recode values only in a single column, you can also use the Cols > Recode option. See “Recode Data” on page 133 in the “Enter and Edit Data” chapter.

Standardize Attributes

By default, the items within the Standardize Attributes panel are dimmed. To access an item, click the Attributes button and select the items to be duplicated across columns.

Note: The Input Format item is applicable only for the Date, Time, and Duration formats.

To change the values of any of the attributes, use the menus in the Standardize Attributes panel.
Standardize Properties

To standardize properties across columns:

1. Click Column Properties in the Standardize Properties area and set up the properties that you want the other columns to have.
2. Click in the data table.
3. Highlight the columns in the data table to which you want to apply the attributes and properties.
4. Go back into the Standardize Columns Attributes window and click Apply.
   The attributes and properties apply to all the selected columns in the data table. You can view your results.
5. Click OK.

Tip: You can select all of the columns that you want to standardize and then select Cols > Standardize Attributes. The first selected column (left-most) is used to set up the window’s values. Then you might skip steps 6 and 7, because you have already selected the columns.

Delete Properties

To delete the same properties across multiple columns:

1. Select the column containing the attributes or properties that you want to delete.
2. Select Cols > Standardize Attributes.
3. Click Column Properties in the Delete Properties area and select the properties that you want to delete.
4. Click OK.

Example of Standardizing a Formula

If you have applied a formula to a column, and you want to apply that same formula to additional columns in the data table, use the Substitute Column Reference option.

Note: This option is dependent upon the location of the column that is referenced in the original formula. For example, if your original formula is based on the previous column, then any other formulas applied to additional columns are based on their previous columns.

For example, the Blood Pressure.jmp sample data table contains blood pressure measurements taken on five subjects three times each day, over a period of three days. You want to find the log of each blood pressure (BP) column.
1. Open the Blood Pressure.jmp sample data table. Create nine new columns, one for each existing BP column.

2. Select Cols > Add Multiple Columns.

3. Add nine columns.

4. Click OK.

Apply your original formula as follows:

5. Right-click on Column 1 and select Formula.

6. Select BP 8M.

7. Select Transcendental > Log.

8. Click OK.

   Column 1 now contains the log of the BP 8M column. You want the rest of the empty columns to contain the log of the remainder of the BP columns.

9. In the data table, select all of the new columns that you created, including the one with the original formula (columns 1-9).

10. Select Cols > Standardize Attributes.

11. In the Standardize Properties panel, click on Column Properties and select Formula.

12. Select the check box next to Substitute Column Reference.

13. Click OK.

   Now all of the new columns are populated with the log of the BP columns, in the order in which they appear. Column 1 contains the log for BP 8M, Column 2 contains the log for BP 12M, and so on.

---

**Assign a Preselected Analysis Role**

You can assign an analysis role, such as x, y, weight, or frequency, to a selected column and save the role with the data table. When you do this and then run an analysis, JMP uses the preselected role to automatically fill in the role boxes in windows. Then you do not have to specify these roles each time you run an analysis. For example, you might want a column named height to take the x role in every analysis of that data table. To enforce the x role, you assign the preselected role of x to the column.

When you select Freq, the values in that column are what JMP uses as the frequency of the observation. If \( n \) is the value of the Freq variable for a given row, then that row is used in computations \( n \) times. If it is less than 1 or is missing, then JMP does not use it to calculate any analyses.
When you select **Weight**, the values in that column provide weights for each observation in the data table. The variable does not have to be an integer, but it is included only in analyses when its value is greater than zero.

*To assign a preselected role to a column:*

1. Highlight the column.
2. Select **Cols > Preselect Role**.
3. Select a role: **No Role**, **X**, **Y**, **Weight**, or **Freq**.

After you select the appropriate roles, icons in the Columns panel signify what roles have been assigned. Click the icon to access a list of roles and select a different one. See “**Icons Representing Column Characteristics and Properties**” on page 43 in the “Get Started” chapter.

---

**Compress Selected Columns**

JMP lets you compress columns in a data table to minimize the size of the file and reduce the amount of memory required to analyze data. This feature is helpful when numeric columns contain many small integers or when any column contains fewer than 255 unique values. For example, compressing columns in a data table with 389 columns and 85,000 rows might decrease the file size from 250MB to 33MB, depending on the type of data.

When you compress columns, JMP verifies whether the data can be stored in a more compact form based on the data type:

- In character columns with fewer than 255 unique values, the List Check property is added to the column (shown in Figure 5.9).
- In numeric columns, data is compressed to 1-byte, 2-byte, or 4-byte integers when possible (shown in Figure 5.10). For details about short integers, see “**The Short-Integer Format**” on page 171.

A numeric column with non-integer values can also be compressed if there are fewer than 255 unique values. In this case, the List Check property is added to the column.

*Caution:* In a column with the List Check property, you can enter only a value that is in the list. Otherwise, JMP warns that the cell contains invalid data when you try to enter the new value. For details about list checking, see “**List Check**” on page 180.
Figure 5.9  List Check Property Added to a Compressed Character Column

Figure 5.10  Column Info Window Showing Numeric Column Before and After Compression

To compress columns, select one or more columns and select **Cols > Compress Selected Columns**. (Select all columns if you do not know which columns can be compressed.)

The column or columns are compressed if possible. The log shows which columns were compressed and how they were compressed. (Select **View > Log** to show the log.)

**Note:** To compress a numeric column manually, set your Tables preferences to allow short numeric data and then change the column's data type to **1-byte integer**, **2-byte integer**, or **4-byte integer**. For details about this preference, see “Tables” on page 410 in the “JMP Preferences” chapter.
This chapter covers the following tasks that you can perform on JMP data:

- create a new data table from a subset of rows and columns
- sort by any number of columns
- stack multiple columns into a single column
- split a column into two or more columns
- transpose rows and columns
- concatenate multiple tables end to end
- join two tables side by side
- update columns in a table with values from another table

Figure 6.1 Creating a Subset Data Table from a Report
Contents

Create a Subset Data Table ................................................................. 199
Stratified Subsets ............................................................................. 201
Create a Subset Data Table from a Report ......................................... 201
Sort Data Tables ................................................................................ 202
Stack Columns .................................................................................. 205
  Example of Stacking into One Column ............................................ 207
  Example of Stacking into More than One Column ............................. 208
Split Columns .................................................................................... 210
  Examples of Splitting Columns ......................................................... 212
Transpose Rows and Columns .............................................................. 214
  Examples of Transposing Rows and Columns ..................................... 216
Concatenate Data Tables ................................................................. 217
  Example of Concatenating Data Tables ............................................. 219
  Example of Concatenating Data Tables and Table Variables .............. 219
Join Data Tables ............................................................................... 220
  Examples of Joining Data Tables ....................................................... 224
Update Data Tables ......................................................................... 231
  Example of Updating a Data Table ................................................... 233
Create a Subset Data Table

You can produce a new data table that is a subset of all rows and columns, only highlighted rows and columns, or randomly selected rows from the active data table.

To create a subset
1. Select **Tables > Subset**.

**Figure 6.2** The Subset Window

2. Specify the content that you want to subset. Select any combination of the following:
   - Subset by (the levels within selected columns)
   - Rows (all, selected, or random)
   - Columns (all or selected)

   For descriptions of these options, see Table 6.1.

3. Customize your subset table further using the additional options. See Table 6.1.

4. Click **OK** to create the subset table.
Table 6.1 Description of the Subset Window

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Subset by</strong></td>
<td>To subset by the levels of a column, select <strong>Subset by</strong> and select the columns that you want to categorize for the subset.</td>
</tr>
<tr>
<td></td>
<td>Consider the fact that many new data tables might be created. A new data table appears for each level of the column that you specified in the <strong>Subset</strong> window.</td>
</tr>
<tr>
<td><strong>All Rows</strong></td>
<td>Creates a subset table that contains all rows from the active table.</td>
</tr>
<tr>
<td><strong>Selected Rows</strong></td>
<td>Creates a subset table that contains only the selected rows from the active table.</td>
</tr>
<tr>
<td><strong>Random - sampling rate</strong></td>
<td>Creates a subset table whose data is a random proportion of the active data table. Enter the proportion of the sample that you want in the text box. For example, if you want a random 50% of the data to be included in the new table, enter 0.5 in the text box.</td>
</tr>
<tr>
<td><strong>Random - sample size</strong></td>
<td>Creates a subset table whose data is a random sample of the active data table. Enter the size of the sample that you want in the text box. For example, if you want 16 random rows to be included in the new table, enter 16 into the text box.</td>
</tr>
<tr>
<td></td>
<td>If you select a random sample that is the entire source table, the result is a random shuffle of the rows of the data table. If you specify columns to stratify, the result is a random shuffle of each of the rows for each group. See “Stratified Subsets” on page 201.</td>
</tr>
<tr>
<td><strong>All columns</strong></td>
<td>Creates a subset table that contains all columns from the active table.</td>
</tr>
<tr>
<td><strong>Selected columns</strong></td>
<td>Creates a subset table that contains only the selected columns from the active table.</td>
</tr>
<tr>
<td><strong>Keep by columns</strong></td>
<td>Retains the column that you subsetted by in the output data tables.</td>
</tr>
<tr>
<td><strong>Output table name</strong></td>
<td>To give a name to the subset table, type a name in the box beside <strong>Output table name</strong>.</td>
</tr>
<tr>
<td><strong>Link to original data table</strong></td>
<td>To keep the subset table linked to the original table, click the box beside <strong>Link to original data table</strong>. When you change values in one table, the other table is updated.</td>
</tr>
</tbody>
</table>
Chapter 6
Using JMP

Reshape Data
Create a Subset Data Table

Table 6.1 Description of the Subset Window  (Continued)

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy formula</td>
<td>To include formulas from the original table in the output columns, click the box beside Copy formula. Include all columns needed for the calculation of the formula.</td>
</tr>
<tr>
<td>Suppress formula evaluation</td>
<td>To prevent JMP from evaluating columns’ formulas when the new table is created, click the box beside Suppress formula evaluation.</td>
</tr>
<tr>
<td>Keep dialog open</td>
<td>To keep this window open after clicking OK, check the box beside Keep dialog open.</td>
</tr>
</tbody>
</table>

Stratified Subsets

If you specify a sample size and add stratification columns, the sample size represents the size per stratum, rather than the size of the whole subset.

Figure 6.3 Stratified Subsets

For stratified random samples with a specified sample size, two columns can be saved: Selection Probability and Sampling Weight. Check the corresponding check box to save these columns.

Create a Subset Data Table from a Report

These two methods produce linked subsets of a data table.

Use a Histogram

Once you have produced output that contains a histogram (by selecting Analyze > Distribution), you can use the histogram to create a new data table. The new data table contains the data in the histogram’s highlighted bars.

To create a subset, double-click a highlighted bar. Or, right-click anywhere in the histogram and select Subset from the menu. The subset table appears, as shown in Figure 6.4.
Sort Data Tables

You can sort a JMP data table by columns in either ascending or descending order. By default, columns sort in ascending order. You can either create a new table that contains the sorted values, or you can replace the original table with the sorted table.

If columns contain value labels, sorting is based on the actual data values, not the value labels. (See “Value Labels” on page 180 in the “Set Column Properties” chapter.) However, the value labels are displayed in the sorted data table.

If your sorted column uses either the Value Ordering property or the List Check property, the column is sorted according to that order.

Example of Sorting Data Tables
1. Open the Popcorn.jmp sample data table.
2. Select Tables > Sort.
3. Highlight the names of the columns that you want to sort by. For this example, select popcorn and yield.

4. Click By to add the columns to the sort list.

   The columns that you add to the list establish the order of precedence for sorting. The first column in the list is the major sort field. Each variable thereafter is sorted within the previous variable in the sort list. You can drag and drop within the By list to change the sort order.

5. Customize your sort further using the additional options. For this example, highlight yield and click the descending button. 

   For a complete list of options, see Table 6.2.

6. Type a name for the new sorted table in the box beside Output table name. For this example, type sorted popcorn.

Figure 6.6 Completed Sort Window

7. Click OK.
Chapter 6
Using JMP

Reshape Data
Sort Data Tables

Figure 6.7 Sorted in Ascending and Descending Order

<table>
<thead>
<tr>
<th>popcorn</th>
<th>allamt</th>
<th>batch</th>
<th>yield</th>
<th>trial</th>
</tr>
</thead>
<tbody>
<tr>
<td>gourmet</td>
<td>lots</td>
<td>small</td>
<td>18.0</td>
<td>1</td>
</tr>
<tr>
<td>gourmet</td>
<td>lots</td>
<td>small</td>
<td>18.0</td>
<td>3</td>
</tr>
<tr>
<td>gourmet</td>
<td>little</td>
<td>small</td>
<td>15.9</td>
<td>2</td>
</tr>
<tr>
<td>gourmet</td>
<td>little</td>
<td>small</td>
<td>12.1</td>
<td>1</td>
</tr>
<tr>
<td>gourmet</td>
<td>lots</td>
<td>large</td>
<td>9.0</td>
<td>2</td>
</tr>
<tr>
<td>gourmet</td>
<td>lots</td>
<td>large</td>
<td>8.2</td>
<td>1</td>
</tr>
<tr>
<td>gourmet</td>
<td>little</td>
<td>large</td>
<td>8.6</td>
<td>1</td>
</tr>
<tr>
<td>gourmet</td>
<td>little</td>
<td>large</td>
<td>8.2</td>
<td>2</td>
</tr>
<tr>
<td>plain</td>
<td>lots</td>
<td>small</td>
<td>10.8</td>
<td>1</td>
</tr>
<tr>
<td>plain</td>
<td>lots</td>
<td>large</td>
<td>10.4</td>
<td>1</td>
</tr>
<tr>
<td>plain</td>
<td>little</td>
<td>small</td>
<td>10.1</td>
<td>2</td>
</tr>
<tr>
<td>plain</td>
<td>little</td>
<td>small</td>
<td>9.9</td>
<td>1</td>
</tr>
<tr>
<td>plain</td>
<td>little</td>
<td>large</td>
<td>8.0</td>
<td>2</td>
</tr>
<tr>
<td>plain</td>
<td>lots</td>
<td>large</td>
<td>8.0</td>
<td>2</td>
</tr>
<tr>
<td>plain</td>
<td>little</td>
<td>large</td>
<td>8.2</td>
<td>1</td>
</tr>
<tr>
<td>plain</td>
<td>lots</td>
<td>small</td>
<td>7.4</td>
<td>2</td>
</tr>
</tbody>
</table>

Table 6.2 Description of the Sort Window

<table>
<thead>
<tr>
<th>Select Columns Filter Menu</th>
<th>Contains options to search and filter through columns. See “Columns Filter Menu” on page 280 in the “JMP Platforms” chapter.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Replace Table</td>
<td>To replace the original data table with the sorted table instead of creating a new table with the sorted values, click the box beside Replace Table. This option is not available if there are any open report windows generated from the original table.</td>
</tr>
<tr>
<td>Output table name</td>
<td>(Optional) To give a name to the sorted table, type a name in the box beside Output name.</td>
</tr>
<tr>
<td>Keep dialog open</td>
<td>To keep this window open after clicking OK, check the box beside Keep dialog open.</td>
</tr>
<tr>
<td>By</td>
<td>Adds the columns that you want to sort by. The columns that you add to the list establish the order of precedence for sorting. The first column in the list is the major sort field. Each variable thereafter is sorted within the previous variable in the sort list.</td>
</tr>
<tr>
<td>Remove</td>
<td>Removes any highlighted columns.</td>
</tr>
</tbody>
</table>
You can rearrange your data table by stacking two or more columns into a single new column, preserving the values from the other columns. Or, you can stack a set of columns into multiple groups. The various ways that you can stack columns are explained in Table 6.3.

To stack columns:
1. Select Tables > Stack.
2. Highlight the names of the columns that you want to stack and click Stack Columns.
3. Customize your stacking further using the additional options. See Table 6.3.
4. Click OK.

Table 6.2 Description of the Sort Window  (Continued)

<table>
<thead>
<tr>
<th>ascending and descending buttons</th>
<th>To change the list order (ascending or descending) of the values for the grouping variables, in the By variable list, select a variable and click the appropriate ascending or descending button. The icon beside the variable changes to indicate the sorting order.</th>
</tr>
</thead>
</table>

Stack Columns

You can rearrange your data table by stacking two or more columns into a single new column, preserving the values from the other columns. Or, you can stack a set of columns into multiple groups. The various ways that you can stack columns are explained in Table 6.3.

To stack columns:
1. Select Tables > Stack.
2. Highlight the names of the columns that you want to stack and click Stack Columns.
3. Customize your stacking further using the additional options. See Table 6.3.
4. Click OK.

Table 6.3 Description of the Stack Window

| Select Columns Filter Menu | Contains options to search and filter through columns. See “Columns Filter Menu” on page 280 in the “JMP Platforms” chapter. |
### Table 6.3 Description of the Stack Window (Continued)

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Multiple series stack</td>
<td>To stack selected columns into two or more columns, check the box beside <strong>Multiple series stack</strong>. Specify the number of columns into which you want the selected columns to be stacked by entering the number into the <strong>Number of Series</strong> box. This box appears when you check the box beside <strong>Multiple series stack</strong>. Select the <strong>Contiguous</strong> option if the series consists of adjacent columns. See “Example of Stacking into More than One Column” on page 208. <strong>Note:</strong> The order in which you add columns to the box on the right determines the group to which they belong.</td>
</tr>
<tr>
<td>Stack by Row</td>
<td>Leaving <strong>Stack by Row</strong> unchecked stacks one column underneath another. Checking it stacks columns by rows.</td>
</tr>
<tr>
<td>Eliminate missing rows</td>
<td>To eliminate missing data from the new table, check the box beside <strong>Eliminate missing rows</strong>. If <strong>Stack by Rows</strong> is checked also, only rows with all data missing are eliminated.</td>
</tr>
<tr>
<td>Non-stacked columns</td>
<td>Includes or drops non-stacked columns from the new data table. Select one of these options: <strong>Keep All</strong> select this option if you want the new table to contain all of the non-stacked columns from the original table. <strong>Drop All</strong> select this option if you want to include only the stacked columns in the new table, and you do not want to include any non-stacked columns. <strong>Select</strong> Choose the non-stacked columns that you want to include or drop in the new table.</td>
</tr>
<tr>
<td>Keep dialog open</td>
<td>To keep this window open after clicking <strong>OK</strong>, check the box beside <strong>Keep dialog open</strong>.</td>
</tr>
<tr>
<td>Stack Columns</td>
<td>Adds the columns that you want to stack.</td>
</tr>
<tr>
<td>Remove</td>
<td>Removes any highlighted columns.</td>
</tr>
<tr>
<td>Output table name</td>
<td>(Optional) To name the new table, type a name in the box beside <strong>Output table name</strong>.</td>
</tr>
</tbody>
</table>
Chapter 6
Using JMP

Reshape Data

Chapter 6
Using JMP

Reshape Data

Chapter 6
Using JMP

Reshape Data

TABLE 6.3 Description of the Stack Window (Continued)

<table>
<thead>
<tr>
<th>Stacked Data Column</th>
<th>To assign a name to the column that will contain the data for the stacked columns, enter a name in the Stacked Data Column box. Leave the box empty if you do not want this column to appear in the new table.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source Label Column</td>
<td>To assign a name to the column that will contain the original table’s column names, enter the name in the Source Label Column box. The default name is Label. Leave the box empty if you do not want this column to appear in the new table.</td>
</tr>
<tr>
<td>Copy formula</td>
<td>To include formulas from the original table in the output columns, click the box beside Copy formula.</td>
</tr>
<tr>
<td>Suppress formula evaluation</td>
<td>To prevent JMP from evaluating columns’ formulas when the new table is created, check the box beside Suppress formula evaluation.</td>
</tr>
</tbody>
</table>

Example of Stacking into One Column

A researcher has two columns in their data table representing yield, and they want to stack the two columns into a single column. (This new single column would be called Data by default.)

1. Open the Popcorn Trials.jmp sample data table.
2. Select Tables > Stack.
3. Select yield1 and yield2 and click Stack Columns.
4. Click OK.

Figure 6.9 Stacked Data Table

<table>
<thead>
<tr>
<th></th>
<th>popcorn</th>
<th>oil amt</th>
<th>batch</th>
<th>Label</th>
<th>Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>plain</td>
<td>little</td>
<td>large</td>
<td>yield1</td>
<td>8.2</td>
</tr>
<tr>
<td>2</td>
<td>plain</td>
<td>little</td>
<td>large</td>
<td>yield2</td>
<td>8.8</td>
</tr>
<tr>
<td>3</td>
<td>gourmet</td>
<td>little</td>
<td>large</td>
<td>yield1</td>
<td>9.5</td>
</tr>
<tr>
<td>4</td>
<td>gourmet</td>
<td>little</td>
<td>large</td>
<td>yield2</td>
<td>9.2</td>
</tr>
<tr>
<td>5</td>
<td>plain</td>
<td>lots</td>
<td>large</td>
<td>yield1</td>
<td>18.4</td>
</tr>
<tr>
<td>6</td>
<td>plain</td>
<td>lots</td>
<td>large</td>
<td>yield2</td>
<td>6.0</td>
</tr>
<tr>
<td>7</td>
<td>gourmet</td>
<td>lots</td>
<td>large</td>
<td>yield1</td>
<td>9.2</td>
</tr>
<tr>
<td>8</td>
<td>gourmet</td>
<td>lots</td>
<td>large</td>
<td>yield2</td>
<td>9.0</td>
</tr>
<tr>
<td>9</td>
<td>plain</td>
<td>small</td>
<td>small</td>
<td>yield1</td>
<td>9.0</td>
</tr>
<tr>
<td>10</td>
<td>plain</td>
<td>small</td>
<td>small</td>
<td>yield2</td>
<td>16.1</td>
</tr>
<tr>
<td>11</td>
<td>gourmet</td>
<td>little</td>
<td>small</td>
<td>yield1</td>
<td>15.1</td>
</tr>
<tr>
<td>12</td>
<td>gourmet</td>
<td>little</td>
<td>small</td>
<td>yield2</td>
<td>15.9</td>
</tr>
<tr>
<td>13</td>
<td>plain</td>
<td>lots</td>
<td>small</td>
<td>yield1</td>
<td>16.8</td>
</tr>
<tr>
<td>14</td>
<td>plain</td>
<td>lots</td>
<td>small</td>
<td>yield2</td>
<td>7.4</td>
</tr>
<tr>
<td>15</td>
<td>gourmet</td>
<td>lots</td>
<td>small</td>
<td>yield1</td>
<td>16.0</td>
</tr>
<tr>
<td>16</td>
<td>gourmet</td>
<td>lots</td>
<td>small</td>
<td>yield2</td>
<td>16.0</td>
</tr>
</tbody>
</table>
The Label column represents the Source Label Column that identifies the source of the data. Its values are the column names in the original table from which the stacked values originated.

Example of Stacking into More than One Column

Suppose that a researcher has data on blood pressure readings. The readings were taken over three days: Monday, Wednesday, and Friday. Three readings were taken each day, at 8am, 12pm, and 6pm.

1. Open the Blood Pressure.jmp sample data table.
   Each BP (blood pressure) column is delineated according to the date and time. The BP 8M column corresponds to readings that were taken at 8am on Monday. The BP 12W column corresponds to readings that were taken on 12pm on Wednesday, and so on. The researcher wants to stack all of the blood pressure columns into three columns that correspond to each day: Monday, Wednesday, and Friday.

2. Select Tables > Stack.

3. Select all of the BP readings and click Stack Columns.
   The order of the columns reflects the way that the columns in the series should be grouped.

4. Select Multiple series stack.

5. Next to Number of Series, type 3.

6. Because you want to stack the columns vertically, select Contiguous.

7. Rename the Stacked Data Column from Data to BP (for blood pressure).

8. Rename the Source Label Column from Label to Day.
9. Click OK.

**Figure 6.11 Stacked Data Table**

<table>
<thead>
<tr>
<th></th>
<th>Subject</th>
<th>Dose</th>
<th>Day 1</th>
<th>BP 1</th>
<th>Day 2</th>
<th>BP 2</th>
<th>Day 3</th>
<th>BP 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>A</td>
<td>BP B</td>
<td>103</td>
<td>BP 89</td>
<td>174</td>
<td>BP 80</td>
<td>171</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>A</td>
<td>BP 12</td>
<td>174</td>
<td>BP 12</td>
<td>176</td>
<td>BP 12</td>
<td>176</td>
</tr>
<tr>
<td>3</td>
<td>1</td>
<td>A</td>
<td>BP 15</td>
<td>181</td>
<td>BP 89</td>
<td>181</td>
<td>BP 89</td>
<td>171</td>
</tr>
<tr>
<td>4</td>
<td>2</td>
<td>A</td>
<td>BP B</td>
<td>173</td>
<td>BP 89</td>
<td>170</td>
<td>BP 89</td>
<td>175</td>
</tr>
<tr>
<td>5</td>
<td>2</td>
<td>A</td>
<td>BP 12</td>
<td>181</td>
<td>BP 12</td>
<td>176</td>
<td>BP 12</td>
<td>185</td>
</tr>
<tr>
<td>6</td>
<td>2</td>
<td>A</td>
<td>BP B</td>
<td>181</td>
<td>BP 89</td>
<td>186</td>
<td>BP 89</td>
<td>183</td>
</tr>
<tr>
<td>7</td>
<td>3</td>
<td>A</td>
<td>BP B</td>
<td>177</td>
<td>BP 89</td>
<td>182</td>
<td>BP 89</td>
<td>180</td>
</tr>
<tr>
<td>8</td>
<td>3</td>
<td>A</td>
<td>BP 12</td>
<td>180</td>
<td>BP 12</td>
<td>175</td>
<td>BP 12</td>
<td>183</td>
</tr>
<tr>
<td>9</td>
<td>3</td>
<td>A</td>
<td>BP B</td>
<td>177</td>
<td>BP 89</td>
<td>182</td>
<td>BP 89</td>
<td>180</td>
</tr>
<tr>
<td>10</td>
<td>4</td>
<td>A</td>
<td>BP B</td>
<td>181</td>
<td>BP 89</td>
<td>176</td>
<td>BP 89</td>
<td>183</td>
</tr>
<tr>
<td>11</td>
<td>4</td>
<td>A</td>
<td>BP 12</td>
<td>177</td>
<td>BP 12</td>
<td>173</td>
<td>BP 12</td>
<td>187</td>
</tr>
<tr>
<td>12</td>
<td>4</td>
<td>A</td>
<td>BP B</td>
<td>182</td>
<td>BP 89</td>
<td>184</td>
<td>BP 89</td>
<td>183</td>
</tr>
<tr>
<td>13</td>
<td>5</td>
<td>A</td>
<td>BP B</td>
<td>184</td>
<td>BP 89</td>
<td>172</td>
<td>BP 89</td>
<td>170</td>
</tr>
<tr>
<td>14</td>
<td>5</td>
<td>A</td>
<td>BP 12</td>
<td>180</td>
<td>BP 12</td>
<td>175</td>
<td>BP 12</td>
<td>190</td>
</tr>
<tr>
<td>15</td>
<td>5</td>
<td>A</td>
<td>BP B</td>
<td>176</td>
<td>BP 89</td>
<td>176</td>
<td>BP 89</td>
<td>183</td>
</tr>
<tr>
<td>16</td>
<td>1</td>
<td>B</td>
<td>BP B</td>
<td>171</td>
<td>BP 89</td>
<td>183</td>
<td>BP 89</td>
<td>185</td>
</tr>
<tr>
<td>17</td>
<td>1</td>
<td>B</td>
<td>BP 12</td>
<td>191</td>
<td>BP 12</td>
<td>176</td>
<td>BP 12</td>
<td>182</td>
</tr>
<tr>
<td>18</td>
<td>1</td>
<td>B</td>
<td>BP B</td>
<td>180</td>
<td>BP 89</td>
<td>174</td>
<td>BP 89</td>
<td>184</td>
</tr>
<tr>
<td>19</td>
<td>2</td>
<td>B</td>
<td>BP B</td>
<td>175</td>
<td>BP 89</td>
<td>183</td>
<td>BP 89</td>
<td>184</td>
</tr>
<tr>
<td>20</td>
<td>2</td>
<td>B</td>
<td>BP 12</td>
<td>180</td>
<td>BP 12</td>
<td>180</td>
<td>BP 12</td>
<td>185</td>
</tr>
<tr>
<td>21</td>
<td>2</td>
<td>B</td>
<td>BP B</td>
<td>180</td>
<td>BP 89</td>
<td>173</td>
<td>BP 89</td>
<td>180</td>
</tr>
</tbody>
</table>

In the stacked data table, note the following:
- The first Day column represents Monday.
- The Day 2 column represents Wednesday.
Split Columns

You can create a new data table from the active table by splitting one column into several new columns. This column is split according to the values found in another column, referred to as the Split By column. You can also split columns according to the values of one or more grouping variables.

To split columns:

1. Select Tables > Split.

Figure 6.12  Split Window

2. Highlight the names of the column or columns that you want to split and click Split Columns.

3. Highlight a column whose values you want to use as the basis for splitting the column.

4. Click Split By.

5. Customize your splitting further using the additional options. See Table 6.4.

6. Click Split.

Table 6.4  Description of the Split Window

| Select Columns Filter Menu | Contains options to search and filter through columns. See “Columns Filter Menu” on page 280 in the “JMP Platforms” chapter. |

- The Day 3 column represents Friday.
### Table 6.4 Description of the Split Window  (Continued)

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Keep All</strong></td>
<td>To include all columns in the new table, click the <strong>Keep All</strong> option in the <strong>Remaining Columns</strong> area.</td>
</tr>
<tr>
<td><strong>Drop All</strong></td>
<td>To include only columns used in the split in the new table, click the <strong>Drop All</strong> option in the <strong>Remaining Columns</strong> area.</td>
</tr>
<tr>
<td><strong>Select</strong></td>
<td>To select which columns to keep in the new table, click the <strong>Select</strong> option in the <strong>Remaining Columns</strong> area. Then select which columns to keep in the new table.</td>
</tr>
<tr>
<td><strong>Keep dialog open</strong></td>
<td>To keep this window open after clicking <strong>OK</strong>, check the box beside <strong>Keep dialog open</strong>.</td>
</tr>
<tr>
<td><strong>Split By</strong></td>
<td>Adds the column whose values you want to use as the new column names, and as the basis for splitting the column.</td>
</tr>
<tr>
<td><strong>Split Columns</strong></td>
<td>Adds the column or columns that you want to split.</td>
</tr>
<tr>
<td><strong>Group</strong></td>
<td>Specify a <strong>Group</strong> variable when you want your data to be split within each group of the selected variable. Each group results in a row in the output table. <strong>Note:</strong> You must also specify the required variables, <strong>Split By</strong>, and <strong>Split Columns</strong>. If your grouping variable contains unequal groups, or if your grouping variable is not grouped in order (is random), then you must specify a <strong>Group</strong> variable. The <strong>Group</strong> variable ensures that your data is restructured properly.</td>
</tr>
<tr>
<td><strong>Sort by Value Order</strong></td>
<td>Sorts the order of the output columns by a Value Ordering property. Before using this option, you must have a Value Ordering property assigned to the column that you want to split by.</td>
</tr>
<tr>
<td><strong>Output table name</strong></td>
<td>(Optional) To assign a name to the new table, enter the name in the box beside <strong>Output table name</strong>.</td>
</tr>
<tr>
<td><strong>Copy formula</strong></td>
<td>(Only appears if there is a formula in the data table) To include formulas from the original table in the output columns, click the box beside <strong>Copy formula</strong>.</td>
</tr>
<tr>
<td><strong>Suppress formula evaluation</strong></td>
<td>(Only appears if there is a formula in the data table) To prevent JMP from evaluating columns’ formulas when the new table is created, click the box beside <strong>Suppress formula evaluation</strong>.</td>
</tr>
</tbody>
</table>
Examples of Splitting Columns

This section contains two examples using the Split command:

• In the first example, one column is split by a second column. See “Split a Column: Basic Example” on page 212.
• The second example uses a Group variable. See “Split a Column: Grouping Rows Example” on page 213.

Split a Column: Basic Example

In the Popcorn.jmp data table, the data in the trial column shows that there are two trials, 1 and 2. In this example, split the yield column into two new columns: one for trial 1 and one for trial 2. Proceed as follows:

1. Open the Popcorn.jmp sample data table.
2. Select Tables > Split.
3. Select the yield column and click Split Columns.
4. Select the trial column and click Split By.
5. Under Remaining columns, select Keep All.
   The default is Drop All, which omits any columns that are not in the Split By, Split Columns, or Group fields. Selecting Keep All includes these columns in the new table.
6. (Optional) Type Yield column split by Trial column in the Output table name field.
7. Click OK.
   A new data table is created. See Figure 6.13. Notice the following:
   – The yield and trial columns are gone.
   – The data table has two new columns, named after the unique values (1 and 2) from the original trial column.
   – The values from the original yield column are now split into the new columns named 1 and 2.
   – The columns other than trial and yield are exactly the same as they were in the original table.
8. (Optional) Rename the new columns to give them meaningful names. For example, rename 1 to yield (trial 1) and rename 2 to yield (trial 2).
Split a Column: Grouping Rows Example

The Drug Measurements.jmp sample data table contains measurements of three different drugs (a, b, and c) administered to 12 different subjects. You want to split the measurement into different columns, one for each drug type. You also want to group the measurements by subject.

1. Open the Drug Measurements.jmp sample data table.
2. Select Tables > Split.
3. Select Drug Type and click Split By.
4. Select Measurement and click Split Columns.

Notice that the Subject variable contains unequal groups. Most of the subjects were given all three drugs, but subject 2 was given only one drug, and subjects 7 and 12 were given only two drugs. In this situation, to ensure that the correct measurements are associated with the correct subject, specify Subject as the Group variable.

5. Select Subject and click Group.
6. Click OK.

You can see that the appropriate missing values appear for subjects 2, 7, and 12.
Transpose Rows and Columns

You can create a new JMP table that is a transposed version of the active data table. The columns of the active table are the rows of the new table, and its rows are the new table’s columns.

When you transpose columns, you do the following:

• Select the columns to be transposed.
• Specify a “label” column, from which the new columns get their names (optional).
• Specify “by” columns, which tells JMP to transpose data within groups (optional).

**Note:** Columns that you want to transpose must have the same data type. Also, if columns contain value labels, transposing uses the actual data values, not the value labels. (See “Value Labels” on page 180 in the “Set Column Properties” chapter.)

**To transpose rows and columns:**

1. Open a data table that contains the rows and columns that you want to transpose.
2. Select **Tables > Transpose**.

**Figure 6.15  Transpose Window**

3. Highlight the column name(s) you want to transpose in the **Select Columns** box on the left.
4. Click **Transpose Columns**.
5. (Optional) Customize your transposed table further using the additional options. See Table 6.5.
6. Click **OK**.
Table 6.5 Description of the Transpose Window

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select Columns Filter Menu</td>
<td>Contains options to search and filter through columns. See “Columns Filter Menu” on page 280 in the “JMP Platforms” chapter.</td>
</tr>
<tr>
<td>Transpose selected rows only</td>
<td>To transpose only rows that are currently highlighted in the active table, click the box beside Transpose selected rows only.</td>
</tr>
<tr>
<td>Output table name</td>
<td>(Optional) To name the subset table, type a name in the box beside Output table name.</td>
</tr>
<tr>
<td>Label column name</td>
<td>(Applicable only if you have specified a Label column.) Specify an alternative name for the Label column. Otherwise, the default column name is Label.</td>
</tr>
<tr>
<td>Keep dialog open</td>
<td>To keep this window open after clicking OK, check the box beside Keep dialog open.</td>
</tr>
<tr>
<td>Transpose Columns</td>
<td>Adds the columns that you want to transpose.</td>
</tr>
<tr>
<td>Label</td>
<td>To use the data from a column in the original table as the column names in the new table:</td>
</tr>
<tr>
<td></td>
<td>1. Highlight a column from the Select Columns box on the left.</td>
</tr>
<tr>
<td></td>
<td>2. Click Label. The column name appears in the Label box.</td>
</tr>
<tr>
<td></td>
<td>The default column name is name. You can specify an alternative name for the column using the Label column name option. Only one column is created for each distinct value in the label column. Therefore, if there are duplicate values in the label column, JMP creates only one column for the duplicated value using the value from the last duplicated row.</td>
</tr>
<tr>
<td>By</td>
<td>To organize the transposed columns into groups based on the columns that you put into the By box:</td>
</tr>
<tr>
<td></td>
<td>1. Highlight the column name(s) in the Select Columns box whose values you want to see as a group.</td>
</tr>
<tr>
<td></td>
<td>2. Click By.</td>
</tr>
</tbody>
</table>
Table 6.6 describes the rules that apply to transposing.

### Table 6.6 Rules for Transposing

<table>
<thead>
<tr>
<th>If</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>The original table has columns but no rows</td>
<td>The new table contains one column that lists those column names.</td>
</tr>
<tr>
<td>The original table has one column and it is assigned to <strong>Label</strong></td>
<td>Its values become the column names in the transposed table.</td>
</tr>
<tr>
<td>The original table has multiple columns and contains a label column</td>
<td>JMP automatically inserts the label column into the <strong>Label</strong> box when the window appears. You can remove this column if you do not want it to appear.</td>
</tr>
<tr>
<td>There is no label column in the original table</td>
<td>The column names in the transposed table are Row 1, Row 2, ..., Row ( n ) where ( n ) is the number of rows in the original table.</td>
</tr>
</tbody>
</table>

### Examples of Transposing Rows and Columns

This section contains three examples: a simple example of transposing, an example using the **Label** option, and an example using a **By** group.

#### Simple Example of Transposing

1. Open the Materials1.jmp sample data table.
2. Select **Tables > Transpose**.
3. Select plastic, tin, and gold and click **Transpose Columns**.
4. Click **OK**.

![Figure 6.16 Simple Transposed Table](image)

The original table in Figure 6.16 has two rows and three continuous columns called plastic, tin, and gold. The transposed table has a row for each of the three columns in the original table, and columns named Row 1 and Row 2 for the original table’s rows. The additional column called **Label** has the column names (plastic, tin, and gold) from the original table as values.
Example Using the Label Option

1. Open the Materials2.jmp sample data table.
2. Select Tables > Transpose.
3. Select plastic, tin, and gold and click Transpose Columns.
4. Select item and click Label.
5. Click OK.

Figure 6.17 Transpose with a Label

<table>
<thead>
<tr>
<th></th>
<th>Label</th>
<th>nails</th>
<th>hooks</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>plastic</td>
<td>1</td>
<td>4</td>
</tr>
<tr>
<td>2</td>
<td>tin</td>
<td>2</td>
<td>5</td>
</tr>
<tr>
<td>3</td>
<td>gold</td>
<td>3</td>
<td>6</td>
</tr>
</tbody>
</table>

The values from the item column in the original table are used as column labels in the transposed table.

Example Using a By Group

1. Open the Animals Subset.jmp sample data table.
2. Select Tables > Transpose.
3. Select subject and miles and click Transpose Columns.
4. Select season and click Label.
5. Select species and click By.
6. Click OK.

Figure 6.18 Transpose Using a By Group

<table>
<thead>
<tr>
<th></th>
<th>species</th>
<th>Label</th>
<th>fall</th>
<th>winter</th>
<th>spring</th>
<th>summer</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>COYOTE</td>
<td>subject</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>COYOTE</td>
<td>miles</td>
<td>4</td>
<td>2</td>
<td>7</td>
<td>6</td>
</tr>
<tr>
<td>3</td>
<td>FOX</td>
<td>subject</td>
<td>3</td>
<td>3</td>
<td>3</td>
<td>3</td>
</tr>
<tr>
<td>4</td>
<td>FOX</td>
<td>miles</td>
<td>4</td>
<td>3</td>
<td>6</td>
<td>2</td>
</tr>
</tbody>
</table>

The transposed table contains values that have been transposed in groups.

Concatenate Data Tables

When you concatenate data tables in JMP, you combine rows from two or more data tables. You can create a new data table or you can append rows to the first data table. If a column name is the same in the data tables that you want to concatenate, then the column in the new
data table lists the values from all of the data tables in the order of concatenation. If the two original data tables have columns with different names, those columns are included in the new data table showing missing values. You can also work with a list of table names.

To concatenate two data tables with the same column names:

1. Select Tables > Concatenate.

Figure 6.19  Concatenate Window

2. Highlight the names of the data tables that you would like to combine, and click Add.
   You can concatenate as many data tables as you choose, and you can also add the same data tables multiple times. The number of rows in the new data tables is the sum of the number of rows in all the data tables.

3. (Optional) Click the Save and evaluate formulas choice to request that JMP include all formulas.
   If you do not select this option, no formulas are included in the new data table.

   **Note:** If columns with the same name have different formulas, then the formula from the first data table is saved in the concatenated data table.

4. (Optional) Click the Create source column choice to add a column called Source Table to the new data table.
   This column identifies the name of the source data table in the corresponding rows.

5. (Optional) Select the Append to first table choice to append rows to the data table listed first in the Data Tables to be Concatenated field instead of creating a new data table.

6. (Optional) Type a name for the new data table in the Output table name field.
   If you do not type a name, JMP names the data table Untitled# (for example, Untitled1). The Output table name field is not available if you selected the Append to first table choice.

7. Click OK.
Example of Concatenating Data Tables

Suppose you want to concatenate two data tables (Trial1 and Trial2) into a new data table.

1. Open the Trial1.jmp and Trial2.jmp sample data tables.
2. From the Trial1.jmp table, select Tables > Concatenate.
3. In the Opened Data Table list, select Trial2 and click Add.
4. Click OK.

The data tables combine into a new concatenated table with all of the rows from the first data table followed by all of the rows from the second data table. See Figure 6.20.

Figure 6.20 Result of Concatenating Two Data Tables

<table>
<thead>
<tr>
<th></th>
<th>popcorn</th>
<th>color</th>
<th>batch</th>
<th>yield</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>plain</td>
<td>large</td>
<td>8.2</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>gourmet</td>
<td>large</td>
<td>9.8</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>plain</td>
<td>large</td>
<td>10.4</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>gourmet</td>
<td>large</td>
<td>9.2</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>plain</td>
<td>small</td>
<td>9.9</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>gourmet</td>
<td>small</td>
<td>12.1</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>plain</td>
<td>small</td>
<td>10.8</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>gourmet</td>
<td>small</td>
<td>10.9</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>plain</td>
<td>large</td>
<td>9.8</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>gourmet</td>
<td>large</td>
<td>9.3</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>plain</td>
<td>large</td>
<td>9.8</td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>gourmet</td>
<td>large</td>
<td>9.8</td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>plain</td>
<td>small</td>
<td>10.1</td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>gourmet</td>
<td>small</td>
<td>15.9</td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>plain</td>
<td>small</td>
<td>7.4</td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>gourmet</td>
<td>small</td>
<td>10.9</td>
<td></td>
</tr>
</tbody>
</table>

Concatenated data tables always have a column for every column name found in the original data tables. However, if the column names do not match exactly, they are not merged. For example, if the yield column was instead named yield1 and yield2, a separate column would be created for each in the concatenated data table.

When you concatenate two or more data tables containing table variables, separate columns are created for each table variable. This ensures that important distinctions are not lost when concatenating data tables.

Note: Columns are not created for table variables that begin with the name Notes.

Example of Concatenating Data Tables and Table Variables

For example, suppose that two cancer trials were conducted at two different hospitals. One of the trials’ data is in the Cancer1.jmp data table, and the other trial’s data is in the Cancer2.jmp data table.
Consolidate the data and the variables into one table, as follows:

1. Open the Cancer1.jmp and Cancer2.jmp sample data tables.
   
   Notice that there are two distinct table variables: Dosage Amount and Location. In the concatenated table, columns will be created for these two table variables.

2. From the Cancer1.jmp data table, select Tables > Concatenate.

3. Select Cancer2 and click Add.

4. Click OK.

**Figure 6.21 Data and Variables Concatenated**

The data and the variables are concatenated. The variables appear as columns in the concatenated table. The notes from each data table are added to the new data table as table variables.

---

### Join Data Tables

You can combine two data tables into one new table by selecting Tables > Join. For an overall description of how to join two data tables, see “To join two data tables into a new data table:” on page 221. Tables can be joined in three different ways:

- By combining them according to row number. See “Example of Joining by Row Number” on page 224.
- In a Cartesian fashion, where you form a new table consisting of all possible combinations of the rows from two original tables. See “Examples of a Cartesian Join” on page 226.
- By matching the values in one or more columns that exist in both data tables, or in a single data table. See “Examples of Joining by Matching Columns” on page 228.
To join two data tables into a new data table:

1. Open the two data tables that you want to join.
2. Select Tables > Join.
   In the window that appears, the names of all open tables appear below Join...with, as shown in Figure 6.22.

**Figure 6.22** The Join Window

3. In the Join...with box, select the table to join with the active table.
4. From the Matching Specification area, select the option that specifies how to join the tables.
5. Type the name of the new table in the text box beside Output table name.
6. (Optional) Customize the join procedure further using the additional options. See Table 6.7.
7. Click OK to create the joined data table.

**Table 6.7** Description of the Join Window

<table>
<thead>
<tr>
<th>Keep dialog open</th>
<th>To keep this window open after clicking OK, check the box beside Keep dialog open.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preserve main table order</td>
<td>Maintains the order of the original data table in the joined table, instead of sorting by the matching columns.</td>
</tr>
</tbody>
</table>
Table 6.7 Description of the Join Window  (Continued)

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Update main table with data from second table** | When Update main table with data from second table is checked, column data from the second table change the data of the same name columns in the original table. Note the following:  
  - JMP does not replace data with missing values.  
  - The output table uses the same columns as the original table. Thus, when you use **Update main table with data from second table**, Select Columns for joined table is not applicable.  
  - The Update main table with data from second table option is available only when joining by row number or by matching columns. |
| **Merge same name columns** | Click the box beside Merge same name columns if you want the data from the second table to replace the data of the same name columns in the original table. Note that missing values in the first table are replaced by nonmissing values in the second. If you join by matching columns, the new table contains a nominal column named Match Flag:  
  - If a one (1) appears in this column, the data originated from the first (active) table.  
  - If a two (2) appears in this column, the data originated from the second table.  
  - If a three (3) appears in this column, the data was found in both the first and second tables. |
| **Copy formula (Main Table and Second Table)** | Click the box beside Copy formula to include formulas from the main table and/or the second table in the output columns. |
| **Suppress formula evaluation (Main Table and Second Table)** | To prevent JMP from evaluating columns’ formulas during the creation of the new table, click the box beside Suppress formula evaluation for the main table and/or the second table. |
Chapter 6
Reshape Data

223
Using JMP Join Data Tables
By Matching Columns
To join rows, select columns in both tables whose values and data types match. You should:

1. Highlight a column name from each list in the Source Columns area. The first highlighted column in the top list pairs with the first highlighted column in the bottom list, the second columns are paired, and so on. Rows join only if values and data types match for all the column pairs.

2. Click Match. The selected pair of columns appears in the Match columns box. Matching columns do not have to have the same names and do not have to be in the same relative column position in both tables.

3. (Optional) To only include the first match found, check the boxes associated with Drop multiples in both tables. Only the first match found is written to the new table. If you specify this option for one table, the first match value is joined with all matches in the other table. If you do not check the boxes associated with Drop multiples in either table, a Cartesian join is performed within each group of matching column values.

4. (Optional) To include all rows from the data table, even when there is no matching value, check the boxes associated with Include non-matches. You can specify this option for either or both data tables being joined.

By Row Number
Joins the two tables side by side.

Cartesian Join
Joins two tables using a Cartesian fashion, where it forms a new table consisting of all possible combinations of the rows from two original tables. JMP crosses the data in the first table with the data in the second to display all combinations of the values in each set.

Select Columns for joined table
Select the Select Columns for joined table option if you want to select a subset of columns from either table for inclusion in the output table. Follow these steps:

1. In the Source Columns area, highlight the columns from each table that you want to include in the new table.

2. Click Select in the Output Columns area.

Output table name
To give a name to the joined table, type a name in the box beside Output table name.
Examples of Joining Data Tables

The following sections provide examples using the Join command.

Example of Joining by Row Number

Joining tables by row number joins the two tables side by side. The new table has all of the columns from both tables, unless you specify to include only certain columns.

To join tables with an unequal number of rows:

If the two tables that you want to join have an unequal number of rows, the new table contains values for the rows found in both tables.

1. Open the Species1.jmp and Species2.jmp sample data tables.
   Notice that the Species1.jmp table has two rows, and the Species2.jmp table has four rows.
2. From the Species1.jmp table, select Tables > Join.
3. In the Join...with box, select Species2.
4. From the Matching Specification area, select By Row Number.
5. Click OK.

Figure 6.23  Joined Tables by Row Number

If one table with two rows is joined with a table with four rows, then the new table contains four rows.

To join columns with the same name:

If the two tables have column names that are the same, the names of these columns in the new table appear as “column name of table name.” For example, suppose that you want to combine the eight rows from the Trial1.jmp and Trial2.jmp data tables shown in Figure 6.24 into a single table. You want to combine them so that the new table contains all of the columns from both tables.

1. Open the Trial1.jmp and Trial2.jmp sample data tables.
2. From the Trial1.jmp data table, select Tables > Join.
3. In the Join...with box, select Trial2.
4. From the Matching Specification menu, select By Row Number.
Chapter 6
Using JMP

Reshape Data
Join Data Tables

5. Click OK.

**Figure 6.24** Original Tables and the Joined Table

<table>
<thead>
<tr>
<th></th>
<th>popcorn of Trial1</th>
<th>all amt of Trial1</th>
<th>batch of Trial1</th>
<th>yield of Trial1</th>
<th>popcorn of Trial2</th>
<th>all amt of Trial2</th>
<th>batch of Trial2</th>
<th>yield of Trial2</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>plain</td>
<td>little</td>
<td>large</td>
<td>8.2</td>
<td>plain</td>
<td>little</td>
<td>large</td>
<td>8.8</td>
</tr>
<tr>
<td>2</td>
<td>gourmet</td>
<td>little</td>
<td>large</td>
<td>8.6</td>
<td>gourmet</td>
<td>little</td>
<td>large</td>
<td>8.2</td>
</tr>
<tr>
<td>3</td>
<td>plain</td>
<td>lots</td>
<td>large</td>
<td>10.4</td>
<td>plain</td>
<td>lots</td>
<td>large</td>
<td>9.8</td>
</tr>
<tr>
<td>4</td>
<td>gourmet</td>
<td>lots</td>
<td>large</td>
<td>9.2</td>
<td>gourmet</td>
<td>lots</td>
<td>large</td>
<td>9.8</td>
</tr>
<tr>
<td>5</td>
<td>plain</td>
<td>little</td>
<td>small</td>
<td>9.9</td>
<td>plain</td>
<td>little</td>
<td>small</td>
<td>16.1</td>
</tr>
<tr>
<td>6</td>
<td>gourmet</td>
<td>little</td>
<td>small</td>
<td>12.1</td>
<td>gourmet</td>
<td>little</td>
<td>small</td>
<td>15.9</td>
</tr>
<tr>
<td>7</td>
<td>plain</td>
<td>lots</td>
<td>small</td>
<td>10.6</td>
<td>plain</td>
<td>lots</td>
<td>small</td>
<td>7.4</td>
</tr>
<tr>
<td>8</td>
<td>gourmet</td>
<td>lots</td>
<td>small</td>
<td>18.0</td>
<td>gourmet</td>
<td>lots</td>
<td>small</td>
<td>16.0</td>
</tr>
</tbody>
</table>

If a column name is the same in the two original tables, the output column name is qualified by the source table name (For example, the column names in the new table appear as <variable name> of table name).

*To join only specified columns:*

Suppose that you do not want all of the columns from the original data tables to be in the joined table. Proceed as follows:

1. Open the Trial1.jmp and Trial2.jmp sample data tables.
2. From the Trial1.jmp data table, select Tables > Join.
3. In the **Join...with** box, select Trial2.
4. From the **Matching Specification** menu, select By Row Number.
5. Click **Select columns for joined table** to specify the subset of columns that you want to include.
6. In the Source Columns list, select popcorn and yield from the Trial1 list and select yield from the Trial2 list.

   Because identical data exists in the popcorn column of both tables, you need to select only one column.

7. Click **Select**.
8. Click **OK**.
Reshape Data
Join Data Tables

Chapter 6
Using JMP

Figure 6.25 Joining Only Specified Columns

<table>
<thead>
<tr>
<th></th>
<th>yield of Trial1</th>
<th>yield of Trial2</th>
<th></th>
<th>yield of Trial1</th>
<th>yield of Trial2</th>
</tr>
</thead>
<tbody>
<tr>
<td>popcorn</td>
<td>1.2</td>
<td>0.8</td>
<td>plain</td>
<td>3.4</td>
<td>2.6</td>
</tr>
<tr>
<td>gourmet</td>
<td>8.6</td>
<td>8.2</td>
<td>plain</td>
<td>10.4</td>
<td>2.8</td>
</tr>
<tr>
<td>gourmet</td>
<td>9.2</td>
<td>9.8</td>
<td>plain</td>
<td>9.9</td>
<td>10.1</td>
</tr>
<tr>
<td>gourmet</td>
<td>12.1</td>
<td>15.9</td>
<td>plain</td>
<td>10.6</td>
<td>7.4</td>
</tr>
<tr>
<td>gourmet</td>
<td>18.0</td>
<td>16.0</td>
<td>plain</td>
<td>18.0</td>
<td>20.0</td>
</tr>
</tbody>
</table>

Examples of a Cartesian Join

When doing a Cartesian join, JMP joins two tables in a Cartesian fashion, where a new table is created that consists of all possible combinations of the rows from two original tables. This creates cases in the output table where there are one case for each combination of column values.

Simple Example
1. Open the Species1.jmp and Species2.jmp sample data tables.
2. From the Species1.jmp table, select Tables > Join.
3. In the Join...with box, select Species2.
4. From the Matching Specification menu, select Cartesian Join.
5. Click OK.

Figure 6.26 Joining Tables Using Cartesian Join

The data in Species1.jmp is crossed with the data in Species2.jmp to produce the joined table, which shows all combinations of the values in each set.

Complex Example
In this example, use the Tables > Join command twice:
- The first join combines the Oil Amount.jmp table with the Batch.jmp table using the Cartesian option.
The second join combines the resulting table (Cartesian oil amount + batch) with the Popcorn Type.jmp table and produces a final table with all tables joined.

1. Open the Oil Amount.jmp, Batch.jmp, and Popcorn Type.jmp sample data tables.
2. From the Oil Amount.jmp table, select Tables > Join.
3. In the Join...with box, select Batch.
4. From the Matching Specification menu, select Cartesian Join.
5. Under Output table name, type Oil Amount and Batch.
6. Click OK.

Figure 6.27 Oil Amount and Batch Joined Table

<table>
<thead>
<tr>
<th>oil amount</th>
<th>batch</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>small</td>
</tr>
<tr>
<td>1</td>
<td>large</td>
</tr>
<tr>
<td>3</td>
<td>small</td>
</tr>
<tr>
<td>4</td>
<td>large</td>
</tr>
</tbody>
</table>

The joined table contains all of the columns from the Oil Amount.jmp and Batch.jmp tables. Add the Popcorn Type.jmp columns, as follows:

7. From the Oil Amount and Batch table that you just created, select Tables > Join.
8. In the Join...with box, select Popcorn Type.
10. Click OK.

Figure 6.28 Oil Amount and Batch Joined with Popcorn Type

<table>
<thead>
<tr>
<th>oil amount</th>
<th>batch</th>
<th>popcorn</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>small</td>
<td>gourmet</td>
</tr>
<tr>
<td>2</td>
<td>small</td>
<td>plain</td>
</tr>
<tr>
<td>3</td>
<td>large</td>
<td>gourmet</td>
</tr>
<tr>
<td>4</td>
<td>large</td>
<td>plain</td>
</tr>
<tr>
<td>5</td>
<td>small</td>
<td>gourmet</td>
</tr>
<tr>
<td>6</td>
<td>small</td>
<td>plain</td>
</tr>
<tr>
<td>7</td>
<td>large</td>
<td>gourmet</td>
</tr>
<tr>
<td>8</td>
<td>large</td>
<td>plain</td>
</tr>
</tbody>
</table>

The final table contains all of the columns from all three original tables. Keep in mind that the number of rows produced by a Cartesian join is the product of the number of rows in the original tables.
Examples of Joining by Matching Columns

When you select to join data tables by matching columns, JMP finds specified column(s) values that exist in both tables and combines all values associated with the specified column(s) values into a new data table.

In order to join by matching columns, the columns must have the same data type (numeric, character, or row state).

You can also join a data table to itself, in order to remove duplicate values or rows from the data table.

To join tables with the same rows in a different order:

1. Open the Students1.jmp and Students2.jmp sample data tables.
   The Students1.jmp data table contains names, ages, and sexes of the students. The Students2.jmp data table contains names, height, and weight of the students. Instead of working with two separate tables, you would like to combine the tables into one. Notice that the students’ names are not in the same order in both tables. For example, Alice is in row 7 and row 9.
2. From the Students1.jmp data table, select Tables > Join.
3. In the Join...with box, select Students2.
   Because both tables have one column (name) that contains the same values, you need to tell JMP that they are matches. JMP then examines each of the values in the name column of the first table to determine whether there was a corresponding value in the second table’s name column. For example, it detects that Alice is located in both tables. It creates a name column in the new table with Alice as a value. It then takes the age and sex of Alice from table one and puts it in the new table. Then it takes the height and weight of Alice and puts them in the new table.
5. From the Students1 and Students2 lists, select name.
6. Click Match.
7. You want the new table to contain only one row for each name, so check the Drop multiples boxes for both tables.
8. Click OK.
Using JMP Join Data Tables

To join tables with different numbers of rows and different column names:

Suppose that Sarah and Joe are performing a popcorn experiment. They are popping different types of popcorn (gourmet and plain) in different amounts of oil. They are recording the amount (yield) of popcorn that is produced. Sarah gave you the first trial data in a file named Trial1.jmp. Joe gave you the second trial data in a file named Little.jmp. You want to combine the two tables into one table.

1. Open the Trial1.jmp and Little.jmp sample data tables.
2. From the Trial1.jmp table, select Tables > Join.
3. In the Join...with box, select Little.
   
   You can see that three of the columns (popcorn, oil amt/oil, and batch) contain the same values in both tables. Identify these columns as matches. Also, because Sarah and Joe gave the oil and oil amt columns different names, you can tell JMP that oil amt and oil match.
5. From the Trial1 list, select popcorn, oil amt, and batch.
6. From the Little list, select popcorn, oil, and batch.
7. Click Match.

Looking at the two data tables, you can see that they have different numbers of rows. Trial1.jmp has values for eight experimental conditions, and Little.jmp has values for only four of those conditions. Sarah completed her experiment, but Joe only partially completed his experiment. You want the joined table to contain all of the rows in Trial1.jmp, even if that row in the Little.jmp table contains a missing value.

8. Select the Include non-matches boxes for both tables.

In the joined table, you only want one column for popcorn, one column for oil, and one column for batch. However, you want two columns for yield: one representing the yield from Trial1.jmp, and another representing the yield from Little.jmp.

9. Select the box beside Select columns for joined table.
10. From the Trial1 list, select all of the columns.
11. Click Select.
12. From the Little list, select yield.
13. Click Select.

**Figure 6.30** Completed Join Window

14. Click OK.

**Figure 6.31** Trial1.jmp and Little.jmp Joined
The joined table is sorted by the matching columns. Note that the yield column from the Little.jmp table (Yield of Little) has missing values indicating no matching values with the Trial1.jmp table.

To join a table to itself (to remove duplicate entries):

1. Open the Coffee Shop Purchases.jmp sample data table.
2. Select Tables > Join.
3. In the Join...with box, select Coffee Shop Purchases.
5. From both Coffee Shop Purchases lists, select all three columns: Date, Customer, and Beverage.
6. Click Match.
7. Select the Drop multiples boxes for both tables (the Main Table and the With Table).
8. Type Coffee Shop Purchases Final for the Output table name.
9. Click OK.

Figure 6.32 Original and Joined Coffee Shop Purchases Data Tables

Update Data Tables

If you have two data tables and would like to update your original table with data from a new table, select Tables > Update. The Update command is a special case of Join in place. It is a Join with the Update option checked, and it does not result in a new table.
Before you update a table, make sure that the name of the column containing the values that you want to replace is the same as the name of the column containing the data that you want to replace it with.

*To replace values in the active table with those found in another open table:*

1. Click on the original table that you want to update (this is the table whose values you want to replace) to make it the active table.
2. Select **Tables > Update.**

**Figure 6.33** Updating a Table

3. Highlight the new table containing the data that you want to transfer to the original table.
4. (Optional) If you do not want JMP to replace the values in the original table with any missing values found in the new table, select the box next to **Ignore missing.** The original table retains its original values if they correspond to missing values in the new table.
5. If the two tables have one or more columns whose values uniquely describe each row, JMP uses those columns as the *match column values.* That is, JMP updates the rows whose match column values coincide. JMP uses these columns to preserve the sorted order of the data. If your tables do not have matching column values, you can incorporate the updated values according to their row order by continuing here. To proceed with tables containing matching column values, see “To update a table using matching columns:” on page 233.
6. From the **Add Columns from Update** table area, select an option. Using these options, you can add columns (that do not exist) from the new table into the original table.
   - Choose **All** to add all columns from the new table into the original table.
   - Choose **Selected** to add only columns that you have selected from the new table into the original table.
Choose None if you do not want to add any non-existent columns from the new table into the original table.

7. Click OK.

To update a table using matching columns:

1. Follow the first three steps outlined in the previous section, “To replace values in the active table with those found in another open table:” on page 232.

2. Select Match columns.

3. Highlight the two column names (in the respective tables) that you want to match.

4. Click Match.

5. (Optional) Repeat to match more columns.

6. Click OK.

Note: Unless the None option is selected in the Add Columns from Update table area, any columns that have different names from the columns in the table that you are updating (and that have not been assigned matches) are appended as separate columns.

Example of Updating a Data Table

Suppose a researcher has a data table containing height measurements for students. The researcher receives an updated table that contains more recent measurements of the students’ heights. The researcher wants to avoid scrolling through the data tables to find the students whose height has changed, and copying and pasting the new values. Using the Update
command, the researcher can quickly update the original data table with the new height values.

1. Open the Big Class.jmp and New Heights.jmp sample data tables.
   The Big Class.jmp table contains the original data, and the New Heights.jmp table contains the updated data.

2. From the Big Class.jmp table, select Tables > Update.

3. In the Update...with data from box, select New Heights.

4. Select Match columns.

5. In the Big Class and New Heights lists, select name.

6. Click Match.
   This tells JMP to use name as the match column value, since it is the column whose values uniquely describe each row.

7. Click OK.

**Figure 6.35** The Updated Big Class.jmp Table

<table>
<thead>
<tr>
<th>name</th>
<th>age</th>
<th>sex</th>
<th>height</th>
<th>weight</th>
</tr>
</thead>
<tbody>
<tr>
<td>KATIE</td>
<td>12</td>
<td>F</td>
<td>62</td>
<td>95</td>
</tr>
<tr>
<td>LOUISE</td>
<td>12</td>
<td>F</td>
<td>61</td>
<td>123</td>
</tr>
<tr>
<td>JANIE</td>
<td>12</td>
<td>F</td>
<td>58</td>
<td>74</td>
</tr>
<tr>
<td>JACLYN</td>
<td>12</td>
<td>F</td>
<td>60</td>
<td>140</td>
</tr>
<tr>
<td>LILIE</td>
<td>12</td>
<td>F</td>
<td>52</td>
<td>84</td>
</tr>
<tr>
<td>TIM</td>
<td>12</td>
<td>M</td>
<td>64</td>
<td>84</td>
</tr>
<tr>
<td>JAMES</td>
<td>12</td>
<td>M</td>
<td>63</td>
<td>120</td>
</tr>
<tr>
<td>ROBERT</td>
<td>12</td>
<td>M</td>
<td>70</td>
<td>79</td>
</tr>
<tr>
<td>BARBARA</td>
<td>13</td>
<td>F</td>
<td>66</td>
<td>112</td>
</tr>
<tr>
<td>ALICE</td>
<td>13</td>
<td>F</td>
<td>61</td>
<td>107</td>
</tr>
<tr>
<td>SUSAN</td>
<td>13</td>
<td>F</td>
<td>58</td>
<td>67</td>
</tr>
<tr>
<td>JOHN</td>
<td>13</td>
<td>M</td>
<td>60</td>
<td>80</td>
</tr>
<tr>
<td>JOE</td>
<td>13</td>
<td>M</td>
<td>64</td>
<td>106</td>
</tr>
<tr>
<td>MICHAEL</td>
<td>13</td>
<td>M</td>
<td>60</td>
<td>85</td>
</tr>
<tr>
<td>DAVID</td>
<td>13</td>
<td>M</td>
<td>61</td>
<td>79</td>
</tr>
</tbody>
</table>

You can see that the height values in the updated table no longer match the values in the original table. The values have been updated to use the newer values from the New Heights.jmp table.
Use the JMP Formula Editor to create a column whose values are computed by a formula and store that formula as part of a column’s information. Formulas can be simple assignments of numeric, character, or row state constants, or they can contain complex evaluations based on conditional clauses. The Formula Editor window operates like a calculator with buttons, displays, and a list of functions.

**Figure 7.1** The Formula Editor

Formulas are an integral part of a data table for the following reasons:

- They are stored as part of a column’s information when you save the data table.
- You can examine or change them at any time by opening the Formula Editor.
- Their values can be linked to, or dependent on, the values in other columns. Their values are automatically recomputed whenever you edit the values in the columns to which the formula is linked.
- Their values are locked in the data table so they cannot be manually edited.

This chapter describes the Formula Editor and shows how to build formulas. For details about each function, see the “Formula Functions Reference” chapter on page 441.
Create a Formula

A formula is an expression stored in a column that performs operations in order to insert values into that column. Formulas can perform mathematical operations, such as addition and multiplication, or they can compare column values or join values by referring to other areas in the same data table. Formulas can consist of any JMP Scripting Language (JSL) command. Once you insert a formula into a column, the column is locked: its values can be edited only by changing or removing the formula.

There are three basic steps to building a formula:

1. Open the Formula Editor by right-clicking the column name to which you want to apply the formula and selecting Formula.
   or
   Double-click the column name to which you want to apply the formula, select Formula from the Column Properties menu, and then click Edit Formula.

2. Select an empty formula element in the formula editing area by clicking it. (See Figure 7.2.)

   **Note:** An element is selected when there is a red outline around it. All terms within the smallest nesting box relative to the place that you clicked become selected. The subsequent actions apply to those combined elements.

3. Add expressions, functions, and terms from the formula work panel. They are applied to the highlighted red box. The following sections in this chapter provide detailed instructions on how to add constants, elements, operators, and functions.
Reference Columns and Table Variables

You can create a formula that refers to values found in other parts of the data table, such as other columns and table variables.

When a formula uses values in other columns, the values in the column with that formula are dependent on the values in those other columns. Whenever a column that the formula refers to changes, the dependent column also changes. If you delete the referenced column, empty terms appear in the column containing the formula.

If you create a formula that refers to values found in table variables, those table variables must already exist in the data table. Table variables are character strings that are available to the entire table. Their names are displayed in the table panel at the left of the data table. (For details, see “Use Table Variables” on page 146 in the “Enter and Edit Data” chapter.)

To build a formula that references values found in columns or table variables:

1. Open the Formula Editor by right-clicking a column name in the data table and selecting Formula.
2. Select a box in the formula editing area by clicking it. (It is selected when there is a red outline around it.)

3. Click the menu on the formula element browser and select either Table Columns or Table Variables. Highlight an element from that category’s list. The element is added to the selected box in the formula editing area.

For an example of referencing a column in a formula, see “Use Basic Formula Editor Features” on page 256.

**Note:** In a formula, when you reference a column using value labels, hover your mouse over the value label to see the actual data value.

---

**Use Local Variables**

You can create and use temporary numeric variables in expressions. You can use ordinary local variables or you can use parameters, which are special types of local variables. Local variables exist only for the evaluation of the formula in which they are defined. They appear in formulas as bold italic terms.

Local variables are most often used with Assignment functions, which can assign expressions to local variables that are used in a complex equation. (For details, see “Assignment Functions” on page 492 in the “Formula Functions Reference” chapter.) This technique can sometimes simplify building an equation and improve the efficiency of its evaluation.

*To build a formula that references values found in local variables:*

**Step 1: Create the Local Variable**

1. Open the Formula Editor by right-clicking a column name in the data table and selecting Formula.

2. Select a box in the formula editing area by clicking it. (It is selected when there is a red outline around it.)

3. Click the menu on the formula element browser and select Local Variables from the formula element browser menu.

4. Click New Local Variable.

5. Type a name for the local variable. By default, local variables have the names t0, t1, and so on, and have missing values.

6. Assign a starting value, and click OK.

7. (Optional) To copy, edit, or delete a local variable, right-click (Ctrl-click on the Macintosh) its name and select Copy, Edit, or Delete.
Step 2: Insert a Local Variable into a Formula

1. Select a term in the formula editing area by clicking it. (It is selected when there is a red outline around it.)
2. Click the local variable name in the Local Variables list. It appears in the formula as a bold italic term.

Note: Another way to create local variables is to use the button on the Formula Editor keypad, which automatically creates and displays local variables and places a semicolon after it. See “Add Operators” on page 242, for details.

Incorporate Parameters

Parameters are special types of local variables that are recognized as model parameters in some platforms, such as Nonlinear fitting. They can be used in formulas just as ordinary local variables can.

To view examples of parameters:

1. In the sample data folder that was installed when you installed JMP, open the Nonlinear Examples folder and then US Population.jmp.
2. Right-click the column name x-formula and select Formula.
3. Click the menu on the formula element browser and select Parameters.

Notes:

- After completing a nonlinear fit or after using the Reset button in the nonlinear control panel, the parameter’s value is the most recent value computed by the nonlinear platform.
- Each time the fitting algorithm takes a step, the updated parameter values are shown in the Nonlinear report.
- When you paste a formula with parameters into a column, the parameters are automatically created for that column unless it has existing parameters with the same names.

To build a formula that references values found in parameters:

Step 1: Create the Parameter

1. Open the Formula Editor by right-clicking a column name in the data table and selecting Formula.
2. Make sure a term is selected (a red highlight is around it in the formula editing area) in the formula editing area.

3. Click the menu on the formula element browser and select Parameters.

4. Click New Parameter.

5. Type a name for the parameter. By default, parameters have the names $b_0$, $b_1$, and so on, and have missing values.

6. Assign a starting value. It is important to enter this value when using a parameter in a model for the nonlinear platform. After completing a nonlinear fit, the parameter’s value is the most recent value computed by the nonlinear platform.

7. (Optional) To add several parameters (one for each level of a categorical variable, for example) at once, select Expand into categories, selecting column. Then select the column for which you want to expand the parameter.

8. Click OK.

9. (Optional) To copy, edit, or delete a parameter, right-click (Ctrl-click on the Macintosh) its name and select Copy, Edit, or Delete.

**Step 2: Insert a Parameter into a Formula**

1. Select a term in the formula editing area by clicking it. (It is selected when there is a red outline around it.)

2. Click the parameter name in the Parameters list. The parameter appears in the formula as bold type.

---

**Insert Constants**

Formulas can be simple assignments of numeric, character, or row state constants, or they can contain complex evaluations based on conditional clauses. Constants include commonly used numeric terms, such as $e$, $\pi$, $-1$, $0$, $1$, and $2$. There are two ways to add a constant value to a formula:

- Type them in manually using the keyboard
- Select them from the formula element browser, as shown in Figure 7.3.
To add constants to a formula:

1. Open the Formula Editor by right-clicking a column name in the data table and selecting Formula.
2. Select a box in the formula editing area by clicking it. (It is selected when there is a red outline around it.)
3. Either type in a number or click the menu at the top of the formula element browser and select Constants, as shown in Figure 7.3. Then click a value in the list that appears: 0, 1, 2, -1, pi, e. The value appears in the outlined box.
4. Complete the remainder of the formula using the keypad and functions. (See “Reference Columns and Table Variables” on page 238, “Add Operators” on page 242, and “Use Functions” on page 244.)

Add Operators

You can add operators to a formula using the keypad, which contains buttons that help build formulas. It includes common operators (also referred to as functions).
To build a formula using keypad operators:

1. Open the Formula Editor by right-clicking a column name in the data table and selecting Formula.
2. Select a box in the formula editing area by clicking it. (It is selected when there is a red outline around it.) The operator performs its action on the area that is highlighted.
3. Select the column or variable that you want to use in your formula.
4. Click the keypad button(s).

Keypad Reference

Table 7.1 describes the keypad buttons.

Table 7.1 Keypad Buttons in the Formula Editor

<table>
<thead>
<tr>
<th>Key</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Arithmetical buttons</td>
<td>Work as they normally do on a pocket calculator, providing addition, multiplication, subtraction, and division operators.</td>
</tr>
<tr>
<td></td>
<td>Insert</td>
<td>Inserts a new clause or function argument. First select the existing clause or argument that you want the new element to follow, and then click this button. The new clause appears and is selected. You can also insert a new clause or argument by typing a comma.</td>
</tr>
</tbody>
</table>
Use Functions

Tip: Within JMP, tooltips are available to help you understand what each function does.

You can add many types of functions to a formula. All of these functions are organized in the function browser. The browser groups collections of functions in lists organized both alphabetically (Functions (all)) and by topic (Functions (grouped)). Use the function browser to specify the type of calculation that you want to perform on the elements in a formula.

To create a formula that contains a function:

1. Open the Formula Editor by right-clicking a column name in the data table and selecting Formula.
2. Select an expression in the formula editing area by clicking it. (It is selected when there is a red outline around it.) The function performs its action on the area that is highlighted.

Table 7.1 Keypad Buttons in the Formula Editor (Continued)

<table>
<thead>
<tr>
<th>Key</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Delete" /></td>
<td>Delete</td>
<td>Deletes an element's value, or deletes a clause. The delete button functions the same as the Delete key on the keyboard.</td>
</tr>
<tr>
<td><img src="image" alt="Exponent" /></td>
<td>Exponent</td>
<td>Raises a given value to a specified power. It has an exponent of two by default.</td>
</tr>
<tr>
<td><img src="image" alt="Root" /></td>
<td>Root</td>
<td>Calculates the specified root of the radicand. It has an implied index of two (a square root), which is not displayed.</td>
</tr>
<tr>
<td><img src="image" alt="Switch terms" /></td>
<td>Switch terms</td>
<td>Looks at the operator that is central to the selected expression and switches the expressions on either side of that operator.</td>
</tr>
<tr>
<td><img src="image" alt="Unary sign function" /></td>
<td>Unary sign function</td>
<td>Inverts the sign of the argument. Apply the unary sign function to variable expressions or use it to enter negative constants.</td>
</tr>
<tr>
<td><img src="image" alt="Local variable" /></td>
<td>Local variable</td>
<td>Creates and displays a local variable and assigns it the value of the selected expression. The local variable has the default name t0 in an expression and a semicolon after it. See “Use Local Variables” on page 239, for details about creating and inserting local variables. See “Use Local Variables in a Formula” on page 257, for an example.</td>
</tr>
<tr>
<td><img src="image" alt="Delete expression (peel)" /></td>
<td>Delete expression (peel)</td>
<td>Removes the outermost expression with the first argument. You can repeat this process to delete a formula term by term. See “Use the Delete Expression Key” on page 260, for an example.</td>
</tr>
</tbody>
</table>
3. Click the menu in the function browser to view the groups of functions.

4. Select a group of functions to view. See Table 7.2 for details.

   The functions that belong to that group are then displayed in the list below the menu. The function groups are briefly described in the following list.

5. Click any function in the Functions list to apply it to the selected item. When you click some items, you reveal a submenu from which you should make a selection.

**Note:** Most functions give hints about appropriate arguments through gray words inserted in the boxes in the formula editing area. Functions also show a small caret in the argument area if additional arguments can be added.

6. Continue to build the formula by highlighting terms and clicking items in the formula element browser, keypad, or function browser.

Table 7.2 Groups of Functions

<table>
<thead>
<tr>
<th>Group</th>
<th>Functions Included</th>
</tr>
</thead>
<tbody>
<tr>
<td>Functions (all)</td>
<td>Displays a list of all available functions in alphabetical order. For details about individual functions, see the “Formula Functions Reference” chapter on page 441.</td>
</tr>
<tr>
<td>Functions (grouped)</td>
<td>Displays a list of all available functions grouped according to topic.</td>
</tr>
<tr>
<td>Row</td>
<td>Displays a list of functions that contains miscellaneous functions such as Lag, Dif, Subscript, Row, and NRow. See “Row Functions” on page 443 in the “Formula Functions Reference” appendix.</td>
</tr>
<tr>
<td>Numeric</td>
<td>Displays a list of functions that are terms commonly used in formulas. See “Numeric Functions” on page 445 in the “Formula Functions Reference” appendix.</td>
</tr>
<tr>
<td>Transcendental</td>
<td>Displays a list of functions that are functions such as natural log, common log, exponential, root, factorial, combinatorial, beta, and gamma. See “Transcendental Functions” on page 445 in the “Formula Functions Reference” appendix.</td>
</tr>
<tr>
<td>Trigonometric</td>
<td>Displays a list of functions that are the standard trigonometric functions: sine, cosine, tangent, inverse functions, and hyperbolic functions. See “Trigonometric Functions” on page 448 in the “Formula Functions Reference” appendix.</td>
</tr>
</tbody>
</table>
### Table 7.2 Groups of Functions  (Continued)

<table>
<thead>
<tr>
<th>Group</th>
<th>Functions Included</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Character</strong></td>
<td>Displays a list of functions that operate on character arguments such as trimming, finding the length of a string, converting between numbers and characters. See “Character Functions” on page 449 in the “Formula Functions Reference” appendix.</td>
</tr>
<tr>
<td><strong>Comparison</strong></td>
<td>Displays a list of functions that are the standard logical comparisons such as less than, less than or equal to, not equal to, and so on. See “Comparison Functions” on page 459 in the “Formula Functions Reference” appendix.</td>
</tr>
<tr>
<td><strong>Conditional</strong></td>
<td>Displays a list of functions that are programming-like functions, such as If, Match, and Choose. See “Conditional Functions” on page 460 in the “Formula Functions Reference” appendix.</td>
</tr>
<tr>
<td><strong>Probability</strong></td>
<td>Displays a list of functions that compute probabilities and quantiles for standard statistical distributions, such as normal, Student's t, Chi-squared, and F-distributions. See “Probability Functions” on page 465 in the “Formula Functions Reference” appendix.</td>
</tr>
<tr>
<td><strong>Discrete Probability</strong></td>
<td>Displays a list of functions that compute discrete probabilities, such as Poisson, Gamma Poisson, and Hypergeometric. See “Discrete Probability Functions” on page 474 in the “Formula Functions Reference” appendix.</td>
</tr>
<tr>
<td><strong>Statistical</strong></td>
<td>Displays a list of functions that calculate standard statistical quantities such as the mean or standard deviation. See “Statistical Functions” on page 476 in the “Formula Functions Reference” appendix.</td>
</tr>
<tr>
<td><strong>Random</strong></td>
<td>Displays a list of functions that generate random numbers based on predefined distributions such as the uniform, normal, Cauchy, and so on. There is also a function to randomize the order of table rows. See “Random Functions” on page 480 in the “Formula Functions Reference” appendix.</td>
</tr>
<tr>
<td><strong>Date Time</strong></td>
<td>Displays a list of functions that require arguments with the date data type, which is interpreted as the number of seconds since January 1, 1904. Date Time functions return values such as day, week, or month of the year. They can also compute dates and can find data intervals. See “Date Time Functions” on page 484 in the “Formula Functions Reference” appendix.</td>
</tr>
</tbody>
</table>
Order Expressions in Formulas

As you build a formula, keep in mind that all functions have an order of precedence shown in the following table, where level one is the highest order of precedence. Expressions with a high order of precedence are evaluated before those at lower levels. When an expression has operators of equal precedence, it is evaluated from left to right. You can use parentheses to override other precedence rules when necessary because any expression within parentheses is always evaluated first. Terms have no order of precedence because they cannot be evaluated further. Table 7.3 shows the first six levels of the order of precedence.

<table>
<thead>
<tr>
<th>Level</th>
<th>Operators/Functions</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Parentheses</td>
</tr>
<tr>
<td>2</td>
<td>Functions in the function browser lists, And, Or, Not</td>
</tr>
<tr>
<td>3</td>
<td>*, ÷, Modulo</td>
</tr>
<tr>
<td>4</td>
<td>+, –</td>
</tr>
</tbody>
</table>

**Table 7.2 Groups of Functions (Continued)**

<table>
<thead>
<tr>
<th>Group</th>
<th>Functions Included</th>
</tr>
</thead>
<tbody>
<tr>
<td>Row State</td>
<td>Displays a list of functions that assign or detect row state status of color, marker, label, hidden, excluded, or selected. See “Row State Functions” on page 487 in the “Formula Functions Reference” appendix.</td>
</tr>
<tr>
<td>Assignment</td>
<td>Displays a list of functions that place the value on the right side of the assignment operator into the variable on the left side of the operator. See “Assignment Functions” on page 492 in the “Formula Functions Reference” appendix.</td>
</tr>
<tr>
<td>Parametric Model</td>
<td>Lets you construct a Linear, Interactions, or Full Quadratic model for columns that you choose. After choosing the type of model, a window appears that lets you select the variables from which to construct the model. Hold the CTRL key and click to select more than one. See “Parametric Model Functions” on page 493 in the “Formula Functions Reference” appendix.</td>
</tr>
<tr>
<td>Finance</td>
<td>Lets you create formulas to calculate principal payments, interest rate, rate of return, and so on. See “Finance Functions” on page 493 in the “Formula Functions Reference” appendix.</td>
</tr>
</tbody>
</table>
Order Expressions in Formulas Using JMP

Note: When a function has an expression as its argument, the argument has a higher order of precedence than it would if enclosed in parentheses outside the function.

Build a Formula in Order of Precedence

It is best to build a formula starting with any expression that serves as an argument. This is because functions have a high order of precedence and are always grouped with their corresponding arguments. It is also a good idea to create expressions working from highest to lowest order of precedence when possible. If you need parentheses, be sure to type the open parenthesis before entering the expression to be enclosed.

For example, given a data table with the columns A, B, and C, use the following steps to compose the expression \( A(B + C) \). Note that this expression is not the same as \( A \times B + C \), which evaluates as \( (A \times B) + C \).

To enter the expression:

1. Select **Table Columns** from the formula element browser list.
2. Click column A in the **Table Columns** list.
3. Click the multiplication button \( \times \) in the Formula Editor keypad.
4. Type an open parenthesis: \( ( \)
5. Click column B in the **Table Columns** list.
6. Click the addition button \( + \) in the Formula Editor keypad.
7. Click column C in the **Table Columns** list.

Because the order of precedence determines which arguments are affected by each functions, it also affects the grouping of expressions. Select functions in the formula to verify how the order-of-precedence rules have been applied.

Structure Formulas for Efficient Evaluation

Usually, it is not necessary to structure formulas with efficient evaluation in mind. Most formulas evaluate almost instantaneously regardless of their structure. This is because statistical functions and constant expressions are evaluated only once when a column's values are calculated.

### Table 7.3 Order of Precedence of Operators in Formulas (Continued)

<table>
<thead>
<tr>
<th>Level 5</th>
<th>Comparisons: (&lt;, \leq, =, \neq, \geq, \leq x &lt;, &lt; x \leq, &lt; x &lt;)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Level 6</td>
<td>Logical Operators &amp;, |, !</td>
</tr>
</tbody>
</table>

**Note:** The order of precedence determines which arguments are affected by each function.
However, when you are creating conditional expressions, keep in mind that *Match* evaluates faster and uses less memory than an equivalent *Condition* function, *If*. (Note that *Match* ignores trailing spaces and *If* does not.)

For example, using Big Class.jmp, you can predict a child’s height from his age as shown in Figure 7.5. There is a base height of 58.125 inches to which a quantity is added depending on the value of the *age* variable.

**Figure 7.5** The Match Conditional Evaluates Faster Than the If Function

The *Match* conditional evaluates faster than the *If* function because the *age* variable is evaluated only once for each row in the data table. The *If* condition must evaluate the *age* variable at each *If* clause for each row until a clause evaluates as true.

---

**Use Formula Editor Options**

There are several options available to you as you create formulas. The following sections discuss each of these options.

**Calculate Derivatives**

The JMP Formula Editor can find and display the derivative of a function. The derivative is found with respect to the function argument (a single variable name) you highlight. Therefore, in order to differentiate with respect to $x$, $x$ must be one of the arguments in the expression. The red triangle menu found above the keypad contains the *Derivative* command.

*To calculate a derivative:*

1. Enter a function.
2. Highlight a variable.
3. Select *Derivative* from the menu. Figure 7.6 shows the completion of these steps.
Use Formula Editor Options

Figure 7.6 Using the Derivative Option

Simplify Complex Formulas

When the Formula Editor contains a complex formula, JMP can simplify it using various algebraic rules. It can find constant expressions, distribute multiplication over addition, combine terms, and more.

To simplify complex formulas:
1. Select a portion or all of the formula.
2. Click the red triangle menu above the keypad.
3. Select Simplify from the menu that appears, as shown in Figure 7.7.

Figure 7.7 Selecting Simplify (Left) Produces a Simplified Formula (Right)

Evaluate Formulas

By default, JMP evaluates each formula that you create. You can turn this evaluation off, or you can use it before you have finished creating a formula.
Suppress Evaluation

Turning off evaluation is a useful formula development mode for building complex formulas. You can turn off evaluation and build sections of a formula, and evaluate only to test it. In particular, you can close the Formula Editor and reopen it at a later time to continue building a formula without JMP evaluating it.

To suppress formula evaluation, click the red triangle menu above the keypad and select Suppress Eval. When evaluation is suppressed, the formula icon appears dimmed 🅺.

Note the following:

- If the icon appears to the right of the red triangle menu in the Formula Editor, it indicates that formula evaluation is suppressed for that formula.
- If the icon appears beside the column name in the Columns panel, it indicates that the values in the column result from a formula. When formula evaluation is suppressed, this plus icon becomes gray. (For details, see “Icons Representing Column Characteristics and Properties” on page 43 in the “Get Started” chapter.)

Note: The Apply button ignores the formula evaluation setting. Therefore, when formula evaluation is suppressed, clicking the Apply button overrides the suppression and evaluates the formula before it is applied to the column.

Ignore Errors

Once you construct a formula and click OK, JMP checks behind the formula for error and alerts you of any errors that it finds. An error message appears for each error and asks whether you want to ignore further errors.

Sometimes you might want to suppress error messages while a formula is under development. For example, you might want the evaluated values for some rows without seeing an error message for each row that causes errors.

To have JMP ignore any errors:
1. Create a formula.
2. Click the red triangle menu above the keypad and select Ignore Errors.

View a Formula’s Values from the Formula Editor

While in the Formula Editor, you can see the value of any expression within a formula with the Evaluate command. For column variables, you get the value at row 1. This is also true for parameters and expressions that evaluate to a constant value. To view values:

1. While in the Formula Editor, select the expression that you want to know about.
2. Right-click the selected expression.
3. Select Evaluate. The current value of the selected expression appears in a box until you move the cursor.

View a Formula in JSL

You have the option of entering or changing any part of a formula in text mode. Text mode displays the formula in JMP Scripting Language (JSL). The entire formula (or any of its terms) appears in text mode when you double-click the white space inside the boxed formula area. The elements of that box appear as plain text and you can then edit the formula as you would in any text editor.

Any element of a formula can be displayed as a scripting command and then edited. After editing formula scripting commands, click outside the formula to see its formatted form. For example, the text for the standardization of weight is (:weight – Col Mean(:weight)) / Col Std Dev(:weight). To enter an If statement in text form, add pairs of arguments for each If/Then clause in the statement, and a single last argument for the else clause if needed. In text form, the If statement in Figure 7.8 looks like this: If(:total!=0, (:count/:total)*100, 0).

Figure 7.8 An If Statement in Formula Mode

Edit Formulas

If you need to change a formula after you have exited the Formula Editor, right-click the column name in the data table and select Formula.

Correct Mistakes

If you make a mistake while entering a formula, hold down the CTRL key and press Z. This reverses the effect of the last (undo-able) command.

Other commands to help modify formulas include the following:

- Click the delete button ( ) on the Formula Editor keypad to remove the selected expression.
- Use the cut, copy, and paste keyboard shortcut commands or right-click a highlighted part of the formula and select Cut, Copy, or Paste from the menu.
• To rearrange terms or expressions, click to see the hand 🤓 grab the term. Drag to move formula pieces.

Select Expressions

Use the keyboard arrow keys to select expressions for editing. You can also use the arrow keys to view the formula’s order of precedence when either parentheses or the boxing option are not present. (See “Hide and Show Boxing” on page 255.)

Clicking an operator (+, −, *, ÷) in an expression selects the operator and its operands. A red box appears around the items. Once an operator is selected:

• The left and right arrow keys move the selection across other associative operators having equal precedence within the expression.
• The up arrow extends the current selection by adding the operand and operator of higher precedence to the selection.
• The down arrow reduces the current selection by removing an operand and operator from the selection.

Delete Functions

Deleting a function also deletes its arguments. Deleting a required argument or missing term from a function sometimes deletes the function as well. You can peel a function to delete it from its argument.

To peel a function from a single argument:
1. Select the function.
2. Click the peel button 🧩 in the Formula Editor keypad. Or, use the hand tool to drag the argument on top of its function.

Figure 7.9 Peeling an Argument

3. Complete formula changes.
4. Click Apply, and the new values fill the data table column automatically.
5. Once you have created a formula, you can change values in columns that are referenced by your formula. JMP automatically recalculates all affected values in the formula’s column.
Cut, Copy, and Paste

You can cut or copy any expression or an entire formula and paste it into another formula display. Use the cut, copy, and paste shortcut commands or right-click a highlighted part of the formula and select Cut, Copy, or Paste from the menu. The following aspects apply when you cut, copy, and paste a formula:

- When you paste it into another formula display, the formula appears in formatted form.
- The formula is saved on the clipboard as a JSL statement. Thus, if you copy it into other applications, it appears as a JMP Scripting Language (JSL) statement.

Note: Press the SHIFT key on your keyboard, and then click the red triangle to reveal a command called Copy As SAS Formula.

Click and Drag

You can drag any part of a formula that can be selected to any other location that can be selected.

To click and drag:
1. Place the arrow cursor inside an expression.
2. Click the expression. It is highlighted and the cursor changes to a hand cursor.
3. Drag across the formula. Destination expressions are highlighted.
4. Drag the selected expression to the new desired location. The selected expression is copied to the new location, where it replaces the existing expression.

Customize Formulas

There are several ways that you can customize formulas in the Formula Editor. The following sections describe how to change font size, show and hide boxing, change the orientation of the formula, and close arguments.

Change the Font Size

To incrementally increase or decrease the font used to display the formatted formula:
1. Click the red triangle menu above the keypad.
2. Select Larger Font or Smaller Font.
3. Repeat this process to further increase or decrease the font size.
Hide and Show Boxing

By default, JMP outlines specific terms within the formula. This is called boxing. Boxing is useful when you want to select and modify a specific portion of a formula, or need to determine the order of evaluation that takes place.

To turn boxing on or off:

1. Build a formula.
2. Click the red triangle menu above the keypad and select Show Boxing. When a check appears on the menu beside Show Boxing, the outline appears in the formula. When it does not, the outline does not appear.

Change a Formula’s Orientation

By default, JMP gauges the size of a formula and displays it in the Formula Editor in the best orientation (horizontally or vertically). However, if you create a long formula, you might want to display it in a different layout.

To change a formula’s orientation:

1. Build a formula.
2. Highlight an argument or formula.
3. Right-click what you have highlighted.
4. Select Orientation.
5. Select from the Orientation options: Best, Horizontal, or Vertical.

Open and Close Arguments

When a formula is too large to fit on the screen, you can close formulas and arguments.

To close an argument:

1. Build a formula.
2. Highlight an argument or formula.
3. Right-click what you have highlighted.
4. Select Close or Close Arguments from the menu that appears.
Examples and Tutorials

To better familiarize yourself with building formulas, review the following examples and tutorials.

Use Basic Formula Editor Features

The following example uses the Big Class.jmp sample data table to walk you through using the basic features of the Formula Editor. You can find Big Class.jmp in the sample data folder, which was installed when you installed JMP.

Big Class.jmp has a column called weight. Suppose you want a new column that computes standardized weight values.

To create this column using a formula to obtain its values:

1. Open Big Class.jmp.
2. Select Cols > New Column.
3. Type the new name, Standard Weight, in the box beside Column Name.
4. Select Formula from the Column Properties menu.
5. Click the empty formula element in the formula editing area to select it.
   When you create a formula and Show Boxing is checked, the selected portion of the formula is outlined with a thin red line. See “Hide and Show Boxing” on page 255. All terms within the smallest nesting box relative to the place that you clicked become selected, and the subsequent action applies to those combined elements.

Next, enter the formula that standardizes the weight values.

1. While the initial missing term is selected, click weight in the formula element browser column selector list.
2. Click the minus button \(-\) in the Formula Editor keypad.
   A new missing term appears after the minus sign as shown in Figure 7.10.
3. Click weight again.
4. Click the function browser menu, and select Statistical.
5. Select Col Mean from the Statistical list.
6. Select the entire expression.
   The red box should now enclose the whole formula.
7. Click the division button \(\div\) in the keypad.
   The result gives a selected missing denominator for the whole expression.
8. Click weight again from the column selector list.
It becomes selected in the denominator.

9. Select Col Std Dev from the Statistical list.

The completed formula should look like that in Figure 7.10.

**Figure 7.10 Building a Formula**

![Building a Formula](image)

10. Close the Formula Editor by clicking OK.

11. Close the Column Info window by clicking OK.

In the data table, the new Standard Weight column fills with values. When a weight value changes, the calculated Standard Weight value automatically recalculates.

**Use Local Variables in a Formula**

Suppose you want to compute the slope in a simple linear regression of $y$ on $x$ using the standard formula shown in Figure 7.11. One way to do this is to create two local variables, and name them XY and Xsqr. (See “Use Local Variables” on page 239.) Then assign them to the numerator and the denominator calculations of the slope formula. Delimit each assignment with a semicolon, as shown in Figure 7.11. (Statements in the Formula Editor are actually JSL programming statements. Multiple statements in a formula must be separated by a semicolons.) The slope computation is simplified to XY divided by Xsqr.
Note: You can also create local variables using the button on the on-screen keypad. Clicking this button creates a local variable with a default name in an expression and places a semicolon after it. The default name is $t1$, and additional local variables are named $t2$, $t3$, and so on. You can change these default names by double-clicking and editing the name. However, you must be careful to rename each instance of the variable to avoid errors.

Use the Munger Function

The following examples show uses of the Munger function. In these examples, assume that there is a character column of names with “Veronica Layman” as one of its values. To simplify the examples, the literal name “Veronica Layman” is the search string instead of a column name.

For instructions on how to incorporate Character functions, such as Munger, into a formula, see “Character Functions” on page 449 in the “Formula Functions Reference” appendix.

Insert Characters

This Munger example finds the blank between the first and last name, and inserts the middle initial “J.” The formula Munger(“Veronica Layman”, 1, “”, “ J.”) inserts the middle initial J., and evaluates as Veronica J. Layman.

Double quotes are required by the Munger function for literal strings, including strings that consist of a blank or when leading or trailing blanks are part of a string.

Delete Characters

To delete one or more characters from a string:

1. Designate the characters to delete as the Find string in the Munger function.
2. Enter an empty Replace string; two quotation marks with nothing between them.

For example, the function, Munger(“Veronica Layman”, 1, "onic", "") removes the “onic” from Veronica and evaluates as Vera Layman.
### Chapter 7

### Formula Editor

**Note:** A Replace field with a null (no value) string enclosed in quotation marks is different from a Replace field with no value. If you delete the Replace string altogether, Munger shows the argument name (“Replace”) in the Formula Editor window and behaves as if that optional argument does not exist. The resulting data type can also change from character to numeric, depending on the value of the **Find/Length** argument.

---

#### Find the Position (Index) of a Value

When the **Find/Length** field contains characters, Munger behaves like an index function and returns the numeric position of the first instance of the search string if it exists. For example, Munger("Veronica Layman", 1, " ") searches for a single blank and finds it in position nine. If the search string is not found, Munger returns a zero. This use of Munger produces the same result as the **Contains** function, as shown in “Character Functions” on page 449 in the “Formula Functions Reference” appendix.

#### Find a Substring

Munger can extract substrings. For example, to extract only the first name, Munger("Veronica Layman", 1, 8,) starts at position one and reads through position eight. The remaining characters are ignored because the replace argument is not defined. This yields “Veronica” and produces the same result as the **Substring**, as shown in “Character Functions” on page 449 in the “Formula Functions Reference” appendix.

An alternative way to find a substring is with a start value, any negative find value, and a no replace argument. Munger("Veronica Layman", 9, –1,) returns “Layman”.

#### Use the Match Conditional Function

This example walks you through using the Match conditional function.

Suppose that you want a **Match** conditional for the nominal variable Type from the Hot Dogs.jmp sample data table.

1. In the Formula Editor, select Type from the **Table Columns** list.
2. Select **Conditional** from the Functions list.
3. Select **Match**.
4. Select **Add Arguments from Data**.

The values are automatically filled in. See Figure 7.12.

**Note:** Rather than complete step 2 through step 4, hold down the SHIFT key, select **Conditional** from the Functions list, and then select **Match**.
If you do not want the values filled in for you, select **Do Not Add** from the **Match** list instead of **Add Arguments from Data**.

### Use the Delete Expression Key

Repeated clicks on the delete expression key produce the following sequence of steps.

1. Start with a formula.

2. Select a formula element.

3. Click the delete expression button ( ).

4. Click the delete expression again.

5. Click the delete expression again.

6. Click the delete expression again.

7. Click the delete expression again.

8. Click the delete expression again.

9. Click the delete expression again.
Keyboard Shortcuts

Table 7.4 describes the keyboard shortcuts that you can use in the Formula Editor.

<table>
<thead>
<tr>
<th>Insert This Item</th>
<th>Using This Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>A missing element (•)</td>
<td>DELETE</td>
</tr>
<tr>
<td>Subscript</td>
<td>[</td>
</tr>
<tr>
<td>() set of parentheses</td>
<td>(</td>
</tr>
<tr>
<td>* (multiplication symbol)</td>
<td>* on keypad or keyboard</td>
</tr>
<tr>
<td>+</td>
<td>+ on keypad or keyboard</td>
</tr>
<tr>
<td>–</td>
<td>– on keypad or keyboard</td>
</tr>
<tr>
<td>÷</td>
<td>/ on keypad or keyboard</td>
</tr>
<tr>
<td>+/-</td>
<td>Hold down the SHIFT key and press the - (MINUS) key</td>
</tr>
<tr>
<td>And</td>
<td>&amp;</td>
</tr>
<tr>
<td>Not</td>
<td>!</td>
</tr>
<tr>
<td>Or</td>
<td></td>
</tr>
<tr>
<td>Power</td>
<td>^</td>
</tr>
<tr>
<td>New argument</td>
<td>,</td>
</tr>
<tr>
<td>x&lt;y</td>
<td>&lt;</td>
</tr>
<tr>
<td>x==y</td>
<td>=</td>
</tr>
<tr>
<td>x&gt;y</td>
<td>&gt;</td>
</tr>
</tbody>
</table>

Glossary of Terms

Remember that:

- Functions always operate on selected expressions.
- Arguments are always grouped with functions.
• To find which expressions serve as a function’s arguments, select that function in the formula.

• The boxed groupings show how order-of-precedence rules apply and show which arguments are deleted when you delete a function. See “Order Expressions in Formulas” on page 247, for details.

Table 7.5 contains terms used for the parts of the formula itself.

Table 7.5  Terms Used in the Formula Editor

<table>
<thead>
<tr>
<th>Element</th>
<th>The name of a constant, table variable, table column, local variable, or parameter that appears in the element browser list.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Argument</td>
<td>Any element or an entire expression (including mathematical operands) that is operated on by a function.</td>
</tr>
<tr>
<td>Term</td>
<td>Indivisible parts of an expression, such as constants and variables.</td>
</tr>
<tr>
<td>Expression</td>
<td>Any part of a formula that can be selected as a single unit, including terms, missing terms, and functions grouped with their arguments, as well as the entire formula.</td>
</tr>
<tr>
<td>Clause</td>
<td>A complete segment in a conditional function.</td>
</tr>
</tbody>
</table>
### Table 7.5 Terms Used in the Formula Editor (Continued)

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Function</td>
<td>A mathematical or logical operation that performs a specific action on one or more arguments. Functions include most items in the function browser list and all keypad operators. Functions always operate upon selected expressions, and arguments are always grouped with functions. To find which expressions serve as a function's arguments, select that function in the formula. The boxed groupings also show how order-of-precedence rules apply and show which arguments are deleted when you delete a function.</td>
</tr>
<tr>
<td>Missing term</td>
<td>Any empty place holder for an expression, represented by an empty box.</td>
</tr>
<tr>
<td>Missing value</td>
<td>Excluded or null data consisting of the missing value mark (♦) for numeric data or null character strings for character data.</td>
</tr>
</tbody>
</table>
This chapter describes how to create a summary data table, which includes summary statistics such as the mean and median, standard deviation, and minimum and maximum values.

**Figure 8.1 Summary Table for Companies.jmp**

<table>
<thead>
<tr>
<th>Size Co</th>
<th>N Rows</th>
<th>Mean(profit temp, Computer)</th>
<th>Mean(profit temp, Pharmaceutical)</th>
</tr>
</thead>
<tbody>
<tr>
<td>big</td>
<td>9</td>
<td>45.39.478</td>
<td>174,40.9,99</td>
</tr>
<tr>
<td>medium</td>
<td>7</td>
<td>-3462.568</td>
<td>2,40,51,15</td>
</tr>
<tr>
<td>small</td>
<td>18</td>
<td>7958.815</td>
<td>30337.161</td>
</tr>
</tbody>
</table>
Contents

Summarize Columns ................................................................. 267
Create a Summary Table .............................................................. 267
Add a Statistics Column to an Existing Summary Table ..................... 271
Explanation of Statistics .............................................................. 272
Example of Creating a Summary Table ........................................... 274
Summarize Columns

The **Tables > Summary** command calculates various summary statistics, including the mean and median, standard deviation, minimum and maximum value, and so on.

In a summary table:

- A single row exists for each level of a grouping variable that you specify. If no grouping variable is specified, a single row exists for the full data table.
- When there are several grouping variables, the table contains rows for each combination of levels of all the grouping variables.
- In addition to one column for each grouping variable, the table contains frequency counts in a column named `N Rows` with counts for each grouping level.
- The summary table can be linked to its source table. When you select rows in the summary table, the corresponding rows are highlighted in its source table.
- If the source table’s column(s) contain value labels, the value labels are displayed in the new table.
- A summary table is not saved when you close it unless you select **File > Save As** to give it a name and location.

Create a Summary Table

To create a summary table:

1. Open a data table.
2. Select **Tables > Summary**. The window in Figure 8.2 appears.
3. Highlight the columns that you want to summarize.

**Note:** For details about the options in the red triangle menu, see “Columns Filter Menu” on page 280 in the “JMP Platforms” chapter.
4. Add summary statistics, groups, subgroups, and select any options needed:
   - “Add Summary Statistics” on page 268
   - “Use One or More Grouping Columns” on page 269
   - “Use Quantile Statistics” on page 270
   - “Change the Format of the Statistics Column Name” on page 270
   - “Link to the Original Data Table” on page 270
   - “Keep the Summary Window Open” on page 271
   - “Create a Two-Way Table of Summary Statistics by Adding a Subgroup Variable” on page 271
5. Name the summary table by typing a name in the box beside **Output table name**.
6. Click **OK**.

**Add Summary Statistics**

You can add columns that display summary statistics (such as mean, standard deviation, median, and so on) for any numeric column in the source table.

1. In the Summary window, highlight the column that you want to use in calculating the statistics.
2. Click the **Statistics** button.
3. Select one of the standard univariate descriptive statistics from the **Statistics** drop-down menu. The statistics are described in “Explanation of Statistics” on page 272.

### Use One or More Grouping Columns

If you want the statistics summarized by group, highlight the column(s) that you want to be your grouping variables and click **Group** to move the variable into the grouping variables list. See “Example of Creating a Summary Table” on page 274, for an example. If you add only grouping variables, the summary table shows a count for each group.

To change the order of the grouping variables:

To change the order of the grouping variables (ascending or descending order), select a variable in the grouping variable list and click the ascending or descending button (▲ ▼). The icon beside the variable changes to indicate the sorting order.

You can also change the order of the grouping variables using the Value Ordering column property. See “Value Ordering” on page 181 in the “Set Column Properties” chapter.

To include marginal statistics:

To add marginal statistics (for the grouping variables) to the output columns, click the box beside **Include marginal statistics**. In addition to adding marginal statistics for each grouping variable, JMP adds rows at the end of the table that summarize each level of the first grouping variable. For example, proceed as follows:

1. Open the Companies.jmp sample data table.
2. Select **Tables > Summary**.
3. Select **Profits (M)** and click **Statistics**.
4. Select **Mean**.
5. Select **Type** and **Size Co** and click **Group**.
6. Select **Include marginal statistics**.
7. Click **OK** (or **Create**). See Figure 8.3 at left.

#### Figure 8.3 Summary Table with and without Marginal Statistics

<table>
<thead>
<tr>
<th></th>
<th>MeanProfit (&lt;)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1,689.83</td>
</tr>
<tr>
<td>2</td>
<td>85.75</td>
</tr>
<tr>
<td>3</td>
<td>44.94</td>
</tr>
<tr>
<td>4</td>
<td>240.87</td>
</tr>
<tr>
<td>5</td>
<td>894.42</td>
</tr>
<tr>
<td>6</td>
<td>698.88</td>
</tr>
<tr>
<td>7</td>
<td>155.85</td>
</tr>
<tr>
<td>8</td>
<td>809.68</td>
</tr>
<tr>
<td>9</td>
<td>409.32</td>
</tr>
</tbody>
</table>
Summarize Data

Summarize Columns Using JMP

Compare the summary table with marginal statistics (at left) to the summary table without marginal statistics (at right). You can see that the marginal statistics are added, and a row showing that there are 32 total Computer and Pharmaceutical companies.

Use Quantile Statistics

To add specific quantile statistics, follow these steps:

1. In the box under **For quantile statistics, enter value (%)** type the desired quantile value (%) for the first quantile (for example, 25).
2. Select the applicable column and click **Statistics**.
3. Select **Quantiles**.
4. (Optional) Repeat this process for any additional quantiles.

Change the Format of the Statistics Column Name

To change the format of the statistics column name in the summary table, select from one of the formats in the **statistics column name format** menu. Table 8.1 illustrates the available options. Assume that you are creating a summary table of the mean profits for a company. Your original column name is **Profits ($M)**.

<table>
<thead>
<tr>
<th>Option</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>stat (column)</td>
<td>Mean (Profits ($M))</td>
</tr>
<tr>
<td>column</td>
<td>Profits ($M)</td>
</tr>
<tr>
<td>stat of column</td>
<td>Mean of Profits ($M)</td>
</tr>
<tr>
<td>column stat</td>
<td>Profits ($M) Mean</td>
</tr>
</tbody>
</table>

Link to the Original Data Table

You can select whether to link the summary table to the original data table. By default, the **Link to original data table** option is selected. If you want to edit the data in the summary table, deselect the **Link to original data table** option. When the summary table is linked to the original data table, you cannot edit the data in the summary table, since that would modify and compromise the original data.

Within linked tables, if you drag columns from the summary table into the column heading of a new column in the original data table, the values are expanded as if they were matched by grouping columns.
Keep the Summary Window Open

If you select the Keep dialog open option, the Summary window remains open after you click Create. Notice that once you select this option, the OK button is replaced by a Create button.

Create a Two-Way Table of Summary Statistics by Adding a Subgroup Variable

1. Highlight the column(s) that you want to be the nested variable(s). These are your “subgroup variable(s).”
2. Click Subgroup to move the variable(s) into the subgroup list.
3. Highlight the column for which you want statistics summarized by subgroup.
4. In the Statistics list, select the specific statistic that you want.
5. Click OK.

For details about the types of statistics, see “Explanation of Statistics” on page 272.

Add a Statistics Column to an Existing Summary Table

After you have created a summary table, you can add columns of descriptive summary statistics for any numeric column in the source table. To do so, from an existing summary table, click on the upper red triangle in the data grid and select Add Statistics Column.

Example of Adding a Statistics Column to an Existing Table

Suppose that you have already created a summary table, and you want to add more statistics to the existing summary table.

1. Open the Companies.jmp sample data table.
2. Select Tables > Summary.
3. Select Type and Size Co and click Group.
4. Click OK.
5. From the red triangle menu in the upper left corner of the data table grid, select Add Statistics Column.
Figure 8.4 Creating a Summary Statistics Column from Within a Data Table

A modified version of the Summary window appears.

6. Select the column that you want, click **Statistics**, and select the specific statistic that you want. For this example, select **profit/emp** and click **Statistics**, and then select **Mean**.

7. Click **OK**.

Figure 8.5 Example of a Summary Table with a Summary Statistics Column

The Mean(profit/emp) column is added to the existing summary table.

**Explanation of Statistics**

You can add columns of descriptive summary statistics for any numeric column in the source table by clicking the **Statistics** button (Figure 8.6) and making a selection from the menu.
The **Statistics** menu gives these summary statistics for numeric columns:

- **N**  Is the number of nonmissing values.
- **Mean**  Is the arithmetic mean of a column’s values. It is the sum of nonmissing values (and if defined, multiplied by the *weight* variable) divided by the **Sum Wgt**.
- **Std Dev**  Is the sample standard deviation, computed for the nonmissing values. It is the square root of the sample variance.
- **Min**  Is the smallest nonmissing value in a column.
- **Max**  Is the largest nonmissing value in a column.
- **Range**  Is the difference between **Max** and **Min**.
- **% of Total**  Is the percent of the total count for each group. Or, if you have so specified, the percent of nonmissing values of the column to the total count for each group.
- **N Missing**  Is the number of missing values.
- **N Categories**  Is the number of distinct categories.
- **Sum**  Is the sum of all values in a column.
- **Sum Wgt**  Is the sum of all weight values in a column. (See “Assign Column Properties” on page 178 in the “Set Column Properties” chapter.) Or, if no column is assigned the *weight* role, **Sum Wgt** is the total number of nonmissing values.
• **Variance**  Is the sample variance, computed for the nonmissing values. It is the sum of squared deviations from the mean, divided by the number of nonmissing values minus one.

• **Std Err**  Is the standard error of the mean. It is the standard deviation divided by the square root of N. If a column is assigned the role of weight, then the denominator is the square root of the sum of the weights.

• **CV** (Coefficient of Variation)  Is the measure of dispersion, which is the standard deviation divided by the mean multiplied by one hundred.

• **Median**  Is the 50th percentile, which is the value where half the data are below and half are above or equal to the 50th quantile (median).

• **Interquartile Range**  Is the difference between the third and first quartiles.

• **Quantiles**  Gives the value at which the specific percentage of the argument is less than or equal to. For example, 75% of the data is less than the 75th quantile. The summary window has an edit box for entering the quantile percentage that you want.

---

**Example of Creating a Summary Table**

Suppose a researcher is working with Companies.jmp, which groups companies by Type and Size. Follow along with this next example by opening Companies.jmp from the sample data folder that was installed when you installed JMP.

Suppose the researcher wants to:

• Create a table that shows the average profit per employee for small, medium, and big computer and pharmaceutical companies. In other words, create a table that contains a row for each size company and a column for the mean profit per employee of each type of company.

• Create it so the cells hold the mean for the subgroup (defined by the intersection of the row and column).

1. Open the Companies.jmp sample data table.
2. Select Tables > Summary.
   The researcher selects Size Co as the grouping variable because he wants the values in that column to become rows in the new table.
4. Select profit/emp and click Statistics.
5. Select Mean.
6. Select Type and click Subgroup.
   This tells JMP to create a column for the average profit per employee (Mean(profit/emp)) for each level (computer, pharmaceutical) of subgroup variable (type).
Figure 8.7 shows the completed Summary window and the resulting summary table.

**Figure 8.7 Summary Statistics for a Subgroup**

<table>
<thead>
<tr>
<th>Size Co</th>
<th>N Rows</th>
<th>Mean(profit, Computer)</th>
<th>Mean(profit, Pharmaceutical)</th>
</tr>
</thead>
<tbody>
<tr>
<td>big</td>
<td>9</td>
<td>4530.478</td>
<td>17140.699</td>
</tr>
<tr>
<td>medium</td>
<td>7</td>
<td>-2482.505</td>
<td>24055.115</td>
</tr>
<tr>
<td>small</td>
<td>18</td>
<td>7958.815</td>
<td>30337.161</td>
</tr>
</tbody>
</table>
Summarize Data
Example of Creating a Summary Table
Most JMP platforms analyze and graph your data using launch windows and report windows. You specify your analysis in a launch window and your analysis and graphs appear in a report window. This chapter describes features that are common to all launch windows and reports.

**Figure 9.1** Example of a JMP Launch Window and Report Window
## Contents

- Launch Windows ................................................................. 279
- Virtual Columns ................................................................. 281
- Platforms that Support Multithreading .................................. 286
- Navigating Reports ................................................................. 287
  - Use the Hand Tool .......................................................... 288
  - Access Report Display Options ........................................ 288
  - Show and Hide Parts of a Report ....................................... 289
  - Combine Several Reports ................................................ 290
  - Increase Font Sizes .......................................................... 290
- How to Access Analysis Options ........................................... 291
- The Data Filter ................................................................. 296
- Format Report Tables ......................................................... 306
- Select Points in Plots .......................................................... 307
- Use Markers ................................................................. 309
- Alter Plot and Chart Appearances ......................................... 316
  - Resize Plots and Graphs .................................................. 316
  - Change Line Widths ...................................................... 318
  - Change the Background Color in a Graph ......................... 318
  - Change the Color of Histogram Bars ................................. 318
  - Display Coordinates and Temporary Reference Lines ........... 319
- Scroll and Scale Axes ......................................................... 319
- Customize Axes and Axis Labels .......................................... 320
- Change the Order of Values ................................................ 326
- Customize Tick Marks and Tick Mark Labels .......................... 326
- Add Reference Lines ........................................................... 329
- Add Geographical Images and Boundaries ............................. 329
- Drag and Drop an Image into a Graph ................................... 330
- Extract Data from an Image ................................................. 332
- Add Graphics Elements to a Report ..................................... 333
Launch Windows

The launch window is your point of entry into a platform. Table 9.1 describes three panels that all launch windows have in common.

Table 9.1 Launch Window Panels

<table>
<thead>
<tr>
<th>Panel</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select Columns</td>
<td>Lists all of the variables in your current data table. Note the following:</td>
</tr>
<tr>
<td></td>
<td>• Right-click on a column name to change the modeling type.</td>
</tr>
<tr>
<td></td>
<td>• Filter the columns using the options in the red triangle menu. See “Columns Filter Menu” on page 280.</td>
</tr>
<tr>
<td>Cast Selected Columns into Roles</td>
<td>Moves selected columns into roles (such as Y, X, and so on.) You cast a column into the role of a variable (like an actor is cast into a role). See “Cast Selected Columns into Roles Buttons” on page 279.</td>
</tr>
<tr>
<td></td>
<td>This panel does not exist in the Graph Builder platform.</td>
</tr>
<tr>
<td>Action</td>
<td>OK performs the analysis.</td>
</tr>
<tr>
<td></td>
<td>Cancel stops the analysis and quits the launch window.</td>
</tr>
<tr>
<td></td>
<td>Remove deletes any selected variables from a role.</td>
</tr>
<tr>
<td></td>
<td>Recall populates the launch window with the last analysis that you performed.</td>
</tr>
<tr>
<td></td>
<td>Help takes you to the Help for the launch window.</td>
</tr>
</tbody>
</table>

Cast Selected Columns into Roles Buttons

Table 9.2 describes buttons that appear frequently throughout launch windows. Buttons that are specific to certain platforms are described in the chapter for the specific platform.
Table 9.2 Descriptions of Role Buttons

<table>
<thead>
<tr>
<th>Role</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Y</td>
<td>Identifies a column as a response or dependent variable whose distribution is to be studied.</td>
</tr>
<tr>
<td>X</td>
<td>Identifies a column as an independent, classification, or explanatory variable that predicts the distribution of the Y variable.</td>
</tr>
<tr>
<td>Weight</td>
<td>Identifies the data table column whose variables assign weight (such as importance or influence) to the data.</td>
</tr>
<tr>
<td>Freq</td>
<td>Identifies the data table column whose values assign a frequency to each row. This option is useful when a frequency is assigned to each row in summarized data. If the value is 0 or a positive integer, then the value represents the frequencies or counts of observations for each row when there are multiple units recorded.</td>
</tr>
<tr>
<td>By</td>
<td>Identifies a column that creates a report consisting of separate analyses for each level of the variable.</td>
</tr>
</tbody>
</table>

Columns Filter Menu

A Column Filter menu appears in most of the launch windows. The Column Filter menu is a red triangle within the Select Columns panel. Use these options to sort columns, show or hide columns, or search columns.

Figure 9.2 The Columns Filter Menu

| Reset | Resets the columns to its original list. |
Virtual Columns

Each launch window in JMP allows you to create one or more temporary virtual columns for use in performing analyses. These virtual columns are not part of the source data table and can only be used within the context of the current launch window. Virtual columns use formulas or calculations to define the column values. Closing the launch window or the generated report deletes any virtual columns.

Each column listed in the Select Columns pane of the launch window includes an icon representing the column’s modeling type (continuous, ordinal, or nominal) and the column name. Right-click on a column name to create a virtual column using either Transform, Combine, Aggregate, Date, Row, or Formula to calculate the column’s values.
Right-click options depend on the selected column’s data type and number of columns selected.

**Figure 9.3** Example of Virtual Column Menu

Transform For continuous and ordinal data, creates a virtual column based on a selected transcendental calculation. See “Transform Menu” on page 283.

Combine For selected multiple continuous data, creates a virtual column based on the selected columns and calculation. See “Combine Menu” on page 283.

Aggregate For continuous and ordinal data, creates a virtual column based on the selected aggregate function. See “Aggregate Menu” on page 283.

Date For nominal data, creates a virtual column based on the selected date/time function. See “Date Time Menu” on page 284.

Row For continuous, nominal, and ordinal data, creates a virtual column based on the selected row function. See “Row Menu” on page 285.

Formula For continuous, nominal, and ordinal data, creates a virtual column containing the custom transform data based on the specified formula. See “Formula Menu” on page 285.

**Note:** The virtual column is only available in the current launch window. To make the virtual column available outside of the current launch window, right-click on the virtual column and select Add to Data Table. The virtual column is appended to the source data table.
Transform Menu

Select a function from the Transform menu to create a virtual column containing the calculations based on the selected function. For details on listed functions, see “Transcendental Functions” on page 445 in the “Formula Functions Reference” appendix and “Numeric Functions” on page 445 in the “Formula Functions Reference” appendix. Also refer to Fitting Linear Models for additional information.

Note: You can apply unary functions to multiple columns resulting in multiple virtual columns.

In addition to the functions described in the appendix, the following functions are included in the menu:

- **Square**  Calculates the square for the selected column values.
- **Pow10**  Calculates 10 raised to the power of the selected column values.
- **Cube**  Calculates the cube for the selected column values.
- **Reciprocal**  Calculates the reciprocal (1/column) for the selected column values.
- **Negation**  Calculates the negative for the selected column values.

Combine Menu

Select multiple columns to access the Combine menu. The Combine menu creates a virtual column containing the calculations based on the selected function. For details on listed functions, see “Statistical Functions” on page 476 in the “Formula Functions Reference” appendix.

In addition to the functions described in the appendix, the following functions are included in the menu:

- **Difference**  Calculates the difference between the first and second columns (A - B).
- **Difference (reverse order)**  Calculates the difference between the second and first columns (B - A).
- **Ratio**  Calculated the ratio of the first column to the second column (A / B).
- **Ratio (reverse order)**  Calculates the ratio of the second column to the first column (B / A).
- **Average**  Returns the average value of the selected columns.

Aggregate Menu

Select a function from the Aggregate menu to create a virtual column containing the statistics calculated from the selected column (or part of a column if you specified a Group By column). For details on listed functions, see “Statistical Functions” on page 476 in the “Formula Functions Reference” appendix.
Functions Reference” appendix.

**Note:** The **Group By** option is useful for these functions.

In addition to the functions described in the appendix, the following functions are included in the menu:

- **Count**  Calculates the number of values in the selected column.
- **Median**  Calculates the median value for the selected column

**Date Time Menu**

For column values containing date or time values, select a function from the **Date** menu to create a virtual column containing values calculated from the selected column. For details on listed functions, see “**Date Time Functions**” on page 484 in the “Formula Functions Reference” appendix.

In addition to the functions described in the appendix, the following functions are included in the menu:

- **Month Year**  Returns the month number and year for the date in the selected column.
- **Week**  Returns the number of the week in the year for the date in the selected column.
- **Year Quarter**  Returns the year and the year’s quarter (1, 2, 3, or 4) for the date in the selected column.
- **Year Week**  Returns a string representing the ISO-8601 week of year format (for example, June 12, 2013 results in “2013W24”).

**Character Menu**

Select a function from the **Character** menu to create a virtual column containing strings formed by the selected **Character** function. For details on listed functions, see “**Character Functions**” on page 449 in the “Formula Functions Reference” appendix.

In addition to the functions described in the appendix, the following functions are included in the menu:

- **Concatenate with Space**  Concatenates the strings in the selected column or columns into a new string with each sub-string separated by a whitespace.
- **Concatenate with Comma**  Concatenates the strings in the selected column or columns into a new string with each sub-string separated by a comma character.
- **First Word**  Extracts the first word from a character string in the selected column or columns.
- **Last Word**  Extracts the last word from a character string in the selected column or columns.
Row Menu

Select a function from the Row menu to create a virtual column containing calculations determined by the selected Row function. For details on listed functions, see “Row Functions” on page 443 in the “Formula Functions Reference” appendix and “Random Functions” on page 480 in the “Formula Functions Reference” appendix.

See the Scripting Guide book for details on Row functions.

In addition to the functions described in the appendix, the following functions are included in the menu:

**Difference**  Calculates the difference of each value in the selected column using the formula:

\[
\text{If}\left( \text{Row}() == 1 \Rightarrow ., \text{else} \Rightarrow \text{Diff}[\text{column name}] \right)
\]

**Note:** The Difference function also supports the Group By option.

**Cumulative Sum**  Calculates the cumulative sum for each value in the selected column using the formula:

\[
\text{If}\left( \text{Row}() == 1 \Rightarrow 0, \text{else} \Rightarrow \text{column name} + \text{Lag}() \right)
\]

**Note:** The Cumulative Sum function also supports the Group By option.

**Moving Average**  Calculates the exponentially weighted moving average, EWMA, (given a smoothing parameter in the range of 0 to 1.0) for each value in the selected column using the formula:

\[
\text{If}\left( \text{Row}() == 1 \Rightarrow \text{column name}, \text{else} \Rightarrow \text{column name} \times 0.25 + \text{Lag}() \times 0.75 \right)
\]

Formula Menu

Select Formula to create a virtual column using a formula. See “Create a Formula” on page 237 in the “Formula Editor” chapter for details on creating and editing a formula.

**Note:** JMP evaluates the formula entered on-demand therefore complex formulas may require a lot of processing time.
Virtual Column Options

After creating a virtual column, you can perform the following actions:

- **Rename**  Renames the virtual column.
- **Add to Data Table**  Adds the virtual column to the data table as a formula column.
- **Remove Transform Column**  Removes the virtual column from the launch window.
- **Group By**  Specifies the column to use for grouping data analysis (that is, all analyses are performed separately for each level of the specified column).

Platforms that Support Multithreading

Some platforms in JMP are coded to take advantage of multiple CPU’s on a machine, allowing these platforms to run significantly faster. This process is called multithreading.

As of JMP 11, the following platforms support multithreading:

- Choice
- Distribution
- Factor Analysis
- Fit Life by X
- Fit Model: Parametric Survival, Mixed Model, Generalized Regression, and Response Screening
- Life Distribution
- Multivariate
- Neural
- Nominal Logistic
- Nonlinear and Nonlinear Curve
- Partial Least Squares
- Partition
- Principal Components
- Profiler (does not apply to Profilers launched from within other platforms)
- Reliability Forecast
Navigating Reports

JMP reports are displayed in standard windows with scroll bars and options to resize. They also have other special buttons and menus like those illustrated in Figure 9.4 and those discussed in the following sections.

Figure 9.4 Basics of the Report Window

Table 9.3 Report Window Actions

<table>
<thead>
<tr>
<th>Number</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Click on the disclosure buttons to hide or show sections of the report.</td>
</tr>
<tr>
<td>2</td>
<td>Click on the red triangle menus to access report options.</td>
</tr>
<tr>
<td>3</td>
<td>Right-click in the table to access formatting options.</td>
</tr>
<tr>
<td>4</td>
<td>Click and drag on the borders to resize graphs.</td>
</tr>
<tr>
<td>5</td>
<td>Right-click anywhere in the graph to access formatting options.</td>
</tr>
<tr>
<td>6</td>
<td>Right-click within the axis to access formatting options.</td>
</tr>
<tr>
<td>7</td>
<td>The arrow cursor turns into a hand when you hover over an axis. Click and drag using to scroll along the axis or to rescale the axis. See “Scroll and Scale Axes” on page 319.</td>
</tr>
</tbody>
</table>
Use the Hand Tool

Select the hand tool using the Tools > Grabber option. There are many functions that you can use with the hand tool (also known as the grabber tool) in a report. Here are some examples of the way the hand behaves in graphs and plots:

- On histograms, for continuous variables, use the hand tool to change the number of bars or to shift the boundaries of the bars.
- In all report tables, use the hand tool to click and drag columns for rearranging.
- Use the hand tool to change the displayed range of axis values. See “Scroll and Scale Axes” on page 319.

Access Report Display Options

Right-click a disclosure button to show a menu that lets you rearrange the report and gives you control over report outline levels. The resulting menu has the following report formatting options:

- **Close** Closes (hides) that section of the report. This can also be accomplished by clicking the disclosure button.
- **Horizontal** if available, the option switches the outline of the report between a vertical and horizontal layout.
- **Open All Below** Opens all outline levels beneath the level where this command is selected, including that level.
- **Close All Below** Closes all outline levels beneath the level where this command is selected, including that level.
- **Open All Like This** Opens all of the same type of reports as the one that is present in the analysis window. If you analyze several variables at a time, you often want to open many of the same type of report tables all at once. You might also want to open all of the same type of report tables at once when you select multiple options on a single analysis.
- **Close All Like This** Closes all of the same type of reports as the one that is present in the analysis window.
- **Close Where No Outlines** Closes all parts of the report that do not have sublevels. This command is usually used at the top level of the report outline. It is a quick way to see a nesting structure overview of a report.
- **Append Item** Displays a submenu, which lists ways that you can add structural items to the report. Items include text, outline title bars, references to other JMP files and windows, a list of all open JMP files, and URLs.
Edit  Displays the submenu shown in Figure 9.5, which affect all reports at the outline level where they are used:

Select  Highlights all reports for that outline level.

Deselect  Deselects all selected reports for that outline level.

Journal  Duplicates the report in a separate window titled Journal so you can edit it or append other reports to it. See “JMP Journals” on page 360 in the “Save and Share Data” chapter.

Copy Picture  Copies the report to the clipboard. You can then open another application and paste it.

Page Break  Inserts a page break for printing purposes.

Show Tree Structure  Opens a window that shows the DisplayBoxes that make up the report. This is mainly used by JSL programmers who are manipulating or reading parts of the report. See the Display Trees chapter in the Scripting Guide book for details.

An alternative way to access these options is to hold down the ALT key and right-click the disclosure button . This displays a window, as shown in Figure 9.5, with check boxes for commands and options so that you can select multiple actions at the same time. You can also do the same for the menu under a red triangle menu.

Figure 9.5  Menu Items in a Window

Show and Hide Parts of a Report

JMP reports are organized in a hierarchical outline. Each level of the outline has a triangle-shaped disclosure button . Click the disclosure button to open and close that section of the report.
Combine Several Reports

Suppose that you perform multiple analyses and want to show all of the results (and the data table) in one window. You can select and combine the reports and the data table in several ways.

**Note:** Most JMP windows can be combined (reports, data tables, scripts, journals, etc.) Look for the empty check box in the lower right corner of each window.

On Windows:

- Right-click the windows that you want to combine in the Home Window or Window List and then select **Combine**.
- Select the check box in the lower right corner of the windows that you want to combine, then select **Combine selected windows** next to the check box. Or, select the corresponding commands in the **Window > Arrange** menu.

On Mac:

1. Select **Window > Combine Windows**.
2. Select the windows that you want to combine and click **OK**.

In the combined window, using the options in the Report red triangle menu, you can:

- Edit the existing layout in the Application Builder
- Save the script to a data table, journal, script window, or as an add-in.

**Rename a Title**

To rename a title in a report, double-click on any of the following titles:

- a title next to a red triangle menu
- a title next to a disclosure button
- a column title

**Increase Font Sizes**

On Windows, change the font size that JMP uses in reports and data tables by selecting **Window > Font Sizes**. Then choose from one of the submenu items:

- **Increase Font Size** Increases the font size. Select again to increase the font size again.
- **Decrease Font Size** Decreases the font size. Select again to decrease the font size again.
How to Access Analysis Options

Click the red triangle menu in a report to access a list of options that apply for that particular report. In addition to clicking the red triangle menu, you can also:

- Select multiple actions at the same time. Hold down the ALT key and click the red triangle menu. A panel of all commands and options appears with check boxes.
- Apply a command to all similar reports in the report window. Hold down the CTRL key and click the red triangle menu. For example, in a One-way analysis, if you hold down the CTRL key, click the icon, and select **Means/Anova/T Test**, an analysis of variance is performed for all One-way analyses in the active report window.

The red triangle options applicable to each platform in the **Analyze** and **Graph** menus are described in the following books:

- Basic Analysis
- Essential Graphing
- Multivariate Methods
- Fitting Linear Models
- Specialized Models
- Quality and Process Methods
- Reliability and Survival Methods

Script Menus

The red triangle menu at the top level of every JMP report contains a **Script** menu. Most of these options are the same throughout JMP. A few platforms add extra options that are described in the specific platform chapters. Table 9.4 lists the **Script** menu options that are common to all platforms.

<table>
<thead>
<tr>
<th><strong>Table 9.4 Description of Script Menu Options</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Redo Analysis</strong></td>
</tr>
<tr>
<td><strong>Relaunch Analysis</strong></td>
</tr>
<tr>
<td><strong>Automatic Recalc</strong></td>
</tr>
</tbody>
</table>
If you have specified a By variable in the platform launch window, the Script All By-Groups menu also appears. These options apply to the reports for all the levels of the By variable.

**Table 9.4** Description of Script Menu Options *(Continued)*

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy Script</td>
<td>Places the script that reproduces the report on the clipboard so that it can be pasted elsewhere.</td>
</tr>
<tr>
<td>Save Script to Data Table</td>
<td>Saves the script to the data table that was used to produce the report.</td>
</tr>
<tr>
<td>Save Script to Journal</td>
<td>Saves a button that runs the script in a journal. The script is added to the current journal.</td>
</tr>
<tr>
<td>Save Script to Script Window</td>
<td>Opens a script editor window and adds the script to it. If you have already saved a script to a script window, additional scripts are added to the bottom of the same script window.</td>
</tr>
<tr>
<td>Save Script to Report</td>
<td>Adds the script to the top of the report window.</td>
</tr>
<tr>
<td>Save Script for All Objects</td>
<td>If you have By groups or similar multiple reports, a script for each object is saved to the script window. Otherwise, this option is the same as Save Script to Script Window.</td>
</tr>
<tr>
<td>Save Script to Project</td>
<td>Saves the script in a project. If you have a project open that contains the report, the script is added to that project. If you do not have a project that contains the report, a new project is created and the script is added to it.</td>
</tr>
<tr>
<td>Data Table Window</td>
<td>Brings the corresponding data table used to create the report to the front.</td>
</tr>
<tr>
<td>Local Data Filter</td>
<td>If your data table contains row states and you do not want to affect them, use the Local Data Filter. The actions of this data filter are temporary and you can experiment with it. <strong>Note:</strong> Platforms that do not support the Automatic Recalc option also do not support the Local Data Filter option.</td>
</tr>
<tr>
<td>Column Switcher</td>
<td>Lets you interactively exchange one column for another on a graph. See “Column Switcher” on page 294.</td>
</tr>
</tbody>
</table>
Chapter 9
JMP Platforms

Using JMP How to Access Analysis Options

Automatic Recalc

The Automatic Recalc feature immediately reflects changes that you make to the data table in the corresponding report window. You can make any of the following data table changes:

- exclude or unexclude data table rows
- delete or add data table rows

This powerful feature immediately reflects these changes to the corresponding analyses, statistics, and graphs that are located in a report window.

To turn on Automatic Recalc for a report window, click on the platform red triangle menu and select Script > Automatic Recalc. To turn it off, deselect the same option. You can also turn on Automatic Recalc using JSL.

Note the following:

- By default, Automatic Recalc is turned off for platforms in the Analyze menu and turned on for platforms in the Graph menu. The exceptions are the Capability, Variability/Gauge Chart, and Control Chart > Run Chart platforms.
- For some platforms, the Automatic Recalc feature is not appropriate and therefore is not supported. These platforms include the following: DOE, Profilers, Choice, Partition, Nonlinear, Neural, Neural Net, Partial Least Squares, Fit Model (REML, GLM, Log

Table 9.5 Descriptions of Script All By-Groups Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Redo Analysis</td>
<td>If the values in the data table that was used to produce the reports have</td>
</tr>
<tr>
<td></td>
<td>changed, this option duplicates the analysis based on the new data and</td>
</tr>
<tr>
<td></td>
<td>produces new reports.</td>
</tr>
<tr>
<td>Relaunch Analysis</td>
<td>Opens the platform Launch window and recalls the settings used to create the</td>
</tr>
<tr>
<td></td>
<td>reports.</td>
</tr>
<tr>
<td>Copy Script</td>
<td>Places the script that reproduces the reports on the clipboard so that it</td>
</tr>
<tr>
<td></td>
<td>can be pasted elsewhere.</td>
</tr>
<tr>
<td>Save Script to Data Table</td>
<td>Saves the script to the data table that was used to produce the reports.</td>
</tr>
<tr>
<td>Save Script to Journal</td>
<td>Saves a button that runs the script in a journal. The script is added to</td>
</tr>
<tr>
<td></td>
<td>the current journal.</td>
</tr>
<tr>
<td>Save Script to Script Window</td>
<td>Opens a script editor window and adds the script to it. If you have</td>
</tr>
<tr>
<td></td>
<td>already saved a script to a script window, additional scripts are added to</td>
</tr>
<tr>
<td></td>
<td>the bottom of the same script window.</td>
</tr>
</tbody>
</table>

Automatic Recalc

The Automatic Recalc feature immediately reflects changes that you make to the data table in the corresponding report window. You can make any of the following data table changes:

- exclude or unexclude data table rows
- delete or add data table rows

This powerful feature immediately reflects these changes to the corresponding analyses, statistics, and graphs that are located in a report window.

To turn on Automatic Recalc for a report window, click on the platform red triangle menu and select Script > Automatic Recalc. To turn it off, deselect the same option. You can also turn on Automatic Recalc using JSL.

Note the following:

- By default, Automatic Recalc is turned off for platforms in the Analyze menu and turned on for platforms in the Graph menu. The exceptions are the Capability, Variability/Gauge Chart, and Control Chart > Run Chart platforms.
- For some platforms, the Automatic Recalc feature is not appropriate and therefore is not supported. These platforms include the following: DOE, Profilers, Choice, Partition, Nonlinear, Neural, Neural Net, Partial Least Squares, Fit Model (REML, GLM, Log

Table 9.5 Descriptions of Script All By-Groups Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Redo Analysis</td>
<td>If the values in the data table that was used to produce the reports have</td>
</tr>
<tr>
<td></td>
<td>changed, this option duplicates the analysis based on the new data and</td>
</tr>
<tr>
<td></td>
<td>produces new reports.</td>
</tr>
<tr>
<td>Relaunch Analysis</td>
<td>Opens the platform Launch window and recalls the settings used to create the</td>
</tr>
<tr>
<td></td>
<td>reports.</td>
</tr>
<tr>
<td>Copy Script</td>
<td>Places the script that reproduces the reports on the clipboard so that it</td>
</tr>
<tr>
<td></td>
<td>can be pasted elsewhere.</td>
</tr>
<tr>
<td>Save Script to Data Table</td>
<td>Saves the script to the data table that was used to produce the reports.</td>
</tr>
<tr>
<td>Save Script to Journal</td>
<td>Saves a button that runs the script in a journal. The script is added to</td>
</tr>
<tr>
<td></td>
<td>the current journal.</td>
</tr>
<tr>
<td>Save Script to Script Window</td>
<td>Opens a script editor window and adds the script to it. If you have</td>
</tr>
<tr>
<td></td>
<td>already saved a script to a script window, additional scripts are added to</td>
</tr>
<tr>
<td></td>
<td>the bottom of the same script window.</td>
</tr>
</tbody>
</table>
Variance), Gaussian Process, Item Analysis, Cox Proportional Hazard, and Control Charts (except Run Chart).

**Column Switcher**

Within a report, use the Column Switcher to quickly analyze different variables without having to recreate your analysis. To activate the Column Switcher, from a report window, click on the red triangle menu. Select **Script > Column Switcher**.

If you have multiple columns, use the buttons to animate the column switching or step through each column manually. Move the slider control to change the speed of the animation.

**Example of the Column Switcher**

You have data about nutrition information for candy bars. You want to examine different factors, to see which factors best predict calorie levels.

1. Open the **Candy Bars.jmp** sample data table.
2. Select **Graph > Graph Builder**.
3. Click **Total fat g** and drag to the **X** zone.
4. Click **Calories** and drag to the **Y** zone.
5. Click **Cholesterol g** and drag to the **Wrap** zone.
6. From the red triangle next to **Graph Builder**, select **Script > Column Switcher**.

Choose the column that you want to switch from:

7. Select **Cholesterol g** and click **OK**.

Choose the columns that you want to switch to:

8. Select **Saturated fat g**, **Cholesterol g**, **Sodium mg**, **Carbohydrate g**, **Dietary fiber g**, and **Sugars g** and click **OK**.
9. Click the **Play** button to cycle between the different factors. Use the slider to control the speed of the animation. Alternatively, you can step through each factor individually.

You can see that the relationship between calories and fat is relatively strong for each level of carbohydrate. Therefore, **Carbohydrate g** appears to be the best predictor of calorie levels.
The Data Filter

The Data Filter gives you a variety of ways to identify subsets of data. You can interactively select complex subsets of data, hide these subsets in plots, or exclude them from analyses.

1. Select Rows > Data Filter.

Tip: In addition to the main Data Filter, you can also launch a local Data Filter within a platform report. From the red triangle menu in a report, select Script > Local Data Filter.

Figure 9.7 Initial Data Filter Window

2. Select the columns that you want to use as filters, then click Add.

Note the following:

- To restore your current row states when the Data Filter window is closed, select the Save and restore current row states option.

- If you have a long list of columns, you can sort, show, hide, or search for columns in the list. Use the options in the Add Filter Columns red triangle menu.

- By default, the Data Filter window is attached to the data table. You can detach it temporarily or persistently, as follows:
  - Detach it temporarily by deseleting the Use Floating Window option from the Data Filter red triangle menu.
  - Detach it persistently by selecting File > Preferences > Tables and deseleting the Use a Floating Window for Data Filters option.
Types of Filter Columns

There are three types of filter columns, as follows:

- **Continuous columns**  Numeric columns whose modeling type is set to continuous. A continuous filter column is represented by a slider that spans the data range.

- **Categorical columns**  Nominal and ordinal columns. For each categorical column, the Data Filter generates a set of distinct categories. These categories can be displayed in different forms.

- **Multiple Response columns**  Character columns that have the Multiple Response column property assigned. Each data cell of the column generally consists of multiple categories, separated by some common separator, like a comma. Since each data cell can contain more than one category, multiple response columns have a richer set of filtering options.

**Note:** For categorical columns with value labels, if you want to include responses that are not present in the data, select the **Include Responses Not in Data** option from **File > Preferences > Tables**.

Filtering Modes

There are three modes of filtering: **Select**, **Show**, and **Include**. You can set and clear these modes using the corresponding check boxes in the Data Filter.

**Note:** The Select mode is not available for the local Data Filter.

- **Select**  Shows the selected rows in the data table in a highlighted state.
  
  You can turn off the automatic selection of this option using the **Data Filter Select Check** preference. See also “Changing the Row State in the Data Table After Making Data Filter Selections” on page 299.

- **Show**  Shows the unselected rows with the Hide icon ( ● ).
  
  You can turn on the automatic selection of this option using the **Data Filter Show Check** preference. For details about row states, see the “Set Column Properties” chapter on page 167.

- **Include**  Shows the unselected rows with the Exclude icon ( ☑ ).
  
  You can turn on the automatic selection of this option using the **Data Filter Include Check** preference. For details about row states, see the “Set Column Properties” chapter on page 167.

There are two additional options when filtering: **Auto clear** and **Conditional**. These options are available from the red triangle menu for the Data Filter. For more information, see “Red Triangle Options for the Data Filter” on page 300.
The Data Filter Control Panel

Once you have added columns in the initial window, the Data Filter control panel appears.

**Figure 9.8** Data Filter Control Panel

The main controls in the Data Filter include the following:

- **Clear**  Clear all selections that you have made on variables in the Data Filter window.
- **Start Over**  Closes the current Data Filter session and returns you to the original Data Filter window.
- **Favorites**  Saves your current data filter criteria as a favorite. Once you have created a favorite, selecting it resets the current conditions to the criteria in the favorite. You can also remove the favorite. To retain favorites once the current session ends, save the data filter script by selecting one of the **Script** options from the Data Filter red triangle menu.
- **Select, Show, and Include**  See “Filtering Modes” on page 297.
- **Inverse**  Inverts the current selection state of the rows in the data table.

**Note:** Only the rows in the data table are inverted, not the selection in the Data Filter. To invert the selection in the Data Filter, from the column’s red triangle menu, select **Invert Selection**.

- **AND**  The AND button opens the Add Filter Columns list. The *and* operator restricts the selection. You can add variables to the filter process at any time.
- **OR**  The OR button opens the OR Add Filter Columns list. The *or* operator extends the selection. You can add variables to the filter process at any time.
Changing the Row State in the Data Table After Making Data Filter Selections

If you modify a row state that you have set in the Data Filter and subsequently alter row states in the data table, or select points in a graph or plot, the selections in the Data Filter might not match the selections in the data table. The Data Filter contains a warning message that says: “Your selection was changed in another window”. The Reset Selection button appears. Clicking the Reset Selection button changes the data table selections back to reflect the selections in the Data Filter.

Example of Modifying Selections
1. Open the Big Class.jmp sample data table.
2. Select Analyze > Distribution.
4. Click OK.
5. Select Rows > Data Filter.
6. Select sex and click Add.
7. In the Data Filter control panel, select all of the males by clicking on the M block.

Figure 9.9 Rows Containing Males Highlighted in Data Table and Histograms
You can see that all of the rows containing males are highlighted in the data table and in the histograms. Now you decide that you only want to see the students who are age 12.

8. In the age histogram, select the bar representing age 12.

Now the selection does not match the Data Filter selection. A warning message and a **Reset selection** button appear in the Data Filter window.

**Figure 9.10** Data Filter Warning Message and Reset Button

---

**Red Triangle Options for the Data Filter**

The red triangle menu next to Data Filter contains the following options:

- **Auto clear** If you have more than one nominal or ordinal column selected in the Data Filter, this option clears any other selections prior to making a new selection. For example, using *Big Class.jmp*, suppose that you have the columns *sex* (nominal) and *age* (ordinal) in your Data Filter. If you have males (M) selected for sex, and you click on an age group, say age 12, your selection of males will be automatically cleared. This means that selecting age 12 is not conditional on selecting males. Conversely, if you turn off Auto clear, you can then select both males and age 12 at the same time. Auto clear is on by default.

- **Conditional** Limits the categories displayed for the unselected filter column. See “Conditional” on page 301.

- **Use Floating Window** Keeps the Data Filter window on top of its associated data table. If you do not want the Data Filter window to remain on top, deselect this option.

- **Animation** Sequentially highlights the values of a single variable in the data table. See “Animation” on page 302.

- **Show Subset** Creates a new data table that contains only the following:
  - The rows identified by the Data Filter.
  - The columns selected in the active data table. If no columns are selected, then all columns are included.

  This option is similar to the **Tables > Subset** command, only without subsetting options.

- **Save Where Clause** Builds a WHERE clause based on the value selections that you make
**Script**  Provides options for saving scripts. See “Save Your Analysis as a Script” on page 355 in the “Save and Share Data” chapter.

**Conditional**

For filter columns with hierarchy, you can use the **Conditional** option to filter what appears in the column lists. For example, you could filter by region so that only the states in the selected region appear in the list.

The following example illustrates how the **Conditional** option helps to show the subcategories clearly, without the extra categories that do not belong.

1. Open the Cities.jmp sample data table.
2. Select **Rows > Data Filter**.
3. In the Data Filter window, select city, State, and Region, and then click **Add**.

   The Data Filter window appears with a Region list and a State list.

4. Select **Conditional** from the Data Filter red triangle menu.
5. Select **MW** in the Region list.
6. Select **OH** from the State list.

   The cities that are in Ohio and in the Midwest region are selected in the data table. In the Data Filter window, only midwestern states appear in the State list, and only cities in Ohio appear in the cities list. See Figure 9.11.
Figure 9.11 Using the Conditional Option

The bracketed number in front of the column name indicates the order in which the column values were selected. In Figure 9.11, Region was selected first, so it has a [1] in front of the column name. State was selected second, so it has a [2] in front of the column name.

To clear the selections and reset the order of the hierarchy, click Clear.

Animation

The animation feature sequentially highlights the values of a single variable. The variable’s values highlight in the data table. However, patterns are more interesting if you first create a plot and then animate a variable using the Data Filter to see how it behaves on the plot.

To use the animation feature, from the red triangle menu next to Data Filter, select Animation. Then select the variable that you want to animate. The highlighted frame around the variable indicates which variable is selected for animation.

Figure 9.12 Animation Control Panel in the Data Filter
The Animation Control panel (Figure 9.12) contains the following controls:

- The middle button (play) starts and stops the animation. After you start the animation cycles, the button changes to a stop button (stop). By default the animation begins with the first value of the topmost variable.
- The backward arrow (go back) moves the animation backward one cycle. Click more than once to go backward more than one cycle.
- The forward arrow (go forward) moves the animation forward one cycle. Click more than once to go forward more than one cycle.
- The square button (hide control) hides the Animation Control section on the Data Filter Window. Select Animation from the menu on the Data Filter title bar again to see the Animation Control.

Use the slider to adjust the speed of the animation (slower to faster).

The Animate drop-down menu contains the following options:

- **Forward**  Highlights values from first to last.
- **Backward**  Highlights values from last to first.
- **Bounce**  Highlights forward and then backward repeatedly.

### Save WHERE Clause

Once you have filtered variable values in the Data Filter, that information can be expressed as a JMP WHERE clause. The WHERE clause is used in JSL (JMP Scripting Language) programs to identify specific rows of data for processing or analysis. The Data Filter builds a WHERE clause based on the value selections that you make.

The options in the Save Where Clause menu include the following:

- **Clipboard**  Creates a WHERE clause from the filter criteria and puts it on the clipboard.
- **Row State Column**  Creates a row state column in the data table that has a formula equivalent to the filter criteria.
- **Data Table**  Creates a WHERE clause from the filter criteria and saves it as a JSL command with the current data table in a table property called Filter.
- **Script Window**  Creates a WHERE clause from the filter criteria and appends it to the current script text window, or creates a new script if one does not exist already.
- **Journal**  Creates the WHERE clause from the filter criteria and appends it to the current journal, or creates a new journal if one does not already exist.

### Example of Saving a WHERE Clause

1. Open the Big Class jmp sample data table.
2. Select **Rows > Data Filter**.
3. Select age, sex, and height and click **Add**.

Select all females who are twelve and fourteen years old and whose height is between 56 and 60 inches:

4. Hold down the CTRL key and click on the 12 and 14 blocks and the F block.
5. Click on 51 and type 56.
6. Click on 70 and type 60.
7. From the red triangle menu next to Data Filter, select **Save Where Clause > to Script Window**.

The WHERE clause that is created from this example appears in a script window, as follows:

```plaintext
Select Where(
  (:age == 12 | :age == 14) & :sex == "F" & (:height >= 56 & :height <= 60)
);
```

**Red Triangle Options for Variables**

Some of the red triangle options for a variable can vary, depending upon the type of variable.

**Options for All Types of Variables**

The red triangle menu next to any type of variable contains the following generic options:

- **Delete**  
  Removes the variable from the Data Filter control panel.

- **Clear Selection**  
  Clears any selection in effect for that variable only.

- **Invert Selection**  
  Deselects any selected values, and selects all values previously not selected, for that variable only.

**Options for Continuous Variables**

For continuous variables, values appear in a range with a slider that you can adjust in one of the following ways:

- Click and drag the slider bar. You can drag from either end of the slider bar. The selected values appear above the slider bar.
- Click anywhere in the empty (not selected) part of the slider to set the filter range at that point.
- Click on the number to type in the value that you want.

By default, the range of values includes an equal sign, which includes the endpoints. You can remove the equal sign by holding down the SHIFT key and clicking on the ≤ or the ≥.
The **Select Missing** option highlights any missing values in the data table.

**Options for Nominal or Ordinal Variables**

For nominal and ordinal variables, values appear in blocks, in a list, or in a menu. If the variable contains only a small number of categories, the values appear in blocks. If the variable contains a large number of categories, the values appear in a list or in a menu. However, you can change these default settings.

The following options are available for nominal or ordinal variables only:

- **Display Options** Changes the appearance of the display. Options may include the following:
  - **Blocks Display** shows each level as a block.
  - **List Display** shows each level as a member of a list, followed by its frequency.
  - **Single Category Display** shows each level, followed by its frequency, in a menu.
  - **Check Box Display** adds a check box next to each value. To make this the default setting, select the **Data Filter Check Box Display** option in **File > Preferences > Tables**.

- **Order by Count** Orders the values in decreasing sort order by count.

- **Find** Provides a text box where you can type a search string for the selected column. Press the Return key to perform the search. Once Find is selected, the following Find options appear in the red triangle menu:
  - **Clear Find** clears the results of the Find operation and returns the window to its original state.
  - **Match Case** uses the case of the search string to return the correct results.
  - **Contains** searches the data for values that includes the search string.
  - **Does not contain** searches the data for values that do not include the search string.
  - **Starts with** searches the data for values that start with the search string.
  - **Ends with** searches the data for values that end with the search string.

**Options for Variables with the Multiple Response Property**

The following options are available for variables with the Multiple Response property set:

- **Match none of the checked items** Selects only rows containing values that do not match any of the selections.

- **Match any of the checked items** Selects all rows that contain values that match any of the checked values. By default, this option is selected.

- **Match all of the checked items** Selects only those rows with values that include all of the checked values.
Match exactly the checked items  Selects only those rows with values that exactly match the checked values.

Match only the checked items  Selects only those rows with contents exactly matching the checked values.

Note: For more details about the Multiple Response property, see the “Set Column Properties” chapter on page 167.

Format Report Tables

After running a table script there are many ways that you can format a report table to meet your needs. Right-click in a report table to access the following formatting options:

**Table Style**  adds borders and dividing lines to the table. Select from the following options:

- **Plain** contains no divider lines or borders.
- **Bordered** contains a border around the table and divider lines between columns.
- **Embossed** on Windows, adds a three-dimensional effect to the border and divider lines. On the Macintosh, changes the border from black to gray.
- **Beveled** on Windows, adds a three-dimensional effect and causes the corners of borders to be rounded instead of square. On the Macintosh, shades the table background gray.
- **Heading Separator** adds a thin line under the boldface table headings.

Note: You can also change the table style using the Report table style option in File > Preferences > Reports.

**Table Row Style**  adds or removes borders from the rows within a table.

**Columns**  shows or hides columns in the table.

Note: Columns whose names begin with a tilde (~), such as ~Bias, are not applicable to the analysis that you ran and do not appear in the table, even if you place checks next to their names.

**Sort by Column**  Sorts the columns in descending or ascending order by the selected column.

**Make into Data Table**  creates a JMP data table from the report table.

**Make Combined Data Table**  searches the report for other tables like the one you selected and combines them into a single data table.

**Make Into Matrix**  creates a JMP matrix from a report table. See “Turn a Report Table Into a Matrix” on page 307.
Bootstrap approximates the sampling distribution of a statistic. For more information, see the Basic Analysis book.

Turn a Report Table Into a Matrix

You can create a JMP matrix from a report table. For example, when working with JMP Scripting Language (JSL), you might want to access a report's table that has been stored into a JSL variable. Or, you might want to store a report table's values into a table property as either a table property or as a JSL assignment, which is stored within the data table and is accessible via a script or the Formula Editor.

To store a table in matrix form into a global variable, into a table property, or into a table property as an assignment:

1. Right-click anywhere in a report table.
2. Select Make into Matrix.
3. In the window that appears, tell JMP how you want to store the table.
4. (Optional) Rename the variable or property by typing a new name into the box beside Name.

Select Points in Plots

To select a point in a plot, click the point with the arrow cursor. This selects the point as well as the corresponding row in the current data table. To select multiple points, hold down the SHIFT key while you select points. A point's label appears when you place the cursor over the point with or without clicking.

Select Rows in Graphs

All graphs and plots that represent the same data table are linked to each other and to the corresponding data table. When you click points in plots or bars of a graph, the corresponding rows highlight in the data table. The example in Figure 9.13 shows a histogram with the SPEEDYTYPE bar highlighted, and the corresponding rows highlighted in the table. You can also extend the selection of bars in a histogram by holding down the SHIFT key and then making your selection.
Select Points in Plots Using JMP

Figure 9.13 Highlighting Rows In a Histogram

Select a Rectangular Area of Points

You can select all points that fall in a rectangular area using the arrow cursor. Click and drag the arrow to highlight points. Alternatively, you can use the brush tool. As you move the brush over the graph, points that fall within the rectangle are selected. Any points marked in the data table as hidden are not selected. See “Hide Rows and Columns” on page 156 in the “Enter and Edit Data” chapter.

To select points using the brush tool:

1. Click the brush tool in the toolbar.
2. Click and hold the cursor (now brush-shaped) in a plot. A rectangle appears.
3. Move the rectangle over points. As it passes over them, they appear larger and are highlighted both in the plot and in the active data table.

Note: To keep all points selected as you move the brush-shaped cursor over points, press the SHIFT key before you click in the plot.

Figure 9.14 Using the Brush Tool
4. Release the mouse. The points within the rectangle remain selected.

You can also use the brush tool to change the size of the selection rectangle. Hold down the ALT key before you click in the plot. This shape acts like a slicing tool that can traverse and highlight slices of points across either axis.

**Select an Irregular-Shaped Area of Points**

You can use the lasso tool to select points that fall in an irregular-shaped area. Any points marked in the data table as hidden are not selected. See “Hide Rows and Columns” on page 156 in the “Enter and Edit Data” chapter.

*To select points within an irregular-shaped area:*

1. Click the lasso tool in the toolbar.
2. Click and hold the cursor (now lasso-shaped) in a plot.

*Note:* To keep all points selected as you drag the lasso around several sets of points, press the SHIFT key before you click in the plot.

3. Drag the lasso around any set of points.

**Figure 9.15 Using the Lasso Tool**

4. Release the mouse. JMP automatically closes the lasso and highlights the points within the enclosed area.

**Use Markers**

Markers are points on a graph that represent data. Once they are changed from their default setting, they also appear next to rows in the data table. The following sections show you how to change marker shape, size, color, and so on.
Change Marker Shape

You can assign a character from the JMP markers palette to replace the standard points in scatterplots. These markers also appear next to row numbers in the data table.

1. Highlight one or more markers whose shape you would like to change.
2. Right-click anywhere in the graph. In a histogram, right-click the box plot area on the right.
3. Select Row Markers.
4. Select a marker shape from the options that appear, or click Custom to enter a character to use as a marker.

Change Marker Colors

You can assign any color to highlighted rows. When you do this, the points in scatterplots appear in the color that you select from the colors palette. The active color assigned to a row appears next to the row number in the data grid.

To change the color of markers (points) on a graph:

1. Highlight one or more markers whose color you would like to change.
2. Right-click anywhere in a graph. In a histogram, right-click the box plot area on the right.
3. Select Row Colors.
4. Select one of the colors, or click Custom to apply a custom color.

Change Marker Size

To increase or decrease the size of markers (points) on a graph:

1. Right-click anywhere in a graph. Hold down the CTRL key and right-click to broadcast the command and apply it to all plots of the same type located in the same window. In a histogram, right-click the box plot area on the right.
2. Select Marker Size.
3. Select one of the marker sizes listed. Preferred Size is the size that JMP estimates to be the best size for the graph.

Change the Marker Drawing Mode and Transparency

When working with a large number of markers on a graph, the markers can appear crowded. If this is the case, you might need to alter the transparency to gain a better view. Altering the transparency might also affect the marker drawing mode, which is the mode JMP uses when it
refreshes a report window. As it draws markers on a plot, it uses one of two speeds: normal or fast.

To change the marker drawing speed:
1. Right-click anywhere in a graph. In a histogram, right-click the box plot area on the right.
2. Select **Marker Drawing Mode**, and then select either **Normal** or **Fast**.

**Normal** If JMP is in normal drawing mode and the number of markers in a graph are more than the specified threshold number, JMP automatically switches to fast mode. See “Reports” on page 403 in the “JMP Preferences” chapter, for details about setting the marker threshold.

**Fast** Graphs displaying a large number of markers appear faster if you set the marker drawing speed to **Fast**. Note that when the drawing speed is set to **Fast**, marker size reverts to Preferred Size, and marker transparency settings revert to the default opaqueness.

**Outlined** see “Add Outlines Around Markers” on page 311.

### Add Outlines Around Markers

You can add a black outline, or frame, to markers in a plot. Outlined markers are available at the medium, larger, XL, XXL, and XXXL marker size. (See “Change Marker Size” on page 310, for details.)

To add outlines:
1. Right-click a plot or graph.
2. Select **Marker Drawing Mode**.
3. Select **Outlined**.

To use an outline effectively, it is best if your marker is a color other than black.

To change marker colors:
1. Highlight the markers whose color you want to change.
2. Right-click anywhere in the graph.
3. Select **Row Colors**.
4. Select a marker color from the options that appear.
**Marker Selection Modes**

When you select markers on a graph, only the selected markers are highlighted. You can change the way markers are highlighted on the current graph. The options are applied to the top two triangles in the following figure.

![Figure 9.16 Examples of Highlighted Triangular Markers](image)

To change the marker highlighting on the current graph:

1. Right-click anywhere in a graph and select **Marker Selection Mode**.
2. Select one of the following options:
   - **Preferred Mode** the Marker Selection Mode JMP preference is applied (by default, Unselected Faded).
   - **Unselected Faded** only the selected markers are highlighted. Everything else is dimmed by the percent specified by **Faded amount for unselected markers** in **Preferences > Graphs**.
   - **Selected Larger** the selected markers are larger than the deselected markers.
   - **Selected Haloed** the edges of the selected markers are outlined in blue.
   - **Selected Outlined** the selected markers are outlined in black.
   - **Selected Same Color** the selected markers are shaded with the same color.

For information about setting the default marker selection mode, see “Graphs” on page 406 in the “JMP Preferences” chapter.

**Specify Marker Transparency**

You can change the transparency of markers (points) on a graph. For example, this enables you to control the visibility of overlapping points.
Note: When the drawing speed is set to Fast, marker transparency settings revert to the default opaqueness and marker size reverts to Preferred Size.

To adjust markers’ transparency:
1. In a graph, right-click anywhere and select Transparency. In a histogram, right-click the box plot area on the right and select Transparency.
2. Enter the level of transparency that you want the markers (points) to have on the graph, and click OK.
   A value of 1 indicates total opaqueness and 0 indicates invisibility. Values between 1 and 0 are semi-transparent.

Exclude and Hide Markers

Using the Exclude/Unexclude command, you can exclude highlighted rows from statistical analyses. Data remains excluded until you select Rows > Exclude/Unexclude for those highlighted rows.

Note: Excluded data are not automatically hidden in plots even though they are excluded from calculations in text reports and graphs.

Using the Hide/Unhide command, you can suppress (hide) the appearance of highlighted points in scatterplots. For example, you can exclude points from analysis and then hide those same points in scatterplots. The data remain hidden until you select Rows > Hide/Unhide for highlighted hidden rows.

Note: Hidden points are not automatically excluded from statistical computations that affect text reports and graphs, even though they are not displayed in the plots. To exclude hidden observations from analyses, you must highlight them and select Rows > Exclude/Unexclude characteristic.

To exclude or hide markers (points) from analyses:
1. Highlight the marker(s) that you would like to exclude or hide.
2. Right-click anywhere in a graph.
3. Select Row Exclude or Row Hide.

Add Labels to Markers

When you position the arrow cursor over a point in a plot, the point’s label appears. By default, the label is the row number. There are three ways that you can customize the label:
• You can change the label so it displays values found in one or more columns instead of the row number.
• You can enable the label to appear always, not just when you position the cursor over points.
• You can click the label with the Arrow tool and drag it to a new location. If a label is dragged a certain distance away from the marker, then a tail is added connecting the label to its point.

To display values found in one or more columns instead of the row number:

1. In the data table, highlight the column(s) whose values you want to appear as the label in plots.
2. Select Label/Unlabel from one of the following places:
   – the Cols menu
   – the red triangle menu in the Columns panel
   – the top red triangle menu in the upper left corner of the data grid

A label or yellow tag icon beside the column name in the Columns panel indicates that points on plots are identified by the column value. If there are multiple labeled columns, their values appear on plots separated by a comma. Data remains labeled until you highlight the column and select Label/Unlabel again.

To enable the label to appear always, not just when you position the cursor over points:

1. Highlight the point(s) whose label you want to always appear in plots.
2. Right-click anywhere in a graph. In a histogram, right-click the box plot area on the right.
3. Select Row Label.

A label or yellow tag icon beside the row number in the data table indicates that points on plots corresponding to the row appear with a label.

Change Marker Shape or Colors Based On Values

In some plots, you can change marker shapes or colors based on the values of points by adding a row legend. It is called a row legend because JMP automatically inserts a legend using row color or row marker settings. When you assign markers or colors in this way, it assigns the characteristic(s) to all points in a graph, regardless of what points you have selected. All previous marker and color settings are overwritten.

To add shapes or colors based on column values:

1. Right-click anywhere in a graph. In a histogram, right-click the box plot area on the right.
2. Select Row Legend.
3. In the window that appears (Figure 9.17), highlight the column whose values you want to color or mark. A preview of the legend is shown on the right.

**Figure 9.17 Adding a Row Legend**

4. Refine your row legend using the following options:

- **Colors**  
  Lets you choose among several pre-defined color schemes.

- **Continuous Scale**  
  Assigns colors on a spectrum that corresponds to the ascending or descending order of the values. Use this option when the highlighted column contains continuous values.

- **Reverse Scale**  
  Reverses the scale of colors.

- **Markers**  
  Lets you choose among several marker schemes.

- **Make Window with Legend**  
  Creates a separate legend window that tells you what colors and shapes correspond to which value.

- **Save Column Property**  
  Adds a column property that stores the selected color theme.

- **Save Table Property**  
  Adds a table property that preserves the selected color and marker configuration.

- **Excluded Rows**  
  Assigns colors or markers to rows that are excluded.

Most legends have one column. However, the following platforms have multi-column legends when there are more than 20 levels:

- Recurrence
- Oneway (for CDF Plot and all three Densities red triangle commands)
- Fit Model (Standard Least Squares in Regression Plot)
- Survival
Remove the Legend

After you make the legend, right-click it to change the colors and the markers or to remove the legend. To remove colors or markers, select Rows > Clear Row States in the data table.

Alter Plot and Chart Appearances

There are many ways that you can format your report to meet your needs. The sections below detail how to make changes to the graphical portions of your output reports.

Tip: If you have a touchscreen, you can pan and zoom most graphs and axes in JMP. Graphs and axes change scale and zoom out if pinched, and zoom in if stretched.

Resize Plots and Graphs

There are two main ways to resize plots and graphs: using the click and drag method or resizing it according to pixel size.

Note: You can also change the default size of a graph using the Graph Height option in File > Preferences > Graphs.
Use Click and Drag

To resize a plot or graph using the click and drag method:

1. Place the cursor on the right edge, bottom edge, or lower right corner of the plot frame. The cursor changes to a small double-arrow pointer.
2. Click and drag to change the size of the plot. When you resize, the height and width of all plots in that frame adjust independently of other frames in the same report window. Table 9.6 describes how to adjust the plot.

Table 9.6 Resizing Actions

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adjust the plot frame but preserve the proportions (aspect ratio)</td>
<td>Hold down the SHIFT key and click and drag the corner of the frame.</td>
</tr>
<tr>
<td>Adjust a plot in 8-pixel increments</td>
<td>Hold down the ALT key and click and drag the corner of the frame.</td>
</tr>
<tr>
<td>Adjust all plots of the same type simultaneously</td>
<td>Hold down the CTRL key and click and drag the corner of one of the plots.</td>
</tr>
<tr>
<td></td>
<td>If you do this for one scatterplot, the action is broadcast to all scatterplots in the window, and they resize together. Any other types of plots remain unchanged.</td>
</tr>
</tbody>
</table>

Specify Size in Pixels

To resize a plot or graph to a specific pixel size:

1. Right-click the plot or graph.
2. Select Size/Scale > Frame Size.
3. Enter the number of pixels for the frame’s height and width.

Note: For details about the other options in the Size/Scale menu, see “Scroll and Scale Axes” on page 319.

Zoom In and Out

The magnifier 🕵️‍♀️ lets you automatically zoom in on any area of a plot. When you click the magnifier, the point or area where you click becomes the center of a new view of the data. The
scale of the new view enlarges, giving you a closer look at interesting points or patterns. You can perform any of the following actions:

- Click and drag the magnifier to focus in on a particular region of the plot.
- On a ternary plot, drag the magnifier to zoom the triangular axes.
- Zoom repeatedly to look closer at the data.
- Hold down the CTRL key and click to return to your previous state before the last zoom.
- Double-click or hold down the ALT key and click the magnifier to restore the original plot.

**Change Line Widths**

After fitting a line to a graph, or producing a graph with a line already present, you can adjust the width of the line:

1. Right-click anywhere in a graph.
2. Select *Line Width Scale*.
3. Select to increase the current line width one to three times its default width. Or, select *Other* and specify a larger or smaller number. Select *Scale with Font* to increase the line size as you increase the display font size using *Window > Font Sizes* (Windows) and *View > Make Text Bigger/Smaller* (Macintosh).

**Change the Background Color in a Graph**

To change the background color in a graph, follow these steps:

1. Right-click anywhere in a graph. (To change only the color of a box plot, right-click the box plot area.)
2. Select *Background Color*.
3. Select one of the predefined colors, or create your own color.
4. Click **OK**.

**Change the Color of Histogram Bars**

To change the color of histogram bars, follow these steps:

1. Right-click anywhere in a histogram and select *Histogram Color*.
2. Click a color, or click *Other* and create your own color.

See your operating system documentation for details about creating your own colors.
Display Coordinates and Temporary Reference Lines

You can measure points and distances in graphs, or easily find the exact value, or coordinates, of points and distances on plots and graphs. To do this, click the crosshairs tool and click and hold anywhere on a graph. The coordinate values appear where the crosshairs intersect the vertical and horizontal axis as you drag the crosshairs within a plot.

Figure 9.18 Using the Crosshairs Tool

On a fitted line or curve, the crosshairs identify the response value for any predicted value. On a ternary plot, this tool displays triangular crosshair lines.

Scroll and Scale Axes

The hand tool (also known as the grabber tool) provides a way to change the axes and view of a plot:

- On a y-axis, dragging scrolls the y-axis; dragging or scales the y-axis.
- On an x-axis, dragging scrolls the x-axis; or scales the x-axis.

You can also right-click in a plot or graph, and select Size/Scale (or Graph > Size/Scale). Choose one of the following options:

- To adjust the scale of the X axis, select X Axis.
- To adjust the scale of the Y axis, select Y Axis or Right Y Axis.
- For details about the Frame Size option, see “Specify Size in Pixels” on page 317.
- Select Size to Isometric when the x- and y-axes are measured in the same units and you want distances on the graph to be represented accurately regardless of direction.
Customize Axes and Axis Labels

Double-click a numeric axis to customize it using the Axis Specification window. Or, right-click the axis area and select Axis Settings to access the window.

Customization features in the window depend on the data type of the axis and the specific platform JMP uses to create the plot or chart. Figure 9.19 shows a typical Axis Specification window for numeric axes.

Figure 9.19 The Axis Specification Window for a Numeric Axis

The following sections describe how to use the axis specification window and what tasks you can accomplish with it.

Establish the Minimum and Maximum Axis Values

For plots and charts that contain a numeric axis area, you can change the minimum and maximum values that you want the graph to display.

To change the minimum and maximum axis values while viewing a graph:

1. Double-click a numeric axis. Or, right-click and select Axis Settings. The axis specification window appears.
2. Type in a value for the minimum and maximum values that you want the graph to display.

**Note:** To restore the default minimum and maximum axis settings of a numeric axis, right-click a numeric axis and select Revert Axis.
3. (Optional) Select **Reverse Order** to reverse the axes by reversing the minimum and maximum values.

To set a default minimum and maximum axis value for a variable, which avoids making this change every time you run an analysis, see “Axis” on page 183 in the “Set Column Properties” chapter.

The example on the right in Figure 9.20 is an enlargement of the point cluster that shows between 80 and 140 in the plot to the left. The enlarged plot is obtained by reassigning the maximum and minimum axis values and changing the number of minor tick marks to 1. (See “Add Minor Tick Marks” on page 327, for details.)

**Figure 9.20**  Rescale Axis to Enlarge a Plot Section

---

**Change the Axis Scale Type**

When viewing a graph with a numeric axis, you can change the axis scale as follows:

2. Select a scale type:
   - **Linear**
   - **Log**
   - **Power**
   - **Geodesic**
   - **Geodesic US**

**Note:** Specific platforms might use other scale types that are fixed and cannot be changed.

**Note:** If you selected a scale type of Log, type the **Base** to use.
Note: If you selected a scale type of Power, type the Power to use.

To set a default scale type for a variable, which avoids making this change every time you run an analysis, see “Axis” on page 183 in the “Set Column Properties” chapter.

Change the Orientation for Tick Labels

You can set the orientation for tick labels as follows:

2. From the Tick Label Orientation menu, select one of the options:
   - **Automatic**  Tick labels are oriented automatically to be readable, depending on the tick increment and length of the labels.
   - **Horizontal**  Baseline at the bottom.
   - **Vertical**  Vertical with the baseline on the right.
   - **Perpendicular**  *(Recommended in place of Horizontal)* Horizontal for vertical axes and vertical for horizontal axes.
   - **Parallel**  *(Recommended in place of Vertical)* Vertical for vertical axes and horizontal for horizontal axes.
   - **Angled**  Angled at about 45 degrees.

Change the Axis Increments

While viewing a graph, you can change the axis increments:

2. In the text box beside **Increment**, type the number of increments that you want displayed.
3. If the format of the axis is **Date** or **Time** (as shown in the **Format** drop-down menu), another drop-down menu appears beside **Increment**. (See Figure 9.21.) From that box, select which format you want the increments to take.
To set a default axis increment for a variable, which avoids making this change every time you run an analysis, see “Axis” on page 183 in the “Set Column Properties” chapter.

**Add and Remove Axis Labels**

You can add or remove labels in a numeric axis. To add an axis label:

1. Right-click a numeric axis and select **Add Axis Label**.
2. Type a name for the axis label. The axis area enlarges to hold the number of label lines that you enter.

This command can be used multiple times to add multiple labels. To edit the label after it has been added to the axis, click it and it will turn into an edit box.

To remove an axis label, right-click a numeric axis and select **Remove Axis Label**. The last label added is removed.
Change the Numeric Format of an Axis

For plots and charts that contain a numeric axis area, you can change the format of the axis. To change the numeric format while viewing a graph:

2. In the box beside **Format**, use the drop-down menu to select an option. See “**Numeric Format Options**” on page 172 in the “**Set Column Properties**” chapter.
3. If you selected:
   - **Date** or **Time** from the **Format** drop-down menu in the previous step, use the drop-down menu to the right of the selection to select date increments for tick marks. For descriptions of options, see “**Numeric Format Options**” on page 172 in the “**Set Column Properties**” chapter. You also need to specify the format of the increments, as described in “**Change the Axis Increments**” on page 322.
   - **Fixed Dec** from the **Format** drop-down menu in the previous step, a text box appears beside the **Format** box. Type the number of decimal places that you want JMP to display.

**Note:** When you change the numeric format of an axis, you do not change the numeric format of the way the values appear in the corresponding data table. To change the way a date or time appears in a data table, see “**Numeric Formats**” on page 172 in the “**Set Column Properties**” chapter.

Selecting a date interval from the date increment drop-down menu divides the JMP date (number of seconds) into the appropriate units. This gives the plot scale that you want for your data. The date axis must be a column with a JMP date value and appear in the Axis Specification window in the date format found in the Column Info window. However, you can use the Axis Specification window to format the date any way that you want it to be displayed in the plot.

Change Axis Label Font

You can modify the axis label font on any axis type. When you modify it, your change only applies to the active graph. To set the default axis label font, see “**Fonts**” on page 425 in the “**JMP Preferences**” chapter.

**Note:** Windows 7 does not support the Adobe Compact Font Format (CFF). As a result, JMP cannot render axis labels using CFF fonts (like certain OpenType fonts). Windows 8 supports CFF fonts, therefore, JMP correctly renders axis labels using CFF fonts.
To change the current font type and size:
1. Right-click an axis label.
2. Select Font.
3. Make your selections in the window.

To change the font color:
1. Right-click an axis label.
2. Select Font Color.
3. Select a color for the text from the color palette provided.

**Rotate Axis Labels**

You can modify the axis label on any axis type. To rotate an axis label:
1. Right-click an axis label.
2. Select Rotate Text.
3. Select which direction to rotate the text: Horizontal, Left, or Right.

To set a default axis label position for a variable, which avoids making this change every time you run an analysis, see “Axis” on page 183 in the “Set Column Properties” chapter.

**Copy and Paste Graph Contents**

After customizing a graph by adding elements such as a fitted line, you can copy and paste the contents from one graph to another compatible graph:
1. Right-click the graph that you have customized.
2. Select Edit > Copy Frame Contents.
3. Right-click the graph to which you would like to copy the settings.
4. Select Edit > Paste Frame Contents.

**Copy and Paste Axis Settings**

After customizing an axis (as described in “Customize Axes and Axis Labels” on page 320), you can copy and paste your new settings to another axis:
1. Right-click the axis that you have customized.
2. Select Edit > Copy Axis Settings.
3. Right-click the axis to which you would like to copy the settings.
Change the Order of Values

Data in a JMP report might not appear in the order that you prefer. To give data a specific order so it appears that way in a report, assign the column the Value Ordering property before running the analysis, as described in “Value Ordering” on page 181 in the “Set Column Properties” chapter.

If your values include any of the following, they automatically appear in the appropriate order in reports:

- January, February, March, April, May, June, July, August, September, October, November, December
- Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec
- Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, Saturday
- Very Low, Low, Medium Low, Medium, Medium High, High, Very High
- Strongly Disagree, Disagree, Neutral, Indifferent, Agree, Strongly Agree
- Failing, Unacceptable, Very Poor, Poor, Bad, Acceptable, Average, Good, Better, Very Good, Excellent, Best

Customize Tick Marks and Tick Mark Labels

On a numeric axis, you can add and remove tick marks, add and remove gridlines, and add minor tick marks. You can also modify font properties, rotate the axis labels, or add an outline box to nominal or ordinal axes’ tick mark labels. The following sections describe how to customize them.

Add Tick Marks, Grid Lines, or Labels

For plots and charts that contain a numeric axis area, you can show or hide tick marks, grid lines, or labels. To do this, double-click a numeric axis. Or, right-click a numeric axis and select Axis Settings. The Axis Specification window appears, as shown in Figure 9.22.

Figure 9.22  Show or Hide Tick Marks and Gridlines

Below the check boxes, the orientation of the Tick Labels can be set by a drop-down list. Horizontal, Vertical, and Angled refer to single axes and Parallel and Perpendicular refer to paired axes, like in Multivariate plots.
To set default tick marks for a variable, which avoids making this change every time you run an analysis, see “Axis” on page 183 in the “Set Column Properties” chapter.

**Add Minor Tick Marks**

To add tick marks to a numeric axis, or to change the number of minor tick marks that appear on a numeric axis, proceed as follows:

1. Double-click the tick mark. Or right-click it and select **Axis Settings**. The Axis Specification window appears.
2. In the box beside # **Minor Ticks**, type the number of minor tick marks that you want to appear between major tick marks.
3. Click the box to the right of **Minor** and below **Tickmark** to indicate that you want the tick marks to appear on the axis.

To set default minor tick marks for a variable, which avoids making this change every time you run an analysis, see “Axis” on page 183 in the “Set Column Properties” chapter.

**Adjust the Field Width of Labels**

On plots and charts that contain a numeric axis area, you can adjust the width of the tick mark labels. Then they show large values with many decimal places or only a small amount of space or truncated values. If the field width is set too small, your tick mark labels appear as an ellipsis (...).

To change the field width while viewing a graph:

2. In the **Width** text box, type the approximate number of characters in the widest tick mark label. The maximum field width is 40 for numeric values. There is no limit for character values.

Note that increasing or decreasing the field width of tick mark labels does not change the field width for the cells containing the values in the corresponding data table. To change the field width of cells in a data table, see the section “**Numeric Formats**” on page 172 in the “Set Column Properties” chapter.

**Change Tick Mark Label Font Types and Sizes**

You can modify a numeric axis tick label's font type, size, and style (bold and italic). To change font type and size:

1. Double-click the tick label. Or, right-click it and select **Axis Settings**. The Axis Specification window appears.
2. Select **Font**, and make your selections.
Note: To make global changes to all types of axes’ font types and sizes, select File > Preferences (JMP > Preferences on the Macintosh). Click the Fonts tab, and then click Axis.

**Rotate Tick Mark Labels**

To rotate tick mark labels vertically or horizontally on a *numeric* axis:

1. Double-click the tick label. Or, right-click it and select **Axis Settings**. The Axis Specification window appears.
2. Modify the **Tick Label Orientation**.

To rotate tick marks on a *nominal* axis, right-click the tick label and select **Rotated Tick Labels**.

To rotate them back, complete the steps again.

**Extend Divider Lines and Frames for Categorical Axes**

Extending the vertical divider line(s) between tick labels is useful when there are many levels of a nominal or ordinal (categorical) variable.

To extend the divider line to the *x*-axis labels:

1. Right-click a nominal or ordinal axis.
2. Select **Tick Marks > Divider Lines** to add the lines, or **Lower Frame** to add a frame around the axis area.

**Figure 9.23** Divider Lines
Add Reference Lines

To add reference lines to graphs, proceed as follows:

1. Double-click a numeric axis. Or, right-click a numeric axis and select **Axis Settings**. The Axis Specification window appears.
2. In the text box to the left of the **Add** button, type the **Value** to which you want the reference line to correspond. This is the position on the graph at which the line is placed.
3. Enter a Label for the line.
4. Further customize the reference line by choosing either of these options:
   - **Color** changes the line color.
   - **Line Style** specifies the line style.
   - **Line Width** specifies the width for the reference line.
5. Click the **Add** button. The value moves into the box to the right of the **Add** button, indicating that it will be placed on the graph.
6. To add more lines, repeat the above steps.

To set a default reference line for a variable, which avoids making this change every time you run an analysis, see “Axis” on page 183 in the “Set Column Properties” chapter.

Add Geographical Images and Boundaries

Adding map images and political boundaries to graphs provides visual context to geospatial data. For example, you can add a map to the graph that displays an image of the U.S. Another option is displaying the boundaries for each state (when data includes the latitudes and longitudes for the U.S.).

The data should have latitudinal and longitudinal coordinates. Otherwise, the map has no meaning in the context of the data. The x and y axes also have range requirements based on the type of map. These requirements are described in the following sections.

Two tools are especially helpful when you are viewing a map:

- The grabber tool (_kb) lets you scroll horizontally and vertically through a map.
- The magnifier tool ( ) lets you zoom in and out.

The following sections describe the map images and boundaries that you can add to a graph. For details about adding maps, see *Essential Graphing*. 
Drag and Drop an Image into a Graph

To add an image that you created, generate your report and then drag and drop the image from your file system onto the graph in the report. After you add the image, JMP provides several options such as resizing, formatting, and rotating an image. Right-click the image and select Image to see these options.

The following example shows a bivariate plot of wind speeds in the Chicago area. The plot on the left includes arrows to illustrate the wind direction and speed. A map image was dropped onto the plot and resized to line up the markers with the stations that provided the wind data (each dot representing a station).

Figure 9.24 Example of a Custom Map Image

Note: Repeated changes to images can degrade image quality. If you are not happy with the results of sizing, scaling, or applying filters to the image, remove the image and start again.

Table 9.7 Descriptions of Image Options

<table>
<thead>
<tr>
<th>Lock</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lock</td>
<td>Locks the image in place so it cannot be moved.</td>
</tr>
<tr>
<td>Size/Scale</td>
<td>Fill Graph: Resizes the image proportionately to fit the graph.</td>
</tr>
<tr>
<td></td>
<td>Specify Size: Resizes the image according to the values that you enter. (The units for these values are the same as your graph axes.)</td>
</tr>
<tr>
<td></td>
<td>Crop: Crops the image according to the values that you enter. (The units for these values are the same as your graph axes.) For example, the left edge might be positioned at 50. You type 60 next to Left, and the portion of the image between 50 and 60 is removed from the image.</td>
</tr>
</tbody>
</table>
### Table 9.7 Descriptions of Image Options (Continued)

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Flip</strong></td>
<td></td>
</tr>
<tr>
<td>• <strong>Flip vertical</strong>: Turns the image upside down.</td>
<td></td>
</tr>
<tr>
<td>• <strong>Flip horizontal</strong>: Flips the image left to right.</td>
<td></td>
</tr>
<tr>
<td>• <strong>Flip both</strong>: Flips the image both horizontally and vertically.</td>
<td></td>
</tr>
<tr>
<td><strong>Rotate</strong></td>
<td>Rotates the image the specified number of degrees. Enter a negative value to rotate the image counterclockwise.</td>
</tr>
<tr>
<td><strong>Transparency</strong></td>
<td>Changes the marker transparency level. Type a value between 0 and 1 (where 1 is completely opaque).</td>
</tr>
<tr>
<td><strong>Filter</strong></td>
<td>Provides filters found in many graphic editing programs to change the appearance of the image. Select a filter repeatedly to increase its effects on the image.</td>
</tr>
<tr>
<td>• <strong>Contrast</strong>: Optimizes the light and dark colors. Larger values lighten the image.</td>
<td></td>
</tr>
<tr>
<td>• <strong>Despeckle</strong>: Removes pixels that do not blend with surrounding pixels. For example, a black pixel surrounded by white pixels is converted to a white pixel.</td>
<td></td>
</tr>
<tr>
<td>• <strong>Edge</strong>: Darkens everything but the outlines of objects.</td>
<td></td>
</tr>
<tr>
<td>• <strong>Enhance</strong>: Reduces the contrast between pixels in a noisy image.</td>
<td></td>
</tr>
<tr>
<td>• <strong>Gamma</strong>: Balances the brightness of an image and the red, green, and blue (RGB) ratios. Larger values create a lighter image.</td>
<td></td>
</tr>
<tr>
<td>• <strong>Gaussian Blur</strong>: Blurs pixels by the specified radius. Larger radii create a smoother image. (In JSL, you can also specify the sigma value. Larger sigma values create a smoother image.)</td>
<td></td>
</tr>
<tr>
<td>• <strong>Median</strong>: Replaces each pixel color value with the median value of the surrounding pixels.</td>
<td></td>
</tr>
<tr>
<td>• <strong>Negate</strong>: Converts each pixel to its complementary color (such as pink to green and white to black).</td>
<td></td>
</tr>
<tr>
<td>• <strong>Normalize</strong>: Removes a percentage of the top and bottom color values. The color values are then stretched to fill the remaining image. This process increases the intensity of the colors.</td>
<td></td>
</tr>
<tr>
<td>• <strong>Reduce Noise</strong>: Finds the minimum and maximum color values and replaces them with values more consistent with the surrounding pixels. Larger values create a smoother image.</td>
<td></td>
</tr>
<tr>
<td>• <strong>Sharpen</strong>: Makes the edges of pixels more distinct.</td>
<td></td>
</tr>
</tbody>
</table>
### Extract Data from an Image

JMP provides the ability to extract information from images into a data table and then analyze that information. Researchers at WildTrack.org analyze digital footprint photos in JMP to track endangered species. They drag and drop a footprint image into a JMP report and draw data points to capture the size and shape of the print. A JMP Scripting Language (JSL) script extracts those measurements into a data table. At that point, the researchers can analyze the data and determine whether the footprint is from a new animal. This method helps them track populations of endangered species in specific regions of the world.

**Figure 9.25** Example of Extracting and Analyzing Data

The details for implementing this feature are beyond the scope of this book, because the needs of the user vary widely. For details about writing JSL scripts, see the *Scripting Guide.*
Add Graphics Elements to a Report

You can add text notes, lines, polygons, ovals, and rectangles to a report using graphics tools found in the toolbar.

Annotations

You can add editable text notes to a JMP report using the annotate tool. To add an annotation:

1. Select the annotate tool from the Tools menu or toolbar.
2. Click the location in the window where you want to add the annotation. Or, click and drag to size the annotation note. A white editable text box appears.
3. Enter text.
4. Click outside the annotation. The annotation turns yellow.
5. (Optional) Right-click the annotation to access the following options:

   **Background Color** Provides you with a color palette, from which you can select the background color for the annotation.

   **Text Color** Provides you with a color palette, from which you can select the color for the annotation’s text. The color of the font also defines the color of the annotation outline. If you select the same color for both the background and the font, the font does not show except for black and white. A black font on a black background changes to white, and a white font on a white background appears black.

   **Font** Lets you change the current font type, style, and size. To change the default font, see “Fonts” on page 425 in the “JMP Preferences” chapter.

   **Tag Line** Attaches a line to the annotation that points to a place in the text, as shown below. To move the line with the annotation to a new position, press the CTRL key and drag the annotation.

   **Filled** Removes the background color from the annotation so it looks transparent. A transparent note is handy for putting titles and footnotes on a graph.

   **Editable** Makes the annotation editable by double-clicking on it.

   **Reanchor** Reanchors the annotation.

   **Delete** Deletes the entire annotation.

**Note:** When adding multiple annotations, press the SHIFT key when selecting the annotation tool for the first time. This causes subsequent clicks to add an annotation, and you do not have to select the annotate tool from the toolbar before the addition of each annotation.
Once you have added an annotation, you can do the following:

Table 9.8 Using Annotations

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add to or edit an annotation</td>
<td>Click inside the text box.</td>
</tr>
<tr>
<td>Move an annotation</td>
<td>Click inside the annotation box and drag it. When an annotation is moved, it becomes selected, as indicated by a double blue line with handles around the perimeter.</td>
</tr>
<tr>
<td>Resize an annotation</td>
<td>Place the cursor on the handle of a selected note (showing in the middle of the edges and in the corners). The cursor appears as a single crossed arrow; drag to resize the annotation.</td>
</tr>
<tr>
<td>Delete an annotation</td>
<td>Highlight the annotation by clicking the handle of a note. Then press the Delete (or Backspace) key.</td>
</tr>
</tbody>
</table>

**Add Shapes**

You can add editable lines, polygons, and simple shapes (ovals or rectangles) to a JMP report using the drawing tools \(\text{\includegraphics[width=1cm]{shapes.png}}\). The following sections describe how each of these tools can be used.

**Note:** Each graphics tool remembers the most recent options chosen. This is useful if you need many annotations or other graphics with the same characteristics. For example, suppose you want many thick green lines with an arrow on one end. Create a line the way you want it, set the options, and subsequent lines appear with those options in effect. The options persist until you change them.

**Add a Line**

To add a line to a report window:

1. Click the line tool \(\text{\includegraphics[width=0.5cm]{line.png}}\) in the tool palette.
2. Click and drag where you want to insert the line. The line appears selected, showing handles on both ends.
3. Click and drag the line to move it.
4. Click a handle and drag to rotate the line.
5. Right-click a line for a menu of options to tailor the appearance of the line, as follows:

**Point to and Point from** Places arrows on either end (or both ends) of the line.

**Thick** Alternately displays the width of a line as thick or thin. A line is thin by default.

**Dashed** Alternately displays a line as dashed or solid. A line is solid by default.

**Color** Displays the JMP color palette to change the color of the shape.

**Reanchor** Reanchors the shape.

**Delete** Removes the shape from the report surface. You can also remove the shape by selecting it and then pressing the DELETE (or BACKSPACE) key.

### Add a Polygon or Bezier Curve

To add a polygon (or bezier curve) to a report window:

1. Click the polygon tool \( \text{polygon tool} \) in the tool palette.
2. Click to create the beginning point for the first side of a polygon.
3. Click again at the location where you want to complete the first side and begin an adjacent side. A square selection box with handles appears around the polygon area.
4. Click a third time to complete the second side.
5. Continue this process until the polygon is the way you want it. Each time a side is complete, the selection box adjusts to encompass the polygon sides.
6. Double-click to release the polygon tool.

Once you have added a polygon, you can perform the following actions:

### Table 9.9 Working with Polygons

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select or deselect the polygon</td>
<td>Click the edge of a completed polygon.</td>
</tr>
<tr>
<td>Resize the polygon</td>
<td>Select it and drag one of the selection box’s handles.</td>
</tr>
<tr>
<td>Move the polygon</td>
<td>Click between the box’s handles and drag the selection box.</td>
</tr>
<tr>
<td>Change the number of sides of the polygon</td>
<td>Click and drag the sides to form the new shape.</td>
</tr>
</tbody>
</table>

Right-click a polygon for a menu of options to tailor its appearance, as follows:

**Filled** Alternately fills or empties the area of the shape.
Raised  Displays thick shaded lines around the shape. If the shape is also filled, the lower edge of the figure appears raised, giving it a three-dimensional look.

Smooth  Smooths the vertices of a polygon to produce a Bezier curve. The smoothed figure is reshaped and resized the same way as the polygon, and can be filled and raised.

Closed  Alternately opens or closes the last segment of a polygon.

Color  Displays the JMP color palette to change the color of the shape’s sides, and its fill color when the Filled option is in effect.

Reanchor  Reanchors the shape.

Delete  Removes the shape from the report. You can also remove the shape by selecting it and then pressing the Delete (or Backspace) key.

Add an Oval or Rectangle

To add an oval or rectangle to a report window:

1. Click the simple shape tool in the tool palette.
2. Click and drag where you want to insert the shape. An oval appears with a selection box around it.
3. (Optional) To turn the oval into a rectangle, right-click on the oval and select Shape > Rectangle.
4. Double-click to release the simple shape tool.

Once you have added the shape, you can do the following:

- Select the shape and drag one of the selection box handles to reshape or resize.
- Click and drag an edge of the selection box (located between the handles) to move it.
- Select the shape, and then right-click it for a menu of options to tailor its appearance, as follows:

Filled  Alternately fills or empties the area of the shape.

Raised  Displays thick shaded lines around the shape. If the shape is also filled, the lower edge of the figure appears raised, giving it a three-dimensional look.

Shape  Displays a submenu whose options transform the shape into either an oval or a rectangle when selected.

Color  Displays the JMP color palette to change the color of the shape’s sides and its fill color when the Filled option is in effect.

Reanchor  Reanchors the shape.

Delete  Removes the shape from the report. You can also remove the shape by selecting it and then pressing the Delete (or Backspace) key.
Add Graphics

To enhance your graphs with logos, pictures, or any other type of graphic, you can paste it into a report in .bmp, .jpeg, or .png format. You can also drag and drop graphics into reports.

To add graphics:
1. Open the graphic file and select the graphic. Copy it to the computer's clipboard.
2. Right-click inside a graph.
3. Select Edit > Paste Background Image. The graphic is inserted at the point in the graph that you right-clicked.

You can also add the graphic to the end of a report window: copy the graphic onto your computer’s clipboard, making sure the report is the active window and selecting Edit > Paste.

Customize Graphical Elements

Graphs consist of markers, lines, text, and other graphical elements that you can customize. For example, in a Scatterplot Matrix graph, you might want to highlight data points in one of the bivariate graphs with a pink solid marker. In a Contour Plot graph, you can increase the width or transparency of the contour lines.

Example of Customizing a Contour Plot
1. Open the Little Pond.jmp sample data table.
2. In the Table panel, click on the red triangle next to Contour Plot and select Run Script.
3. Click on the red triangle next to Contour Plot for Z and deselect Fill Areas.

Figure 9.26 Contour Plot Before Customization

4. Right-click on the plot and select Customize.
The Customize Graph window appears.

**Figure 9.27** Customize Graph Window

5. Click on **Contours**.
6. Change the Line Width to 3.
7. Click on **Boundary**.
8. Change the Line Width to 2.
9. Click on the color next to Line Color and select a shade of green.
10. Click **OK**.

**Figure 9.28** Customized Contour Plot

The graphical elements that you can customize differ on each graph. For example, in a Control Chart graph, there are three line elements (Center Line, Limits, and Connect Line). In other graphs, the line element might be named Line or Custom.

To customize graphical elements in the current graph:

1. Right-click the graph and select **Customize**.
2. Select the element that you want to change, and then modify the properties.
   Your changes are immediately shown on the graph.
3. Click OK to save your changes to the current graph.

Each element can include properties for line color, marker style and size, text style, and so on. Here are some common properties:

**Line Color**  Changes the color of the line. Click to select any color in the window. Right-click to choose from more colors.

**Line Style**  Changes the style of the line. Click to select one of five different styles.

**Line Width**  Changes the width of the line. Click in the box and enter the desired line width in points.

**Marker**  Changes the marker shape or size. Click to change the shape. Right-click to change the size. For more information about markers, refer to “Use Markers” on page 309.

**Arrow**  Adds an arrowhead to a line at either None, Start, End, or Both ends of the line.

**Line of Fit**  Changes the color, width, or style of the line.

**Text Color**  Changes the color of the text.

**Font**  Changes the font, style, and point size of the text.

**Text Style**  Changes the text alignment to centered, left-aligned, or right-justified. The Fill option applies the selected color to the background.

**Fill Color**  Changes the color of objects such as box plots and Fit Confidence regions.

**Transparency**  Changes the marker or label transparency. Enter the level of transparency to draw markers (points) on the graph. The degrees of opacity ranges from 0 (clear) to 1 (opaque). For more information about changing the transparency of markers, see “Specify Marker Transparency” on page 312.

### Create Scripts for Graphical Elements

In addition to customizing graphical elements, you can write JSL scripts that add elements. These scripts run when you display the graph. You can write the scripts from scratch, or you can select from the following lists of commands and scripts, accessed by clicking on the **Add a new script button**:

- Use the **Templates** list to insert a single JSL command. For example, the **Polygon** option inserts the Polygon command. The text enclosed in underscores are placeholders for point values, which you replace with your own values.

  ```
  Polygon([_x0_, _x1_, ...], [_y0_, _y1_, ...]);
  ```
• Use the **Samples** list to insert a script that creates elements such as bubble plots and sine waves. In this list, the **Polygon** option shows examples of the Transparency, Fill Color, and Polygon values, which you replace with your own values.

**Figure 9.29** The Polygon Sample Script

In some graphs, you can view the JSL that creates graphical elements. Figure 9.30 shows the Group Label script for a Discriminant Analysis graph. The script defines markers and text for group labels. The commands included in these built-in scripts cannot be modified or deleted. You can insert commands from the Templates or Samples list, but you cannot click in the window and type new commands.

**Figure 9.30** Example of JSL that Creates Group Labels

For information about JSL, see the *Scripting Guide* book.

**To create a graphics script:**

1. Right-click on the graph and select **Customize**.
2. Click the **Add a new script** button (➕) to create a new script.
   
   The default name, **Script**, is highlighted.
3. With the default name highlighted, type a more descriptive name, and then press ENTER.
   (If you already moved the cursor and the name is no longer highlighted, double-click
   Script, and then type the new name.)

4. Do one or more of the following:
   - Enter JSL in the Properties window.
   - Select one or more JSL commands from the Templates list, and modify the placeholder
     text. For example, change the Pen Color option from “blue” to “red.”
   - Select one or more sample scripts from the Samples list and modify, if necessary.

5. (Optional) Click Apply to update the graph with your changes without closing the
   window. Unlike other property changes, script changes to not take effect until you click
   Apply or OK.

6. Click OK to save your changes.

   One of the following occurs:
   - The element that you created appears on the graph.
   - An error message appears if the script contains an error. Select View > Log to read
     about the error, and then correct the script.

To delete a script that you created, select the script and then select the Delete selected script
button ( ).

Change the Drawing Order of Graphical Elements

The graphical elements are drawn in the order in which they are listed. The first element on
the list is drawn first, so it appears behind all other graphical elements. If one element hides
another, you can rearrange the order of the elements.

To rearrange graphical elements:

1. Right-click the graph and select Customize.
2. Select the element that you want to move.
3. Click the Move up in drawing order button ( ) or Move down in drawing order ( ) button
   one or more times until the elements are in the order in which you want them drawn.
4. Click OK.

Save Your Customizations

The graph customizations apply to the current graph and are also used when you redo an
analysis. To re-create your graph at a later time with its customizations, select Script from the
red triangle menu, and then select one of the Save options. For example, you can save the
script to the data table, which applies your customized properties each time you run the
script. See “Save Your Analysis as a Script” on page 355 in the “Save and Share Data” chapter.
Copy Your Customizations

You can copy your customizations from one graph to another. All objects that you created or modified, such as colored text or lines, are pasted to the other graph.

To copy lines from one graph to another, see “Copy and Paste Graph Contents” on page 325.

To copy other objects:
1. Right-click in the graph with custom elements and select **Edit > Copy Customizations**.
2. Right-click in the destination graph and select **Edit > Paste Customizations**.

**Note:** The customizations are pasted into all similar graphs when you press CTRL, click, and then paste.

The objects appear on the current graph and are added to the list of customized elements.

**Note:** The copy customizations feature copies only the elements that you added or modified. It does not copy the other contents of the graph.
This chapter covers the following topics:

- Save data tables as text files, SAS data sets, Excel files, and so on
- Save reports as interactive HTML 5 or Adobe Flash files
- E-mail reports and data tables
- Save analyses as scripts
- Create JMP journals or projects
- Save log windows

The method that you choose depends on how you want to interact with your analyses in the future.
Contents

Save and Share Data Tables .......................................................... 345
  Save as a CSV File ................................................................. 346
  Save as a Text File ............................................................... 346
  Save as a SAS Transport File .................................................. 347
  Save as a SAS Data Set .......................................................... 348
  Save as a Microsoft Excel File ............................................... 349
  Save Data Tables to a Database ............................................. 350
  Replace a Database with a Data Table .................................... 351
  E-mail a Data Table ............................................................. 351

Save and Share Reports ............................................................. 351
  E-mail a Report ................................................................. 353
  Save the Report as Interactive HTML ..................................... 353
  Save as Flash ................................................................. 355
  Setting the DPI ............................................................... 355

Save Your Analysis as a Script .................................................. 355

Print Reports ................................................................. 359

Copy and Paste Reports ........................................................ 359

JMP Journals ................................................................. 360

Save JMP Sessions .............................................................. 367

JMP Projects (Windows Only) .................................................. 368

Save a Log Window .............................................................. 373
Save and Share Data Tables

JMP saves data tables in the formats listed in Table 10.1.

Here are the basic steps for saving a data table:

- On Windows, select **File > Save As** to save in multiple formats.
- On Macintosh, select **File > Save As** to save as a JMP file (.jmp). Select **File > Export** to save in Text (.dat), Microsoft Excel (.xls), SAS Transport (.xpt), and SAS Data Sets (.sas7bdat) formats.

**Note:** To save a data table as a journal or layout, select **Edit > Journal** or **Edit > Layout** and then **File > Save As**.

In addition to these file types, JMP can save files for types that have a corresponding ODBC driver. See “Save Data Tables to a Database” on page 350, for details. Note that for Macintosh, the Excel ODBC driver is required for exporting to Excel.

### Table 10.1  File Types and Extensions

<table>
<thead>
<tr>
<th>File Type(s)</th>
<th>Extension</th>
<th>OS Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>JMP Data Table</td>
<td>.jmp</td>
<td>All</td>
</tr>
<tr>
<td>Excel Workbook</td>
<td>.xls</td>
<td>All</td>
</tr>
<tr>
<td>Text Export File</td>
<td>.txt</td>
<td>All</td>
</tr>
<tr>
<td>SAS Data Set</td>
<td>.sas7bdat</td>
<td>All</td>
</tr>
<tr>
<td>SAS Transport File</td>
<td>.xpt</td>
<td>All</td>
</tr>
<tr>
<td>dBASE Files</td>
<td>.dbf, .ndx, .mdx</td>
<td>Windows</td>
</tr>
</tbody>
</table>

**Note:** For Macintosh, due to a limitation of the Open Database Connectivity (ODBC) driver, each cell must contain no more than 255 characters. Additional characters do not show up in the data table. To prevent this issue, divide the 255 characters into two or more cells.

The maximum length of the data table’s name depends on your computer’s operating system. See your operation system documentation for details.
Note: JMP tries to save any modified files when a crash is detected.

Save as a CSV File

JMP can convert data from a JMP data table to a comma-separated values (CSV) file. To save a data table as a CSV file:
1. With the specific data table open in JMP, select File > Save As.
2. Select CSV (Comma delimited) (*.csv) from the Save as type drop-list.
3. Enter the File name.
4. Select the location for the CSV file.
5. Click Save.

Save as a Text File

JMP can convert data from a JMP data table to standard text format with rows and columns. To save a data table as a text file, follow the steps in Table 10.2 based on your operating system and how you want to save the file.

Table 10.2 Saving a Data Table as a Text File

<table>
<thead>
<tr>
<th>Windows</th>
<th>1. Select File &gt; Save As.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>2. Select Text Export File from the Save as type list.</td>
</tr>
<tr>
<td></td>
<td>3. Click the Options button and specify end-of-line and end-of-field characters, and choose whether to export column headings as text.</td>
</tr>
<tr>
<td></td>
<td>4. Click OK.</td>
</tr>
<tr>
<td></td>
<td>5. Click Save.</td>
</tr>
<tr>
<td></td>
<td>An alert appears regarding loss of formulas, formatting information, and other metadata.</td>
</tr>
<tr>
<td></td>
<td>6. Click Yes.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Macintosh</th>
<th>1. Select File &gt; Export.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>2. Select Text and click Next.</td>
</tr>
<tr>
<td></td>
<td>3. Enter a name for the file in the Save As box and change the extension to .txt.</td>
</tr>
<tr>
<td></td>
<td>4. Specify end-of-line and end-of-field characters, and choose whether to export column headings as text.</td>
</tr>
<tr>
<td></td>
<td>5. Click Export.</td>
</tr>
</tbody>
</table>
Text formatting options are:

- **Export Column Names to Text File**  To save column headings in the first line of text, and to save labels or header information with the data, select **Export Table Headers**.

- **End of Field**  Select the radio button next to the character that marks the end of a field (or cell). Select **Other** and enter a character if the appropriate character is not listed.

- **End of Line**  Select the radio button next to the character that marks the end of a line (or row). Select **Other** and enter a character if the appropriate character is not listed.

**Note:** If double quotation marks are found when importing text data, the delimiter rules change, and JMP looks for an end double quotation marks. Other text delimiters, including spaces embedded within the quotation marks, are ignored and treated as part of the text string.

### Save as a SAS Transport File

You can save a JMP data table in SAS transport file format. JMP replaces spaces in filenames and column names with underscores, converts column headings to uppercase SAS variables, and makes other changes to follow the transport file specifications.

When you save the data table as a transport file, you can opt to append it to an existing transport file. When you reopen the transport file in JMP, the two data tables open in separate windows.

**Note:** The maximum length for the filename is 32 characters. JMP warns that characters beyond that limit are omitted.

### Windows

1. Select **File > Save As**.
2. Select **SAS Transport File** from the **Save as type** list.
3. (Optional) Append the data table to an existing SAS transport file. Select the file to which you want to append the data table, and then click the **Save** arrow. Select **Append To**, and then click **Yes** to replace the selected data table.

   An alert appears regarding loss of formulas, formatting information, and other metadata.

4. Click **Yes**.

   Alerts appear regarding other SAS format modifications.

5. Click **OK** on each alert.
Save and Share Data

Macintosh

1. Select File > Export.
2. Select SAS Transport.
3. (Optional) To append the data table to an existing SAS transport file, select the Append check box.
4. Click Next.
5. Do one of the following:
   – If you chose to append the data table, select the file to which you want to append the data table and click Append.
   – Enter a name for the file in the Save As box, and then click Export.
   Alerts appear regarding SAS format modifications.
6. Click OK on each alert.

Save as a SAS Data Set

You can save data tables as SAS version 6 and higher data sets. JMP writes columns as SAS variables, writes rows as SAS observations, and makes other changes to follow the SAS data set specifications.

When you export data to a SAS data set, JMP date columns become SAS date values with the appropriate SAS format.

Windows

1. Select File > Save As.
2. Enter a name for your file in the File Name box. The maximum length for the filename is 32 characters. JMP warns that characters beyond that limit are omitted.
3. Select SAS Data Set from the Save as type list.
4. (Optional) To save SAS variable names or SAS formats, select the Preserve SAS column names or Preserve SAS formats check boxes.
5. (Optional) To store JMP metadata (such as, column and table properties) as extended attributes for SAS 9.4, select Store table and column properties in SAS 9.4 extended attributes.
6. Click Save.
   An alert appears regarding loss of formulas, formatting information, and other metadata.
7. Click Yes.
8. If other alerts appear, click OK on each alert.
Macintosh

1. Select File > Export.
2. Select SAS and click Next.
3. Enter the filename and select export options.
   Honor Excluded Rows exports rows with the Excluded row state. The other options are described in the preceding section.

Save as a Microsoft Excel File

You can save a JMP data table in Microsoft Excel format.

**Note:** The maximum length of the Excel filename is determined by your computer’s operating system.

Windows

1. Select File > Save As.
3. Enter a name for your file in the File Name box.
4. Click Save.

Macintosh

**Note:** To save *.xlsx files, an Excel ODBC driver must be installed on your computer. The document is saved in the format that is specified in the ODBC driver properties. 64-bit JMP requires a 64-bit ODBC driver.

1. Select File > Export.
2. Select Excel.
3. Click Next.
4. Enter a name for the file in the Save As box.
5. Click Export.
Save Data Tables to a Database

You can save a data table to any database on your system that has a compliant ODBC (Open Database Connectivity) driver:

1. Select **File > Database > Save Table**. Figure 10.1 shows the window that is initially displayed.

**Figure 10.1** The Database Save Table Window

2. In the Connections box, highlight the name of the database to which you want to save the file. The Connections box contains a list of databases to which your system is connected. If you are not connected to the needed database, create it by using another application, or see “**To add a new database connection:**” on page 350.

3. From the **JMP data table to be saved menu**, select the open JMP data table that you want to save to the database.

4. In the **Save to database table** box, enter the name that you want the table to have when you save it in the database.

5. Click **Save Table**.

**To add a new database connection:**

1. Click **Connect**.

2. Select the data source that you want and click **OK**. Or, to create a new source, click the **New** button (Windows) or **Add** button (Macintosh).

Depending on which data source you select (and which database drivers you have installed on your computer), you might be presented with a variety of windows. Use them to create the database source.

3. Select the database to which you want to save the file.
Replace a Database with a Data Table

To replace a database with a data table:

1. Select **File > Database > Save Table**.
   
   Figure 10.1 shows the window that is initially displayed.

2. In the Connections box, select the name of the database to which you want to replace the file. The Connections box contains a list of databases to which your system is connected.
   
   If you are *not* connected to the needed database, create it by using another application, or see “To add a new database connection:” on page 350.

3. In the Schemas - Tables box, select the database table that you want to replace.

   **Note:** Remember the name for the database table. You will use this same name for the replacement database table.

4. Click **Drop Table**.
   
   The database table is deleted from the database.

5. From the **JMP data table to be saved** drop list, select the JMP data table you want to save to the database.

6. In the **Save to database table** box, type the name for the deleted database table.

7. Click **Save Table**.
   
   The data table is saved to the database.

8. Click **Disconnect**.

9. Close the Save Database Table window.

E-mail a Data Table

On Windows, you can e-mail a JMP data table by selecting **File > Send**. Your default e-mail application opens with the data table file attached to a new e-mail.

Save and Share Reports

To save a report, select **File > Save As**.

- On Windows, you can save the report as any of the file types listed in Table 10.3.
- On Macintosh, the report is saved as a JMP report (.jrp). If you want to save the report as a text, image, HTML, or RTF file, select **File > Export**. Supported image files include .eps, .png, .svg, and .tiff.
Table 10.3  Windows Supported Report File Types

<table>
<thead>
<tr>
<th>File Type</th>
<th>Extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Word</td>
<td>.doc</td>
<td>Word processing format; mixture of pictures, text, and tables.</td>
</tr>
<tr>
<td>Enhanced Metafile</td>
<td>.emf</td>
<td>Can contain both vector and bitmap components.</td>
</tr>
<tr>
<td>Encapsulated PostScript File</td>
<td>.eps</td>
<td>Line drawing (or <em>vector</em> image) that can show a bitmap preview of the image.</td>
</tr>
<tr>
<td>CompuServe Graphics Interchange Format</td>
<td>.gif</td>
<td>Compressed bitmap pictures.</td>
</tr>
<tr>
<td>Hypertext Markup Language</td>
<td>.htm, .html</td>
<td>Browser format; marked up text and references to separate picture files. Save pictures within the HTML file by selecting one of these formats: PNG, JPEG, SVG, or GIF.</td>
</tr>
<tr>
<td>Interactive HTML</td>
<td>.htm, .html</td>
<td>Saves the data, reports, and graphs in an HTML 5 web page, so non JMP users can explore the data. See “Save the Report as Interactive HTML” on page 353 for more information.</td>
</tr>
<tr>
<td>Joint Photographics Expert Group</td>
<td>.jpg</td>
<td>Compressed bitmap pictures; standard for photographs. See “Setting the DPI” on page 355.</td>
</tr>
<tr>
<td>JMP Journal</td>
<td>.jrn</td>
<td>Analysis report duplicated in a separate window titled Journal. You can edit it or append other reports to it. Note that on Macintosh, select <strong>Edit &gt; Journal</strong>, and then <strong>File &gt; Save</strong>. On Windows, choose <strong>File &gt; Save</strong>, and then choose the journal format.</td>
</tr>
<tr>
<td>JMP Report</td>
<td>.jrp</td>
<td>Analysis report originally created in JMP. It can be reopened for continued analysis.</td>
</tr>
<tr>
<td>Portable Document Format</td>
<td>.pdf</td>
<td>Format for sharing documents regardless of the operating system or application in which they were created.</td>
</tr>
<tr>
<td>Portable Network Graphics</td>
<td>.png</td>
<td>Compressed bitmap pictures; successor to GIF. See “Setting the DPI” on page 355.</td>
</tr>
</tbody>
</table>
Table 10.3 Windows Supported Report File Types  *(Continued)*

<table>
<thead>
<tr>
<th>File Type</th>
<th>Extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rich Text Format</td>
<td>.rtf</td>
<td>Word processing format; mixture of pictures, text, and tables. Save pictures within the RTF file by selecting one of these formats: PNG, JPEG, or EMF.</td>
</tr>
<tr>
<td>Scalable Vector Graphic</td>
<td>.svg</td>
<td>Pictures stored as text; best used for two-dimensional graphics.</td>
</tr>
<tr>
<td>Tagged Image File Format</td>
<td>.tiff</td>
<td>Raster file format. See “Setting the DPI” on page 355.</td>
</tr>
<tr>
<td>Text Format</td>
<td>.txt</td>
<td>Plain text format; no pictures.</td>
</tr>
</tbody>
</table>

**E-mail a Report**

On Windows, you can e-mail a JMP report by selecting File > Send. Your default e-mail application opens with the report file attached to a new e-mail. Note that the report must be saved before you can e-mail it.

**Save the Report as Interactive HTML**

Interactive HTML enables you to share JMP reports that contain dynamic graphs so that even non JMP users can explore the data. The JMP report is saved as a web page that includes interactive HTML 5 features. Users then explore the data as they would in JMP.

Interactive HTML provides a subset of features from JMP:

- Explore interactive graph features, such as selecting histogram bars and viewing data values.
- View data by brushing.
- Show or hide report sections.
Many changes that you make to the graphs, such as ordered variables, horizontal histograms, background colors, and colored data points, are saved in the web page. Graphs and tables that are closed when you save the content remain closed on the web page until the user opens them.

**Interactive HTML Contains Data**

When you save reports as interactive HTML in JMP, your data are embedded in the HTML. The content is unencrypted, because web browsers cannot read encrypted data. To avoid sharing sensitive data, save your results as a non-interactive web page. (Select **File > Save As > HTML File** on Windows, or **File > Export > HTML** on Macintosh.)

To create interactive HTML:

1. In JMP, create the report.
2. On Windows, select **File > Save As** and select **Interactive HTML with Data** from the Save as type list. On Macintosh, select **File > Export > Interactive HTML with Data**.
3. Name and save the file (or export on Macintosh).
   The output appears in your default browser.

**Which Reports are Supported**

When you save a report as interactive HTML, the Save Report As window warns when one or more features in the report are not supported.

- If the contents are fully supported, output is created with no warnings.
Chapter 10
Using JMP

Save as Flash

Certain types of reports can be exported into Flash and saved as a .swf file. You can embed .swf files into Microsoft PowerPoint presentations.

The following platforms support Flash output:

- Distribution
- Profiler
- Bubble Plot

For details, see http://www.jmp.com/support/swfhelp/en/.

Setting the DPI

On Windows, if you are saving the report as a PNG, TIFF, or JPG file, you can set the DPI to either Default or 300. The Default option uses the default setting of your operating system. Select Always use this setting if you want to retain your choice within this session and across multiple JMP sessions.

Save Your Analysis as a Script

After completing an analysis and receiving a report, you might want to save the process that you used to arrive at the report as a JSL script. You can save the script inside the data table, inside the report, or in a separate script window. To do this, click the red triangle menu in the report title and select Script. Then select the Save Script option that you prefer. See “Script Menus” on page 291.

Non-English versions of JMP can save scripts in either English or your local language. See “General” on page 399 in the “JMP Preferences” chapter.

Save Using the Layout Command

You can edit or manipulate the report before you save, enabling you to combine several reports into one or rearrange the report elements. You do this by selecting Edit > Layout. Using this command is different from using the Edit > Journal command; the Layout command
provides additional options that let you ungroup parts of a report and restructure it to best fit your needs.

To create a layout:

1. Select Edit > Layout. (Or hold down the CTRL key and press L.)
   The report window is duplicated in a separate window titled Layout.
   In the Layout window, the Layout menu appears between the Edit menu and the Tables menu. Items in the Layout menu are available only when you select an item with the arrow tool.

2. Click inside the layout window. The entire report becomes highlighted. To show the Layout menu, place your cursor over the bar at the top.

3. Select Layout > Ungroup, or right-click (hold the CTRL key and click on Macintosh) inside the report and select Ungroup.
   This performs the first stage of ungrouping report elements, which ungroups (or disconnects) the topmost title bar from its reports and subreports. Each time you ungroup a report outline level title from its reports, the disclosure button for that level disappears and you can no longer close it. However, you can do many of the surface operations available, use the context menu in plots, customize axes, rerun the analysis in a new window, edit scripts, and so on.

4. Select Layout > Ungroup again to ungroup the next level of the report outline. Note that only selected items are ungrouped.

5. Continue to select specific report elements (or all elements) and ungroup them until each title and each piece of a report or plot is an object.

Note: You can ungroup a report from its title bar and ungroup all of its major pieces, but you cannot ungroup a column in a report table from its column heading.

6. Click an object to select it and move it anywhere in the layout window. The layout window has as many pages as you want, outlined with gray boundary lines.

7. Select File > Save As. JMP saves the file as a journal file (.jrn).

Table 10.4 describes other layout options.

Table 10.4 Working in a Layout Window

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit a title bar</td>
<td>Double-click the title bar or report table column heading.</td>
</tr>
<tr>
<td>Quickly ungroup a layout to</td>
<td>Repeatedly press CTRL and U.</td>
</tr>
<tr>
<td>its smallest objects</td>
<td></td>
</tr>
</tbody>
</table>
Table 10.4  Working in a Layout Window  (Continued)

<table>
<thead>
<tr>
<th>Action</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rerun the report in a new window</td>
<td>Click the red triangle menu on the title bar and select <strong>Rerun in new window</strong> from the menu.</td>
</tr>
<tr>
<td>Edit a script</td>
<td>Click the red triangle menu on the title bar and select <strong>Edit Script</strong> from the menu.</td>
</tr>
<tr>
<td>Access Layout menu items (on the main menu bar)</td>
<td>Select the arrow cursor.</td>
</tr>
<tr>
<td>Insert a page break</td>
<td>This feature applies only to windows that you can print (journals and reports).</td>
</tr>
<tr>
<td>Select and deselect items</td>
<td>Right-click a disclosure button (  on Windows and  on the Macintosh) on the title bar and select <strong>Edit &gt; Select</strong> or <strong>Edit &gt; Deselect.</strong></td>
</tr>
</tbody>
</table>

The example in Figure 10.3 shows results combined and organized from a bivariate analysis, distribution analysis, and one-way analysis (means and $t$-test). The result shows a summary of oxygen uptake as a function of run time in an exercise experiment. This was done by forming a layout window for one analysis, dragging the other desired analysis elements into the layout window, arranging the desired pieces, and deleting unwanted elements.

**Figure 10.3** Multiple Analysis Results in a Layout Window
Save and Share Data
Chapter 10
Using JMP

Save Parts of a Report in a Graphic Format

You can save part of an analysis report window as a graphic. On Windows, you can save the selection in .png, .jpg, .gif, .eps, .emf, .pdf, .tiff, and .svg formats. On the Macintosh, you can save the selection in .png format.

To save a selection:

1. Click the selection tool ( ).
2. Highlight the area that you want to save.
3. On Windows, select Edit > Save Selection As. On Macintosh, hold down the CTRL key and select File > Save Selection As.
   The Save Selection As window appears.

   Figure 10.4 Save Selection As Window

4. Enter the File name for the graphic.
5. Select the graphics file format type to which you want to save the selection. See “Save and Share Reports” on page 351.
6. Select the Image DPI Setting as either Default (72) or 300.

   Tip: You can configure the default DPI setting selection in Windows Specific preferences.
7. To keep your selected DPI Setting for the current session, select Always use this setting.
8. Select Select this filter the next time this window is invoked to save your file type selection for the current session.

   Note: If you cannot see the Select this filter option, select a folder location for saving the graphic file.
9. Click Save.
Print Reports

To print the report in the active window, select File > Print. This command displays the standard window for printing. The appearance of the window depends on your operating system and printer driver.

To insert a page break for printing purposes:

1. Right-click the disclosure button in the report window.
2. Select Edit > Page Break.

Copy and Paste Reports

When you need to use JMP reports or data tables in another program, you can copy and paste or drag and drop parts of a report or table into another program, such as Microsoft Word or PowerPoint. Then save the document in that application.

1. Click the selection tool .
2. Click and drag (or hold down the SHIFT key and click) to select items in a report window or data table. Clicking near the edge of the report window selects the entire report.
3. Click the selected items and drag them from JMP to the other program. Or, copy the selected items in JMP and paste them into the other program. When you paste an element into another application, the format used depends on the application into which you paste. If the application has a Paste Special command and you use it, you can select a format to use, such as text (.rtf), unformatted text (.txt), bitmap (.bmp), or Enhanced Metafile (.emf).

Note the following actions:

- To copy all text (no graphs) from the active report window as unformatted text, select Edit > Copy As Text. On the Macintosh, press the SHIFT key and select Edit > Copy As Text.
- To copy a graph, which includes labels and axes, right-click the graph and select Edit > Copy Graph.
- To copy anything other than a graph, right-click and select Edit > Copy Picture. For example, to copy a report, right-click on the bar containing the report title and select the option.
JMP Journals

Journals consist of JMP graphs and reports, graphics, text, and links to items such as Web pages and files. Using journals has several advantages:

- Journals let you save relevant graphs and reports and then arrange the content as you want.
- Journals let you store information for presentations. You can then edit and interact with the content as you would in JMP (such as scrolling an axis or changing marker sizes). This interactivity is not available in a slide presentation. See “Example of Making a Journal for a Presentation” on page 365 for details.
- Journals are an intermediate format to export to Microsoft Word, HTML, and other formats.
- Journals also let you store data tables and reports from a session, close and reopen JMP, and then open the journaled files instantly.

You can create a journal that groups items under headings (or outline levels). To close the groups, click the gray disclosure icon next to the heading.

Figure 10.5 shows some of the items that you can add to a journal.

**Figure 10.5  Example of a Journal**

![Diagram showing different types of items in a journal]

**Note:** Links to directories of files, windows, and all open files look like other links, so they are not included in the preceding figure.

Create a New Journal

1. Close all open journals, and do one of the following:
   - To create an empty journal, select **File > New > Journal**. Or, from the JMP Starter window, select **New Journal**.
   - To create a journal from an entire report or data table, select **Edit > Journal**.
To create a journal from a specific report or text in a report, click and drag the Selection ( ) tool to select adjacent items in a report or data table. To select discontinuous items, press SHIFT and click the items with the Selection ( ) tool. Then select Edit > Journal.

To create a journal from specific text in a data table, select the text, and then select Edit > Journal.

To create a journal from most graphs, right-click on the graphic, and then select Edit > Journal. (Not available for surface plots and 3-D scatterplots.)

Write a JSL script to create a new journal. See the Scripting Guide for more information.

Tip: If you prefer keyboard shortcuts, hold down CTRL (Windows) or COMMAND (Macintosh) and press J to create the new journal.

2. Select File > Save and save the journal in .jrn format.

Prevent Modifications

When a journal is opened, and then journal another report or data table, the second report or data table is added to the end of the first journal.

To prevent modifications to a journal, right-click the blank area at the bottom of the journal and select Lock. Additional reports are not added to the journal (as described in the following section). JMP instead finds an open unlocked journal or creates a new journal when you select the Edit > Journal command again.

To unlock the journal, right-click the blank area at the bottom of the journal and deselect Lock.

Alternatively, place separate reports in separate layout windows by using the Layout command, as described in “Save Using the Layout Command” on page 355.

Append Reports to a Journal

To append other reports to a report that you already journaled, select Edit > Journal again. If an area of an analysis window is selected, Edit > Journal saves only the selected area instead of the entire window.

When manipulating the report, remember that:

- The journal window has the same functions as the report window: you can click icons, click and drag, and right-click to access menus.
- When a report is journaled, the journaled copy is no longer connected to the data table.
Add and Edit Outline Levels

You can group text and links in an outline level and then click the gray disclosure icon to expand and collapse the group.

**Note:** Links to files have absolute paths. If you move the journal to another location on your computer, the links continue to work. When adding links to files in the JMP sample data folder, use the pathname `$SAMPLE_DATA/xx`. `xx` is the absolute path from the sample data directory. (Right-click the link, select **Edit > Set Script**, and then edit the path.)

- To add an outline level, right-click in the journal, and then select **Append Item > Add Outline Item**. You can also add nested outline levels to outline levels that you have created. (When you click the red triangle menu of a graph that you have journaled, the **Add Outline Item** option is unavailable.) Click the outline level's red triangle menu and select **Add Outline Item**.
- To edit the outline level heading, double-click the heading, enter the new name, and press **Enter**.
- To add text or links within an outline level, click the outline level's red triangle menu and select an option described in Table 10.5. Note that these options are not available when you click a scripted item's red triangle menu.
- To add text or links outside an outline level, right-click on the journal and then select one of the options described in Table 10.5.
- To edit a link, right-click the link, select **Edit > Set Script**, edit the path, and then click **OK**.
- To edit the name of the link displayed in the journal, right-click the link, select **Set Button Name**, enter the new name, and then click **OK**.

**Tip:** In Windows, show the preceding options by holding down the ALT key and right-clicking the outline level's gray disclosure icon.

### Table 10.5 Journal Item Options

<table>
<thead>
<tr>
<th><strong>Add Outline Item</strong></th>
<th>Groups text and links into collapsible and expandable lists.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Add Text Item</strong></td>
<td>Enter up to six paragraphs with the option to add a bullet or hide the text. To unhide, right-click the hidden text and deselect <strong>Hide</strong>.</td>
</tr>
<tr>
<td><strong>Note:</strong> To add text outside an outline level, you can also double-click at the end of the journal and enter text in the box that appears. Click outside the box to exit the editing mode.</td>
<td></td>
</tr>
<tr>
<td><strong>Add Window Reference</strong></td>
<td>Creates a link to a window already opened in JMP.</td>
</tr>
</tbody>
</table>
Chapter 10
Using JMP

Save and Share Data
JMP Journals

Table 10.5 Journal Item Options (Continued)

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add File Reference</td>
<td>Creates a link to a file on your computer.</td>
</tr>
<tr>
<td>Add Directory of Files</td>
<td>Creates links to all files (including non-JMP files) in the selected directory.</td>
</tr>
<tr>
<td>Add All Open Files</td>
<td>Creates outline levels and links to open files in JMP (except for the log). For example, a link to the open Big Class.jmp data table and chart is displayed below a collapsible heading named Big Class. Files such as journals, scripts, and tutorials are grouped below a collapsible heading called Other Files.</td>
</tr>
<tr>
<td>Add URL Reference</td>
<td>Creates a link to files that are delivered through an Internet protocol such as HTTP, FTP, or FILE://</td>
</tr>
<tr>
<td>Add Script Button</td>
<td>Creates a link to a JSL script.</td>
</tr>
</tbody>
</table>

Control the Display of Outline Levels

You can instantly control which outline levels are displayed (for example, closing all sublevels below the selected level). Click the red triangle menu for that level, select OutlineBox, and then select one of the Open or Close commands. For details about the Open and Close commands, see “Access Report Display Options” on page 288 in the “JMP Platforms” chapter.

Tip: On Windows, show the OutlineBox options by holding down the ALT key and right-clicking the outline level's gray disclosure icon.

Add a Graph or Graphic

Do one of the following:

- Copy a graph from within JMP or a graphic from another application and then select Edit > Paste. JMP places the graphic at the end of the journal.
- Drag and drop the graph or graphic from another window to the journal. (See “Add Graphics” on page 337 in the “JMP Platforms” chapter.) A blue line indicates where you can drop the graphic.

Customize Journal Items

- To click and drag journal items to different positions, select the selection tool ( ), select the item, and then drag the item to the new position. A line indicates where you can drag the item.
• To adjust text wrapping, right-click the text and select Set Wrap. Enter the number of desired pixels per line and click OK. To apply the wrap to all text items, select Set Wrap, select Extend this to other text boxes, and then click OK.

• To modify a plot axis, double-click or drag the axis. See “Customize Axes and Axis Labels” on page 320 in the “JMP Platforms” chapter.

• To add text or shapes anywhere in the report, use the drawing tools (Annotate, Line, Polygon, and Simple Shape). For details about the drawing tools, see “Add Graphics Elements to a Report” on page 333 in the “JMP Platforms” chapter.

• To resize plots and graphs, do one of the following:
  – Click and drag the edge.
  – Right-click the plot or graph, and then select Size/Scale > Frame Size. See “Resize Plots and Graphs” on page 316 in the “JMP Platforms” chapter.

Save the Journal in Another Format

You can save a journal in another format (such as HTML or PDF). When you save the journal as HTML, buttons and links are active when the file is viewed in a Web browser.

Note: The header and footer defined in your printer setup appears in the PDF file. However, you can set the left, center, and right header and footer in a JSL script. For more information, search for the Set Print Footers message in the JMP Scripting Index. (Select Help > Scripting Index in JMP.)

Windows
1. Select File > Save As.
2. Select the format. See “Save and Share Reports” on page 351.
3. Click OK.

Macintosh
1. Select File > Export.
2. Select the format. See “Save and Share Reports” on page 351.
3. Click Next.
4. Enter a name for the file in the Save As box.
5. Click Export.

Print a Journal

Select File > Print.
Delete Items from a Journal

1. Click the selection tool ( ).
2. Select the item that you want to delete and press DELETE.

Example of Making a Journal for a Presentation

Most people use a presentation application like PowerPoint to give presentations. With JMP journals, you can avoid using a presentation application: all your bullet points can be combined with live links and buttons to help automate the analyses that you want to show. Interactivity is also maintained in reports.

Follow this example to create a presentation using a journal.

2. Right-click in the journal. Start your outline by selecting Add Outline Item.
3. Enter the title of the presentation “My Bivariate Demo.”

Figure 10.6 Add an Outline Item

A presentation should have outline nodes, which are nested, opened, and closed in sequence, as you give the presentation.

4. Add bullet points into the outline by clicking the red triangle in the My Bivariate Demo title bar and selecting Add Text Item.
5. Type the text shown in the following figure.
6. Select the Bullet Point check box and click OK.
Now add a window reference as a link. These links let you open a file with one click during the presentation.

7. Open the Big Class.jmp sample data table.
8. Click the red triangle in the My Bivariate Demo title bar and select **Add Window Reference**.
9. Select Big Class and click **OK**.

**Figure 10.8 Add Window Reference**

10. Click the window reference to verify the link.
11. Display the window reference as a button by right-clicking the link and deselecting **Underline Style**.
Save JMP Sessions

Each time you use JMP is called a session. A saved session is a JSL script that re-opens documents and re-runs analyses to restore JMP’s state when the session script was saved. A saved session can help get you back to a previous state without having to manually re-open files and re-run analyses.

If you are an advanced user, it is important to understand what session information is preserved in a saved session. Any documents (such as data tables, scripts, and journals) that have been saved are re-opened. JMP windows that support script saving are re-run (equivalent to clicking the red triangle in a report and selecting Script > Redo Analysis). Side effects of running scripts, such as global variable values or custom windows, are not saved. The state of highly interactive analyses is also not saved.

Save Sessions Upon Exiting

The most common use of saved sessions is to save the state when JMP exits so it can be restored when JMP restarts. By default, JMP asks whether you would like to save the state of your session each time you exit the program (Figure 10.10). This enables you to quit JMP, and then return to it later without having to open the files with which you were previously working.

Figure 10.10  Saving Session Upon Exiting

To always save the session upon exiting, select Do not ask me again about saving the session and click Yes or No. This option also prevents JMP from saving the session upon exiting.

You can change this option later in Preferences:
1. Choose File > Preferences.
2. Select the General icon.
3. Next to the Save the session when exiting option, choose when you want JMP to save the session. Always, never, and prompt whether you want to save are the options.

Save Sessions Manually

You can also save a session to a location of your choosing and continue working, so you can restore the saved state whenever you like. Manually saving sessions is useful when you want more control of session saving and restoring. This option is especially helpful when you want to maintain multiple independent session states, each with a different set of files and analyses.
Save and Share Data

JMP Projects (Windows Only)

To create a script of a JMP session:
1. Select File > Save Session Script.
2. Enter the name of your script in the window and click Save.

Another way of manually saving a session is by creating a journal of each session. A journal can be a notebook-style or project-style file. With it, you can collect references to files in a project, develop presentation launch pads, document projects, and store many scripts in one place. See “JMP Journals” on page 360 for details.

To create a journal of a JMP session:
1. Open the files that you would like to include in the journal.
2. Select File > New > Journal. Or, to append your open files to an existing journal, open that journal.
3. Right-click in the empty journal and select Add All Open Files.

JMP Projects (Windows Only)

A JMP Project is useful when you want to save multiple JMP file types (data tables, reports, scripts, or other JMP supported formats) into a single file. The single JMP project file contains everything needed to re-open all the included files. This is its major difference from saved session scripts. The scripts save the state of the software and the projects save the state along with the files.

Projects can also include non-JMP documents (such as Microsoft Word or Adobe PDF files). This option lets you group and quickly open files.

Note: Though you can script and open projects on Macintosh, this section only covers working with projects on Windows.

Create a JMP Project

To create a new project, click on the black book icon in the Projects pane. Or, select File > New > Project. The new project appears in the Projects pane of the JMP Home Window. If the Projects pane is closed, the Project window appears instead.
To name the project, right-click the project name, select **Rename**, enter the name, and then press ENTER.

**Save a JMP Project**

After you create and name a project, save it using one of the following methods:

- Right-click the project name in the Projects window and select **Save “project name”**.
- Select the project name and click the **Save Selected Project** button on the Projects window toolbar.
- In another open JMP window (such as the JMP Home Window), select **File > Save Projects**.

When you save a project, JMP creates a compressed file with the `.jmpprj` extension and saves a copy of each item in the project. You actually modify the archived items rather than the originals. Other JMP users on Windows and Mac can then open the project on their computers, and the links remain intact.

JMP maintains the links by creating a folder structure that mirrors the location of the original files. Say that you save a project in the following folder:

C:\MyProjects

The project has a link to the `MyDataTables` folder.

When you open this project, JMP creates the following file structure in the project’s subdirectory:

C:\MyProjects\Project Name Dependencies\C\MyDataTables
At times, you might want to continue to modify the original files rather than the archived copies. Here are some examples:

- When you add a file to multiple projects, you are actually modifying three different copies of that file. If sales figures in one of the files need to be updated, you must update three different copies of that file.

- When you add files to a project from a network drive, you and other JMP users can edit those files without having to open the JMP project file.

In these instances, turn off archiving by right-clicking the project in the Projects window and deselecting **Archive all files and folders when project is saved**.

When you save a project, JMP notifies you when files in the project archive are not found. See “Fix Broken Links” on page 372 for details about fixing the links.

**Close a JMP Project**

To close a project, right-click the project name and select **Close**.

**Open a JMP Project**

On Windows, open a project by selecting **File > Open** and selecting **JMP Projects** from the list next to **File name**. The file also shows up in the JMP Home Window Recent Files list if you previously opened it with the **File > Open** command or the **Open** toolbar button.

On Macintosh, open a project by selecting **File > Open** and selecting the file. Though there is no project window on Macintosh, the files that are set to open or run automatically appear.

**Add Items to a JMP Project**

You can add either saved or open files to a JMP project. If a file has not already been saved, you are prompted to save it before it can be added to the project. You can drag and drop files from the Home Window into a project.

**Project Menu**

To add items using the **Project** menu, right-click on the project name in the Projects window and select the desired command.

- **New Group**  Adds a collapsible and expandable container that organizes related items.

- **Add Window**  Opens a window that lets you select which open JMP window to add to the project. If the contents of the window has not been saved, you are prompted to do so before the window is added to the project.
Add Document  Adds a copy of a file (if the archiving option is turned on) or a link to the file (when the archiving option is turned off). After selecting this option, the standard File Open window appears.

Add Folder   Adds a Windows folder to the project. You browse to select the folder from your computer.

Add Database Query   Opens the JMP database query Window, where you can create or open a query to a database. This query is then added to the project. For detailed information about creating queries, see “Import Data from a Database” on page 103 in the “Import Your Data” chapter.

Add URL  Opens the Internet Open window, where you specify a URL to add to the project. Select an option from the Open As list to specify how JMP opens the file.

Add SAS Stored Process   Lets you add a SAS Stored Process. If you are not connected to a SAS Metadata Server, you are either connected to the server using your saved profile, or the SAS Server Connection window is opened for you. Once you are connected, you can select the SAS Stored Process to add to the project. See “Run Stored Processes” on page 95 in the “Import Your Data” chapter.

Add All Windows   Adds links to all open windows.

Drag and Drop Files

With the Projects window open, you can drag and drop files into a project from the following programs:

- Windows Explorer
- Microsoft Outlook (such as e-mails, attachments, notes, and calendar entries)
- JMP windows (Hold down the CTRL key, click the title bar, and drag the window to the project.)

Drop the files onto the project name inside the window, not into the empty space.

Customize the Project

JMP has several commands that let you organize and customize your project.

Open Files

When you open a project, JMP can automatically open most files or run scripts in that project. To open all files or run scripts or database queries automatically, right-click the project name and select When project is reopened > Restore all items in the project.
To open or run specific items automatically, do the following:

1. Right-click each file that you want to open or run and select **Restore this item when the project is opened**. The name of the options depends on the file type. For documents, the option is named **Restore this document when the project is opened**. For windows, the option is named **Restore this window when the project is opened**.

2. Right-click the project name and select **When project is reopened > Restore only marked items**. (This is the default project setting.)

Though you cannot create a project on Macintosh, you can open files in a project if you set the files to open automatically.

**Note:** Be careful setting *all* items to open automatically. When you add a folder full of files, opening all of those files might cause a delay.

When you double-click a file in a project, most files open in their default programs. For example, data tables, journals, and scripts open in JMP. Graphics open in your default graphics program. Files that can be imported into JMP (such as Excel files or SAS data sets) are opened based on your text import preferences.

You can also choose how to open a file by right-clicking it and selecting an option. The options differ based on the file type. For example, files that are imported as data have text import options, or you can open them outside of JMP.

**Groups**

Adding a group to a project lets you organize files into collapsible and expandable containers. To add a new group, right-click on the project and select **New Group**. You can add files by right-clicking on the new group, or you can drag and drop existing files into the group.

**Notes**

JMP enables you to add descriptive notes about a project. Select the **Edit Notes** command from the **Project** menu to add or edit a project's notes. The notes are shown in the project properties. Right-click the project name and select **Properties** to view the notes.

**Fix Broken Links**

When you save a project, JMP warns you if the link to a file is broken.

To fix a broken link:

1. Click **No** on the broken link warning window.
2. In the Projects window, right-click the affected file, and select **Fix Broken Link**.
3. Browse to find the file.
4. Click OK.

**Save a Log Window**

Selecting View > Log displays a window that monitors JMP activities, such as JSL statements as they execute and script errors. You might also encounter instances where running a formula, matrix, or another operation writes information of interest to the log window.

*To save a log:*

1. Open the Log window.
2. Select File > Save As.

**Note:** (Windows only) To open the log automatically when text is added to it, select File > Preferences > Windows Specific. In the Open the JMP Log window list, select whenever text is added.
This chapter describes how to customize JMP menus and toolbars to show only the commands that you need. For example, you might remove the SAS option in the File menu if you do not use SAS. Or you might assign a shortcut key to the Run Script command.

Customizing JMP also lets you set up JMP for groups with special interests. If one group does not design experiments, you could remove DOE from the JMP menu.

Another way to customize JMP is to write add-ins to extend JMP’s functionality. An add-in can be any scriptable option. For example, you could add a Graph menu option that opens two data tables included in the add-in and runs a script to produce a bubble plot.
Contents

Personalize Toolbars and Menus on Windows ................................................................. 377
  Create Toolbars ........................................................................................................... 380
  Create Main Menus ...................................................................................................... 382
  Create Menu Items and Toolbar Buttons ................................................................. 383
  Rearrange Toolbars ................................................................................................... 386
  Copy and Paste Menus, Menu Items, Toolbars, and Buttons ................................. 387
  Rearrange Custom Menus, Menu Items, and Buttons ............................................. 389
  Delete Custom Items ................................................................................................. 390
  Show and Hide Items ................................................................................................. 391
  Import Customizations .............................................................................................. 392
  Remove Customizations ............................................................................................ 392

Personalize Toolbars on Macintosh ............................................................... 393

JMP Add-Ins .................................................................................................................. 395
  Manage JMP Add-Ins .................................................................................................. 395
Personalize Toolbars and Menus on Windows

Toolbars consist of buttons that execute commands and dividers that help you organize the buttons. In Windows, there are many ways to personalize toolbars. For example, you can create, rename, hide, and modify toolbars or buttons. You can also rearrange or delete toolbars and buttons that you create.

Menus consist of commands, submenus, and separators. As with toolbars and buttons, you can create, rename, hide, and modify menus. You can also rearrange or delete menus and menu items that you create.

You personalize toolbars and menus in the Menu Editor. The names of modified items are formatted to indicate which items were created, modified, or hidden, and which items are unsaved, as shown in Figure 11.1.

Figure 11.1 Menu Editor Options
Change Customization Sets

JMP gives you the flexibility to specify which users see your customized toolbars and buttons. Your changes are saved in a text file with the .jmpcust extension called a customization set. By default, your customizations are shown only to the current user; other users who log on to the computer and open JMP do not see your personal toolbars and menus.

All customization sets include the built-in JMP buttons and menus. You can also base customization sets on other customization sets. For example, you might create a new customization set that shows the JMP add-in menus and toolbars along with your modifications.

When you modify the Current user customization set, JMP creates a backup file of the set. The file is located in your Windows Users folder within the JMP or JMPPro folder.

C:\Users\<user name>\AppData\Local\SAS\JMP\<version number>\*

When you modify the All users customization set, JMP creates a backup file of the set. The file is located in the Windows All Users folder within the JMP or JMPPro folder.

C:\Users\All Users\SAS\JMP\<version number>\*

The All Users folder does not appear when you try to browse for it, so you must type the path into the Windows Explorer address field.

Note: To find the customization set files in Windows Explorer, show all hidden files in the Windows Explorer Folder Options. See your operating system documentation for details.

To change the customization set:

1. Select View > Customize > Menus and Toolbars.
   The Menu Editor appears.
2. Click Change.
   When you try to change the customization set, and changes to the selected set are not saved, you are prompted to save the changes. Click Save Changes.
3. Select the customization set in the Customization Set to Modify area. (By default, changes apply only to the Current user customization set.) Table 11.1 describes the options.
4. (Optional) To change the set on which the selected customization set is based, select the set in the Starting Set area. (Not available for the All users customization set.) Table 11.1 describes the options.
5. Click OK.
### Table 11.1 Customization Set Options

<table>
<thead>
<tr>
<th>Customization Set to Modify</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Current User</strong></td>
<td>Only you see the changes. The customization file is called <code>usercust.jmpcust</code>. Modifying this file manually might cause unexpected results.</td>
</tr>
<tr>
<td><strong>All users</strong></td>
<td>All users who open JMP on the computer see the changes. The customization file is called <code>admincust.jmpcust</code>.</td>
</tr>
<tr>
<td><strong>JMP Add-In</strong></td>
<td>Those who use the selected JMP Add-in, and select <strong>JMP Add-In customizations</strong> as the <strong>Starting Set</strong>, see the changes. When you modify the customization set for a disabled add-in, those changes do not appear until you enable the add-in.</td>
</tr>
<tr>
<td><strong>Other file</strong></td>
<td>Changes appear when the selected <code>.jmpcust</code> file is chosen as the customization set. You create this file in a text editor.</td>
</tr>
<tr>
<td><strong>New</strong></td>
<td>Changes appear when this new customization is selected. (After you make your changes, click <strong>Save</strong> to name the new file in the selected folder.)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Starting Set</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>JMP built-in items</strong></td>
<td>The selected customization set is based on the default JMP toolbars and menus. (Applies to all customization sets and cannot be deselected.)</td>
</tr>
<tr>
<td><strong>All Users customizations</strong></td>
<td>The selected customization set is based on the <strong>All users</strong> customization set. (Available for the <strong>Other file</strong> or <strong>New</strong> customization sets. Cannot be deselected from the <strong>Current user</strong> customization set.)</td>
</tr>
<tr>
<td><strong>JMP Add-In customizations</strong></td>
<td>The selected customization set is based on the JMP Add-In customizations. The add-in customizations are typically installed with the add-in. (Available for all customization sets except for <strong>All users</strong>.)</td>
</tr>
<tr>
<td><strong>Current User customizations</strong></td>
<td>The selected customization set is based on the <strong>Current user</strong> customization set. (Available only for <strong>Other file</strong> and <strong>New</strong> customization sets.)</td>
</tr>
</tbody>
</table>
Create Toolbars

JMP includes toolbars that you can add new buttons to, or you can create your own toolbars. Table 11.2 describes the toolbars.

Table 11.2 JMP Toolbars

<table>
<thead>
<tr>
<th>Toolbar</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File_Edit</td>
<td>Shows icons for commands found in the <strong>File</strong> and <strong>Edit</strong> menus. The <strong>Debug Script</strong> button on the end of the toolbar is active only where you run scripts: in the Script window and JSL Debugger.</td>
</tr>
<tr>
<td>Analyze</td>
<td>Shows icons for commands found in the <strong>Analyze</strong> menu.</td>
</tr>
<tr>
<td>Graph</td>
<td>Shows icons for commands found in the <strong>Graph</strong> menu.</td>
</tr>
<tr>
<td>Tools</td>
<td>Shows icons of tools that you can click and use as your cursor. In some windows, the toolbar is hidden. A blue line appears instead. Hover your cursor over the blue line to show the toolbar.</td>
</tr>
<tr>
<td>Data_Tables_List</td>
<td>Shows a list of open data tables. You select a data table in this list to make it the current table. Note that the current table is not necessarily the front window. To bring a table (or any window) to the front, select its name from the list in the <strong>Window</strong> menu.</td>
</tr>
<tr>
<td>Tables</td>
<td>Shows icons for commands in the <strong>Tables</strong> menu.</td>
</tr>
<tr>
<td>DOE</td>
<td>Shows icons for commands in the <strong>DOE</strong> menu.</td>
</tr>
<tr>
<td>SAS</td>
<td>Shows icons for accessing and browsing SAS data and folders.</td>
</tr>
</tbody>
</table>
Using JMP Personalize Toolbars and Menus on Windows

Create your own toolbars for frequently used commands that are not included in the default toolbars. You assign a command to the button and can add other properties such as shortcut keys, icons, and JMP Scripting Language (JSL) scripts.

When you want to create a toolbar based on an existing toolbar, make a copy of the existing toolbar and then change settings as necessary. See “Copy and Paste Menus, Menu Items, Toolbars, and Buttons” on page 387 for details.

**Step 1: Create the Toolbar**

1. Select **View > Customize > Menus and Toolbars**. The Toolbars list appears on the left.
2. (Optional) Change the customization set to control which users see your customizations. See “Change Customization Sets” on page 378 for details.
3. With the Menu Editor still opened, right-click one of the toolbars, such as **File>Edit**. Select any toolbar, because all new toolbars appear at the end of the Toolbars list.
4. Select **New Toolbar**. The toolbar is inserted at the end of the list. The toolbar includes an untitled button, because all toolbars must have at least one button.

**Step 2: Specify the Caption and Internal Name**

Toolbars have several basic properties:

- The caption appears in the **View > Toolbars** list, which lets you show or hide the toolbar. Give each toolbar a unique name. JMP merges toolbars with the same name after you close and reopen the Menu Editor.
- The internal name, which is case insensitive. JMP identifies the location of an item by its internal name rather than its caption.

To specify these toolbar properties, follow these steps:

1. With the Menu Editor still opened, select the toolbar.

---

**Table 11.2 JMP Toolbars (Continued)**

<table>
<thead>
<tr>
<th>Toolbars</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Home</strong></td>
<td>Shows frequently used icons from the File and Edit menus along with icons for opening the JMP Starter window and filtering data.</td>
</tr>
<tr>
<td><strong>Application Builder</strong></td>
<td>Shows icons for commands in the Application Builder.</td>
</tr>
</tbody>
</table>

Create your own toolbars for frequently used commands that are not included in the default toolbars. You assign a command to the button and can add other properties such as shortcut keys, icons, and JMP Scripting Language (JSL) scripts.
The General properties appear on the right.

2. Enter the internal name next to Internal name.

3. Enter a unique name for the toolbar or button in the Caption box.

4. (Optional) To specify the translation for the caption, do the following:
   - Click the Localize button for the item that you want to customize.
   - Select the language.
   - Enter the translation next to Text.
   - Click OK.

5. (Optional) Click Hidden to keep the toolbar hidden after creation.

6. Customize the untitled button as described in “Create Menu Items and Toolbar Buttons” on page 383.

7. Click Save to save your changes.

Create Main Menus

On Windows, you can add your own menus to the main menu bar in JMP. These menus appear before or after menus such as File, Edit, and Tables. An untitled command is inserted automatically in the menu, because all menus must have at least one command.

When you want to create a main menu based on an existing menu, make a copy of the existing menu and then change settings as necessary. See “Copy and Paste Menus, Menu Items, Toolbars, and Buttons” on page 387 for details.

To create a main menu:

1. Select View > Customize > Menus and Toolbars.
   
   The Main Menu list appears on the left.

2. (Optional) Change the customization set to control which users see your customizations. See “Change Customization Sets” on page 378 for details.

3. Right-click the menu next to which you want to add a new menu.

4. Select Insert Before or Insert After.
   
   An untitled menu and a menu item are added to the list.

5. Complete “Step 2: Specify the Caption and Internal Name” on page 381 to rename the main menu.

6. Customize the menu item as described in “Create Menu Items and Toolbar Buttons” on page 383.

7. Click Save to save your changes.
Create Menu Items and Toolbar Buttons

Menus consist of the following menu items:

- Commands are the items that you click to execute a command (such as Data Table and Script).
- Submenus are menu items that you click to reveal more menu options. An example of submenu is New inside the top-level File menu. New is also a submenu because it contains commands (such as Data Table and Script).
- Separators are lines that divide or group commands and submenus.

The button on a toolbar is considered a type of command, so you also complete the following steps to create new toolbar buttons.

When you want to create a menu item or button based on an existing item, make a copy of the existing item and then change settings as necessary. See “Copy and Paste Menus, Menu Items, Toolbars, and Buttons” on page 387 for details.

Step 1: Create a New Menu Item or Button

1. Select View > Customize > Menus and Toolbars.
   The Menu Editor appears.
2. (Optional) Change the customization set to control which users see your customizations. See “Change Customization Sets” on page 378 for details.
3. Right-click where you want to add the menu item or button.
   A list of possible locations appears.
4. Select Insert Before or Insert After.
   The Specify Type window appears.

5. Do one of the following:
   - To create a button, select Command.
   - To create a menu within a menu, select Submenu. (Not available for buttons.)
   - To create divider between menu items or toolbar buttons, select Separator.
6. Click OK.
   The new untitled button, submenu, or separator is added.
Step 2: Specify the Caption, Tooltip, and Internal Name

Buttons have several basic properties:

- The caption appears in the View > Toolbars list, which lets you show or hide the toolbar. Give each toolbar a unique name. JMP merges toolbars with the same name after you close and reopen the Menu Editor.
- The tooltip appears when you place the cursor over a menu item or button.
- The internal name, which is case insensitive. JMP identifies the location of an item by its internal name rather than its caption.

Menu items include the same properties, but the tip does not appear in JMP.

To specify these properties, follow these steps:

1. With the Menu Editor still opened, select the menu item or button. The General properties appear on the right.
2. Enter the internal name next to Internal name.
3. Enter a unique name for the menu item or button in the Caption box.
4. Enter a description for button in the Tip box.
5. (Optional) To specify the translation for the caption or tip, do the following:
   - Click the Localize button for the item that you want to customize.
   - Select the language.
   - Enter the translation next to Text.
   - Click OK.
6. Customize the untitled button or menu item as described in the following procedure.

Step 3: Assign Functionality

Clicking a menu item or button either executes a predefined command or runs a JSL script. The script can be stored in a separate file, or you can enter the JSL in the Run this JSL area of the Menu Editor. If users have access to a central location, such as a network, you typically want to run the script from that location. This also simplifies giving users access to updated scripts. Otherwise, store the JSL in the menu item or button definition.

To associate a menu item or button with an add-in JSL script, you have two options:

- Select Run JSL in this file, and then browse to find the external file.
- Type the relative path to the JSL script, and select the add-in from the Use add-in home folder list. For example, the following command runs the mds_application.jsl script from the selected add-in:

\$$ADDIN\_HOME(com\_jmp\_mdswithr)\mds\_application.jsl$$
In addition, you can select **Use the “Here” namespace for unqualified JSL variable names** if you include namespaces in the internal or external JSL script. See the *Scripting Guide* book for details about namespaces.

To assign this functionality, follow these steps:

1. With the Menu Editor still opened, select the menu item or button that you want to modify.
   The Action properties appear on the right.
2. Select the action that you want to execute.
3. To run an internal JSL script, delete the placeholder text `print("Not implemented.");` in the **Run this JSL** area and enter the JSL.
4. (Optional) If your internal or external JSL script includes namespaces, click **Use the “Here” namespace for unqualified JSL variable names**.
5. Click **Save** to save your changes.

**Step 4: Show an Icon on the Menu Item or Button (Optional)**

New menu items have no icon next to the item. New buttons show up as blue squares on the toolbars. You can assign a descriptive icon to the menu item or button. The graphic can reside on your computer or in an add-in folder. .ico, .png, .jpg, and .bmp graphics are supported.

Assigning an icon to a button is particularly important. Otherwise, the user must view the button’s tooltip to see what the button does.

To show an icon on the menu item or button, follow these steps:

1. With the Menu Editor still opened, select the menu item or button.
   The Icon properties appear on the right.
2. Select one of the following options:
   - **None**: Select this option to show a blue square instead of an icon.
   - **Built-in icon**: Select this option to show an icon that JMP provides, and then select the icon from the list.
   - **Use image from file**: Select this option to show an image that you created. Click **Browse**, select the graphic, and then click **OK**. You can also use an icon defined in an add-in. Select **Use add-in home folder**, and then select the add-in.
3. Click **Save** to save your changes.

**Step 5: Assign a Shortcut Key (Optional)**

A shortcut key executes an action so that you do not have to select the menu item or click the button on the toolbar. This option is also helpful when the button’s toolbar is not shown, but you still want to execute the action.
Shortcuts begin with CTRL, CTRL+SHIFT, CTRL+ALT and end with a number, letter, or symbol that appears on the keyboard. The Function keys (such as F1) are also supported. Many CTRL + letter and Function shortcuts are already assigned in JMP, but you can reassign them to your buttons if you want.

Shortcut keys appear in menus next to each menu item.

To assign a shortcut key, follow these steps:

1. With the Menu Editor still opened, select the menu item or button.
   The Shortcuts properties appear on the right.
2. Do one of the following:
   - To assign a new shortcut, click in the New shortcut area and press the shortcut keys. If the keystrokes then appear in the Currently assign to box, press another combination of shortcut keys. (You do not have to delete the keystrokes before pressing the shortcut keys.)
   - To change a shortcut that you previously specified, click Remove, click in the New shortcut area and press the shortcut keys.
3. Click Assign.
   The shortcut appears in the Current shortcuts list.
4. Click Save to save your changes.

To remove a shortcut, select the shortcut and click Remove.

Figure 11.3 shows examples of a completed toolbar, menu, and submenu.

**Figure 11.3** Examples of Buttons and Menu Items in the Menu Editor

---

**Rearrange Toolbars**

On Windows, there are two ways to rearrange toolbars:

- To rearrange toolbars quickly for the current user, drag the toolbar above, below, to the left, or to the right of the adjacent toolbar.
To specify the new location rather than drag the toolbar, right-click the toolbar and select a position from the **Location** menu. This method lets you move toolbars to the top or bottom of the window. You can also position the toolbars vertically on the left or right side of the window.

In some windows, the toolbar is hidden by default. Specifying a new location shows the toolbar in all windows of that type. On Windows, you can change the toolbar preferences to always show toolbars. See “Windows Specific” on page 421 in the “JMP Preferences” chapter.

To drag a toolbar:

1. Click the left corner of the toolbar until the Move cursor appears.
2. Drag the toolbar to the new location. When a toolbar is too wide to show completely, click the arrow to show all of the buttons, as shown in Figure 11.4.

**Figure 11.4** Expanding a Toolbar

To position the toolbar:

1. Right-click the toolbar that you want to move.
2. Select **Location**, and then select the new position.

**Note:** After you move a toolbar to the left, right, or bottom positions, you can add other toolbars to the same position. For example, you might relocate the File Edit toolbar to the right side of the JMP window. To add other toolbars on the right side, right-click the bar and select the toolbar that you want to add.

**Copy and Paste Menus, Menu Items, Toolbars, and Buttons**

Copying existing items is a shortcut to creating new items in a menu or toolbar. This option lets you change only a few settings in the new item when possible.

To copy and paste menus and menu items:

1. Select **View > Customize > Menus and Toolbars**.
   
   The Menu Editor appears.

2. (Optional) Change the customization set to control which users see your customizations. See “Change Customization Sets” on page 378 for details.

3. Right-click the menu or menu item that you want to copy and select **Copy**.
4. Right-click the menu or menu item before, after, or into which the item will appear and select Paste.

One of the following occurs:
- A list of possible locations appears.
- The menu or menu item appears below the selected item. Skip to step 7.

5. Select the location of the menu by doing one of the following:
- To paste the item before the selected menu, select Paste before.
- To paste the menu after the selected menu, select Paste after.
- To paste the menu inside the selected menu, select Paste into. (Only available when you select a menu as the new location.)
- To cancel the action, select Cancel.

The item appears as you indicated.

6. Modify the item.

7. Click Save to save your changes.

See “Create Main Menus” on page 382 and “Create Menu Items and Toolbar Buttons” on page 383 for details about modifying the items.

To copy and paste toolbars and buttons:

1. Select View > Customize > Menus and Toolbars.

   The Menu Editor appears.

2. (Optional) Change the customization set to control which users see your customizations.
   See “Change Customization Sets” on page 378 for details.

3. Right-click the toolbar or button that you want to copy and select Copy.

4. Do one of the following:
   - To paste a toolbar, right-click Toolbar and select Paste. The toolbar appears at the end of the list of toolbars.
   - To paste a button, right-click the button before or after which you want the new button, and select Paste. If you selected the first button on the toolbar, select the location of the button. Otherwise, the button is pasted below the selected button.

5. Modify the item.

6. Click Save to save your changes.

See “Create Toolbars” on page 380 and “Create Menu Items and Toolbar Buttons” on page 383 for details about modifying the items.
Rearrange Custom Menus, Menu Items, and Buttons

On Windows, you can rearrange the order of menus, menu items, and buttons that you create. For example, under the File > New menu, you could move your custom menu before the Data Table command.

In the item’s General properties, the Source determines whether you can move the item. You can move items if the Source is Custom Item. Built-in items cannot be moved. Items that are defined in other customization sets can be moved only in that customization set. See “Change Customization Sets” on page 378 for details.

**Note:** The right-click menu has options for cutting and pasting items. To cut an item, you can also hold down the CTRL key and press X, or hold down the SHIFT key and press DELETE. To paste, hold down the CTRL key and press V, or hold down the SHIFT key and press INSERT.

To rearrange custom menus and menu items:

1. Select View > Customize > Menus and Toolbars.
   The Main Menu list appears on the left.
2. Do the following:
   - Select the item that you want to move.
   - Verify that the Source is Custom Item.
   - If the Source is All Users or JMP Add-In, select the specified customization set and verify that the Source is Custom Item.
3. Right-click the custom menu or menu item that you want to move and select Cut.
4. Right-click the new location of the cut item and select Paste.
   One of the following occurs:
   - A list appears with the possible locations of the cut item. This occurs when you select a menu (such as File or New) or the first item in a menu (such as Data Table in the File > New menu).
   - The cut menu item appears below the selected menu item. Skip to step 6.
5. Select the location of the cut item by doing one of the following:
   - To paste the cut item before the selected item, select Paste before.
   - To paste the cut item after the selected item, select Paste after.
   - To paste the cut item inside the selected menu, select Paste into. (Only available when you select a menu as the new location.)
   - To cancel the move, select Cancel.
   The item appears as you indicated.
6. Click **Save** to save your changes.

**To rearrange custom buttons:**

1. Select **View > Customize > Menus and Toolbars.**
   The Toolbars list appears on the left.

2. Do the following:
   - Select the custom button that you want to move.
   - Verify that the Source is *Custom Item*.
   - If the Source is *All Users* or *JMP Add-In*, select the specified customization set and verify that the Source is *Custom Item*.

3. Right-click the custom button that you want to move and select **Cut**.

4. Right-click the new location of the cut button.
   One of the following occurs:
   - A list appears with the possible locations of the cut button. This occurs when you select the first button on the toolbar (such as **New Data Table** in the **File_Edit** toolbar).
   - The button is pasted at the end of the toolbar. This occurs when you select the name of the toolbar. For example, when you select **File_Edit** and paste, the button appears after the last button, **Run Script**. Skip to step 6.
   - The cut button appears after the selected button. Skip to step 6.

5. Select the location of the cut button by doing one of the following:
   - To paste the cut button *before* the selected button, select **Paste before**.
   - To paste the cut button *after* the selected button, select **Paste after**.

6. Click **Save** to save your changes.

**Delete Custom Items**

Rather than temporarily showing or hiding toolbars, buttons, menus, and menu items, you can delete items that you created to remove them permanently from JMP. The Source determines whether you can delete the item and which customization set contains the item. Figure 11.5 shows examples of customization Source types.
Figure 11.5 Examples of Customization Sources

Empty menus are not supported. When you delete the only item in a menu, the entire menu is deleted, not just the selected item.

**Note:** Make sure that you really want to delete custom items. They are removed immediately without confirmation.

To delete a custom item:

1. Select View > Customize > Menus and Toolbars. The Menu Editor appears.
2. Select the item that you want to delete.
3. Verify whether the item can be deleted, and change the customization set, if necessary.
4. Right-click the selected item and select Delete. The item is immediately deleted.
5. Click Save. Your changes are saved.

Show and Hide Items

In the Menu Editor, you show or hide toolbars, buttons, menus, and menu items in specific customization sets. The item’s Source determines where you show or hide the item. For example:

- When the Source is *All Users*, change the customization set to *All users* to hide the item from all users.
- When the Source is *JMP Add-In*, change the customization set to *JMP Add-In* followed by the name of the add-in. The item is shown or hidden in all sets that include the selected JMP add-in.
If you do not change the customization set, the item is shown or hidden only in the currently selected set. See “Change Customization Sets” on page 378 for details about customization sets.

**Note:** To quickly hide or show toolbars for the current user, select or deselect them from the View > Toolbars list.

---

**To show and hide items in a customization set:**

1. Select View > Customize > Menus and Toolbars.
   The Menu Editor appears.
2. Select the customization set that you want to modify.
3. Select the item that you want to show or hide.
4. Select or deselect Hidden in the General properties. See “Step 2: Specify the Caption and Internal Name” on page 381 for details about the General properties.
5. Click Save to save your changes.

---

**Import Customizations**

Changes to toolbars and menus are stored in customization sets, or plain text files. You open a customization set in JMP to import your modified toolbars and menus. The customizations are then shown in the Menu Editor.

**To import customizations:**

1. Select File > Open.
2. In the File name list.
3. Click Open.
   A confirmation is displayed, stating that the customizations have been imported. The Menu Editor is also opened.
4. Display the Menu Editor and click OK to save the changes, or click Cancel to discard them.

---

**Remove Customizations**

As you modify items, you discard unsaved changes by clicking the Menu Editor’s Cancel button and clicking Yes to confirm. After saving customizations, you can also remove all customizations and revert to the original menus and toolbars.

**To remove all of the current user’s customizations:**

1. Select View > Customize > Revert to Factory Defaults.
2. Click Yes to remove the current user’s customizations.
   
   When JMP finds customizations from a previous version of JMP, a confirmation appears. Do one of the following:
   
   ‒ Select No to avoid adding those customizations to the current installation of JMP.
   ‒ Select Yes to add those customizations to the current installation of JMP.

   **Note:** Select **Do not ask me again about merging my old menus** for JMP to ignore customizations found in a previous JMP version *every time* you open JMP. However, when you revert toolbars and menus to the factory defaults, you always have the opportunity to merge old menus, whether you previously checked the merging old menus option.

 To remove customizations from another customization set:

1. Select **View > Customize > Menus and Toolbars**.
   
   The Menu Editor appears.
2. Click Change.
3. Select the customization set, and click OK.
4. Click Revert All.
   
   A confirmation window appears.
5. Click Yes to remove your customizations.

 To remove customizations from the selected item:

1. Select **View > Customize > Menus and Toolbars**.
   
   The Menu Editor appears.
2. (Optional) Select the customization set that contains the item.
3. Select the item that you want to modify.
4. Do one of the following:
   
   ‒ To restore the *previous* properties of an *unsaved* item, click Reset.
   ‒ To restore the *original* properties of a *built-in* item, click Revert All, and then click Yes to confirm.
5. Click Save to save your changes.

---

**Personalize Toolbars on Macintosh**

On the Macintosh, you can set up toolbars to display only the icons that you need. Icons are available based on the type of window. For example, in a script window, icons for options
such as reformatting, encrypting, and running the script are available. Table icons are available only for data table toolbars.

You can specify whether the icon, icon and icon name, or just the name appear on the toolbar. Displaying small icons is also an option.

To add, remove, or rearrange toolbar icons:

1. Open the type of window whose toolbar you want to customize.
2. Select View > Customize Toolbar.
   A window appears that shows icons relevant to the current type of window.
3. Do any of the following:
   - To add an icon to the toolbar, drag the icon from the window onto the toolbar.
   - To move an icon on the toolbar, drag the icon to its new location onto the toolbar.
   - To remove an icon from the toolbar, drag the icon from the toolbar onto the window.
   Your changes are applied to the current window and all open windows of the same type.

Figure 11.6 Add, Rearrange, and Remove Toolbar Buttons on the Macintosh

4. Click Done.

   When a toolbar is too wide to display completely, click the right arrows on the toolbar to show and then select other icons. Alternatively, you can click and drag the window until the entire toolbar appears.

Note: To display the original set of toolbar icons, drag the default set from the bottom of the toolbar customization window to the toolbar.

To change the appearance of toolbar icons:

1. Open the type of window whose toolbar you want to customize.
2. Select View > Customize Toolbar.
   A window containing toolbar icons appears.
3. At the bottom of the window, select one of the following options from the Show list:
To display only an icon, select **Icon**.

- To display an icon and its name, select **Icon and Text**.
- To display only the icon name, select **Text**.

4. To display small or standard icons, select or deselect **Use small size**.

Your changes are applied to the current window and all open windows of the same type.

5. Click **Done**.

---

**JMP Add-Ins**

Experienced JSL script writers can create scripts that extend JMP in many ways (for example, add a custom analytical tool or a user interface to communicate with a database). The JMP add-in architecture simplifies deploying and using these complicated scripts.

You can send co-workers a suite of scripts and tell them how to run them. Another option is sending a single add-in file that any JMP user can install and then use just like any other part of JMP.

As a JMP user, you might be given add-ins to use by co-workers. You can also find add-ins on the JMP Web site at [http://www.jmp.com/addins](http://www.jmp.com/addins).

**Note:** Developing add-ins requires experience with JMP scripting, and the process is discussed at length in the *Scripting Guide*.

---

**Manage JMP Add-Ins**

**Install Add-Ins**

A JMP add-in is a file that has the `.jmpaddin` extension. You can install it in one of two ways:

1. Select **File > Open**.
2. Navigate to the `.jmpaddin` file and select it.
3. Click **Open**.

Or, you can double-click the `.jmpaddin` file.

**View Your Add-Ins**

Select **View > Add-Ins** to see the add-ins that you have already installed.
Update Add-Ins

If you are given an update to an add-in you already have installed, you can just install the update as you did the original add-in. Doing so overwrites the old version with the new one.

Disable, Enable, and Remove Add-Ins

To temporarily disable an add-in without removing it:

1. Select View > Add-Ins.
2. Select the add-in that you want to disable.
3. Deselect the Enabled check box.

To enable a disabled add-in:

1. Select View > Add-Ins.
2. Select the add-in that you want to enable.
3. Select the Enabled check box.

To unregister an add-in:

1. Select View > Add-Ins.
2. Select the add-in that you want to remove.
3. Click Unregister.
JMP preferences enable you to specify general and specific settings and save the settings.

To change preferences:
1. Select **File > Preferences** (Windows) or **JMP > Preferences** (Macintosh). The window in Figure 12.1 appears with the **General** preferences category showing.
2. Click a category and make selections. Click **Apply** to see the results, and then click **OK**.

**Figure 12.1** The General Preferences Window (Windows)
## Contents

Overview ................................................................. 399
General ............................................................... 399
Reports ................................................................. 403
Graphs ................................................................. 406
Styles ................................................................. 408
Tables ................................................................. 410
Platforms ............................................................ 414
Print ................................................................. 416
Text Data Files .................................................... 418
Windows Specific ................................................ 421
Mac OS Settings .................................................. 424
Fonts ................................................................. 425
Communications ............................................... 427
File Locations .................................................... 428
Script Editor ....................................................... 429
SAS Integration .................................................. 432
JMP Updates ....................................................... 435
JSL Debugger ....................................................... 436
Menu Preferences ............................................... 438
Scripting-Only Preferences ................................. 439
Overview

The **Preferences** command on the **File** menu (on the **JMP** menu on Macintosh) displays the Preferences window. See Figure 12.2. Each category is described in this chapter.

Changes that you make to preferences are stored in a version-specific **JMP.PFS** file (for example, in `C:\Users\<user name>\AppData\Local\SAS\JMP\<version number>`). JMP looks for this file when you open the program and considers your changes to be the factory defaults. And all subsequent changes are stored in this file.

**Note:** The **Reset to Defaults** button is on every page of the preferences. Clicking the button on the General, Graphs, Reports, or Styles pages resets preferences on all of those pages. On the remaining pages, clicking the button resets preferences only on the current page.

General

The **General** page is initially displayed when you open Preferences. Most **General** preferences customize your JMP session at start-up. Others set preferences for file-handling and the general appearance of the JMP workspace.
Figure 12.2 General Preferences

Table 12.1 Preferences on the General Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Show Tip of the Day at startup</strong></td>
<td>Select this option to show the Tip of the Day window at start-up. This option is selected by default. Clear this option to prevent the Tip of the Day window from appearing at start-up.</td>
</tr>
<tr>
<td><strong>Initial Splash Window</strong></td>
<td>Select this option to show the initial splash window at start-up. This option is selected by default. Clear this option to prevent the initial splash window from appearing at start-up.</td>
</tr>
<tr>
<td><strong>Initial JMP Starter Window</strong></td>
<td>(Macintosh only) Select this option to show the JMP Starter window every time you start JMP. This option is on by default.</td>
</tr>
<tr>
<td><strong>Initial JMP Window</strong></td>
<td>(Windows only) Select one of the listed windows as the default window. When JMP starts this window appears.</td>
</tr>
<tr>
<td>Preference</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Reopen the initial JMP window on last window close</td>
<td>(Windows only) Select this option to open whichever window you have set as the Initial JMP Window when you close the last JMP window. If this option is turned off, closing the last JMP window also quits JMP. This option is on by default.</td>
</tr>
<tr>
<td>Select Individual Excel Worksheets</td>
<td>Select this option to always be prompted to select specific worksheets when you open a Microsoft Excel workbook. This option is not selected by default. On Windows, you can also select File &gt; Open, select the workbook, click the Open button arrow, and select Open Selected Worksheets. Note that when you open an Excel file on Macintosh, an option to select worksheets is always available.</td>
</tr>
<tr>
<td>Use Excel Labels as Headings</td>
<td>Select this option to allow JMP to use Excel label names as column headings when importing Excel files. Available settings include:</td>
</tr>
<tr>
<td></td>
<td>• Use best guess (default)</td>
</tr>
<tr>
<td></td>
<td>• Always</td>
</tr>
<tr>
<td></td>
<td>• Never</td>
</tr>
<tr>
<td>Use SPSS Labels for column names during import</td>
<td>Select this option to allow JMP to use SPSS label names as column headings when importing SPSS files.</td>
</tr>
<tr>
<td>Show menu tips</td>
<td>Select this option to see tooltips on main menu options and options in red triangle menus. This option is selected by default.</td>
</tr>
<tr>
<td>Open Text File Charset</td>
<td>Select one of the options from the menu to determine what character encoding JMP uses to open files. Best Guess is the default.</td>
</tr>
<tr>
<td>Save Text Files as Unicode</td>
<td>JMP uses the Unicode character set, which supports special characters such as é and ½. It saves files without special Unicode characters as plain text automatically. This option is selected by default. Clear this check box to save all your files as plain text. Note that versions of JMP earlier than 5.1.2 cannot read Unicode files.</td>
</tr>
</tbody>
</table>
### Table 12.1 Preferences on the General Page (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Save Journals GZ Compressed</strong></td>
<td>Select this option to save JMP journals in a compressed format to save disk space. Clear this option to save journals normally. This option is not selected by default.</td>
</tr>
<tr>
<td><strong>Save Data Table Columns GZ Compressed</strong></td>
<td>Select this option to allow JMP to save data tables using GZ compression. For backwards compatibility, JMP 10 can read the compressed files but not save them. This option is not selected by default.</td>
</tr>
<tr>
<td><strong>Save Scripts in English</strong></td>
<td>Non-English versions of JMP can save scripts in either English or your local language. User-specified values (such as column names and text strings) in these scripts appear as they do in the data table. However, command words (such as <code>Distribution</code> and <code>Set Value</code>) appear in English rather than the local language in order for the script to run on JMP in English. JMP properly displays non-Roman characters (such as Japanese variable names) in JMP in English when the fonts support the necessary characters. Select this option to save scripts in English no matter what language JMP is using. Clear this option to save scripts in your local language. Note that these scripts run correctly only if JMP is running in the same language. This option is selected by default.</td>
</tr>
</tbody>
</table>
| **Display indexes in English** | Shows sections of the JMP Indexes in English or the current locale's language. The preference is selected by default. When you deselect it, the following items are displayed in the current locale's language:  
  - The message list for objects  
  - The message list for display boxes.  
  - The category list for JSL functions.  
  **Note:** The description of each index item is always displayed in the current locale's language. Examples are always in English. |
| **Report Invalid Display Box Messages** | Sends information about invalid display box messages to the log. This option is off by default. This option can be useful during script development, but can cause unwanted log messages for existing scripts. |
Table 12.1 Preferences on the General Page  (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add files opened by scripts to the Recent Files list</td>
<td>(Windows only) Select this option to include files opened by the JSL Open() command in the Home Window Recent Files pane and the File &gt; Recent Files list.</td>
</tr>
<tr>
<td>Save the session when exiting</td>
<td>This option allows you to save the state of the JMP window when existing JMP. When opening JMP, the saved state is restored including any open files and windows.</td>
</tr>
</tbody>
</table>

**Reports**

Report preferences customize the appearance of reports.

**Figure 12.3** Reports Preferences
Table 12.2 Preferences on the Reports Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date Title on Output</td>
<td>Select this option to display the date and time the analysis occurred in your report windows. This option is cleared by default.</td>
</tr>
<tr>
<td>Data Table Title on Output</td>
<td>Select this option to display the name of the data table and notes, if there are any, at the top of the report. This option is cleared by default.</td>
</tr>
<tr>
<td>Hover Help</td>
<td>On some numeric output, JMP provides tooltip-style help when you circle the mouse over a result. Select this option to see hover help where it is offered. This option is selected by default.</td>
</tr>
</tbody>
</table>
| Close report action                 | Select one of the options from the menu to determine what happens when you close a report:  
  - **Prompt**: When you close a report, you are prompted to save it.  
  - **Discard**: When you close a report, you are not prompted to save it, and the report is not saved. This is the default selection.  
  - **Save / Auto-save**: When you close a report, it is automatically saved using the preference selected in the “Auto-save the report to” menu. |
| Auto-save the report to             | Select one of the options from the menu to determine where a report is saved:  
  - **Prompt**: When you close a report, you are prompted for a location to save it. This is the default selection.  
  - **Data Table Script**: When you close a report, it is saved as a script in the open data table.  
  - **Journal Script**: When you close a report, it is saved to a journal window.  
  - **Log Window**: When you close a report, its script is written to the log window. |
### Table 12.2 Preferences on the Reports Page  *(Continued)*

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Save table with report</strong></td>
<td>Select one of the options from the menu to determine how a table is saved to a report:</td>
</tr>
<tr>
<td><strong>Embed</strong></td>
<td>When you save a report, the table is embedded into the report. Choose this option if you want to share the report with others. The data table that is stored in the report is reopened (unchanged) each time the report is opened. If you make changes to the table, they are not saved into the report unless you re-save the report.</td>
</tr>
<tr>
<td><strong>Separate</strong></td>
<td>When you save a report, the table is referenced in the report.</td>
</tr>
<tr>
<td><strong>Prompt</strong></td>
<td>When you save a report, you are prompted to specify how to save the report: either to embed the table within the report, or to add a reference to the table in the report.</td>
</tr>
<tr>
<td><strong>Prompt</strong> is selected by default.</td>
<td></td>
</tr>
<tr>
<td><strong>Laser pointer</strong></td>
<td>JMP has a built-in laser pointer that enables you to visually emphasize parts of a report. It is off by default.</td>
</tr>
<tr>
<td></td>
<td>To turn it on, select a color for the laser pointer from the menu.</td>
</tr>
<tr>
<td><strong>Show conditional formatting</strong></td>
<td>Conditionally formats the color of the text that represents the values. Available for correlation values, ( p )-values, and factor pattern values.</td>
</tr>
<tr>
<td></td>
<td>Select one of the options from the menu:</td>
</tr>
<tr>
<td><strong>Always</strong></td>
<td>Conditional formatting is always applied to correlation values, ( p )-values, and factor pattern values.</td>
</tr>
<tr>
<td><strong>Screen Only</strong></td>
<td>Conditional formatting is always applied to correlation values, ( p )-values, and factor pattern values. However, the conditional formatting does not show when the report is printed.</td>
</tr>
<tr>
<td><strong>Never</strong></td>
<td>Conditional formatting is never applied to correlation values, ( p )-values, and factor pattern values.</td>
</tr>
<tr>
<td><strong>Manage Rules</strong></td>
<td>Creates custom conditional formatting rules that can be applied to numeric columns or matrices.</td>
</tr>
<tr>
<td><strong>Use an Asterisk with the PValue Format</strong></td>
<td>Select this option to have ( p )-values display with an asterisk (*) for significant ( p )-values. This option is on by default.</td>
</tr>
</tbody>
</table>
Graph preferences customize the appearance of graphs. See “Styles” on page 408 for additional details on configuring the appearance of graphs.

Table 12.3  Preferences on the Graphs Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Graph Border</td>
<td>Draws a border line around the area of the graph. This option is not selected by default.</td>
</tr>
<tr>
<td>Y-Axis Title Above Graph</td>
<td>Shows the Title for the Y-Axis above the line rather than beside the line. This option is not selected by default.</td>
</tr>
<tr>
<td>Hide Overlapping Labels</td>
<td>Select this option to have JMP hide chart labels that overlap. This option is selected by default.</td>
</tr>
<tr>
<td>Graph Height</td>
<td>Sets the default height (in pixels) for a graph. Default is 240 pixels.</td>
</tr>
<tr>
<td>Line Width</td>
<td>Sets the default width (in pixels) for lines that pertain to content. Default is 2 pixels.</td>
</tr>
</tbody>
</table>

**Note:** Does not apply to background or grid lines.
Table 12.3 Preferences on the Graphs Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Graph Marker size</td>
<td>Select a default size for the markers in graphs: Dot, Small, Medium, Large, XL, XXL, or XXXL.</td>
</tr>
<tr>
<td>Graph Marker</td>
<td>Select a default marker shape for the markers in graphs.</td>
</tr>
<tr>
<td>Graph Marker Theme</td>
<td>Select a default theme for the markers in graphs when you mark by row or column.</td>
</tr>
<tr>
<td>Marker Selection Mode</td>
<td>Select the default formatting for selected markers. See “Marker Selection Modes” on page 312 in the “JMP Platforms” chapter.</td>
</tr>
<tr>
<td>Marker Selection Color</td>
<td>When the Marker Selection Mode is Selected Same Color, this setting applies the specified color to selected markers. Default color is Red.</td>
</tr>
<tr>
<td>Marker Selection Fade</td>
<td>When the Marker Selection Mode is Unselected Faded, this setting fades the unselected markers by the specified amount (in percent). The default is 65 percent.</td>
</tr>
<tr>
<td>Fast Marker Threshold</td>
<td>When JMP refreshes a report window, it can draw markers on a plot at two different speeds: normal and fast. If JMP is in normal drawing mode, and the number of markers in a graph are more than the specified threshold number, JMP automatically switches to fast mode. Enter the number of markers that separate normal and fast mode. The default is 50,000.</td>
</tr>
<tr>
<td>Continuous Color Theme</td>
<td>Select a default color theme for continuous data. The default theme is Blue to Gray to Red. See “Create Color Themes” on page 160 in the “Enter and Edit Data” chapter.</td>
</tr>
<tr>
<td>Categorical Color Theme</td>
<td>Select a default color theme for categorical data. The default theme is JMP Default. See “Create Color Themes” on page 160 in the “Enter and Edit Data” chapter.</td>
</tr>
</tbody>
</table>
**Styles**

The Style pages allows you to customize colors, tick marks and grid lines, and report colors. See “Graphs” on page 406 for additional details on configuring the appearance of graphs.

**Figure 12.5** Styles Preferences

![Styles Preferences](image)

**Table 12.4** Preferences on the Styles Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
</table>
| Color Presets            | The Color Presets provides a set of predefined colors for use in customizing the appearance of reports, graphs, charts, etc. Tints of the selected color are applied to the various elements.  
                          | **Note:** The selected color is applied also to windows.                                                                                     |
| Frame Color              | Defines the color applied to a graph frame and tick marks. Click to change the default color.                                                |
| Major Grid Line Color    | Defines the major grid line color. Click to change the default color.                                                                        |
| Minor Grid Line Color    | Defines the minor grid line color. Click to change the default color.                                                                        |
Table 12.4  Preferences on the Styles Page  (continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Graph Background Color</td>
<td>Click the color box to select a background color for all graphs. Click to change the default color.</td>
</tr>
<tr>
<td>Window Background Color</td>
<td>Click the color box to select a background color for all reports and data tables. Click to change the default color.</td>
</tr>
<tr>
<td>Original</td>
<td>Click to restore default color settings.</td>
</tr>
<tr>
<td>Frame Border</td>
<td>Shows borders only on the axes.</td>
</tr>
<tr>
<td>Tick marks inside graph frame</td>
<td>Shows axis tick marks inside the graph frame.</td>
</tr>
<tr>
<td>Major Grid Lines</td>
<td>Shows major grid lines on graphs.</td>
</tr>
<tr>
<td>Minor Grid Lines</td>
<td>Shows minor grid lines on graphs.</td>
</tr>
<tr>
<td>Underline Table Headings</td>
<td>Shows border under table headings.</td>
</tr>
<tr>
<td>Shade Table Headings</td>
<td>Shows table headings with shading.</td>
</tr>
<tr>
<td>Table Column Borders</td>
<td>Shows borders between table columns.</td>
</tr>
<tr>
<td>Table Row Borders</td>
<td>Shows borders between table rows.</td>
</tr>
<tr>
<td>Shade Alternate Table Rows</td>
<td>Shows alternate table rows with shading.</td>
</tr>
<tr>
<td>Shade Table Cells</td>
<td>Shows table cells with shading.</td>
</tr>
<tr>
<td>Preview Graph</td>
<td>Shows a preview area where you can see your changes before applying them.</td>
</tr>
</tbody>
</table>
Tables

Table preferences customize JMP data tables, including formula handling, appearance, and compatibility with SAS data sets.

**Figure 12.6 Tables Preferences**

![Tables Preferences](image)

**Table 12.5 Preferences on the Tables Page**

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Suppress OnOpen Script Eval</td>
<td>If you save a script to a data table and name it OnOpen, that script is automatically run whenever the data table is opened. Select this option to prevent any script named OnOpen in the data table from running when you open the data table. Clear this option to allow OnOpen scripts to run. This option is cleared by default.</td>
</tr>
</tbody>
</table>
Table 12.5 Preferences on the Tables Page  (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allow short numeric data format</td>
<td>JMP has the ability to store numeric data in as few as 8 bits (one byte). This option makes short-integer formats available to you when you select Cols &gt; Column Info and assign a column a data type. When you use the correct short-integer format for your data, the numbers are not displayed differently, but the data table uses less disk space. See “The Short-Integer Format” on page 171 in the “Set Column Properties” chapter.</td>
</tr>
<tr>
<td>Save table in extended file format</td>
<td>Starting with JMP 8, data tables can contain a very large number of columns. To accomplish this feature, much of the internal data table coding was changed to support the large (that is, extended) file format. By default, this option is on. Clear this check box if you want to open your JMP data table in versions earlier than JMP 8.</td>
</tr>
<tr>
<td>Print Data Grid as is</td>
<td>Select this option to print the JMP data table as it appears on the screen. Clear this option to resize column widths to accommodate the content width. This option is cleared by default.</td>
</tr>
<tr>
<td>Preserve SAS variable names when exporting to SAS</td>
<td>Select this option to use variable names that are compliant with SAS when you export a JMP data table to a SAS data set. This option is cleared by default.</td>
</tr>
<tr>
<td>Preserve SAS formats when exporting to SAS</td>
<td>Select this option to use formats that are compliant with SAS when you export a JMP data table to a SAS data set. This option is selected by default.</td>
</tr>
</tbody>
</table>
Table 12.5  Preferences on the Tables Page  (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
</table>
| Show Alternate Column Name        | Select this option to show the name-label pair of the column. A column has name-label pair if the two column properties are defined and the Column Name equals one of the two properties. JMP recognizes the following name-label pairs:  
  • SAS name-label pair, where the properties are “SAS Name” and “SAS Label”  
  • SPSS name-label pair, where the properties are “SPSS Name” and “SPSS Label”  
  • Short-long name-label pair, where the properties are “Short Name” and “Long Name”  
If the preference is checked, then both the name and label will appear in the dialog. |
| Use Thousands Separator           | Select this option to display numbers using the locale-appropriate thousands separator. This option is not selected by default. |
| Default Field Width               | Changes the number of digits that appear in numeric columns.                |
| Use a Floating Window for Data Filters | Select this option to float the Data Filter window on top of its associated data table. Clearing this option causes the Data Filter window to behave like any other window. This option is selected by default. |
| Data Filter Select Check          | Select this option to show the Select check box in the Data Filter. This option is selected by default. |
| Data Filter Show Check            | Select this option to show the Show check box in the Data Filter. This option is not selected by default. |
| Data Filter Include Check         | Select this option to show the Include check box in the Data Filter. This option is not selected by default. |
| Data Filter Auto Clear            | Select this option to show the Auto clear option in the Data Filter red triangle menu. This option is selected by default. |
| Data Filter Check Box Display     | Select this option to always use check boxes for categorical filter columns. This option is not selected by default. |
| Include Responses Not in Data     | (Categorical columns only) Shows all of the possible responses listed in value labels, even if the response is not present within the data. |
### Table 12.5 Preferences on the Tables Page (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Numeric keypad Enter key moves down</strong></td>
<td>(Windows only) When a data table cell is selected and you press the Enter (or Return) key on the keyboard, the next table cell down is selected. Pressing either the TAB key or the ENTER key on the numeric keypad located to the right of the keyboard selects the next table cell to the right. Select this option to change the behavior of the ENTER key on the numeric keypad to select the next table cell down instead of to the right. This option is cleared by default.</td>
</tr>
<tr>
<td><strong>Suppress Formula Eval On Open</strong></td>
<td>Select this option to prevent columns formulas from being evaluated when you open data tables. Clear this option to allow formulas to be evaluated when you open data tables. This option is cleared by default.</td>
</tr>
<tr>
<td><strong>ODBC Hide Connection String</strong></td>
<td>Select this option to have the Open Database command hide the ODBC connection settings (that is, user ID and password). See the Scripting Guide book for additional information.</td>
</tr>
<tr>
<td><strong>Data Table Background Color</strong></td>
<td>Click the color box to select a background color for data tables.</td>
</tr>
<tr>
<td><strong>Data Table Grid Color</strong></td>
<td>Click the color box to select a color for the grid lines in a data table.</td>
</tr>
<tr>
<td><strong>Data Table Header Grid Color</strong></td>
<td>Click the color box to select a background color for the column names.</td>
</tr>
</tbody>
</table>
Platforms

Each analysis report has a variety of plot and table options that are shown by default. However, there might be additional options that you want to see each time you run a particular analysis. For example, a bivariate analysis shows a scatterplot by default, but you might also always want to see a linear fit each time. By selecting the Platforms option in the left panel of the Preferences window, you can set the default options for analyses. (Analyses are run by using platforms, such as the Bivariate platform. Thus, the name of this category is Platforms.)

Highlight an analysis name in the Platforms list. Its available options appear in the Options box with the defaults selected.

Click Reset Platform to Defaults to return the selected platform options to the default settings.

Click Reset to Defaults to return all platforms to their default settings.

Figure 12.7 Platforms Preferences
Graph Builder Preferences

There are a few preferences in Graph Builder that do not appear as options within JMP and cannot be scripted. Select Platforms, and then select Graph Builder from the list of platforms to see these preferences.

Table 12.6 Frequently Used Graph Builder Preferences

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Continuous Points Limit</td>
<td>For continuous variables, this number indicates the number of rows at which the Points element is no longer shown initially. The default value is 1500.</td>
</tr>
<tr>
<td>Continuous Alternate</td>
<td>For continuous variables, indicates the element to display when there are more rows than the Points limit can handle. The default value is None, or you can select Contour (density contour). If None is selected, and the Continuous Smoother is turned off, Points appear when the limit is breached.</td>
</tr>
<tr>
<td>Continuous Smoother</td>
<td>For continuous variables, indicates whether the Continuous Smoother should appear.</td>
</tr>
<tr>
<td>Categorical Points Limit</td>
<td>For categorical variables, this number indicates the number of rows at which the Points element is no longer shown initially. The default value is 1500.</td>
</tr>
<tr>
<td>Categorical Alternate</td>
<td>For categorical variables, indicates the element to display when there are more rows than the Points limit can handle. The default value is Box Plot, or you can select from the following options:</td>
</tr>
<tr>
<td>Jitter</td>
<td>Indicates whether jittering is on by default. Small spaces are displayed between the data points so that you can see each point more clearly. (Only applies to elements that support jittering.)</td>
</tr>
</tbody>
</table>
Print

The Print pages allows you to configure default print settings such as, margins, header, and footers.

Figure 12.8 Print Preferences

Table 12.7 Preferences for Print Settings

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top (margin)</td>
<td>Sets the print page's top margin. The default value is 0.75 inches.</td>
</tr>
<tr>
<td>Left (margin)</td>
<td>Sets the print page’s left margin. The default value is 0.75 inches.</td>
</tr>
<tr>
<td>Right (margin)</td>
<td>Sets the print page’s right margin. The default value is 0.75 inches.</td>
</tr>
<tr>
<td>Bottom (margin)</td>
<td>Sets the print page’s bottom margin. The default value is 0.75 inches.</td>
</tr>
<tr>
<td>Left (header)</td>
<td>Sets the page’s left-side header information. The default value is &amp;wt; (that is, the title).</td>
</tr>
</tbody>
</table>
Table 12.7  Preferences for Print Settings

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Center (header)</td>
<td>Sets the page’s center header information. The default value is blank.</td>
</tr>
<tr>
<td>Right (header)</td>
<td>Sets the page’s right-side header information. The default value is Page &amp;pn; of &amp;pc; (that is, Page # of count).</td>
</tr>
<tr>
<td>Left (footer)</td>
<td>Sets the page’s left-side header information. The default value is blank.</td>
</tr>
<tr>
<td>Center (footer)</td>
<td>Sets the page’s center header information. The default value is blank.</td>
</tr>
<tr>
<td>Right (footer)</td>
<td>Sets the page’s right-side header information. The default value is blank.</td>
</tr>
<tr>
<td>Orientation</td>
<td>Sets the page’s print orientation as either Portrait or Landscape. The default value is Portrait.</td>
</tr>
<tr>
<td>Scale Factor</td>
<td>Sets the page’s print scaling factor (in percent). The default value is 100%.</td>
</tr>
</tbody>
</table>

*Note:* The code for printing the current date in the header or footer is &d.
Text Data Files

Text Data File preferences customize the handling of importing and exporting text files.

Figure 12.9 Text Data Files Preferences
Table 12.8 Preferences for Import Settings for Text Files

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Import Settings</strong></td>
<td>Select the strategy JMP uses to open text files. The default selection is <em>Use these settings</em>. In that case, you need to ensure that the settings reflect your text files.</td>
</tr>
<tr>
<td></td>
<td>If you select <em>Use Best Guess</em>, JMP collects statistics in the text file on tabs, commas, blanks, and a few other characters and uses a rule-based system to decide what the file format might be. The rules try to make reasonable field widths and a reasonable number of fields per line. If your data format is too different from what the rules are designed to guess, JMP guesses incorrectly. In that case, either use the wizard or explicitly describe your data in these preference settings.</td>
</tr>
<tr>
<td><strong>End Of Field</strong></td>
<td>Select one or more characters to use as the delimiter that signifies the end of a field when importing text data.</td>
</tr>
<tr>
<td></td>
<td>Select the <em>Other</em> option and enter a character to specify a delimiter that is not listed.</td>
</tr>
<tr>
<td><strong>End Of Line</strong></td>
<td>Select one or more characters to use as the delimiter that signifies the end of a line (row).</td>
</tr>
<tr>
<td></td>
<td>Select the <em>Other</em> option and enter a character to specify a delimiter that is not listed.</td>
</tr>
<tr>
<td></td>
<td>Note that if double-quotes are encountered when importing text data, the delimiter rules change to look for an end double-quote. Other text delimiters, including spaces, that are embedded within the quotes are ignored and treated as part of the text string.</td>
</tr>
<tr>
<td><strong>Table contains column headers</strong></td>
<td>Select this option if your text file contains columns names. If you select this option, enter the line number where the column names are located in the field next to <em>Column Names are on line</em>.</td>
</tr>
<tr>
<td><strong>Column Names are on line</strong></td>
<td>If you select the <em>Table contains column headers</em> option, enter the line number where the column names are located in this field.</td>
</tr>
<tr>
<td><strong>Data starts on line</strong></td>
<td>Enter the line number where the data starts in your text file.</td>
</tr>
</tbody>
</table>
When determining column types

Set how long JMP scans a text file to determine data types for the columns. The default value is **Scan whole file**. Note that the **Scan whole file** option can cause importing a text file to be slow for large files.

When your text file contains columns of missing data, select **Treat empty columns as numeric** to import the columns as numeric rather than character. A period, Unicode dot, \( NaN \), or a blank string are possible missing value indicators. This option is deselected by default.

**Two-digit year rule**

Select the rule that you want to use to import dates that use two digits instead of four. For details about these rules, see “Two-digit year rule” on page 72 in the “Import Your Data” chapter.

**Try to compress**

Select the options used for compressing text files. Available options are:

- Numeric columns
- Character columns
- Allow List Check

**Note:** This feature requires a scan of the entire file.

**Strip enclosing quotation marks**

Select this option to remove quotation marks that enclose data in the text file. This option is selected by default.

**Recognize apostrophe as quotation mark**

Select this option to treat apostrophes as quotation marks. This option is off by default.

**Note:** This option is not recommended unless your data comes from a nonstandard source that uses apostrophes around data fields rather than quotation marks.

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Export Table Headers</strong></td>
<td>Select this option to include column names when you save data tables as text files.</td>
</tr>
</tbody>
</table>
These preferences customize settings for machines running the Windows operating system, including graphics formats and the window background color.

**Figure 12.10** Windows Specific Preferences

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>End Of Field</strong></td>
<td>Select one or more characters to use as the delimiter signifying the end of a field when exporting text data. Select the <strong>Other</strong> option and enter a character to specify a delimiter that is not listed.</td>
</tr>
<tr>
<td><strong>End Of Line</strong></td>
<td>Select one or more characters to use as the delimiter that signifies the end of a line (row). Select the <strong>Other</strong> option and enter a character to specify a delimiter that is not listed.</td>
</tr>
</tbody>
</table>

**Windows Specific**
Table 12.10  Windows Specific Preferences

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Language</td>
<td>Select the language in which you want to run JMP. The locale settings for your operating system normally determine settings for number, date, and currency formats. Select the option below the language menu to use that language to determine these formats instead. Text that appears in windows provided by the operating system (for example, File &gt; Open), do not reflect changes in the language setting.</td>
</tr>
<tr>
<td>Copy/Drag Graphic Formats</td>
<td>Select one or more graphic formats to use when copying and pasting (or dragging and dropping) graphics from JMP into other applications.</td>
</tr>
<tr>
<td>Resolution (DPI) for PNG and JPEG Images</td>
<td>Specify the DPI to be used when you copy a graphic format. Choose from the Default (96) or 300 DPI. 300 DPI is good for images that must be stretched, embedded in trade publications, or printed. However, this setting uses more memory and is slower to generate for large images.</td>
</tr>
<tr>
<td>Graphics Formats</td>
<td>Select the format to use for graphics when you save a JMP report as an RTF file or an HTML file. In the Graphic Scale Factor % box, enter the percentage at which you want graphics to appear in other applications. This feature might not work with all versions of your chosen application.</td>
</tr>
<tr>
<td>Highlight Outline Headers</td>
<td>Select this option to give title bars in the data table and report windows a light shade of gray. This option is selected by default. Clear this option to give the title bars a darker shade of gray.</td>
</tr>
<tr>
<td>JSL Scripts should be run only, not opened, when selected from Recent Files or a file browser</td>
<td>Select this option to force all scripts to run when opened. If this is selected, the script window for the script is not opened. This option is off by default.</td>
</tr>
<tr>
<td>Show on the Windows task bar</td>
<td>Select which JMP windows you would like displayed on the Windows task bar. The default selection is All Windows. You can also choose to display the main JMP window and data table windows.</td>
</tr>
<tr>
<td>Preference</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Open the JMP Log window</td>
<td>Select one of the options to open the log only when text (such as error messages) is added to it or every time you start JMP. The default setting displays the log only when you open it.</td>
</tr>
<tr>
<td>Auto-hide menu and toolbars</td>
<td>Select the rule used to determine when menus and toolbars are hidden. The default value is Based on window size.</td>
</tr>
<tr>
<td>Wrap the main menu in narrow windows</td>
<td>Select this option to wrap the menu to additional lines when the window is narrower is than the menu. This option is on by default.</td>
</tr>
<tr>
<td>Show the thumbnail panel in data table windows</td>
<td>Select this option to show the thumbnail panel of reports at the bottom of a data table. This option is on by default.</td>
</tr>
<tr>
<td>Dock the Window List in maximized windows</td>
<td>Select this option to automatically dock the Window List if you maximize your JMP windows. This option is off by default.</td>
</tr>
<tr>
<td>Reset file associations to this application</td>
<td>Click this button to associate all JMP file types with the JMP version that you are running.</td>
</tr>
</tbody>
</table>
Mac OS Settings

Mac OS Settings preferences customize settings for Macintosh machines, including the display language, graphics formats, and file associations.

Figure 12.11 Mac OS Settings Preferences

Table 12.11 Macintosh OS Settings

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alternate Image Formats for Clipboard and Drag &amp; Drop</td>
<td>Select one or more graphic formats to use when copying and pasting (or dragging and dropping) graphics from JMP into other applications.</td>
</tr>
<tr>
<td>Clipboard Image Scale Factor</td>
<td>Enter the percentage at which you want graphics to appear in other applications.</td>
</tr>
<tr>
<td>Image format for RTF</td>
<td>Select the format to use for graphics when you save a JMP report as an RTF file.</td>
</tr>
<tr>
<td>RTF Image Scale Factor</td>
<td>Enter the percentage at which you want graphics to appear in RTF documents.</td>
</tr>
</tbody>
</table>
Fonts

Font preferences customize the appearance of reports, data tables, and scripts, including fonts, text size, and font style.

Figure 12.12  Fonts Preferences

Table 12.11  Macintosh OS Settings  (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image format for HTML</td>
<td>Select the format to use for graphics when you save a JMP report as an HTML file.</td>
</tr>
</tbody>
</table>

Table 12.12  Preferences for Customizing Fonts

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Sets the font for the text portion of a JMP analysis report.</td>
</tr>
<tr>
<td>Heading</td>
<td>Sets the font for the heading of columns in an analysis report and a data table.</td>
</tr>
</tbody>
</table>
Table 12.12 Preferences for Customizing Fonts  *(Continued)*

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Sets the font for the title shown in all title bars.</td>
</tr>
<tr>
<td>Small</td>
<td>Sets the font for small text, which is used in the upper left corner of the data grid to show the number of columns and rows.</td>
</tr>
<tr>
<td>Mono</td>
<td>Sets the font used in the JMP Scripting Language (JSL) editor for script commands.</td>
</tr>
<tr>
<td>Formula Editor</td>
<td>Sets the font for the expressions entered into the Formula Editor.</td>
</tr>
<tr>
<td>Annotation</td>
<td>Sets the default font used in annotations.</td>
</tr>
<tr>
<td>Axis</td>
<td>Sets the font used for the axis tick labels.</td>
</tr>
<tr>
<td>Marker</td>
<td>Sets the font used for alphanumeric markers.</td>
</tr>
<tr>
<td>Axis Title</td>
<td>Sets the font for axis titles.</td>
</tr>
<tr>
<td>Data Table</td>
<td>Sets the font for displaying data in the data table.</td>
</tr>
<tr>
<td>Font Family</td>
<td>Select a proportional font. The font that you select is immediately applied to all settings except for Mono, which is used for scripts.</td>
</tr>
<tr>
<td>Enable special font effects</td>
<td><em>(Windows only)</em> Select this option to enable setting Underline and Strikeout in the other font settings. This option is cleared by default.</td>
</tr>
<tr>
<td>Use Greek letters</td>
<td>Select this option to use Greek letters instead of spelling out Greek letters. <em>(For example, ( \pi ) instead of pi.)</em> This option is selected by default.</td>
</tr>
<tr>
<td>Use math symbols</td>
<td>Select this option to use math symbols instead of simple text representations of math symbols. <em>(For example, ( \pm ) instead of +/-)</em> This option is selected by default.</td>
</tr>
</tbody>
</table>
Communications

(Windows only) Communications preferences customize settings for reading data from an external source. These settings need to be specified only if you are using an instrument to do so.

**Figure 12.13  Communications Preferences**

![Communications Preferences](image)

**Table 12.13  Preferences on the Communications Page**

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Port</td>
<td>Select the port that your data source uses.</td>
</tr>
<tr>
<td>Baud Rate</td>
<td>Set the baud rate for your data source.</td>
</tr>
<tr>
<td>Data Bits</td>
<td>Set the number of data bits (7 or 8).</td>
</tr>
<tr>
<td>Parity</td>
<td>Set the parity bit. None is the default value.</td>
</tr>
<tr>
<td>Stop Bits</td>
<td>Set the stop bits (1 or 2).</td>
</tr>
<tr>
<td>Flow Control</td>
<td>Set the flow control. XON/XOFF is the default value.</td>
</tr>
</tbody>
</table>
File Locations

(Windows only) File Locations preferences set the default locations of JMP system files. Usually, the files can stay where JMP installs them, and you do not have to change anything here. However, if you do move files, such as Help files, elsewhere, you should update the location here.

Figure 12.14 File Locations Preferences

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Files directory</td>
<td>Change the folder in which JMP looks for data files (for example, data tables).</td>
</tr>
<tr>
<td>Help Files directory</td>
<td>Change the folder in which JMP looks for Help files.</td>
</tr>
<tr>
<td>Installation directory</td>
<td>Change the JMP installation folder.</td>
</tr>
<tr>
<td>License file path</td>
<td>Change the folder in which JMP looks for your JMP License file.</td>
</tr>
</tbody>
</table>
Chapter 12
JMP Preferences

Using JMP Script Editor

Script Editor preferences customize the appearance of the JSL Script Editor, such as tab width, syntax coloring, and tooltips.

Figure 12.15 Script Editor Preferences

Table 12.14 Preferences on the File Locations Page (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preferences file directory</td>
<td>Change the folder in which JMP looks for preference information.</td>
</tr>
<tr>
<td>Save As directory</td>
<td>Change the folder in which JMP saves data files when you select File &gt; Save As.</td>
</tr>
<tr>
<td>Always go to this directory when the File Open window is displayed</td>
<td>Select to have JMP always use the selected path when you select File &gt; Open.</td>
</tr>
</tbody>
</table>
### Table 12.15 Preferences on the Script Editor Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use tabs</td>
<td>Select this option to enable tabs in your scripts. This option is selected by default. Clear this option to replace any tab that you type with spaces.</td>
</tr>
<tr>
<td>Tab width</td>
<td>Enter how many spaces a tab should indent. If you have disabled tabs, any tab you type is replaced with the number of spaces specified. The default value is 4.</td>
</tr>
<tr>
<td>Extra space at bottom of document</td>
<td>Select this option to enable scrolling up from the last blank lines of a script. This option is selected by default on Windows and deselected on Macintosh.</td>
</tr>
<tr>
<td>Auto-complete parentheses and braces</td>
<td>Select this option to enable the script editor to automatically add closing parentheses, square brackets, and curly braces when you type an opening one. This option is selected by default.</td>
</tr>
<tr>
<td>Show line numbers</td>
<td>Select this option to show the line numbers on the left side of the script editor. This option is off by default.</td>
</tr>
<tr>
<td>Show indentation guides</td>
<td>Select this option to see faint vertical lines that mark indentation. This option is selected by default.</td>
</tr>
<tr>
<td>Show operator tips</td>
<td>Select this option to see tooltips for JSL operators. This option is selected by default.</td>
</tr>
<tr>
<td>Show variable value tips</td>
<td>Select this option to see tooltips for variable values. This option is selected by default.</td>
</tr>
<tr>
<td>Wrap Text</td>
<td>Select this option to always wrap text in the script editor. This option is off by default.</td>
</tr>
<tr>
<td>Show embedded log on script window open</td>
<td>Select this option to have an embedded log window appear in the scripting window when editing or running scripts. This option is off by default.</td>
</tr>
<tr>
<td>Color unknown object messages</td>
<td>Select this option to always show unknown object messages in color. Unknown object messages will appear in the color specified by “Message unknown color”. This option is off by default.</td>
</tr>
<tr>
<td>Save and restore document state information</td>
<td>Saves the state of collapsed and expanded code, and restores that state when the script is reopened.</td>
</tr>
</tbody>
</table>
### Table 12.15 Preferences on the Script Editor Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Spaces inside parentheses</strong></td>
<td>Select this option to cause the script editor to add spaces between parentheses, brackets, and braces and their contents for automatically formatted scripts. This is on by default.</td>
</tr>
<tr>
<td><strong>Spaces in operator names</strong></td>
<td>Select this option to cause the script editor to add spaces between words within operator names. For example, turning on this option results in <code>New Window</code> instead of <code>NewWindow</code>. This option is selected by default.</td>
</tr>
<tr>
<td><strong>JSL code folding</strong></td>
<td>Select this option to use code folding markers in the script editor, which mark the opening and closing of user defined functions and <code>Expr()</code> blocks. You can expand and collapse these marked blocks of code. This option is off by default. You can also choose the appearance of the marker using the JSL code folding marker menu.</td>
</tr>
<tr>
<td><strong>Allow additional code folding keywords</strong></td>
<td>Select this option to enable using additional keywords for folding markers in the script editor. See the <em>Scripting Guide</em> book for details.</td>
</tr>
<tr>
<td><strong>Color selection</strong></td>
<td>To set your own color for any of the listed types, click the color box and select your color.</td>
</tr>
</tbody>
</table>
SAS Integration preferences customize the default settings for working with SAS servers. For details about using the SAS Integration capabilities, see “Import Data from SAS” on page 78 in the “Import Your Data” chapter.

**Note:** The SAS Environment options appear only when you select SAS 9.3 from the SAS Server Version list.

**Figure 12.16** SAS Integration Preferences

**Table 12.16** Preferences on the SAS Integration Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
</table>
Table 12.16  Preferences on the SAS Integration Page  (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>I want to connect to a SAS Environment</td>
<td>Select this option to always connect to a SAS Environment and click <strong>Configure</strong> to configure the URL of the location.</td>
</tr>
<tr>
<td>I want to connect to a SAS Metadata Server</td>
<td>Select this option to always connect to a SAS Metadata Server. This option is selected by default. Clear this option if you do not have a SAS Metadata Server available, and you connect directly to SAS Workspace Servers instead.</td>
</tr>
<tr>
<td>I will manually connect to SAS workspace servers</td>
<td>Select this option to manually connect to a SAS workspace server.</td>
</tr>
<tr>
<td>Automatically connect metadata-defined SAS libraries</td>
<td>Select this option to connect to metadata-defined SAS libraries automatically when you connect to a SAS Workspace Server. Selected by default. When the Workspace Server contains a large number of metadata-defined SAS libraries, deselect this option to speed up your connection to the server.</td>
</tr>
<tr>
<td>Automatically generate ODS results</td>
<td>Select this option to generate ODS (operational data store) results. This option is cleared by default.</td>
</tr>
<tr>
<td>ODS Result Format</td>
<td>Select the format for ODS reports. The default value is HTML.</td>
</tr>
<tr>
<td>ODS Style</td>
<td>Enter the style name for ODS reports. The default value is Statistical.</td>
</tr>
<tr>
<td>ODS Style sheet</td>
<td>Enter the style sheet name for ODS reports.</td>
</tr>
<tr>
<td>Prompt if results are larger than ___ MB</td>
<td>Enter the number of MB that triggers a prompt for you to continue or cancel the operation. The default value is 5.</td>
</tr>
<tr>
<td>Graphics Format</td>
<td>Select the format for graphics for ODS reports.</td>
</tr>
<tr>
<td>Generate ODS statistical graphics</td>
<td>Select this option to include statistical graphics in the ODS reports.</td>
</tr>
<tr>
<td>Import generated SAS data sets into JMP</td>
<td>Select this option to import any generated data sets into JMP automatically.</td>
</tr>
<tr>
<td>Prompt if data set has more than ___ rows</td>
<td>Enter the number of rows that triggers a prompt for you to continue or cancel the operation. The default value is 100,000.</td>
</tr>
</tbody>
</table>
Table 12.16 Preferences on the SAS Integration Page (Continued)

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use SAS variable labels for column names during data import</td>
<td>Select this option to use the column labels in the SAS data set as the JMP data table column names when importing a SAS data set into a JMP data table.</td>
</tr>
<tr>
<td>Convert SAS custom formats to JMP value labels</td>
<td>Select this option to use the information in the SAS column formats to set JMP value labels when importing a SAS data set into a JMP data table.</td>
</tr>
<tr>
<td>Warn before closing unsaved imported data</td>
<td>Select this option to trigger a prompt to save any SAS data sets that you imported into JMP and have not saved before closing.</td>
</tr>
<tr>
<td>On export, store table and column properties in extended attributes</td>
<td>Select to allow extended attribute support during SAS 9.4 data export. This option is not selected by default.</td>
</tr>
<tr>
<td>On import, apply table and column properties from extended attributes</td>
<td>Select to allow extended attribute support during SAS 9.4 data import. This option is not selected by default.</td>
</tr>
<tr>
<td>Stored Process Results: Format</td>
<td>Select a report format: HTML, RTF, or PDF.</td>
</tr>
<tr>
<td>Stored Process Results: Graph Format</td>
<td>Select a graph format: ActiveX Image (only available on a SAS server that runs on Windows), Java Image, PNG, JPEG, or GIF.</td>
</tr>
<tr>
<td>Show SAS Log</td>
<td>Select Always, Never, or On Error to set when the SAS log is displayed.</td>
</tr>
<tr>
<td>Location</td>
<td>Select the location for SAS log information: within the JMP log window, or in a separate SAS log window.</td>
</tr>
</tbody>
</table>
The JMP Update preferences show you what version of JMP you currently have, the last time it was updated, and whether and how often JMP checks automatically for updates.

Figure 12.17 JMP Updates Preferences

![JMP Updates Preferences](image)

Table 12.17 Preferences on the JMP Updates Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Check for Updates</td>
<td>Select this option to have JMP automatically check for updates. If this option is selected, specify how often the check is performed: <strong>Daily</strong>, <strong>Weekly</strong>, or <strong>Monthly</strong>.</td>
</tr>
<tr>
<td>Current Version</td>
<td>What version of JMP you are currently running.</td>
</tr>
<tr>
<td>Last Check</td>
<td>The last time you checked for an update.</td>
</tr>
<tr>
<td>Check Now</td>
<td>Click this button to perform an update check immediately.</td>
</tr>
</tbody>
</table>
JSL Debugger

The JSL Debugger preferences let you show or hide line numbers, create breaks in scripts, and show warnings.

**Figure 12.18** JSL Debugger Preferences

<table>
<thead>
<tr>
<th>Preference Group</th>
<th>Preference Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td>Show Line Numbers</td>
</tr>
<tr>
<td></td>
<td>Break On Multiple Statements Per Line</td>
</tr>
<tr>
<td></td>
<td>Break On Throw</td>
</tr>
<tr>
<td></td>
<td>Break On Execution Error</td>
</tr>
<tr>
<td></td>
<td>Warn On Assignment In Condition</td>
</tr>
<tr>
<td></td>
<td>Enter Debugger Upon Termination</td>
</tr>
</tbody>
</table>

**Table 12.18** Preferences on the JSL Debugger Page

<table>
<thead>
<tr>
<th>Preference</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Line Numbers</td>
<td>Shows or hides the line numbers for the script in the debugger. The default value is selected.</td>
</tr>
<tr>
<td>Break on Multiple Statements Per Line</td>
<td>Stops executing the script between each expression in a single line. The default value is deselected.</td>
</tr>
</tbody>
</table>
Break On Throw

Breaks when an exception error occurs in a Try() function. For example, the exception error in the Try() function is thrown by a Throw() function. The Debugger breaks on the Throw() instead of continuing through the rest of the codes. This lets you identify where the problem occurred in the script and then return to debugging. The default value is deselected.

Break On Execution Error

Stops executing the script when the error occurs rather than closing the Debugger. The default value is selected.

Warn On Assignment In Condition

Select to show a warning when you enter an assignment expression for the breakpoint condition. For example, if you specify x = 1 instead of x == 1 in the breakpoint condition, you are prompted to verify the specification. The default value is selected.

Enter Debugger Upon Termination

Select to enter the Debugger when JMP terminates. The default value is selected.
Menu Preferences

The Menu preferences show and hide menus based on how you use JMP. This gives you fewer menu items to browse through and streamlines the JMP interface. For example, if you never design experiments, deselect Design of Experiments. Other menus are grouped by area of interest, such as quality engineering, advanced modeling, reliability and survival, SAS options and Excel Modeling.

Figure 12.19 Menu Preferences
Scripting-Only Preferences

The following preferences can be changed only by using a JSL script. See the Scripting Guide for information about scripting.

Table 12.19 Scripting-Only Preferences

<table>
<thead>
<tr>
<th>Preference</th>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>JMP 6 Scoping</td>
<td>Preferences(JMP 6 Scoping(0</td>
<td>1))</td>
</tr>
<tr>
<td>Warn On Scoping Conflict</td>
<td>Preferences(Warn On Scoping Conflict(0</td>
<td>1))</td>
</tr>
</tbody>
</table>
You can add functions to a formula. All of these functions are organized in the function browser, which groups collections of functions and features in lists organized both alphabetically (Functions (all)) and by topic (Functions (grouped)). This chapter gives a description of functions in the Formula Editor.

More information about functions is available in the following resources:

- **Scripting Index** describes all functions and their arguments, demonstrates how the functions work, and links to online Help. In JMP, select Help > Scripting Index to view this interactive resource.

- The **Scripting Guide** also provides the arguments for all JMP functions, not just those available in the Formula Editor. In JMP, select Help > Books > Scripting Guide to open a PDF of the Scripting Guide.

**Figure A.1** Functions in the Formula Editor

For instructions on how to create a formula that contains a function, see “Create a Formula” on page 237 in the “Formula Editor” chapter.
Contents

Row Functions ................................................................. 443
Numeric Functions ............................................................ 445
Transcendental Functions .................................................. 445
Trigonometric Functions .................................................... 448
Character Functions .......................................................... 449
Character Pattern Functions ................................................. 456
Comparison Functions ....................................................... 459
Conditional Functions ........................................................ 460
Probability Functions ........................................................ 465
Discrete Probability Functions ............................................. 474
Statistical Functions .......................................................... 476
Random Functions ............................................................ 480
Date Time Functions .......................................................... 484
Row State Functions .......................................................... 487
Assignment Functions ....................................................... 492
Parametric Model Functions ............................................... 493
Finance Functions ............................................................ 493
Appendix A
Using JMP

Row Functions

Adding a row function to a formula lets you reference specific rows or cells within specific rows. You can also insert values based on an arithmetic sequence. See the Scripting Guide for details about syntax.

Sequence

Produces an arithmetic sequence of numbers across the rows in a data table, where the start value, ending limit, and increment are specified as arguments.

Count

Creates a list of values beginning with the from value and ending with the to value. The number of steps specifies the number of values in the list between and including the from and to values. Each value determined by the first three arguments of the count function occurs consecutively the number of times that you specify with the times argument. When the to value is reached, Count starts over at the from value.

Also, you can add the times argument with the insert button on the keyboard. This argument is one by default, but repeats the count process as many times as you specify, as illustrated by the Count4 column in the data table in Figure A.2. To add any argument to the Count function, highlight the argument preceding the one that you want to enter. Either type a comma or use the insert button on the Formula Editor keypad.

The columns in the data table below result from the following formulas:

- Count (1, 9, 2) gives Count 1
- Count (1, 9, 3) gives Count 2
- Count (1, 9, 9) gives Count 3
- Count (1, 9, 3, 3) gives Count 4

Figure A.2 Example of the Count Function

The Count function is useful for generating a column of grid values. For example, the following formulas create a square grid of increment NRow(). NRow() is the Row function that gives the total number of rows in the data table) and axes that range from –5 to 5:

```
Count (-5, 5, Root(NRow()))
```
Count (-5, 5, Root(NRow()), Root(NRow()))

Lag

Returns the value of the first argument in the row defined by the current row less the second argument. The default Lag is one, which you can change to any number. The value returned for any lag that identifies a row number less than one is missing. Note that Lag(X, n) gives the same result as the subscripted notation, \( X_{Row()-n} \).

Dif

Returns the difference between the value of the first argument in the current row and its value in the row defined by the current row less the second argument. The default Dif is one, which you can change to any number. Note that Dif(X, n) gives the same result as \( X_{Row()}-X_{Row()-n} \), or as \( X_{Row()}-Lag(X, n) \).

Subscript

Enables you to use a column’s value from a row other than the current row. After choosing Subscript from the list, enter a numeric expression into the subscript argument. Subscripts that evaluate to nonexistent row numbers produce missing values. Column names with no subscript refers to the current row. To remove a subscript, select the subscript and delete it. Then delete the missing box.

The formula \( Count_{Row()} - Count_{Row()-1} \), where \( Row() \) is the row number as described below, uses subscripts to calculate the difference between each pair of values from the column named Count. This result is the same as that given by the Dif() function. When \( Row() \) is 1, the computation produces a missing value.

The formula below calculates a column called Fib, which contains the terms of the Fibonacci series (each value is the sum of the two preceding values in the calculated column).

\[
\begin{align*}
&i \text{ if } i \leq 2 \Rightarrow 1 \\
&Fib_{Row() - 1} + Fib_{Row() - 2} \\
\end{align*}
\]

It shows the use of subscripts to do recursive calculations. A recursive formula includes the name of the calculated column, subscripted such that it references only previously evaluated rows (rows 1 through \( i-1 \)). The calculation of the Fibonacci series shown includes a conditional expression and a comparison. See the sections “Conditional Functions” on page 460, and “Comparison Functions” on page 459, for details.

Row

Returns the current row number when an expression is evaluated for that row. You can use Row() in any expression, including column name subscripts. The default subscript of a column name is Row() unless otherwise specified.
NRow

Returns the total number of rows in the active data table.

## Numeric Functions

You can create a formula that contains arithmetic operators that are commonly used in formulas. See the Scripting Guide for details about syntax.

**Abs**

Returns a positive number of the same magnitude as the value of its argument. For example, $|5|$ and $|-5|$ both result in 5.

**Modulo**

Returns the remainder when the second argument is divided into the first. For example, $\text{Modulo}(6, 5)$ results in 1.

**Ceiling**

Returns the smallest integer greater than or equal to its argument. For example, $\text{Ceiling}(2.3)$ results in 3, while $\text{Ceiling}(-2.3)$ results in $-2$.

**Floor**

Returns the largest integer less than or equal to its argument. For example, $\text{Floor}(2.7)$ results in 2, but $\text{Floor}(-0.5)$ results in $-1$.

**Round**

Rounds the first argument to the number of decimal places given by the second argument. For example, $\text{Round}(3.554, 2)$ rounds to 3.55 and $\text{Round}(3.555, 2)$ rounds to 3.56.

## Transcendental Functions

You can create a formula that supports transcendental functions, such as logarithmic functions for any base, functions for combinatorial calculations, the Beta function, and several gamma functions. See the Scripting Guide for details about syntax.

**Exp**

Raises $e$ to the power that you specify. Thus, $\text{Exp}(1) = e$. 
LnZ
Calculates the natural logarithm of x, except returns 0 when x is 0; for use with derivatives.

Log and Log10
Calculates the natural logarithm (base e). To change the default base, highlight the argument and type a comma or click the insert key on the keypad. The base appears and is editable. The Log argument can be any numeric expressions. The expression Log(e) evaluates as 1, and Log2(32) is 5. The Log10 function calculates the logarithm of base 10 only.

Log1P
Returns a more accurate calculation of Log(1+x) when x is very small.

Squash
Computes the function 1 / (1 + e^x), where x is any numeric column, variable, or expression.

Logist
Also known as Squish or Logistic, is an efficient computation of the function 1 / (1+e^-x), where x is any numeric column, variable, or expression.

Root or Square Root
Calculates the root of its argument as specified by the index. Root initially shows with an index of 2. To change the index, highlight the index argument and enter the value that you want.

Factorial
Returns the product of all numbers 1 through the argument that you specify. For example, Factorial(5) evaluates as 120.

NChooseK
Returns the number of n things taken k at a time (n select k) and is computed in the standard way using factorials, as n! / (k!(n – k)!). For example, NChooseK(5,2) evaluates as 10.

NChooseK Matrix
Returns a matrix of n things taken k at a time (n select k)
Beta

Adds the two parameter Beta function and is written terms of the Gamma function as:

\[ B(m, n) = \frac{\Gamma(m)\Gamma(n)}{\Gamma(m + n)} \]

Gamma

Adds the Gamma function, denoted \( \Gamma(i) \), and is defined as:

\[ \Gamma(i) = \int_{0}^{\infty} x^{i-1}e^{-x}dx \]

Gamma with a single argument is the same as Gamma(x, infinity). The optional second argument changes the upper integer from infinity to the value that you enter. Other interesting gamma function relationships are

- for any \( \alpha > 1 \), \( \Gamma(\alpha) = (\alpha-1) \cdot \Gamma(\alpha-1) \)
- for any positive integer, \( n \), \( \Gamma(n) = (n-1)! \)
- \( \Gamma(0.5) = \) the square root of \( \pi \)

LGamma

Is the natural log of the result of the gamma function evaluation. You get the same result using the Log (natural log) function with the Gamma function. However, the LGamma function computes more efficiently than do the Log (natural log) and the Gamma functions together.

NChooseK

is implemented using LGamma functions. The result is not always an exact integer. If the result is close to an integer, it is rounded up using the Floor function.

Digamma

The logarithmic derivative of the Gamma function.

Trigamma

The derivative of the Digamma function, or the logarithmic second derivative of the Gamma function.

Arrhenius

Calculates the non-specific component of the Arrhenius relationship that is then multiplied by the activation energy in the Arrhenius equation.

\[ \frac{11605}{T + 273.15} \]
Arrhenius Inv
The inverse of the Arrhenius function:
\[
\frac{11605}{y} - 273.15
\]

Logit
Applies the logit transformation to the argument using:
\[
\text{logit}(p) = \log\left(\frac{p}{1 - p}\right)
\]

Logit Percent
Calculates the logit as a percent for the argument.
\[
\text{LogitPct}(pct) = \log\left(\frac{\frac{pct}{100}}{1 - \frac{pct}{100}}\right)
\]

Logistic Percent
Calculates the logistic as a percent for the argument.
\[
\text{LogisticPct}(x) = \frac{100}{1 + e^{-x}}
\]

Schefee Cubic
Is used in fitting certain models. Schefee Cubic (X1, X2) is equivalent to X1*X2*(X1-X2).

Trigonometric Functions
You can create a formula that supports transcendental functions, such as logarithmic functions for any base, functions for combinatorial calculations, the Beta function, and several gamma functions. See the Scripting Guide for details about syntax.

Sine, Cosine, Tangent
The Sine and Cosine functions calculate the sine and cosine of their respective arguments given in radians. For example, the expression \(\text{Sine}(0)\) evaluates to 0, and \(\text{Cosine}(0)\) evaluates to 1. The tangent function calculates the tangent of an argument given in radians. The expression \(\text{Tan}(\Pi/4)\) evaluates to 1.
**ArcSine, ArcCosine, ArcTangent**

The `ArcSine` and `ArcCosine` functions return the inverse sine and inverse cosine of their respective arguments. The returned value is measured in radians. For example, both expressions `ArcSine(1)` and `ArcCosine(0)` evaluate as 1.57080. The `ArcTangent` function returns the inverse tangent of its argument. The returned value is measured in radians. The expression `ArcTangent(1)` evaluates as 0.78540 (=3.14159/4).

**SinH, CosH, TanH**

The `SinH` and `CosH` functions return the hyperbolic sine and hyperbolic cosine of their respective arguments. The expression `SinH(1)` evaluates as 1.175201, and `CosH(0)` evaluates as 1.0. The `TanH` function returns the hyperbolic tangent of its argument. The expression `TanH(1)` evaluates as 0.761594.

**ArcSinH, ArcCosH, ArcTanH**

The `ArcSinH` and `ArcCosH` functions return the inverse hyperbolic sine and inverse hyperbolic cosine of their respective arguments. The expression `ArcSinH(1)` evaluates as 0.881374, and `ArcCosH(1)` is 0. The `ArcTanH` function returns the inverse hyperbolic tangent of its argument. The expression `ArcTanH(0.5)` evaluates as 0.549306.

---

**Character Functions**

You can create a formula that accepts character arguments or returns character strings and converts the data type of a value from numeric to character, or character to numeric. When you create these formulas, note that:

- Character functions can result in either character or numeric data. If you calculate a data type different from the one specified, the data type of the computed column is automatically changed to match the result.
- Arguments that are literal character strings must be enclosed in quotation marks.

See the *Scripting Guide* for details about syntax.

**Char**

Produces a character string that corresponds to the digits in its numeric argument. For example, `Char(1.123)` evaluates as 1.123. See the *Scripting Guide*, for details.

**Collapse Whitespace**

Trims leading and trailing whitespace and replaces interior whitespace with single space. That is, if more than one white space character is present, the *Collapse Whitespace* command replaces the two spaces with one space.
Concat \(||\)

Concatenates character strings to produce a new string with the function’s second character argument appended to the first. For example, "Dr. \(||\) " \(||\) name produces a new string consisting of the title Dr. followed by a space and the contents of the name string. (See also “Concat Items” on page 454.)

Contains

Returns the numeric position within the first argument of the first instance of the second argument, if it exists. The second argument can contain one or more characters. If the second argument does not exist, Contains returns a zero. For example, Contains("Veronica Layman", "ay") evaluates as 11. Contains("Lillie Layman", "L") evaluates as 1. The third argument is optional and is a numeric value that specifies the starting position. If offset is negative, Contains searches backward from offset from the end of the string.

Munger

Computes new character strings from existing strings by inserting or deleting characters. It can also produce substrings, calculate indices, and perform other tasks depending on how you specify its arguments. The Munger function treats uppercase and lowercase letters as different characters.

Text is a character expression. Munger applies the other three arguments to this string to compute a result.

Offset is a numeric expression indicating the starting position to search in the string. If Offset is greater than the position of the first instance of the find argument, the first instance is disregarded.

Find/Length is a character or numeric expression. Use a character string as search criterion, or use a positive integer to return that number of consecutive characters starting from the Offset position. If you specify a negative integer as the Length value, Munger returns all characters from the Offset through to the end of the string.

Replace (optional argument) can be a string or unspecified. If it is a string and the Find/Offset value is numeric, Munger replaces the search criterion with the Replace string to form the result. If the Find/Offset value is numeric and no string is specified, Munger calculates a substring. If the Find/Length value is a character string, Munger always returns the numeric offset, disregarding the Replace value if it exists. To insert the Replace argument, click any argument in the Munger function and then click the insert button. Use the delete key on your keyboard or the delete button (\(\text{Backspace}\)) on the Formula Editor keypad to remove the Replace argument.
Lowercase, Uppercase

The **Lowercase** function converts any uppercase character found in its argument to the equivalent lowercase character. For example, `Lowercase("VERONICA LAYMAN")` evaluates as veronica layman. The **Uppercase** function converts any lowercase character found in its argument to the equivalent uppercase character. For example, `Uppercase("Veronica Layman")` evaluates as VERONICA LAYMAN.

Length

Calculates the length of its argument. For example, `Length("Veronica")` evaluates as 8. If the argument is

- a string, length returns the number of characters;
- a list, length returns the number of items in the list;
- a blob (binary object), the number of bytes.

Num

Produces a numeric value that corresponds to its character string argument when the character string consists of numbers only. If a character string contains a non-numeric value, the result is a missing value. For example, `Num("1.123")` evaluates as 1.123.

Substr

Extracts the characters that are the portion of the first argument. Begins at the position given by the second argument, and ends based on the number of characters specified in the third argument. The first argument can be either a character column or a literal value. The starting argument and the length argument can be numbers of expressions that evaluate to numbers. For example, to show the first name only, `Substr("Veronica Layman", 10, 6)` starts at position 11 and reads through position 16, which yields Layman.

If `start` is negative, `Substr` searches backward from `start` from the end of the string. If `length` is negative or absent, `Substr` returns a string that begins with `start` and continues to the end of the text string.

`Substr` can also be used with lists.

Titlecase

Converts the string to title case, that is, an initial uppercase character and subsequent lowercase characters. For example, `Titlecase("Veronica Layman")` results in Veronica layman.

Trim Whitespace

Removes leading and trailing whitespace and replaces internal whitespace with single space. For example, if an extra space was inserted before and after the name John, the command `Trim
Whitespace(" John ") would delete the spaces resulting in John. This function is an alias for Trim.

Trim

Produces a new character string from its argument, removing any leading and trailing whitespace and replacing interior whitespace with a single space. The second argument determines if whitespace is removed from the left, the right, or both ends of the string. If no second argument is used, whitespace is removed from both ends. For example, Trim("john ") evaluates as john.

This function performs the same function as Trim Whitespace.

Word

Extracts the n\textsuperscript{th} word from a character string. One or more spaces define where each word begins and ends unless the optional delimiters argument is specified. For example, Word(2, "Veronica Layman") returns the word Layman.

To insert the delimiters argument, click on any argument in the Word function and then click the insert button on the Formula Editor keypad. Use the delete key on your keyboard or the delete button on the Formula Editor keypad to remove the delimiters argument. If you do not specify a delimiter, space is used as the delimiter. If you define the delimiter as an empty string, each character is treated as a separate word.

Most special characters act as single delimiters. You can enter any character or set of characters to act as a word delimiter. For example, to extract the last name in the following example, use a comma and blank together as the delimiting characters and ask for the first word. \text{Word}(1, "Layman, Veronica", ", ") returns the word Layman.

Words

Extracts the words from text according to the delimiters listed in the optional second argument. The default delimiter is space. For example, Words("the quick brown fox") returns \{"the","quick","brown","fox"\}.

If you include a second argument, any and all characters in that argument are taken to be delimiters. For example, Words("Doe, Jane P.", ", ") returns \{"Doe","Jane","P"\}.

To insert the delimiters argument, click on any argument in the Words function and then click the insert button on the Formula Editor keypad. Use the delete key on your keyboard or the delete button on the Formula Editor keypad to remove the delimiters argument. If you do not specify a delimiter, white space is used as the delimiter. If you define the delimiter as an empty string, each character is treated as a separate word.
Left, Right

Returns a substring of the left-most or right-most $n$ characters of the string $text$, respectively. Both functions also work with lists.

Starts With, Ends With

Returns 1 if $whole$ begins or ends with $part$, respectively. Returns 0 otherwise. Both functions also work with lists.

Item

Is different than the Word function because of the way it treats word delimiters. If a delimiter is found multiple times, or you enter a delimiter with multiple characters, the Word function treats them as a single delimiter. The Item function uses each delimiter to define a new word position. To compare, suppose a name is of the form lastname, firstname. The delimiter is a comma followed by a blank, such as:

Item(2, "Layman, Veronica", ", ")
Word(2, "Layman, Veronica", ", ")

The Item function returns a missing value because it treats the comma and blank separately and finds nothing between them. The Word function treats the comma and blank as a single delimiter and finds Veronica as the second word.

If you do not specify a delimiter, white space (blank space) is used as the delimiter. If you define the delimiter as an empty string, each character is treated as a separate item.

Char to Hex, Hex, Hex to Char, Hex to Number

Converts between Hex and other formats.

Hex returns the hexadecimal representation of its argument. If the argument is character (in quotes), then the result is a character string twice as long containing the hexadecimal codes for the character values. For example, Hex("A") returns the string 41.

If the argument is numeric and “integer” is specified, the Hex function returns an 8-hexadecimal-character representation of the integer returned. For example, Hex(12, “integer”) returns the string 0000000C.

Hex to Char converts hexadecimals to characters. The resulting character string might not be valid display characters. All the characters must be in pairs, in the ranges 0-9, A-Z, and a-z. Blanks and commas are allowed and skipped.

Char to Hex converts characters to hexadecimals.

Hex to Number converts hexadecimals to numbers.

For details, see the Scripting Guide book.
Repeat

Creates a string that is the first argument repeated the number of times specified by the second argument. The first argument can be either a character literal, a character variable, or a character expression. For example, `Repeat("Katie", 3)` creates `KatieKatieKatie`.

A third argument applies when `Repeat` is used in a JSL script to repeat a matrix. When the first argument is a matrix, the second argument is the rowwise repeat and the third argument is the columnwise repeat.

Insert, Insert Into

`Insert` inserts a new item into the list or expression at the given position. If position is not given, it is inserted at the end.

`Insert Into` is the same as `insert`, but it inserts in place.

Remove, Remove From

`Remove` the character(s) at the indicated position. If n is omitted, the item at position is deleted. If position and n are omitted, the item at the end is removed. There are three possible arguments: the string, followed by the position, followed by the number of characters to be removed.

`Remove From` returns items removed in place. The function returns the removed item(s), but you do not have to assign them to anything. The first argument is a variable name, followed by the position, followed by the number of characters to be removed.

Shift, Shift Into

`Shift` shifts an item or n items from the front to the back of the list or expression. Shifts items from back to front if n is negative. `Shift Into` shifts items in place.

Reverse, Reverse Into

`Reverse` reverses the characters in the string. `Reverse Into` reverses the characters in place.

Concat Items

`Concat Items` converts a list of string expressions into one string, with each item separated by a delimiter. The delimiter is a blank, if unspecified.

Substitute, Substitute Into

The first argument is a string, the second is a pattern, and the third is a replacement string. `Substitute` finds all matches to the pattern in the string, and replaces them with the replacement string. `Substitute Into` does the same substitution in place.
Regex

The first argument is the source string that Regex searches for a match to the pattern. The second argument is the pattern, in the form of a regular expression. The Formula Editor prompts you for these two required arguments.

Tip: For more information about using regular expressions, search the Internet for regular expression tutorial.

By default, Regex performs a case-sensitive search and returns the parts of the source string that match the pattern that you specified (or returns MISSING if the match fails). There are two optional arguments that you can add. You can type a third argument—the format—that specifies the string to return. If you choose, you can use regular expressions to specify replacement text in the returned string. If you specify the third argument, you can also specify IGNORECASE so that Regex ignores capitalization when searching the source string for a match.

Table A.1 Regex Examples

<table>
<thead>
<tr>
<th>Sample Regex function</th>
<th>String that is returned</th>
</tr>
</thead>
<tbody>
<tr>
<td>Regex( &quot;@ q3 #&quot;, &quot;([a-z])([0-9])&quot; )</td>
<td>q3</td>
</tr>
<tr>
<td></td>
<td>The function is case sensitive, so q3 matches but Q3 would not.</td>
</tr>
<tr>
<td>Regex( &quot;@ Q3 #&quot;, &quot;([a-z])([0-9])&quot;, &quot;\0&quot;,IGNORECASE)</td>
<td>Q3</td>
</tr>
<tr>
<td></td>
<td>Although \0 is the default argument, it is required in this example so that IGNORECASE can be specified.</td>
</tr>
<tr>
<td>Regex( &quot;@ Q3 #&quot;, &quot;([a-z])([0-9])&quot;, &quot;\2\1&quot;,IGNORECASE)</td>
<td>3Q</td>
</tr>
</tbody>
</table>

For more information and an example that you can run, select Help > Indexes > JSL Operators and select Regex.

Hex to Blob, Char to Blob, Blob to Char

Hex to Blob converts the hexadecimal to a blob (Binary Large Object).

Char to Blob converts the string to a blob. You can specify the encoding in an optional second argument. Supported encodings are: utf-8, utf-16le, utf-16be, us-ascii, iso-8859-1, and ascii~hex.
Blob to Char converts the blob to a string. You can specify the encoding in an optional second argument. Supported encodings are: utf-8, utf-16le, utf-16be, us-ascii, iso-8859-1, and ascii~hex.

**Character Pattern Functions**

These functions provide powerful pattern matching abilities. Pattern matching is a flexible method for searching and manipulating strings, and regular expressions are also supported. When you create these formulas, note that:

- First, you define a pattern with one more of the character patterns.
- Then, you use **Pat Match** to compare a string to the pattern.
- **Pat Match** returns True (1) if the pattern is found in the string, or it returns False (0) if the pattern was not found in the string.
- To use regular expressions instead of patterns, use **Regex Match**.

For complete details, see the *Scripting Guide*.

**Pat Any**

Constructs a pattern that matches a single character in the argument.

**Pat Not Any**

Constructs a pattern that matches a single character that is not in the argument.

**Pat Break**

Constructs a pattern that matches zero or more characters that are not in its argument; it stops or breaks on a character in its argument. It fails if a character in its argument is not found. In particular, it fails to match if it finds the end of the source string without finding a break character.

**Pat Span**

Constructs a pattern that matches one or more (not zero) occurrences of characters in its argument. It is greedy; it always matches the longest possible string. It fails rather than matching zero characters.

**Pat String**

Constructs a pattern that matches its string argument.

**Pat Len**

Constructs a pattern that matches n characters.
Pat Pos
Constructs patterns that match the null string if the current position is int from the left end of the string, and fail otherwise.

Pat R Pos
Constructs patterns that match the null string if the current position is int from the right end of the string, and fails otherwise.

Pat Tab
Constructs a pattern that matches forward to position int in the source string. It can match 0 or more characters. It fails if it would have to move backwards or beyond the end of the string.

Pat R Tab
Constructs a pattern that matches up to position n from the end of the string. It can match 0 or more characters. It fails if it would have to move backwards or beyond the end of the string.

Pat Test
Constructs a pattern that succeeds and matches the null string if expr is not zero and fails otherwise.

Pat At
Constructs a pattern that matches the null string and stores the current position in the source string into the specified JSL variable (varName). The assignment is immediate, and the variable can be used with expr() to affect the remainder of the match.

Pat Rem
Constructs a pattern that matches the remainder of the string. It is equivalent to patRTab(0).

Pat Arb
Constructs a pattern that matches an arbitrary string. Initially it matches the null string. It matches one additional character each time the pattern matcher backs into it.

Pat Succeed
Constructs a pattern that always succeeds, even when the matcher backs into it. It matches the null string.
Pat Fail
Constructs a pattern that fails whenever the matcher attempts to move forward through it. The matcher backs up and tries different alternatives. If and when there are no alternatives left, the match fails and Pat Match returns 0.

Pat Abort
Constructs a pattern that immediately cancels the pattern match. The matcher does not back up and retry any alternatives. Conditional assignments are not made. Immediate assignments that were already made are kept.

Pat Fence
Constructs a pattern that succeeds and matches the null string when the matcher moves forward through it, but fails when the matcher tries to back up through it. It is a one-way trap door that can be used to optimize some matches.

Pat Arb No
Constructs a pattern that matches zero or more copies of pattern.

Pat Repeat
Matches pattern between minimum and maximum times.

Pat Conditional
Saves the result of the pattern match, if it succeeds, to a variable named as the second argument (type) after the match is finished.

Pat Immediate
Saves the result of the pattern match to a variable named as the second argument (varName) immediately.

Pat Altern
Constructs a pattern that matches any one of the pattern arguments.

Pat Concat
Constructs a pattern that matches each pattern argument in turn.

Pat Regex
Constructs a pattern that matches the regular expression in the quoted string argument.
Pat Match

Pat Match executes a pattern match using the source in the first argument and the pattern in the second argument. The pattern must be constructed first, either inline or by assigning it to a JSL variable elsewhere. A third argument, if present, is the replacement text for the matched characters in the source argument (if the source argument is a variable). Pat Match returns true if the match succeeds. Additional arguments, in any order, are ANCHOR (match must begin at start of source), FULLSCAN (turn off some optimizations for special situations), and MATCHCASE (by default, A == a).

Pat Match returns true or false rather than a string, so Pat Match is somewhat difficult to use in a formula. You might find the Regex function (“Regex” on page 455) easier to use when you are adding pattern-matching formulas in the Formula Editor.

Regex Match

Regex Match is similar to Pat Match. Regex Match executes a pattern match using the source in the first argument and the pattern in the second argument. Regex Match uses a regular expression for the second argument and returns a list of information about the result of the match.

A simpler function, Regex (“Regex” on page 455), is also available. Regex returns a string value rather than a list, so Regex is usually easier to use in the Formula Editor than RegEx Match.

Comparison Functions

You can create a formula that compare the values of two arguments by using the comparison function. Each comparison relationship evaluates as true or false based on numeric magnitudes or character rankings. A true relationship evaluates as one, and false evaluates as zero.

Comparisons are useful when you include them in conditional expressions, but they can also stand alone as numeric expressions if neither term in comparison is missing. A relational symbol’s arguments can be any two expressions. However, both arguments in a comparison function must be of the same data type. Also note that:

- JMP displays an error if you use a single “=” in a conditional where “==” is expected.
- The Formula Editor uses the International Utilities package when comparing character strings. This package contains different rankings for each international character set and takes diacritical marks into consideration.
- You should not use comparison operators to specifically compare to a missing value. Instead, use the Is Missing function to detect a missing value.

See the Scripting Guide for details about syntax.
Conditional Functions

You can include conditional expressions (called conditionals for short) in your formulas. These expressions let you build a sequence of clauses paired with result expressions. Constructing a sequence of clauses is the way you conditionally assign values to cells in a calculated column. Conditionals follow these rules:

- When no clause is true, the Formula Editor evaluates the result expression that accompanies the else clause.
- All result expressions in a conditional expression must evaluate to the same data type.
- A missing term matches any data type.
- By definition, expressions that evaluate as zero are false.
- If an expression evaluates as missing, no clauses are executed and missing is returned. All other numeric expressions are true.

See the Scripting Guide for details about syntax.

Use the insert and delete clause buttons on the Formula Editor panel to expand the expression. For maximum efficiency, list the most frequently evaluated clause and result pairs first in the sequence.

Note: Interpolate, Step, For, and While are most often used in conjunction with other commands to build a JSL script. You can use the Formula Editor to create and execute a script in that column, but this is not recommended because of dependencies and ambiguities that can result. Most often, scripts are stored as .jsl files, and can be saved with a data table as a table property. For details about table properties, see “Table Panel” on page 40 in the “Get Started” chapter. For documentation of all scripting commands, see the Scripting Guide.
If

Shows a single if condition with a missing expression and a missing then clause. Highlight either expr or then clause and enter a value. For example, to calculate count as a percentage of total when total is not 0, enter the conditional expression (using columns called count and total) in Figure A.3.

Figure A.3 A Conditional Expression

To add a new condition to the if conditional, highlight then clause and click the insert button (▲) on the Formula Editor keypad. Initially, this changes the existing else condition to an expr clause. Click the insert button again to add an else clause. Highlighting then or else and repetitively clicking the insert button changes the else to expr or adds a new expr clause.

To delete a clause, select the then clause above it and press the delete key on your keyboard or click the delete button (▲) on the Formula Editor keypad.

By definition, expressions that evaluate as zero are false. If an expression evaluates as missing, no clauses are executed and missing is returned. All other numeric expressions are true.

Match

Compares an expression to a list of clauses and returns the value of the resulting expression for the first matching clause encountered. You provide the matching expression only once and then give a match value for each clause.

After you select Match in the Formula Editor, a list appears with two options:

- Select Add Match Arguments from Data, and clauses that correspond to all of the levels in your data are added automatically. Alternatively, hold down the SHIFT key, select Conditional, and then select Match. In Figure A.4, the example on the left shows clauses that were added automatically.
- Select Don’t Add so that you can add each clause individually. In Figure A.4, the example on the right shows an empty clause, which you fill with the missing expressions.

Figure A.4 Examples of Using the Match Function

automatically added Match arguments           empty Match argument
In an automatically filled argument, you should highlight \textit{then clause}, and then enter an expression. In an empty argument, you highlight either \textit{expr}, \textit{value}, or \textit{then clause}, and then enter an expression. (Or, if you highlight an expression and click \textit{Match}, the Formula Editor creates a new \textit{Match} conditional, with the original highlighted expression as \textit{expr} and nothing for the \textit{value} and \textit{else clause}.) Also, keep in mind that:

- \textit{Match} evaluates faster and uses less memory than an equivalent \textit{If} because the variable is evaluated only once for each row in the data table. The \textit{If} condition must evaluate the variable at each \textit{If} clause for each row until a clause evaluates as true. See “Comparison Functions” on page 459, for a comparison of \textit{Match} and \textit{If} conditionals.

- With \textit{If} and \textit{Match}, the Formula Editor searches down from the top of the sequence for the first true clause and evaluates the corresponding result expression. Subsequent true clauses are ignored.

In the following example, each value is assigned depending on the value of the \textit{age} variable.

\textbf{Figure A.5} An Example of Using the Match Function

\begin{figure}
\centering
\includegraphics[width=0.3\textwidth]{figure_a5.png}
\caption{An Example of Using the Match Function}
\end{figure}

\textbf{Note:} \textit{Match} ignores trailing spaces and \textit{If} does not.

Although \textit{Match} returns missing for any missing values, you can also specifically match missing values.

\textbf{Choose}

\textit{Choose} is a special case of \textit{Match} in which the arguments of the condition are a sequence of integers starting at one. The value of \textit{clause} replaces the match condition. An example of a \textit{Choose} condition is shown in Figure A.6. With \textit{Choose}, the Formula Editor goes directly to the correct choice clause and evaluates the result expression.

\textbf{Figure A.6} Example of a \textit{Choose} Condition

\begin{figure}
\centering
\includegraphics[width=0.3\textwidth]{figure_a6.png}
\caption{Example of a \textit{Choose} Condition}
\end{figure}
When you highlight an expression and click Choose, the Formula Editor creates a new conditional expression with one clause. Use the insert (\(\text{-insert}\)) and delete (\(\text{-del}\)) buttons on the keypad to add new clauses or remove unwanted clauses, as described previously for the If conditional.

Choose evaluates the choose expression and goes immediately to the corresponding result expression to generate the returned value. With Choose, you provide a choosing expression that yields sequential integers starting at 1 only once, and then you give a choice for each integer in the sequence.

IfMax

Evaluates the first of each pair of arguments and returns the evaluation of the result expression (the second of each pair) associated with the maximum of the expressions. If more than one expression is the maximum, the first maximum is returned. If all expressions are missing and a final result is not specified, missing is returned. If all expressions are missing and a final result is specified, that final result is returned. The test expressions must evaluate to numeric values, but the result expressions can be anything.

IfMin

Evaluates the first of each pair of arguments and returns the evaluation of the result expression (the second of each pair) associated with the minimum of the expressions. If more than one expression is the minimum, the first minimum is returned. If all expressions are missing and a final result is not specified, missing is returned. If all expressions are missing and a final result is specified, that final result is returned. The test expressions must evaluate to numeric values, but the result expressions can be anything.

And &

Evaluates as 1 when both of its arguments are true. Otherwise, it evaluates as 0. (See Figure A.9.) The formula in Figure A.7 labels Group 1 as drivers only if both comparisons are true.

Figure A.7  Creating an And Function

```
[sex = "M" & age > 13] = "Group 1"
else = "Group 2"
```

Or 

Evaluates as 1 when either of its arguments is true. If both of its arguments are false, then the Or expression evaluates as 0. (See Figure A.9.) The formula in Figure A.8 assigns males and all participants who are more than 13 years old to Group 1.
Figure A.8 Creating an Or Function

The truth tables on the left in Figure A.9 illustrate the results of the And (\&) and Or (|) functions when both arguments have nonmissing values that evaluate to true or false. The table on the right illustrates the result when either the left or right expression (call them a and b) or both have missing values.

Figure A.9 Evaluations of And and Or Expressions

Not

Evaluates as 1 when its argument is false. Otherwise, Not evaluates as 0. When you apply the Not function, use parentheses where necessary to avoid ambiguity. For example, !(weight==64) can be either true or false (either 1 or 0), but (!weight)==64 is always false (0) because Not can return only 0 or 1. Expressions such as !(weight==64) can also be entered as weight != 64.

Interpolate

Linearly interpolates the y-value between two points, x1, y1 and x2, y2 that corresponds to the arguments that you give. You can insert additional pairs of x, y arguments with the insert key. Interpolate finds the pair of x, y points that correspond to the x-value and completes the interpolation.

Step

Is like Interpolate except that it returns the y-value corresponding to the greatest x-value less than or equal to the x and y arguments. That is, it finds the corresponding y for a given x from a step function rather than a linear fit between points. Like Interpolate, you can have as many x and y argument pairs as you want.
For
Repeats the statements in the body argument as long as the while condition is true. The init and next control the iterations.

While
Repeatedly tests the expr condition and executes the body until expr is no longer true.

Break, Continue
Break stops execution of a loop completely and continues to the statement following the loop. Continue ends the current iteration of a loop and begins the loop at the next iteration.

Both are used in For, While, and For Each Row loops.

Stop
Immediately stops a script that is running.

Probability Functions

You can create a formula that calculates probabilities and quantiles for statistical distributions like beta, Chi-square, F, gamma, normal, Student’s t, Weibull distributions, Tukey HSD, and so on. See the Scripting Guide for details about syntax.

Beta Density
Requires three arguments: quantile argument and the shape parameters alpha and beta. A threshold parameter (θ) and a scale parameter (σ > 0) are additional arguments. It returns the value of the beta probability density function (pdf) for the given arguments. The beta density is useful for modeling the probabilistic behavior of random variables such as proportions constrained to fall in the interval [0, 1].

Beta Distribution
The beta distribution has two shape parameters: α > 0 and β > 0. A threshold parameter (θ) and a scale parameter (σ) are additional arguments, where θ ≤ x ≤ θ + σ. The default value for θ is 0. The default value for σ is 1.
The beta distribution function is the inverse of the beta quantile function.

**Beta Quantile**

Accepts a probability argument, \( p \), and shape and scale parameters, \( \alpha > 0 \) and \( \beta > 0 \). It returns the \( p^{\text{th}} \) quantile from the standard beta distribution. The beta quantile function is the inverse of the beta distribution function.

**ChiSquare Density**

Accepts a quantile argument from the range of values for the Chi-squared distribution, a degrees of freedom argument, and an optional noncentrality parameter. It returns the value of the Chi-squared density function (pdf) for the arguments.

**ChiSquare Distribution**

Accepts a response argument (range of \( x \) values) and three parameter arguments: a quantile, a degrees of freedom, and a noncentrality parameter. It returns the probability that an observation from the Chi-squared distribution with the specified noncentrality parameter and degrees of freedom is less than or equal to the given quantile. For example, the expression \( \text{ChiSquare Distribution}(11.264, 5) \) returns the probability that an observation from the Chi-squared distribution centered at 0 with 5 degrees of freedom is less than or equal to 11.264. The expression evaluates as 0.95361.

Furthermore, the \( \text{ChiSquare Distribution} \) function accepts integer and noninteger degrees of freedom. It is centered at 0 by default. The \( \text{ChiSquare Distribution} \) function is the inverse of the \( \text{ChiSquare Quantile} \) function.

**ChiSquare Quantile**

Accepts three arguments: a probability \( p \), a degrees of freedom, and a noncentrality parameter. It returns the \( p^{\text{th}} \) quantile from the Chi-squared distribution with the specified noncentrality parameter and degrees of freedom. For example, the expression \( \text{ChiSquare Quantile}(0.95, 3.5, 4.5) \) returns the 95% quantile from the Chi-squared distribution centered at 4.5 with 3.5 degrees of freedom. The expression evaluates as 17.50458.

The \( \text{ChiSquare Quantile} \) function accepts integer and noninteger degrees of freedom. It is centered at 0 by default. The \( \text{ChiSquare Quantile} \) function is the inverse of the \( \text{ChiSquare Distribution} \) function.

**Dunnett P Value**

Returns the \( p \)-value from Dunnett’s multiple comparison test.

**Dunnett Quantile**

Returns the quantile needed in Dunnett’s multiple comparison tests.
**F Density**

Accepts a quantile argument from the range of values for the $F$-distribution, numerator and denominator degrees of freedom arguments, and an optional noncentrality parameter. It returns the value of the $F$-density function (pdf) for the arguments.

**F Distribution**

Accepts four arguments: a quantile, a numerator and denominator degrees of freedom, and a noncentrality parameter. It returns the probability that an observation from the $F$-distribution with the specified noncentrality parameter and degrees of freedom is less than or equal to the given quantile. For example, the expression `F Distribution(3.32, 2, 3)` returns the probability that an observation from the central $F$-distribution with 2 degrees of freedom in the numerator and 3 degrees of freedom in the denominator is less than or equal to 3.32. The expression evaluates as 0.82639.

The $F$-distribution function accepts integer and noninteger degrees of freedom. By default, the non-central parameter is set to 0. The $F$-distribution function is the inverse of the $F$ Quantile function.

**F Quantile**

Accepts four arguments: a probability $p$, a numerator and denominator degrees of freedom, and a noncentrality parameter. It returns the $p^{th}$ quantile from the $F$-distribution with the specified noncentrality parameter and degrees of freedom. For example, the expression `F Quantile(0.95, 2, 10, 0)` returns the 95% quantile from the $F$-distribution centered at 0 with 2 degrees of freedom in the numerator and 10 degrees of freedom in the denominator. The expression evaluates as 4.1028.

The $F$ Quantile function accepts integer and noninteger degrees of freedom. By default, the non-central parameter is set to 0. The $F$ Quantile function is the inverse of the $F$ Distribution function.

**Frechet Density**

Returns the density at $x$ of a Fréchet distribution with location $mu$ and scale $sigma$.

**Frechet Distribution**

Returns the probability that a Fréchet distribution with location $mu$ and scale $sigma$ is less than $x$.

**Frechet Quantile**

Returns the quantile associated with a cumulative probability $p$ for a Fréchet distribution with location $mu$ and scale $sigma$. 
Gamma Density
Requires a quantile argument. Also accepts an optional shape parameter, which must be greater than zero and defaults to 1. A scale parameter $b$, which must be greater than zero and defaults to 1 is optional. And a threshold parameter, which must be in the range $-\infty < \theta < +\infty$ and defaults to zero is optional.

Gamma Distribution
Is based on the standard gamma function, and accepts a single argument with a quantile value. The shape, scale, and threshold parameters are optional, with defaults as described previously in the discussion of the Gamma Density function. It returns the probability that an observation from a standard gamma distribution is less than or equal to the specified $x$. The Gamma Distribution function is the inverse of Gamma Quantile function.

Gamma Quantile
Accepts a probability argument $p$, and returns the $p^{th}$ quantile from the standard gamma distribution with the shape parameter that you specify. The Gamma Quantile function is the inverse of the Gamma Distribution function.

LEV Density
Returns the density at $x$ of the largest extreme value distribution with location $mu$ and scale $sigma$.

LEV Distribution
Returns the probability that the largest extreme value distribution with location $mu$ and scale $sigma$ is less than $x$.

LEV Quantile
Returns the quantile associated with a cumulative probability $p$ of the largest extreme value distribution with location $mu$ and scale $sigma$.

Logistic Density
Returns the density at $x$ of a logistic distribution with location $mu$ and scale $sigma$.

Logistic Distribution
Returns the probability that the logistic distribution with location $mu$ and scale $sigma$ is less than $x$. 
Logistic Quantile
Returns the quantile associated with a cumulative probability \( p \) of the logistic distribution with location \( \mu \) and scale \( \sigma \).

Loglogistic Density
Returns the density at \( x \) of the loglogistic distribution with location \( \mu \) and scale \( \sigma \).

Loglogistic Distribution
Returns the probability that the loglogistic distribution with location \( \mu \) and scale \( \sigma \) is less than \( x \).

Loglogistic Quantile
Returns the quantile associated with a cumulative probability \( p \) of the loglogistic distribution with location \( \mu \) and scale \( \sigma \).

Lognormal Density
Returns the density at \( x \) of the lognormal distribution with location \( \mu \) and scale \( \sigma \).

Lognormal Distribution
Returns the probability at \( x \) of the lognormal distribution with location \( \mu \) and scale \( \sigma \).

Lognormal Quantile
Returns the quantile associated with a cumulative probability \( p \) of a lognormal distribution with location \( \mu \) and scale \( \sigma \).

Normal Density
Accepts a quantile argument from the range of values for the standard normal distribution. It returns the value of the standard normal probability density function (pdf) for the argument. For example, you can create a column of quantile values \( (x) \) with the formula `count(-3, 3, nrow())`. A second column is computed as `Normal Density(X)` to generate density values. Then select `Graph > Overlay` to plot the normal density by \( x \).

Normal Distribution
Accepts a quantile argument from the range of values for the standard normal distribution with mean 0 and standard deviation 1. It returns the probability that an observation from the standard normal distribution is less than or equal to the specified quantile. For example, the expression `Normal Distribution(1.96)` returns 0.975, the probability that an observation from the standard normal distribution is less than or equal to the 1.96th quantile. Also, you can specify
mean and standard deviation parameters to obtain probabilities from nonstandard normal distributions. The **Normal Distribution** function is the inverse of the **Normal Quantile** function.

**Normal Quantile (Probit)**

Accepts a probability argument \( p \), and returns the \( p \)th quantile from the standard normal distribution. For example, the expression **Normal Quantile(0.975)** returns the 97.5% quantile from the standard normal distribution, which evaluates as 1.96. Also, you can specify parameter values for the mean and standard deviation to obtain quantiles from nonstandard normal distributions. The **Normal Quantile** function is the inverse of the **Normal Distribution** function.

**Normal Biv Distribution**

Computes the probability that an observation is less than or equal to \((x, y)\) with correlation coefficient \( r \) where the observation is marginally normally distributed. You can specify the mean and standard deviation for the X and Y coordinates of the observation. The default values are 0 for both means and 1 for both standard deviations.

**GLog Density**

Returns the density or pdf at a particular quantile \( q \) of a generalized logarithm distribution with location \( \mu \), scale \( \sigma \), and shape \( \lambda \). When the shape parameter is equal to zero, the distribution reduces to a Lognormal\((\mu, \sigma)\).

**GLog Distribution**

Returns the probability or cdf that a generalized logarithm distributed random variable is less than \( q \). When the shape parameter is equal to zero, the distribution reduces to a Lognormal\((\mu, \sigma)\).

**GLog Quantile**

Returns the quantile, the value for which the probability is \( p \) that a random value would be lower. When the shape parameter is equal to zero, the distribution reduces to a Lognormal\((\mu, \sigma)\).

**SEV Density**

Returns the density at \( x \) of the smallest extreme distribution with location \( \mu \) and scale \( \sigma \).

**SEV Distribution**

Returns the probability that the smallest extreme distribution with location \( \mu \) and scale \( \sigma \) is less than \( x \).
SEV Quantile

Returns the quantile associated with a cumulative probability $p$ of the smallest extreme distribution with location $mu$ and scale $sigma$.

t Density

Accepts a quantile argument from the range of values for the $t$-distribution, a degrees of freedom argument, and an optional noncentrality parameter. It returns the value of the $t$-density function (pdf) for the arguments. To compare a $t$-density with 5 df with a standard normal distribution, you can create a column of quantile values ($x$) with the formula `count(-3, 3, nrow())`. A second column is computed as $t$ Density($X$). A third column is computed as Normal Density($X$). Then select Graph > Overlay to plot the $t$-density and the normal density by $x$. You will see that the $t$-density has slightly more spread than the normal.

t Distribution

Accepts three arguments: a quantile, a degrees of freedom, and a noncentrality parameter. It returns the probability that an observation from the Student’s $t$-distribution with the specified noncentrality parameter and degrees of freedom is less than or equal to the given quantile. For example, the expression $t$ Distribution($0.9$, $5$) returns the probability that an observation from the Student’s $t$-distribution centered at 0 with 5 degrees of freedom is less than or equal to 0.9. 
The expression is evaluated as 0.79531. $t$-distribution accepts integer and noninteger degrees of freedom. It is centered at 0 by default, but you can enter a value for the noncentrality parameter. The $t$ Quantile function is the inverse of the $t$ Distribution function.

t Quantile

Accepts three arguments: a probability $p$, a degrees of freedom, and a noncentrality parameter. It returns the $p^{th}$ quantile from the Student’s $t$-distribution with the specified noncentrality parameter and degrees of freedom. For example, the expression $Student’s t$ Quantile($0.95$, $2.5$) returns the 95% quantile from the Student’s $t$-distribution centered at 0 with 2.5 degrees of freedom. The expression evaluates as 2.558219. The $t$ Quantile function is the inverse of the $t$ Distribution function. This function also accepts integer and noninteger degrees of freedom. It is centered at 0 by default, but you have the option to enter a value for the noncentrality parameter. The $t$ Distribution function is the inverse of the $t$ Quantile function.

Weibull Density

Accepts a quantile argument from a range of values for the Weibull distribution. It returns the value of the Weibull probability density function (pdf). This function is the probability that an observation from a Weibull distribution is less than or equal to the specified quantile argument.
Weibull Distribution

Uses an argument with a quantile valued, an optional value for the scale parameter $\alpha$ and an optional shape parameter $\beta$. It returns the probability that an observation is less than or equal to the specified $x$ for Weibull distribution with the shape and scale parameters that you specified. The **Weibull Distribution** function is the inverse of **Weibull Quantile** function.

The Weibull distribution has different shapes depending on the values of $\alpha$ (a scale parameter that affects the $x$ direction) and $\beta$ (a shape parameter). It often provides a good model for estimating the length of life, especially for mechanical devices and in biology. The two-parameter Weibull is the same as the three-parameter Weibull with a threshold of zero.

The Weibull distribution has two parameters, $\alpha > 0$ and $\beta > 0$. When $\beta = 1$ the pdf reduces to the exponential distribution (with $\gamma = 1 / \beta$). The exponential distribution is a special case of both the gamma and Weibull distributions. However, there are Weibull distributions that are not exponential distributions.

Weibull Quantile

Accepts a probability argument $p$, and returns the $p^{th}$ quantile from the Weibull distribution with the shape and scale parameters that you specify. The **Weibull Quantile** function is the inverse of the **Weibull Distribution** function.

Johnson Su Distribution

Returns the probability that a Johnson Su-distributed random variable is less than $x$.

Johnson Su Quantile

Returns the quantile whose value for which the probability is $p$ that a random value would be lower.

Johnson Su Density

Returns the density at $x$ of a Johnson Su distribution.

Johnson Sb Distribution

Returns the probability that a Johnson Sb-distributed random variable is less than $x$.

Johnson Sb Quantile

Returns the quantile whose value for which the probability is $p$ that a random value would be lower.

Johnson Sb Density

Returns the density at $x$ of a Johnson Sb distribution.
Johnson Sl Distribution
Returns the probability that a Johnson Sl-distributed random variable is less than \( x \).

Johnson Sl Quantile
Returns the quantile whose value for which the probability is \( p \) that a random value would be lower.

Johnson Sl Density
Returns the density at \( x \) of a Johnson Sl distribution.

Tukey HSD Quantile
Accepts a probability argument \( 1 - \alpha \), and returns the \( 1 - \alpha \) quantile from Tukey’s HSD test for the parameters that you specify. The \( \alpha \) argument is the significance level that you want. \( nGroups \) is the number of groups in a study. \( dfe \) is the error degrees of freedom (based on the total study sample). This is the quantile used to calculate least significant difference in Tukey’s multiple comparisons test.

Tukey HSD P Quantile
Returns the \( p \)-value from Tukey’s HSD multiple comparisons test.

F Power and F Sample Size
The \text{F Power} function calculates the power from a given situation that involves an F-test or t-test, and the \text{F Sample Size} function computes the sample size. The arguments are the values that you specify for computation of a prospective power analysis. (These functions perform the same computations as if you selected \text{DOE > Sample Size and Power}. See the \text{Design of Experiments Guide} for a discussion of power and sample size.) The arguments include:

- \text{alpha} The significance level that you are willing to tolerate (often 0.05).
- \text{dfh} The hypothesis degrees of freedom. It is one (1) for a t-test.
- \text{dfm} The model degrees of freedom (such that \( dfe = n - dfm \)).
- \text{SquaredSize} The squared effect size scaled by the error variance, which is used for making the noncentrality argument for the \( F \)-distribution. For this argument, use squared size \( = \Delta^2 / \sigma^2 \) where \( \sigma^2 \) is the error variance. That is, use:

\[
\Delta^2 = (\bar{x} - \mu)^2 \quad \text{for a one-sample t-test}
\]

\[
\Delta^2 = \left( \frac{\bar{x}_1 - \bar{x}_2}{4} \right)^2 \quad \text{for a two-sample t-test}
\]
Discrete Probability Functions

**Gamma Poisson Probability**

Returns the probability or pmf that a gamma-Poisson distributed random variable is equal to \( x \). In general, the gamma Poisson functions accept arguments that are the mean parameter \( \lambda \), the overdispersion parameter \( \sigma \), and the count of interest \( x \). When the overdispersion is equal to one, the Gamma Poisson reduces to a Poisson(\( \lambda \)) distribution.

**Gamma Poisson Distribution**

Returns the probability that a gamma-Poisson distributed random variable is less than or equal to \( x \). In general, the gamma Poisson functions accept arguments that are the mean parameter \( \lambda \), the overdispersion parameter \( \sigma \), and the count of interest \( x \).

**Gamma Poisson Quantile**

Returns the smallest integer quantile for which the cumulative probability of the Gamma Poisson (\( \lambda, \sigma \)) distribution is larger than or equal to \( p \).

**Binomial Distribution**

Returns the probability that an observation from a binomial distribution with parameters \( p \) and \( n \) is less than or equal to \( k \). In general, the binomial functions accept arguments that are the probability of success \( p \) (the event of interest), the number of trials \( n \), and the number of successes \( k \).

**Binomial Probability**

Computes the probability that a random variable from a binomial distribution is equal to \( k \). In general, the binomial functions accept arguments that are the probability of success \( p \) (the event of interest), the number of trials \( n \), and the number of successes \( k \).

**Binomial Quantile**

Returns the smallest integer quantile for which the cumulative probability of the Binomial \( (p, n) \) distribution is larger than or equal to the specified probability.
Neg Binomial Distribution
Returns the probability that a negative binomially distributed random variable is less than or equal to \( k \), where the probability of success is \( p \), and the number of successes is \( n \).

Neg Binomial Probability
Returns the probability that a negative binomially distributed random variable is equal to \( k \), where the probability of success is \( p \), and the number of successes is \( n \).

Beta Binomial Distribution
Returns the probability or pmf that a beta binomially distributed random variable is less than or equal to \( x \). In general, the beta binomial functions accept arguments that are the probability of success \( p \) (the event of interest), the overdispersion parameter \( \delta \), and the number of trials \( n \). When the overdispersion parameter for the beta binomial is zero, the distribution reduces to a binomial\((p, n)\).

Beta Binomial Probability
Returns the probability or cmf that a beta binomially distributed random variable is equal to \( x \). When the overdispersion parameter for the beta binomial is zero, the distribution reduces to a binomial\((p, n)\).

Beta Binomial Quantile
Returns the smallest integer quantile for which the cumulative probability of the Beta Binomial \((p, n, \delta)\) distribution is larger than or equal to the specified probability. When the overdispersion parameter for the beta binomial is zero, the distribution reduces to a binomial \((p, n)\).

Hypergeometric Distribution
Computes the probability that a random variable from a hypergeometric distribution is less than or equal to \( x \). The hypergeometric distribution models the total number of successes in a fixed sample drawn without replacement from a finite population. The hypergeometric functions accept as arguments the size of the population \( N \), the total number of items with the desired characteristic in the population \( K \), the number of samples drawn \( n \), and the number of successes in the sample \( x \).

Hypergeometric Probability
Computes the probability that a random variable from a hypergeometric distribution is equal to \( x \).
Poisson Distribution
Computes the probability that a random variable from a Poisson distribution with mean lambda is less than or equal to the count of interest. In general, Poisson functions accept an argument that is the count of interest, and lambda, the mean parameter.

Poisson Probability
Computes the probability that a random variable from a Poisson distribution with mean lambda is equal to the count of interest.

Poisson Quantile
Returns the smallest integer quantile for which the cumulative probability of the Poisson (lambda) distribution is larger than or equal to p.

Statistical Functions

There are two types of Statistical functions you can use in a formula:

• The functions with names that have the prefix Col. These functions compute statistics for a column of numbers or expressions involving columns.

• The Mean, Std Dev, Number, Sum, Quantile, Maximum, Minimum, and N Missing functions. These functions evaluate across columns or arguments. The statistic is computed for each row across the series of arguments. You can use the insert key ( ) on the on-screen keypad, or type a comma to add arguments to the functions that accept multiple arguments. When there are multiple contiguous arguments, select the function and the first argument, and then Shift-click the last argument in the group. These functions then automatically show with the complete list.

See the Scripting Guide for details about syntax.

Col Mean
Calculates the mean (or arithmetic average) of the numeric values identified by its argument. The formula Col Mean(age) calculates the average of all nonmissing values in the age column.

Col Std Dev
Measures the spread around the mean of the distribution identified by its argument. In the normal distribution, about 68% of the distribution is within one standard deviation of the mean. 95% of the distribution is within two standard deviations of the mean. 99% of the distribution is within three standard deviations of the mean.
Col Number
Counts the number of nonmissing values in the column that you specify. A missing numeric value occurs when a cell has no assigned value or is the result of an invalid operation (such as division by zero). Missing values show on the spreadsheet as a missing value mark (•). Missing character values are null character strings. In formulas for row state columns, an excluded row state characteristic is treated as a missing value.

Col N Missing
Counts the number of missing values in the column that you specify. A missing numeric value occurs when a cell has no assigned value or is the result of an invalid operation (such as division by zero). Missing values show in the data grid with a missing value character (•). Missing character values are null character strings.

Col Sum
Computes the sum of the values in its numeric argument. Missing values are ignored.

Col Minimum and Col Maximum
Takes the minimum of its numeric arguments. Col Minimum ignores missing values. Col Maximum takes the maximum of a numeric column argument and ignores missing values.

Col Quantile
Computes the value at which a specific percentage of the values is less than or equal to that value. For example, the value calculated as the 50% quantile, also called the median, is greater than or equal to 50% of the data. Half of the data values are less than the 50th quantile.

The Col Quantile function’s quantile argument represents the quantile percentage divided by 100. The 25% quantile, also called the lower quartile, corresponds to \( p = 0.25 \), and the 75% quantile, called the upper quartile, corresponds to \( p = 0.75 \).

The Formula Editor computes a quantile for a column of \( n \) nonmissing values by arranging the values in ascending order. The subscripts of the sorted column values, \( y_1, y_2, \ldots, y_n \), represent the ranks in ascending order.

The \( p \)th quantile value is calculated using the formula \( p(n + 1) \), where \( p \) is the percent value and \( n \) is the total number of nonmissing values. If \( p(n+1) \) is an integer, then the quantile value is \( y_{p(n+1)} \). If \( p(n + 1) \) is not an integer, then the value is interpolated by assigning the integer part of the result to \( i \), assigning the fractional part to \( f \), and applying the formula \((1 – f)y_i + (f)y_{i+1}\).

For example, suppose a column has values 2, 4, 6, 8, 10, 12, 14, 16, 18, and 20. The 50% quantile is calculated as \( 0.5(10 + 1) = 5.5 \).

Because the result is fractional, the 50% quantile value is interpolated as

\[(1 – 0.5) \times 10 + (0.5) \times 12 = (0.5)10 + (0.5)12 = 6 + 5 = 11\]
The following are example ColQuantile formulas:

- `ColQuantile(age, 1)` Calculates the maximum age.
- `ColQuantile(age, 0.75)` Calculates the upper quartile age.
- `ColQuantile(age, 0.5)` Calculates the median age.
- `ColQuantile(age, 0.25)` Calculates the lower quartile age.
- `ColQuantile(age, 0)` Calculates the minimum age.

The ColQuantile argument can be any expression that evaluates to a value between (and including) 0 and 1. For example, the first formula in Figure A.11 calculates quantile values of age in ascending order for each row. The column then contains the interpolated values of age in ascending order in the calculated column. The second formula lists the interpolated values of age in descending order.

**Figure A.11** Examples of the Quantile Function

Col Rank

Ranks each row’s value, from 1 for the lowest value to the number of non-missing columns for the highest value. Ties are broken arbitrarily.

Col Standardize

Performs the usual standardization on its numeric expression. For each row i, 

`Col Standardize(height)` is `<i>(HeightRow()–Col Mean(Height))/Col Std Dev(Height)</i>`.

Mean

Calculates the arithmetic average of the nonmissing arguments that you specify. The arguments can be constants, numbers, or expressions. The Mean function initially shows with a single argument. You add arguments with the insert button ((shift) on the Formula Editor keypad or by typing a comma.

Std Dev

Computes standard deviation of the list of arguments that you specify. The arguments can be constants, numbers, or expressions. The Std Dev function initially shows with a single argument. You add arguments by clicking the insert button (shift) on the Formula Editor keypad or by typing a comma.

Number

Counts the number of nonmissing values in the list of arguments that you specify.
Sum
Returns the sum of the arguments.

Quantile
Calculates the quantile given by its first argument for all the following arguments given.

**Summation (Σ)**
Evaluates for an explicit range of values in a column, as given by the summation indices. This behavior is different from all other statistical functions (except **Product**), which always evaluate on every row. The **Summation** function uses the summation notation shown in Figure A.12. To calculate a sum, replace the missing body term with an expression containing the index variable $i$, or an index variable that you assign. **Summation** repeatedly evaluates the expression for $i = 1$, $i = 2$, through $i = \text{NRow}()$ and then adds the nonmissing results together to determine the final result.

You can replace $\text{NRow}()$, the number of rows in the active spreadsheet, and the index constant, $i$, with any expression appropriate for your formula. For example, the summation formula in Figure A.12 computes the total for each row of all revenue values for rows 1 through the current row number, filling the calculated column with the cumulative totals of the revenue column.

**Figure A.12** Example of the **Summation** function

![Summation Formula](image)

**Product (Π)**
Evaluates for an explicit range of values in a column, as given by the summation indices, as opposed to all other statistical functions (except **Summation**), which always evaluate on every row. **Product** uses the notation shown in the formulas on the right in Figure A.13. To calculate a product, replace the missing body term with an expression containing the index variable $j$. **Product** repeatedly evaluates the expression for $i = 1$, $i = 2$, through $i = n$ and multiplies the nonmissing results together to determine the final result.

You can replace $\text{NRow}()$, the number of rows in the active spreadsheet and the index constant, $i$, with any expression appropriate for your formula.

For example, the expression second product example in Figure A.13 calculates $i!$ (each row number’s factorial).
Minimum and Maximum

Return the minimum and maximum value, respectively, from the list of nonmissing arguments that you specify.

N Missing

Counts the number of missing values in the list of arguments that you specify.

Desirability

Are smooth piecewise functions that are crafted to fit the control points. The minimize and maximize functions are three-part piecewise smooth functions that have exponential tails and a cubic middle.

The target function is a piecewise function. It is a scale multiple of a normal density on either side of the target (with different curves on each side), which is also piecewise smooth and fit to the control points.

Random Functions

You can create formulas that generate real numbers by effectively “rolling the dice” within the constraints of the specified distribution. Each time you click Apply in the Formula Editor window, these functions produce a new set of random numbers.

Note: Random numbers are generated using the Mersenne-Twister technique. This technique has a period length of $2^{19937}-1$. For details about the generators, see Matsumoto and Nishimura (1998). The new generators are verified to pass all the DIEHARD tests as documented in Marshalled (1996).

See the Scripting Guide for details about syntax.

Random Uniform

Generates random numbers uniformly between 0 and 1. This means that any number between 0 and 1 is as likely to be generated as any other. The result is an approximately even distribution. You can shift the distribution and change its range with constants. For example, $5 + \text{Random Uniform()} \times 20$ generates uniform random numbers between 5 and 25.
Random Normal
 Generates random numbers that approximate a normal distribution with a mean of 0 and standard deviation of 1 if no arguments are used, or with the mean and standard deviation entered as arguments. The normal distribution is bell shaped and symmetrical. You can also modify the Random Normal function with constants if no arguments are entered to give a normal distribution with specific mean and standard deviation. For example, the formula Random Normal() * 5 + 30 generates a random normal variable with a mean of 30 and a standard deviation of 5.

Random Exp
 Generates a single parameter exponential distribution for the distribution parameter lambda=1. You can modify the exponential function to use a different lambda.

For example, Random Exp() / .1 generates an exponential distribution for lambda=0.1. The exponential distribution is often used to model simple failure time data, where lambda is the failure rate.

Random Gamma
 Gives a gamma distribution for the parameter, alpha, you enter as the function argument. The gamma distribution describes the time until the kth occurrence of an event. The gamma distribution can also have a scale parameter, beta. A gamma variate with shape parameter alpha and scale beta can be generated with the formula beta*Random Gamma(alpha). If 2*alpha is an integer, a Chi-squared variate with 2*alpha degrees of freedom is generated with the formula 2*Random Gamma(alpha).

Random Beta
 Generates a pseudo-random number distributed Beta(alpha, beta).

Random Cauchy
 Generates a Cauchy distribution with location parameter 0 and scale parameter 1. The Cauchy distribution is bell shaped and symmetric but has heavier tails than the normal distribution. A Cauchy variate with location parameter alpha and scale parameter beta can be generated with the formula alpha + beta * Random Cauchy().

Random Category
 Generates a random category given an alternation of probability and result expressions (for example, Random Category(.2, "A", .3, "B", .4, "C", "D").)

Random Johnson Su
 Returns a random number from the Johnson Su distribution.
Random Johnson Sb
Returns a random number from the Johnson Sb distribution.

Random Johnson Sl
Returns a random number from the Johnson Sl distribution.

Random Triangular
Generates a triangular distribution of numbers between 0 and 1, with the midpoint that you enter as the function argument. You can add a constant to the function to shift the distribution and multiply to change its span.

Random Integer
Generates a uniform distribution of integers between 1 and the argument that you enter as n1, if nothing is entered for n2. If you enter both n1 and n2 (n1<n2), Random Integer generates a uniform distribution of the integers between and including n1 and n2.

Random Binomial
Generates random numbers from a binomial distribution with parameters that you enter as function arguments. The first argument is n, the number of trials in a binomial experiment. The second argument is p, the probability that the event of interest occurs. When n is 1, the binomial function generates a distribution of Bernoulli trials. For example, n =1 and p = 0.5, give the distribution of tossing a fair coin. The mean of the binomial distribution is np, and variance is np(1 – p).

Random Negative Binomial
Generates a negative binomial distribution for the parameters that you enter as function arguments. The first parameter is the number of successes of interest (r) and the second argument is the probability of success (p). The random variable of interest is the number of failures that precede the rth success. In contrast to the binomial variate, where the number of trials is fixed and the number of successes is variable, the negative binomial variate is for a fixed number of successes and a random number of trials. The mean of the negative binomial distribution is (r(1 – p))/p and the variance is (r(1 – p))/p^2.

Random Beta Binomial
Returns random numbers from the beta binomial distribution for n trials with probability p and correlation or overdispersion delta.

Random Frechet
Returns a random number from a Fréchet distribution with the location mu and scale sigma.
Random Geometric
Returns random numbers from the geometric distribution with the parameter that you enter as the function argument. The parameter, $p$, is the probability that a specific event occurs at any one trial. The number of trials until a specific event occurs for the first time is described by the geometric distribution. The mean of the geometric distribution is \((1-p)/p\), and the variance is \((1 - p)/p^2\).

Random Poisson
Generates a Poisson variate based on the value of the parameter, lambda, you enter as the function argument. Lambda is often the expected number of events occurring per unit time or unit of area. Lambda is both the mean and the variance of the Poisson distribution.

Random Gamma Poisson
Returns random numbers from the gamma Poisson distribution with parameters $\lambda$ and $\sigma$.

Random Weibull
Returns a random number from a Weibull distribution.

Random Logistic
Returns a random number from a logistic distribution with the location $\mu$ and scale $\sigma$.

Random Loglogistic
Returns a random number from a loglogistic distribution with the location $\mu$ and scale $\sigma$.

Random Lognormal
Returns a Lognormal-distributed random number with location parameter $\mu$ and scale $\sigma$.

Random GLog
Returns random numbers from the generalized logarithm distribution with parameters $\mu$, $\sigma$, and $\lambda$. When $\lambda$ is equal to zero, the function returns a lognormal($\mu$, $\sigma$).

Random Reset
Restarts the random number sequences with a seed that you specify.

Random LEV
Returns a random number from an LEV distribution with the specified location $\mu$ and scale $\sigma$. 
Random SEV

Returns a random number from the smallest extreme distribution with the specified location \( mu \) and scale \( sigma \).

Col Shuffle

Selects a row number at random from the current data table. Each row number is selected only once. When \( \text{Col Shuffle} \) is used as a subscript, it returns a value selected at random from the column that serves as its argument. Each value from the original column is assigned only once as \( \text{Col Shuffle} \)'s result.

For example, to identify a 50% random sample without replacement, use the formula in Figure A.14.

**Figure A.14** Formula Identifying 50% Random Sample

\[
\begin{align*}
\text{Col Shuffle}^{\lfloor \text{Col} \times 0.5 \rfloor} & = \begin{cases} 
\text{Col Shuffle} & \text{if } \text{Col} \leq 0.5 \\
\text{else} & \text{Col Shuffle}
\end{cases}
\end{align*}
\]

The formula in Figure A.14 selects half the values \((n/2)\) from the column \(x\) and assigns them to the first half of the rows in the computed column. The remaining rows of the computed column fill with missing values.

Resample Freq

Generates a random selection with replacement frequency counts, suitable for use in bootstrapping. For example, it supports a second \( \text{Freq Column} \) argument, enabling it to do bootstrap samples relating to a pre-existing frequency column specified in the second argument. \( \text{Resample Freq()} \) generates a 100% resample. \( \text{ResampleFreq(rate)} \) generates a rate frequency sample. \( \text{Resample(rate, column)} \) generates a sample that is calculated by the rate multiplied by the sum of the specified column.

**Date Time Functions**

JMP stores dates and times in numeric columns using the Macintosh standard of the number of seconds since January 1, 1904. When a column has date values, you can assign a date format to that column by double-clicking a column name and selecting Date or Time from the Format menu. See “Numeric Format Options” on page 172 in the “Set Column Properties” chapter.

See the Scripting Guide for details about syntax.
In Minutes, In Hours, In Days, In Weeks, In Years

Converts from the units of the function name to the equivalent number of seconds for the argument. The argument must be a number or numeric expression. For example, In Minutes(2) yields 120, and In Years(1) yields 31,557,600 (60 seconds * 60 minutes * 24 hours * 365.25 days).

Date DMY, Date MDY

Accepts numeric expressions for day, month, and year and return the associated JMP date. For example, Date DMY (20, 3, 1991) and Date MDY(3, 20, 1991) evaluate to 2,752,272,000.

Today

Returns the number of seconds between January 1, 1904 and the current date. For example, at midnight on March 20, 1991 (a Wednesday), the Today function returns 2752272000 (2,752,272,000 seconds) and continues counting. If you evaluate the Today function later in the day, it reflects the additional seconds.

Day, Month, Year,

Returns the day of the month, the month (as a number from 1 to 12), a four-digit year, respectively. The argument for these functions is interpreted as a JMP date. For example, on March 20, 1991:

- Day(2752272000) returns the number 20.
- Month(2752272000) returns the number 3.
- Year(2752272000) returns the number 1991.

Quarter

Returns the annual quarter of a datetime value as an integer 1-4.

Hour, Minute, Second

Returns the hour, the minute, and the seconds of a date-time value, respectively. The argument for these functions is interpreted as a JMP date. For example, on March 20, 1991:

- Hour(2752572649) returns the number 11.
- Minute(2752572649) returns the number 30.
- Second(2752572649) returns the number 49.

Day of Week, Day of Year, Week of Year, Time of Day

The argument for these functions is a JMP date. Day Of Week returns a number from 1 to 7, where 1 represents Sunday. Day Of Year returns the number of days from the beginning of the year. Week Of Year returns a number from 1 to 52 based on the rule specified. Rule 1 (default) has weeks start on Sunday with the first Sunday being week 2 and week 1 is a partial week or
empty; rule 2 has the first Sunday begins week 1 with any previous days being week 0; rule 3 returns the ISO week number where the week starts on Monday and week 1 is the first week of the year with four days in that year. With ISO weeks, it is possible for the first or last three days of the year to belong to the neighboring year’s week number. Time Of Day returns a number from 0 to 86399 (time of day in seconds). For example, on Wednesday, March 20, 1991:

- Day Of Week(2752272000) returns the number 4.
- Day Of Year(2752272000) returns the number 79.
- Week Of Year(2752272000) returns the number 12.
- Time Of Day(2752272000) returns the number 0.

Informat

The argument for the Informat function is a date character string. For example, Informat(“03/20/1991”) returns the appropriate JMP date value, 2752272000. JMP can read all the date formats except for Abbrev Date and Long Date.

Abbrev Date, Long Date, Short Date

The argument for these date functions is a JMP date. They return character strings that are the formatted representation of the argument. For example:

- Abbrev Date(2752272000) returns Wed, Mar 20,1991.
- Long Date(2752272000) returns Wednesday, March 20, 1991.
- Short Date(2752272000) returns 3/20/91.

Format

The first argument in the Format function is a JMP date. This function returns the character string representation of the date by the date format that you specify in the second argument, which is a quoted string. If you apply this formula to a numeric column, JMP automatically changes the column’s data type to character.

You can also supply a column for the first argument and leave the rest blank. The result is the formatted value of the column reference. This can be used to extract value labels of a column when the value labels are turned off.

MDYHMS

The argument of MDYHMS is a JMP date. This function shows all date and time fields, appending zeros as time fields if no time information is present. This is useful if a date column is formulated such that not all date information is displayed. The MDYHMS function can be used to see all available date and time information.
Date Increment

Adds 1 or more intervals to a starting datetime value. For example, `Date Increment(Today(), "Day", 3)` adds three days to the current date. `Date Increment(Today(), "Year", 3)` adds 3 years to the current date.

Date Difference

Returns the difference of two datetime values. The interval argument can be Second, Minute, Hour, Day, Week, Month, Quarter, Year. The alignment arguments are described here:

- **Start** is used to count the number of times an interval starts.
- **Actual** is used to count whole intervals.
- **Fractional** is used to count fractional intervals.

For example, the following formula returns `207.890243055556`, the number of days between the dates:

```
Date Difference(01Jan2010:00:00:00, 27Jul2010:21:21:57, "Day", "fractional"));
```

The following formula returns `207`, the number of completed days between the dates:

```
Date Difference(01Jan2010:00:00:00, 27Jul2010:21:21:57, "Day", "actual"));
```

The following formula returns `9`, the number of completed hours between the times:

```
Date Difference(01Jan2010:00:00:00, 01Jan2010:09:22:57, "Hour", "actual"));
```

The following formula returns `1`, the number of times a new hour started between the times:

```
Date Difference(31Dec2010:23:59:59, 01Jan2011:00:59:59, "Hour", "start"));
```

Row State Functions

There are six characteristics that rows in a data table can have: selected, hidden, excluded, labeled, colored, and marked. If you give rows one or more of these characteristics and then create row state data table columns, you can then create a formula that computes and saves row state conditions. (See “Assign Column Properties” on page 178 in the “Set Column Properties” chapter, and “Row State Columns” on page 175 in the “Set Column Properties” chapter.) This formula processes row state data just as it would process character and numeric data.

See the *[Scripting Guide]* for details about syntax.

**Note:** A row can be assigned any combination of row states; a row state column can have multiple row states as a value.
Table A.2 describes the type of argument each Row State function requires and what each returns.

**Table A.2  Row State Functions**

<table>
<thead>
<tr>
<th>Function Name</th>
<th>Argument Type Required</th>
<th>What the Function Returns (Your Column Data Type Should be This Type)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Row State</td>
<td>none</td>
<td>row state of current row</td>
</tr>
<tr>
<td>As Row State</td>
<td>numeric</td>
<td>all row states of current row</td>
</tr>
<tr>
<td>Combine States</td>
<td>multiple row state arguments</td>
<td>multiple row state assignments</td>
</tr>
<tr>
<td>Excluded State</td>
<td>positive integer or zero</td>
<td>row state-excluded or not excluded</td>
</tr>
<tr>
<td>Hidden State</td>
<td>positive integer or zero</td>
<td>row state-hidden or not hidden</td>
</tr>
<tr>
<td>Labeled State</td>
<td>positive integer or zero</td>
<td>row state-labeled or not labeled</td>
</tr>
<tr>
<td>Color State</td>
<td>integer or color name or {red, green, blue}</td>
<td>row state color</td>
</tr>
<tr>
<td>Marker State</td>
<td>integer or character</td>
<td>row state marker</td>
</tr>
<tr>
<td>Selected State</td>
<td>positive integer or zero</td>
<td>row state-selected or not selected</td>
</tr>
<tr>
<td>Hue State</td>
<td>integer</td>
<td>row state hue</td>
</tr>
<tr>
<td>Shade State</td>
<td>integer 1-5</td>
<td>row state intensity</td>
</tr>
<tr>
<td>Excluded</td>
<td>Row State() or row state column</td>
<td>numeric 0 (not excluded) or 1 (excluded)</td>
</tr>
<tr>
<td>Hidden</td>
<td>Row State() or row state column</td>
<td>integer 0 (not hidden) or 1 (hidden)</td>
</tr>
<tr>
<td>Labeled</td>
<td>Row State() or row state column</td>
<td>integer 0 (not labeled) or 1 (labeled)</td>
</tr>
<tr>
<td>Color Of</td>
<td>Row State() or row state column</td>
<td>color map integer</td>
</tr>
<tr>
<td>Marker Of</td>
<td>Row State() or row state column</td>
<td>marker map integer</td>
</tr>
<tr>
<td>Selected</td>
<td>Row State() or row state column</td>
<td>integer 0 (not selected) or 1 (selected)</td>
</tr>
</tbody>
</table>
Row State

Returns the active row state condition of the current row as true or false. You can use this function to conveniently write conditional clauses that depend on the status of the current row. For example, Figure A.15 assigns a 1 to rows that are currently selected and labeled and 0 otherwise.

**Figure A.15 Row State**

As Row State

Converts a numeric argument to a row state or set of row state conditions. Row states are stored internally in JMP as a 16-bit number, with each bit assigned to represent one of the possible row states as illustrated in Figure A.3. For example, the binary representation of 1327 is `0000010100101111`. As Row State(1327) would therefore set the row state as selected, excluded, hidden, labeled, with marker 2 and color 10.

**Table A.3 Row States Stored as 16-Bit Numbers: Each Bit Represents a Row State**

<table>
<thead>
<tr>
<th>Bit</th>
<th>Row State</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Not selected (0) or Selected (1)</td>
</tr>
<tr>
<td>1</td>
<td>Unexcluded (0) or Excluded (1)</td>
</tr>
<tr>
<td>2</td>
<td>Unhidden (0) or Hidden (1)</td>
</tr>
<tr>
<td>3</td>
<td>Unlabeled (0) or Labeled (1)</td>
</tr>
<tr>
<td>4-7</td>
<td>Marker</td>
</tr>
<tr>
<td>8-14</td>
<td>Color</td>
</tr>
</tbody>
</table>

Combine States

Generates a row state combination with two or more arguments. Use the insert button (امج) on the Formula Editor keypad or type a comma to add arguments to the Combine States function. The currently selected expression becomes the first argument when you select Combine States. Replace each argument with an expression that evaluates to a row state. This formula:

```
Combine States(
    Selected State(Modulo(Row(),2)),
    Labeled State(Modulo(Row()+1,2))
)
alternately labels or selects each row in the calculated row state column. The Selected State and Labeled State functions are defined later in this section. Use the insert (\texttt{\textbf{[}}) and delete (\texttt{\textbf{]}\textbf{)} buttons on the Formula Editor keypad to add more arguments or remove unwanted arguments.

If you include conflicting row states in a combination, the results are unpredictable.

**Excluded State**

Interprets a numeric argument as true or false. When an argument evaluates as true, the Excluded State function assigns the excluded condition as the value of the column for that row. For example, 
\[
\text{Excluded State(Modulo(Row(),2))}
\]
assigns the excluded row state as the value of the row state column for each odd numbered row.

**Hidden State**

Assigns the hidden row state condition when its argument is greater than zero. If the argument is zero, the value in the column for that row is not hidden.

**Labeled State**

Gives the labeled row state condition when its argument is greater than zero. If the argument is zero the row value in the column for that row is not labeled.

**Color State**

Returns the color from the JMP color map that corresponds to its integer argument. JMP colors are numbered 0 through 84. Zero maps to black.

**Marker State**

Returns markers from the JMP marker map that correspond to its integer argument. JMP markers are numbered 0 through 16. The formula 
\[
\text{Marker State(Row())}
\]
assigns all the row state markers in a repeating sequence determined by the current row number to the calculated row state column. A row state column can have multiple row states as a value.

**Selected State**

Gives the selected row state condition when its argument is greater than zero. If the argument is zero, the value in the column for that row is not selected.

**Hue State**

Returns the color from the JMP hue map that corresponds to its integer argument. JMP hues are numbered 0 through 11 but larger integers are treated as \textit{modulo} 12. The \texttt{\textbf{Hue State}} function does not map to black, gray, or white. A hue of zero maps to red and hue of 11 maps to magenta. The formula on the left in Figure A.16 assigns row state colors in a chromatic spread based on the value of \(z\). The \texttt{\textbf{Hue State}} function used with a row state data type column.
Shade State

Assigns five shade levels to a color or hue. A shade of –2 is darkest and shade of +2 is lightest. A shade of zero is a pure color. The formula on the right in Figure A.16 assigns shade values based on the value of \( z \).

**Figure A.16** Examples of Hue and Shade Functions

To assign all shades of all the colors in the colors palette, you need to use the **Hue State** and **Shade State** assignments together. The formula in Figure A.17 uses the **Combine States** function described at the beginning of this section. The first argument in the **Combine States** function is the **Hue State** formula shown previously, and the second argument is the **Shade State** formula. In addition, the **Marker State** function with an argument of 2 assigns the \( X \) marker to each row, and the **Selected State** function with an argument of 1 selects each row.

**Figure A.17** Combine States Example For Using Both Hue State and Row State

**Excluded, Hidden, Labeled, and Selected**

Accepts a row state expression argument (row state column or row state constant) that evaluates as either 1 or 0 (true or false). These characteristics are inactive by default. Often, the **Row()** function is the argument, which detects the active row state condition of each row. For example, in Figure A.18, the formula assigns 99 whenever a row is actively selected, and 0 otherwise. Note that this formula is used in a column that has a numeric data type.

**Figure A.18** Example of a Formula Using the **Selected** Function

The example in Figure A.19 assigns row state conditions to a row state column. The formula for the row state column (in the columns called **row state col**) checks to determine whether the active row state is either **Hidden** or **Excluded**, and if so, assigns the **Labeled** row state.
Color Of

Accepts any row state expression or column, or the `Row State()` function as its argument. Returns a number from the JMP color map that corresponds to the active color state, or zero if there is no assigned color.

Marker Of

Accepts any row state expression or column, or the `Row State()` function as its argument. Returns a number from the JMP marker map that corresponds to the active marker or zero if there is no assigned marker.

---

**Assignment Functions**

**Assignment** functions work in place. That is, the result returned by the operation (on the right of the operator) is stored in the argument on the left of the operator and replaces its current value.

Assignment statements are most often used in conjunction with other commands to build a JSL script. You can use the Formula Editor to create and execute a script in that column, but this is not recommended because of dependencies and ambiguities that can result. Most often, scripts are stored as .jsl files, and can be saved with a data table. See “Create and Save Scripts” on page 148 in the “Enter and Edit Data” chapter. For details about syntax, see the *Scripting Guide*.

**Note:** The first argument of an assignment function must be capable of being assigned. This means you cannot have an assignment such as `3+=4`, because 3 is a constant value that cannot be reassigned. You must first create a variable (a table variable or local variable) whose value is 3. (For details about table variables, see “Use Table Variables” on page 146 in the “Enter and Edit Data” chapter. For details about local variables, see “Reference Columns and Table Variables” on page 238 in the “Formula Editor” chapter). Then use that variable as the left-hand argument of the assignment function.

\[ = \text{ (assign) } \]
put the value of \( b \) into \( a \). For example \((a=b)\).
+= (add to)  Adds the value of \( b \) to \( a \) and puts the result back into \( a \). For example, \( a += b \).

-= (subtract to)  Subtracts the value of \( b \) and puts the result back into \( a \). For example, \( a -= b \).

*= (multiply to)  Multiplies \( b \) with \( a \) and puts the result back into \( a \). For example, \( a *= b \).

/= (divide to)  Divides \( b \) into \( a \) and puts the result back into \( a \). For example, \( a /= b \).

++ (post increment)  Adds one (1) to \( a \), in place, so that \( a++ \). For example, if the initial value of \( a \) is 4, the expression \( a++ \) changes \( a \) to 5.

-- (post decrement)  Subtracts one (1) from \( a \), in place, so that \( a-- \). For example, if the initial value of \( a \) is 4, the expression \( a-- \) changes \( a \) to 3.

--- Parametric Model Functions ---

This category is a short cut to create three parametric models that are linear functions of set of window-selected columns.

Linear Model, Interactions Model, Full Quadratic Model

Selecting each of these opens a column selection box that lets you select one or more columns to be included in the model. The function then creates and populates the chosen model.

--- Finance Functions ---

Lets you create formulas to calculate principal payments, interest rate, rate of return, and so on.

Double Declining Balance

Returns the depreciation of an asset for a specified period of time. The function uses the double-declining balance method or some other depreciation factor.

Future Value

Returns the future value of an investment that is based on periodic, constant payments and a constant interest rate.

Interest Payment

Returns the interest payment for a given period for an investment that is based on periodic, constant payments and a constant interest rate.

Interest Rate

Returns the interest rate per period of an annuity.
Internal Rate of Return
Returns the internal rate of return for a series of cash flows in the `values` argument.

Modified Internal Rate of Return
Returns the modified internal rate of return for a series of periodic cash flows. The cost of investment and the interest received on reinvested cash is included.

Net Present Value
Returns the net present value of an investment by using a discount rate and a series of future payments (negative values) and income (positive values).

Number of Periods
Returns the number of periods for an investment that is based on periodic, constant payments and a constant interest rate.

Payment
Returns the payment for a loan that is based on constant payments and a constant interest rate.

Present Value
Returns the present value of an investment.

Principal Payment
Returns the payment on the principal for a given period for an investment that is based on periodic, constant payments and a constant interest rate.

Straight Line Depreciation
Returns the straight-line depreciation of an asset for one period.

Sum Of Years Digits Depreciation
Returns the sum-of-years’ digits depreciation of an asset for a specified period.
Symbols

^, See insert button on keypad 464
! (Not) function 464
!= (not equal to) function 460
.emf 358
.eps 358
.gif 358
.pdf 358
*= (Multiply To) function 493
/= (Divide To) function 493
& (And) function 463
& (And) function and conditional clauses 464
+= (Add to) function 493
< (less than) function 460
<= (less than or equal to) function 460
= (Assign) function 492
== (equal to) function 460
> (greater than) function 460
>= (greater than or equal to) function 460
| (Or) function 463

Numerics

1, 2, and 4-byte integers 171

A

A tool. See annotate tool
Abbrev Date function 486
Abs function 445
Add All Windows 371
Add Database Query 371
Add Document 371
Add files opened by scripts to the Recent Files list 403
Add Filter Columns 280
Add Folder 371
add ranges, missing values 180

Add SAS Stored Process 371
Add to (+=) function 493
Add URL 371
Add Window 370
adding
columns 119
graphics and graphics scripts 339
maps and boundaries 329
rows 119
statistics columns 271
add-ins
managing 395–396
opening as text 73
Aggregate 282
Aggregate functions (SQL) 110
allowing short numeric formats 171, 411
analysis roles 194
Analyze toolbar 380
And (&) function 463
And (&) function and conditional clauses 464
annotate tool 333
annotations
creating 333
setting the default font 426
apostrophes in imported data 72
appending horizontally. See joining
appending tables. See concatenating tables
Application toolbar 381
ArcCosH function 449
ArcCosine function 449
archive files in project 370
ArcSine function 449
ArcSinH function 449
ArcTangent function 449
ArcTanH function 449
arguments
definition 262
opening and closing 255
arithmetic buttons on keypad 243
arrange
windows 51
Arrhenius function 447
Arrhenius Inv function 448
arrow
cursor tool 48
double arrow tool 49
As Row State function 488–489
Assign (=) function 492
Assignment functions 492–493
assignment table property 307
asterisk icon 43, 178
attaching tables. See concatenating tables
Auto-complete parentheses and braces, in script editor 430
Auto-hide menu and toolbars 423
automatic recalc option 293
Automatically generate ODS results 433
Auto-save the report to 404
Average 283
axis
adjusting 288, 320
copying and pasting settings 325
customizing 320
divider lines and frames 328
gridlines 326
increments 322
labels 323
minimum and maximum values 320
numeric format 324
scale 321
scrolling 319
specifications for columns 181
tick marks 326

B
background colors 318
backwards compatibility 401
bars, histogram colors 318
base e 446
Bernoulli trials 482
best numeric formats 172
Beta Binomial Distribution function 475
Beta Binomial Probability function 475
Beta Binomial Quantile function 475
Beta Density function 465
Beta Distribution function 465
Beta function 447
Beta functions 447
Beta Quantile function 466
BETWEEN statement (SQL) 109
Big Class.jmp 256
Binomial Distribution function 474
Binomial Probability function 474
Binomial Quantile function 474
Blink button in row editor 142
Blob to Char function 455
boxes around formulas 255
braces in script editor, auto-complete 430
Break function 465
brush tool 308
building formulas 237
buttons
copying 387
creating 383
show and hide 391
By Matching Columns option. See joining

C
Cartesian join. See joining
Categorical Color Theme 407
Cauchy distribution 481
Ceiling function 445
cell formulas 121
Char function 449
Char to Blob function 455
Char to Hex function 453
character data types 170
Character functions 449–456
Character Pattern functions 456–459
character sets
save text as Unicode preference 401
select during text import 71
characteristics, rows and columns 155
ChiSquare Density function 466
ChiSquare Distribution function 466
ChiSquare Quantile function 466
Choose function 462
circle with strikethrough icon 156
Index

Using JMP

clauses 262
cleaning data 133
closing
  JMP Starter window 37
  levels in a report 288
closing JMP Starter window 29
coding, column property 184
Coefficient of Variation 274
Col functions 477, 484
Col Maximum function 477
Col Mean function 476
Col Minimum function 477
Col N Missing function 477
Col Number function 477
Col Quantile function 477
Col Rank function 478
Col Shuffle function 484
Col Standardize function 478
Col Std Dev function 476
Col Sum function 477
Collapse Whitespace function 449
Color function 488
Color Of function 492
Color Presets 408
Color selection, in script editor 431
Color State function 488, 490
Color Theme 182
Color unknown object messages, in script editor 430
colors
  background in graph 318
  backgrounds 318
  by row state 158
  histogram bars 318
  markers 310
  rows and columns 158
  shapes added to reports 334–336
column switcher 292
columns
  adding 119
  adjusting widths 39
  axis specifications 181
  characteristics 155
  compress 195
  control limits 185
  deleting 119
design roles 186
duplicating 140
excluding 155
excluding and hiding 155
fonts used in headings 425
formulas 179, 237
hiding 156
joining 220
labeling 157
locking 165, 169
measuring units 186
moving 140
names 39, 133
notes 179
order of data in reports 185
panel 42–43
preselected analysis roles 194
properties 178, 191
reordering 139
response limits 185
row state 175–176
Sigma values 186
sorting 139
source column 218
spec limits 185
splitting 210
stacking 205
transposing 214
validating data 179–180
value labels 180
Columns Viewer 126
columnwise statistics functions 476
Combine 282
combine reports 290
Combine States function 488–489
communications settings 114, 427
Compare column 132
Comparison functions 459–460
compress columns 195
Compress file when saved option 41
Compress Selected Columns 42
compressing
data tables 41
Compuserve Graphics Interchange Format. See GIF
Concat function 450
Concat Items function 454
concatenating tables 217
Conditional functions 460–465
Connections, database. See database connection
Contains function 450
Continue function 465
**Continuous Color Theme** 407
continuous modeling types 170
**Continuous Scale** command 315
control limits 185
Convert SAS custom formats 434
Copy As SAS Formula 254
**Copy Formula** button, using when
creating a subset 201
joining tables 201, 207, 211, 222
copy menu and toolbar items 387
Copy/Drag Graphic Formats 422
copying
axis frame settings 325
graph contents 325
row states 176
text 359
copying toolbars 380
CosH function 449
Cosine function 448
Count 284
Count (in a formula) 444
Count column 136
Count function 443
creating
menu items and buttons 383
menus 382
source columns (when concatenating tables) 218
creating data tables 114
crosshairs tool 319
Cube 283
Cumulative Sum 285
currency formats
columns 173
cursor forms 48
customization sets
changing 378
importing 392
customizing
axes 320

data
grid 39
missing 134
recoding 133
data feed. See communications settings
Data Filter 296
data filter
conditional 301
Data Filter Auto Clear 412
Data Filter Check Box Display 412
Data Filter Include Check 412
Data Filter Select Check 412
Data Filter Show Check 412
data table
compressing 41
extended file format 41
Data Table Background Color 413
Data Table Clear Selection 165
Data Table Grid Color 413
Data Table Header Grid Color 413
data tables
compare 151–154
compressing 145
concatenating 217
creating 114
data grid 39–49
editing 132
elements of data tables 39
joining 220
locking 41, 145
names and notes, placing on reports 404
names, changing 145
opening 49
panels 40
preferences 410
properties 41, 307
saving 345
sorting 202
<table>
<thead>
<tr>
<th>Using JMP</th>
</tr>
</thead>
<tbody>
<tr>
<td>splitting 210</td>
</tr>
<tr>
<td>stacking 205</td>
</tr>
<tr>
<td>subsetting 199</td>
</tr>
<tr>
<td>summarizing 267</td>
</tr>
<tr>
<td>transposing 214</td>
</tr>
<tr>
<td>updating 231</td>
</tr>
<tr>
<td>Data Tables List toolbar 380</td>
</tr>
<tr>
<td>data types</td>
</tr>
<tr>
<td>character formats 170</td>
</tr>
<tr>
<td>date and time formats 172</td>
</tr>
<tr>
<td>numeric formats 172</td>
</tr>
<tr>
<td>row states 170, 176</td>
</tr>
<tr>
<td>specifying 170</td>
</tr>
<tr>
<td>data view</td>
</tr>
<tr>
<td>created from rows panel 44</td>
</tr>
<tr>
<td>database connection 104–107, 350</td>
</tr>
<tr>
<td>datafeed. See communications settings</td>
</tr>
<tr>
<td>Date 284</td>
</tr>
<tr>
<td>Date Difference function 487</td>
</tr>
<tr>
<td>Date DMY function 485</td>
</tr>
<tr>
<td>Date Increment function 487</td>
</tr>
<tr>
<td>Date MDY function 485</td>
</tr>
<tr>
<td>Date Time functions 484–487</td>
</tr>
<tr>
<td>dates and times</td>
</tr>
<tr>
<td>formats 172–173</td>
</tr>
<tr>
<td>inserting on report window 404</td>
</tr>
<tr>
<td>Day function 485</td>
</tr>
<tr>
<td>Day of Week function 485</td>
</tr>
<tr>
<td>Day of Year function 485</td>
</tr>
<tr>
<td>decreasing font sizes 290</td>
</tr>
<tr>
<td>Default Field Width 412</td>
</tr>
<tr>
<td>defaults</td>
</tr>
<tr>
<td>JMP window 400</td>
</tr>
<tr>
<td>defaults. See factory defaults</td>
</tr>
<tr>
<td>delete button, on formula editor keypad 244</td>
</tr>
<tr>
<td>delete expression 244</td>
</tr>
<tr>
<td>deleting</td>
</tr>
<tr>
<td>columns 119</td>
</tr>
<tr>
<td>functions 253</td>
</tr>
<tr>
<td>menus 390</td>
</tr>
<tr>
<td>rows 119</td>
</tr>
<tr>
<td>toolbars 390</td>
</tr>
<tr>
<td>derivatives 249</td>
</tr>
<tr>
<td>descriptive statistics. See statistics columns</td>
</tr>
<tr>
<td>deselecting parts of a report 289</td>
</tr>
<tr>
<td>Design of Experiments. See DOE 184</td>
</tr>
<tr>
<td>design roles 186, 195</td>
</tr>
<tr>
<td>Design, table variable 147</td>
</tr>
<tr>
<td>Desirability function 480</td>
</tr>
<tr>
<td>desirability values, as column properties 186</td>
</tr>
<tr>
<td>diamond icon, on a report 289</td>
</tr>
<tr>
<td>Dif function 444</td>
</tr>
<tr>
<td>Difference 283, 285</td>
</tr>
<tr>
<td>Difference (reverse order) 283</td>
</tr>
<tr>
<td>Digamma function 447</td>
</tr>
<tr>
<td>disclosure icon. See diamond icon</td>
</tr>
<tr>
<td>discontiguous selection 122, 126</td>
</tr>
<tr>
<td>Discrete Probability functions 474–476</td>
</tr>
<tr>
<td>Display Language 422</td>
</tr>
<tr>
<td>distribution</td>
</tr>
<tr>
<td>column property 187</td>
</tr>
<tr>
<td>setting column property to automatically fit curve 187</td>
</tr>
<tr>
<td>Divide To (/=) function 493</td>
</tr>
<tr>
<td>Dock the Window List 423</td>
</tr>
<tr>
<td>DOE (Design of Experiments)</td>
</tr>
<tr>
<td>coding 184</td>
</tr>
<tr>
<td>toolbar 380</td>
</tr>
<tr>
<td>Double Declining Balance function 493</td>
</tr>
<tr>
<td>downsaving 401</td>
</tr>
<tr>
<td>DPI, report graphics 355</td>
</tr>
<tr>
<td>dragging and dropping</td>
</tr>
<tr>
<td>in data table 140</td>
</tr>
<tr>
<td>into formulas 253</td>
</tr>
<tr>
<td>into other programs 359</td>
</tr>
<tr>
<td>drawing speed of markers 310</td>
</tr>
<tr>
<td>drawing tools 334–336</td>
</tr>
<tr>
<td>dropping</td>
</tr>
<tr>
<td>columns when splitting tables 211</td>
</tr>
<tr>
<td>columns when stacking tables 206</td>
</tr>
<tr>
<td>duplicates when joining tables 223</td>
</tr>
<tr>
<td>Dunnett P Value function 466</td>
</tr>
<tr>
<td>Dunnett Quantile function 466</td>
</tr>
<tr>
<td>duplicating cells and columns 140</td>
</tr>
</tbody>
</table>

**E**

<table>
<thead>
<tr>
<th>Edit Notes 372</th>
</tr>
</thead>
<tbody>
<tr>
<td>editing</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>column names 133</td>
</tr>
<tr>
<td>formulas 252</td>
</tr>
<tr>
<td>names of data tables 145</td>
</tr>
<tr>
<td>names of report tables 307</td>
</tr>
</tbody>
</table>
Index
Using JMP

reports 289
   table variables 147
tables 132
   WHERE clauses 111
efficient evaluations 248
   elements and element browser in formula 262
   eliminating missing rows (when stacking tables) 206
EMS 352
Encapsulated PostScript File 352
End of Field and End of Line options 71
Ends With function 453
end-to-end merging. See concatenating tables
Enhanced Metafile 352
EPS support in reports 352
equal to (==) function 460
equation editor. See formula editor
errors, ignoring in formulas 251
   evaluating columns’ formulas
      viewing evaluations in formulas 252
      when creating subsets 201
      when joining tables 222
      when splitting columns 211
      when stacking columns 207
examples, formulas 256
Excel
   versions 2007+ 62
Excel files
   opening 62
Excel Import Wizard 62
Excel versions 61
Excel, selecting worksheets when opening 401
Excluded function 490–491
Excluded functions 488
excluded rows, showing in a data view 44
excluding
   columns when splitting tables 211
   columns when stacking tables 206
   duplicates when joining tables 223
   rows and columns from analyses 155
Exp function 445
exponent button on keypad 244
exporting
   column names to text files 347
   data tables 345
   reports 351
extended attribute support 434
Extra space at bottom of document, in script editor 430
extracting data from image 332

F
F Density function 467
F Distribution function 467
F Power function 473
F Quantile function 467
F Sample Size function 473
factor
   for mixture experiments 184
Factorial function 446
factory defaults
   min and max axis values 320
fast marker
   drawing speed 310
   threshold 407
fat plus tool 48
Fibonacci series 444
field widths
   of tick mark labels 327
File>Edit toolbar 380
files
   opening 401
   saving without Unicode 401
filling columns with data 177
filtering columns 280
filtering data 296
Finance Functions 493
Find/Length expression 450
finding and replacing values 136
Finding values in a data table. See Search/Find
fit
   column property to draw automatically
      when analyzing distribution of column 187
Floor function 445
fonts
   changing in data tables 39
   changing size in data tables 290
For function 465
For quantile statistics option when summarizing tables 270
Format 434
Index

Using JMP

Format function 486

**Formula** 282

- formula editor 237–260
- formula element browser 242

formulas

- arguments, opening and closing 255
- boxes, hiding and showing 255
- cell expressions 121
- constants, adding 241
- creating 179
  - types of formulas 237
- data table elements, adding 238
- editing 252
- entering into cells 121
- evaluating 247, 251, 413
- examples 256
- expressions 253
- fonts 254, 426
- functions, adding 244, 443
- glossary of terms 261
- JSL view 252
- keyboard shortcuts 261
- opening and closing arguments 255
- operators, adding 242
- orientation in formula editor 255
- shortcuts, keyboard 261
- tutorials 256
- viewing 252, 254

**Frame Border** 409

**Frame Color** 408

- frame sizes of plots or graphs 317

Freq (Frequency). See preselected role

Full Quadratic Model function 493

function browser 244

function types

- Add to (+=) 493
- And 464
- Assign (=) 492
- Assignment 492
- Beta 447
- Character 449
- Character Pattern 456
- Col 477, 484
- Color 488
- Color State 488
- Combine States 488

Comparison 459

Conditional 460

Date Time 484

Discrete Probability 474

Divide To 493

Excluded 488

Hidden 488

Hidden State 488

Hue State 488

Is Missing 459

Marker 488

Match 259

Multiply To (*=) 493

Numeric 445

Parametric Model 493

Post Decrement (−) and Increment (++) 493

Probability 465

Random 480

Row 443

Row State 487

Shade State 488

Statistical 476

Transcendental 445

trigonometric 448–449

functions

- adding 244
- aggregate (SQL) 110
- columnwise statistics 476
- deleting 253
- glossary of terms 263
- peeling 253
- Row States 488

Future Value function 493

**G**

- Gamma Density function 468
- Gamma Distribution function 468
- Gamma function 447
- Gamma Poisson Distribution function 474
- Gamma Poisson Probability function 474
- Gamma Poisson Quantile function 474
- Gamma Quantile function 468
- general preferences 397
- Generate ODS statistical graphics 433
- GIF 352
- global variables, storing a report table 307
GLog Density function 470
GLog Distribution function 470
GLog Quantile function 470
glossary of formula terms 261
Go To command 125
Go To Row command 122
grabber tool. See hand (grabber) tool
Graph
toolbar 380
Graph Background Color 409
Graph Border 406
Graph Builder preferences 415
Graph Format 434
Graph Height 406
graph marker theme, default 407
graph preferences 406
graphics
adding to buttons 385
adding to reports 337
saving reports as graphics 358
scripts 339
Graphics Format 433
Graphics Formats 422
graphics, dragging into graph 330
graphs
copying and pasting contents 325
customizing elements 337
greater than (>) function 460
greater than or equal to (>=) function 460
grid. See data grid
gridlines 326
GROUP BY command (SQL) 110
grouping variables
using when sorting tables 205
using when splitting tables 210

H
hand (grabber) tool
using in formula editor 253
using in reports 288
using to scroll axes 319
HAVING command (SQL) 110
Hex function 453
Hex to Blob function 455
Hex to Char function 453
Hex to Number function 453
Hidden function 490–491
Hidden functions 488
hidden rows
showing in a data view 44
Hidden State function 488
Hide Overlapping Labels 406
hiding
columns 156
menu tips 401
results 289
rows 156
thumbnails of reports 423
toolbars 377
hierarchical data filter 301
Highlight Outline Headers option 422
histograms, bar colors 318
Home
toolbar 381
Home Window 33
horizontal
alignment in reports 288
formula display 255
Hot Dogs.jmp 259
Hour function 485
Hover Help 404
HTML
importing 75
HTML 5, save output as 353
Hue State function 488, 490
Hypergeometric Distribution function 475
Hypergeometric Probability function 475
I
I want to connect to a SAS Environment 433
I want to connect to a SAS Metadata Server 433
I will manually connect to SAS workspace
servers 433
I-beam cursors 48
icons
asterisk 43, 178
circle with strikethrough 156
column characteristics 43
column properties 43
compress 146
diamond (disclosure) 289
list check 43
Index
Using JMP

lock 43, 145
mask 43, 156
modeling types 43
plus 43, 179
preselected roles 195
range check 43
red triangle 291
yellow tag 43, 157
ID column. See Source Label Column
If function 461
IfMax function 463
IfMin function 463
ignoring
errors 251
missing values (when updating tables) 232
images
dragging into graph 330
extracting data 332
Import generated SAS data sets into JMP 433
importance values, entering 186
importing
data 61–77
Excel files 62
HTML 75
ODBC 350
SAS files 79–81
text files 67
text from the Script window 75
toolbar and menu customizations 392
using a database 104
using SQL statements 106
In Days function 485
In Hours function 485
In Minutes function 485
IN statement (SQL) 109
In Weeks function 485
In Years function 485
Include marginal statistics option 269
Include Non Matches option 223
Include Responses Not in Data 412
increasing font sizes 290
indent guides, showing in script editor 430
Informat function 486
initial
data values 177
input formats 172
insert button on keypad 243
Insert function 454
Insert Into function 454
insertion points 48
instruments, connecting 114, 427
Interactions Model function 493
interactive HTML, save output as 353
Interest Payment function 493
Interest Rate function 493
internal name 381, 384
Internal Rate of Return function 494
international numeric formats 175
Internet
file formats 352
opening Internet files 75
Interpolate function 464
Interquartile Range (summary statistics) 274
Is Missing function 459–460
Item function 453

J
JMP Projects 368–373
JMP Starter 29
hiding on startup 400
JMP tutorials 27
JMP.PFS 399
Johnson Sb Density function 472
Johnson Sb Distribution function 472
Johnson Sb Quantile function 472
Johnson Sl Density function 473
Johnson Sl Distribution function 473
Johnson Sl Quantile function 473
Johnson Su Density function 472
Johnson Su Distribution function 472
Johnson Su Quantile function 472
joining
by matching columns 223, 228
by row number 223
tables, methods 220
using Cartesian join 223, 226
Joint Photographic Experts Group (JPEG, JPG) 352, 358
journals
creating 360
JPEG, JPG 352, 358
JSL code folding 431
JSL scripts
  adding 148
  copying 151
  creating from a report 355
  deleting 42, 151
  editing 42, 151
  fonts 426
  formula editor 252
  graphics scripts 339
  new 41
  running 42, 151
  saving in data tables 41
  suppressing automatic execution 410
  viewing in formula editor 252

JSL Scripts should be run only 422

K
  Keep All option 211
  keypad, formula editor 112

L
  Label column name 208
  Labeled and Labeled State functions 488
  Labeled function 491
  Labeled State function 490
  labelled rows
    showing in a data view 44
  labels
    axis 323
    field widths 327
    icon 157, 314
    markers 313
    rows and columns 157
    tick marks 326–328
    value labels 180
  Lag function 444
  language preference, JMP indexes 402
  large plus cursor 48
  laser pointer 405
  lasso tool 309
  Left function 453
  legends 315
    add 314
    remove 316
  Length function 451
  LEV Density function 468
  LEV Distribution function 468
  LEV Quantile function 468
  LGamma function 447
  library. See SAS transport files
  LIKE statement (SQL) 109
  limits, specification, control, response 185
  line numbers, in script editor 430
  line tool 334
  Line Width 406
  linear axis scale 321
  Linear Model function 493
  lines
    width 318
  lines, dotted or dashed reference lines 329
  linked data table 200, 307
  list checking
    cursor 49
    sorting data 202
  Little.jmp 229
  loading, SQL queries 111
  Local Data Filter 292
  local variables
    button on keypad 244
    using in formula 239, 257
  localizing toolbar and button captions 382
  Location 434
  locking
    columns, preventing from being moved 165
    data tables 41, 145
  log
    opening by default 423
    saving 373
    saving a report to 404
    showing DisplayBox messages 402
  Log function 446
  Log window, saving reports to 404
  Log, axis scale type 321
  Log10 function 446
  logarithm, natural 446
  Logist function 446
  Logistic Density function 468
  Logistic Distribution function 468
  Logistic function 446
  Logistic Quantile function 469
  Logit function 448
Loglogistic Density function 469
Loglogistic Distribution function 469
Loglogistic Quantile function 469
Lognormal Density function 469
Lognormal Distribution function 469
Lognormal Quantile function 469
Long Date function 486
lower control limits (LCL) and spec limits 185
Lowercase function 451

M
magnifying glass tool 317
Major Grid Line Color 408
Major Grid Lines 409
Make into Matrix command 307
Make Window with Legend command 315
Manage Rules, in reports 405
manipulating plots/graphs 317
marginal statistics 269
Marker functions 488
Marker Of function 492
Marker Selection Color 407
Marker Selection Fade 407
marker selection mode 407
Marker State function 490
markers
adding 158
changing shape 314
changing sizes 310
colors 310
default shape 407
default size 407
drawing speed 310
drawing speed/marker 310
excluding 313
excluding and hiding 313
hiding 313
highlighting 312
highlighting in plots 307
labeling 313
labels 313
legends 314
outlines 311
point values 315
shapes 158, 310
speed 310, 407
threshold 407
transparency 312
mask icon 156
Match Flag column 222
Match function 259, 461
matching
cases while searching 137
columns when joining tables 228
targets 186
values of two data tables. See joining whole words in search 137
matching columns (update) 233
matching specifications 221, 224
matrix 307
Max (summary statistics) 273
Maximum function 480
MDYHMS function 486
Mean (summary statistics) 273
Mean function 478
measuring units, columns 186
Median 284
Median (summary statistics) 274
members, importing 81
menu items
creating 383
menu preferences 438
menu tips 28, 401
menus
copying 387
creating 382
deleting 390
rearranging 389
merge horizontally. See joining
merge old menus 393
merge vertically. See concatenating
merging same name columns 222
Mersenne-Twister technique 480
Microsoft Excel, preview data 62
Microsoft Word and PowerPoint 359
Min (summary statistics) 273
minimum and maximum axis values 320
Minimum function 480
Minor Grid Line Color 408
Minor Grid Lines 409
Minute function 485
missing
terms, in formulas 263
value comparison 459
values, in formulas 263
values, updating tables 232
missing data patterns 134
missing value code, SPSS 77
missing values 180
add ranges 180
mode, marker drawing 310
modeling types
  continuous 170
  icons 43
  nominal 170
  ordinal 170
  specifying 170
Modified Internal Rate of Return function 494
Modulo function 445
Month function 485
Month Year 284
moving
  cells and columns 140
  rows 140
  selection in data table 413
Multiple Series Stack 206
Multiply To (\*=) function 493
Munger function 450
  example 258

N
N and N Missing (summary statistics) 273
N Categories (summary statistics) 273
N Missing function 480
naming
  data tables 145
  report tables 307
  reports 290
natural logarithm 446
NChooseK function 446
NChooseK Matrix function 446
Neg Binomial Distribution function 475
Neg Binomial Probability function 475
Negation 283
nested variables 271
nesting boxes, formula editor 256
Net Present Value function 494
  new
  columns 119
  rows 119
New Group 370, 372
no-intercept model 184
nominal
  modeling types 170
Non matches, include when joining tables 223
noncentrality 466–467, 471
Normal Biv Distribution function 470
Normal Density function 469
Normal Distribution function 469
Normal Quantile function 470
Not (!) function 464
not equal to (!=) function 460
notes
  as table variables 146
  displaying in report windows 404
  saving in a column 179
NRow function 445
Num function 451
Number function 478
Number of Periods function 494
Number of Series option 206
numeric
  allowing short numeric 411
  formats 172–175
    in axes 324
    short 171
  international formats 175
Numeric functions 445

O
ODBC 104, 350
ODBC drivers for importing data 62
ODBC Hide Connection String 413
ODS Result Format 433
ODS results 97
ODS Style 433
ODS Style sheet 433
Offset expression 450
OnOpen 149
Open All Below command 288
Open All Like This command 288
Open Database Connectivity 350
Open Text File Charset, in general 401
open windows 35
opening
   add-ins as text 73
   data in text editors 73
   databases 104
   Excel files 62
   Excel worksheets 401
   Internet files 76
   JMP files 49
   JMP Starter window 29, 37
   journals 49
   SAS data sets 79
   SAS files 79
   SAS stored process report as data table 77
   scripts 49
   SPSS files 77
   text files 67
operator names
   script editor, adding spaces between words 431
operator tips, showing in script editor 430
operators
   adding 242
   in assignment functions 492
Or (|) function 463
ORACLE synonyms 105
order of operations 247
ordering
   columns 139
   row order levels 185
   values 181
ordinal modeling types 170
orientation of formulas 255
Original 409
outlines
   adding to markers 311
   structure of reports 289
Output Table option
   joining tables 221
   sorting tables 203
oval tool (simple shape tool) 334, 336
parentheses
   script editor, adding spaces inside 431
   script editor, auto-complete 430
password protected data sets 95
Paste Special command 359
Pat Abort function 458
Pat Altern function 458
Pat Any function 456
Pat Arb function 457
Pat Arb No function 458
Pat At function 457
Pat Break function 456
Pat Concat function 458
Pat Conditional function 458
Pat Fail function 458
Pat Fence function 458
Pat Immediate function 458
Pat Len function 456
Pat Match function 459
Pat Not Any function 456
Pat Pos function 457
Pat R Pos function 457
Pat R Tab function 457
Pat Regex function 458
Pat Rem function 457
Pat Repeat function 458
Pat Span function 456
Pat String function 456
Pat Succeed function 457
Pat Tab function 457
Pat Test function 457
patterns of missing data 134
Payment function 494
PDF 352
PDF file, headers and footers 364
peel (delete expression) 244
peel function 253
percent of total (summary statistics) 273
Personalization window 38
Pin File 34
platform preferences 414
platforms
   common features 279
   launch windows 279
plots and graphs
   adding graphics 337
annotations, adding 333
appearances, altering 316
markers, changing 309
resizing 316
shapes, adding 334
statistics, adding 269
PNG 352, 358
points. See markers
Poisson Distribution function 476
Poisson Probability function 476
Poisson Quantile function 476
polygon (spline) tool 335–336
Portable Network Graphics. See PNG
Post Decrement (--) and Increment (++)
functions 493
Pow10 283
power. See Sample Size and Power
PowerPoint 359
precedence 247
preferences 397
   Graph Builder 415
preferences, reset 399
preselected analysis roles 194
Present Value function 494
presentations, journal 365
Preserve SAS formats 348
Preserve SAS formats when exporting to
SAS 411
Preserve SAS variable names 348
Preserve SAS variable names when exporting
to SAS 411
Preview Graph 409
preview pane 52
previewing text on import 69
Principal Payment function 494
Print Data Grid as is 411
printing
   page breaks 359
Probability functions 465–474
Probit function 470
Product function 479
projects
   automatically open files 371
   dragging and dropping files into 371
   fix broken link 372
Prompt if data set has more than 433
properties
   creating with JSL 191
   table properties 307
Q
Quantile function 479
quantile statistics 270
Quarter function 485
queries, SQL 111
quotation marks in imported data 72
R
Random Beta Binomial function 482
Random Beta function 481
Random Binomial function 482
Random Cauchy function 481
random data, adding 177–178
Random Exp function 481
Random Frechet function 482
Random functions 480–484
Random Gamma function 481
Random Gamma Poisson function 483
Random Geometric function 483
Random GLog function 483
Random Integer function 482
Random Johnson Sb function 482
Random Johnson Sl function 482
Random Johnson Su function 481
Random LEV 483
Random Logistic function 483
Random Loglogistic function 483
Random Lognormal function 483
Random Negative Binomial function 482
Random Normal function 481
Random Poisson function 483
Random Reset function 483
random sample (subset) 200
Random Triangular function 482
Random Uniform function 480
Random Weibull function 483
range checking 49
range comparison function 460
ranges, summary statistics 273
Ratio 283
Index
Using JMP

<table>
<thead>
<tr>
<th>Term</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ratio (reverse order)</td>
<td>283</td>
</tr>
<tr>
<td>read-only data</td>
<td>145</td>
</tr>
<tr>
<td>rearrange open windows</td>
<td>35</td>
</tr>
<tr>
<td>rearranging</td>
<td></td>
</tr>
<tr>
<td>cells and columns</td>
<td>140</td>
</tr>
<tr>
<td>results</td>
<td>355</td>
</tr>
<tr>
<td>rearranging toolbars</td>
<td>386</td>
</tr>
<tr>
<td>recent files</td>
<td>34</td>
</tr>
<tr>
<td>Reciprocal</td>
<td>283</td>
</tr>
<tr>
<td>recoding data</td>
<td>133</td>
</tr>
<tr>
<td>rectangle tool (simple shape tool)</td>
<td>334</td>
</tr>
<tr>
<td>red triangle icon</td>
<td>291</td>
</tr>
<tr>
<td>reference lines, adding</td>
<td>329</td>
</tr>
<tr>
<td>Regex function</td>
<td>455</td>
</tr>
<tr>
<td>Regex Match function</td>
<td>459</td>
</tr>
<tr>
<td>Remove From function</td>
<td>454</td>
</tr>
<tr>
<td>Remove function</td>
<td>454</td>
</tr>
<tr>
<td>renaming</td>
<td></td>
</tr>
<tr>
<td>data tables</td>
<td>145</td>
</tr>
<tr>
<td>report tables</td>
<td>307</td>
</tr>
<tr>
<td>reports</td>
<td>290</td>
</tr>
<tr>
<td>reordering</td>
<td></td>
</tr>
<tr>
<td>columns</td>
<td>139</td>
</tr>
<tr>
<td>Repeat function</td>
<td>454</td>
</tr>
<tr>
<td>Replace argument</td>
<td>450</td>
</tr>
<tr>
<td>replacing</td>
<td></td>
</tr>
<tr>
<td>tables (when sorting)</td>
<td>204</td>
</tr>
<tr>
<td>values in a data table</td>
<td>136</td>
</tr>
<tr>
<td>Report Invalid Display Box Messages</td>
<td>402</td>
</tr>
<tr>
<td>report preferences</td>
<td>403</td>
</tr>
<tr>
<td>report windows</td>
<td></td>
</tr>
<tr>
<td>customizing</td>
<td>355</td>
</tr>
<tr>
<td>dates and times, adding</td>
<td>404</td>
</tr>
<tr>
<td>disclosure button</td>
<td>289</td>
</tr>
<tr>
<td>formatting</td>
<td>288</td>
</tr>
<tr>
<td>options</td>
<td>291</td>
</tr>
<tr>
<td>order of data</td>
<td>181, 185</td>
</tr>
<tr>
<td>rearranging results</td>
<td>355</td>
</tr>
<tr>
<td>red triangle icon</td>
<td>291</td>
</tr>
<tr>
<td>renaming</td>
<td>290</td>
</tr>
<tr>
<td>saving</td>
<td>351</td>
</tr>
<tr>
<td>tables</td>
<td>306</td>
</tr>
<tr>
<td>Resample Freq function</td>
<td>484</td>
</tr>
<tr>
<td>Reset file associations</td>
<td>423</td>
</tr>
<tr>
<td>reset preferences</td>
<td>399</td>
</tr>
<tr>
<td>resizing plots/graphs</td>
<td>317</td>
</tr>
<tr>
<td>response limits</td>
<td>185</td>
</tr>
<tr>
<td>responses, multiple</td>
<td>186</td>
</tr>
<tr>
<td>restricting search to selected rows or columns</td>
<td>137</td>
</tr>
<tr>
<td>results. See report windows</td>
<td></td>
</tr>
<tr>
<td>Reverse function</td>
<td>454</td>
</tr>
<tr>
<td>Reverse Into function</td>
<td>454</td>
</tr>
<tr>
<td>reverting columns to original order</td>
<td>139</td>
</tr>
<tr>
<td>rich text format. See RTF</td>
<td></td>
</tr>
<tr>
<td>Right function</td>
<td>453</td>
</tr>
<tr>
<td>roles</td>
<td></td>
</tr>
<tr>
<td>design roles</td>
<td>186</td>
</tr>
<tr>
<td>preselected analysis roles</td>
<td>194</td>
</tr>
<tr>
<td>root button on keypad</td>
<td>244</td>
</tr>
<tr>
<td>Root function</td>
<td>446</td>
</tr>
<tr>
<td>Round function</td>
<td>445</td>
</tr>
<tr>
<td><strong>Row</strong></td>
<td>282</td>
</tr>
<tr>
<td>row</td>
<td></td>
</tr>
<tr>
<td>editor</td>
<td>141</td>
</tr>
<tr>
<td>selection</td>
<td>123</td>
</tr>
<tr>
<td>Row function</td>
<td>443–444</td>
</tr>
<tr>
<td>Row functions</td>
<td>443–445</td>
</tr>
<tr>
<td>row selection, direction of movement when</td>
<td></td>
</tr>
<tr>
<td>pressing Enter/Return</td>
<td>413</td>
</tr>
<tr>
<td>row state</td>
<td></td>
</tr>
<tr>
<td>columns</td>
<td>170, 175–176</td>
</tr>
<tr>
<td>data types</td>
<td>170, 176</td>
</tr>
<tr>
<td>Row State function</td>
<td>489</td>
</tr>
<tr>
<td>Row State functions</td>
<td>487–489</td>
</tr>
<tr>
<td>row states</td>
<td></td>
</tr>
<tr>
<td>clear</td>
<td>165</td>
</tr>
<tr>
<td>coloring rows by column values</td>
<td>158</td>
</tr>
<tr>
<td>rows</td>
<td></td>
</tr>
<tr>
<td>adding</td>
<td>119</td>
</tr>
<tr>
<td>characteristics</td>
<td>155</td>
</tr>
<tr>
<td>coloring</td>
<td>158</td>
</tr>
<tr>
<td>deleting</td>
<td>119</td>
</tr>
<tr>
<td>excluding</td>
<td>155</td>
</tr>
<tr>
<td>hiding</td>
<td>156</td>
</tr>
<tr>
<td>joining</td>
<td>220</td>
</tr>
<tr>
<td>labeling</td>
<td>157, 314</td>
</tr>
<tr>
<td>legends</td>
<td>314</td>
</tr>
<tr>
<td>markers</td>
<td>158</td>
</tr>
<tr>
<td>menu items</td>
<td>48</td>
</tr>
<tr>
<td>moving</td>
<td>140</td>
</tr>
<tr>
<td>order of data in reports</td>
<td>185</td>
</tr>
<tr>
<td><strong>Using JMP</strong></td>
<td><strong>Index</strong></td>
</tr>
<tr>
<td>----------------</td>
<td>----------</td>
</tr>
<tr>
<td>sorting in data tables</td>
<td>202</td>
</tr>
<tr>
<td>subsetting</td>
<td>199</td>
</tr>
<tr>
<td>summarizing</td>
<td>267</td>
</tr>
<tr>
<td>transposing</td>
<td>214</td>
</tr>
<tr>
<td>rows panel</td>
<td>44</td>
</tr>
<tr>
<td>creating a data view of selected rows</td>
<td>44</td>
</tr>
<tr>
<td>RTF (Rich Text Format) files</td>
<td>353</td>
</tr>
<tr>
<td>running scripts</td>
<td>42</td>
</tr>
</tbody>
</table>

**S**

| **Sampling** | **in databases** | 105 |
| SAS |creating transport files | 81 |
| files | 81 |
| importing password-protected data sets | 95 |
| opening data sets | 79 |
| saving in SAS format | 347–349 |
| toolbar | 380 |
| transport files | 347 |
| variable names | 79 |
| variable names in imported data | 79 |
| SAS 9.3 preferences | 432 |
| SAS 9.4 | store extended attributes | 348 |
| SAS metadata server | supported version | 82 |
| SAS metadata server, automatically connect | 433 |
| SAS Server Version | 432 |
| SAS server version | 86 |
| SAS variable labels, importing | 434 |
| SAS, submit code | 96 |

**Save and restore document state information**, in script editor | 430 |
| Save and Save As menu items | 345 |
| Save Data Table Columns GZ Compressed preference | 42 |
| **Save Data Table Columns GZ Compressed**, in general | 402 |
| **Save Journals GZ Compressed**, in general | 402 |
| Save Session Script | 368 |
| Save table in extended file format | 411 |
| Save table in extended file format preference | 41 |
| **Save the session when exiting**, in general | 403 |

**saving**

| **column property** | 184 |
| **data tables** | 345 |
| log windows | 373 |
| reports | 351 |
| reports as graphics | 358 |
| results to a database | 350 |
| scripts | 355 |
| scripts in English | 402 |
| spec, control, and response limits | 185 |
| SQL queries | 111 |
| Unicode | 401 |

**saving and evaluating formulas (when concatenating tables)** | 218 |
| **Scalable Vector Graphic format** | 358 |
| **scaling** | axes | 319 |
| Scheffe Cubic function | 448 |
| Script All By-Groups menu | 292 |
| **script editor**
| auto-complete parentheses and braces | 430 |
| extra space at bottom of document | 430 |
| indent guides, showing | 430 |
| line numbers, showing | 430 |
| operator tips, showing | 430 |
| spaces in operator names | 431 |
| spaces inside parentheses | 431 |
| tab width | 430 |
| use tabs | 430 |
| variable value tips, showing | 430 |
| **Script menu** | 291–293 |
| **scripts**
| graphics | 339 |
| running when a data table is opened | 149 |
| saving in English | 402 |
| See JSL scripts |
| scroll lock/unlock | 165 |
| **scrolling** | axes | 319 |
| Search/Find | 136 |
| using the row editor | 142 |
| Second function | 485 |
| Select Dominant | 123 |
| Select Individual Excel Worksheets command | 401 |
| Select Randomly | 123 |
SELECT statement (SQL) 107
Selected function 488, 491
selected rows
  showing in a data view 44
Selected State function 488, 490
selecting
cells 122, 126, 131
columns 125
  when joining tables 223
irregular area of points 309
parts of a report 289
points in plots 307
rectangular area of points 308
rows and columns in data tables 48–124
rows and columns in plots 308
selection (large plus) cursor 48
Semiconductor Capability.jmp 128–129
sequence data, adding 177
Sequence function 443
sessions, saving 367
setting
  markers according to point values 315
SEV Density function 470
SEV Distribution function 470
SEV Quantile function 471
Shade Alternate Table Rows 409
Shade State function 488, 491
Shade Table Cells 409
Shade Table Headings 409
shapes. See drawing tools
Shift function 454
Shift Into function 454
Short Date function 454
short, allowing short numeric 171, 411
shortcuts, keyboard 261
short-integer format 411
Show Alternate Column Name 412
Show conditional formatting, in reports 405
Show embedded log on script window open, in script editor 430
Show indent guides, in script editor 430
Show line numbers, in script editor 430
Show on the Windows task bar 422
Show operator tips, in script editor 430
Show SAS Log 434
show toolbar 387
Show Tree Structure 289
Show variable value tips, in script editor 430
showing
  boxes around formulas 256
  results 289
Sigma, assigning values 186
simple shape tool (oval or rectangle) 334
simplify formulas 250
Sine function 448
SinH function 449
sizing/scaling 317, 319
slope computation 257
Sorting
  results by fields in a database (SQL) 108
sorting
  data tables 202
  list check 202
  order 205
  value labels 202
  value ordering 202
source columns 218
Source Flag column 222
Source Label Column 207–208
Spaces in operator names, in script editor 431
Spaces inside parentheses, in script editor 431
spec limits 185
specifying columns when importing text files 72
speed, marker 310, 407
splash window 400
Split By column 212
Split Label Col 210
splitting columns 210
SPSS files, opening 77
SQL statements 106–107
SQL WHERE clause editor 111
Square 283
Squish function 446
stacking columns 205
Standard Deviation 273
Standard Deviation function 478
Standard Error 274
Starter Window 37
Starts With function 430
startup windows 400
Statistical functions 476–480
Statistics button 268, 272
statistics column 268, 271–272
Std Dev and Std Err (summary statistics) 273
Std Dev function 478
Step function 464
Stop function 465
Store extended attributes 348
Stored Process Results 434
stored process, copy metadata path 96
Straight Line Depreciation function 494
stripping enclosing quotes on imported data 72
subgroups, summary statistics 271
submit SAS code 96
Subqueries (SQL) 111
Subscript function 444
subsetting
  from a data table 199
  from a histogram 201
Substitute function 454
Substitute Into function 454
Substr function 451
Subtract To (−=) function 493
Sum function 479
Sum Of Years Digits Depreciation function 494
Sum Wgt (summary statistics) 273
summary table, creating 267
Summation function 479
supported version of SAS metadata server 82
suppressing formula evaluation
  in data tables 41
  on open 413
    when creating a subset 201
    when creating formulas 251
    when joining tables 222
    when splitting columns 211
    when stacking columns 207
SVG 353
switch terms button on keypad 244
synonyms (ORACLE) 105
system tables (ORACLE) 105

T

t Density function 471
t Distribution function 471

t Quantile function 471
Tab width, in script editor 430
Table Column Borders 409
table properties
  compare 154
Table Row Borders 409
table variables
  adding 146–220
  creating 41, 147
  editing 147
  in formulas 147, 238
  notes 147
tables
  concatenating 217
  panel 40, 42
  report tables 306–307, 425
  toolbar 380
tabs
  script editor 430
  Tangent function 448
TanH function 449
target value 185–186
terms, formula 262
terms, switching in a formula 244
text
  editing 73
  importing 68
  mode for formulas 252
  opening add-ins as text 73
  opening text files 67
  saving as text 346
threshold of markers 407
tick marks 326
Tick marks inside graph frame 409
Time of Day function 485
time, adding to reports 404
Tip of the Day window
  hiding and showing 400–401
title bar fonts 426
Titlecase function 451
Today function 485
toolbars
  adding buttons 380
  Analyze toolbar 380
  copy 380
  copying 387
Using JMP

create 380
deleting 390
File_Edit toolbar 380
hidden 387
personalizing (Macintosh) 393–395
rearranging 386
show and hide 391
showing by default 423
Tools toolbar 380
types of 380
toolbars and menus
    personalizing (Windows) 377–393
tools, cursor 48, 333
tooltips 28
Transcendental functions 445–448
Transform 282
transform columns 283
transparency, markers 312
transport files, creating 81
transposing rows and columns 214
treat empty columns as numeric 420
Trial1.jmp 224–225
Trial2.jmp 224–225
triangle icon 291
Trigamma function 447
trigonometric function types 448
Trim function 452
truth tables 464
Tukey HSD P Quantile function 473
Tukey HSD Quantile function 473
tutorials 27
    creating formulas 256
two-digit year rule, importing data 72
two-way table of summary statistics 271

U
unary sign function button on keypad 244
Underline Table Headings 409
Ungroup command 356
Unicode 401
    save text files preference 401
units 186
univariate statistics 269
update
    matching columns 233
    updating data tables 231
upper control limits (UCL) 186
upper spec limits 185
Uppercase function 451
US Population.jmp 240
Use a Floating Window for Data Filters 412
Use an Asterisk with the PValue Format, in reports 405
Use Excel Labels as Headings, in general 401
Use SPSS Labels for column names during import, in general 401
Use tabs, in script editor 430
Use Thousands Separator 412
User Tables, database connections 105
V
validating data 179–180
value labels 180
    sorting 202
value ordering
    sorting data 202
values
    high and low for columns (in DOE) 184
    minimum and maximum 320
    ordering 181
variable names 79
variable value tooltips, showing in script editor 430
variables
    local 239
    table. See table variables
Variance (summary statistics) 274
vertical, formula display 255
viewing
    subset of rows in a data view 44
Views, database 105
W-Z
Warn before closing unsaved imported data 434
Week 284
Week of Year function 485
Weibull Density function 471
Weibull Distribution function 472
Weibull Quantile function 472
weight, preselected roles 195
WHERE clause editor 111
WHERE statement (SQL) 108
While function 465
widths
tick mark labels 327
wildtrack.org 332
Window Background Color 409
windows 400
hide splash 400
JMP Starter 400
Windows Explorer
preview pane 52
Word function 452
Word. See Microsoft Word
Words function 452
worksheets, selecting 401
Wrap Text, in script editor 430
Wrap the main menu in narrow windows 423
WWW. See Internet
Y-Axis Title Above Graph 406
Year function 485
Year Quarter 284
yellow tag icon 157, 314
zooming 317