New Features for JMP 7.0
What’s new in JMP

JMP 7 builds on the improvements seen in previous versions of JMP, adding new data access, statistics,
and graphics commands. JMP’s scripting language also continues to expand.

This paper provides an overview of the enhancements. For complete details of each command, see the
appropriate entry in the main documentation.
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Projects

New in SAS Integration

JMP 7 vastly extends the integration with SAS that was present in JMP 6.
¢ A SAS submenu has been added to the File menu in JMP. This submenu has three commands:
Browse Data Opens a window that allows you to browse through servers, libraries, data sets, and
even column within a data set. From here, you can import all or portions of a data set into JMP.
Browse SAS Stored Processes Opens a window that allows you to browse through any stored
processes on the metadata server. From here, you can run those stored processes.
SAS Metadata Server Connection Opens a window that allows you to connect to a metadata
server or a logical server and set your default workspace server.
If you select either of the first two options without being connected to a server, the Connect to SAS
Metadata Server window appears, allowing you to make a connection.
* The JSL interface to SAS has been completely overhauled and extended. Unlike JMP 6, all JSL
methods work identically on all hosts.
* A new category, SAS Integration, has been added to the Preferences window to control settings for
connections and results.
For detailed information on working with SAS, see “SAS Integration,” p. 363 of JMP Users Guide. For
scripting with SAS, see the /MP Scripting Guide.

JMP User Assistance

Projects

Projects are a new addition (Windows only). They allow you to store data tables, reports, journals,
scripts, etc. in one file. By default, a project contains links to its contents. You may also save a project so
it contains copies of the files within it, making it possible to share a project with other people.

You may create a new project from the main menu (File > New > Project), or the JMP starter (File cat-
egory, New Project button), or from the Project manager (View > Projects).

The Project list lists all open projects and allows you to access all files stored in it. A project’s context
menu allows you to add items to it, save and close it, rename it, and specify settings for it.

Although you cannot create, modify, or save projects on Macintosh or Linux, you can open a project
that was saved on Windows and use the files contained within it.

JMP Starter
A new SAS category has been added to the JMP Starter. Options on it are:

* New SAS Program
* Open SAS Program
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Docked Lists

Open SAS Data File (not yet available on Macintosh and Linux)
Import Data from Server
Run Stored Process

Server Connections

In this Beta release, Macintosh and Linux users may have problems with the Open and Save dialogs

related to SAS programs and the file type folders.

Docked Lists

From the View menu, you can select new lists that are docked on the left side of the JMP window for
Linux and Windows users.

Menu List (Windows only) Shows a list of menu and toolbar items. This is the new way to cus-
tomize menus and toolbars.

Windows List (Windows and new for Linux) Shows a list of all open JMP windows (data tables,
scripts, reports, journals, etc.). On Linux, this list is only a list, not a tree control. You may also
filter the displayed windows by type (Linux only).

File System (Windows and Linux only) Shows the file system of your local PC. You can drag files
into JMP from this window.

Projects (Windows and Linux only) Shows a list of open projects.

New in Data Tables

Percent is now a format for both columns and axes that multiplies the value by 100 and adds the %
suffix. You can specify any number of decimal places. Parsing of percent values also works with text
import.

Data Filter

The Data Filter command in the Rows menu gives a variety of ways to identify subsets of data. Using
Data Filter commands and options, you interactively select complex subsets of data, hide these subsets
in plots, or exclude them from analyses.

For details, see the chapter “The Data Filter” of JMP User Guide.

New Platforms

The following platforms are all new in JMP 7.
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Bubble Plot

Bubble Plot

A bubble plot is a scatter plot which draws its points as circles (bubbles). Optionally, the bubbles can be
sized according to another column, colored by another column, aggregated across groups defined by
one or more other columns, and dynamically indexed by a time column. With the opportunity to see
up to five dimensions at once (x-position, y-position, size, color, and time), bubble plots can produce
dramatic visualizations and make interesting discoveries easy.

To launch the Bubble Plot platform, select Graph > Bubble Plot from the main menu.

For details on categorical analysis, see the “Bubble Plots” chapter of /MP Statistics and Graphics Guide.

Capability
This new platform performs a capability analysis on one or more variables, then offers a variety of
graphs to view and compare the capability of processes simultaneously.
Goal Plot displays, for each variable as a point on the plot, the shift away from the target on the
X-axis, and the noise outside the range of the spec limits on the Y-axis.
Capability Box Plots are also displayed by default, showing one boxplot for each variable, cen-
tered on the target, and scaled by the range of the spec limits.
To launch the Capability platform, select Graph > Capability from the main menu.

For details on this new platform, see the “Capability Analysis” chapter of JMP Statistics and Graphics
Guide.

Categorical

The Categorical platform tabulates and summarizes categorical response data, including multiple
response data, and calculates test statistics. It is designed to handle survey and other categorical
response data, including multiple response data like defect records, side effects, and so on.

To launch the Categorical platform, select Analyze > Modeling > Categorical from the main menu.

For details on categorical analysis, see the “Categorical Response Analysis” chapter of JMP Statistics and
Graphics Guide.

Gaussian Process

The Gaussian Process platform is used to model the relationship between a continuous response and
one or more continuous predictors. These models are common in areas like computer simulation
experiments, such as the output of finite element codes, and they often perfectly interpolate the data.
Gaussian processes can deal with these no-error-term models.

The Gaussian Process platform fits a spatial correlation model to the data, where the correlation of the
response between two observations decreases as the values of the independent variables become more
distant.

To launch the Gaussian Process platform, select Analyze > Modeling > Gaussian Process from the
main menu.
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Multivariate Control Chart

For details on Gaussian Process, see the “Gaussian Processes” chapter of JMP Statistics and Graphics
Guide.

Multivariate Control Chart

Multivariate control charts address process monitoring problems where several related variables are of
interest.

To launch the Multivariate Control Chart platform, select Graph > Control Chart> Multivariate
Control Chart from the main menu.

For details on this new platform, see the “Multivariate Control Charts” chapter of JMP Statistics and
Graphics Guide.

Principal Components

The purpose of principal component analysis is to derive a small number of independent linear combi-
nations (principal components) of a set of variables that retain as much of the information in the origi-
nal variables as possible. To help capture and visualize variation in higher dimensions, the spinning
platform displays a biplot representation of the points and variables when you request principal compo-
nents.

JMP also offers several types of orthogonal and oblique Factor-Analysis-Style rotations to help interpret
the extracted components.

To launch the Principal Components platform, select Analyze > Multivariate Methods > Principal
Components from the main menu.

For details, see the “Principal Components” chapter of JMP Statistics and Graphics Guide.

Scatterplot 3D

The Scatterplot 3D platform displays a three-dimensional view of data and an approximation of higher
dimensions through principal components. The plot is a rotatable display of the values of numeric col-
umns in the current data table. The Scatterplot 3D platform displays three variables at a time from the
columns you select.

To help capture and visualize variation in higher dimensions, Scatterplot 3D displays a biplot represen-
tation of the points and variables when you request principal components.

Note: Scatterplot 3D supersedes the Spinning Plot platform, which has been deprecated and is only
available through scripts.

To launch the Scatterplot 3D platform, select Graph > Scatterplot 3D from the main menu.

For details on the Scatterplot 3D platform, see the “Three-Dimensional Scatterplots” chapter of JMP
Statistics and Graphics Guide.
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Scatterplot Matrix

Scatterplot Matrix

The Scatterplot Matrix platform allows quick production of scatterplot matrices. These matrices are
orderly collections of bivariate graphs, assembled so that comparisons among many variables can be
conducted visually. In addition, the plots can be customized and decorated with other analytical quan-
tities (like density ellipses) to allow for further analysis.

These matrices can be square, showing the same variables on both sides of the matrix or triangular,
showing only unique pairs of variables in either a lower or upper triangular fashion. In addition, you
can specify that different variables be shown on the sides and bottom of the matrix, giving maximum

flexibility for comparisons.
To launch the Scatterplot Matrix platform, select Graph > Scatterplot Matrix from the main menu.

For details on the Scatterplot 3D platform, see the “Scatterplot Matrices” chapter of JMP Statistics and
Graphics Guide.

Screening

The Screening platform helps select a model for a two-level screening design by showing which effects
are large. This platform is only used when all the factors are continuous or two-level categorical.

To launch the Screening platform, select Analyze > Modeling > Screening from the main menu.

For details on the Screening platform, see the “Analyzing Screening Designs” chapter of /MP Statistics
and Graphics Guide.

Preferences

General

A new option, Save Journal GZ Compressed, compresses journals. Compressing a saved journal can

make some (but not all) journal files much smaller. The format of the compression is compatible with

the GZIP format (which is 7ot the same as the Zip format). JMP does not add the .gz extension to the
file name. The journal opens normally in JMP 7 but produces errors in earlier versions of JMP. Utilities
such as Winzip can convert the compressed journal back to an uncompressed journal which earlier ver-
sions of JMP may be able to read, subject to other backward compatibility constraints.

Reports

* Hover Help (tooltip help that appears when you make a circular mouse gesture over a piece of a
report) can now be turned off.

* There is a new preference, Default Graph Height, which is a usually a relative measure. It is the
height in pixels for graphs like scatterplots. In other graphs, like leverage plots, a scaled version of
the preference is used. The height for JMP 6-sized graphs is 180.
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Script Editor

¢ There is a new Default Marker preference that applies when a row has no marker state information.

Script Editor

There is a new category for specifying preferences for the new JSL Script Editor. “Changing Formula
and Scripting Options,” p. 324 of JMP Users Guide.

SAS

There is a new category for specifying preferences for the SAS Integration. For details, see “Specifying
Settings for SAS Integration,” p. 340 of JMP Users Guide.

JMP Updates

There is a new category for specifying automatic software update checking. You can set it to never
check, or to check at certain intervals.

Data Table Improvements

Data tables can now have more than 32,767 columns. Larger data tables are saved in a format that can-
not be read by previous versions of JMP. To save a data table in JMP 7 format, open Preferences, select
the Tables category, and select Save table in extended file format. Selecting this option allows you to
save a data table with more than 32,767 columns, but you will not be able to open it in any previous
version of JMP.

The default value for this preference is off, so JMP 7 data tables with fewer than 32,767 columns are
still compatible with previous versions of JMP.

Formula Editor

* A new category appears in the Function category list: Parametric Model. This is a shortcut to create
parametric models that are linear functions of sets of dialog-selected columns.

* The Formula Editor now supports categorized parameters. This feature is useful for constructing
Nonlinear models involving categories.
When you click New Parameter in the Parameters menu, the dialog to enter a name and initial
value for the parameter has a new checkbox titled Expand into categories, selecting column.
If you check this, then click OK, you will be prompted to select a category column. The result in the
Parameters list will be an item with a name like prefix_colname where prefix is the name you
entered into the dialog, and colname is the name of the column you selected. They represent a
whole series of parameters in the resulting model.
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Import

When you navigate to a place in the model where you want to insert a categorized parameter and
click the categorized parameter in the parameters item list, instead of inserting one parameter, JMP
inserts a Match expression clause of the form:

Match(colname, Tevell, prefix_levell, level2, prefix_level2, ...)

where each level is the unique value of one of the categories of the categorical column, and each
becomes a suffix for the set of parameter names that result in the formula.

Import

When you import a text file, a script is now placed in the data table that reproduces the imported
data from the text file.

Text import has a more consistent set of rules for deciding whether to use text import preferences or
to guess the file format. In Preferences (in the Text Data Files category), you can choose between two
new options for importing text files: Use these settings and Use best guess.

If you use the File > Open command, these settings take their initial value from your Preferences
setting. You can change the option while opening a text file, but that does not reset your Preferences
setting.

By default, drag and drop behavior uses preference settings rather than guessing.

Tables Menu

Join

The Join window now has a Recall button that recalls the settings from the last time the Join window

was used.

Tabulate

Rows are now excluded for missing values only for the grouping columns involved in building the
table.

There is a new option Include missing for grouping columns that causes missing data in a group-
ing column to be treated as a category.

Missing rows are not included in the computation of % of Total unless Missing is included as a cat-
egory.

There is a new option Order by count of grouping columns that causes the categories of a group-
ing column to be listed by counts.

Cols Menu

Col Info

There is now a Reverse button available for Value Ordering and List Check.
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Rows Menu

Recode
* Recode now gives you a choice on where to place the recoded values:

— InPlace The default choice. Recoded values are put back in the same column, and the opera-
tion cannot be undone.

— New Column Makes a new column with the same name, plus a numeric suffix, and the
recoded values.

— Formula Column Makes a new column with a recoding formula. The formula is useful for
recoding added rows, or for copying and pasting into other tables.
No new columns are made for columns that had no changes.
* Recode now allows you several options to control case and whitespace:

Convert to Titlecase Change each word to start with an uppercase letter, and all the rest to low-
ercase. (Example: My New Value)

Convert to Uppercase Change every letter to uppercase. (Example: MY NEW VALUE)
Convert to Lowercase Change every letter to lowercase. (Example: my new value)
Trim Whitespace Removes leading and trailing whitespace.

Collapse Whitespace Trims plus converts each run of interior whitespace into a single space.

Rows Menu

Row Editor

There is a new button with a Plus sign on it that adds a new row.

Row States

Row states now support full 24-bit color. Note: When a table that contains 24-bit color row states is
opened in JMP 6 and eatlier, the closest palette color is used instead, and the 24-bit color information
is lost if the file is edited and saved in JMP 6 or earlier.

Design of Experiments Improvements

Custom Designer

* You can now create split-split plot designs. You can set factors as Very-Hard-to-change,
Hard-to-change, and Easy-to-change. For details, see the “Creating Split-Split Plot Designs” chapter
of JMP Design of Experiments.

* You can now create strip-plot designs. To set up a strip plot design, enter responses and factors as
usual, designating factors as Very Hard, Hard, or Easy to change. Then, in the Design Generation
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Custom and Augment Designers

panel, check the box that says Hard to change factors can vary independently of Very Hard to
change factors. For details, see the “Creating Strip Plot Designs” chapter of JMP Design of Experi-

ments.

* The new Fraction of Design Space plot is a way to see how much of the model prediction variance
lies above (or below) a given value. It is most useful when there are multiple factors. It summarizes
the prediction variance, showing the fractional design space for all the factors taken together.

* It is now possible to save a script that reproduces a custom design is a script window. From the red
triangle menu, select the last item, Save Script to Script Window.

¢ For ordinary least squares designs (without split plot effects) the numerical optimization algorithms
have been completely rewritten and are much faster, so that much larger designs can be computed.

* Optimal randomized block designs are now available.
* Optimal Bayesian D-Optimal split-plot designs are now available.
* Power calculations for each model term are now available.

* You can now save a designed experiment to a script. Running the script will reproduce the design.

Custom and Augment Designers

In the outline node for reporting the relative variance of the coefficients of a model, there is now a new

column showing the power of the design as specified to detect effects of a certain size.

There are controls to change the alpha level of the test and the magnitude of the effects compared to the

error standard deviation.

* The alpha level edit box is labeled Alpha. Smaller alpha values (requiring a more significant test),
reduce power.

* The magnitude of the effects edit box is labeled SN Ratio, which is the ratio of the absolute value of
the regression parameter to sigma. Increasing the magnitude of the effect that is to be detected raises
power. The power reported is the probability of finding a model parameter significant if the true
effect is SN Ratio times sigma.

Space Filling Design
Space Filling Design has three new design methods: Maximum Entropy, Gaussian Process IMSE
Optimal, and Gaussian Process I-Optimal.

For details on the Custom Designer, see the “Space Filling Designs” chapter of JMP Design of Experi-

ments.

Nonlinear Design

Algorithms have been improved, and the platform now has a launch window similar to other platforms.
Weight columns are now supported so that optimal designs for logistic and Poisson regressions are now
possible.

For details on the Custom Designer, see the “Nonlinear Designs” chapter of JMP Design of Experiments.
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Distribution

Analyze Menu Improvements

Distribution

* There are three new distributions for fitting; the system of three Johnson distributions, unbounded
(Su), bounded (Sb), or log (Sl). The Johnson distributions tend to be more flexible than other distri-
butions, and fit well for most data, except data which is normally distributed.

* Large-scale multi-variable problems should be faster if using a multi-core processor.

* You can now set the color for histograms to a custom color. A Custom button has been added to the
Histogram Color command.

Fit Y by X

Contingency

A report that formerly broke down contributions to likelihoods has been simplified to show only the
logLikelihood difference that is meaningful.

Logistic

There is a new command in the Plot Options submenu, Show Rate Curve. If you have data with
many points for each X value, then you can get reasonable estimates of the rate for each value, and com-
pare this with the fitted logistic curve. To prevent too many degenerate points, usually at zero or 1, it
only shows the rate value if it had a frequency of at least 3. It is colored green to distinguish it from the
blue fitted curve.

Fit Model

The two SAS-related menu items in the Model dialog menu, Create SAS Job and Submit to SAS, are
now always present.

Standard Least Squares Personality

* A new command, Joint Factor Tests, assembles a joint test on all the parameters involving each fac-
tor (term) in the model. The menu item for this test is dimmed when there are no interaction
effects, or if there are random effects whose tests are not implemented yet.

* The command Sorted Estimates now produces a different version of the Parameter Estimates
report that is more useful in screening situations when you want to look for big effects among many,
especially if the design is saturated and typical reports are less informative. This option is used auto-
matically if all the factors are two-level factors or if the emphasis is screening and all effects have only
one parameter, in which case it is used instead of the Scaled Estimates feature. Differences between
this and the regular Parameter Estimates report:
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Fit Model

— The report does not show the intercept.

— The effects are sorted by the absolute value of the 7" Ratio, showing most significant estimates at
the top.

— A bar graph shows the 7" Ratio, with a line showing where the 0.05 significance level is.

— If the standard errors of the estimates are unobtainable, it will show the relative standard errors,
with a note explaining it.

— If there is no degrees of freedom for residual error, it will construct 7" Ratios and P Values using
the Pseudo Standard Error (Lenth), labeling these with the Pseudo name. A note explains the
change and show the PSE. To calculate p-values, it will imply a dfe of 72/3 where 7 is the number
of parameter estimates, except the intercept.

— In calculating PSE, if the parameter estimates have different standard errors, then the Lenth PSE
is defined with respect to the T Ratio rather than with respect to the common standard error.

The command Save Coding Table produces a new table containing all the coded columns on the X
and Y side. Coding refers to all the transformations, including indicator columns, interactions, cen-
terings, and transformations. The X columns are named the same as the parameters they estimate,
and the Y columns are named like the original Y’s or their transform.

The new command under the Box Cox analysis, Save Specific Transformation, behaves like the
option Save Best Transformation, but allows you to enter a lambda value.

Manova

The redesigned Compound Response Effect window makes it easier to set the responses as a cross of
two factors.

LogLinear Variance

A new submenu Save Columns now allows you to save columns individually. The available options
are: Prediction Formula, Variance Formula, Std Dev Formula, Residuals, Studentized
Residuals, Std Error of Predicted, Std Error of Individual, Mean Confidence Interval, Indiv
Confidence Interval.

A new submenu Row Diagnostics allows you to add these plots: Plot Actual by Predicted, Plot
Studentized Residual by Predicted, and Plot Studentized Residual by Row.

Models are now based on REML.

Nominal and Ordinal Logistic Personalities

The Profiler for logistic regression now supports categorical responses as a single response, with the
probabilities separating the lines in the plot.

Proportional Hazard Personality

The option Risk Ratios no longer is on the report by default. The two new options Unit Risk Ratio,
and Range Risk Ratio are used to produce them.

Unit Risk Ratio Is Exp(estimate), and is related to unit changes in the regressor.

Range Risk Ratio Is the change over the whole range of the regressor.
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Modeling: Nonlinear

Modeling: Nonlinear

* The new Show Prediction Expression command displays the fitting expression at the top of the
report. Selecting the command alternately turns it on or off.

* In most cases, the Nonlinear platform will do its computations in a separate computational thread.
This improves the responsiveness of JMP to doing other things during the iterative calculations of
Nonlinear. In the Iteration Options submenu, the option Unthreaded provides the ability to run
the iterations in the main thread, which may be needed in some cases (for example, if there are mod-
els with side effects that call a display routine). The default value is off.

* A new option has been added to the Save Formulas menu, Save Specific Solving Formula, that
saves the formula for the inverse function of the fitted model.

Modeling: Neural Net

* Neural Net now has two ways to call the Profiler for categorical responses. The Profiler option
shows a separate row of graphs for each response category, as before. The new Categorical Profiler
command shows the response probabilities in one row of graphs, with the probabilities being the
distance between the separating curves.

* The new Sequential of Fits command fits a sequence of models that vary the number of hidden
nodes and the value of the overfit penalty.

Modeling: Partition

e The menu in a split now has an option called Lock which will prevent it or any of its subnodes from
being chosen for a split. This is in contrast to the other Lock Columns option, which prevents cer-
tain columns from being chosen for future splits. When this option is checked, it also shows a
locked icon in the node.

* Partition now supports extending a selection made with Select Rows when the shift key is held
down. This allows you to collect a selection from several nodes in the tree. Select the first, and
shift-select the rest.

* Large-scale problems should be faster if youre running JMP on a multi-core processor.

Modeling: Time Series

Time Series has been greatly enhanced with new options, such as cross correlation, prewhitening, and
transfer function models. For details, see the “Time Series Analysis” chapter of /MP Statistics and

Graphics Guide.

Multivariate Methods: Cluster

* A new clustering method, Fast Ward, is available for handling large numbers of rows.

* Hierarchical Cluster now has a Legend option, producing a legend like that of a Cell Plot. The
Legend command only appears in the popup menu if there is a color map.



New Features for JMP 7.0 Graph Menu Improvements 15

Muiltivariate Methods: Discriminant

Hierarchical Cluster has new scaling options. A new submenu titles Dendrogram Scale replaces the
option Geometric X Scale. The submenu has three scaling options: Even Spacing, Geometric
Spacing, and Distance Scale. Geometric Spacing is the same as the old option Geometric X
Scale.

Multivariate Methods: Discriminant

The Score Data command no longer completely eliminate the outline for Scores. Now the com-
mand suppresses the listing of the scores by row.

Quadratic and Regularized methods are now available, as well as the previously-implemented
Linear discriminant analysis.

A 3D version of the Canonical plot is available when there are 4 or more groups.

Graph Menu Improvements

There is a new Customize option on the right-click menu for any plot that brings up a window
where the user can:

— see graph components;

— change properties of graph components (line thickness, etc.);
— add, edit, and remove custom graphic scripts;

— try examples of custom graphic scripts.

For details on using this new feature, see “Adding and Editing Graphics Scripts,” p. 215 of /MP Users

Guide.
Many platforms now display the Units properties in graph labels.

New default colors are improved.

Chart now supports the different common orderings supported by the Distribution platform.

Default colors have changed.

If there is only one graph with one X variable and no Value Colors, Chart now uses a single color
and doesn't show the legend. You can still show the legend manually and change the bar colors as
before.

If there is only one graph, the axes are attached to the graph.

Spacing between multiple graphs has been improved.
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Overlay Plot

Overlay Plot

There is a new option Overlay Groups that is available when you have at least one grouping column. It
overlays the different groups in one plot.

Parallel Plot

If the columns in a Parallel Plot have Spec Limits properties, the lower and upper spec limits will be
shown by red lines in the plot.

Cell Plot

Cell Plot now supports one or more label columns for use in identifying the rows in the graph.

Ternary Plot
Many display problems have been fixed.

Control Chart

A new feature, Save Summaries creates a new data table and saves the sample number, sample label (if
there is one), and statistic being plotted in each plot within the window. For example, if you run the
XBar/R chart combination script in the sample data table Diameter.jmp, it will save the columns
Sample, Sample Label, Mean of Diameter, and Range of Diameter.

Variability/Gauge Chart

For Variability Gauge Charts
* The Variability Gauge menu contains several new options:
Mean Diamonds Adds mean diamonds to the Response plot.
XBar Control Limits Adds XBar control limits to the Response plot.

Variability Summary Report Adds a table under the Response plot called Variability Summary
for Response. This table contains the columns Mean, Std Dev, Std Err Mean, Lower 95%, Upper
95% Minimum, Maximum, and Observations for the Response and for each Group.

Mean of Std Dev Adds a line that shows the mean of the standard deviation to the Std Dev plot.
S Control Limits Adds S control limits to the Std Dev plot.

Gauge Studies Has a sub-menu, Gauge RR Plots, with two new plots that you can add to your
report: Mean Plots and Std Dev Plots.

* You can set your own default K value on the Platforms page of the Preference Settings window
(File > Preferences).
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Profiler

Instead of using EMS methods, variance components are now used to compute the discrimination
ratio.

Variability now gives the discrimination ratio for nested factors.

There is a new Gauge R&R report format. In Preferences (in the Platform category, under Variabil-
ity Chart), you can select Reduced Gauge RR Report to see the previous report format instead.

If your response column properties includes Sigma and Spec Limits, those values are now automati-
cally used.

If you hold the shift key when you select Linearity Study, you are prompted to enter an alpha value
other than 0.05.

For Attribute Gauge Charts

There are new overall and categorical Kappa statistics.

Profiler

The new option Reset Factor Grid resets the factor settings.

If you have a prediction standard error formula saved for the same response for which you have a
Prediction formula saved, you may use it to make confidence intervals, rather than profiling it as a
separate column.

The new command Output Random Table prompts for a number of runs and creates an output
table with that many rows, with random factor settings, and predicted values over those settings.
This is equivalent, but much simpler, to opening up the Simulator, resetting all the factors to ran-
dom, picking the uniform distribution, and then simulating to an output table.

The new command Link Profilers allows you to link all the profilers together, so that a change to a
factor in one profiler causes the factor to change in all the other profilers (including Surface Plot) in
which that factor is a factor.

This is a global option that is set and unset for all profilers.

In the Factor Settings submenu of several profilers, the new command Set Script allows you to
specify a script to be called whenever the factors change.

Simulator

The Simulator has new options: Spec Limits, Defect Profiler (available after adding spec limits),
Defect Parametric Profile (available after opening the defect profiler), Simulation Experiment,
and Automatic Histogram Update.

The Simulator now creates new columns for each Remembered Factor Setting that record the dis-
tance from the simulated settings to the remembered ones (typically the optimum or nominal set-
ting). Each coordinate is measured by 2*dif/factorRange for continuous factors, and 0 or 1 for
categorical variables. The resulting column name is Distance Setting where Setting is the name of
the remembered setting.

Factor specifications are now located directly below the factors in the Prediction profiler.
A separate Sim button simulates directly into histograms in the Prediction profiler.

The Sequencing feature in the Simulator has been redesigned to operate separately from the factor
source specification.
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* Normal Truncated and Normal Censored distributions are now supported for factors.

Normal Truncated is a normal distribution limited by lower and upper limits. Any random realiza-
tion that exceeds these limits is discarded and the next variate within the limits is chosen.

Normal Censored is a normal distribution limited by lower and upper limits. Any random realiza-
tion that exceeds a limit is just set to that limit, putting a density mass on the limits.

* Normal weighted is an importance-sampled normal that generates weighted samples for the first
120 runs per factor in a simulation. Analysis for the output data sets must be weighted.

¢ Spec Limits and Control Limits are now also copied for the X variables, not just the Y variables.

Graphics/Display Improvements

* Disclosure triangle clicks can now be broadcast. Holding the control key (command key on macin-
tosh) while clicking the outline box disclosure triangle broadcasts the command. Such a click is
equivalent to either Close All Like This or Open All Like This.

* The new option, Customize, in the graph contextual menu replaces the Edit > Add Graphic Script
and Edit > Edit Graphic Scripts commands. For compatibility Add Graphic Script is still avail-
able for scripting in JSL.

The Customize window shows a list of graph elements and a properties panel for editing properties
of the selected item. You can add Custom script items to the graph using the + button and remove
them using the — button. The list order reflects the drawing order of the graph elements and custom
script elements can be moved up or down with the up/down buttons to change their position in the
drawing order (this feature supersedes the Draw in front checkbox in the old Add Graphics Script
window).

* More commands are now broadcast when you hold the control key while making choices from the
menu.

JMP Scripting Language
For details, see the /MP Scripting Guide.

* There is a new script editor with many new features, including syntax coloring, auto-completion,
hover help, and bracket matching. See “The JSL Editor,” p. 44 of JMP Scripting Guide for more
details.

¢ The JSL Operators browser (Help > Indexes > JSL Operators) has a new format, which incudes
not only a description, but also live examples of many JSL commands.

* An associative array data structure is now available. “Associative array” is the general term for a map-
ping from unique keys to values (possibly non-unique). It’s called a “dictionary” in Smalltalk, a
“map” (or “hash map”) in Java, and a “hash table” in C#. And in JavaScript, it’s just an “array”.

* Operators for pattern matching, which also includes regular expressions, are now available in JSL.
For details, see “Pattern Matching and Regular Expressions,” p. 412 of JMP Scripting Guide.
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Operators for creating, managing, using, and closing sockets are now available, allowing a greater
range of data gathering. For details, see “Socket Commands and Messages,” p. 532 of JMP Scripting
Guide.

The new SAS Interface is fully scriptable.

To better support Unicode, JSL literals now support direct input of Unicode numbers to become
unicode characters. The format inside a character literal is \!Uxxxx where U can be upper or lower
case, and where each of the four «’s is a hexadecimal digit, i.e. 0-9 and A-F (or a-f).

Binary data is now supported with a blob (Binary Large OBject) data type. The following are new
functions for blobs:

Hex To Blob(string) Converts a string of hexadecimal codes into a binary object.
Char to Blob(string, <enc>) Converts a string into a binary object.

Blob to Char(blob, <enc>) Converts a binary object into a string.

Blob Peek(blob,offset,length) Extracts some bytes from a blob.

The following functions now also handle blob data:

Hex(value, <intlenc>) Obtains a string of hex codes from a value.
Concat(blob1,blob2) or blob1 || blob2 Concatenates two blobs.

Length(blob) Returns the number of bytes in a blob.

When blob objects are listed on the log, they are shown with the constructor function

CharToBlob("...").

Invalid byte values are encoding with either a ? or the Unicode replacement character. This differs
from JMP 6, which skipped over invalid bytes. Supported encodings may vary depending on the
operating system, but include at least the following: utf-8, utf-16le, utf-16be, us-ascii, iso-8859-1
and ascii-hex.

Hexadecimal functions have been enhanced:

Hex(value, <integer>) Returns the hexadecimal text corresponding to the given value, which
may be a number, a string, or a blob. If the value is a number, IEEE 754 64-bit encoding is used
unless the optional argument integer is provided, in which case the integer portion of the
number is returned as a 32-bit hexadecimal number.

Hex To Char(hextext, <enc>) Returns the text corresponding to the hexadecimal text, assuming
UTF-8 encoding.

Hex To Number(hextext) Returns the number corresponding to the hexadecimal text. 16 hex
digits are converted as IEEE 754 64-bit floating point numbers; otherwise the input is treated as
a 32-bit signed hex integer.

Journal buttons with scripts have Encrypt and Decrypt commands on their context menus. A script
that is encrypted with edit and run passwords will require the run password each time the button is
clicked. The script will not prompt for the run password if the run password was not supplied on
the encrypt dialog. Subsequent editing of an encrypted script will prompt for the edit password to
open and edit and run passwords when saved. Decrypting a script requires the edit password.
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Data Table Operators

Data Table Operators

e The data table command <<MakeRowStateHandTer is used to create a handler object for an inter-

active application to be able to keep track of changes in row states. The command makes an object
that calls back a function with the row numbers that have changed. The object must be held in a
global. If you change the value of the global variable, it will dispose of the object. The callback func-
tion takes one argument, a matrix that will be filled with row numbers that have changed. In the
special condition of all the row selections being cleared, the callback will be called with an empty
matrix argument.

Summarize() now handles situations when all data are excluded or when the data table contains no
rows. Instead of generating an error, the function now returns empty or missing values, as appropri-
ate.

Color State() now accepts an RGB triplet in addition to the palette colors. The triplet is a JSL
list with values in the range 0..1. For example: Color State(0.2, 1.0, 0.1). For RGB colors,
Color OfQ) returns a negative number, which corresponds to the negation of the RGB number
0x00rrggbb.

Colors can be specified as either lists or matrices:

Color State( { r, g, b } );
Color State( [ 1 .50 ] );

Displays

JSL can now click a button:

newwindow("hi", fred=buttonbox("fred",print("hello")));

fred<<click(); // shows hello in Tog. the variable fred is the button with
the Tabel "fred".

To limit the minimum and maximum number of items in a ColListBox, used for column selection
dialogs, the Co1L1istBox function supports the two arguments:

— MinItems(number)
— MaxItems(number)

Saved scripts now remember axis font settings.

A new Script Box(<“text”>, <width>, <height>) operator adds a script box to a display
box. For example:
New Window( "script box",
V List Box(
sb = Script Box( "initial contents", 500, 300 ),
Text Box( "plain text" )
)
);
sb << get text();
NormalContour now supports color and fill arguments:
NormalContour(prob, [means], [stds], [corr],<[colors]>,<fill>)

Colors is a matrix of color numbers, one color for each group (each row of [means]).
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Miscellaneous JSL Operators

Fill defaults to 0, in which case it draws the ellipse lines. Fill=1 means it will fill the ellipse with the
current color. Fill values between 0 and 1 indicate filling with transparency, resulting in lightened
colors that can be overlapped.

Miscellaneous JSL Operators

SimpTifyExpr has been extended to nested If expressions.

SortDescending and SortAscending sort the elements of a matrix or list in the order named in
the operator. The result has the same dimension as the argument, but the elements are reordered.
For matrices with several rows and several columns, the direction of rows takes precedence.
SortList(1ist) is equivalent to SortAscending(Tist).

In addition to XMLPARSE and SASODSXML, LoadTextF1ile also accepts BLOB as an option,
which returns a blob instead of a string.

Comparison operators now support unicode. The following unicode characters can now be used to
represent the comparison operations in JSL and formulas. The older equivalent 2-character opera-
tors continue to work.

< unicode 2264
>= 2 unicode 2265
unicode 2260

A
I
N

unicode 2266
unicode 2267

=
=

-
Y

Window() with no arguments returns a list of windows. The command <<GetWindowTit1e now
works for all Windows, not just DisplayBox windows.

Open() can now indicate if the user pressed Cancel.
The Open() command now opens the Menu editor if you open the JMPMENU file.

When importing a text file, an additional Import Settings option allows you to specify the num-
ber of rows to import. You can enter a number or ALL to import all rows. The default value is ALL.
Open(“text file”, Import Settings(Lines to Read(n)))

The file picker can be customized:
filename = Pick File(); // standard behavior
filename = PickFile(<”caption”, “initial directory”, {filter 1list}>);

— Caption is a string with the dialog title.

— Initial Directory is the starting directory. If it’s an empty string, the JMP default directory
is used.

— Filter Tistisa list of strings with the following syntax:
“Description|filetypel;filetype2;..;filetypeN” where
* Description describes the filter, such as “All Files (*.*)” or perhaps just “JMP Files”.

* FileType is the extension on windows or linux. “jpg” is interpreted as “*.jpg” for example.

wx» Wk *»

means all files, as in
Note: All three parameters are required for the new behavior.

Concat (| |) now supports a numeric first argument and also list concatenation.
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Platforms

Add Potential Term When sent as a message to a Custom DOE object, this new command
adds an If Possible term to the model. Such terms cause the resulting design to be Bayesian D- (or
I-) optimal.

Utility Functions

ClearGlobals () can now clear specified globals. ClearGlobals() still clears the values from all
globals. ClearGlobals(namel,name2, .. .) clears the values from any globals named as argu-
ments.

The new command Clear Log() clears the log.

ExprAsPicture now supports a wrap width argument —

ExprAsPicture(expr(expression) ,wrapWidth). Use a second argument if you want it wider
or narrower than the usual 256-pixel wrap width.

Formula Editor Functions

Match now supports recoding missing values. Previously, the rule was that Match always returned

missing for missing arguments. Now Match supports comparing to a numeric missing value if it is
the first value in the matching list. For example, this formula will recode missing values of :Code to
999, and take :Code for the other values:

Match(:Code, . , 999, :Code)

These new date-time functions correspond to the Year(), Month(), and Day () functions:

— Hour(datetime, <12>); Returns the hours part of a date-time value, in 12-hour mode (12,
1-11) or 24-hour mode (0 - 23).

— Minute(datetime); Returns the minutes part of a date-time value, 0 - 59.

— Second(datetime); Returns the seconds part of a date-time value, including any fractional
part, 0 inclusive to 60 exclusive.

The new Date Short format reflects the numeric date format set in the Operating System’s
regional settings.

New string/list functions have been added:

— Left(s, n, <fi11>); Forastring, returns a substring of the 7 leftmost characters. For a list,
returns a sublist of the 7 leftmost items. Equivalent to Substr(s, 1, n). The optional Fil1l
specifies a character to fill the string or list in case the string or list is shorter than the provided

length.

— Right(s, n, <fil1>); For astring, returns a substring of the » rightmost characters. For a
list, returns a sublist of the 7 rightmost items. Equivalent to Substr(s, - n, n). The optional
Fi17 specifies a character to fill the string or list in case the string or list is shorter than the pro-

vided length.
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Formula Editor Functions

Starts With(s, sub); Returns 1 if s starts with sub, otherwise returns 0. § and sub may be
both strings or both lists. Equivalent to Left(s, Length(sub)) == sub.

Ends With(s , sub); Returns 1 ifsends with sub, otherwise returns 0. S and sub may be
both strings or both lists. Equivalent to Right(s, Length(sub)) == sub.

* Many string functions have been extended, mainly in two ways:

negative offsets are treated as offsets from the end.

most string functions also operate on lists (like Contains() already did).

* Some string functions have been modified:

Contains(x, item, <start>); Returns the position of item within x, starting at position
start if provided. If szart is negative, search backward from length - szart. The start argument is
new for JMP 7.

Length(x); Returns the length of the given string (in characters), list (in items) or blob (in
bytes). Handling lists is new for JMP 7, and redundant with N Ttems ().

Substr(s, start, <count>); Returns the part of s composed of count characters starting
at position start. Negative or absent count means the rest of the string. Negative start means start-
ing start characters from the end. May also be applied to lists. Handling negative values for start
and list-handling are new for JMP 7.

Word(n, s, <delim>); Returns the nth word of s, where words are sub-strings separated by
any number of any of the characters in delim. If delim is absent, whitespace is used. If delim is the
empty string, each character is treated as a separate word. The empty delim treatment is new for

JMP 7.

Words(s, <delim>); Returns alist of sub-strings separated by any of the characters in delim.
If delim is absent, whitespace is used. If delim is the empty string, each character is treated as a
separate word. The empty delim treatment is new for JMP 7, allowing one to “explode” a string
into a list of characters.

Item(n, s, <delim>); Returns the nth item of 5, where items are the sub-strings (possibly
empty) separated by exactly one of any of the characters in delim. If delim is absent, whitespace is
used. If delim is the empty string, each character is treated as a separate item. The empty delim
treatment is new for JMP 7.

* An optional second argument for Trim allows you to control whether the trimming occurs on the
LEFT, RIGHT, or BOTH sides.

* The following list/expr functions now also handle strings: Insert, Insert Into, Remove,
Remove From, Shift, Shift Into, Reverse, Reverse Into, Substitute, and
Substitute Into.

¢ Functions for Johnson distributions are now available:

— Johnson Sb Density, Johnson Sb Distribution, Johnson Sb Quantile,

Random Johnson Sb, SbInv, Sb Trans

— Johnson S1 Density, Johnson ST Distribution, Johnson ST Quantile,

Random Johnson S1, S1Inv, ST Trans
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— Johnson Su Density, Johnson Su Distribution, Johnson Su Quantile,
Random Johnson Su, Sulnv, Su Trans

¢ Quantile functions for Binomial and Poisson distributions are now available: Binomial Quantile
and Poisson Quantile.

e Random Weibul1 is now available. It returns random values from the specified Weibull distribu-
tion.

¢ Additional functions for color conversions are now available:
RGB Color Converts red, green, and blue values into a JMP color number.
HLS Color Converts hue, lightness, and saturation values into a JMP color number.
Color to RGB Converts a JMP color number to a list of red, green, and blue.
Color to HLS Converts a JMP color number to a list of hue, lightness, and saturation values.

¢ There is a new function Heat Color that a color value based on either the default color theme or a
theme specified as an optional argument.

* The formula function Format(column) can now operate without a second argument in the con-
text of a current row, returning the formatted value of the column referenced. This is useful to
extract value labels that are otherwise inaccessible.

* The new function RandomShuffle(matrix) returns the argument matrix with the elements ran-
domly shuffled (permuted).

¢ The new CholUpdate(L,V,C) function updates a Cholesky root. CholUpdate performs a low
rank update of a Cholesky factor. If L is the Cholesky root of an n*n matrix A, then CholUpdate
will update it to be the Cholesky root of A+V*C*V' where C is an m*m symmetric matrix and V is
an n*m matrix.

¢ RadialDistance(x1,x2,<m>) calculates a distance useful in certain radial smoothers. The
default for m is 2 if ncol<3, (ncol+1)/2 otherwise. For matrices, it calculates the distance matrix
between xI rows and x2 rows where they both have nco/ columns. For smoothing applications, x7 is
a matrix of data, and x2 is a matrix of knot points.

Windows Automation

New Platform Support
Support for Partition, Scatterplot 3D, Scatterplot Matrix, Bubble Plot has been added to Windows

automation.

Data Table Automation For Rowstate Change Detection

Windows automation already has several methods for enumerating rows with non-zero states (selected,
excluded, hidden etc). One returns a vector of indices that show those rows with a given state. However,
this vector does not indicate what has changed, so if you poll it and Row 5 is always selected, it will
always return 5.

This update introduces two methods that will hopefully prove more efficient for automation users.
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Windows Automation

RowStateBeginMonitoring() — starts the monitoring of the datatable for changes to the row states
(selected, excluded, hidden etc). If you are going to use GetChangedRowStateVector, you must call
this method first. It is only necessary to call this once per datatable.

GetChangedRowStateVector(stateToCheck as RowState) As Variant -
GetChangedRowStateVector returns a vector of only those rows that have changed since the last
invocation of the method. So, if you want to know what rows have been selected/deselected since the
last time you polled or pressed a button, this the method to use. The return value is a two dimensional
array. The first dimension consist of the indices of the rows that have changed for the provided crite-
rion. The second dimension has a 1 or 0 to indicate if the row state is on (Selected, Excluded etc) or off
(deselected, no longer excluded etc) for that particular row.

DOE Automation Enhancement For Factor “Change” Difficulty

Add ability to change the level of difficulty for factor modification (Easy, Hard) in DOE automation.
We did not modify the existing API. Rather than create a new set of factor methods with one more
parameter, we implemented a function SpecifyChangeDifficulty that takes an Easy or Hard con-
stant value. Factors that are added using the following automation methods:

¢ AddMixtureFactorWithName

¢ AddContinuousFactorWithName

e AddCategoricalFactorWithName

¢ AddCategoricalFactorWithLevelNames

These will honor the setting after SpecifyChangeDifficulty has been used.

soianjesa4 MaN






	New in SAS Integration
	JMP User Assistance
	Projects
	JMP Starter
	Docked Lists

	New in Data Tables
	Data Filter

	New Platforms
	Bubble Plot
	Capability
	Categorical
	Gaussian Process
	Multivariate Control Chart
	Principal Components
	Scatterplot 3D
	Scatterplot Matrix
	Screening

	Preferences
	General
	Reports
	Script Editor
	SAS
	JMP Updates

	Data Table Improvements
	Formula Editor
	Import
	Tables Menu
	Join
	Tabulate

	Cols Menu
	Col Info
	Recode

	Rows Menu
	Row Editor
	Row States


	Design of Experiments Improvements
	Custom Designer
	Custom and Augment Designers
	Space Filling Design
	Nonlinear Design

	Analyze Menu Improvements
	Distribution
	Fit Y by X
	Contingency

	Logistic
	Fit Model
	Standard Least Squares Personality
	Manova
	LogLinear Variance
	Nominal and Ordinal Logistic Personalities
	Proportional Hazard Personality

	Modeling: Nonlinear
	Modeling: Neural Net
	Modeling: Partition
	Modeling: Time Series
	Multivariate Methods: Cluster
	Multivariate Methods: Discriminant

	Graph Menu Improvements
	Chart
	Overlay Plot
	Parallel Plot
	Cell Plot
	Ternary Plot
	Control Chart
	Variability/Gauge Chart
	Profiler
	Simulator


	Graphics/Display Improvements
	JMP Scripting Language
	Data Table Operators
	Displays
	Miscellaneous JSL Operators
	Platforms
	Utility Functions
	Formula Editor Functions
	Windows Automation
	New Platform Support
	Data Table Automation For Rowstate Change Detection
	DOE Automation Enhancement For Factor “Change” Difficulty



